PowerINSPECT 4.315 Automation

Delcam makes every effort to maintain compatibility of the automation API between releases. However, some enhancements may require changes that are not compatible with previous versions: we reserve the right to make such API changes if necessary.
The effects of automation API changes can sometimes be hard to detect at runtime. We therefore strongly recommend that programs using the automation API be recompiled for each new release of PowerINSPECT.

Objects

Collections

Interfaces

Methods

Properties

Enums

Components

Name | Description
ActiveObject | ActiveObject Class
AddInManager | AddInManager Class
AlignmentFreeFormFit |
AlignmentFromFile |
AlignmentItem |
AlignmentRPS |
Application | the PowerINSPECT Application Object
Arc3D | EntityFromPoint Class
BestFitItem |
BestFitResult |
BoundingBox |
BrowseHelper | BrowseHelper Class
CADFile |
CADFiles |
CADLevel |
CADLevels |
CADObject |
CADObjects |
CADViewReportItem |
CADViewStateItem |
Calibration | Calibration
CalibrationAdmin | CalibrationAdmin Class
Carriage | Carriage Class
Carriages | Carriages Class
CMMBoolParameter | CMMBoolParameter Class
CMMCNCController | CMMCNCController class
CMMDatum |
CMMFloatParameter | CMMFloatParameter Class
CMMIndexableProbeHeadProtocol |
CMMParameters | CMMParameters : a Collection of CMMParameter
CMMParametersCategories | CMMParametersCategories Class
CMMParametersCategory | CMMParametersCategory Class
CMMParameterToolBox | CMMParameterToolBox Class
CMMPlaneParameter | CMMPlaneParameter Class
CMMPoint | CMMPoint Class
CMMPointParameter | CMMPointParameter Class
CMMPoints | CMMPoints Class
CMMProtocol_dummy |
CMMSimulationProtocol | CMMSimulationProtocol Class
CMMSimulator | CMMSimulator Class
CMMVectorParameter | CMMVectorParameter Class
CoClass | Constant Class
Collection | Collection Class
CommandBar | CommandBar Class
CommandBarButton | CommandBarButton Class
CommandBarComboBox | CommandBarComboBox Class
CommandBarControls | CommandBarControls Class
CommandBarPopup | CommandBarPopup Class
CommandBars | CommandBars Class
Constant | Constant Class
CustomActionItem |
DatumFeatureCollection | DatumFeatureCollection
DatumOnExistingFeatures_ |
DatumRotate |
DatumRotateToFeature2D |
DatumRotateToFeature3D |
DatumShift |
DatumSphere | DatumSphere Class
Dispinterface | Dispinterface Class
Document | a PowerINSPECT Document Object (.PWI)
Documents |
DynamicPoint |
DynamicPoints |
DynamicTarget |
DynamicTargetResult |
DynamicTargetResults |
DynamicTargets |
EdgePointItem |
EdgePointResult |
EdgePointResultStack |
EntityFromPoints | EntityFromPoint Class
Enum | Enum Class
Feat_Circle_PlaneConic |
Feat_CircleThroughNPoints |
Feat_Cone |
Feat_Cylinder |
Feat_LaserScannedCircle |
Feat_LaserScannedPatch |
Feat_LaserScannedRectangle |
Feat_LaserScannedSphere |
Feat_Polygone |
Feat_ProbedCircle |
Feat_Rectangle |
Feat_SinglePointCircle |
Feat_Slot |
Feat_Sphere |
Feat_Torus |
Feature |
Features |
Function | Function Class
GDTDatumFeatureLink |
GDTFeature |
GDTFeaturesLink |
GDTItem |
GeometricGroup |
IndexableProbeHead | IndexableProbeHead Class
IntermediateProbePath |
LaserScannedCylinder |
LaserScannedSlot |
Line_Bissector |
Line_Inter2Planes |
Line_ParallelTroughPoint |
Line_PerpendicularTroughPoint |
Line_PointVector |
Line_Probed |
Line_ProjectedOnPlane |
Line_ThroughPoints |
Line_WithAngle |
Line_WithOffsetPoint |
Links |
MachineAxes | MachineAxes Class
MachineAxis | MachineAxis Class
MachineOrientationData | MachineOrientationData Class
ManualProbeHead |
ManualToolChanger | ManualToolChanger
MathToolbox | MathToolbox Class
Meas_3DAngle2Vectors |
Meas_3DAnglePlaneLine |
Meas_Angle2Lines |
Meas_Angle2Planes |
Meas_Distance2Points |
Meas_DistancePointLine |
Meas_DistancePointPlane |
Meas_RelativePosition |
measure |
Measures |
MultiaxisConfiguration |
MultipleLink |
NominalPoint |
NominalVector |
ObjectPool | ObjectPool Class
OffsetPoint |
OffsetPoints |
OMVExporter | OMVExporter Class
OMVImportCtrl | OMVImportCtrl Class
OMVImporter | OMVImporter Class
OMVIProbePathXMLItem | OMVIProbePathXMLItem Class
OMVIProbePathXMLItems | OMVIProbePathXMLItems Class
OMVIProbePathXMLReader | OMVIProbePathXMLReader Class
OMVIScriptItem | OMVIScriptItem Class
OMVIScriptItems | OMVIScriptItems Class
OMVIScriptReader | OMVIScriptReader Class
OMVIXmlCutFileItem | OMVIXmlCutFileItem Class
OMVIXmlCutFileItems | OMVIXmlCutFileItems Class
OMVIXmlCutFileReader | OMVIXmlCutFileReader Class
OMVScriptReaderBridge | OMVScriptReaderBridge Class
Parameter | Parameter Class
ParameterAngle |
ParameterAngleQuadrant |
ParameterBoolean |
ParameterBoundary |
ParameterCompensationMethod |
ParameterCompositeOffset |
ParameterDimension |
ParameterDirection |
ParameterGuidedMeasure |
ParameterInteger |
ParameterMainPlane |
ParameterMaterialCondition |
ParameterMaterialSide |
ParameterMatrixDefinition |
ParameterPoint3D |
ParameterPoint3DEx |
ParameterReportSettings |
ParameterRPSConstraints |
Parameters |
ParameterVector3D |
ParameterVector3DEx |
PCSDatum |
PDBDefinition | PDBDefinition Class
Plane_Bissector |
Plane_LinePoint |
Plane_LineVector |
Plane_OffsetDistance |
Plane_ParallelThroughPoint |
Plane_PointVector |
Plane_Probed |
Plane_WithOffsetPoints |
plane | EntityFromPoint Class
Point_FeatureIntersection |
Point_Inter2Lines3D |
Point_Inter2LinesProjected |
Point_Inter3Planes |
Point_InterPlaneLine |
Point_Middle |
Point_ProjectedOnLine |
Point_ProjectedOnPlane |
Point_RetracePoint |
Point3D | Point Class
PointCloud | PointCloud Class
PointCloudPoint | PointCloudPoint Class
PointCloudSelection | IPointCloudSelection Class
Position | ProbeHeadPosition Class
ProbeDatabase | ProbeDatabase Class
ProbeDatabaseToolbox | ProbeDatabaseToolbox
ProbePath | ProbePath Class
ProbePathCXMOutputter | ProbePathCXMOutputter Class
ProbePathDynamicPosition | ProbePathDynamicPosition Class
ProbePathEditor |
ProbePathFaultItem | ProbePathFaultItem Class
ProbePathFaultItems | ProbePathFaultItems Class
ProbePathFaults | ProbePathFaults Class
ProbePathItemActiveMove | ProbePathItemActiveMove Class
ProbePathItemCNCParameter | ProbePathItemCNCParameter Class
ProbePathItems | ProbePathItems Class
ProbePathMachineConfiguration | ProbePathMachineConfiguration Class
ProbePathPositionalItem | ProbePathItemIntermediatePoint Class
ProbePathReplay | ProbePathReplay Class
ProbePathScanItem | ProbePathScanItem Class
ProbePathTeach | ProbePathTeach Class
ProbeRack | ProbeRack
ProbeRackCollection | ProbeRackCollection
ProbeRackSlot | ProbeRackSlot
ProbeRackSlotCollection | ProbeRackSlotCollection
ProbeReconciliator | DatumFeatureCollection
ProbeSensorCollection | ProbeSensorCollection Class
ProbeSensorCylinder | ProbeSensorCylinder Class
ProbeSensorSphere | ProbeSensorSphere Class
ProbeStructureBuilder | ProbeStructureBuilder Class
probeTip | ProbeTip Class
ProbeTipCollection | ProbeTipCollection Class
ProbeTool | ProbeTool Class
ProbeToolCollection | ProbeDatabase Class
ProbeToolConnection | ProbeToolConnection
ProbeToolConnections | ProbeToolConnections
Properties |
PropertyAngle |
PropertyGeometricTolerance |
PropertyLinearDimension |
PropertyPoint3D |
PropertyRadialDimension |
PropertyUnitVector3D |
PropertyVector3D |
ProtocolConnector |
rbDHTMLBridge | rbDHTMLBridge Class
rbReportVariables | rbReportVariables Class
rbTemplatesManager | rbTemplatesManager Class
RegPropertyBag | Property bag class for storing properties in the registry.
ReportVariable |
ReportVariables |
RPSConstraint |
ScanItem | ScanItem Class
ScanItems | ScanItems Class
ScanItemWithPrimary | ScanItemWithPrimary Class
ScanItemWithSecondary | ScanItemWithSecondary Class
ScanOnCircle | ScanOnCircle Class
ScanOnCurve | ScanOnCurve Class
ScanOnHelix | ScanOnHelix Class
ScanOnLine | ScanOnLine Class
SelectionManager | A selection manager that handles CAD entity selection
SequenceDefinitionDatum |
SequenceGroup |
SequenceItem |
SequenceItemIterator | SequenceItemIterator Class
SequenceItems |
SequenceReplayEngine | SequenceReplayEngine Class
SequenceReplayEngineCtrl | SequenceReplayEngineCtrl Class
SequenceReplayValidator | SequenceReplayValidator Class
SimpleLink |
SimpleProbeDatabase |
SurfaceGroup |
SurfacePointItem |
SurfacePointResult |
SurfacePointResultStack |
SurfaceSectionGroup |
TemperedTrackingPoints | TemperedTrackingPoints Class
TrackerCommand | TrackerCommand Class
TrackerProbeDb | TrackerProbeDb Class
transform | Transform Class
TransformDefinition |
TypeDesc | TypeDesc Class
TypeInfo | TypeInfo Class
TypeInformation | TypeInformation Class
TypeLibrary | TypeLibrary Class
UnitConverter | UnitConverter Class
UnitVector3D | UnitVector Class
VarDesc | Constant Class
Vector3D | Vector Class
VerticeSelectionManager | A selection manager that handles vertice selection on an CADFILE
WebScreen | WebScreen Class
Name | Description
AddInCollection | returns the AddIn Collection Object
Axes | The list of machine axes.
CADFiles |
CADLevels | Collection of CAD levels belonging to this item.
CADObjects | Collection of CAD objects belonging to this item.
CADSelectionManager | the CAD Selection manager
Categories | property Categories
Clone | Clone : create an exact copy of this object and return a pointer to it
CMMParameters | CMMParameters
CMMPoints | return a pointer to the inner CMMPoints Array that can be populated
CommandBars | returns the CommandBars collection object
ConnectedLinks | return the collection of the links that reference this feature
Connections | retrieves the connections ProbeToolConnections
ContactPoints |
Controls |
Controls | property Controls
DatumFeatureCollection | retrieves the datum feature collection available on this carriage
Documents |
DynamicPoints | Dynamic Point collection
Elements | property Elements
entities | a list of entities in the document
EventSources | sources of event
ExtraEntities | retrieve the extra feature available
Features | get the colection of Features attached to this link
Features | return a collection of feature that this element provides
Features |
FindCompatibleFeaturePlanes | find a list of plane features that are compatible with the given entity
FindControls |
GDTFeatures |
getElementsByTagName | build a list of elements by name
ImpInterfaces | the interfaces implemented by this coclass
Interfaces | Returns collection of interfaces/dispinterfaces/eventsource.
Item | Allows random access to individual Category object within the collection. Index can be an ordinal from 0 to Count -1 or a string being a name of a category
Items | The list of probe-path faults.
Items | property Items
Links | return a collection of links that need to be defined for this entity
Measures |
Methods | property Methods
notations | a list of notations in the document
Offsets |
Parameters | property Parameters
Parameters | return a collection of parameters that defined the entity
parent | returns the parent object of this object i.e the collection
PossibleFeatures | property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link
PredictedPath | Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.
ProbeTipCollection | retrieves the probe tip collection
ProbeTipCollection | returns the probe tip collection which are all registered position (calibrated or not)
ProbeToolCollection | retrieves the probe tool collection associated with this carriage
ProbingParameters | returns a collection of parameters than can be used by a object that knows how to generate this probe path
Properties |
Properties | property Properties
RackCollection | retrieves the rack collection associated with this carriage
ReportVariables |
ReportVariables | property ReportVariables
Results | returns a collection of result points
ResultStack | stack of results for the given measure
ResultStack | stack of results for the given measure
ScanItems | Get the list of scan-items contained in this item.
selectNodes | execute query on the subtree
SequenceItems |
SequenceItems |
SequenceItemsForMeasure |
SlotCollection | returns the collection of slots
Targets | returns a collection of target points
TypeInfos | property TypeInfos
UIExtensionCommands | User Interface Extension Commands
UserLevels | Collection of user CAD levels belonging to this document.
VerticeSelectionManager | the Vertice Selection manager
Name | Description
_IAddInManagerEvents | _IAddInManagerEvents Interface
_IApplicationEvents |
_ICarriageEvents | _ICarriageEvents Interface : events generated by a CCarriage Object
_ICMMParameterEvents | _ICMMParameterEvents Interface
_ICMMParametersEvents | _ICMMParametersEvents Interface
_ICMMProtocolEvents | _ICMMProtocolEvents Interface
_ICMMSimulatorEvents | _ICMMSimulatorEvents Interface
_ICMMUIExtensionCommandsEvents |
_ICollectionEvents | _ICollectionEvents Interface
_ICommandBarButtonEvents | _ICommandBarButtonEvents Interface
_ICommandBarComboBoxEvents | _ICommandBarComboBoxEvents Interface
_ICommandBarControlsEvents | _ICommandBarControlsEvents Interface
_ICommandBarEvents | _ICommandBarEvents Interface
_ICommandBarsEvents | _ICommandBarsEvents Interface
_IDocumentEvents |
_IDynamicPointsEvents |
_IIndexableProbeHeadEvents | _IIndexableProbeHeadEvents Interface
_IIndexableProbeHeadProtocolEvents | _IIndexableProbeHeadProtocolEvents Interface
_IOMVImportCtrlEvents | _IOMVImportCtrlEvents Interface
_IOMVImporterEvents | _IOMVImporterEvents Interface
_IPositionEvents | _IPositionEvents Interface
_IProbePathEditorEvents |
_IProbePathEvents | _IProbePathEvents Interface
_IProbePathReplayEvents | _IProbePathReplayEvents Interface
_IProbePathReplayEvents2 | _IProbePathReplayEvents Interface
_IProbePathTeachEvents | _IProbePathTeachEvents Interface
_IProbeToolEvents | _IProbeToolEvents Interface
_IrbDHTMLBridgeEvents | _IrbDHTMLBridgeEvents Interface
_ISelectionManagerEvents |
_ISequenceReplayEngineCtrlEvents | _ISequenceReplayEngineCtrlEvents Interface
_ISequenceReplayEngineEvents | _ISequenceReplayEngineEvents Interface
_ISimpleProbeDatabaseEvents | _ISimpleProbeDatabaseEvents Interface
_ISynchronousReplayEvents | _IProbePathReplayEvents Interface
_ITemperedTrackingPointsEvents | _ITemperedTrackingPointsEvents Interface
_IToolChangerEvents | _IToolChangerEvents Interface
_IWebScreenEvents | _IWebScreenEvents Interface
IActiveObject | IActiveObject Interface
IAddInCollection | IAddInCollection Interface
IAddInInfo | IAddIn Interface
IAlignmentFreeFormFit | IAlignmentFreeFormFit interface
IAlignmentFromFile | IAlignmentFromFile Interface
IAlignmentItem | IAlignmentItem Interface
IAlignmentRPS | IAlignmentRPS interface
IApplication | IApplication Interface
IBestFitItem | IBestFitItem Interface
IBestFitResult | IBestFitResult Interface
IBestFitStat | IBestFitStat Interface
IBoundingBox3D | IBoundingBox3D Interface - a 3D rectangular bounded box
IBrowseHelper | IBrowseHelper Interface
ICADEntities | ICADEntities Interface
ICADEntity | ICADEntity Interface
ICADFile | ICADFile Interface
ICADFiles | ICADFiles Interface
ICADLevel | ICADLevel Interface
ICADLevels | ICADLevels Interface
ICADObject | ICADObject Interface
ICADObjects | ICADObjects Interface
ICADSelectionManager | ICADSelectionManager Interface
ICADViewReportItem | ICADViewReportItem Interface
ICADViewStateItem | ICADViewStateItem Interface
ICalibration | ICalibration Interface
ICalibrationAdmin | ICalibrationAdmin Interface
ICarriage | ICarriage Interface
ICarriages | ICarriages Interface
ICMMBoolParameter | ICMMBoolParameter Interface
ICMMCNCController | ICMMCNCController Interface
ICMMDatumItem |
ICMMFloatParameter | ICMMFloatParameter Interface
ICMMParameter | ICMMParameter Interface
ICMMParameters | ICMMParameters Interface
ICMMParametersCategories | ICMMParametersCategories Interface
ICMMParametersCategory | ICMMParametersCategory Interface
ICMMParameterToolbox | ICMMParameterToolbox Interface
ICMMPlaneParameter | ICMMPlaneParameter Interface
ICMMPoint | ICMMPoint Interface
ICMMPointParameter | ICMMPointParameter Interface
ICMMPoints | ICMMPoints Interface - a collection of CMMPoint
ICMMProtocol | ICMMProtocol Interface
ICMMProtocolConfigurator | ICMMProtocolConfigurator Interface
ICMMSimulator | IICMMSimulator Interface
ICMMUIExtensionCommand | ICMMUIExtensionCommand Interface
ICMMUIExtensionCommands | ICMMUIExtensionCommands Interface
ICMMVectorParameter | ICMMVectorParameter Interface
ICoClass | ICoClass Interface
ICollection | ICollection Interface
ICommandBar | ICommandBar Interface
ICommandBarButton | ICommandBarButton Interface
ICommandBarComboBox | ICommandBarComboBox Interface
ICommandBarControl | ICommandBarControl Interface
ICommandBarControls | ICommandBarControls Interface
ICommandBarPopup | ICommandBarPopup Interface
ICommandBars | ICommandBars Interface
IConstant | IConstant Interface
ICoordFormat | ICoordFormatPoint3D Interface
ICoordFormatPoint3D | ICoordFormatPoint3D Interface
ICoordFormatUnitVector3D | ICoordFormatUnitVector3D Interface
ICoordFormatVector3D | ICoordFormatVector3D Interface
ICustomActionItem | ICustomActionItem Interface
IDatumFeatureCollection | IProbeRackSlotCollection Interface
IDatumOnExistingFeatures_Item |
IDatumRotateItem |
IDatumRotateToFeature2DItem |
IDatumRotateToFeature3DItem |
IDatumShiftItem |
IDatumSphere | IDatumSphere Interface
IDigitisedCurve | IDigitisedCurve Interface
IDispinterface | IDispinterface Interface
IDocument | the PowerINSPECT Document interface
IDocuments | IDocuments Interface
IDynamicPoint | IDynamicPoint Interface
IDynamicPoints | IDynamicPoints Interface
IDynamicTarget | IDynamicTarget Interface
IDynamicTargetResult | IDynamicTargetResult Interface
IDynamicTargetResults | IDynamicTargetResults Interface
IDynamicTargets | IDynamicTargets Interface
IEdgePoint | IEdgePoint Interface
IEdgePointItem | IEdgePointItem Interface
IEdgePointResult | IEdgePointResult Interface
IEdgePointResultStack | IEdgePointResultStack - a collection of EdgePointResult objects
IEntityFromPoints | IEntityFromPoints
IEnum | IEnum Interface
IFeat_Circle_PlaneConicItem |
IFeat_CircleThroughNPointsItem |
IFeat_ConeItem |
IFeat_CylinderItem |
IFeat_LaserScannedCircleItem |
IFeat_LaserScannedPatchItem |
IFeat_LaserScannedRectangleItem |
IFeat_LaserScannedSphereItem |
IFeat_PolygoneItem |
IFeat_ProbedCircleItem |
IFeat_RectangleItem |
IFeat_SinglePointCircleItem |
IFeat_SlotItem |
IFeat_SphereItem |
IFeat_TorusItem |
IFeature | IFeature Interface
IFeatures | IFeatures Interface
IFireCMMProtocolEvents | IFireCMMProtocolEvents Interface
IFunction | IFunction Interface
IGDTDatumFeatureLink | IGDTDatumFeatureLink Interface
IGDTFeature | IGDTFeature Interface
IGDTFeaturesLink | IGDTFeaturesLink Interface
IGDTItem | IGDTItem Interface
IGeometricCircleItem |
IGeometricGroup | IGeometricGroup Interface
IGeometricItem | IGeometricItem Interface
IGeometricLaserScannedItem |
IGeometricLineItem |
IGeometricPlaneItem |
IGeometricPointItem |
IHTMLConnector | IHTMLConnector Interface
IIndexableProbeHead | IIndexableProbeHead Interface
IIndexableProbeHeadProtocol | IIndexableProbeHeadProtocol
IIntermediateProbePathItem |
ILaserScannedCylinderItem |
ILaserScannedSlotItem |
ILine_BissectorItem |
ILine_Inter2PlanesItem |
ILine_ParallelTroughPointItem |
ILine_PerpendicularTroughPointItem |
ILine_PointVectorItem |
ILine_ProbedItem |
ILine_ProjectedOnPlaneItem |
ILine_ThroughPointsItem |
ILine_WithAngleItem |
ILine_WithOffsetPointItem |
IMachineAxes | IMachineAxes Interface
IMachineAxis | IMachineAxis Interface
IMachineOrientationData | IMachineOrientationData Interface
IManualProbeHead | IManualProbeHead Interface
IMathToolbox | IMathToolbox Interface
IMeas_3DAngle2VectorsItem |
IMeas_3DAnglePlaneLineItem |
IMeas_Angle2LinesItem |
IMeas_Angle2PlanesItem |
IMeas_Distance2PointsItem |
IMeas_DistancePointLineItem |
IMeas_DistancePointPlaneItem |
IMeas_RelativePositionItem |
IMeasure | IMeasure Interface
IMeasures | IMeasures Interface
IMeasureStatistics | IMeasureStatistics Interface
IMultiaxisConfigurationItem |
INominalPointItem |
INominalVectorItem |
IObjectPool | IObjectPool Interface
IOffsetPoint | IOffsetPoint Interface
IOffsetPoints | IOffsetPoints Interface
IOMVExporter | IOMVExporter Interface
IOMVIItem | IOMVIItem Interface
IOMVIItemRichInfo | IOMVIItemRichInfo Interface
IOMVIItemSequentialStream | IOMVIItemSequentialStream Interface
IOMVImportCtrl | IOMVImportCtrl Interface
IOMVImporter | IOMVImporter Interface
IOMVIReader | IOMVIReader Interface
IOMVIScriptReader | IOMVIScriptReader Interface
IOMVScriptReaderBridge | IOMVScriptReaderBridge Interface
IParameter | IParameter Interface
IParameter1 | IParameter1 Interface
IParameterAngleQuadrant | IParameterAngleQuadrant Interface
IParameterBoundary | IParameterBoundary Interface
IParameterCompensationMethod | IParameterCompensationMethod Interface
IParameterCompositeOffset | IParameterVector3D Interface
IParameterDirection | IParameterDirection Interface
IParameterEnum | IParameterEnum Interface
IParameterGuidedMeasure | IParameterGuidedMeasure Interface
IParameterMainPlane | IParameterMainPlane Interface
IParameterMaterialCondition | IParameterMaterialCondition Interface
IParameterMaterialSide | IParameterMaterialSide Interface
IParameterMatrixDefinition | IParameterMatrixDefinition Interface
IParameterPoint3D | IParameterPoint3D Interface
IParameterPoint3DEx | IParameterPoint3DEx Interface
IParameterReportSettings | IParameterReportSettings Interface
IParameterRPSConstraints | IParameterRPSConstraints Interface
IParameters | IParameters Interface
IParameterVector3D | IParameterVector3D Interface
IParameterVector3DEx | IParameterVector3DEx Interface
IPCSDatumItem |
IPDBDefinition | IPDBDefinition Interface
IPlane_BissectorItem |
IPlane_LinePointItem |
IPlane_LineVectorItem |
IPlane_OffsetDistanceItem |
IPlane_ParallelThroughPointItem |
IPlane_PointVectorItem |
IPlane_ProbedItem |
IPlane_WithOffsetPointsItem |
IPoint_FeatureIntersectionItem |
IPoint_Inter2Lines3DItem |
IPoint_Inter2LinesProjectedItem |
IPoint_Inter3PlanesItem |
IPoint_InterPlaneLineItem |
IPoint_MiddleItem |
IPoint_ProjectedOnLineItem |
IPoint_ProjectedOnPlaneItem |
IPoint_RetracePointItem |
IPoint3D | IPoint3D Interface
IPointCloud | IPointCloud Interface
IPointCloudImportCallback | IPointCloud Interface
IPointCloudItem | IPointCloudItem Interface
IPointCloudPoint | IPointCloudPoint Interface
IPointCloudSelection | IIPointCloudSelection Interface
IPosition | IPosition Interface
IProbeDatabase | IProbeDatabase Interface
IProbeDatabaseSettings | IProbeDatabaseSettings Interface
IProbeDatabaseToolbox | IProbeDatabaseToolbox Interface
IProbeHead | IProbeHead Interface
IProbePath | IProbePath Interface
IProbePathCXMOutputter | IProbePathCXMOutputter Interface
IProbePathDynamicPosition | IProbePathPositionalItem Interface
IProbePathEditor | IProbePathEditor Interface
IProbePathEditorCallBack | IProbePathEditorCallBack Interface
IProbePathFaultItem | IProbePathFaultItem Interface
IProbePathFaultItems | IProbePathFaultItems Interface
IProbePathFaults | IProbePathFaults Interface
IProbePathItem | IProbePathItem Interface
IProbePathItemActiveMove | IProbePathItemActiveMove Interface
IProbePathItemCNCParameter | IProbePathItemActiveMove Interface
IProbePathItems | IProbePathItems Interface
IProbePathMachineConfiguration | IProbePathMachineConfiguration Interface
IProbePathPositionalItem | IProbePathPositionalItem Interface
IProbePathReplay | IProbePathReplay Interface
IProbePathScanItem | IProbePathScanItem Interface
IProbePathTeach | IProbePathTeach Interface
IProbeRack | IProbeRack Interface
IProbeRackCollection | IProbeRackCollection Interface
IProbeRackSlot | IProbeRackSlot Interface
IProbeRackSlotCollection | IProbeRackSlotCollection Interface
IProbeReconciliator | IProbeReconciliator Interface
IProbeSensor | IProbeSensor Interface
IProbeSensorCollection | IProbeSensorCollection Interface
IProbeSensorCylinder | IProbeSensorCylinder Interface
IProbeSensorSphere | IProbeSensorSphere Interface
IProbeStructureBuilder | IProbeStructureBuilder Interface
IProbeTip | IProbeTip Interface
IProbeTipCollection | IProbeTipCollection Interface
IProbeTool | IProbeTool Interface
IProbeToolCollection | IProbeToolCollection Interface
IProbeToolConnection | IProbeToolConnection Interface
IProbeToolConnections | IProbeToolConnections Interface
IProperties | IProperties Interface
IProperty | IProperty Interface
IProperty1 | IProperty1 Interface for Angle, Dimension
IProperty3 | IProperty3 Interface
IPropertyAngle | IPropertyAngle Interface for Angle
IPropertyGeometricTolerance | GeometricTolerance Interface for Geometric Tolerancing
IPropertyLinearDimension | IPropertyLinearDimension Interface for Geometric Tolerancing
IPropertyPoint3D | IPropertyPoint3 Interface
IPropertyRadialDimension | IPropertyRadialDimension Interface for Geometric Tolerancing
IPropertyUnitVector3D | IPropertyUnitVector3D Interface
IPropertyVector3D | IPropertyVector3D Interface
IPWIArc3D | IPWIArc3D Interface
IPWICircle3D | IPWICircle3D Interface
IPWICone | IPWICone Interface
IPWICylinder | IPWICylinder Interface
IPWILine3D | IPWILine3D Interface
IPWIPlane | IPWIPlane Interface
IPWIPoint | IPWIPoint Interface
IPWIRectangle | IPWIRectangle Interface
IPWIScript | IPWIScript Interface
IPWISlot | IPWISlot Interface
IPWISphere | IPWISphere Interface
IPWITorus | IPWITorus Interface
IPWIWireframeEvaluator3D | IPWIWireframeEvaluator3D Interface
IrbDHTMLBridge | IrbDHTMLBridge Interface
IrbReportVariables | IrbReportVariables Interface
IrbTemplatesManager | IrbTemplatesManager Interface
IRegPropertyBag | IRegPropertyBag Interface
IReportVariable | IReportVariable Interface
IReportVariables | IReportVariables Interface
IRPSConstraint | IRPSConstraint Interface
IScanInstruction | IScanInstruction Interface
IScanItem | IScanItem Interface
IScanItems | IScanItems Interface
IScanItemWithPrimary | IScanItemWithPrimary Interface
IScanItemWithSecondary | IScanItemWithSecondary Interface
IScanOnCircle | IScanOnCircle Interface
IScanOnCurve | IScanOnCurve Interface
IScanOnHelix | IScanOnHelix Interface
IScanOnLine | IScanOnLine Interface
ISecondaryDatumItem |
ISequenceGroup | ISequenceGroup Interface
ISequenceItem | ISequenceItem Interface
ISequenceItemIterator | ISequenceItemIterator Interface
ISequenceItems | ISequenceItems Interface
ISequenceLink | ISequenceLink_base base Interface
ISequenceLinks | ISequenceLinks Interface
ISequenceMultipleLink | ISequenceMultipleLink Interface
ISequenceReplayEngine | ISequenceReplayEngine Interface
ISequenceReplayEngineCtrl | ISequenceReplayEngineCtrl Interface
ISequenceReplayValidator | ISequenceReplayValidator Interface
ISequenceResult | ISequenceResult Interface
ISequenceSimpleLink | ISequenceLink Interface
ISimpleProbeDatabase | ISimpleProbeDatabase Interface
ISurfaceGroup | ISequenceGroup Interface
ISurfacePoint | ISurfacePoint Interface
ISurfacePointItem | ISurfacePointItem Interface
ISurfacePointResult | ISurfacePointResult Interface
ISurfacePointResultStack | ISurfacePointResultStack - a collection of SurfacePointResult objects
ISurfaceSectionGroup | ISurfaceSectionGroup Interface
ITemperedTrackingPoints | ITemperedTrackingPoints Interface
IToolChanger | IToolChanger Interface
ITrackerCommand | ITrackerCommand Interface
ITransform | ITransform Interface
ITransform2 | ITransform2 Interface : (an extended Transform that gives more information about the internal vectors )
ITransformDefinition | the ITransformDefinition interface
ITypeDesc | ITypeDesc Interface
ITypeInformation | ITypeInformation Interface
ITypeLibrary | ITypeLibrary Interface
IUnitConverter | IUnitConverter Interface
IUnitVector3D | IUnitVector3D Interface
IVarDesc | ICoClass Interface
IVector3D | IVector3D Interface
IVerticeSelectionManager | IVerticeSelectionManager Interface
IWebScreen | IWebScreen Interface
IWorkplaneItem | IWorkplaneItem Interface
IXMLDOMAttribute |
IXMLDOMCDATASection |
IXMLDOMCharacterData |
IXMLDOMComment |
IXMLDOMDocument |
IXMLDOMDocumentFragment |
IXMLDOMDocumentType |
IXMLDOMElement |
IXMLDOMEntityReference |
IXMLDOMImplementation |
IXMLDOMNamedNodeMap |
IXMLDOMNode | Core DOM node interface
IXMLDOMNodeList |
IXMLDOMParseError | structure for reporting parser errors
IXMLDOMProcessingInstruction |
IXMLDOMText |
Name | Description
_internal_PutActiveTip | INTERNAL USE ONLY
_internal_PutProbeTool | INTERNAL USE ONLY
Abort |
abort | abort an asynchronous download
Activate | enter the Geometry Explorer mode
ActivateCustomTab | Bring the indicated custom tab to the front.
ActivateSensor |
ActiveSensorChange |
ActiveSensorChanged | fired after the active sensor on the probe Head has changed
ActiveSensorChanged | fired after the active Sensor on the probe Head has changed
ActiveTipChanged | fired after the active tip on the probe Head has changed
ActiveToolChanged | fired after the active tool mounted on the probe Head has changed
Add | fired after a element has been inserted into the collection
Add | method Add : add an item to the collection
Add | method Add : add an item to the collection
Add | Add a feature to the list
Add | method Add : add an item to the collection
Add | method Add : add an item to the collection
Add | method Add : add an item to the collection
Add | method Add : add an item to the collection
Add |
Add | Add an add in
Add | method Add
Add | method Add
Add | Method Add
Add | method Add
Add |
Add | method Add
Add | method Add
Add | Add a feature to the list
Add | add a new measure to the collection
Add | add a new constraint
AddAlignment | method AddAlignment : Add a AddAlignment to this collection of sequence items
AddBoolParameter | method AddBoolParameter
AddCMMPoint | OBSOLETE : Add a single CMMPoint ( probe offset compensation will not apply
AddCMMPoints |
addCone | Adds cone to new probe
addCylinder | Adds cylinder to new probe
AddFloatParameter | method AddFloatParameter
AddGeometricItem | method AddAlignment : Add a AddAlignment to this collection of sequence items
AddGroup | method AddGroup
AddItem | method AddItem
AddItem | method AddItem : Add an item to this collection of sequence items
AddMachineAxisAndConstraints | Add a machine axis to the list of machine axes.
AddMachineAxisAndValue | Add a machine axis to the list of machine axes.
AddMachineAxisValueAndConstraints | Add a machine axis to the list of machine axes.
AddNamedXYZIJK | method AddNamedXYZIJK
AddPlaneParameter | Add a plane parameter
AddPointFault | Add a fault-item to the end of the list
AddPointParameter | Add a plane parameter
AddPoints | Add contact points.
AddPointXYZ | method AddPointXYZ
AddPointXYZIJK | method AddPointXYZIJK
AddRangeFault | Add a fault-item to the end of the list.
addSphere | Adds sphere to new probe
addTip | Adds a new probe tip
AddVectorParameter | Add a vector parameter
AddXYZIJK | method AddXYZJIK
AfterDelete | fired after a element has been removed from the collection
AnglesAreTrusted | Ask if the current probe angles are correct
AnglesChanged | method OnProbeHeadAnglesChanged
AngleVector | method AngleVector
Append | Append: add a copy of the srcCollection into this collection
Append | Appends the given probe path to output.
appendChild | append a child node
AppendComment | Appends the given string as a comment.
appendData | append string to value
AppendMOWorkplane | Appends a machine-orientation workplane definition to the output
AppendWithName | Appends the given probe path to output and marks it as belonging to a sequence item with the given name.
AppendWorkplane | Appends workplane definition to the output
ApplicationBeforeClose | fires when the application is about to close and to shutydown : client should release all the pointer to the application at this stage
ApplyOffsetNow |
ApplyPackedValue |
ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
ApplyToleranceNow |
ApplyViewSettings | applies the view settings on the active CADView again
Assign | Assigns an object with the given name to this collection. The object will be removed from the original level.
Attribute |
BeforeCommandExecution | indicates that PowerINSPECT is about to execute a command
BeforeDeleteItem | an item is about to be deleted from the ProbePath
BeforeDeleteItem | indicates that an item is beeing deleted from document
BeforeDeleteMeasure | indicates that a measure is beeing deleted from document
BrowseIDispatchTypeLibrary | Browse the type library of a given object
BrowseTypeLibrary | method BrowseTypeLibrary
BrowseTypeLibraryIID | method BrowseTypeLibraryIID
BuildProbeHeadEnvelope | Graphically build the envelope around a probe head ( start from the tool mounting point toward the quill ( upward )
BuildProbePathForTipCalibration | Build a probe path that can be used to calibrate the following tip
BuildProbeToolGraphics | Graphically build a tool
Calculate | Evaluate the bestfit
Calibrate | invokes the User Interface Wizard that will carried out the calibration for this element
CalibrateActiveSensor | brings a user interface to allow the active sensor to be calibrated
CalibrationStatusChanged | fired when the status of the calibration changed
CalibrationStatusChanged | fired when the status of the calibration changed for the given item : item could be head,sensor,or tip
CallScript | method CallScript
Cancel | exit the EDIT mode and revert back to the previous probe path
Cancel | exit the Geometry Explorer
CancelCurrentCNCAction | method CancelCurrentCNCAction
Change | method Change
Changed | fired after a element definition has changed
ChangeTarget |
ChangeTool | request a tool changing ( could be a asynchronous operation)
CheckIntersectionWithCADModel | Check intersection of a segment with the CAD model along a direction, if multiple solution found then the method returns the closest to point1
CheckPaf | returns the number of day left for the licence: (0= no licence or expired) ( -1 = permanent ) ( n : n day left)
Circle3Points | calculate the center,normale and radius of a circle through the 3 given points
Clear | Clear and remove all elements in this probe path
Clear | method Clear : Empty all points from the list
Clear | method Clear
Clear | Remove all the fault-items.
Clear | Remove all the scan items.
ClearAxisList | Clear the list of machine axes
ClearMessageArea | Removes all the messages from the info area
ClearPoints | Clear contact points.
Click | method Click
client_add | method client_add
client_set_html_document | method client_set_html_document
client_set_template | method client_set_template
Clone | Clone : create an exact copy of this object and return a pointer to it
Clone | Create a new sequence item which has all the same properties as this one
cloneNode |
Close | close all opened documents
Close | Informs the stream that it may release all the resources.
Close | Closes the registry key.
Close | Close the specified document
CMMConnectionAboutToChange |
CNCControllingLockChanged | Fired when a CNC controlling object locks or unlocks its CNC control
CollectSensorDefinitionItems |
CommandsModified | method CommandsModified
CommandStateChanged | method CommandStateChanged
Commit | commit the changes made
Commit | commit the current probe path and remain in Edit mode
CompareMachineOrientation | Is the machine transform in this machine-orientation the same as the one in the parameter.
Compensate | Apply the probe offset compensation to the give coordinates according the current active tip
Compensate | Apply the probe offset compensation to the give coordinates according to this tip
Compensate | get the compemsate coordinates according the active sensor
ComputeBestAngles | Calculate the best A and B angles to match the given vector, vector is supposed to be the stem direction from tip toward the shank
ComputeBestAnglesV | ( SCRIPT VERSION of ComputeBestAngles ) Calculate the best A and B angles to match the given vector, vector is supposed to be the stem direction from tip toward the shank
ConfigChanged |
ConfigurationChanged | fired when the configuration of the carriage has changed
Configure | Call a user interface that will allow the user to set the script parameters
Configure | The method is called when a user wants to configure the reader.
Connect |
ConnectObject | Connect an object
ContactPoint | method ContactPoint
ContactPointCalibration | method ContactPointCalibration
Convert |
Convert | convert that point to the type specified, the point will snap to the closest point on the edge or on the surface
ConvertPointAccordingToMachinePosition | Convert the given point and vector from the current type to the new type according to the current position of the machine.
ConvertTo | change the type of the radial dimension, by changing the nominal value accordingly
Copy | Copy the parameter object data to this object.
Copy | Copy the parameter object data into this object.
Copy | Copy the parameter object data to this object.
CopyFrom | CopyFrom: create a copy from srcCollection into this collection
CopyMeasure | Copy the result of the item from one measure to the other
CopyTo | copy the contents of this CMMPameters object to the pDest
CopyTo | copy the contents of this probe path into the specified one
CPPTypeStr | retrieve the CPPType String
createAttribute | create an attribute node
createCDATASection | create a CDATA section node
createComment | create a comment node
CreateCopy |
createDocumentFragment | create a DocumentFragment node
CreateDynamicPoint | create a new dynamic point
createElement | create an Element node
createEntityReference | create an entity reference node
CreateFreeFormFitAlignment | use all points to create a free form fit alignemnt
CreateGuidedPoint | convert that point into a guided point in the specified group
CreateGuidedPoints | convert all points of this container into a guided points in the specified group
CreateLocalObject | Create a object in the same thread context as the PowerINSPECT Application
createNode | create a node of the specified node type and name
CreateObject | Create an object local to the thread of this
CreateProbeHeadFromCatalogue | build up a probe head from the catalogue
CreateProbeRackFromCatalogue | build up a probe rack from the catalogue
CreateProbeToolFromAssemblyDefinition | create a probe from a assembly reference that exists in the ProbeCatalogue, assemblyDefinition can also be a XMLDocument containing the tag <AssemblyDefinition>
createProcessingInstruction | create a processing instruction node
CreateReport | Creates an HTML Report and saves it as a single web-archive file (*.mht file) to the given location
CreateRotation | Create a rotation of the specified angle ( in degree) around one axis ( through the origin )
CreateRotationAtPoint | Create a rotation of the specified angle ( in degree) around one axis ( defined with a vector and a point )
CreateScriptReader | Helps to create and properly initialiaze a script reader
CreateSimpleStarProbe | create a coumpound tools with 5 simple touch trigger sensors
createTextNode | create a text node
CreateTouchTriggerProbeWithOneSensor | create a simple touch trigger probe with a single spherical tip
CreateTransform | Create a transformation with 2 vectors and an origin
CreateTransform1V | Create a transformation with a single vector and an origin
CreateTranslation | Create a translation
CrossProduct | method CrossProduct : a and b can be either IVector3D or IUnitVector3D and the result will be a Vector3D
DeactivateCustomTab | Send the indicated custom tab to the back.
Delete | remove this element from its parent collection
Delete |
Delete | Delete the item. this method may failed if the item is already referenced
Delete | delete this item from the collection
Delete | Delete this measure from the document
Delete | Deletes the object and remove it from it's containing document
Delete | method Delete
Delete | remove this connection from the parent connections collection
Delete | add a new constraint
Delete | method Delete : delete a tip from the collection
Delete | method Delete : delete an item from the collection
Delete | method Delete the specifyed measure from the collection
Delete | remove a connection from the collection
Delete | fired before a element will be removed from the collection
DeleteAll | Delete all the connections
DeleteAll | method Delete all Dynamic Points from the collection
DeleteAll | method Delete all measures from the collection
deleteData | delete string within the value
Disconnect |
DisconnectObject | Disconnect an object
Distance | method Distance Calculates the distance between 2 points : a and b can be either IPoint3D
DocumentActivate |
DocumentBeforeClose |
DocumentBeforeSave |
DocumentClose | indicates that this document is going to be closed and should not be accessed anymore
DocumentDeactivate |
DocumentOpen |
DoRepositioning | OnRelocate
DotProduct | method DotProduct
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
Edit | enter the EDIT mode
EditDatabase | brings a user dialog box to allow the underlying probe database to be managed
EditSensor |
EmergencyStop | cancel any pending action. current step is also cancelled
EnableModeless |
EnableModeless | Fired to request the client to disable or enable its main window and other modeless dialogs
endElement | Completes an element in the structure
EndProbeBuilder | End building a new probe
EndQueue |
EnumValueAsString | resolve a enum value into a string
EnvironmentUpdate |
ErrorsInMarkedRange | Validate all sequence items in the marked range.
ErrorsWithActiveItem | Validate the active sequence item
Evaluate | Evaluate the boundary of a entity
Execute | Execute the custom action
Execute | Executes the interface extension command
Execute | method Execute
ExecuteCommand | Execute a command by string
ExecuteCommandID | Send a command to the application, a positive number 'send' a command, a negative number will 'post' a command
Export | method Export
ExportPoints |
ExportPoints |
ExportXMLCutFile | method ExportXMLCutFile
ExportXMLProbePath | method ExportXMLProbePath
ExtendsChanged | fired when the extends of the carriage has changed
extract_variables | method extract_variables
FakeCalibrate |
FakeCalibrateTip |
FillArrayWithMeasuredCMMPoints |
FillIdentityCard | fill the node with the identity card of this item
FilterDataObject |
FindBar |
FindBestFeaturePlane | Find one feature plane compatible with the given entity excluding features provided by alignments
FindClosestPoint | Find the closest point on the CAD model, within the specified proximity distance. If -1.0 is provided as proximity distance the current default value will be used. An approximation of the expected surface normal can be provided if necessary or Nothing.
FindControl |
FindEnum | find a enum by name
FindMeasureByUniqueID | find a SequenceItem by its UniqueID
FindMultiAxisConfigForSequenceItem | Find the MultiaxisConfigurationItem used to set the machine orientation for the given sequence item.
FindSequenceItemByUniqueID | find a SequenceItem by its UniqueID
FindTip |
Flush | Performs a flush on the open registry key.
ForceCurrentPositionUpdate | Forces the protocol to update the current position. Not all protocols will be able to implement this.
FullStop | Suspend the current action. Restart the current entity. Unlock the CMM.
GenerateImage | Generates CAD View Report image
GeometryExplorerEvent | fired when the user has made a selection with GE
Get | method Get
GetActiveSensor | extract the active sensor at the current location or if not defined
GetActiveSensorAtCursor | returns the name and identity card of the current active tip
GetAngles | retrieve the current A and B angle of the physical indexable probe head
GetAngles | Get the current angular position of the probe
getAttribute | look up the string value of an attribute by name
getAttributeNode | look up the attribute node by name
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
GetCNCControllingObject | Creates an object to allow CNC controlling actions to be performed on the protocol.
getConfig | method getConfig
GetCoordinate | retrieve the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)
GetCoordinate | retrieve the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)
GetCoordinates | retreives the 3 coordinates ( cartesian ) in one round trip ( this version cannot be used in scripts )
GetCoordinates | retreives the 3 coordinates ( cartesian ) in one round trip
GetCoordinates | retreives the 3 coordinates ( cartesian ) in one round trip ( this version is not scriptable )
GetCoordinatesV | retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )
GetCoordinatesV | retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )
GetCopy | create a copy the contents of this probe path into the specified one
GetCurrentPosition | method CurrentPosition
GetDropTarget |
GetExternal |
GetHostInfo |
GetLastMappingError | method GetLastMappingError
GetLocalDatumAtProbeMountingPoint | return the local matrix of the probe head mounting point for the specified angles
GetMachineAxis | Get the absolute value of the machine axis.
GetMessageString |
getNamedItem | lookup item by name
GetOptionKeyPath |
GetPackedStringBool | Get the packed string for a BOOLEAN
GetPackedStringBooleanParameter | Create the packed value for a CMM BooleanParameter
GetPackedStringFloat | Get the packed string for a Float
GetPackedStringFloatParameter | Create the packed value for a CMM FloatParameter.
GetPackedStringPlane | Get the packed string for a Plane
GetPackedStringPoint | Get the packed string for a Point
GetPackedStringTransform | Create a Transform xml-element that has the given name and units attributes
GetPackedStringVector | Get the packed string for a Vector
getParameters | Returns the available collection of id's as an XML document
GetPoints | Get the points.
GetProbeHeadKinematics | retrieve the probe head kinematics for as a XML iland string
GetProbePathReplay |
GetProbeTip | retrieves the probe tip that match the given A and B angle, if bCreate = True, a new tip will be automatically create if none exists
GetPropertyDouble | extract a double property from the PDBdefinition
GetPropertyString | extract a string property from the PDBdefinition
getQualifiedItem | lookup the item by name and namespace
GetRefMarks | method GetRefMarks : return a copy of the current reference marker position
GetSmartName | return a smart name for this tip based on the sensor/tool and type of probehead actually used
getStyles | method getStyles
getTemplate | method getTemplate
getTemplateNoCache | returns a template as it is stored
GetTrackingPointObject | Creates an object to allow collection of tracking points.
GetUserCamera | GetUserCamera
GetValueUnit | Get the current value in the specified unit
GoBack | Move back at the start of the current entity or at the start of the previous entity
GoDefaultHome |
GoStep | do one step only
GoStep | method GoStep
hasChildNodes |
hasFeature |
HideUI |
Home | Home or Reset the CMM Device
Home | Method Homed : Home or Reset the CMM Device
Import | method Import
ImportMeasuredData | Copies measured data from amother measure, transforming it between the two alignments.
ImportPointCloudFile | Read a file file of point as a cloud, will generate one or more point clouds
Initialise |
Initialize | Informs the stream that it needs to take any initialization action.
Initialize |
Insert | method Add
Insert | method Insert
insertBefore | insert a child node
InsertBooleanParameter | Add a Float Parameter
InsertCompositeMeasureMove | Add an Composite Move to the probe path
InsertCopy | Insert Copy
insertData | insert string into value
InsertDynamicPositionalItem | Add a positional instruction to the probe Path, which is a defined
InsertFloatParameter | Add a Float Parameter
InsertMachineConfiguration | Insert a machine-configuration item into the probe-path.
InsertParameter | Add a Parameter
InsertPositionalItem | Add a positional instruction to the probe Path
InsertProbeAutoOrientation | Add a probe orientation change,instruct the probe to rotate so that the current active tip is along the specified vector
InsertProbePath | append the content of other ProbePath to this one at the specified location
InsertProbeSensorDefinition | Add a probe sensor definition/recall in the probe path
InsertScanCommand | Insert a scan instruction into the probe-path.
InsertScanItem | Insert an ordinary scan-item.
InsertScanItemWithPrimary | Insert a scan-item which contains a primary tool-vector.
InsertScanItemWithSecondary | Insert a scan-item which contains a both a primary and secondary tool-vector.
InstallCustomTab | InstallCustomTab
InstallProbeHead | Install a new probe Head
InstallStandardProbe | Install a standard probe into Probe database (the argument can be the name of a standard probe (i.e TP20x20x2 or a full assembly definition
IntermediatePoint | method IntermediatePoint
IntersectionWithCADModel | Intersects a segment with the CAD model along a direction, if multiple solution found then the method returns the closest to point1, a full description of the surface point including point3D , parametric parameter and normal is provided, the function returns ?ç?
Invalidate | invalid the item result for the given measure
Invalidate | Invalidate all items to a unmeasured state for this particular measure
InvalidateMeasures | Clear all recorded CMMPoints on items
Inverse | method Inverse
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
IsItemSafeForReplayUI | Check if the given sequence is safe for replay. If not, warn the user and ask them if they wish to replay the item.
IsPackedString | returns true if the string is a valid packed string
IsRangeSafeForReplayUI | Check if the current range of items is safe for replay. If not, warn the user and ask them if they wish to replay the items.
IsValidValue | check if the value provided is suitable for this parameter
LevelToGravity |
load | load document from the specified XML source
Load | Load the probe database, stream could be a BSTR
Load | Load the full state of the simulator from a stream or a file
Load | load the definition matrix from a .MAT file
LoadCMMConfiguration | Install a new cmm kinematic file
LoadConfigurationInteractive | Displays a file dialog to allow user to load the configuration of the simulator
Loaded | fired when the carriage has been persisted back from a storage
LoadFromFile |
LoadKinematicsInteractive | Displays a file dialog to allow user to load a different model for the CMM
LoadUnitFile |
loadXML | load the document from a string
LocalizeString | return a localized version of a string
LocalizeString | Returns localised string if possible
locate_file | method locate_file
LockCNCControl | Locks the protocol to be controlled by this object alone. Must be called successfully before controlling calls will succeed.
LockEdit |
LockUnit | Prevent other clients of the object from changing the units.
LogonUser | logon as a specific user
MachineAxisAddress | The machine axes address.
MachineAxisType | The machine axes type.
MeasuredPoint | the measured surface point for the given measure
MeasuredPoint | the measured surface point for the given measure
MeasureTo | Perform a composite measure move.
MessageBox | Display a message box on the screen: you are encouraged to use the built in VBScript MsgBox as this method is for backward compatibility only
Motors |
Move | Move the item into a different location ( either within the same group or into a different group)
MoveProbe | Move the probe to the specified position.
MultipointMove | MultipointMove
NewDocument |
nextNode | get next node from iterator
Node | depreciated - do not use
nodeFromID | retrieve node from it's ID
NormaliseAngles | normalize the 2 angles : will make sure that startAngle < endAngle and that the 2 angles are in the proper range
NormaliseAnglesV | normalize the 2 angles ( SCRIPTABLE version of NormaliseAngles ) : will make sure that startAngle < endAngle and that the 2 angles are in the proper range
normalize | collapse all adjacent text nodes in sub-tree
OnActiveItemChange | indictates that the active item ( as selected in the active Tree view ) has changed
OnActiveMeasureChange | indictates that the active measure ( as selected in the active Tree view ) has changed
OnActiveWorkplaneChanged | The current Active work plane has changed
OnAddDynamicPoint | indicates that a dynamic point has been added on the collection
OnAddItem | an item has been added to the ProbePath
OnAddItem | indicates that a new item has been added to the document
OnBeforeDeleteDynamicPoint | indicates that a dynamic point is about to be removed from the collection
OnBeforeModifyDynamicPoint | indicates that a dynamic point in the collection is about to be modfied
OnBeforeMoveItem | Indicates that the specified item is going to be moved in the sequence tree. there is a opportunity to cancel the action
OnCalibrationModeChanged | OnCalibration Mode change
OnChanged | method OnChanged
OnChangeRequested | method OnChangeRequested
OnClickedBackOneStep | Fired when the user presses the One Step button
OnClickedDoNextStep | Fired when the user presses the Next Step button
OnClickedEStop | Fired when the user presses the EStop button
OnClickedFullStop | Fired when the user presses the Full Stop button
OnClickedReplay | Fired when the user presses the Replay button
OnClickedRewind | Fired when the user presses the Rewind button
OnClickedSuspend | Fired when the user presses the Suspend button
OnClose | Fired when the control is asked to close.
OnCMMHomed | method OnCMMHomed : the CMM homed flag is now set
OnCMMParameterChanged | method OnCMMParamerChanged
OnCMMParameterChanged | method OnCMMParamerChanged
OnCMMParameterChangeRequested | method OnCMMParameterChangeRequested
OnCNCError | Fired when a CNC error occurs during the reply, asking whether to retry and continue
OnCNCStatusChanged | method OnCNCStatusChanged
OnCompletion | method OnCNCError
OnConnectionChanged | method Connect
OnContactPointAdded |
OnContactPointMoved |
OnCoordTypeChange | the Coordinate Type has has changed (ABSOLUTE/INCREMENTAL
OnCurrentItemProgressChanged | Fired to notify progress on the current item being replayed
OnCurrentItemProgressChanged | method OnCurrentItemProgressChanged
OnCursorChange | the insertion point has changed
OnDocWindowActivate |
OnDoubleClick | Fires when the user double-clicks the object.
OnElementClicked | Informs the engine that an element is clicked
OnError | method OnError
OnExecuteCustomAction | indicates that PowerINSPECT is about to execute a custom action
OnFrameWindowActivate |
OnFullScreenInspectionCompleted | indicates that a full screen inspection has completed
OnFullScreenInspectionStarted | indicates that a full screen inspection has started
OnGlobalChange | All elements of the probe path have changed
OnIntermediatePoint | Fired when the user has inserted a intermediate point
OnItemChange | an item has changed
OnItemChange | indicates that an item definition has changed
OnItemDeleted | an item has been delete from the collection ( see BeforeDeleteItem)
OnItemImported | method OnItemImported
OnItemMeasureChange | indicates that an item measurement has changed
OnItemMeasurementCompleted | indictates that element has leaved the Measurement state
OnItemMeasurementStart | indictates that element has entered a Measurement state for the specified measure ( the GUI to measure this item is about to be display )
OnItemPositionMeasured | method OnItemPositionMeasured
OnJobStatusChanged | Change when the job status has changed
OnKeyDown | Fires when the user presses a key.
OnKeyPress | Fires when the user presses an alphanumeric key.
OnKeyUp | Fires when the user releases a key.
OnLocaleChange | indicates that the locale setting has change
OnLockStateChanged | the lock state of the probe path items has changed
OnLoggedInUserChanged | Indicates that the user has changed (security). The argument states whether the user can change items in the sequence tree.
OnManualContactPoint | Fired when a contact point has been probed manually
OnMeasureAdd | indicates that an new measure has been added to the document
OnModifyDynamicPoint | indicates that a dynamic point in the collection has been modfied
OnMouseDown | Fired when the user presses a mouse button down.
OnMouseLClick | Fired when the user clicks on a report in editing mode with the left button.
OnMouseMove | Fires when the user moves the mouse over the object.
OnMouseOver | Fires when the user moves the mouse pointer into the object.
OnMouseRClick | Fired when the user clicks on a report in editing mode with the right button.
OnMouseUp | Fires when the user releases a mouse button while the mouse is over the object.
OnPaletteButtonClicked | indicates that PowerINSPECT is about to open the dialog box to edit a inserted item, this give a chance not to display it by setting the boolean flag to TRUE
OnPositionalItemTypeChange | Fire_OnPositionalItemTypeChange
OnProgressChanged | method OnProgressChanged
OnRangeMarkersChanged | indicates that the range markers in the sequence tree have changed.
OnReadyForCommand | method OnReadyForCommand: call to the Protocol Object can be made here
OnRefMarks | method OnRefMarks
OnResetUserInterface |
OnResize | Fires when the size of the object is about to change.
OnScroll | Fires when the user repositions the scroll box in the scroll bar on the object.
OnSelectionChange | indicates that the selection has changed
OnSettingsChanged | Fired when the import setting was changed by a user.
OnStatusChanged | indicates that the state of the ProbePathEditor has changed
OnStatusChanged | Change when the job status has changed
OnStatusChanged | method OnStatusChanged
OnStepStatusChanged | Change when the status of the current step has changed
OnStrategyUpdateRequested | The application has requested a Probe Path Update from the strategy
OnTick | Change when the job status has changed
OnUnitChange | indicates that units of the document has changed
Open | Opens a registry key to store properties in.
Open | Open a particular PowerINSPECT document
OpenSubKey | Opens a subkey of the open registry key.
PackValueAndUnits | Returns a string that contains the value followed by the units
Parse | method Parse
PlaySound | Play a sound on the DCE Device
PointLaser |
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates
PreTouchIJKModeChanged | method PreTouchIJKModeChanged
Print | method Print
ProbeDatabaseChanged | Fired by the protocol if the probe database object changes
ProbeHeadAnglesChanged | method OnProbeHeadAnglesChanged
ProbeHeadChanged | fired after the probe Head has changed
ProbeHeadPositionChanged | fired when the position of the probe head has changed
ProbeStructureExists | Returns TRUE if the graphical structure for the probe specified by the vcard exists
ProbeTipAdded | fired when a probe tip has been added
ProbeTipChanged | Fired by the protocol for convenience when the probe database fires its ProbeTipChanged event
ProbeTipChanged | method OnProbeTipChanged
ProbeTipDeleted | fired when a probe tip has been deleted
ProjectPoints |
Property |
PseudoCalibrateTip |
PseudoCalibrateTool |
PutAngles | Put both angles at the same time
PutAngles | sets the A and B angles of the probe head, this function will returns after the physical angles have been set
QueryDeleteItem | indicates that an item is asked to be deleted from document by the user
QueryDeleteMeasure | indicates that an measure is asked to be deleted from document by the user
Quit | Quit the application
RapidMoveTo | Perform a rapid move from the current position to the new position.
RapidMoveWithMachineOrientation | Perform a rapid move from the current position/orientation to the new position/orientation.
Read | Reads a property from the open registry key.
Read | Provides the current item object, the Stream Status must be READY in order this method to succeed.
ReadObjectAsBinaryStream | Initialises an instance of an object from a binary stream in the open registry key.
ReconcileProbeTip |
ReconcileSensor |
Reconciliate |
ReconciliateTip |
RecordCurrentPosition | Insert a point matching the e current position of the CMM using the current settings
RecordMeasuredPositionAndVector | use to record the measure point ( only valid for MEASURE_TO COMPOSITE_MEASURE_MOVE )
RecordViewSettings | records the current view settings in the item
Refresh | Make sure the statistic are up-to-date and refresh them eventually
Refresh | method Refresh
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
RefreshReport | Force the current showing report to be re-generated
RegisterVCARD |
RemoteMouseChanged | Fired when the protocol's remote mouse state changes
Remove | method Remove
Remove | Remove a feature to the list
Remove | Method Remove
Remove | method Remove : remove a point from the list at the specified index
Remove | Remove an add-in by index ( zero based ) , prog ID or IDispatch
Remove | Remove a probe path item at the specified position
Remove | Remove At
Remove | Remove the item at the specified position
removeAttribute | remove an attribute by name
removeAttributeNode | remove the specified attribute
removeChild | remove a child node
RemoveCustomTab | RemoveCustomTab
RemoveItem | method RemoveItem
RemoveItem | Remove the fault-item at the given index.
removeNamedItem | remove item by name
removeQualifiedItem | remove the item by name and namespace
RemoveUnusedAutomaticTips | remove unused tips that may have been created automaticaly by the system
RenumberPointNow |
replaceChild | replace a child node
replaceData | replace string within the value
ReplayWithPoints | Replay the elements with the given points
ReportCompleted | Fired when a report creation was completely finished.
ReportParameters | Returns XML reported by report engine about settings of report
ReportSettings | Returns XML reported by report engine about settings of report
RequestDisconnect | Fired to request consent to disconnect
RequestDisconnection |
Reset | method Reset
Reset | reset the box to a invalid box
reset | reset the position of iterator
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.
ResetMachineOrientation | Reset the machine orientation to the home position.
ResetStatistics | Reset the animation statistics.
ResizeBorder |
RetrieveCount | Retrieve the number of entities between the ]low,high] range
Reverse | reverse the normal vector of the point
Reverse | Reverse the vector
Revert | Returns an object with the given name to the original collection. Results: S_OK - success, S_FALSE - the object was not found, E_FAIL - error.
Rewind | set the curent step to be the first
Rollback | rollback to the state we were in at the start of this transaction
RotateProbe | Rotate the probe head.
Run | method Run
Run | runs all steps up to the end
RunOnNewMeasure | Add a new measure inside PowerINSPECT , and start rerunning the sequence
RunSelectedItem | Runs the currently selected item
RunWithController | runs all steps up to the end
SafeMoveTo | Perform a safe move from the current position to the new position.
Save | Save the specified document. this methoid will fail if the document has not been save yet
Save | Save the probe database, if stream is null then the last known filename is used
save | save the document to a specified desination
Save | Save the full state of the simulator in a stream or a file
Save | save the definition matrix from a .MAT file
Save | Saves the generated CXM file to a file on the disk.
SaveAs |
SaveConfigurationInteractive | Displays a file dialog to allow user to save the configuration of the simulator
SaveCopyAS | Make a copy of the specified document
SaveDefaultConfiguration | Save the configuration of the simulator in the default location
saveTemplate | Saves the provided template with the provided name
SaveToXML | Dumps the generated CXM to the given XMLDocument object.
Scale | scale this vector by a factor
Scale | method Scale : scale the point cloud
Scale | scale the probe path ( note : units are not changed
Scale | scale the translation component by the specified amount
Scale | Scale: scale the points cloud ( usefull to convert between inches and mm
Scan |
ScanMove | Perform a Scan move.
Search |
selectSingleNode | execute query on the subtree
SendCMMPoint | Send a CMM point to PowerINSPECT
set_export_info | method set_export_info
set_page_settings | method set_page_settings
Set | method Set
SetAll | method SetAll
SetAngles | Move the probe to a new angular position
SetApparentAngles | set the ABC coordinates of the vector
setAttribute | set the string value of an attribute by name
setAttributeNode | set the specified attribute on the element
SetAzimuthElevation | set the Azimuth and Elevation of the vector , keeping the length
SetCalibrationData | internal use only: set the data that will be used to perform the calibration, the content depends on which item is beeing calibrated
SetCoefficients |
SetCoordinates | set the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)
SetCoordinates | set the IJK coordinates of the vector ( coordinates will be unified)
SetCoordinates | set the XYZ coordinates of the point
SetDiameterUnit | set the value using the specify value ( in the specified units ) without altering the internal units
SetDirection | sets the compensation direction, the Compensation Method will be updated accordingly, Dir could be a IFeature, a Vector or an empty variant
SetExcelTemplateName |
SetExpanded | sets flag indicating group is expanded in the sequence tree
SetFocus | method SetFocus
SetLowerTolerances | set the 3 lower tolerance values
SetMachineAxis | Set the absolute value of the machine axis.
SetMachineOrientation | Move the machine into the given position/orientation using the kinematic method and constraints given.
setNamedItem | set item by name
SetNominals | set the 3 nominal values
SetOrientationPointName | Set the current orientation point name.
SetPolarCoordinates | set the Polar coordinates (Angle,Radius,Height) of the vector
SetPolarCoordinates | set the Polar coordinates (Angle,Radius,Height) of the point
SetProbeHeadOrientation |
SetProbeHeadType | explicitly set the type of this probehead, usufull to identify its technology
SetSectionParameters | set the parameter of the section plane
SetSize | method SetSize
SetSphericalCoordinates | set the Spherical coordinates (Azimuth,Elevation,Magnitude) of the vector
SetSphericalCoordinates | set the Spherical coordinates (Azimuth,Elevation,Magnitude) of the point
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
SetUpperTolerances | set the 3 upper tolerance values
SetValueUnit | set the value using the specify value ( in the specified units ) without altering the internal units
ShowContextMenu |
ShowHTMLDialog |
ShowPageSetup | method ShowPageSetup
ShowPrintPreview | method ShowPrintPreview
ShowUI |
Sight |
SimulateProbePath | Start the asynchronous simulation of the probe path.
Sleep | Suspends the execution of the current thread while continuing to service the Windows message queue.
splitText | split the text node into two text nodes at the position specified
startElement | Starts a new element in the structure
StartPointStreamTransaction | Starts a transaction and creates an object to receive the contact points as a stream. Only usable by C++ clients.
StartProbeBuilder | Start building a new probe
StartQueue |
StartTransaction | creates a start point which we can rollback to
StartTransaction | method StartTransaction
Statistics | not yet implemented
StatusChanged | fired when the tool changer status has changed
Stop | cancel any pending action. current step is completed
Stop | method Stop
Stop | stop the simulator
StopTransaction | method StopTransaction
substringData | retrieve substring of value
Suspend | Cancel any pending action. Current step is completed.
Suspend | method Suspend
SynchroniseDatabase | Copy all the tools from the source into the destination, avoiding duplicates. Copied tools will be uncalibrated in the destination.
SynchroniseProbeHead | this method check that the correctnesss Head parameter and insert a element if necessary
TakeManualPoint |
TakeOwnership | take ownership of this document, ( note : you must have enough privileged to set the Owner SID
TakeStaticPoint |
tm_getConfig | method tm_getConfig
tm_getConfigLocation | method tm_getConfigLocation
tm_getParameters | Returns the available collection of id's as an XML document
tm_getStyles | method tm_getStyle
tm_getTemplate | method tm_getTemplate
tm_getTemplateNoCache | returns a template as it is stored
tm_init | method tm_init
tm_locate_file | method tm_locate_file
tm_saveTemplate | Saves the provided template with the provided name
ToolChanged | method ProbeHeadActiveToolChanged
TouchPoint | method TouchPoint
TrackingPoint | method TrackingPoint
TransactionChanged | Fired by the protocol when it has been informed that a transaction has started or stopped
TransactionEnded | fired when a transaction is committed or rolled back
TransactionStarted | fired when we start a transaction
TransferParameters | TransferParameters : set all parameters to their values when defined in refParemeters
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
TransformFrom |
TransformFrom |
TransformFrom | Transformation of point
TransformFrom | Transformation of points
TransformFrom | Apply the transformation to the machine-transform.
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.
TransformTo |
TransformTo |
TransformTo | Transformation of point
TransformTo | Transformation of points
TransformTo | Apply the inverse transformation to the machine-transform.
TranslateAccelerator |
TranslateUrl |
Uncompensate | get the compemsate coordinates according the active sensor
Uncompensate | Undo the effect of the probe offset compensation on the give coordinates according the current active tip
Uncompensate | Undo the effect of the probe offset compensation on the give coordinates according to this tip
UncompensatePoint | Undoes any process implicitly done by the protocol to a point
UnCompensatePointV | Undoes any process implicitly done by the protocol to a point
Unify | make this vector a unit vector
UNITTYPE |
UnlockCNCControl | Unlocks this object's control of the protocol object for use by other controllers.
UnlockEdit |
UnlockUnit | Remove existing unit lock, if any from the object.
UnpackParameter | Unpack a CMMParameter Packed string
UnpackPointParameter | Unpack the point XYZ values held in strParam (packed using GetPackedStringPoint)
UnpackPointParameterV | Unpack the point XYZ values held in strParam (packed using GetPackedStringPoint)
UnpackTransformParameter | Unpack Transform element from strParam (packed using GetPackedStringTransform()) into transform.
UnpackVectorParameter | Unpack the vector IJK values held in strParam (packed using GetPackedStringVector)
UnpackVectorParameterV | Unpack the vector IJK values held in strParam (packed using GetPackedStringVector)
UnsetProjectionData | method UnsetProjectionData
UnsetProjectionData | method UnsetProjectionData
UpdateProbePath | request the recalculation of the probepath from the strategy object
UpdateUI |
UpdateWithBox | update the box with a other box
UpdateWithPoint | update the box with a point
Validate | Validates the sequence tree of the document against the given helper source (CXM file)
ValidateActiveItem | Validate some or all sequence items, depending on the type of the active item.
ValidateAllItems | Validate all sequence items in the marked range.
ValidateMarkedRange | Validate all sequence items in the marked range.
ValidationResult | Returns the problems found during the last validation
VBTypeStr | retrieve the VBType String
VirtualCommand | method VirtualCommand
VirtualCommandCalibration | method VirtualCommandCalibration
Write | Writes a property to the open registry key.
WriteObjectAsBinaryStream | Writes an object as a binary stream to the open registry key.
XMLOutput | Get probe path in XML format
XMLOutput | XMLOutput
XMLOutput | Get CMMParameter path in XML format
Name | Description
_ID | INTERNAL USE ONLY
A |
A | retrieve the A angle of the vector (angle in the XY plane)
A | retrieve the A parameter, this parameter describes the valid range and increment for the A angle
A | retrieves the A angle for which this tip is defined
AboveToleranceCount | retrieve the number of points above the higher tolerance bound
AbsolutePosition | property AbsolutePosition: returns/sets the absolute coordinates of the targeted position of the probe center.Note setting the absolute position doesn;t aloter the CoordType property
AcceptPoints | return TRUE if this element can be probed and thus can accept CMMPoints
ActionControl | returns the button that has just been pressed
Active | Whether the CAD level is active for projection.
ActiveDocument | set/get the currently active document
ActiveFeatureVisibility | sets/get the active item visibilty mode
ActiveGroup | set/retrieve the current active Group Item in the current active Tree( Nothing means top level)
ActiveItem | Returns the current active Sequence Item in the current active Tree
ActiveItem | set/retrieve the current active Sequence Item in the current active Tree
ActiveMeasure | Returns the current active Measure in the current active Tree
ActiveMeasure | set/retrieve the current active Measure in the current active Tree
ActivePositioningMatrix | property ActivePositioningMatrix
ActiveSensor | sets/retrieves the active probe sensor
ActiveSensor | sets/retrieves the active sensor,if necessary a probe tool change will happen, the active tip is not guaranty to be correctly set at the end
ActiveSensorName | returns the name of the current active sensor
ActiveSensorType | returns the type of the current active sensor
ActiveTip | sets/retrieves the active probe tip,ProbeTip could be a FULLQUALIFIED name for the type, in this case a probe tool operation may be executed.
ActiveTip | sets/retrieves the current active probe tip, setting the active probe tip may invoke a probe change and a move of the physical device
ActiveTool | sets/retrieves the active probe tool,ProbeTool could be a 0-based index , a string representing the name of the tool or a pointer to a tool, in this case, the tool must belong to the collection
ActiveWorkplane | sets/get the current active plane
AddInType |
Address | The address of this axis
AddToTaskBarMenu | Whether to add this command to the task bar icon context menu
AddToToolbar | Whether to add this command to the user interface extension toolbar
Admin | Internal use only, retrieve the CalibrationAdministration Object
AHingeOffset | returns the offet of the A Hinge point relative to the origin of the probe head local datum( when A=0,B=0)
AlignmentDatum |
AllowMultipleExecution |
AllowTX | set/retrieve whether the best-fit is allowed to translate in X ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)
AllowTY | set/retrieve whether the best-fit is allowed to translate in Y ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)
AllowTZ | set/retrieve whether the best-fit is allowed to translate in Z ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)
Angle | The maximum angle between the 2 segments between the last 3 points.
Angle | The maximum expected angle between the nominal line and the actual line.
Angle | get the Angle of the point ( First Polar Coordinate)
AngleRange | Return the desired range for reporting the angle
AnglesAreTrusted | Retrieves whether the current A,B angle can be trusted. Can be False for probe heads that do not return the actual value until it has been changed.
AngleToScan | The angle to scan.
AngularVelocity | Retrieves/sets the angular feedrate of the probe head (in deg/sec) for animation (when Anmination = cmms_ANIMATED)
Animation | Set/retreive the animation mode
Apex | returns the Apex point of the cone
Appearance |
Application |
Application | property Application
Application | returns the application object
ApproachVector | property ApproachVector
Arc1 | return the first arc, readOnly
Arc2 | return the second arc, readOnly
assemblyDefinition | retrieves/sets the Assembly definition XML string
async | flag for asynchronous download
AtNominals | VARIANT_TRUE if the arguments Distance and Angle are ignored.
attributes | the collection of the node's attributes
AutoLoad | property AutoLoad : True if the OLE object is automatically loaded when the document that contains it is opened. Read/write Boolean.
AutoRepeatInterval | AutoRepeatInterval : number of millisecond between two points capture in rigid scanning
AutoSize |
AutoTrimmingEnabled |
AverageMinimumZoneEntity | return the Least Square entity
axis |
AxisByAddress | Get the axis with the given address.
AxisByIndex | Get the axis at the given index.
Azimuth | retrieve the Azimuth angle of the vector
Azimuth | get the Azimuth of the point ( First Spherical Coordinate)
B |
B | retrieve the B angle of the vector (angle in the YZ plane)
B | retrieve the B parameter, this parameter describes the valid range and increment for the B angle
B | retrieves the B angle for which this tip is defined
BackfaceColor | sets/retrieves flag indicating the back-facing color is on
BackOffBehaviour | Retrieve the backoff behavior of the CMM.
baseName | the base name of the node (nodename with the prefix stripped off)
BeginGroup | property BeginGroup
Behavior | set/retrieve the editor behavior
BelowToleranceCount | retrieve the number of points below the lower tolerance bound
BestFitMethod | set/retrieve the bestfit method
BestFitMethodString | retrieve the bestfit method as a human readable localised string.
BitMap | Get a pointer to the CBitmap for this command
BootstrapPosition | BootstrapPosition: define the bootstrap aligment defined for this file
BottomBase |
Boundary | not yet implemented
BoundingBox | returns the Bounded Box of all the CAD file in the collection
BoundingBox | returns the Bounded Box of the CAD file
BuildNumber | returns the PowerINSPECT current BuildNumber
BuiltIn | property BuiltIn
BUSY |
Busy | property Busy
BUSY | Return the busy flag.
C |
C | retrieve the C angle of the vector (angle in the ZX plane)
CADBoundingBox | Allows to get/set the CAD bounding box, it is used in the FromPoint coordinates calculation
CalculusMethod | Calculus Method : describe the method used for the calculation
CalibratedDiameter | returns the calibrated diameter in mm
CalibratedLength | returns/sets the calibrated length of the sensor which is the length of its stem as process during the calibration phase
Calibration | retrieves the calibration object
CalibrationMode | Calibration Mode
CallBackObject | Set the call back object
CanContainCNCProbePath | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CanPlaySound | Can play a sound on the DCE Device
Caption | property Caption
Carriage | Carriage
Carriage | retrieves the carriage on which this datum sphere is fitted
Carriage | returns the carriage on which this ToolChanger is based
Carriage | returns the parent carriage
Carriage | returns the parent ICarriage
CatalogueXMLPath | returns the path where all XML components related files are stored
Category | Get the current category name
CenterPoint |
Centre |
Centre | The nominal centre point of the circle.
Centre | The nominal centre point of the helix.
ChangeSilently | Returns TRUE if the changer is in Silent mode. Silent means No message boxes or prompts are used during ctool changes.
Checked | The user interface extension command's checked state
childNodes | the collection of the node's children
Class |
Closed | Whether the contour is closed.
CMM2UserTransformation | CMM2UserTransformation
CMMConfigurationPath | returns the path where all CMM Kinematics and related files are stored
CMMDatum | Returns the CMM Datum item
CMMDriver | Retrieves the CMMDriver object which is hosted in the PowerINSPECT application
CMMPosition | R/O retrieve the current position of the CMM.
CMMProtocol | calling this function will also set the carriage, you may want to use CMMProtocol or Carriage at your convenience but only call one of them
CMMProtocol | CMMProtocol object to collect tracking points from
CMMProtocol | get the protocol
CMMProtocol | set the protocol
CMMProtocol | the CMMProtocol being managed by this object
CMMProtocol | The protocol object being controlled by this object.
CMMProtocol | CMMProtocol object to collect tracking points from
CMMTYPE | gets the technology of the CMM
CMMVisible | Show/Hide the CMM
CNCControllingObjectHasLock | Whether a CNC controlling object currently has a CNC lock on this object.
CNCProbePath | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | returns the CNC Probing strategy object associated with this item
CNCProtocolRunningAsManual | True when the protocol is CNC but is operating as manual due to absence of CNC licence.
CNCSTATUS | property CNCStatus
CollisionChecking | Returns true if the joystick move (i.e MoveProbe) performs collision checking
Color | The color of the CAD level
CommandBarType | property Type
Comment | Get/Set an arbitrary comment string for an item.
CompensationDir | get the compensation Direction. only valid when PWI_ProbeCompenstionMethod = pcm_ALONG_A_EXPLICIT_DIRECTION
CompensationMethod | sets/retrieves the CompensationMethod type
CompositeOffsetType | return the type of point
ConfettiSize | sets/retrieves the confetti size
config_location | property config_location
Configurable | Allows to check if this reader is configuirable
Configuration | retreives/sets the Carriage configuration
Configurator | retrieves the Configurator Object
Connected | proterty Connected
connection | sets/returns the connection on which this sensor is fitted on the probe tool
ContactPoint | the coordinates of the point of the probe that touch the actual surface
ContactPoint | the coordinates of the probe point in contact with the actual surface
ContainsMachineConfiguration | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
ContainsMultiaxisConfiguration | Does the probe-path contain machine configurations?
ControlsEndOfItem | method ControlsEndOfItem
ControlsEndOfItem | property ControlsEndOfItem
ControlType |
CoordinateSystem | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
CoordinateType | prefered coordinate system
CoordinateType | Prefered coordinate system
CoordinateType | prefered coordinate type ( cartesian, polar, spherical
CoordinateType | Prefered coordinate type
CoordType | property CoordType
CoordType | retreive the coordinate format
CoordType | Retrieves/sets the recording mode for new coordinates
Count |
Count | Indicates the number of items in the collection.
Count | indicates the number selected vertex
Count | property Count: returns the number of point in the point cloud
Count | property Count
Count | returns the number of add-in in the collection
Count | returns the number of elements in the collection
Count | returns the number of items in the collection.
Count | Returns the number of objects in the collection
Count | The number of axes.
Count | The number of fault items.
Count | The number of items in the collection.
Count | The number of scan-items
Count | Indicates the number of items in the collection.
Count | Indicates the number of parameter under this category
Count | Indicates the number of categories in the categorie collection
Counter |
CPPParameters | property CPPParameters
CPPType |
CPPTypeStr |
CurrentMeasure | property CurrentMeasure
CurrentPosition | method CurrentPosition : return a read/only point that describe the current position
CurrentProbePathItem |
CurrentSequenceItem |
cursor |
cursor | property Cursor
CurStep |
CurStepStatus |
CurveID |
CustomAction | set/returns the macro to execute when this element is played
CustomData |
D |
data | the data
data | value of the node
dataType | the data type of the node
DatumA |
DatumB |
DatumC |
DatumSphere | sets/retrieves the active Datum Sphere used to calibrate sensor on this carriage
Debug | Retrieve the debugging mode
Definition |
definition | pointer to the definition of the node in the DTD or schema
DefinitionDatumItem | request the SequenceItem which represents the datum on which this element is defined
DefinitionType | sets/returns the item defition type
DelayInspection | Returns the state of the DelayInspection Flag
DelayNotifications |
DeltaTransform | the Delta Transformation
Description |
Description | return a description of the feature in the current locale language
Description | return a description of the parameter in the current locale language
Description | Description of the parameter
DescriptionText | property DescriptionText
Deviation | Deviation : retrieve the signed deviation of the specified point
Deviation | property Deviation
Deviation | the deviation
Deviation | The maximum expected bias of measured data from the nominal data in the direction of the nominal direction vector.
Deviation | the true length deviation
DeviationVector | the deviation vector
DeviceRepositionner | returns thedevice repositionner object - of type IRePosition
DHTMLBridge | property DHTMLBridge
Diameter |
Diameter | Actual Diameter as calibrated ( in milimeters )
Diameter | property Diameter : set/retrieve the associated probe diameter
Diameter | retrieve the diameter in MM
Diameter | returns the parameter that describes the manufactured probe diameter
DiameterUnit | Get the current value in the prefered unit
Direction |
Direction | Direction of the probe shaft when this tip is active ( from tip along the shaft direction : i.e for a vertical probe, this will be 0,0,+1)
Direction | targetting direction
DirVector |
Displacement | The maximum expected distance between the nominal circle center and the actual circle center.
DisplayTooltips | property DisplayTooltips
distance | retuns distance between a projected target and a measured point
Distance | returns the absolute ( >0 ) distance from the point to the entity
distance | The maximum distance between 2 returned points.
DMIS | DMIS
doctype | node corresponding to the DOCTYPE
Document | property Document
Document | property PowerINSPECT Document
Document | returns the associated document for this item
Documentation | property Documentation
documentElement | the root of the tree
documentElement | the root of the tree
DropDownHeight | property DropDownHeight
DropDownWidth | property DropDownWidth
DynamicPointType | get the type of this dynamic point
EdgeID |
EdgeNormal |
EdgeOffset |
EdgeOffset | set/get the edge offset
EdgePoint | the information on the projected point
EdgePointHighTol | sets/retrieves the default tolerance for edge points
EdgePointLowTol | sets/retrieves the default tolerance for edge points
EdgePointOffset | sets/retrieves the default offset for edge points
EdgePointProximityCriteria | sets/retrieves the default proximity criteria for edge Point
EdgeType |
Editing | Retrieve the editing mode
Editing | Set/Retrieve the editing mode
Elevation | retrieve the Elevation angle coordinate of the vector
Elevation | get the Elevation of the point ( Second Spherical Coordinate)
EmergencyStop | set/retreive the state of the Manual Emmergency stop button
Enable |
Enabled |
Enabled | property Enabled
Enabled | The user interface extension command's enabled state
EnableModeless |
End | The end point of the fault segment.
EndAngle | set/retrieve the end angle in degree
EndAngle | sets/retrieves the end angle in degree
EndParam |
EndPoint |
EndPoint | The end point of the line.
Entity | extract the entity for the feature
Entity | return the entity matching type
EntityType | return/set the type of the entity
error_str | property error_str
Error | return the actual measured error for the given measure
Error | return the measured error ( also called deviation ) for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
errorCode | the error code
ErrorMap | Object used by protocol to perform error map compensation on point co-ordinates
ErrorMap | Object used by protocol to perform error map compensation on point co-ordinates
ErrorMappingType | The type of error mapping support this protocol is capable of
Evaluator |
EX | Euler Angle X in radian
ExcelTemplateName |
ExplicitDefinition |
Extra | Extra
EY | Euler Angle Y in radian
EZ | Euler Angle Z in radian
FaceId | method Id: returns the Face ID of the button ( the look of the button )
FailureCount | retrieve the number of failures
FaultType | The probe-path fault-type.
Feature | put the Feature attached to this link
Feature | set/retrieve the constrained feature
FeatureApex |
FeatureArc |
FeatureAxis |
FeatureAxisX |
FeatureAxisY |
FeatureAxisZ |
FeatureCentre |
FeatureCentre1 |
FeatureCentre2 |
FeatureCone |
FeatureCylinder |
FeatureDatum |
FeatureLicenced | Check if a feature is licenced
FeatureLine |
FeatureMajorAxis |
FeatureMask | return the mask for this link
FeatureMinorAxis |
FeatureNormalVector |
FeatureOrigin |
FeaturePlane |
FeaturePlaneXY |
FeaturePlaneXZ |
FeaturePlaneYZ |
FeaturePoint |
FeaturePolygon |
FeatureProbeCenter |
FeatureRectangle |
FeatureRoundedSlot |
FeatureSphere |
FeatureTorus |
FeatureType | property FeatureType : Get the type of this Feature
FeatureVector |
Feedrate | Retrieves/sets the feedrate (in mm/sec) for animation (when Anmination = cmms_ANIMATED)
filename | filename
Filename | property Filename
Filename | The current file where this database is store
filepos | the absolute file position in the XML document containing the error
Filter | set/retrieve the filter type / pwicetUNSPECIFIED if no filter
FindCompatibleFeaturePlanesTolerance | Allows to set/get tolerance for searching compatible planes
Fire | Property Fire
firstChild | first child of the node
FirstRangeMarker | Sets/retrieves the first sequence tree sub-range marker.
FittingType | Get/set the fitting type (which tolerances are used)
FittingTypeString | Get a text description of the fitting type
FixedLine | Returns the reference line used for the rotational axis.
FixedPlaneAxis | returns Fixed Axis definition , ( only valid if BestFitMethod = BST_2D_BESTFIT)
fixedPoint | Fixed Point , ( only valid if BestFitMethod = BST_ROTATION_ONLY
ForceManualCalibration | Whether a manual calibration shall be performed in place of CNC calibration
Form | The maximum expected form deviation of the Gauss calculated circle.
Form | The maximum expected form deviation of the Gauss calculated line.
From |
FromPoint | Allows to get/set the starting point coordinates (so called From Point)
FullName | retrieves the full name of this object ( this includes the identifiers of the owner object
FullPathName |
FullPathname | property FullPathname
Fullscreen | Returns or sets the fullscreen Mode state
FuncFlags | property FuncFlags a combinaison of FUNCFLAGS values
FuncKind | property FUNCKIND
GDIHandlesInUse | Retrieve the number of GDI handles in use in the PI process.
GDTType |
GridMode | sets/retrieves the grid mode of the active view
Group | return the group which own this element or nothing
GUIDAsString | property GUIDAsString
HalfAngle | set/retrieve the half angle in degree
Handle | return the handle of this item
Handle | return the internal handle of this link
HasCNCControlLock | Whether this object has a CNC controlling lock.
HasFailed | returns is the point failed
HasProjectedInfo | property HasProjectedInfo: returns TRUE if this objects contains some information about deviation associated with the points
HasValidIJK | property HasValidIJK: returns true if the point cloud contains valid IJK vectors in its original set
HasValidProjection | property HasValidProjection
HeadClearance | Sets/gets the head clearance used for collision-checking
Header | Set/Get the text of the control header
HeadTransform | The transform that maps the machine datum onto the head datum (in world coordinates).
Height |
Height | Returns or sets the size of the specified object, in points. ( 1 point = 1/72 inch)
Height | get the Height of the point ( Third Polar Coordinate)
HelpContext | property HelpContext
HelperInfoSource | property HelperInfoSource
HelperSource | property HelperSource
HelpFile | property HelpFile
hInstance | Retrieves the handle of the PowerINSPECT hInstance
hKey | The handle to the open registry key. THIS PROPERTY SHOULD BE USED WITH CARE!
Homed | proterty Homed : return true if the DEVICE has been homed or initialised
HomeOrientation | Get the home orientation of the machine.
HTMLReportTemplateName | Sets/gets the location of the current HTML Report template
hWnd | Retrieves the handle of the Main PowerINSPECT window
I | retrieve the I coordinate of the vector
id |
Id | method Id: returns the command ID of the button
ID | property ID : Get the ID of this Feature
ID | property ID
ID | sets the internal id of the object that identifies this item unicaly
IdentityCard | retrieves the identity card for the item
IgnoreMissingContactPoints | Sets/gets whether the collision-checker ignores missing contact points
implementation | info on this DOM implementation
ImplicitDefinition |
ImportEnabled | Allows to enable/disable the import controls
Importer | property Importer
Increment | increment or 0 if all values possible
Index |
Index | get the current index of the item within its parent container
Index | Index of the CAD level.
Index | Index of the CAD object.
Index | index of the constraint
Index | Index
Index | property Index : returns the index of this elements in the collection ( start at 1 )
Index | property Index
index | returns the 0-based index of this object within the parent collection. this correspond to the index of the connector on which this element is connected to
index | returns the 0-based index of this object within the parent collection
Index | Returns the index number of the object within the collection of similar objects. Read-only Long.
index | returns the index of this object within the parent collection
Index | returns the index of this property in its parent collection
Index | The index of this axis relative to the list of axes in the IMachineOrientationData parent.
Index | The index of this item relative to the list of faults in the IProbePathFaults parent.
InfoString | Get the displayable info string of the coordinate specified by the index
initialized | property initialized
InputFile | property InputFile
InputSource | property InputSource
InterfaceType |
InterfaceType | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
InTransaction | Returns whether the protocol is currently in a measurement transaction. Note that the result returned is also affected by changes to the CalibrationMode property.
Inverse | method InverseMatrix
InvocationKind |
IsBuiltIn | returns whether the measure is a built-in measure - these cannot be deleted
IsCompleted | Returns TRUE if the item has all points for PowerINSPECT sequence item or the last portion of points. FALSE otherwise.
isDMIS | Is this parameter a DMIS Parameter
IsEditLocked |
IsReadOnly | Return true if this collection is read-only and cannot be modified.
IsReadOnly | returns TRUE if the collection is a readonly collection
IsReportReady | property IsReportReady
IsSimulated | returns whether the measure is the automatic simulated measure
IsTemporary | returns TRUE if the tip is a temporary position, a temporary position is not persisted and is removed once the tip is not active anymore
IsUIAccessible | Get the current IsUIAccessible flag
IsUnitLocked | Test whethee the units are currently locked.
IsValid |
IsValid | returns TRUE if the box is valid
IsVCARDRegistered | returns T_TRUE if the VCARD is already known by the reconcilator
Item | Allows random access to individual CADFile within the collection. Index can be an ordinal from 1 to Count or a string
item | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string
Item | Allows random access to individual document within the collection. Index can be an ordinal from 1 to Count or a string
Item | Allows random access to individual feature within the collection. Index can be an ordinal from 1 to Count or a string
Item | Allows random access to individual Link within the collection. Index can be an ordinal from 1 to Count or a string
Item | Allows random access to individual offsetPoint within the collection. Index can be an ordinal from 1 to Count or a string
Item | Allows random access to individual parameter within the collection. Index can be an ordinal from 1 to Count or a string
Item | Allows random access to individual property within the collection. Index can be an ordinal from 1 to Count or a string
Item | Allows random access to individual ReportVariable within the collection. Index can be an ordinal from 1 to Count or a string
Item | Allows random access to individual SequenceItem within the collection. Index can be an ordinal from 1 to Count or a string
Item | Allows random access to individual Vertex within the collection. Index can be an ordinal from 1 to Count or a string
Item |
Item | Allows random access to individual CAD levels within the collection. Index can be an ordinal from 1 to Count, or a string.
Item | Allows random access to individual CAD objects within the collection. Index can be an ordinal from 1 to Count, or a string.
Item | allows random access to individual measure within the collection. Index can be an ordinal from 1 to Count or a string
Item | Allows random access to individual points. Index can be an ordinal from 1 to Count or a string
item | collection of nodes
Item | Get the fault-item at the given index.
Item | Get the scan-item at the given index
Item | property Item
Item | Returns a specific object in the collection
Item | returns the item at index ( zero based or progID)
Item | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count -1 or a string
Item | Allows random access to individual Parameter within the collection. Index can be an ordinal from 0 to Count -1 or a string being a name of a parameter
ItemID |
ItemType |
ItemType | ItemType
ItemType | return the type of the element ( could be one constant from
IteratorType | Put/Get iterator type as a combination of IteratorType types
J | retrieve the J coordinate of the vector
JOBSTATUS |
JunctionOffset | retreives the position of the junction point of this tool relative to the probe Head center point the local Probe Head co-ordinate system
K | retrieve the K coordinate of the vector
KeyOpen | True if the object has an open registry key.
KinematicsMethod | The kinematic method that users of this object should use
Label |
LargeButtons | property LargeButtons
LastCalibrationDate | returns the date when the last calibration has been performed
lastChild | first child of the node
LastCNCErrorDescription | property LastCNCErrorDescription
LastRangeMarker | Sets/retrieves the last sequence tree sub-range marker.
LastScriptError | Returns a description of the last error found in a script
LCID | retrieve the current LCID
Lead | The lead in mm per 360 degrees rotation.
LeastSquareEntity | return the Least Square entity
Left | Returns or sets the position of the specified object, in points. ( 1 point = 1/72 inch)
Length |
length | number of characters in value
length | number of nodes in the collection
length | property length
length | returns/sets the length description of the sensor which is the length of its stem as provided by the manufacturer
LimitInX | set/retrieve if the boundary limits along the X direction
LimitInY | set/retrieve if the boundary limits along the Y direction
LimitInZ | set/retrieve if the boundary limits along the Z direction
line | the line number in the XML document where the error occurred
linepos | the character position in the line containing the error
Link | get the link or NULL if the type is not appropriate
Link | gets the link. only valid when PWI_ProbeCompenstionMethod = pcm_ALONG_A_EXISITING_DIRECTION
LinkedAlignment | Returns an alignment item that was corrected with this best fit.
LinkGroups | returns the collections of linked groups
Links2 |
Links3 |
LinkType | return the type of the link (Simple/Multiple)
ListCount | property ListCount
ListIndex | property ListIndex: returns or set the index of the selected iten in the list (0 means none,1 means the first etc...
Loaded |
LocalCoordinateSystem | sets/retreieves the local coordinate system
LocalDatum |
LocalDatum | LocalDatum: define the transformation matrix defined for this file
LocalDatum | returns a local datum
LocalDatum | returns the nominal local of the rack in CMM coordinate
Locale | Set the locale used by PowerINSPECT. No documents must be opened. locale can be a string following the ISO standard or a LCID
LocaleID | property LocaleID
LocalisedValue | Returns value as localised string.
Location | Location of the probe sensor active point(tip) relative to the probe head origin on the local probe head coordinates system
LockDirection | set/retrieve the lock state for plane /axis
LockPlaneTranslation | set/retrieve whether the best-fit is allowed to translate along the axis of the 2D Bestfit ( only valid if BestFitMethod = pwibst_BST_2D_BESTFIT)
LockX | set/retrieve the X coordinate lock state
LockY | set/retrieve the Y coordinate lock state
LockZ | set/retrieve the Z coordinate lock state
LowerRange | minimum authorized value
LowerTol | get the lower tolerance for this property
LowerTol | get the Lower Tolerance value for the specified coordinate ( index = 0,1 or 2)
LowerTolerance |
LowerTolerance | Get/set the lower tolerance for fitting
LowerTolerance | retrieve the Lower Tolerance
LowerTolerance | set/get the lower tolerance
MachineConfiguration | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MachineConfigurationCreatorType | The type of object that created this item.
MachineOrientation | Get the current machine orientation data for the machine being used in the simulator.
MachineOrientation | Get the current machine orientation.
MachineOrientation | The machine orientation of this item.
MachineOrientationSet | Has the machine orientation been set?
MachineTransform | The transform that maps the table datum onto the head datum (in CAD or CMM probe-centre coordinates only).
MachineTransformCoordinateSystem | The coordinate system that the machine transform is in (CAD or CMM probe-centre coordinates only).
MagicNumber |
Magnitude | get the Magnitude of the vector ( Third Spherical Coordinate)
Magnitude | get the Magnitude of the point ( Third Spherical Coordinate)
MainPlane |
MaintainCameraPosition | Retrieves the camera position being maintained during simulation.
MajorAxis |
MajorDiameter |
MajorRadius |
MajorVersion | property MajorVersion
MajorVersion | returns the PowerINSPECT Major Version
ManualCalibAutoDismiss | Whether the manual calibration dialog automatically dismisses itself when the specified number of points have been taken
ManualOnly | Determines whether the probe head position can be driven by a protocol
MaterialCondition |
MaterialSide |
matrix | Return a pointer to the internal matrix definition object.
MaxConstraint | The maximum axis value allowed.
MaxDeviation | retreives the maximum deviation found with the provides CMMpoints
MaxDeviationPointIndex | retreives the index of the point with the maximum deviation found
MaximumDeviation | property MaximumDeviation
MaximumDeviation | retrieve the Maximum Deviation
MaximumInscribedEntity | return the Least Square entity
MaximumMultipointMovePoints | MaximumMultipointMovePoints
MaximumTimeout | Configures maximum time for report creation, milliseconds
MaximumValue | returns maximum value in the serie
MaxIteration | set/retrieve the number of iterations maximum allowed for this bestfit
MaxPoint | property MaxPoint
MaxPoint | R/W returns the Max Point of the carriage volume
MaxPoint | Returns the max point of the box
MaxPoint | the max point of the boundary box
maxValue | get the maximum allowed deviation
Mean | retrieve the Mean Error
MeanError | retrieve the mean of error
measure |
measure | property Measure
Measured | return the actual measured value for the given measure
Measured | return the measured value for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Measured | set the actual measured deviation
MeasureDate | returns the last date this elements has been defined for the specified measure
MeasuredCMMPoint | property MeasuredPoint
MeasuredCoord | get the measured coordinates for the given measure
MeasurementState |
MeasureState | returns the measurement state / see also ResultValid
MeasureState | returns the measurement state
Memberid | Returns memid.
MinConstraint | The minimum axis value allowed.
MinimumCircumscribedEntity | return the Least Square entity
MinimumDeviation | property MinimumDeviation
MinimumDeviation | retrieve the Minimum Deviation
MinimumNumberOfPoints | Minimum number of points to make the measurement valid
MinimumValue | returns minimum value in the serie
MinorAxis |
MinorDiameter |
MinorRadius |
MinorVersion | property MinorVersion
MinorVersion | returns the PowerINSPECT MinorVersion
MinPoint | property MinPoint
MinPoint | R/W returns the Min Point of the carriage volume
MinPoint | Returns the min point of the box
MinPoint | the min point of the boundary box
MinRadiusOfCurvature | The prognostic minimum radius in the curve to measure. Only values greater zero are allowed.
MNTLEN |
Mode |
Mode | set/retrieve the geometry explorer mode
Mode | sets/retrieves the probe path editor mode
ModelShadingMode | sets/gets the current model shading mode
Mounting | Mounting - returns the mounting type technology ( m8 , Autojoint etc...)
MTDMachineName | The machine name (from MTD file) used to create any forward kinematics.
MultiplyTransform | multiply 2 matrix
Name |
name | get name of the attribute
Name | name of a point
Name | Name of the CAD level.
Name | Name of the CAD object.
name | name of the document type (root of the tree)
Name | property Name : return the name of this feature
name | property name
Name | property Name
Name | retrieve the name of the parameter
Name | return the name of the element
Name | return the name of the link
Name | set/get the name of the point
Name | Set/retrieve the name of the Measure object
Name | name of the parameter
Name | property Name
namespaceURI | the URI for the namespace applying to the node
NeedsInputFile | property NeedsInputFile
NextItemName | returns the name that will be given by default to the next created sequence item of the specified type
nextSibling | right sibling of the node
nodeName | name of the node
nodeType | the node's type
nodeTypedValue | get the strongly typed value of the node
nodeTypeString | the type of node in string form
nodeValue | value stored in the node
Nominal | get the nominal value of the property
Nominal | return the nominal value for the specified coordinate ( index = 0,1 or 2)
NominalCoord | get the nominal coordinates
NominalEntity |
NominalEntityFlag | returns the method that this entity is using to be defined from nominals
NominalPositionRelativeToRack | return the position of this slot relative to the Rack Local Coordinate System - Before Calibration - as provided by the manufacturer or defined by the user
NominalTransformation | NominalTransformation: define the nominal transformation defined for this file.
Normal |
Normal | The normal vector of the circle plane.
Normal | The normal vector of the helix plane.
Normal | The surface normal vector.
NormalVector |
NoseType | sets/returns the type of cylindrical probe nose
NumberOfDigits | sets/retrieves the number of digit used to display coordinates or dimension
NumberOfDigitsAngle | sets/retrieves the number of digit used to display angles.
NumberOfDigitsNeutral | sets/retrieves the number of digit used to display neutral values.
NumberOfFailure | retrieve the Number of Point in Failure
NumberOfMachineAxes | Number of machine axes.
NumberOfMeasurableItem |
NumberOfMeasuredItem |
NumberOfPoints | retrieve the Number of entities
NumberOfStep | returns the number of step for whole completion
NumberOfSteps | property NumberOfSteps
NumberOfValue | Get the number of choice ( number of value) for the current coordinate format
NumberPointsCylinder | Number of points to take for cylinder calibration
NumberPointsSphere | Number of points to take for sphere calibration
Object | Returns the OLE Automation object associated with this OLE object. Read-only Object.
ObjectPool |
Offset | property Offset
Offset | return the offset
offset | returns the calibrated offset for this tip
OnAction | property OnAction
ondataavailable | register an ondataavailable event handler
onreadystatechange | register a readystatechange event handler
ontransformnode | register an ontransformnode event handler
origin |
origin | Origin
OuterMaterialDirection |
OuterMaterialDirection | property OuterMaterialDirection
OuterMaterialPoint | OuterMaterialPoint
OutputCoordToReport | return true if the specified coordinate is candidate to be printed in the Excel Report
OutputPoint | Get/Put the type of outputted point coordinates
OutputPointType | Set/Get the output point for the probe path
OutputToReport |
OutputToReport | get/set `output to report` flag
OutputTransform | The transformation that will be applied to all output coordinates
OutputWorkplane | The output workplane
OutputWorkplaneName | The output workplane name
OverRun | return the actual measured overrun for the given measure
OverRun | return the measured OVERUN ( if error is outof tolerance bounds) , for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
OverRun | set the actual measured overrun
ownerDocument | document that contains the node
OwnerSID |
PackedValue | PackValue
ParameterAlternateSolution |
ParameterAngle |
ParameterAxis |
ParameterBasePoint |
ParameterBoundary |
ParameterCentroid |
ParameterCompensationMethod |
ParameterCompositeOffsets |
ParameterDistance |
ParameterEvaluateWithNominal |
ParameterExtrusion |
ParameterFixedPlane |
ParameterGuidedMeasure |
ParameterHeight |
ParameterLength |
ParameterMaterialCondition |
ParameterMaterialSide |
ParameterNewOrigin |
ParameterNumberOfEgdes |
ParameterOffset |
ParameterOrientation |
ParameterPlayWhenMeasured |
ParameterPoint |
ParameterQuadrant |
ParameterQuadrantAz |
ParameterQuadrantEl |
ParameterRadius |
ParameterReferenceAxis |
ParameterReportSettings |
Parameters | Allows to provide an object to the reader where it can save its own data
Parameters | Provides an object to the reader where it can save its own data
ParameterSearchDistance |
ParameterType |
ParameterType | return the Type of the parameter
ParameterType | type of this parameter
ParameterUseUnboundedEntities |
ParameterVector |
Parent |
Parent | indicates the parent of this object : a PowerINSPECT Document
Parent | retrieves the Parent CommandBar
Parent | return ISequence Item that owns this feature
Parent | The parent IMachineOrientationData object.
Parent | The parent IProbePathFaults object
Parent |
ParentFrame | property ParentFrame
parentNode | parent of the node
ParentWindow | Parent Window
parsed | has sub-tree been completely parsed
parseError | get the last parser error
PartName | Allows to get/set the NC program part name
PartName | Set/Get the part name for the outputted path
Path | Retrieves the Path of the PowerINSPECT Executable
PathType |
PCSDatum | Returns the PCS Datum item
PeckerStrategy | returns the Pecker Strategy object
PIXmlDocument | property
PIXmlDocument | property PIXmlDocument
Plane | returns the plane
point |
point | property Point
point | retrieve the point
point | returns the nominal coordinates of the point in the RPS localDatum
Point | returns the point
PointAtParam |
PointCloud |
PointCloud | return the point cloud associated with the given measure, in CMM coordinates
PointerDesc | Returns a TypeInformation object with more information about the VT_USERDEFINED type.
PointType |
PointType | property PointType
Position |
Position | Position of the carriage relative to the first carriage
Position | property Position: returns/sets the position of the probe center at the expected contact point.The position is either as an increment or a absolute position, depending of the CoordType value
Position | retrieves the R/O Position object that describes the position and orientation of the probe head relative to the CMM Zero Point
Position | The position at which the machine orientation should be performed.
PositionalItemType | property Type
PositionalItemType | Retrieves/sets the type of Positional Item that will be next inserted
PositioningMatrixForSimulatedMachine | Get the alignment which maps the PCS (Cad Datum) onto the simulated-machine-datum. Note: Only valid in OMV PRO.
PositioningMatrixForSimulation | Get the alignment which maps the PCS (Cad Datum) onto the Machine Datum.
PositionRelativeToCMM | return the Calibrated position of this slot relative to CMM Coordinate System
PositionRelativeToRack | return the Calibrated position of this slot relative to the Rack Local Coordinate System
PowerInspect | property PowerInspect
PreferedUnit | Get the prefered units
Prefix | Get the displayable prefix of the coordinate specified by the index
prefix | the prefix for the namespace applying to the node
preserveWhiteSpace | indicates whether the parser preserves whitespace
PreTouchIJKMode | PreTouchIJKMode
PreTouchPoint |
PreviousAbsolutePosition | (property PreviousAbsolutePosition, The theorical absolute position of the probe before this move is executed
previousSibling | left sibling of the node
PrimaryToolDirection | The primary tool vector.
ProbeCenter |
ProbeCenter | the coordinates of the probe center in CADCoordinates
ProbeCenter | the coordinates of the probe center
ProbeClearanceVector | the coordinates of the CMM point vector
ProbeClearanceVector | the coordinates of the CMM point vector in CAD Coordinates
ProbeDatabase | Get the probe database for simulation
ProbeDatabase | retrieves the parent probedatabase
ProbeDatabase | The object that allows us to access the probe database and the active sensor
ProbeDatabaseIsInstalled | Determines whether a probe database is currently set. Useful for clients that do not want to invoke the probe database installation through a call to get_ProbeDatabase.
ProbeDiameter |
ProbeDiameter | PropDiameter
ProbeDiameter | property ProbeDiameter
ProbeDiameter | returns the probe diameter
ProbeDiameter | the probe diameter
ProbeHead | sets/retrieves the probeHead
ProbeHeadCatalogue | return the catalogue as a MSXMLDocumentObject
ProbeHeadMountingDirection | R/W returns the direction of the probe head mounting device ( usually Z-)
ProbeHeadType | retrieves the type of this probehead, usufull to identify its technology / OBSOLETE USE TYPE
ProbeHeadVisible | Show/Hide the ProbeHead
ProbeMountingPointDatum | returns the probe mounting point datum relative to the CMM Coordinates system and the CMMZero Point, when the probe head is at its original position ( i.e A=0,B=0 for an indexable probe head
ProbePartCatalogue | Access the ProbePart Catalogue
ProbePath |
ProbePath | returns the parent probe path
ProbePath | sets/retrieves the probe path to edit
ProbePathEditor | returns the probepath editor object
ProbePathItemIndex | The index of the probe-path item that this fault relates to.
ProbePathReplayEngine | ProbePathReplay
ProbePathTeachEngine | ProbePathTeachEngine
ProbePathVerificationMode | Sets/gets the probe path collision-checking mode
ProbePathVisibility | sets/retrieves the current probe path visibility in CAD view.
ProbeReconciliator | sets/retrieves the ProbeReconcilator, which will be used to substitute probes that do not formally exists on the driven system
ProbeSensor | return the parent ProbeSensor
ProbeSensor | sets/retrieves the attached sensor
ProbeStructureBuilder | Get the probe-structure builder used when creating probe-graphics
ProbeTool | retrieves the parent probe tool
ProbeTool | sets/retrieves the current probe tool which is physically mounted on the probe head
ProbeToolClearance | Sets/gets the probe tool clearance used for collision-checking
ProbeToolMountingPoint | returns the probe mounting point relative the probe head local datum ( which has its origin at the hinge point), this is the connection point of a Probe Tool mounted on the probed head
ProbeType | returns the type of this sensor
ProbeVisible | Show/Hide the Probe
ProductType | Return the generic product type
ProgID | property ProgID
ProjectedPoint | property ProjectedPoint
ProjectedVector | property ProjectedVector
PromptForStart | Informs if a user should be prompted for start
Property |
PropertyAngle |
PropertyCentre |
PropertyCircularity |
PropertyConicity |
PropertyCylindricity |
PropertyDirection |
PropertyDistance |
PropertyDistanceOnPlane |
PropertyDistanceToTarget |
PropertyDistanceToTargetPlane |
PropertyExscribedRadius |
PropertyHalfAngle |
PropertyInscribedRadius |
PropertyLength |
PropertyLinearity |
PropertyLocation |
PropertyMajorAxis |
PropertyMajorRadius |
PropertyMinorRadius |
PropertyNormalVector |
PropertyPlanarity |
PropertyPoint |
PropertyProfile |
PropertyRadius |
PropertyRelativePosition |
PropertySphericity |
PropertyTargetPoint |
PropertyType |
PropertyWidth |
Protocol | sets/retrieves the actual protocol object that directly interact with the physical device
Protocol | sets/retrieves the protocol that actually controls this carriage
ProvidesApproachVector |
ProvidesApproachVector | property ProvidesApproachVector
ProvidesProbeDiameter | property ProvidesProbeDiameter
ProvidesProbeDiameter | Return VARIANT_TRUE if the reader is able to provide probe diameter for items, VARIANT_FALSE otherwise.
QueueComplete | A command queue has completed execution.
QueuedCount | Number of commands in queue which have yet to complete execution.
Queuing | Protocol is building a command queue.
QuillMountingPoint | returns the probe head mounting point on the quill relative the probe head local datum ( which has its origin at the hinge point)
Rack | return the parent Rack
RadialDimensionType | change the type of the radial dimension, by preseving the nominal value
Radius |
Radius | get the Radius of the point ( Second Polar Coordinate)
Reader | property Reader
ReadOnly |
ReadOnly | return true if the link cannot be modified
ReadOnly | return true if the parameter cannot be modified
ReadOnly | returns true if the box is read only
ReadOnly | ReadOnly
ReadOnly | ReadOnly
readyState | get the state of the XML document
reason | the cause of the error
ReferenceConic |
ReferenceDatum |
ReferenceDirection |
ReferenceDirection1 |
ReferenceDirection2 |
ReferenceFeature |
ReferenceFeature2D |
ReferenceLine |
ReferenceLine1 |
ReferenceLine2 |
ReferencePlane |
ReferencePlane | Reference Plane
ReferencePlane1 |
ReferencePlane2 |
ReferencePlane3 |
ReferencePoint |
ReferencePoint1 |
ReferencePoint2 |
ReferencePoints |
ReferenceProbeLength | sets/retrieves the reference probe length -> the length of the probe used to do the calibration of the head
ReferenceVector |
RegistryOptionPath | Returns registry subpath of HCKU where used settings of IE are contained
RegistryPath | Retrieve registry path for application
RemoteMouse | Enables/disables remote mouse functionality
ReportCompleted | Property ReportCompleted. To be set by the report composer engine (currently scripting) when a report is completed and ready to use.
ReportConfigName | method ReportConfigName
ReportConfigName | property ReportConfigName
ReportCustomiserEngine | property ReportCustomiserEngine
ReportDocument | property ReportDocument
ReportSettings | retrieves report settings of the document
RequireNewCalibration | retrieves whether or not a new Calibration is requested for this element, before it can be used accuratly
RequiresLicence | Get whether a licence is required to use this object.
resolveExternals | indicates whether the parser resolves references to external DTD/Entities/Schema
Result |
ResultValid | return TRUE if this element is Valid for the given measure
RetracePointAutoCompletionDistance | sets/retrieves the default maximal distance to target allowed for retrace point
RetracePointAutomaticCompletion | sets/retrieves the default option for automatic completion ( the retrace point will be automatically accepted if it is within the RetracePointGuidedDistance criteria
RetracePointCatchmentDistance | sets/retrieves the default catchement distance for retrace points
RetracePointRecordAllPointInCatchementZone | sets/retrieves the default recording option for retrace point
RetryAndContinueMode | set/retrieve the retry and continue mode.
ReturnType | property ReturnType
Reversed | sets/retrieves the reverse flag of the link
Reversible | returns if the link can support reversed features
RichInfo |
RotationAxisA | retrieves the Rotation Axis Vector of the A angle when B=0, in CMM Coordinates
RotationAxisB | retrieves the Rotation Axis Vector of the B angle when A=0, in CMM Coordinates
RowIndex |
SafeDistance | Probe safe distance
SafeDistanceHead | Head safe distance
SafeMoveDirection | Allows to get/set the safe move direction
SafeMoveDistance | Allows to get/set the safe move distance
Saved | True if no changes have been made to the specified document since it was last saved. Read/write Boolean.
ScanInstruction | The scan instruction associated with this object.
ScanInstructionType | The scan item-type.
ScanItemFormat | Get the type of scan-item format stored. The format is set by the first item added.
ScanItemFormat | The scan item format.
ScanlineCount | property ScanlineCount
ScanningMode | retrieve/set the Scanning mode
ScanStart | The point on the circle radius where the scan starts.
ScanStart | The point on the helix radius where the scan starts.
ScriptFileName | The current script file name
ScriptReaderPath | Provides the path of the current reader script
SecondaryToolDirection | The secondary tool vector.
Sensor | retrieve a sensor of this probe by name
SensorMountingDirection | returns the sensor Mounting Direction
SensorMountingPoint | returns the sensor Mounting point
SensorProperty |
SequenceItem | property SequenceItem
SequenceReplayEngine | property SequenceReplayEngine
SequenceReplayEngine | returns a pointer to the SequenceReplayEngine used for the CMM
SequenceSimulatorEngine | returns a pointer to the SequenceReplayEngine used for the simulation
Settings | The general settings for the probe database
ShowText | property ShowText
Simulator | retrieves the CNC simulator object
SmartName | return a smart name for this tip based on the sensor/tool and type of probehead actually used
Source |
specified | indicates whether node is a default value
srcElement | The object that fired the event
srcText | the data where the error occurred
StandardDeviation | retrieve the Standard Deviation
Start | The start point of the fault segment.
StartAngle | set/retrieve the start angle in degree
StartAngle | sets/retrieves the start angle in degree
StartParam |
StartPoint |
StartPoint | The start point of the line.
StatisticAfter | the statistics after the Best-fit have been applied
StatisticBefore | the statistics before the Best-fit have been applied
Statistics | Returns a string containing some animation performance statistics
status |
Status | internal use only: set the calibration state
Status | property Status
Status | retreives the status of the tool changer module
Status | returns the calibration state of this element
Status | returns the current status of the stream
StemDirection |
StemVector | stem vector of the sensor expressed on the local probe head coordinates system
Step |
StepW | The average angular distance between 2 measured points in degrees.
StepW | The average distance between 2 measured points in mms.
StopCriteria | set/retrieve the stop criteria for this bestfit
StrategyType |
Stream | items stream
Style | property Style
SupportRefMarks | Support Reference Marks
SupportScanning | Support Scanning features
SupportsLocalCoordinateSystem | returns true if the entity supports a local coordinate system
SupportsUserCamera | SupportsUserCamera
SupportTracking | The object fully supports tracking points
SuppressBeepOnContact | Suppress protocol default beeping on contact. For clients that will explicitly call PlaySound when processing contact points.
Surface | not yet implemented
Surface | NOT YET IMPLEMENTED
SurfaceAngle | The surface angle of the circle.
SurfaceAngle | The surface angle of the helix (90 and 270 not allowed).
SurfaceGroupType |
SurfaceID | get the id of the surface on which this dynamic point lies
SurfaceName | Name of a surface
SurfaceName | Name of surface
SurfaceNormal |
SurfaceOffset |
SurfaceOffset | set/get the surface offset
SurfacePoint | property SurfacePoint
SurfacePoint | the information on the projected point
SurfacePoint | The surface point in the scanning path.
SurfacePointHighTol | sets/retrieves the default tolerance for surface points
SurfacePointLowTol | sets/retrieves the default tolerance for surface points
SurfacePointOffset | sets/retrieves the default offset for surface points
SurfacePointProximityCriteria | sets/retrieves the default proximity criteria for Surface Point
SurfaceVector | The nominal surface vector at the surface point.
SurfID |
SurfID | targetting surface ID
T | parameter along the curve of the edge
TableTransform | The transform that maps the machine datum onto the table datum (in world coordinates).
TabStop |
Tag |
Tag | Integer defining if the nth nominal point is assumed to be on the part surface (+1) or without contact to the surface (-1).
Tag | property Tag: user defined string that help to find the control
tagName | get the tagName of the element
Target | target point coordinates
target | the target
TargetAxis |
TargetPoint |
templatesManager | Allows to set/get template manager object for this report document
templatesManager | property templatesManager
Text | returns or sets the text in the display or edit portion of the command bar combo box control.
text | text content of the node and subtree
Text | The user interface extension command's text
ThreadID |
TipHeight | returns the information concerning the valid height of the cylinder tip of the sensor
TipOffset | Retrieve the current tip offset, from Quill mounting point to Tip Position.
TipPosition | R/O retrieve the current position of the active sensor tip.
TipShankDirection | Retrieve the current tip shank direction from tip toward the shank.
tm_error_str | property tm_error_str
tm_initialized | property tm_initialized
tm_MaximumTimeout | Configures maximum time for report creation, milliseconds
To |
ToleranceType | Get/set the tolerance type (which tolerances are used)
ToleranceTypeString | Get a text description of the tolerances used for fitting
Toolbox | returns a toolbox in the same context (process and thread ) as the probedatabase
ToolChanger | retrieves/sets the tool changer
ToolChangerType | returns the type of this ToolChanger
ToolMountingPointPosition | R/O retrieve the current position of the tool mounting point.
ToolNumber | Allows to get/set the tool number
ToolNumber | Set/Get the tool number for the outputted path
TooltipText | property TooltipText
ToolTipText | Tooltip text for this command
Top | Returns or sets the position of the specified object, in points. ( 1 point = 1/72 inch)
TopBase |
TrackingFrame | An object that allows the current tracking frame to be retrieved. Only usable by C++ clients.
TrackingInterval | Minimum interval (in ms) at which tracking points are sent
TransactionState | are we currently carrying out a transaction
transform | get the transformation matrix
TriangulationTolerance3D | Get the 3D-triangulation-tolerance
TriangulationToleranceMax3D | Get the maximum 3D-triangulation-tolerance
TrustInitialValues | retrieves/sets if the Indexable Probe Head could trust the A,B values returned by the protocol at connection time
type |
type | Constraint type
Type | Returns a ITypeDesc object that describes the type of constant.
Type | Returns the type as combination of VARENUM.
TypeFlags | Returns TYPEFLAGS
TypeInfo | property TypeInfo
TypeInfoKind | Returns TYPEKIND.
TypeOf |
U |
UIName | User defined (translated) name of the parameter
UniqueID | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UniqueID | returns a unique Identifier (ID) of this Item, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UniqueID | Unique ID of the CAD object.
Unit | Get the unit of the value specified by the index
Units |
units | sets/retrieves the unit of the probe path ( only mm or in or empty string)
units | expected unit for this parameter
UNITTYPE |
UpperRange | maximum authorized value
UpperTol | get the upper tolerance for this property
UpperTol | get the Upper Tolerance value for the specified coordinate ( index = 0,1 or 2)
UpperTolerance |
UpperTolerance | Get/set the upper tolerance for fitting
UpperTolerance | retrieve the Upper Tolerance
UpperTolerance | set/get the upper tolerance
url | get the URL for the loaded XML document
url | the URL of the XML document containing the error
UsableHeight | Returns maximum width of the specified object, in points. ( 1 point = 1/72 inch)
UsableWidth | Returns maximum width of the specified object, in points. ( 1 point = 1/72 inch)
UseActiveOnly | Put/Get using the active item only
UseAxisValue | Is the value for this axis valid?
UseConstraints | Are the constraints for this axis valid?
UseGuidedMeasure |
UseRange | Put/Get controlling the range usage
UserCMMDefinitionPath | returns the path where the user store his own complete CMM Definition
UserDefinedDesc | Returns a TypeInformation object with more information about the VT_USERDEFINED type.
UserHandlesInUse | Retrieve the number of User handles in use in the PI process.
UserName | sets/retrieves the user name of the object, this name could be freely defined by the user
V |
validateOnParse | indicates whether the parser performs validation
ValidMeasure | return TRUE is the held measured is valid
ValidUnits | returns the list of supported units
Value |
value | property value
Value | retrieve the value of the parameter as a VARIANT
Value | Returns value of constant.
Value | string value of the attribute
Value | The axis value.
Value | value of the parameter
ValueArray | Get a array that contains the values
ValueCount | get the total number of items
VBParameters | property VBParameters
VBReturnType | property VBReturnType
VBType |
VBTypeStr |
VCARD | Get the VCARD of the parameter
vector |
vector | property Vector
vector | retrieve the coordinates of the point
vector | retrieves the current orientation of the probe axis in CMM coordinates
vector | returns the point
VerificationStatus | Returns true if the sequence tree contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.
VerificationStatus | The probe-path verification status.
VerificationStatusOfActiveItem | Returns true if the active sequence item contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.
VerificationStatusOfRange | Returns true if the selected range of sequence items contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.
Version | returns the version string
Vertex |
VerticeCount |
Visible |
Visible | property Visible
Visible | return the current state of the visible flag
Visible | Visibility of the CAD level in the active view.
vX | VX
vY | VY
vZ | VZ
WCSNumber | Allows to get/set the Workpiece coordinate system number
WebBrowser | property WebBrowser
Width |
Width | Retrieves/sets the with of the control
Width | Returns or sets the size of the specified object, in points. ( 1 point = 1/72 inch)
WindowState | Returns or sets the main window state
WithinToleranceCount | retrieve the number of points within the tolerance bounds
WorkpieceCoordSystemNumber | Set/Get the Workpiece coordinate system number
WorkPlane |
X | get the X coordinate of the point
xml | Get/Set an report configuration for an item. Must be well-formed XML.
xml | return the XML source for the node and each of its descendants
XVEC |
Y | get the Y coordinate of the point
Z | get the Z coordinate of the point
ZVEC |
Name | Description
_ACTIVATE_SENSOR_RETVAL |
_CMMTYPE |
_CNCSTATUS |
_PROBESENSORTYPE |
_SENSORPROPERTY |
ApplyPackValueOption |
BESTFIT_FITTING_TYPE |
BESTFIT_TOLERANCE_TYPE |
CALIBRATIONSTATE |
ChangeMask |
cmms_ANIMATION |
cmms_AXIS_TYPE |
cmms_BACKOFF |
cmms_CAMERA_POSITION |
cmms_MOVETYPE |
cmms_ROTATEHEADOPTION |
CNCCOMPLETION |
ERROR_MAPPING_TYPE |
FINDPLANE_METHOD |
GDT_DATUM_PLANE |
GDT_ERRORN |
GDT_SUBTYPE |
GDT_TYPE |
GeometryExplorerMode |
geomPoint3DCoordinateType |
geomUnitType |
geomVector3DCoordinateType |
ItemDefinitionType |
IteratorType |
JOBSTATUS |
KinematicMethodType |
LSTSQ_CALCULATION |
LSTSQ_ENTYPE |
LSTSQ_TYPE |
MachineConfigurationCreatorType |
MATERIAL_CONDITION |
MATERIAL_SIDE |
OMVEXmlCutOptions |
OMVImporterError |
OMVImporterStatus |
OMVImportResult |
OMVImportValidationResult |
OMVISequentialStreamStatus |
OutputPointType |
ParameterItemType |
ParameterType |
ParameterType |
PDBOBJECTTYPE |
PLAY_SOUND_TYPE |
PointType |
PROBECOMPONENT_TYPE |
PROBEHEAD_TYPE |
ProbeItemType |
ProbeItemType |
ProbePathEditorBehavior |
ProbePathEditorMode |
ProbePathFaultType |
ProbePathStrategyType |
ProbePathType |
ProbePathType |
ProbePathVerificationStatus |
ProbePositionalCoordType |
ProbePositionalItemType |
PROBESENSORCYLINDER_TYPE |
PRODUCT_FEATURE |
PRODUCT_TYPE |
PSAI_AddInAutoLoadOption |
PSAI_AddInType |
PWI_ACTIVEFEATURE_VISIBILITY |
PWI_AlignmentType |
PWI_AngleValidRange |
PWI_BESTFIT_Method |
PWI_CompositeOffsetType |
PWI_DynamicPointType |
PWI_EdgeType |
PWI_EntityItemType |
PWI_FeatureMask |
PWI_FeatureType |
PWI_GeometricItemType |
PWI_GeometryExplorerEventReason |
PWI_GridMode |
PWI_GroupType |
PWI_LINK_DATUMONEXISTINGFEATURES_ |
PWI_LINK_DATUMROTATE |
PWI_LINK_DATUMROTATETOFEATURE2D |
PWI_LINK_DATUMROTATETOFEATURE3D |
PWI_LINK_DATUMSHIFT |
PWI_LINK_FEAT_CIRCLE_PLANECONIC |
PWI_LINK_FEAT_CIRCLETHROUGHNPOINTS |
PWI_LINK_FEAT_POLYGONE |
PWI_LINK_FEAT_RECTANGLE |
PWI_LINK_FEAT_SLOT |
PWI_LINK_GEOMETRICCIRCLE |
PWI_LINK_LINE_BISSECTOR |
PWI_LINK_LINE_INTER2PLANES |
PWI_LINK_LINE_PARALLELTROUGHPOINT |
PWI_LINK_LINE_PERPENDICULARTROUGHPOINT |
PWI_LINK_LINE_POINTVECTOR |
PWI_LINK_LINE_PROBED |
PWI_LINK_LINE_PROJECTEDONPLANE |
PWI_LINK_LINE_THROUGHPOINTS |
PWI_LINK_LINE_WITHANGLE |
PWI_LINK_LINE_WITHOFFSETPOINT |
PWI_LINK_MEAS_3DANGLE2VECTORS |
PWI_LINK_MEAS_3DANGLEPLANELINE |
PWI_LINK_MEAS_ANGLE2LINES |
PWI_LINK_MEAS_ANGLE2PLANES |
PWI_LINK_MEAS_DISTANCE2POINTS |
PWI_LINK_MEAS_DISTANCEPOINTLINE |
PWI_LINK_MEAS_DISTANCEPOINTPLANE |
PWI_LINK_MEAS_RELATIVEPOSITION |
PWI_LINK_PLANE_BISSECTOR |
PWI_LINK_PLANE_LINEPOINT |
PWI_LINK_PLANE_LINEVECTOR |
PWI_LINK_PLANE_OFFSETDISTANCE |
PWI_LINK_PLANE_PARALLELTHROUGHPOINT |
PWI_LINK_PLANE_POINTVECTOR |
PWI_LINK_POINT_FEATUREINTERSECTION |
PWI_LINK_POINT_INTER2LINES3D |
PWI_LINK_POINT_INTER2LINESPROJECTED |
PWI_LINK_POINT_INTER3PLANES |
PWI_LINK_POINT_INTERPLANELINE |
PWI_LINK_POINT_MIDDLE |
PWI_LINK_POINT_PROJECTEDONLINE |
PWI_LINK_POINT_PROJECTEDONPLANE |
PWI_LinkType |
PWI_MainDirection |
PWI_MainPlane |
PWI_MaterialCondition |
PWI_MaterialSide |
PWI_MeasureState |
PWI_MODEL_SHADING_MODE |
PWI_NominalEntityFlag |
PWI_ParameterEXType |
PWI_ParamType |
PWI_POINTCLOUD_EXPORT_FLAG |
PWI_POINTCLOUD_EXPORT_FORMAT |
PWI_POINTCLOUD_EXPORT_WHAT |
PWI_PointType |
PWI_PROBE_PATH_VISIBILITY |
PWI_ProbeCompenstionMethod |
PWI_PropertyType |
PWI_RadialDimensionType |
PWI_RPSConstraintType |
PWI_RPSDirectionLock |
PWI_SequenceItemInterfaceType |
PWI_SurfaceGroupType |
PWI_SurfacePoint |
PWI_Units |
PWI_WindowState |
PWICADENTITYTYPE |
PWICommandBarButtonStyle |
PWICommandBarPosition |
PWICommandBarType |
PWICommandControlType |
RECONCILIATION_STATUS |
REPLAYPOINTSFLAGS |
ScanInstructionType |
ScanItemFormat |
SOLVER_STATUS |
SRE_MODE |
SRE_STATUS |
status |
STEPSTATUS |
tagCALLCONV |
tagDESCKIND |
tagDOMNodeType | Constants that define a node's type
tagFUNCFLAGS |
tagFUNCKIND |
tagINVOKEKIND |
tagSYSKIND |
tagTYPEFLAGS |
tagTYPEKIND |
tagVARKIND |
TOLERANCE_ZONE |
TOOLCHANGER_TYPE |
TOOLCHANGERSTATUS |
UNCOMPENSATE_TYPE |
UNITTYPE |
ValidMeasureState |
VARENUM |
VirtualCommand |
Name | Description
pwi_alg_PlanLinePoint |
pwi_alg_3Spheres |
pwi_alg_FreeFormFit |
pwi_alg_FromFile |
pwi_alg_FromGeometrics |
pwi_alg_BestfitFromPoints |
pwi_alg_RPS |
pwi_alg_321 |
pwi_ent_NominalPoint |
pwi_ent_NominalVector |
pwi_ent_Plane_Probed |
pwi_ent_Plane_Bissector |
pwi_ent_Plane_ParallelThroughRefPoint |
pwi_ent_Plane_ParallelThroughPoint |
pwi_ent_Plane_Nominal |
pwi_ent_Plane_OffsetDistance |
pwi_ent_Plane_PointVector |
pwi_ent_Plane_WithOffsetPoints |
pwi_ent_Plane_LineVector |
pwi_ent_Plane_LinePoint |
pwi_ent_Line_Probed |
pwi_ent_Line_ThroughPoints |
pwi_ent_Line_ProjectedOnPlane |
pwi_ent_Line_Inter2Planes |
pwi_ent_Line_WithAngle |
pwi_ent_Line_Bissector |
pwi_ent_Line_ParallelTroughPoint |
pwi_ent_Line_PerpendicularTroughPoint |
pwi_ent_Line_WithOffsetPoints |
pwi_ent_Line_PointVector |
pwi_ent_Line_AtAngle |
pwi_ent_Point_ProjectedOnLine |
pwi_ent_Point_Inter2LinesProjected |
pwi_ent_Point_ProjectedOnPlane |
pwi_ent_Point_Middle |
pwi_ent_Point_InterPlaneLine |
pwi_ent_Point_Inter3Planes |
pwi_ent_Point_Inter2Lines3D |
pwi_ent_Point_RetracePoint |
pwi_ent_Point_FeatureIntersection |
pwi_ent_Meas_Angle2Lines |
pwi_ent_Meas_Angle2Planes |
pwi_ent_Meas_3DAngle2Vectors |
pwi_ent_Meas_3DAnglePlaneLine |
pwi_ent_Meas_Distance2Points |
pwi_ent_Meas_DistancePointLine |
pwi_ent_Meas_DistancePointPlane |
pwi_ent_Meas_RelativePosition |
pwi_ent_Feat_Slot |
pwi_ent_Feat_Rectangle |
pwi_ent_Feat_Polygone |
pwi_ent_Feat_CircleThroughNPoints |
pwi_ent_Feat_ProbedCircle |
pwi_ent_Feat_Cylinder |
pwi_ent_Feat_Cone |
pwi_ent_Feat_Sphere |
pwi_ent_Feat_Torus |
pwi_ent_Feat_SinglePointCircle |
pwi_ent_Feat_Circle_PlaneConic |
pwi_ent_Feat_Circle_OnConeAtHeight |
pwi_ent_Feat_Circle_OnConeWithDiameter |
pwi_ent_TruePosition |
pwi_ent_GDT |
pwi_ent_LaserScannedCircle |
pwi_ent_LaserScannedSlot |
pwi_ent_LaserScannedRectangle |
pwi_ent_LaserScannedHexagon |
pwi_ent_LaserScannedCorner |
pwi_ent_LaserScannedPatch |
pwi_ent_LaserScannedGapFlush |
pwi_ent_LaserScannedSphere |
pwi_ent_LaserScannedCylinder |
pwi_ent_LaserScannedSCorner |
pwi_ent_LaserScannedEdge |


ActiveObject

ActiveObject - object

Description

ActiveObject Class

Interfaces

IActiveObject

Methods of IActiveObject

Delete Deletes the object and remove it from it's containing document

Properties of IActiveObject

AutoLoad | R/W | property AutoLoad : True if the OLE object is automatically loaded when the document that contains it is opened. Read/write Boolean.
Index | R/O | Returns the index number of the object within the collection of similar objects. Read-only Long.
Name | R/W | property Name
Object | T/O | Returns the OLE Automation object associated with this OLE object. Read-only Object.
ProgID | R/O | property ProgID


AutoLoad

AutoLoad - Read & Write property

Description

property AutoLoad : True if the OLE object is automatically loaded when the document that contains it is opened. Read/write Boolean.

Syntax in Visual Basic or VBScript

AutoLoad () As Boolean

Syntax in C++

HRESULT get_AutoLoad (VARIANT_BOOL* retVal)
HRESULT put_AutoLoad (VARIANT_BOOL Value)

Applies to

ActiveObject
IAddInInfo


Index

Index - Read property

Description

Returns the index number of the object within the collection of similar objects. Read-only Long.

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

ActiveObject
IAddInInfo


Name

Name - Read & Write property

Description

property Name

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)
HRESULT put_Name (BSTR Value)

Applies to

ActiveObject
CoClass
CommandBar
Constant
Dispinterface
Enum
Function
IHTMLConnector
OffsetPoint
PointCloudPoint
TypeInfo
TypeLibrary
VarDesc


Object

Object - Reference Write property

Description

Returns the OLE Automation object associated with this OLE object. Read-only Object.

Syntax in Visual Basic or VBScript

Object () As Object

Syntax in C++

HRESULT get_Object (IDispatch** retVal)

Applies to

ActiveObject
IAddInInfo


ProgID

ProgID - Read property

Description

property ProgID

Syntax in Visual Basic or VBScript

ProgID () As String

Syntax in C++

HRESULT get_ProgID (BSTR* retVal)

Applies to

ActiveObject
IAddInInfo


Delete

Delete - method

Description

Deletes the object and remove it from it's containing document

Syntax in Visual Basic or VBScript

Delete ()

Syntax in C++

HRESULT Delete ()

Applies to

IAddInInfo


AddInManager

AddInManager - object

Description

AddInManager Class

Events

OnResetUserInterface


OnResetUserInterface

OnResetUserInterface - event

Syntax in Visual Basic or VBScript

OnResetUserInterface ()

Syntax in C++

HRESULT OnResetUserInterface (HRESULT* retVal)

Applies to

AddInManager


AlignmentFreeFormFit

AlignmentFreeFormFit - object

Interfaces

IAlignmentFreeFormFit

Methods of IAlignmentFreeFormFit

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IAlignmentFreeFormFit

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IAlignmentFreeFormFit

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
Results | returns a collection of result points
Targets | returns a collection of target points


AcceptPoints

AcceptPoints - Read property

Description

return TRUE if this element can be probed and thus can accept CMMPoints

Syntax in Visual Basic or VBScript

AcceptPoints () As Boolean

Syntax in C++

HRESULT get_AcceptPoints (VARIANT_BOOL* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


CanContainCNCProbePath

CanContainCNCProbePath - Read property

Description

returns TRUE if this item is a good candidate to own a CNC Probe Path Item

Syntax in Visual Basic or VBScript

CanContainCNCProbePath () As Boolean

Syntax in C++

HRESULT get_CanContainCNCProbePath (VARIANT_BOOL* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


CNCProbePath

CNCProbePath - Read & Write property

Description

returns the CNC Probe Path object associated with this item

Syntax in Visual Basic or VBScript

CNCProbePath () As Object

Syntax in C++

HRESULT get_CNCProbePath (IDispatch** retVal)
HRESULT put_CNCProbePath (IDispatch* Value)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


CNCProbePathFaults

CNCProbePathFaults - Reference Write property

Description

returns the CNC-Probe-Path Faults object associated with this item

Syntax in Visual Basic or VBScript

CNCProbePathFaults () As Object

Syntax in C++

HRESULT get_CNCProbePathFaults (IDispatch** retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


CNCProbingStrategy

CNCProbingStrategy - Read & Write property

Description

returns the CNC Probing strategy object associated with this item

Syntax in Visual Basic or VBScript

CNCProbingStrategy () As Object

Syntax in C++

HRESULT get_CNCProbingStrategy (IDispatch** retVal)
HRESULT put_CNCProbingStrategy (IDispatch* Value)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


Comment

Comment - Read & Write property

Description

Get/Set an arbitrary comment string for an item.

Syntax in Visual Basic or VBScript

Comment () As String

Syntax in C++

HRESULT get_Comment (BSTR* retVal)
HRESULT put_Comment (BSTR Value)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


ContainsMachineConfiguration

ContainsMachineConfiguration - Read property

Description

Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.

Syntax in Visual Basic or VBScript

ContainsMachineConfiguration () As Boolean

Syntax in C++

HRESULT get_ContainsMachineConfiguration (VARIANT_BOOL* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


DefinitionDatumItem

DefinitionDatumItem - Read property

Description

request the SequenceItem which represents the datum on which this element is defined

Syntax in Visual Basic or VBScript

DefinitionDatumItem () As SequenceItem

Syntax in C++

HRESULT get_DefinitionDatumItem (SequenceItem* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


Document

Document - Read property

Description

returns the associated document for this item

Syntax in Visual Basic or VBScript

Document () As Document

Syntax in C++

HRESULT get_Document (Document* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
measure
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


Group

Group - Read property

Description

return the group which own this element or nothing

Syntax in Visual Basic or VBScript

Group () As SequenceGroup

Syntax in C++

HRESULT get_Group (SequenceGroup* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


Index

Index - Read property

Description

get the current index of the item within its parent container

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


InterfaceType

InterfaceType - Read property

Description

return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports

Syntax in Visual Basic or VBScript

InterfaceType () As PWI_SequenceItemInterfaceType

Syntax in C++

HRESULT get_InterfaceType (PWI_SequenceItemInterfaceType* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


ItemType

ItemType - Read property

Description

return the type of the element ( could be one constant from

Syntax in Visual Basic or VBScript

ItemType () As PWI_EntityItemType

Syntax in C++

HRESULT get_ItemType (PWI_EntityItemType* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


MachineConfiguration

MachineConfiguration - Read & Write property

Description

The machine orientation that will be used to set the machine orientation for the sequence items below it.

Syntax in Visual Basic or VBScript

MachineConfiguration () As MachineOrientationData

Syntax in C++

HRESULT get_MachineConfiguration (MachineOrientationData* retVal)
HRESULT put_MachineConfiguration (MachineOrientationData* Value)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


MeasureDate

MeasureDate - Read property

Description

returns the last date this elements has been defined for the specified measure

Syntax in Visual Basic or VBScript

MeasureDate (measure As Variant) As ??? 7 ???

Syntax in C++

HRESULT get_MeasureDate (VARIANT measure , ??? 7 ???* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


MeasureState

MeasureState - Read property

Description

returns the measurement state / see also ResultValid

Syntax in Visual Basic or VBScript

MeasureState (measure As Variant) As PWI_MeasureState

Syntax in C++

HRESULT get_MeasureState (VARIANT measure , PWI_MeasureState* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


Name

Name - Read & Write property

Description

return the name of the element

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)
HRESULT put_Name (BSTR Value)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


NominalEntityFlag

NominalEntityFlag - Read property

Description

returns the method that this entity is using to be defined from nominals

Syntax in Visual Basic or VBScript

NominalEntityFlag () As PWI_NominalEntityFlag

Syntax in C++

HRESULT get_NominalEntityFlag (PWI_NominalEntityFlag* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


ResultValid

ResultValid - Read property

Description

return TRUE if this element is Valid for the given measure

Syntax in Visual Basic or VBScript

ResultValid (measure As Variant) As Boolean

Syntax in C++

HRESULT get_ResultValid (VARIANT measure , VARIANT_BOOL* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


UniqueID

UniqueID - Read property

Description

returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem

Syntax in Visual Basic or VBScript

UniqueID () As Long

Syntax in C++

HRESULT get_UniqueID (LONG* retVal)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


Visible

Visible - Read & Write property

Description

return the current state of the visible flag

Syntax in Visual Basic or VBScript

Visible () As Boolean

Syntax in C++

HRESULT get_Visible (VARIANT_BOOL* retVal)
HRESULT put_Visible (VARIANT_BOOL Value)

Applies to

AlignmentFreeFormFit
AlignmentFromFile
AlignmentItem
AlignmentRPS
BestFitItem
CADViewReportItem
CADViewStateItem
CMMDatum
CustomActionItem
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
IDigitisedCurve
EdgePointItem
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
GeometricGroup
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
IntermediateProbePath
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
MultiaxisConfiguration
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
IPointCloudItem
SequenceDefinitionDatum
SequenceGroup
SequenceItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup
IWorkplaneItem


Clone

Clone - method

Description

Create a new sequence item which has all the same properties as this one

Syntax in Visual Basic or VBScript

Clone () As SequenceItem

Syntax in C++

HRESULT Clone (SequenceItem* retVal)

Parameters

Name | Description
Return Value |

Applies to

SequenceItem


CopyMeasure

CopyMeasure - method

Description

Copy the result of the item from one measure to the other

Syntax in Visual Basic or VBScript

CopyMeasure (measureSrc As Variant , measureDst As Variant , bRecursive As Boolean)

Syntax in C++

HRESULT CopyMeasure (VARIANT measureSrc , VARIANT measureDst , VARIANT_BOOL bRecursive)

Parameters

Name | Description
measureSrc |
measureDst |
bRecursive |

Applies to

SequenceItem


Delete

Delete - method

Description

Delete the item. this method may failed if the item is already referenced

Syntax in Visual Basic or VBScript

Delete ()

Syntax in C++

HRESULT Delete ()

Applies to

SequenceItem


Duplicate

Duplicate - method

Description

Duplicate the item ( in the same group) and returns a pointer on the copy

Syntax in Visual Basic or VBScript

Duplicate () As SequenceItem

Syntax in C++

HRESULT Duplicate (SequenceItem* retVal)

Parameters

Name | Description
Return Value |

Applies to

SequenceItem


GetCMMPointArray

GetCMMPointArray - method

Description

retrieves the CMMPoint that were used to measure this item into a SafeArray

Syntax in Visual Basic or VBScript

GetCMMPointArray (measure As Variant , ByRef ProbeDiameter As Variant , ByRef arrayOfPoint As Variant)

Syntax in C++

HRESULT GetCMMPointArray (VARIANT measure , VARIANT* ProbeDiameter , VARIANT* arrayOfPoint)

Parameters

Name | Description
measure |
ProbeDiameter |
arrayOfPoint |

Applies to

SequenceItem


GetCMMPointDeviation

GetCMMPointDeviation - method

Description

Retrieves the deviations for each received CMMPoint into a SafeArray

Syntax in Visual Basic or VBScript

GetCMMPointDeviation (a_measure As Variant , ByRef a_deviation_array As Variant)

Syntax in C++

HRESULT GetCMMPointDeviation (VARIANT a_measure , VARIANT* a_deviation_array)

Parameters

Name | Description
a_measure |
a_deviation_array |

Applies to

SequenceItem


GetCMMtoLocalTransform

GetCMMtoLocalTransform - method

Description

request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined

Syntax in Visual Basic or VBScript

GetCMMtoLocalTransform (measure As Variant , ByRef transform As ITransform2)

Syntax in C++

HRESULT GetCMMtoLocalTransform (VARIANT measure , ITransform2* transform)

Parameters

Name | Description
measure |
transform |

Applies to

SequenceItem


Invalidate

Invalidate - method

Description

invalid the item result for the given measure

Syntax in Visual Basic or VBScript

Invalidate (measure As Variant) As Boolean

Syntax in C++

HRESULT Invalidate (VARIANT measure , VARIANT_BOOL* retVal)

Parameters

Name | Description
measure |
Return Value |

Applies to

SequenceItem


IsA

IsA - method

Description

Check if this object implements the interface of PWI_SequenceItemInterfaceType type

Syntax in Visual Basic or VBScript

IsA (type As PWI_SequenceItemInterfaceType) As Boolean

Syntax in C++

HRESULT IsA (PWI_SequenceItemInterfaceType type , VARIANT_BOOL* retVal)

Parameters

Name | Description
type |
Return Value |

Applies to

SequenceItem


Move

Move - method

Description

Move the item into a different location ( either within the same group or into a different group)

Syntax in Visual Basic or VBScript

Move (newPos As Long , newparentgroup As Variant)

Syntax in C++

HRESULT Move (LONG newPos , VARIANT newparentgroup)

Parameters

Name | Description
newPos |
newparentgroup |

Applies to

SequenceItem


PositioningMatrix

PositioningMatrix - method

Description

return the positioning matrix to convert CMM coordinates to Part Coordinates

Syntax in Visual Basic or VBScript

PositioningMatrix (measure As Variant) As ITransform2

Syntax in C++

HRESULT PositioningMatrix (VARIANT measure , ITransform2* retVal)

Parameters

Name | Description
measure |
Return Value |

Applies to

AlignmentItem


Refresh

Refresh - method

Description

Refresh: this method update this elements and all related items on the PowerINSPECT GUI

Syntax in Visual Basic or VBScript

Refresh ()

Syntax in C++

HRESULT Refresh ()

Applies to

SequenceItem


ReplayWithPoints

ReplayWithPoints - method

Description

Replay the elements with the given points

Syntax in Visual Basic or VBScript

ReplayWithPoints (measure As Variant , ProbeDiameter As Variant , CMMPoints As Variant , combination_of_REPLAYPOINTSFLAGS As Long) As Boolean

Syntax in C++

HRESULT ReplayWithPoints (VARIANT measure , VARIANT ProbeDiameter , VARIANT CMMPoints , LONG combination_of_REPLAYPOINTSFLAGS , VARIANT_BOOL* retVal)

Parameters

Name | Description
measure |
ProbeDiameter |
CMMPoints |
combination_of_REPLAYPOINTSFLAGS |
Return Value |

Applies to

SequenceItem


SetupNominalsFromMeasure

SetupNominalsFromMeasure - method

Description

Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified

Syntax in Visual Basic or VBScript

SetupNominalsFromMeasure (ByRef measure As measure)

Syntax in C++

HRESULT SetupNominalsFromMeasure (measure* measure)

Parameters

Name | Description
measure |

Applies to

SequenceItem


TransformationFrom

TransformationFrom - method

Description

Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane

Syntax in Visual Basic or VBScript

TransformationFrom (ByRef From As IWorkplaneItem , ByRef measure As measure) As ITransform2

Syntax in C++

HRESULT TransformationFrom (IWorkplaneItem* From , measure* measure , ITransform2* retVal)

Parameters

Name | Description
From |
measure |
Return Value |

Applies to

AlignmentItem


TransformationTo

TransformationTo - method

Description

Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane

Syntax in Visual Basic or VBScript

TransformationTo (ByRef To As IWorkplaneItem , ByRef measure As measure) As ITransform2

Syntax in C++

HRESULT TransformationTo (IWorkplaneItem* To , measure* measure , ITransform2* retVal)

Parameters

Name | Description
To |
measure |
Return Value |

Applies to

AlignmentItem


UpdateProbePath

UpdateProbePath - method

Description

request the recalculation of the probepath from the strategy object

Syntax in Visual Basic or VBScript

UpdateProbePath (measure As Variant) As Boolean

Syntax in C++

HRESULT UpdateProbePath (VARIANT measure , VARIANT_BOOL* retVal)

Parameters

Name | Description
measure |
Return Value |

Applies to

SequenceItem


XMLOutput

XMLOutput - method

Description

XMLOutput

Syntax in Visual Basic or VBScript

XMLOutput (ByRef xmlStream As Variant , flag As Long , options As Variant)

Syntax in C++

HRESULT XMLOutput (VARIANT* xmlStream , LONG flag , VARIANT options)

Parameters

Name | Description
xmlStream |
flag |
options |

Applies to

Document


Features

Features - Read property

Description

return a collection of feature that this element provides

Syntax in Visual Basic or VBScript

Features () As Features

Syntax in C++

HRESULT get_Features (Features* retVal)

Applies to

SequenceItem


Links

Links - Read property

Description

return a collection of links that need to be defined for this entity

Syntax in Visual Basic or VBScript

Links () As Links

Syntax in C++

HRESULT get_Links (Links* retVal)

Applies to

SequenceItem


Parameters

Parameters - Read property

Description

return a collection of parameters that defined the entity

Syntax in Visual Basic or VBScript

Parameters () As Parameters

Syntax in C++

HRESULT get_Parameters (Parameters* retVal)

Applies to

SequenceItem


Properties

Properties - Read property

Syntax in Visual Basic or VBScript

Properties () As Properties

Syntax in C++

HRESULT get_Properties (Properties* retVal)

Applies to

SequenceItem


Results

Results - Read property

Description

returns a collection of result points

Syntax in Visual Basic or VBScript

Results (measure As Variant) As DynamicTargetResults

Syntax in C++

HRESULT get_Results (VARIANT measure , DynamicTargetResults* retVal)

Applies to

AlignmentFreeFormFit


Targets

Targets - Read property

Description

returns a collection of target points

Syntax in Visual Basic or VBScript

Targets () As DynamicTargets

Syntax in C++

HRESULT get_Targets (DynamicTargets* retVal)

Applies to

AlignmentFreeFormFit


AlignmentFromFile

AlignmentFromFile - object

Interfaces

IAlignmentFromFile

Methods of IAlignmentFromFile

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
LoadFromFile |
Move | Move the item into a different location ( either within the same group or into a different group)
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IAlignmentFromFile

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IAlignmentFromFile

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


LoadFromFile

LoadFromFile - method

Syntax in Visual Basic or VBScript

LoadFromFile (measure As Variant , filename As String , bInverse As Boolean)

Syntax in C++

HRESULT LoadFromFile (VARIANT measure , BSTR filename , VARIANT_BOOL bInverse)

Parameters

Name | Description
measure |
filename |
bInverse |

Applies to

AlignmentFromFile


AlignmentItem

AlignmentItem - object

Interfaces

IAlignmentItem

Methods of IAlignmentItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IAlignmentItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IAlignmentItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


AlignmentRPS

AlignmentRPS - object

Interfaces

IAlignmentRPS

Methods of IAlignmentRPS

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IAlignmentRPS

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalDatum | R/W | returns a local datum
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IAlignmentRPS

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


LocalDatum

LocalDatum - Read & Write property

Description

returns a local datum

Syntax in Visual Basic or VBScript

LocalDatum () As ITransform2

Syntax in C++

HRESULT get_LocalDatum (ITransform2* retVal)
HRESULT put_LocalDatum (ITransform2* Value)

Applies to

AlignmentRPS


Application

Application - object

Description

the PowerINSPECT Application Object

Interfaces

IApplication

Events

ApplicationBeforeClose | fires when the application is about to close and to shutydown : client should release all the pointer to the application at this stage
CMMConnectionAboutToChange |
DocumentActivate |
DocumentBeforeClose |
DocumentBeforeSave |
DocumentClose | indicates that this document is going to be closed and should not be accessed anymore
DocumentDeactivate |
DocumentOpen |
NewDocument |
OnActiveItemChange | indictates that the active item ( as selected in the active Tree view ) has changed
OnActiveMeasureChange | indictates that the active measure ( as selected in the active Tree view ) has changed
OnExecuteCustomAction | indicates that PowerINSPECT is about to execute a custom action
OnFullScreenInspectionCompleted | indicates that a full screen inspection has completed
OnFullScreenInspectionStarted | indicates that a full screen inspection has started
OnItemChange | indicates that an item definition has changed
OnItemMeasureChange | indicates that an item measurement has changed
OnLocaleChange | indicates that the locale setting has change

Methods of IApplication

CheckPaf | returns the number of day left for the licence: (0= no licence or expired) ( -1 = permanent ) ( n : n day left)
CreateLocalObject | Create a object in the same thread context as the PowerINSPECT Application
ExecuteCommand | Execute a command by string
ExecuteCommandID | Send a command to the application, a positive number 'send' a command, a negative number will 'post' a command
LogonUser | logon as a specific user
Quit | Quit the application
RequestDisconnection |
SendCMMPoint | Send a CMM point to PowerINSPECT
ShowHTMLDialog |

Properties of IApplication

ActiveDocument | R/W | set/get the currently active document
ActiveItem | R/O | Returns the current active Sequence Item in the current active Tree
ActiveMeasure | R/O | Returns the current active Measure in the current active Tree
Application | R/O | property Application
BuildNumber | R/O | returns the PowerINSPECT current BuildNumber
CMMDriver | T/O | Retrieves the CMMDriver object which is hosted in the PowerINSPECT application
DelayInspection | R/W | Returns the state of the DelayInspection Flag
FeatureLicenced | R/O | Check if a feature is licenced
Fullscreen | R/W | Returns or sets the fullscreen Mode state
GDIHandlesInUse | R/O | Retrieve the number of GDI handles in use in the PI process.
Height | R/W | Returns or sets the size of the specified object, in points. ( 1 point = 1/72 inch)
hInstance | R/O | Retrieves the handle of the PowerINSPECT hInstance
hWnd | R/O | Retrieves the handle of the Main PowerINSPECT window
LCID | R/O | retrieve the current LCID
Left | R/W | Returns or sets the position of the specified object, in points. ( 1 point = 1/72 inch)
Locale | R/W | Set the locale used by PowerINSPECT. No documents must be opened. locale can be a string following the ISO standard or a LCID
MajorVersion | R/O | returns the PowerINSPECT Major Version
MinorVersion | R/O | returns the PowerINSPECT MinorVersion
Path | R/O | Retrieves the Path of the PowerINSPECT Executable
ProductType | R/O | Return the generic product type
RegistryPath | R/O | Retrieve registry path for application
Top | R/W | Returns or sets the position of the specified object, in points. ( 1 point = 1/72 inch)
UsableHeight | R/O | Returns maximum width of the specified object, in points. ( 1 point = 1/72 inch)
UsableWidth | R/O | Returns maximum width of the specified object, in points. ( 1 point = 1/72 inch)
UserHandlesInUse | R/O | Retrieve the number of User handles in use in the PI process.
Version | R/O | returns the version string
Visible | R/W |
Width | R/W | Returns or sets the size of the specified object, in points. ( 1 point = 1/72 inch)
WindowState | R/W | Returns or sets the main window state

Collections of IApplication

AddInCollection | returns the AddIn Collection Object
CommandBars | returns the CommandBars collection object
Documents |


ActiveDocument

ActiveDocument - Read & Write property

Description

set/get the currently active document

Syntax in Visual Basic or VBScript

ActiveDocument () As Document

Syntax in C++

HRESULT get_ActiveDocument (Document* retVal)
HRESULT put_ActiveDocument (Document* Value)

Applies to

Application


ActiveItem

ActiveItem - Read property

Description

Returns the current active Sequence Item in the current active Tree

Syntax in Visual Basic or VBScript

ActiveItem () As SequenceItem

Syntax in C++

HRESULT get_ActiveItem (SequenceItem* retVal)

Applies to

Application


ActiveMeasure

ActiveMeasure - Read property

Description

Returns the current active Measure in the current active Tree

Syntax in Visual Basic or VBScript

ActiveMeasure () As measure

Syntax in C++

HRESULT get_ActiveMeasure (measure* retVal)

Applies to

Application


Application

Application - Read property

Description

property Application

Syntax in Visual Basic or VBScript

Application () As Application

Syntax in C++

HRESULT get_Application (Application* retVal)

Applies to

Application


BuildNumber

BuildNumber - Read property

Description

returns the PowerINSPECT current BuildNumber

Syntax in Visual Basic or VBScript

BuildNumber () As Long

Syntax in C++

HRESULT get_BuildNumber (LONG* retVal)

Applies to

Application


CMMDriver

CMMDriver - Reference Write property

Description

Retrieves the CMMDriver object which is hosted in the PowerINSPECT application

Syntax in Visual Basic or VBScript

CMMDriver () As Object

Syntax in C++

HRESULT get_CMMDriver (IDispatch** retVal)

Applies to

Application


DelayInspection

DelayInspection - Read & Write property

Description

Returns the state of the DelayInspection Flag

Syntax in Visual Basic or VBScript

DelayInspection () As Boolean

Syntax in C++

HRESULT get_DelayInspection (VARIANT_BOOL* retVal)
HRESULT put_DelayInspection (VARIANT_BOOL Value)

Applies to

Application


FeatureLicenced

FeatureLicenced - Read property

Description

Check if a feature is licenced

Syntax in Visual Basic or VBScript

FeatureLicenced (feat As PRODUCT_FEATURE) As Boolean

Syntax in C++

HRESULT get_FeatureLicenced (PRODUCT_FEATURE feat , VARIANT_BOOL* retVal)

Applies to

Application


Fullscreen

Fullscreen - Read & Write property

Description

Returns or sets the fullscreen Mode state

Syntax in Visual Basic or VBScript

Fullscreen () As Boolean

Syntax in C++

HRESULT get_Fullscreen (VARIANT_BOOL* retVal)
HRESULT put_Fullscreen (VARIANT_BOOL Value)

Applies to

Application


GDIHandlesInUse

GDIHandlesInUse - Read property

Description

Retrieve the number of GDI handles in use in the PI process.

Syntax in Visual Basic or VBScript

GDIHandlesInUse () As Long

Syntax in C++

HRESULT get_GDIHandlesInUse (LONG* retVal)

Applies to

Application


Height

Height - Read & Write property

Description

Returns or sets the size of the specified object, in points. ( 1 point = 1/72 inch)

Syntax in Visual Basic or VBScript

Height () As Double

Syntax in C++

HRESULT get_Height (double* retVal)
HRESULT put_Height (double Value)

Applies to

Application


hInstance

hInstance - Read property

Description

Retrieves the handle of the PowerINSPECT hInstance

Syntax in Visual Basic or VBScript

hInstance () As Long

Syntax in C++

HRESULT get_hInstance (LONG* retVal)

Applies to

Application


hWnd

hWnd - Read property

Description

Retrieves the handle of the Main PowerINSPECT window

Syntax in Visual Basic or VBScript

hWnd () As Long

Syntax in C++

HRESULT get_hWnd (LONG* retVal)

Applies to

Application


LCID

LCID - Read property

Description

retrieve the current LCID

Syntax in Visual Basic or VBScript

LCID () As Long

Syntax in C++

HRESULT get_LCID (LONG* retVal)

Applies to

Application


Left

Left - Read & Write property

Description

Returns or sets the position of the specified object, in points. ( 1 point = 1/72 inch)

Syntax in Visual Basic or VBScript

Left () As Double

Syntax in C++

HRESULT get_Left (double* retVal)
HRESULT put_Left (double Value)

Applies to

Application


Locale

Locale - Read & Write property

Description

Set the locale used by PowerINSPECT. No documents must be opened. locale can be a string following the ISO standard or a LCID

Syntax in Visual Basic or VBScript

Locale () As String

Syntax in C++

HRESULT get_Locale (BSTR* retVal)
HRESULT put_Locale (VARIANT Value)

Applies to

Application


MajorVersion

MajorVersion - Read property

Description

returns the PowerINSPECT Major Version

Syntax in Visual Basic or VBScript

MajorVersion () As Long

Syntax in C++

HRESULT get_MajorVersion (LONG* retVal)

Applies to

Application


MinorVersion

MinorVersion - Read property

Description

returns the PowerINSPECT MinorVersion

Syntax in Visual Basic or VBScript

MinorVersion () As Long

Syntax in C++

HRESULT get_MinorVersion (LONG* retVal)

Applies to

Application


Path

Path - Read property

Description

Retrieves the Path of the PowerINSPECT Executable

Syntax in Visual Basic or VBScript

Path () As String

Syntax in C++

HRESULT get_Path (BSTR* retVal)

Applies to

Application


ProductType

ProductType - Read property

Description

Return the generic product type

Syntax in Visual Basic or VBScript

ProductType () As PRODUCT_TYPE

Syntax in C++

HRESULT get_ProductType (PRODUCT_TYPE* retVal)

Applies to

Application


RegistryPath

RegistryPath - Read property

Description

Retrieve registry path for application

Syntax in Visual Basic or VBScript

RegistryPath () As String

Syntax in C++

HRESULT get_RegistryPath (BSTR* retVal)

Applies to

Application


Top

Top - Read & Write property

Description

Returns or sets the position of the specified object, in points. ( 1 point = 1/72 inch)

Syntax in Visual Basic or VBScript

Top () As Double

Syntax in C++

HRESULT get_Top (double* retVal)
HRESULT put_Top (double Value)

Applies to

Application


UsableHeight

UsableHeight - Read property

Description

Returns maximum width of the specified object, in points. ( 1 point = 1/72 inch)

Syntax in Visual Basic or VBScript

UsableHeight () As Double

Syntax in C++

HRESULT get_UsableHeight (double* retVal)

Applies to

Application


UsableWidth

UsableWidth - Read property

Description

Returns maximum width of the specified object, in points. ( 1 point = 1/72 inch)

Syntax in Visual Basic or VBScript

UsableWidth () As Double

Syntax in C++

HRESULT get_UsableWidth (double* retVal)

Applies to

Application


UserHandlesInUse

UserHandlesInUse - Read property

Description

Retrieve the number of User handles in use in the PI process.

Syntax in Visual Basic or VBScript

UserHandlesInUse () As Long

Syntax in C++

HRESULT get_UserHandlesInUse (LONG* retVal)

Applies to

Application


Version

Version - Read property

Description

returns the version string

Syntax in Visual Basic or VBScript

Version () As String

Syntax in C++

HRESULT get_Version (BSTR* retVal)

Applies to

Application


Visible

Visible - Read & Write property

Syntax in Visual Basic or VBScript

Visible () As Boolean

Syntax in C++

HRESULT get_Visible (VARIANT_BOOL* retVal)
HRESULT put_Visible (VARIANT_BOOL Value)

Applies to

Application


Width

Width - Read & Write property

Description

Returns or sets the size of the specified object, in points. ( 1 point = 1/72 inch)

Syntax in Visual Basic or VBScript

Width () As Double

Syntax in C++

HRESULT get_Width (double* retVal)
HRESULT put_Width (double Value)

Applies to

Application


WindowState

WindowState - Read & Write property

Description

Returns or sets the main window state

Syntax in Visual Basic or VBScript

WindowState () As PWI_WindowState

Syntax in C++

HRESULT get_WindowState (PWI_WindowState* retVal)
HRESULT put_WindowState (PWI_WindowState Value)

Applies to

Application


ApplicationBeforeClose

ApplicationBeforeClose - event

Description

fires when the application is about to close and to shutydown : client should release all the pointer to the application at this stage

Syntax in Visual Basic or VBScript

ApplicationBeforeClose (ByRef accepted As Boolean)

Syntax in C++

HRESULT ApplicationBeforeClose (VARIANT_BOOL* accepted)

Parameters

Name | Description
accepted |

Applies to

Application


CheckPaf

CheckPaf - method

Description

returns the number of day left for the licence: (0= no licence or expired) ( -1 = permanent ) ( n : n day left)

Syntax in Visual Basic or VBScript

CheckPaf (option As String) As Long

Syntax in C++

HRESULT CheckPaf (BSTR option , LONG* retVal)

Parameters

Name | Description
option |
Return Value |

Applies to

Application


CMMConnectionAboutToChange

CMMConnectionAboutToChange - event

Syntax in Visual Basic or VBScript

CMMConnectionAboutToChange (connected As Boolean , ByRef accepted As Boolean)

Syntax in C++

HRESULT CMMConnectionAboutToChange (VARIANT_BOOL connected , VARIANT_BOOL* accepted)

Parameters

Name | Description
connected |
accepted |

Applies to

Application


CreateLocalObject

CreateLocalObject - method

Description

Create a object in the same thread context as the PowerINSPECT Application

Syntax in Visual Basic or VBScript

CreateLocalObject (strProgID As String) As Object

Syntax in C++

HRESULT CreateLocalObject (BSTR strProgID , IDispatch** retVal)

Parameters

Name | Description
strProgID |
Return Value |

Applies to

Application


DocumentActivate

DocumentActivate - event

Syntax in Visual Basic or VBScript

DocumentActivate (ByRef doc As Document)

Syntax in C++

HRESULT DocumentActivate (Document* doc)

Parameters

Name | Description
doc |

Applies to

Application


DocumentBeforeClose

DocumentBeforeClose - event

Syntax in Visual Basic or VBScript

DocumentBeforeClose (ByRef doc As Document , ByRef Cancel As Boolean)

Syntax in C++

HRESULT DocumentBeforeClose (Document* doc , VARIANT_BOOL* Cancel)

Parameters

Name | Description
doc |
Cancel |

Applies to

Application


DocumentBeforeSave

DocumentBeforeSave - event

Syntax in Visual Basic or VBScript

DocumentBeforeSave (ByRef doc As Document , SaveAsUI As Boolean , ByRef Cancel As Boolean)

Syntax in C++

HRESULT DocumentBeforeSave (Document* doc , VARIANT_BOOL SaveAsUI , VARIANT_BOOL* Cancel)

Parameters

Name | Description
doc |
SaveAsUI |
Cancel |

Applies to

Application


DocumentClose

DocumentClose - event

Description

indicates that this document is going to be closed and should not be accessed anymore

Syntax in Visual Basic or VBScript

DocumentClose (ByRef pdoc As Document)

Syntax in C++

HRESULT DocumentClose (Document* pdoc)

Parameters

Name | Description
pdoc |

Applies to

Application


DocumentDeactivate

DocumentDeactivate - event

Syntax in Visual Basic or VBScript

DocumentDeactivate (ByRef doc As Document)

Syntax in C++

HRESULT DocumentDeactivate (Document* doc)

Parameters

Name | Description
doc |

Applies to

Application


DocumentOpen

DocumentOpen - event

Syntax in Visual Basic or VBScript

DocumentOpen (ByRef doc As Document)

Syntax in C++

HRESULT DocumentOpen (Document* doc)

Parameters

Name | Description
doc |

Applies to

Application


ExecuteCommand

ExecuteCommand - method

Description

Execute a command by string

Syntax in Visual Basic or VBScript

ExecuteCommand (strCommandStr As String)

Syntax in C++

HRESULT ExecuteCommand (BSTR strCommandStr)

Parameters

Name | Description
strCommandStr |

Applies to

Application


ExecuteCommandID

ExecuteCommandID - method

Description

Send a command to the application, a positive number 'send' a command, a negative number will 'post' a command

Syntax in Visual Basic or VBScript

ExecuteCommandID (CommandID As Long)

Syntax in C++

HRESULT ExecuteCommandID (LONG CommandID)

Parameters

Name | Description
CommandID |

Applies to

Application


LogonUser

LogonUser - method

Description

logon as a specific user

Syntax in Visual Basic or VBScript

LogonUser (userName As String , domain As String , password As String) As Boolean

Syntax in C++

HRESULT LogonUser (BSTR userName , BSTR domain , BSTR password , VARIANT_BOOL* retVal)

Parameters

Name | Description
userName |
domain |
password |
Return Value |

Applies to

Application


NewDocument

NewDocument - event

Syntax in Visual Basic or VBScript

NewDocument (ByRef doc As Document)

Syntax in C++

HRESULT NewDocument (Document* doc)

Parameters

Name | Description
doc |

Applies to

Application


OnActiveItemChange

OnActiveItemChange - event

Description

indictates that the active item ( as selected in the active Tree view ) has changed

Syntax in Visual Basic or VBScript

OnActiveItemChange (ByRef pMeasure As SequenceItem)

Syntax in C++

HRESULT OnActiveItemChange (SequenceItem* pMeasure)

Parameters

Name | Description
pMeasure |

Applies to

Document


OnActiveMeasureChange

OnActiveMeasureChange - event

Description

indictates that the active measure ( as selected in the active Tree view ) has changed

Syntax in Visual Basic or VBScript

OnActiveMeasureChange (ByRef pMeasure As measure)

Syntax in C++

HRESULT OnActiveMeasureChange (measure* pMeasure)

Parameters

Name | Description
pMeasure |

Applies to

Document


OnExecuteCustomAction

OnExecuteCustomAction - event

Description

indicates that PowerINSPECT is about to execute a custom action

Syntax in Visual Basic or VBScript

OnExecuteCustomAction (ByRef Item As CustomActionItem , ByRef bIntercepted As Boolean)

Syntax in C++

HRESULT OnExecuteCustomAction (CustomActionItem* Item , VARIANT_BOOL* bIntercepted)

Parameters

Name | Description
Item |
bIntercepted |

Applies to

Application


OnFullScreenInspectionCompleted

OnFullScreenInspectionCompleted - event

Description

indicates that a full screen inspection has completed

Syntax in Visual Basic or VBScript

OnFullScreenInspectionCompleted ()

Syntax in C++

HRESULT OnFullScreenInspectionCompleted ()

Applies to

Application


OnFullScreenInspectionStarted

OnFullScreenInspectionStarted - event

Description

indicates that a full screen inspection has started

Syntax in Visual Basic or VBScript

OnFullScreenInspectionStarted (hWnd As Long , toolbarID As Long , ByRef pSequenceItem As SequenceItem)

Syntax in C++

HRESULT OnFullScreenInspectionStarted (LONG hWnd , LONG toolbarID , SequenceItem* pSequenceItem)

Parameters

Name | Description
hWnd |
toolbarID |
pSequenceItem |

Applies to

Application


OnItemChange

OnItemChange - event

Description

indicates that an item definition has changed

Syntax in Visual Basic or VBScript

OnItemChange (ByRef pItem As SequenceItem)

Syntax in C++

HRESULT OnItemChange (SequenceItem* pItem)

Parameters

Name | Description
pItem |

Applies to

Document


OnItemMeasureChange

OnItemMeasureChange - event

Description

indicates that an item measurement has changed

Syntax in Visual Basic or VBScript

OnItemMeasureChange (ByRef pItem As SequenceItem , ByRef pMeasure As measure)

Syntax in C++

HRESULT OnItemMeasureChange (SequenceItem* pItem , measure* pMeasure)

Parameters

Name | Description
pItem |
pMeasure |

Applies to

Document


OnLocaleChange

OnLocaleChange - event

Description

indicates that the locale setting has change

Syntax in Visual Basic or VBScript

OnLocaleChange (newLCID As Long)

Syntax in C++

HRESULT OnLocaleChange (LONG newLCID)

Parameters

Name | Description
newLCID |

Applies to

Application


Quit

Quit - method

Description

Quit the application

Syntax in Visual Basic or VBScript

Quit ()

Syntax in C++

HRESULT Quit ()

Applies to

Application


RequestDisconnection

RequestDisconnection - method

Syntax in Visual Basic or VBScript

RequestDisconnection () As Boolean

Syntax in C++

HRESULT RequestDisconnection (VARIANT_BOOL* retVal)

Parameters

Name | Description
Return Value |

Applies to

Application


SendCMMPoint

SendCMMPoint - method

Description

Send a CMM point to PowerINSPECT

Syntax in Visual Basic or VBScript

SendCMMPoint (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double) As Boolean

Syntax in C++

HRESULT SendCMMPoint (double X , double Y , double Z , double I , double J , double K , VARIANT_BOOL* retVal)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |
Return Value |

Applies to

Application


ShowHTMLDialog

ShowHTMLDialog - method

Syntax in Visual Basic or VBScript

ShowHTMLDialog (str As String , bModeless As Boolean) As Variant

Syntax in C++

HRESULT ShowHTMLDialog (BSTR str , VARIANT_BOOL bModeless , VARIANT* retVal)

Parameters

Name | Description
str |
bModeless |
Return Value |

Applies to

Application


AddInCollection

AddInCollection - Read property

Description

returns the AddIn Collection Object

Syntax in Visual Basic or VBScript

AddInCollection () As IAddInCollection

Syntax in C++

HRESULT get_AddInCollection (IAddInCollection* retVal)

Applies to

Application


CommandBars

CommandBars - Read property

Description

returns the CommandBars collection object

Syntax in Visual Basic or VBScript

CommandBars () As CommandBars

Syntax in C++

HRESULT get_CommandBars (CommandBars* retVal)

Applies to

Application


Documents

Documents - Read property

Syntax in Visual Basic or VBScript

Documents () As Documents

Syntax in C++

HRESULT get_Documents (Documents* retVal)

Applies to

Application


Arc3D

Arc3D - object

Description

EntityFromPoint Class

Interfaces

IPWIArc3D

Methods of IPWIArc3D

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties of IPWIArc3D

CenterPoint | R/O |
EndAngle | R/W | set/retrieve the end angle in degree
EndPoint | R/O |
Evaluator | T/O |
Name | R/W |
NormalVector | R/O |
Radius | R/W |
ReadOnly | R/O |
StartAngle | R/W | set/retrieve the start angle in degree
StartPoint | R/O |
TypeOf | R/O |


BestFitItem

BestFitItem - object

Interfaces

IBestFitItem

Methods of IBestFitItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IBestFitItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
AllowTX | R/W | set/retrieve whether the best-fit is allowed to translate in X ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)
AllowTY | R/W | set/retrieve whether the best-fit is allowed to translate in Y ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)
AllowTZ | R/W | set/retrieve whether the best-fit is allowed to translate in Z ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)
BestFitMethod | R/W | set/retrieve the bestfit method
BestFitMethodString | R/O | retrieve the bestfit method as a human readable localised string.
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FittingType | R/W | Get/set the fitting type (which tolerances are used)
FittingTypeString | R/O | Get a text description of the fitting type
FixedLine | R/O | Returns the reference line used for the rotational axis.
FixedPlaneAxis | R/O | returns Fixed Axis definition , ( only valid if BestFitMethod = BST_2D_BESTFIT)
fixedPoint | R/O | Fixed Point , ( only valid if BestFitMethod = BST_ROTATION_ONLY
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LinkedAlignment | R/O | Returns an alignment item that was corrected with this best fit.
LinkGroups | R/O | returns the collections of linked groups
LockPlaneTranslation | R/W | set/retrieve whether the best-fit is allowed to translate along the axis of the 2D Bestfit ( only valid if BestFitMethod = pwibst_BST_2D_BESTFIT)
LowerTolerance | R/W | Get/set the lower tolerance for fitting
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MaxIteration | R/W | set/retrieve the number of iterations maximum allowed for this bestfit
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
Result | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
StopCriteria | R/W | set/retrieve the stop criteria for this bestfit
ToleranceType | R/W | Get/set the tolerance type (which tolerances are used)
ToleranceTypeString | R/O | Get a text description of the tolerances used for fitting
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W | Get/set the upper tolerance for fitting
Visible | R/W | return the current state of the visible flag

Collections of IBestFitItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


AllowTX

AllowTX - Read & Write property

Description

set/retrieve whether the best-fit is allowed to translate in X ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)

Syntax in Visual Basic or VBScript

AllowTX () As Boolean

Syntax in C++

HRESULT get_AllowTX (VARIANT_BOOL* retVal)
HRESULT put_AllowTX (VARIANT_BOOL Value)

Applies to

BestFitItem


AllowTY

AllowTY - Read & Write property

Description

set/retrieve whether the best-fit is allowed to translate in Y ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)

Syntax in Visual Basic or VBScript

AllowTY () As Boolean

Syntax in C++

HRESULT get_AllowTY (VARIANT_BOOL* retVal)
HRESULT put_AllowTY (VARIANT_BOOL Value)

Applies to

BestFitItem


AllowTZ

AllowTZ - Read & Write property

Description

set/retrieve whether the best-fit is allowed to translate in Z ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)

Syntax in Visual Basic or VBScript

AllowTZ () As Boolean

Syntax in C++

HRESULT get_AllowTZ (VARIANT_BOOL* retVal)
HRESULT put_AllowTZ (VARIANT_BOOL Value)

Applies to

BestFitItem


BestFitMethod

BestFitMethod - Read & Write property

Description

set/retrieve the bestfit method

Syntax in Visual Basic or VBScript

BestFitMethod () As PWI_BESTFIT_Method

Syntax in C++

HRESULT get_BestFitMethod (PWI_BESTFIT_Method* retVal)
HRESULT put_BestFitMethod (PWI_BESTFIT_Method Value)

Applies to

BestFitItem


BestFitMethodString

BestFitMethodString - Read property

Description

retrieve the bestfit method as a human readable localised string.

Syntax in Visual Basic or VBScript

BestFitMethodString () As String

Syntax in C++

HRESULT get_BestFitMethodString (BSTR* retVal)

Applies to

BestFitItem


FittingType

FittingType - Read & Write property

Description

Get/set the fitting type (which tolerances are used)

Syntax in Visual Basic or VBScript

FittingType () As BESTFIT_FITTING_TYPE

Syntax in C++

HRESULT get_FittingType (BESTFIT_FITTING_TYPE* retVal)
HRESULT put_FittingType (BESTFIT_FITTING_TYPE Value)

Applies to

BestFitItem


FittingTypeString

FittingTypeString - Read property

Description

Get a text description of the fitting type

Syntax in Visual Basic or VBScript

FittingTypeString () As String

Syntax in C++

HRESULT get_FittingTypeString (BSTR* retVal)

Applies to

BestFitItem


FixedLine

FixedLine - Read property

Description

Returns the reference line used for the rotational axis.

Syntax in Visual Basic or VBScript

FixedLine () As SimpleLink

Syntax in C++

HRESULT get_FixedLine (SimpleLink* retVal)

Applies to

BestFitItem


FixedPlaneAxis

FixedPlaneAxis - Read property

Description

returns Fixed Axis definition , ( only valid if BestFitMethod = BST_2D_BESTFIT)

Syntax in Visual Basic or VBScript

FixedPlaneAxis () As ParameterVector3DEx

Syntax in C++

HRESULT get_FixedPlaneAxis (ParameterVector3DEx* retVal)

Applies to

BestFitItem


fixedPoint

fixedPoint - Read property

Description

Fixed Point , ( only valid if BestFitMethod = BST_ROTATION_ONLY

Syntax in Visual Basic or VBScript

fixedPoint () As ParameterPoint3DEx

Syntax in C++

HRESULT get_fixedPoint (ParameterPoint3DEx* retVal)

Applies to

BestFitItem


LinkedAlignment

LinkedAlignment - Read property

Description

Returns an alignment item that was corrected with this best fit.

Syntax in Visual Basic or VBScript

LinkedAlignment () As SequenceItem

Syntax in C++

HRESULT get_LinkedAlignment (SequenceItem* retVal)

Applies to

BestFitItem


LinkGroups

LinkGroups - Read property

Description

returns the collections of linked groups

Syntax in Visual Basic or VBScript

LinkGroups () As MultipleLink

Syntax in C++

HRESULT get_LinkGroups (MultipleLink* retVal)

Applies to

BestFitItem


LockPlaneTranslation

LockPlaneTranslation - Read & Write property

Description

set/retrieve whether the best-fit is allowed to translate along the axis of the 2D Bestfit ( only valid if BestFitMethod = pwibst_BST_2D_BESTFIT)

Syntax in Visual Basic or VBScript

LockPlaneTranslation () As Boolean

Syntax in C++

HRESULT get_LockPlaneTranslation (VARIANT_BOOL* retVal)
HRESULT put_LockPlaneTranslation (VARIANT_BOOL Value)

Applies to

BestFitItem


LowerTolerance

LowerTolerance - Read & Write property

Description

Get/set the lower tolerance for fitting

Syntax in Visual Basic or VBScript

LowerTolerance () As Double

Syntax in C++

HRESULT get_LowerTolerance (double* retVal)
HRESULT put_LowerTolerance (double Value)

Applies to

BestFitItem


MaxIteration

MaxIteration - Read & Write property

Description

set/retrieve the number of iterations maximum allowed for this bestfit

Syntax in Visual Basic or VBScript

MaxIteration () As Long

Syntax in C++

HRESULT get_MaxIteration (LONG* retVal)
HRESULT put_MaxIteration (LONG Value)

Applies to

BestFitItem


Result

Result - Read property

Syntax in Visual Basic or VBScript

Result (measure As Variant) As BestFitResult

Syntax in C++

HRESULT get_Result (VARIANT measure , BestFitResult* retVal)

Applies to

BestFitItem


StopCriteria

StopCriteria - Read & Write property

Description

set/retrieve the stop criteria for this bestfit

Syntax in Visual Basic or VBScript

StopCriteria () As Double

Syntax in C++

HRESULT get_StopCriteria (double* retVal)
HRESULT put_StopCriteria (double Value)

Applies to

BestFitItem


ToleranceType

ToleranceType - Read & Write property

Description

Get/set the tolerance type (which tolerances are used)

Syntax in Visual Basic or VBScript

ToleranceType () As BESTFIT_TOLERANCE_TYPE

Syntax in C++

HRESULT get_ToleranceType (BESTFIT_TOLERANCE_TYPE* retVal)
HRESULT put_ToleranceType (BESTFIT_TOLERANCE_TYPE Value)

Applies to

BestFitItem


ToleranceTypeString

ToleranceTypeString - Read property

Description

Get a text description of the tolerances used for fitting

Syntax in Visual Basic or VBScript

ToleranceTypeString () As String

Syntax in C++

HRESULT get_ToleranceTypeString (BSTR* retVal)

Applies to

BestFitItem


UpperTolerance

UpperTolerance - Read & Write property

Description

Get/set the upper tolerance for fitting

Syntax in Visual Basic or VBScript

UpperTolerance () As Double

Syntax in C++

HRESULT get_UpperTolerance (double* retVal)
HRESULT put_UpperTolerance (double Value)

Applies to

BestFitItem


BestFitResult

BestFitResult - object

Interfaces

IBestFitResult

Methods of IBestFitResult

Calculate | Evaluate the bestfit
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates

Properties of IBestFitResult

DeltaTransform | R/O | the Delta Transformation
IsValid | R/O |
measure | R/O |
MeasureState | R/O | returns the measurement state
Parent | R/O |
StatisticAfter | R/O | the statistics after the Best-fit have been applied
StatisticBefore | R/O | the statistics before the Best-fit have been applied


DeltaTransform

DeltaTransform - Read property

Description

the Delta Transformation

Syntax in Visual Basic or VBScript

DeltaTransform () As transform

Syntax in C++

HRESULT get_DeltaTransform (transform* retVal)

Applies to

BestFitResult


IsValid

IsValid - Read property

Syntax in Visual Basic or VBScript

IsValid () As Boolean

Syntax in C++

HRESULT get_IsValid (VARIANT_BOOL* retVal)

Applies to

BestFitResult
EdgePointResult
ISequenceResult
SurfacePointResult


measure

measure - Read property

Syntax in Visual Basic or VBScript

measure () As measure

Syntax in C++

HRESULT get_measure (measure* retVal)

Applies to

BestFitResult
EdgePointResult
IMeasureStatistics
ISequenceResult
SurfacePointResult


MeasureState

MeasureState - Read property

Description

returns the measurement state

Syntax in Visual Basic or VBScript

MeasureState () As PWI_MeasureState

Syntax in C++

HRESULT get_MeasureState (PWI_MeasureState* retVal)

Applies to

BestFitResult
EdgePointResult
measure
ISequenceResult
SurfacePointResult


Parent

Parent - Read property

Syntax in Visual Basic or VBScript

Parent () As SequenceItem

Syntax in C++

HRESULT get_Parent (SequenceItem* retVal)

Applies to

BestFitResult
EdgePointResult
ISequenceResult
SurfacePointResult


StatisticAfter

StatisticAfter - Read property

Description

the statistics after the Best-fit have been applied

Syntax in Visual Basic or VBScript

StatisticAfter () As IBestFitStat

Syntax in C++

HRESULT get_StatisticAfter (IBestFitStat* retVal)

Applies to

BestFitResult


StatisticBefore

StatisticBefore - Read property

Description

the statistics before the Best-fit have been applied

Syntax in Visual Basic or VBScript

StatisticBefore () As IBestFitStat

Syntax in C++

HRESULT get_StatisticBefore (IBestFitStat* retVal)

Applies to

BestFitResult


Calculate

Calculate - method

Description

Evaluate the bestfit

Syntax in Visual Basic or VBScript

Calculate (max_iteration As Long , stop_criteria As Double) As Boolean

Syntax in C++

HRESULT Calculate (LONG max_iteration , double stop_criteria , VARIANT_BOOL* retVal)

Parameters

Name | Description
max_iteration |
stop_criteria |
Return Value |

Applies to

BestFitResult


BoundingBox

BoundingBox - object

Interfaces

IBoundingBox3D

Methods of IBoundingBox3D

Reset | reset the box to a invalid box
UpdateWithBox | update the box with a other box
UpdateWithPoint | update the box with a point

Properties of IBoundingBox3D

IsValid | R/O | returns TRUE if the box is valid
MaxPoint | R/O | Returns the max point of the box
MinPoint | R/O | Returns the min point of the box
ReadOnly | R/O | returns true if the box is read only


BrowseHelper

BrowseHelper - object

Description

BrowseHelper Class

Interfaces

IBrowseHelper

Methods of IBrowseHelper

BrowseIDispatchTypeLibrary | Browse the type library of a given object
BrowseTypeLibrary | method BrowseTypeLibrary
BrowseTypeLibraryIID | method BrowseTypeLibraryIID
CPPTypeStr | retrieve the CPPType String
VBTypeStr | retrieve the VBType String


BrowseIDispatchTypeLibrary

BrowseIDispatchTypeLibrary - method

Description

Browse the type library of a given object

Syntax in Visual Basic or VBScript

BrowseIDispatchTypeLibrary (pObjectToScan As Object) As Dispinterface

Syntax in C++

HRESULT BrowseIDispatchTypeLibrary (IDispatch* pObjectToScan , Dispinterface* retVal)

Parameters

Name | Description
pObjectToScan |
Return Value |

Applies to

BrowseHelper


BrowseTypeLibrary

BrowseTypeLibrary - method

Description

method BrowseTypeLibrary

Syntax in Visual Basic or VBScript

BrowseTypeLibrary (bstrPath As String) As TypeLibrary

Syntax in C++

HRESULT BrowseTypeLibrary (BSTR bstrPath , TypeLibrary* retVal)

Parameters

Name | Description
bstrPath |
Return Value |

Applies to

BrowseHelper


BrowseTypeLibraryIID

BrowseTypeLibraryIID - method

Description

method BrowseTypeLibraryIID

Syntax in Visual Basic or VBScript

BrowseTypeLibraryIID (ByRef iid As TKIND_RECORD , MajorVersion As Integer , MinorVersion As Integer) As TypeLibrary

Syntax in C++

HRESULT BrowseTypeLibraryIID (TKIND_RECORD* iid , INT MajorVersion , INT MinorVersion , TypeLibrary* retVal)

Parameters

Name | Description
iid |
MajorVersion |
MinorVersion |
Return Value |

Applies to

BrowseHelper


CPPTypeStr

CPPTypeStr - method

Description

retrieve the CPPType String

Syntax in Visual Basic or VBScript

CPPTypeStr (VARENUM As Long) As String

Syntax in C++

HRESULT CPPTypeStr (LONG VARENUM , BSTR* retVal)

Parameters

Name | Description
VARENUM |
Return Value |

Applies to

BrowseHelper


VBTypeStr

VBTypeStr - method

Description

retrieve the VBType String

Syntax in Visual Basic or VBScript

VBTypeStr (VARENUM As Long) As String

Syntax in C++

HRESULT VBTypeStr (LONG VARENUM , BSTR* retVal)

Parameters

Name | Description
VARENUM |
Return Value |

Applies to

BrowseHelper


CADFile

CADFile - object

Interfaces

ICADFile

Properties of ICADFile

BoundingBox | R/O | returns the Bounded Box of the CAD file
filename | R/W | filename
LocalDatum | R/O | LocalDatum: define the transformation matrix defined for this file

Collections of ICADFile

CADLevels Collection of CAD levels belonging to this item.


BoundingBox

BoundingBox - Read property

Description

returns the Bounded Box of the CAD file

Syntax in Visual Basic or VBScript

BoundingBox () As BoundingBox

Syntax in C++

HRESULT get_BoundingBox (BoundingBox* retVal)

Applies to

CADFile


filename

filename - Read & Write property

Description

filename

Syntax in Visual Basic or VBScript

filename () As String

Syntax in C++

HRESULT get_filename (BSTR* retVal)
HRESULT put_filename (BSTR Value)

Applies to

CADFile


LocalDatum

LocalDatum - Read property

Description

LocalDatum: define the transformation matrix defined for this file

Syntax in Visual Basic or VBScript

LocalDatum () As TransformDefinition

Syntax in C++

HRESULT get_LocalDatum (TransformDefinition* retVal)

Applies to

CADFile


CADLevels

CADLevels - Read property

Description

Collection of CAD levels belonging to this item.

Syntax in Visual Basic or VBScript

CADLevels () As CADLevels

Syntax in C++

HRESULT get_CADLevels (CADLevels* retVal)

Applies to

CADFile


CADFiles

CADFiles - object

Interfaces

ICADFiles

Methods of ICADFiles

Add | method Add
Remove | method Remove

Properties of ICADFiles

BoundingBox | R/O | returns the Bounded Box of all the CAD file in the collection
Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual CADFile within the collection. Index can be an ordinal from 1 to Count or a string


BoundingBox

BoundingBox - Read property

Description

returns the Bounded Box of all the CAD file in the collection

Syntax in Visual Basic or VBScript

BoundingBox () As BoundingBox

Syntax in C++

HRESULT get_BoundingBox (BoundingBox* retVal)

Applies to

CADFiles


Count

Count - Read & Write property

Description

Indicates the number of items in the collection.

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)
HRESULT put_count (LONG Value)

Applies to

ICADEntities
CADFiles
Carriages
CMMPoints
DatumFeatureCollection
Documents
DynamicTargetResults
DynamicTargets
EdgePointResultStack
Features
GDTFeaturesLink
OffsetPoints
ParameterRPSConstraints
Parameters
ProbeRackCollection
ProbeRackSlotCollection
ProbeSensorCollection
ProbeTipCollection
ProbeToolCollection
ProbeToolConnections
Properties
ReportVariables
SequenceItems
Links
SurfacePointResultStack


Item

Item - Read property

Description

Allows random access to individual CADFile within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As CADFile

Syntax in C++

HRESULT get_Item (VARIANT Index , CADFile* retVal)

Applies to

CADFiles


Add

Add - method

Description

method Add

Syntax in Visual Basic or VBScript

Add () As CADFile

Syntax in C++

HRESULT Add (CADFile* retVal)

Parameters

Name | Description
Return Value |

Applies to

CADFiles


Remove

Remove - method

Description

method Remove

Syntax in Visual Basic or VBScript

Remove (which As Variant) As Boolean

Syntax in C++

HRESULT Remove (VARIANT which , VARIANT_BOOL* retVal)

Parameters

Name | Description
which |
Return Value |

Applies to

CADFiles


CADLevel

CADLevel - object

Interfaces

ICADLevel

Properties of ICADLevel

Active | R/W | Whether the CAD level is active for projection.
Color | R/W | The color of the CAD level
Index | R/O | Index of the CAD level.
Name | R/W | Name of the CAD level.
Visible | R/W | Visibility of the CAD level in the active view.

Collections of ICADLevel

CADObjects Collection of CAD objects belonging to this item.


Active

Active - Read & Write property

Description

Whether the CAD level is active for projection.

Syntax in Visual Basic or VBScript

Active () As Boolean

Syntax in C++

HRESULT get_Active (VARIANT_BOOL* retVal)
HRESULT put_Active (VARIANT_BOOL Value)

Applies to

CADLevel


Color

Color - Read & Write property

Description

The color of the CAD level

Syntax in Visual Basic or VBScript

Color () As Long

Syntax in C++

HRESULT get_Color (LONG* retVal)
HRESULT put_Color (LONG Value)

Applies to

CADLevel


Index

Index - Read property

Description

Index of the CAD level.

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

CADLevel


Name

Name - Read & Write property

Description

Name of the CAD level.

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)
HRESULT put_Name (BSTR Value)

Applies to

CADLevel


Visible

Visible - Read & Write property

Description

Visibility of the CAD level in the active view.

Syntax in Visual Basic or VBScript

Visible () As Boolean

Syntax in C++

HRESULT get_Visible (VARIANT_BOOL* retVal)
HRESULT put_Visible (VARIANT_BOOL Value)

Applies to

CADLevel


CADObjects

CADObjects - Read property

Description

Collection of CAD objects belonging to this item.

Syntax in Visual Basic or VBScript

CADObjects () As CADObjects

Syntax in C++

HRESULT get_CADObjects (CADObjects* retVal)

Applies to

CADLevel


CADLevels

CADLevels - object

Interfaces

ICADLevels

Methods of ICADLevels

Add | Method Add
Remove | Method Remove

Properties of ICADLevels

Count | R/O | The number of items in the collection.
IsReadOnly | R/O | Return true if this collection is read-only and cannot be modified.
Item | R/O | Allows random access to individual CAD levels within the collection. Index can be an ordinal from 1 to Count, or a string.


Count

Count - Read property

Description

The number of items in the collection.

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

CADLevels
CADObjects


IsReadOnly

IsReadOnly - Read property

Description

Return true if this collection is read-only and cannot be modified.

Syntax in Visual Basic or VBScript

IsReadOnly () As Boolean

Syntax in C++

HRESULT get_IsReadOnly (VARIANT_BOOL* retVal)

Applies to

CADLevels
CADObjects


Item

Item - Read property

Description

Allows random access to individual CAD levels within the collection. Index can be an ordinal from 1 to Count, or a string.

Syntax in Visual Basic or VBScript

Item (a_index As Variant) As CADLevel

Syntax in C++

HRESULT get_Item (VARIANT a_index , CADLevel* retVal)

Applies to

CADLevels


Add

Add - method

Description

Method Add

Syntax in Visual Basic or VBScript

Add () As CADLevel

Syntax in C++

HRESULT Add (CADLevel* retVal)

Parameters

Name | Description
Return Value |

Applies to

CADLevels


Remove

Remove - method

Description

Method Remove

Syntax in Visual Basic or VBScript

Remove (ByRef a_which As CADLevel) As Boolean

Syntax in C++

HRESULT Remove (CADLevel* a_which , VARIANT_BOOL* retVal)

Parameters

Name | Description
a_which |
Return Value |

Applies to

CADLevels


CADObject

CADObject - object

Interfaces

ICADObject

Properties of ICADObject

Index | R/O | Index of the CAD object.
Name | R/O | Name of the CAD object.
UniqueID | R/O | Unique ID of the CAD object.


Index

Index - Read property

Description

Index of the CAD object.

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

CADObject


Name

Name - Read property

Description

Name of the CAD object.

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)

Applies to

CADObject


UniqueID

UniqueID - Read property

Description

Unique ID of the CAD object.

Syntax in Visual Basic or VBScript

UniqueID () As String

Syntax in C++

HRESULT get_UniqueID (BSTR* retVal)

Applies to

CADObject


CADObjects

CADObjects - object

Interfaces

ICADObjects

Methods of ICADObjects

Assign | Assigns an object with the given name to this collection. The object will be removed from the original level.
Revert | Returns an object with the given name to the original collection. Results: S_OK - success, S_FALSE - the object was not found, E_FAIL - error.

Properties of ICADObjects

Count | R/O | The number of items in the collection.
IsReadOnly | R/O | Return true if this collection is read-only and cannot be modified.
Item | R/O | Allows random access to individual CAD objects within the collection. Index can be an ordinal from 1 to Count, or a string.


Item

Item - Read property

Description

Allows random access to individual CAD objects within the collection. Index can be an ordinal from 1 to Count, or a string.

Syntax in Visual Basic or VBScript

Item (aIndex As Variant) As CADObject

Syntax in C++

HRESULT get_Item (VARIANT aIndex , CADObject* retVal)

Applies to

CADObjects


Assign

Assign - method

Description

Assigns an object with the given name to this collection. The object will be removed from the original level.

Syntax in Visual Basic or VBScript

Assign (aName As String) As Boolean

Syntax in C++

HRESULT Assign (BSTR aName , VARIANT_BOOL* retVal)

Parameters

Name | Description
aName |
Return Value |

Applies to

CADObjects


Revert

Revert - method

Description

Returns an object with the given name to the original collection. Results: S_OK - success, S_FALSE - the object was not found, E_FAIL - error.

Syntax in Visual Basic or VBScript

Revert (aName As String) As Boolean

Syntax in C++

HRESULT Revert (BSTR aName , VARIANT_BOOL* retVal)

Parameters

Name | Description
aName |
Return Value |

Applies to

CADObjects


CADViewReportItem

CADViewReportItem - object

Interfaces

ICADViewReportItem

Methods of ICADViewReportItem

ApplyViewSettings | applies the view settings on the active CADView again
Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GenerateImage | Generates CAD View Report image
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
RecordViewSettings | records the current view settings in the item
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ICADViewReportItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterPlayWhenMeasured | R/O |
ParameterReportSettings | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ICADViewReportItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterPlayWhenMeasured

ParameterPlayWhenMeasured - Read property

Syntax in Visual Basic or VBScript

ParameterPlayWhenMeasured () As ParameterAngle

Syntax in C++

HRESULT get_ParameterPlayWhenMeasured (ParameterAngle* retVal)

Applies to

CADViewReportItem


ParameterReportSettings

ParameterReportSettings - Read property

Syntax in Visual Basic or VBScript

ParameterReportSettings () As ParameterReportSettings

Syntax in C++

HRESULT get_ParameterReportSettings (ParameterReportSettings* retVal)

Applies to

CADViewReportItem


ApplyViewSettings

ApplyViewSettings - method

Description

applies the view settings on the active CADView again

Syntax in Visual Basic or VBScript

ApplyViewSettings ()

Syntax in C++

HRESULT ApplyViewSettings ()

Applies to

CADViewStateItem


GenerateImage

GenerateImage - method

Description

Generates CAD View Report image

Syntax in Visual Basic or VBScript

GenerateImage () As String

Syntax in C++

HRESULT GenerateImage (BSTR* retVal)

Parameters

Name | Description
Return Value |

Applies to

CADViewReportItem


RecordViewSettings

RecordViewSettings - method

Description

records the current view settings in the item

Syntax in Visual Basic or VBScript

RecordViewSettings ()

Syntax in C++

HRESULT RecordViewSettings ()

Applies to

CADViewStateItem


CADViewStateItem

CADViewStateItem - object

Interfaces

ICADViewStateItem

Methods of ICADViewStateItem

ApplyViewSettings | applies the view settings on the active CADView again
Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
RecordViewSettings | records the current view settings in the item
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ICADViewStateItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ICADViewStateItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Calibration

Calibration - object

Description

Calibration

Interfaces

ICalibration

Methods of ICalibration

Calibrate invokes the User Interface Wizard that will carried out the calibration for this element

Properties of ICalibration

Admin | R/O | Internal use only, retrieve the CalibrationAdministration Object
LastCalibrationDate | R/O | returns the date when the last calibration has been performed
RequireNewCalibration | R/O | retrieves whether or not a new Calibration is requested for this element, before it can be used accuratly
Status | R/O | returns the calibration state of this element


Admin

Admin - Read property

Description

Internal use only, retrieve the CalibrationAdministration Object

Syntax in Visual Basic or VBScript

Admin () As CalibrationAdmin

Syntax in C++

HRESULT get_Admin (CalibrationAdmin* retVal)

Applies to

Calibration


LastCalibrationDate

LastCalibrationDate - Read property

Description

returns the date when the last calibration has been performed

Syntax in Visual Basic or VBScript

LastCalibrationDate () As ??? 7 ???

Syntax in C++

HRESULT get_LastCalibrationDate (??? 7 ???* retVal)

Applies to

Calibration


RequireNewCalibration

RequireNewCalibration - Read property

Description

retrieves whether or not a new Calibration is requested for this element, before it can be used accuratly

Syntax in Visual Basic or VBScript

RequireNewCalibration () As Boolean

Syntax in C++

HRESULT get_RequireNewCalibration (VARIANT_BOOL* retVal)

Applies to

Calibration


Status

Status - Read property

Description

returns the calibration state of this element

Syntax in Visual Basic or VBScript

Status () As CALIBRATIONSTATE

Syntax in C++

HRESULT get_Status (CALIBRATIONSTATE* retVal)

Applies to

Calibration


Calibrate

Calibrate - method

Description

invokes the User Interface Wizard that will carried out the calibration for this element

Syntax in Visual Basic or VBScript

Calibrate (CMMProtocol As Variant)

Syntax in C++

HRESULT Calibrate (VARIANT CMMProtocol)

Parameters

Name | Description
CMMProtocol |

Applies to

Calibration


CalibrationAdmin

CalibrationAdmin - object

Description

CalibrationAdmin Class

Interfaces

ICalibrationAdmin

Methods of ICalibrationAdmin

SetCalibrationData internal use only: set the data that will be used to perform the calibration, the content depends on which item is beeing calibrated

Properties of ICalibrationAdmin

Status | W/O | internal use only: set the calibration state
ThreadID | R/O |


Status

Status - Write property

Description

internal use only: set the calibration state

Syntax in Visual Basic or VBScript

Status (Value As CALIBRATIONSTATE)

Syntax in C++

HRESULT put_Status (CALIBRATIONSTATE Value)

Applies to

CalibrationAdmin


ThreadID

ThreadID - Read property

Syntax in Visual Basic or VBScript

ThreadID () As Long

Syntax in C++

HRESULT get_ThreadID (LONG* retVal)

Applies to

CalibrationAdmin
Carriage
DatumSphere
IndexableProbeHead
ManualProbeHead
IProbeHead
ProbeRack
ProbeRackSlot
IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
probeTip
ProbeTool
ProbeToolConnection
ManualToolChanger


SetCalibrationData

SetCalibrationData - method

Description

internal use only: set the data that will be used to perform the calibration, the content depends on which item is beeing calibrated

Syntax in Visual Basic or VBScript

SetCalibrationData (data As Variant)

Syntax in C++

HRESULT SetCalibrationData (VARIANT data)

Parameters

Name | Description
data |

Applies to

CalibrationAdmin


Carriage

Carriage - object

Description

Carriage Class

Interfaces

ICarriage

Events

ActiveSensorChanged | fired after the active sensor on the probe Head has changed
ActiveTipChanged | fired after the active tip on the probe Head has changed
ActiveToolChanged | fired after the active tool mounted on the probe Head has changed
CalibrationStatusChanged | fired when the status of the calibration changed for the given item : item could be head,sensor,or tip
ConfigurationChanged | fired when the configuration of the carriage has changed
ExtendsChanged | fired when the extends of the carriage has changed
Loaded | fired when the carriage has been persisted back from a storage
ProbeHeadChanged | fired after the probe Head has changed
ProbeHeadPositionChanged | fired when the position of the probe head has changed
ProbeTipAdded | fired when a probe tip has been added
ProbeTipDeleted | fired when a probe tip has been deleted
TransactionEnded | fired when a transaction is committed or rolled back
TransactionStarted | fired when we start a transaction

Methods of ICarriage

Commit | commit the changes made
Compensate | Apply the probe offset compensation to the give coordinates according the current active tip
FillIdentityCard | fill the node with the identity card of this item
FindTip |
Rollback | rollback to the state we were in at the start of this transaction
StartTransaction | creates a start point which we can rollback to
Uncompensate | Undo the effect of the probe offset compensation on the give coordinates according the current active tip

Properties of ICarriage

_ID | R/W | INTERNAL USE ONLY
ActiveSensor | R/W | sets/retrieves the active sensor,if necessary a probe tool change will happen, the active tip is not guaranty to be correctly set at the end
ActiveTip | R/W | sets/retrieves the active probe tip,ProbeTip could be a FULLQUALIFIED name for the type, in this case a probe tool operation may be executed.
ActiveTool | R/W | sets/retrieves the active probe tool,ProbeTool could be a 0-based index , a string representing the name of the tool or a pointer to a tool, in this case, the tool must belong to the collection
Calibration | R/O | retrieves the calibration object
Configuration | R/W | retreives/sets the Carriage configuration
DatumSphere | R/O | sets/retrieves the active Datum Sphere used to calibrate sensor on this carriage
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
MaxPoint | R/O | R/W returns the Max Point of the carriage volume
MinPoint | R/O | R/W returns the Min Point of the carriage volume
Position | R/O | Position of the carriage relative to the first carriage
ProbeDatabase | R/O | retrieves the parent probedatabase
ProbeHead | R/W | sets/retrieves the probeHead
ProbeHeadMountingDirection | R/O | R/W returns the direction of the probe head mounting device ( usually Z-)
Protocol | R/O | sets/retrieves the protocol that actually controls this carriage
ThreadID | R/O |
ToolChanger | R/W | retrieves/sets the tool changer
TransactionState | R/O | are we currently carrying out a transaction
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections of ICarriage

DatumFeatureCollection | retrieves the datum feature collection available on this carriage
ProbeTipCollection | retrieves the probe tip collection
ProbeToolCollection | retrieves the probe tool collection associated with this carriage
RackCollection | retrieves the rack collection associated with this carriage


_ID

_ID - Read & Write property

Description

INTERNAL USE ONLY

Syntax in Visual Basic or VBScript

_ID () As TKIND_RECORD

Syntax in C++

HRESULT get__ID (TKIND_RECORD* retVal)
HRESULT put__ID (TKIND_RECORD Value)

Applies to

Carriage
DatumSphere
IndexableProbeHead
ManualProbeHead
IProbeHead
ProbeRack
ProbeRackSlot
IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
probeTip
ProbeTool
ProbeToolConnection
ManualToolChanger


ActiveSensor

ActiveSensor - Read & Write property

Description

sets/retrieves the active sensor,if necessary a probe tool change will happen, the active tip is not guaranty to be correctly set at the end

Syntax in Visual Basic or VBScript

ActiveSensor () As IProbeSensor

Syntax in C++

HRESULT get_ActiveSensor (IProbeSensor* retVal)
HRESULT put_ActiveSensor (VARIANT Value)

Applies to

Carriage


ActiveTip

ActiveTip - Read & Write property

Description

sets/retrieves the active probe tip,ProbeTip could be a FULLQUALIFIED name for the type, in this case a probe tool operation may be executed.

Syntax in Visual Basic or VBScript

ActiveTip () As probeTip

Syntax in C++

HRESULT get_ActiveTip (probeTip* retVal)
HRESULT put_ActiveTip (VARIANT Value)

Applies to

Carriage


ActiveTool

ActiveTool - Read & Write property

Description

sets/retrieves the active probe tool,ProbeTool could be a 0-based index , a string representing the name of the tool or a pointer to a tool, in this case, the tool must belong to the collection

Syntax in Visual Basic or VBScript

ActiveTool () As ProbeTool

Syntax in C++

HRESULT get_ActiveTool (ProbeTool* retVal)
HRESULT put_ActiveTool (VARIANT Value)

Applies to

Carriage


Calibration

Calibration - Read property

Description

retrieves the calibration object

Syntax in Visual Basic or VBScript

Calibration () As Calibration

Syntax in C++

HRESULT get_Calibration (Calibration* retVal)

Applies to

Carriage
DatumSphere
IndexableProbeHead
ManualProbeHead
IProbeHead
ProbeRack
ProbeRackSlot
IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
probeTip
ProbeTool
ManualToolChanger


Configuration

Configuration - Read & Write property

Description

retreives/sets the Carriage configuration

Syntax in Visual Basic or VBScript

Configuration () As String

Syntax in C++

HRESULT get_Configuration (BSTR* retVal)
HRESULT put_Configuration (BSTR Value)

Applies to

Carriage


DatumSphere

DatumSphere - Read property

Description

sets/retrieves the active Datum Sphere used to calibrate sensor on this carriage

Syntax in Visual Basic or VBScript

DatumSphere () As DatumSphere

Syntax in C++

HRESULT get_DatumSphere (DatumSphere* retVal)

Applies to

Carriage


FullName

FullName - Read property

Description

retrieves the full name of this object ( this includes the identifiers of the owner object

Syntax in Visual Basic or VBScript

FullName () As String

Syntax in C++

HRESULT get_FullName (BSTR* retVal)

Applies to

Carriage
DatumSphere
IndexableProbeHead
ManualProbeHead
IProbeHead
ProbeRack
ProbeRackSlot
IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
probeTip
ProbeTool
ProbeToolConnection
ManualToolChanger


ID

ID - Read property

Description

sets the internal id of the object that identifies this item unicaly

Syntax in Visual Basic or VBScript

ID () As String

Syntax in C++

HRESULT get_ID (BSTR* retVal)

Applies to

Carriage
DatumSphere
IndexableProbeHead
ManualProbeHead
IProbeHead
ProbeRack
ProbeRackSlot
IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
probeTip
ProbeTool
ProbeToolConnection
ManualToolChanger


IdentityCard

IdentityCard - Read property

Description

retrieves the identity card for the item

Syntax in Visual Basic or VBScript

IdentityCard () As String

Syntax in C++

HRESULT get_IdentityCard (BSTR* retVal)

Applies to

Carriage
DatumSphere
IndexableProbeHead
ManualProbeHead
IProbeHead
ProbeRack
ProbeRackSlot
IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
probeTip
ProbeTool
ProbeToolConnection
ManualToolChanger


InterfaceType

InterfaceType - Read property

Syntax in Visual Basic or VBScript

InterfaceType () As PDBOBJECTTYPE

Syntax in C++

HRESULT get_InterfaceType (PDBOBJECTTYPE* retVal)

Applies to

Carriage
DatumSphere
IndexableProbeHead
ManualProbeHead
IProbeHead
ProbeRack
ProbeRackSlot
IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
probeTip
ProbeTool
ProbeToolConnection
ManualToolChanger


MaxPoint

MaxPoint - Read property

Description

R/W returns the Max Point of the carriage volume

Syntax in Visual Basic or VBScript

MaxPoint () As Point3D

Syntax in C++

HRESULT get_MaxPoint (Point3D* retVal)

Applies to

Carriage


MinPoint

MinPoint - Read property

Description

R/W returns the Min Point of the carriage volume

Syntax in Visual Basic or VBScript

MinPoint () As Point3D

Syntax in C++

HRESULT get_MinPoint (Point3D* retVal)

Applies to

Carriage


Position

Position - Read property

Description

Position of the carriage relative to the first carriage

Syntax in Visual Basic or VBScript

Position () As ITransform2

Syntax in C++

HRESULT get_Position (ITransform2* retVal)

Applies to

Carriage


ProbeDatabase

ProbeDatabase - Read property

Description

retrieves the parent probedatabase

Syntax in Visual Basic or VBScript

ProbeDatabase () As ProbeDatabase

Syntax in C++

HRESULT get_ProbeDatabase (ProbeDatabase* retVal)

Applies to

Carriage


ProbeHead

ProbeHead - Read & Write property

Description

sets/retrieves the probeHead

Syntax in Visual Basic or VBScript

ProbeHead () As IProbeHead

Syntax in C++

HRESULT get_ProbeHead (IProbeHead* retVal)
HRESULT put_ProbeHead (IProbeHead* Value)

Applies to

Carriage


ProbeHeadMountingDirection

ProbeHeadMountingDirection - Read property

Description

R/W returns the direction of the probe head mounting device ( usually Z-)

Syntax in Visual Basic or VBScript

ProbeHeadMountingDirection () As UnitVector3D

Syntax in C++

HRESULT get_ProbeHeadMountingDirection (UnitVector3D* retVal)

Applies to

Carriage


Protocol

Protocol - Read property

Description

sets/retrieves the protocol that actually controls this carriage

Syntax in Visual Basic or VBScript

Protocol () As CMMProtocol_dummy

Syntax in C++

HRESULT get_Protocol (CMMProtocol_dummy* retVal)

Applies to

Carriage
ProbeDatabase
SimpleProbeDatabase


ToolChanger

ToolChanger - Read & Write property

Description

retrieves/sets the tool changer

Syntax in Visual Basic or VBScript

ToolChanger () As ManualToolChanger

Syntax in C++

HRESULT get_ToolChanger (ManualToolChanger* retVal)
HRESULT put_ToolChanger (ManualToolChanger* Value)

Applies to

Carriage


TransactionState

TransactionState - Read property

Description

are we currently carrying out a transaction

Syntax in Visual Basic or VBScript

TransactionState () As Boolean

Syntax in C++

HRESULT get_TransactionState (VARIANT_BOOL* retVal)

Applies to

Carriage


UserName

UserName - Read & Write property

Description

sets/retrieves the user name of the object, this name could be freely defined by the user

Syntax in Visual Basic or VBScript

UserName () As String

Syntax in C++

HRESULT get_UserName (BSTR* retVal)
HRESULT put_UserName (BSTR Value)

Applies to

Carriage
DatumSphere
IndexableProbeHead
ManualProbeHead
IProbeHead
ProbeRack
ProbeRackSlot
IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
probeTip
ProbeTool
ProbeToolConnection
ManualToolChanger


ActiveSensorChanged

ActiveSensorChanged - event

Description

fired after the active sensor on the probe Head has changed

Syntax in Visual Basic or VBScript

ActiveSensorChanged (pOld As Object , pNew As Object)

Syntax in C++

HRESULT ActiveSensorChanged (IDispatch* pOld , IDispatch* pNew)

Parameters

Name | Description
pOld |
pNew |

Applies to

Carriage


ActiveTipChanged

ActiveTipChanged - event

Description

fired after the active tip on the probe Head has changed

Syntax in Visual Basic or VBScript

ActiveTipChanged (pOld As Object , pNew As Object)

Syntax in C++

HRESULT ActiveTipChanged (IDispatch* pOld , IDispatch* pNew)

Parameters

Name | Description
pOld |
pNew |

Applies to

Carriage


ActiveToolChanged

ActiveToolChanged - event

Description

fired after the active tool mounted on the probe Head has changed

Syntax in Visual Basic or VBScript

ActiveToolChanged (pOld As Object , pNew As Object)

Syntax in C++

HRESULT ActiveToolChanged (IDispatch* pOld , IDispatch* pNew)

Parameters

Name | Description
pOld |
pNew |

Applies to

Carriage


CalibrationStatusChanged

CalibrationStatusChanged - event

Description

fired when the status of the calibration changed for the given item : item could be head,sensor,or tip

Syntax in Visual Basic or VBScript

CalibrationStatusChanged (item As Object)

Syntax in C++

HRESULT CalibrationStatusChanged (IDispatch* item)

Parameters

Name | Description
item |

Applies to

Carriage


Commit

Commit - method

Description

commit the changes made

Syntax in Visual Basic or VBScript

Commit ()

Syntax in C++

HRESULT Commit ()

Applies to

Carriage


Compensate

Compensate - method

Description

Apply the probe offset compensation to the give coordinates according the current active tip

Syntax in Visual Basic or VBScript

Compensate (ByRef pointOrVector As Variant)

Syntax in C++

HRESULT Compensate (VARIANT* pointOrVector)

Parameters

Name | Description
pointOrVector |

Applies to

Carriage


ConfigurationChanged

ConfigurationChanged - event

Description

fired when the configuration of the carriage has changed

Syntax in Visual Basic or VBScript

ConfigurationChanged ()

Syntax in C++

HRESULT ConfigurationChanged ()

Applies to

Carriage


ExtendsChanged

ExtendsChanged - event

Description

fired when the extends of the carriage has changed

Syntax in Visual Basic or VBScript

ExtendsChanged ()

Syntax in C++

HRESULT ExtendsChanged ()

Applies to

Carriage


FillIdentityCard

FillIdentityCard - method

Description

fill the node with the identity card of this item

Syntax in Visual Basic or VBScript

FillIdentityCard (ByRef pNode As IXMLDOMNode)

Syntax in C++

HRESULT FillIdentityCard (IXMLDOMNode* pNode)

Parameters

Name | Description
pNode |

Applies to

IProbeHead


FindTip

FindTip - method

Syntax in Visual Basic or VBScript

FindTip (VCARD As String , bStrict As Boolean , ByRef retVal As probeTip)

Syntax in C++

HRESULT FindTip (BSTR VCARD , VARIANT_BOOL bStrict , probeTip* retVal)

Parameters

Name | Description
VCARD |
bStrict |
retVal |

Applies to

Carriage


Loaded

Loaded - event

Description

fired when the carriage has been persisted back from a storage

Syntax in Visual Basic or VBScript

Loaded ()

Syntax in C++

HRESULT Loaded ()

Applies to

Carriage


ProbeHeadChanged

ProbeHeadChanged - event

Description

fired after the probe Head has changed

Syntax in Visual Basic or VBScript

ProbeHeadChanged (pOld As Object , pNew As Object)

Syntax in C++

HRESULT ProbeHeadChanged (IDispatch* pOld , IDispatch* pNew)

Parameters

Name | Description
pOld |
pNew |

Applies to

Carriage


ProbeHeadPositionChanged

ProbeHeadPositionChanged - event

Description

fired when the position of the probe head has changed

Syntax in Visual Basic or VBScript

ProbeHeadPositionChanged (item As Object)

Syntax in C++

HRESULT ProbeHeadPositionChanged (IDispatch* item)

Parameters

Name | Description
item |

Applies to

Carriage


ProbeTipAdded

ProbeTipAdded - event

Description

fired when a probe tip has been added

Syntax in Visual Basic or VBScript

ProbeTipAdded (pDispProbeTip As Object)

Syntax in C++

HRESULT ProbeTipAdded (IDispatch* pDispProbeTip)

Parameters

Name | Description
pDispProbeTip |

Applies to

Carriage


ProbeTipDeleted

ProbeTipDeleted - event

Description

fired when a probe tip has been deleted

Syntax in Visual Basic or VBScript

ProbeTipDeleted (pDispProbeTip As Object)

Syntax in C++

HRESULT ProbeTipDeleted (IDispatch* pDispProbeTip)

Parameters

Name | Description
pDispProbeTip |

Applies to

Carriage


Rollback

Rollback - method

Description

rollback to the state we were in at the start of this transaction

Syntax in Visual Basic or VBScript

Rollback ()

Syntax in C++

HRESULT Rollback ()

Applies to

Carriage


StartTransaction

StartTransaction - method

Description

creates a start point which we can rollback to

Syntax in Visual Basic or VBScript

StartTransaction ()

Syntax in C++

HRESULT StartTransaction ()

Applies to

Carriage


TransactionEnded

TransactionEnded - event

Description

fired when a transaction is committed or rolled back

Syntax in Visual Basic or VBScript

TransactionEnded (ByRef committed As Boolean)

Syntax in C++

HRESULT TransactionEnded (VARIANT_BOOL* committed)

Parameters

Name | Description
committed |

Applies to

Carriage


TransactionStarted

TransactionStarted - event

Description

fired when we start a transaction

Syntax in Visual Basic or VBScript

TransactionStarted ()

Syntax in C++

HRESULT TransactionStarted ()

Applies to

Carriage


Uncompensate

Uncompensate - method

Description

Undo the effect of the probe offset compensation on the give coordinates according the current active tip

Syntax in Visual Basic or VBScript

Uncompensate (ByRef pointOrVector As Variant)

Syntax in C++

HRESULT Uncompensate (VARIANT* pointOrVector)

Parameters

Name | Description
pointOrVector |

Applies to

Carriage


DatumFeatureCollection

DatumFeatureCollection - Read property

Description

retrieves the datum feature collection available on this carriage

Syntax in Visual Basic or VBScript

DatumFeatureCollection () As DatumFeatureCollection

Syntax in C++

HRESULT get_DatumFeatureCollection (DatumFeatureCollection* retVal)

Applies to

Carriage


ProbeTipCollection

ProbeTipCollection - Read property

Description

retrieves the probe tip collection

Syntax in Visual Basic or VBScript

ProbeTipCollection () As ProbeTipCollection

Syntax in C++

HRESULT get_ProbeTipCollection (ProbeTipCollection* retVal)

Applies to

Carriage


ProbeToolCollection

ProbeToolCollection - Read property

Description

retrieves the probe tool collection associated with this carriage

Syntax in Visual Basic or VBScript

ProbeToolCollection () As ProbeToolCollection

Syntax in C++

HRESULT get_ProbeToolCollection (ProbeToolCollection* retVal)

Applies to

Carriage


RackCollection

RackCollection - Read property

Description

retrieves the rack collection associated with this carriage

Syntax in Visual Basic or VBScript

RackCollection () As ProbeRackCollection

Syntax in C++

HRESULT get_RackCollection (ProbeRackCollection* retVal)

Applies to

Carriage


Carriages

Carriages - object

Description

Carriages Class

Interfaces

ICarriages

Events

Add | fired after a element has been inserted into the collection
AfterDelete | fired after a element has been removed from the collection
Changed | fired after a element definition has changed
Delete | fired before a element will be removed from the collection

Methods of ICarriages

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties of ICarriages

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


item

item - Read property

Description

Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string

Syntax in Visual Basic or VBScript

item (index As Variant) As probeTip

Syntax in C++

HRESULT get_item (VARIANT index , probeTip* retVal)

Applies to

Carriages
DatumFeatureCollection
ProbeRackCollection
ProbeRackSlotCollection
ProbeSensorCollection
ProbeTipCollection
ProbeToolCollection
ProbeToolConnections


Add

Add - event

Description

fired after a element has been inserted into the collection

Syntax in Visual Basic or VBScript

Add (pItem As Object)

Syntax in C++

HRESULT Add (IDispatch* pItem)

Parameters

Name | Description
pItem |

Applies to

Carriages


Add

Add - method

Description

method Add : add an item to the collection

Syntax in Visual Basic or VBScript

Add (ByRef pCarriage As Carriage)

Syntax in C++

HRESULT Add (Carriage* pCarriage)

Parameters

Name | Description
pCarriage |

Applies to

Carriages


AfterDelete

AfterDelete - event

Description

fired after a element has been removed from the collection

Syntax in Visual Basic or VBScript

AfterDelete (pItem As Object)

Syntax in C++

HRESULT AfterDelete (IDispatch* pItem)

Parameters

Name | Description
pItem |

Applies to

Carriages


Changed

Changed - event

Description

fired after a element definition has changed

Syntax in Visual Basic or VBScript

Changed (pItem As Object)

Syntax in C++

HRESULT Changed (IDispatch* pItem)

Parameters

Name | Description
pItem |

Applies to

Carriages


Delete

Delete - method

Description

method Delete : delete an item from the collection

Syntax in Visual Basic or VBScript

Delete (Sensor As Variant)

Syntax in C++

HRESULT Delete (VARIANT Sensor)

Parameters

Name | Description
Sensor |

Applies to

ProbeToolCollection


Delete

Delete - event

Description

fired before a element will be removed from the collection

Syntax in Visual Basic or VBScript

Delete (pItem As Object)

Syntax in C++

HRESULT Delete (IDispatch* pItem)

Parameters

Name | Description
pItem |

Applies to

Carriages


CMMBoolParameter

CMMBoolParameter - object

Description

CMMBoolParameter Class

Interfaces

ICMMBoolParameter

Events

OnChanged | method OnChanged
OnChangeRequested | method OnChangeRequested

Methods of ICMMBoolParameter

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
IsValidValue | check if the value provided is suitable for this parameter

Properties of ICMMBoolParameter

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter


Category

Category - Read & Write property

Description

Get the current category name

Syntax in Visual Basic or VBScript

Category () As String

Syntax in C++

HRESULT get_Category (BSTR* retVal)
HRESULT put_Category (BSTR Value)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


Description - Read & Write property

Description

Description of the parameter

Syntax in Visual Basic or VBScript

Description () As String

Syntax in C++

HRESULT get_Description (BSTR* retVal)
HRESULT put_Description (BSTR Value)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


isDMIS

isDMIS - Read property

Description

Is this parameter a DMIS Parameter

Syntax in Visual Basic or VBScript

isDMIS () As Boolean

Syntax in C++

HRESULT get_isDMIS (VARIANT_BOOL* retVal)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


IsUIAccessible

IsUIAccessible - Read & Write property

Description

Get the current IsUIAccessible flag

Syntax in Visual Basic or VBScript

IsUIAccessible () As Long

Syntax in C++

HRESULT get_IsUIAccessible (LONG* retVal)
HRESULT put_IsUIAccessible (LONG Value)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


Name

Name - Read property

Description

name of the parameter

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


PackedValue

PackedValue - Read property

Description

PackValue

Syntax in Visual Basic or VBScript

PackedValue (unit As Variant) As String

Syntax in C++

HRESULT get_PackedValue (VARIANT unit , BSTR* retVal)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


ParameterType

ParameterType - Read property

Description

type of this parameter

Syntax in Visual Basic or VBScript

ParameterType () As ParameterType

Syntax in C++

HRESULT get_ParameterType (ParameterType* retVal)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


ReadOnly

ReadOnly - Read & Write property

Description

ReadOnly

Syntax in Visual Basic or VBScript

ReadOnly () As Boolean

Syntax in C++

HRESULT get_ReadOnly (VARIANT_BOOL* retVal)
HRESULT put_ReadOnly (VARIANT_BOOL Value)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


UIName

UIName - Read & Write property

Description

User defined (translated) name of the parameter

Syntax in Visual Basic or VBScript

UIName () As String

Syntax in C++

HRESULT get_UIName (BSTR* retVal)
HRESULT put_UIName (BSTR Value)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


Value

Value - Read & Write property

Description

value of the parameter

Syntax in Visual Basic or VBScript

Value () As Variant

Syntax in C++

HRESULT get_Value (VARIANT* retVal)
HRESULT put_Value (VARIANT Value)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


VCARD

VCARD - Read property

Description

Get the VCARD of the parameter

Syntax in Visual Basic or VBScript

VCARD () As String

Syntax in C++

HRESULT get_VCARD (BSTR* retVal)

Applies to

CMMBoolParameter
CMMFloatParameter
ICMMParameter
CMMPlaneParameter
CMMPointParameter
CMMVectorParameter


ApplyPackedValue

ApplyPackedValue - method

Description

modify the value and/or definition of this parameter using a packed String

Syntax in Visual Basic or VBScript

ApplyPackedValue (Value As Variant , option As ApplyPackValueOption)

Syntax in C++

HRESULT ApplyPackedValue (VARIANT Value , ApplyPackValueOption option)

Parameters

Name | Description
Value |
option |

Applies to

ICMMParameter


Clone

Clone - method

Description

Clone : create an exact copy of this object and return a pointer to it

Syntax in Visual Basic or VBScript

Clone () As ICMMParameter

Syntax in C++

HRESULT Clone (ICMMParameter* retVal)

Parameters

Name | Description
Return Value |

Applies to

ICMMParameter


IsValidValue

IsValidValue - method

Description

check if the value provided is suitable for this parameter

Syntax in Visual Basic or VBScript

IsValidValue (pVal As Variant) As Boolean

Syntax in C++

HRESULT IsValidValue (VARIANT pVal , VARIANT_BOOL* retVal)

Parameters

Name | Description
pVal |
Return Value |

Applies to

ICMMParameter


OnChanged

OnChanged - event

Description

method OnChanged

Syntax in Visual Basic or VBScript

OnChanged (flag As Long)

Syntax in C++

HRESULT OnChanged (LONG flag)

Parameters

Name | Description
flag |

Applies to

CMMBoolParameter


OnChangeRequested

OnChangeRequested - event

Description

method OnChangeRequested

Syntax in Visual Basic or VBScript

OnChangeRequested (newValue As Variant , ByRef bAccepted As Variant)

Syntax in C++

HRESULT OnChangeRequested (VARIANT newValue , VARIANT* bAccepted)

Parameters

Name | Description
newValue |
bAccepted |

Applies to

CMMBoolParameter


CMMCNCController

CMMCNCController - object

Description

CMMCNCController class

Interfaces

ICMMCNCController

Events

CNCControllingLockChanged | Fired when a CNC controlling object locks or unlocks its CNC control
ContactPoint | method ContactPoint
ContactPointCalibration | method ContactPointCalibration
EnableModeless | Fired to request the client to disable or enable its main window and other modeless dialogs
IntermediatePoint | method IntermediatePoint
OnCalibrationModeChanged | OnCalibration Mode change
OnCMMHomed | method OnCMMHomed : the CMM homed flag is now set
OnCMMParameterChanged | method OnCMMParamerChanged
OnCNCStatusChanged | method OnCNCStatusChanged
OnCompletion | method OnCNCError
OnConnectionChanged | method Connect
OnReadyForCommand | method OnReadyForCommand: call to the Protocol Object can be made here
OnRefMarks | method OnRefMarks
PreTouchIJKModeChanged | method PreTouchIJKModeChanged
ProbeDatabaseChanged | Fired by the protocol if the probe database object changes
ProbeTipChanged | Fired by the protocol for convenience when the probe database fires its ProbeTipChanged event
RemoteMouseChanged | Fired when the protocol's remote mouse state changes
RequestDisconnect | Fired to request consent to disconnect
TransactionChanged | Fired by the protocol when it has been informed that a transaction has started or stopped
VirtualCommand | method VirtualCommand
VirtualCommandCalibration | method VirtualCommandCalibration

Methods of ICMMCNCController

CancelCurrentCNCAction | method CancelCurrentCNCAction
EndQueue |
Home | Home or Reset the CMM Device
LockCNCControl | Locks the protocol to be controlled by this object alone. Must be called successfully before controlling calls will succeed.
MeasureTo | Perform a composite measure move.
MultipointMove | MultipointMove
RapidMoveTo | Perform a rapid move from the current position to the new position.
RapidMoveWithMachineOrientation | Perform a rapid move from the current position/orientation to the new position/orientation.
SafeMoveTo | Perform a safe move from the current position to the new position.
ScanMove | Perform a Scan move.
StartQueue |
TouchPoint | method TouchPoint
UnlockCNCControl | Unlocks this object's control of the protocol object for use by other controllers.

Properties of ICMMCNCController

CMMProtocol | R/O | The protocol object being controlled by this object.
HasCNCControlLock | R/O | Whether this object has a CNC controlling lock.
MachineOrientation | R/O | Get the current machine orientation.
QueueComplete | R/O | A command queue has completed execution.
QueuedCount | R/O | Number of commands in queue which have yet to complete execution.
Queuing | R/O | Protocol is building a command queue.


CMMProtocol

CMMProtocol - Read property

Description

The protocol object being controlled by this object.

Syntax in Visual Basic or VBScript

CMMProtocol () As CMMProtocol_dummy

Syntax in C++

HRESULT get_CMMProtocol (CMMProtocol_dummy* retVal)

Applies to

CMMCNCController


HasCNCControlLock

HasCNCControlLock - Read property

Description

Whether this object has a CNC controlling lock.

Syntax in Visual Basic or VBScript

HasCNCControlLock () As Boolean

Syntax in C++

HRESULT get_HasCNCControlLock (VARIANT_BOOL* retVal)

Applies to

CMMCNCController


MachineOrientation

MachineOrientation - Read property

Description

Get the current machine orientation.

Syntax in Visual Basic or VBScript

MachineOrientation () As MachineOrientationData

Syntax in C++

HRESULT get_MachineOrientation (MachineOrientationData* retVal)

Applies to

CMMCNCController


QueueComplete

QueueComplete - Read property

Description

A command queue has completed execution.

Syntax in Visual Basic or VBScript

QueueComplete () As Boolean

Syntax in C++

HRESULT get_QueueComplete (VARIANT_BOOL* retVal)

Applies to

CMMCNCController


QueuedCount

QueuedCount - Read property

Description

Number of commands in queue which have yet to complete execution.

Syntax in Visual Basic or VBScript

QueuedCount () As Long

Syntax in C++

HRESULT get_QueuedCount (LONG* retVal)

Applies to

CMMCNCController


Queuing

Queuing - Read property

Description

Protocol is building a command queue.

Syntax in Visual Basic or VBScript

Queuing () As Boolean

Syntax in C++

HRESULT get_Queuing (VARIANT_BOOL* retVal)

Applies to

CMMCNCController


CancelCurrentCNCAction

CancelCurrentCNCAction - method

Description

method CancelCurrentCNCAction

Syntax in Visual Basic or VBScript

CancelCurrentCNCAction ()

Syntax in C++

HRESULT CancelCurrentCNCAction ()

Applies to

CMMProtocol_dummy


CNCControllingLockChanged

CNCControllingLockChanged - event

Description

Fired when a CNC controlling object locks or unlocks its CNC control

Syntax in Visual Basic or VBScript

CNCControllingLockChanged (Locked As Boolean)

Syntax in C++

HRESULT CNCControllingLockChanged (VARIANT_BOOL Locked)

Parameters

Name | Description
Locked |

Applies to

CMMCNCController


ContactPoint

ContactPoint - event

Description

method ContactPoint

Syntax in Visual Basic or VBScript

ContactPoint (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double)

Syntax in C++

HRESULT ContactPoint (double X , double Y , double Z , double I , double J , double K)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |

Applies to

CMMCNCController


ContactPointCalibration

ContactPointCalibration - event

Description

method ContactPointCalibration

Syntax in Visual Basic or VBScript

ContactPointCalibration (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double)

Syntax in C++

HRESULT ContactPointCalibration (double X , double Y , double Z , double I , double J , double K)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |

Applies to

CMMCNCController


EnableModeless

EnableModeless - event

Description

Fired to request the client to disable or enable its main window and other modeless dialogs

Syntax in Visual Basic or VBScript

EnableModeless (Enable As Boolean)

Syntax in C++

HRESULT EnableModeless (VARIANT_BOOL Enable)

Parameters

Name | Description
Enable |

Applies to

CMMCNCController


EndQueue

EndQueue - method

Syntax in Visual Basic or VBScript

EndQueue ()

Syntax in C++

HRESULT EndQueue ()

Applies to

CMMCNCController


Home

Home - method

Description

Home or Reset the CMM Device

Syntax in Visual Basic or VBScript

Home () As status

Syntax in C++

HRESULT Home (status* retVal)

Parameters

Name | Description
Return Value |

Applies to

CMMCNCController


IntermediatePoint

IntermediatePoint - event

Description

method IntermediatePoint

Syntax in Visual Basic or VBScript

IntermediatePoint (X As Double , Y As Double , Z As Double)

Syntax in C++

HRESULT IntermediatePoint (double X , double Y , double Z)

Parameters

Name | Description
X |
Y |
Z |

Applies to

CMMCNCController


LockCNCControl

LockCNCControl - method

Description

Locks the protocol to be controlled by this object alone. Must be called successfully before controlling calls will succeed.

Syntax in Visual Basic or VBScript

LockCNCControl ()

Syntax in C++

HRESULT LockCNCControl ()

Applies to

CMMCNCController


MeasureTo

MeasureTo - method

Description

Perform a composite measure move.

Syntax in Visual Basic or VBScript

MeasureTo (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double) As status

Syntax in C++

HRESULT MeasureTo (double X , double Y , double Z , double I , double J , double K , status* retVal)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |
Return Value |

Applies to

CMMCNCController


MultipointMove

MultipointMove - method

Description

MultipointMove

Syntax in Visual Basic or VBScript

MultipointMove (arrayofPoint As Variant) As status

Syntax in C++

HRESULT MultipointMove (VARIANT arrayofPoint , status* retVal)

Parameters

Name | Description
arrayofPoint |
Return Value |

Applies to

CMMCNCController


OnCalibrationModeChanged

OnCalibrationModeChanged - event

Description

OnCalibration Mode change

Syntax in Visual Basic or VBScript

OnCalibrationModeChanged (bCalibrationMode As Boolean)

Syntax in C++

HRESULT OnCalibrationModeChanged (VARIANT_BOOL bCalibrationMode)

Parameters

Name | Description
bCalibrationMode |

Applies to

CMMCNCController


OnCMMHomed

OnCMMHomed - event

Description

method OnCMMHomed : the CMM homed flag is now set

Syntax in Visual Basic or VBScript

OnCMMHomed (bHomed As Boolean)

Syntax in C++

HRESULT OnCMMHomed (VARIANT_BOOL bHomed)

Parameters

Name | Description
bHomed |

Applies to

CMMCNCController


OnCMMParameterChanged

OnCMMParameterChanged - event

Description

method OnCMMParamerChanged

Syntax in Visual Basic or VBScript

OnCMMParameterChanged (ByRef pParameter As ICMMParameter)

Syntax in C++

HRESULT OnCMMParameterChanged (ICMMParameter* pParameter)

Parameters

Name | Description
pParameter |

Applies to

CMMCNCController


OnCNCStatusChanged

OnCNCStatusChanged - event

Description

method OnCNCStatusChanged

Syntax in Visual Basic or VBScript

OnCNCStatusChanged (status As CNCSTATUS)

Syntax in C++

HRESULT OnCNCStatusChanged (CNCSTATUS status)

Parameters

Name | Description
status |

Applies to

CMMCNCController


OnCompletion

OnCompletion - event

Description

method OnCNCError

Syntax in Visual Basic or VBScript

OnCompletion (err As CNCCOMPLETION)

Syntax in C++

HRESULT OnCompletion (CNCCOMPLETION err)

Parameters

Name | Description
err |

Applies to

CMMCNCController


OnConnectionChanged

OnConnectionChanged - event

Description

method Connect

Syntax in Visual Basic or VBScript

OnConnectionChanged (bConnected As Boolean)

Syntax in C++

HRESULT OnConnectionChanged (VARIANT_BOOL bConnected)

Parameters

Name | Description
bConnected |

Applies to

CMMCNCController


OnReadyForCommand

OnReadyForCommand - event

Description

method OnReadyForCommand: call to the Protocol Object can be made here

Syntax in Visual Basic or VBScript

OnReadyForCommand ()

Syntax in C++

HRESULT OnReadyForCommand ()

Applies to

CMMCNCController


OnRefMarks

OnRefMarks - event

Description

method OnRefMarks

Syntax in Visual Basic or VBScript

OnRefMarks (pRefMarks As Object)

Syntax in C++

HRESULT OnRefMarks (IDispatch* pRefMarks)

Parameters

Name | Description
pRefMarks |

Applies to

CMMCNCController


PreTouchIJKModeChanged

PreTouchIJKModeChanged - event

Description

method PreTouchIJKModeChanged

Syntax in Visual Basic or VBScript

PreTouchIJKModeChanged (Enabled As Boolean)

Syntax in C++

HRESULT PreTouchIJKModeChanged (VARIANT_BOOL Enabled)

Parameters

Name | Description
Enabled |

Applies to

CMMCNCController


ProbeDatabaseChanged

ProbeDatabaseChanged - event

Description

Fired by the protocol if the probe database object changes

Syntax in Visual Basic or VBScript

ProbeDatabaseChanged ()

Syntax in C++

HRESULT ProbeDatabaseChanged ()

Applies to

CMMCNCController


ProbeTipChanged

ProbeTipChanged - event

Description

Fired by the protocol for convenience when the probe database fires its ProbeTipChanged event

Syntax in Visual Basic or VBScript

ProbeTipChanged (pOld As Object , pNew As Object)

Syntax in C++

HRESULT ProbeTipChanged (IDispatch* pOld , IDispatch* pNew)

Parameters

Name | Description
pOld |
pNew |

Applies to

CMMCNCController


RapidMoveTo

RapidMoveTo - method

Description

Perform a rapid move from the current position to the new position.

Syntax in Visual Basic or VBScript

RapidMoveTo (X As Double , Y As Double , Z As Double) As status

Syntax in C++

HRESULT RapidMoveTo (double X , double Y , double Z , status* retVal)

Parameters

Name | Description
X |
Y |
Z |
Return Value |

Applies to

CMMCNCController


RapidMoveWithMachineOrientation

RapidMoveWithMachineOrientation - method

Description

Perform a rapid move from the current position/orientation to the new position/orientation.

Syntax in Visual Basic or VBScript

RapidMoveWithMachineOrientation (ByRef machine_orientation As MachineOrientationData) As status

Syntax in C++

HRESULT RapidMoveWithMachineOrientation (MachineOrientationData* machine_orientation , status* retVal)

Parameters

Name | Description
machine_orientation |
Return Value |

Applies to

CMMCNCController


RemoteMouseChanged

RemoteMouseChanged - event

Description

Fired when the protocol's remote mouse state changes

Syntax in Visual Basic or VBScript

RemoteMouseChanged (RemoteMouse As Boolean)

Syntax in C++

HRESULT RemoteMouseChanged (VARIANT_BOOL RemoteMouse)

Parameters

Name | Description
RemoteMouse |

Applies to

CMMCNCController


RequestDisconnect

RequestDisconnect - event

Description

Fired to request consent to disconnect

Syntax in Visual Basic or VBScript

RequestDisconnect (ByRef Accepted As Boolean)

Syntax in C++

HRESULT RequestDisconnect (VARIANT_BOOL* Accepted)

Parameters

Name | Description
Accepted |

Applies to

CMMCNCController


SafeMoveTo

SafeMoveTo - method

Description

Perform a safe move from the current position to the new position.

Syntax in Visual Basic or VBScript

SafeMoveTo (X As Double , Y As Double , Z As Double) As status

Syntax in C++

HRESULT SafeMoveTo (double X , double Y , double Z , status* retVal)

Parameters

Name | Description
X |
Y |
Z |
Return Value |

Applies to

CMMCNCController


ScanMove

ScanMove - method

Description

Perform a Scan move.

Syntax in Visual Basic or VBScript

ScanMove (ByRef scan_instruction As IScanInstruction) As status

Syntax in C++

HRESULT ScanMove (IScanInstruction* scan_instruction , status* retVal)

Parameters

Name | Description
scan_instruction |
Return Value |

Applies to

CMMCNCController


StartQueue

StartQueue - method

Syntax in Visual Basic or VBScript

StartQueue ()

Syntax in C++

HRESULT StartQueue ()

Applies to

CMMCNCController


TouchPoint

TouchPoint - method

Description

method TouchPoint

Syntax in Visual Basic or VBScript

TouchPoint (X As Double , Y As Double , Z As Double) As status

Syntax in C++

HRESULT TouchPoint (double X , double Y , double Z , status* retVal)

Parameters

Name | Description
X |
Y |
Z |
Return Value |

Applies to

CMMCNCController


TransactionChanged

TransactionChanged - event

Description

Fired by the protocol when it has been informed that a transaction has started or stopped

Syntax in Visual Basic or VBScript

TransactionChanged (InTransaction As Boolean)

Syntax in C++

HRESULT TransactionChanged (VARIANT_BOOL InTransaction)

Parameters

Name | Description
InTransaction |

Applies to

CMMCNCController


UnlockCNCControl

UnlockCNCControl - method

Description

Unlocks this object's control of the protocol object for use by other controllers.

Syntax in Visual Basic or VBScript

UnlockCNCControl ()

Syntax in C++

HRESULT UnlockCNCControl ()

Applies to

CMMCNCController


VirtualCommand

VirtualCommand - event

Description

method VirtualCommand

Syntax in Visual Basic or VBScript

VirtualCommand (Command As VirtualCommand)

Syntax in C++

HRESULT VirtualCommand (VirtualCommand Command)

Parameters

Name | Description
Command |

Applies to

CMMCNCController


VirtualCommandCalibration

VirtualCommandCalibration - event

Description

method VirtualCommandCalibration

Syntax in Visual Basic or VBScript

VirtualCommandCalibration (Command As VirtualCommand)

Syntax in C++

HRESULT VirtualCommandCalibration (VirtualCommand Command)

Parameters

Name | Description
Command |

Applies to

CMMCNCController


CMMDatum

CMMDatum - object

Interfaces

ICMMDatumItem

Methods of ICMMDatumItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ICMMDatumItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ICMMDatumItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureAxisX

FeatureAxisX - Read property

Syntax in Visual Basic or VBScript

FeatureAxisX () As Feature

Syntax in C++

HRESULT get_FeatureAxisX (Feature* retVal)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
PCSDatum
SequenceDefinitionDatum


FeatureAxisY

FeatureAxisY - Read property

Syntax in Visual Basic or VBScript

FeatureAxisY () As Feature

Syntax in C++

HRESULT get_FeatureAxisY (Feature* retVal)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
PCSDatum
SequenceDefinitionDatum


FeatureAxisZ

FeatureAxisZ - Read property

Syntax in Visual Basic or VBScript

FeatureAxisZ () As Feature

Syntax in C++

HRESULT get_FeatureAxisZ (Feature* retVal)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
PCSDatum
SequenceDefinitionDatum


FeatureDatum

FeatureDatum - Read property

Syntax in Visual Basic or VBScript

FeatureDatum () As Feature

Syntax in C++

HRESULT get_FeatureDatum (Feature* retVal)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
PCSDatum
SequenceDefinitionDatum


FeatureOrigin

FeatureOrigin - Read property

Syntax in Visual Basic or VBScript

FeatureOrigin () As Feature

Syntax in C++

HRESULT get_FeatureOrigin (Feature* retVal)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
PCSDatum
SequenceDefinitionDatum


FeaturePlaneXY

FeaturePlaneXY - Read property

Syntax in Visual Basic or VBScript

FeaturePlaneXY () As Feature

Syntax in C++

HRESULT get_FeaturePlaneXY (Feature* retVal)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
PCSDatum
SequenceDefinitionDatum


FeaturePlaneXZ

FeaturePlaneXZ - Read property

Syntax in Visual Basic or VBScript

FeaturePlaneXZ () As Feature

Syntax in C++

HRESULT get_FeaturePlaneXZ (Feature* retVal)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
PCSDatum
SequenceDefinitionDatum


FeaturePlaneYZ

FeaturePlaneYZ - Read property

Syntax in Visual Basic or VBScript

FeaturePlaneYZ () As Feature

Syntax in C++

HRESULT get_FeaturePlaneYZ (Feature* retVal)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
PCSDatum
SequenceDefinitionDatum


LocalCoordinateSystem

LocalCoordinateSystem - Read & Write property

Description

sets/retreieves the local coordinate system

Syntax in Visual Basic or VBScript

LocalCoordinateSystem () As Feature

Syntax in C++

HRESULT get_LocalCoordinateSystem (Feature* retVal)
HRESULT put_LocalCoordinateSystem (Feature* Value)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
SequenceDefinitionDatum


SupportsLocalCoordinateSystem

SupportsLocalCoordinateSystem - Read property

Description

returns true if the entity supports a local coordinate system

Syntax in Visual Basic or VBScript

SupportsLocalCoordinateSystem () As Boolean

Syntax in C++

HRESULT get_SupportsLocalCoordinateSystem (VARIANT_BOOL* retVal)

Applies to

CMMDatum
DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
NominalPoint
NominalVector
PCSDatum
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint
SequenceDefinitionDatum


CMMFloatParameter

CMMFloatParameter - object

Description

CMMFloatParameter Class

Interfaces

ICMMFloatParameter

Events

OnChanged | method OnChanged
OnChangeRequested | method OnChangeRequested

Methods of ICMMFloatParameter

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
GetValueUnit | Get the current value in the specified unit
IsValidValue | check if the value provided is suitable for this parameter
SetValueUnit | set the value using the specify value ( in the specified units ) without altering the internal units

Properties of ICMMFloatParameter

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
Increment | R/W | increment or 0 if all values possible
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
LowerRange | R/W | minimum authorized value
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
units | R/W | expected unit for this parameter
UNITTYPE | R/O |
UpperRange | R/W | maximum authorized value
ValidUnits | R/O | returns the list of supported units
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter


CMMIndexableProbeHeadProtocol

CMMIndexableProbeHeadProtocol - object

Interfaces

IIndexableProbeHeadProtocol

Events

ProbeHeadAnglesChanged method OnProbeHeadAnglesChanged

Methods of IIndexableProbeHeadProtocol

AnglesAreTrusted | Ask if the current probe angles are correct
GetAngles | Get the current angular position of the probe
SetAngles | Move the probe to a new angular position


AnglesAreTrusted

AnglesAreTrusted - method

Description

Ask if the current probe angles are correct

Syntax in Visual Basic or VBScript

AnglesAreTrusted (TrustInitialValues As Boolean) As Boolean

Syntax in C++

HRESULT AnglesAreTrusted (VARIANT_BOOL TrustInitialValues , VARIANT_BOOL* retVal)

Parameters

Name | Description
TrustInitialValues |
Return Value |

Applies to

CMMIndexableProbeHeadProtocol


GetAngles

GetAngles - method

Description

Get the current angular position of the probe

Syntax in Visual Basic or VBScript

GetAngles (ByRef A As Double , ByRef B As Double)

Syntax in C++

HRESULT GetAngles (double* A , double* B)

Parameters

Name | Description
A |
B |

Applies to

CMMIndexableProbeHeadProtocol


ProbeHeadAnglesChanged

ProbeHeadAnglesChanged - event

Description

method OnProbeHeadAnglesChanged

Syntax in Visual Basic or VBScript

ProbeHeadAnglesChanged (A As Double , B As Double)

Syntax in C++

HRESULT ProbeHeadAnglesChanged (double A , double B)

Parameters

Name | Description
A |
B |

Applies to

CMMIndexableProbeHeadProtocol


SetAngles

SetAngles - method

Description

Move the probe to a new angular position

Syntax in Visual Basic or VBScript

SetAngles (A As Double , B As Double) As status

Syntax in C++

HRESULT SetAngles (double A , double B , status* retVal)

Parameters

Name | Description
A |
B |
Return Value |

Applies to

CMMIndexableProbeHeadProtocol


CMMParameters

CMMParameters - object

Description

CMMParameters : a Collection of CMMParameter

Interfaces

ICMMParameters

Events

OnCMMParameterChanged | method OnCMMParamerChanged
OnCMMParameterChangeRequested | method OnCMMParameterChangeRequested

Methods of ICMMParameters

AddBoolParameter | method AddBoolParameter
AddFloatParameter | method AddFloatParameter
AddPlaneParameter | Add a plane parameter
AddPointParameter | Add a plane parameter
AddVectorParameter | Add a vector parameter
ApplyPackedValue |
CopyTo | copy the contents of this CMMPameters object to the pDest
InsertCopy | Insert Copy
TransferParameters | TransferParameters : set all parameters to their values when defined in refParemeters
XMLOutput | Get CMMParameter path in XML format

Properties of ICMMParameters

Count | R/O | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count -1 or a string
ReadOnly | R/W | ReadOnly

Collections of ICMMParameters

Categories | property Categories
Clone | Clone : create an exact copy of this object and return a pointer to it


OnCMMParameterChanged

OnCMMParameterChanged - event

Description

method OnCMMParamerChanged

Syntax in Visual Basic or VBScript

OnCMMParameterChanged (ByRef pParameter As ICMMParameter , flag As Long)

Syntax in C++

HRESULT OnCMMParameterChanged (ICMMParameter* pParameter , LONG flag)

Parameters

Name | Description
pParameter |
flag |

Applies to

CMMParameters


OnCMMParameterChangeRequested

OnCMMParameterChangeRequested - event

Description

method OnCMMParameterChangeRequested

Syntax in Visual Basic or VBScript

OnCMMParameterChangeRequested (ByRef pParameter As ICMMParameter , newValue As Variant , ByRef bAccepted As Variant)

Syntax in C++

HRESULT OnCMMParameterChangeRequested (ICMMParameter* pParameter , VARIANT newValue , VARIANT* bAccepted)

Parameters

Name | Description
pParameter |
newValue |
bAccepted |

Applies to

CMMParameters


CMMParametersCategories

CMMParametersCategories - object

Description

CMMParametersCategories Class

Interfaces

ICMMParametersCategories

Properties of ICMMParametersCategories

Count R/O Indicates the number of categories in the categorie collection

Collections of ICMMParametersCategories

Item Allows random access to individual Category object within the collection. Index can be an ordinal from 0 to Count -1 or a string being a name of a category


CMMParametersCategory

CMMParametersCategory - object

Description

CMMParametersCategory Class

Interfaces

ICMMParametersCategory

Properties of ICMMParametersCategory

Count | R/O | Indicates the number of parameter under this category
Item | R/O | Allows random access to individual Parameter within the collection. Index can be an ordinal from 0 to Count -1 or a string being a name of a parameter
Name | R/O | property Name


CMMParameterToolBox

CMMParameterToolBox - object

Description

CMMParameterToolBox Class

Interfaces

ICMMParameterToolbox

Methods of ICMMParameterToolbox

GetPackedStringBool | Get the packed string for a BOOLEAN
GetPackedStringBooleanParameter | Create the packed value for a CMM BooleanParameter
GetPackedStringFloat | Get the packed string for a Float
GetPackedStringFloatParameter | Create the packed value for a CMM FloatParameter.
GetPackedStringPlane | Get the packed string for a Plane
GetPackedStringPoint | Get the packed string for a Point
GetPackedStringTransform | Create a Transform xml-element that has the given name and units attributes
GetPackedStringVector | Get the packed string for a Vector
IsPackedString | returns true if the string is a valid packed string
PackValueAndUnits | Returns a string that contains the value followed by the units
UnpackParameter | Unpack a CMMParameter Packed string
UnpackPointParameter | Unpack the point XYZ values held in strParam (packed using GetPackedStringPoint)
UnpackPointParameterV | Unpack the point XYZ values held in strParam (packed using GetPackedStringPoint)
UnpackTransformParameter | Unpack Transform element from strParam (packed using GetPackedStringTransform()) into transform.
UnpackVectorParameter | Unpack the vector IJK values held in strParam (packed using GetPackedStringVector)
UnpackVectorParameterV | Unpack the vector IJK values held in strParam (packed using GetPackedStringVector)


GetPackedStringBool

GetPackedStringBool - method

Description

Get the packed string for a BOOLEAN

Syntax in Visual Basic or VBScript

GetPackedStringBool (strName As String , Value As Boolean) As String

Syntax in C++

HRESULT GetPackedStringBool (BSTR strName , VARIANT_BOOL Value , BSTR* retVal)

Parameters

Name | Description
strName |
Value |
Return Value |

Applies to

CMMParameterToolBox


GetPackedStringBooleanParameter

GetPackedStringBooleanParameter - method

Description

Create the packed value for a CMM BooleanParameter

Syntax in Visual Basic or VBScript

GetPackedStringBooleanParameter (strName As String , strDescription As String , Value As Boolean) As String

Syntax in C++

HRESULT GetPackedStringBooleanParameter (BSTR strName , BSTR strDescription , VARIANT_BOOL Value , BSTR* retVal)

Parameters

Name | Description
strName |
strDescription |
Value |
Return Value |

Applies to

CMMParameterToolBox


GetPackedStringFloat

GetPackedStringFloat - method

Description

Get the packed string for a Float

Syntax in Visual Basic or VBScript

GetPackedStringFloat (strName As String , Value As Double , units As String) As String

Syntax in C++

HRESULT GetPackedStringFloat (BSTR strName , double Value , BSTR units , BSTR* retVal)

Parameters

Name | Description
strName |
Value |
units |
Return Value |

Applies to

CMMParameterToolBox


GetPackedStringFloatParameter

GetPackedStringFloatParameter - method

Description

Create the packed value for a CMM FloatParameter.

Syntax in Visual Basic or VBScript

GetPackedStringFloatParameter (strName As String , strDescription As String , Value As Double , minValue As Double , maxValue As Double , incr As Double , strUnits As String) As String

Syntax in C++

HRESULT GetPackedStringFloatParameter (BSTR strName , BSTR strDescription , double Value , double minValue , double maxValue , double incr , BSTR strUnits , BSTR* retVal)

Parameters

Name | Description
strName |
strDescription |
Value |
minValue |
maxValue |
incr |
strUnits |
Return Value |

Applies to

CMMParameterToolBox


GetPackedStringPlane

GetPackedStringPlane - method

Description

Get the packed string for a Plane

Syntax in Visual Basic or VBScript

GetPackedStringPlane (strName As String , X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double , units As String) As String

Syntax in C++

HRESULT GetPackedStringPlane (BSTR strName , double X , double Y , double Z , double I , double J , double K , BSTR units , BSTR* retVal)

Parameters

Name | Description
strName |
X |
Y |
Z |
I |
J |
K |
units |
Return Value |

Applies to

CMMParameterToolBox


GetPackedStringPoint

GetPackedStringPoint - method

Description

Get the packed string for a Point

Syntax in Visual Basic or VBScript

GetPackedStringPoint (strName As String , X As Double , Y As Double , Z As Double , units As String) As String

Syntax in C++

HRESULT GetPackedStringPoint (BSTR strName , double X , double Y , double Z , BSTR units , BSTR* retVal)

Parameters

Name | Description
strName |
X |
Y |
Z |
units |
Return Value |

Applies to

CMMParameterToolBox


GetPackedStringTransform

GetPackedStringTransform - method

Description

Create a Transform xml-element that has the given name and units attributes

Syntax in Visual Basic or VBScript

GetPackedStringTransform (strName As String , ByRef transform As ITransform2) As String

Syntax in C++

HRESULT GetPackedStringTransform (BSTR strName , ITransform2* transform , BSTR* retVal)

Parameters

Name | Description
strName |
transform |
Return Value |

Applies to

CMMParameterToolBox


GetPackedStringVector

GetPackedStringVector - method

Description

Get the packed string for a Vector

Syntax in Visual Basic or VBScript

GetPackedStringVector (strName As String , I As Double , J As Double , K As Double) As String

Syntax in C++

HRESULT GetPackedStringVector (BSTR strName , double I , double J , double K , BSTR* retVal)

Parameters

Name | Description
strName |
I |
J |
K |
Return Value |

Applies to

CMMParameterToolBox


IsPackedString

IsPackedString - method

Description

returns true if the string is a valid packed string

Syntax in Visual Basic or VBScript

IsPackedString (str As String) As Boolean

Syntax in C++

HRESULT IsPackedString (BSTR str , VARIANT_BOOL* retVal)

Parameters

Name | Description
str |
Return Value |

Applies to

CMMParameterToolBox


PackValueAndUnits

PackValueAndUnits - method

Description

Returns a string that contains the value followed by the units

Syntax in Visual Basic or VBScript

PackValueAndUnits (Value As Double , units As String) As String

Syntax in C++

HRESULT PackValueAndUnits (double Value , BSTR units , BSTR* retVal)

Parameters

Name | Description
Value |
units |
Return Value |

Applies to

CMMParameterToolBox


UnpackParameter

UnpackParameter - method

Description

Unpack a CMMParameter Packed string

Syntax in Visual Basic or VBScript

UnpackParameter (parameterVCARD As String , ByRef Value As Variant , ByRef unit As String , ByRef minVal As Double , ByRef maxVal As Double , ByRef incr As Double , ByRef type As ParameterType)

Syntax in C++

HRESULT UnpackParameter (BSTR parameterVCARD , VARIANT* Value , BSTR* unit , double* minVal , double* maxVal , double* incr , ParameterType* type)

Parameters

Name | Description
parameterVCARD |
Value |
unit |
minVal |
maxVal |
incr |
type |

Applies to

CMMParameterToolBox


UnpackPointParameter

UnpackPointParameter - method

Description

Unpack the point XYZ values held in strParam (packed using GetPackedStringPoint)

Syntax in Visual Basic or VBScript

UnpackPointParameter (parameterVCARD As String , expectedUnit As String , ByRef valueX As Double , ByRef valueY As Double , ByRef valueZ As Double)

Syntax in C++

HRESULT UnpackPointParameter (BSTR parameterVCARD , BSTR expectedUnit , double* valueX , double* valueY , double* valueZ)

Parameters

Name | Description
parameterVCARD |
expectedUnit |
valueX |
valueY |
valueZ |

Applies to

CMMParameterToolBox


UnpackPointParameterV

UnpackPointParameterV - method

Description

Unpack the point XYZ values held in strParam (packed using GetPackedStringPoint)

Syntax in Visual Basic or VBScript

UnpackPointParameterV (parameterVCARD As String , expectedUnit As String , ByRef valueX As Variant , ByRef valueY As Variant , ByRef valueZ As Variant)

Syntax in C++

HRESULT UnpackPointParameterV (BSTR parameterVCARD , BSTR expectedUnit , VARIANT* valueX , VARIANT* valueY , VARIANT* valueZ)

Parameters

Name | Description
parameterVCARD |
expectedUnit |
valueX |
valueY |
valueZ |

Applies to

CMMParameterToolBox


UnpackTransformParameter

UnpackTransformParameter - method

Description

Unpack Transform element from strParam (packed using GetPackedStringTransform()) into transform.

Syntax in Visual Basic or VBScript

UnpackTransformParameter (strParam As String , ByRef transform As ITransform2)

Syntax in C++

HRESULT UnpackTransformParameter (BSTR strParam , ITransform2* transform)

Parameters

Name | Description
strParam |
transform |

Applies to

CMMParameterToolBox


UnpackVectorParameter

UnpackVectorParameter - method

Description

Unpack the vector IJK values held in strParam (packed using GetPackedStringVector)

Syntax in Visual Basic or VBScript

UnpackVectorParameter (strParam As String , ByRef valueI As Double , ByRef valueJ As Double , ByRef valueK As Double)

Syntax in C++

HRESULT UnpackVectorParameter (BSTR strParam , double* valueI , double* valueJ , double* valueK)

Parameters

Name | Description
strParam |
valueI |
valueJ |
valueK |

Applies to

CMMParameterToolBox


UnpackVectorParameterV

UnpackVectorParameterV - method

Description

Unpack the vector IJK values held in strParam (packed using GetPackedStringVector)

Syntax in Visual Basic or VBScript

UnpackVectorParameterV (parameterVCARD As String , ByRef valueI As Variant , ByRef valueJ As Variant , ByRef valueK As Variant)

Syntax in C++

HRESULT UnpackVectorParameterV (BSTR parameterVCARD , VARIANT* valueI , VARIANT* valueJ , VARIANT* valueK)

Parameters

Name | Description
parameterVCARD |
valueI |
valueJ |
valueK |

Applies to

CMMParameterToolBox


CMMPlaneParameter

CMMPlaneParameter - object

Description

CMMPlaneParameter Class

Interfaces

ICMMPlaneParameter

Methods of ICMMPlaneParameter

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
IsValidValue | check if the value provided is suitable for this parameter

Properties of ICMMPlaneParameter

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
Plane | R/O | returns the plane
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
units | R/W | expected unit for this parameter
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter


CMMPoint

CMMPoint - object

Description

CMMPoint Class

Interfaces

ICMMPoint

Methods of ICMMPoint

TransformFrom
TransformTo

Properties of ICMMPoint

Name | R/W
OuterMaterialDirection | R/O
PreTouchPoint | R/O
ProbeCenter | R/O
ProbeDiameter | R/W
Value | R/W


CMMPointParameter

CMMPointParameter - object

Description

CMMPointParameter Class

Interfaces

ICMMPointParameter

Methods of ICMMPointParameter

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
IsValidValue | check if the value provided is suitable for this parameter

Properties of ICMMPointParameter

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
Point | R/O | returns the point
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
units | R/W | expected unit for this parameter
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter


CMMPoints

CMMPoints - object

Description

CMMPoints Class

Interfaces

ICMMPoints

Methods of ICMMPoints

Add | method Add
AddNamedXYZIJK | method AddNamedXYZIJK
AddXYZIJK | method AddXYZJIK
Append | Append: add a copy of the srcCollection into this collection
Clear | method Clear : Empty all points from the list
CopyFrom | CopyFrom: create a copy from srcCollection into this collection
Remove | method Remove : remove a point from the list at the specified index
Scale | Scale: scale the points cloud ( usefull to convert between inches and mm
TransformFrom |
TransformTo |

Properties of ICMMPoints

Count | R/W | Indicates the number of items in the collection.
IsReadOnly | R/O | returns TRUE if the collection is a readonly collection
Item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 1 to Count or a string
ProbeDiameter | R/W | returns the probe diameter


CMMProtocol_dummy

CMMProtocol_dummy - object

Interfaces

ICMMProtocol

Events

CNCControllingLockChanged | Fired when a CNC controlling object locks or unlocks its CNC control
ContactPoint | method ContactPoint
ContactPointCalibration | method ContactPointCalibration
EnableModeless | Fired to request the client to disable or enable its main window and other modeless dialogs
IntermediatePoint | method IntermediatePoint
OnCalibrationModeChanged | OnCalibration Mode change
OnCMMHomed | method OnCMMHomed : the CMM homed flag is now set
OnCMMParameterChanged | method OnCMMParamerChanged
OnCNCStatusChanged | method OnCNCStatusChanged
OnCompletion | method OnCNCError
OnConnectionChanged | method Connect
OnReadyForCommand | method OnReadyForCommand: call to the Protocol Object can be made here
OnRefMarks | method OnRefMarks
PreTouchIJKModeChanged | method PreTouchIJKModeChanged
ProbeDatabaseChanged | Fired by the protocol if the probe database object changes
ProbeTipChanged | Fired by the protocol for convenience when the probe database fires its ProbeTipChanged event
RemoteMouseChanged | Fired when the protocol's remote mouse state changes
RequestDisconnect | Fired to request consent to disconnect
TransactionChanged | Fired by the protocol when it has been informed that a transaction has started or stopped
VirtualCommand | method VirtualCommand
VirtualCommandCalibration | method VirtualCommandCalibration

Methods of ICMMProtocol

CancelCurrentCNCAction | method CancelCurrentCNCAction
DoRepositioning | OnRelocate
ForceCurrentPositionUpdate | Forces the protocol to update the current position. Not all protocols will be able to implement this.
GetCNCControllingObject | Creates an object to allow CNC controlling actions to be performed on the protocol.
GetCurrentPosition | method CurrentPosition
GetLastMappingError | method GetLastMappingError
GetRefMarks | method GetRefMarks : return a copy of the current reference marker position
GetTrackingPointObject | Creates an object to allow collection of tracking points.
GetUserCamera | GetUserCamera
Home | Method Homed : Home or Reset the CMM Device
PlaySound | Play a sound on the DCE Device
StartPointStreamTransaction | Starts a transaction and creates an object to receive the contact points as a stream. Only usable by C++ clients.
StartTransaction | method StartTransaction
StopTransaction | method StopTransaction
UncompensatePoint | Undoes any process implicitly done by the protocol to a point
UnCompensatePointV | Undoes any process implicitly done by the protocol to a point

Properties of ICMMProtocol

AutoRepeatInterval | R/W | AutoRepeatInterval : number of millisecond between two points capture in rigid scanning
CalibrationMode | R/W | Calibration Mode
CanPlaySound | R/O | Can play a sound on the DCE Device
CMM2UserTransformation | R/O | CMM2UserTransformation
CMMTYPE | R/O | gets the technology of the CMM
CNCControllingObjectHasLock | R/O | Whether a CNC controlling object currently has a CNC lock on this object.
CNCProtocolRunningAsManual | R/O | True when the protocol is CNC but is operating as manual due to absence of CNC licence.
CNCSTATUS | R/O | property CNCStatus
Configurator | R/O | retrieves the Configurator Object
Connected | R/W | proterty Connected
CurrentPosition | R/O | method CurrentPosition : return a read/only point that describe the current position
DeviceRepositionner | T/O | returns thedevice repositionner object - of type IRePosition
ErrorMap | R/W | Object used by protocol to perform error map compensation on point co-ordinates
ErrorMap | W/O | Object used by protocol to perform error map compensation on point co-ordinates
ErrorMappingType | R/O | The type of error mapping support this protocol is capable of
Fire | R/O | Property Fire
Homed | R/O | proterty Homed : return true if the DEVICE has been homed or initialised
InTransaction | R/O | Returns whether the protocol is currently in a measurement transaction. Note that the result returned is also affected by changes to the CalibrationMode property.
LastCNCErrorDescription | R/O | property LastCNCErrorDescription
MaximumMultipointMovePoints | R/O | MaximumMultipointMovePoints
ParentWindow | R/W | Parent Window
PreTouchIJKMode | R/W | PreTouchIJKMode
ProbeDatabase | R/O | The object that allows us to access the probe database and the active sensor
ProbeDatabaseIsInstalled | R/O | Determines whether a probe database is currently set. Useful for clients that do not want to invoke the probe database installation through a call to get_ProbeDatabase.
ProbePathReplayEngine | T/O | ProbePathReplay
ProbePathTeachEngine | T/O | ProbePathTeachEngine
RemoteMouse | R/W | Enables/disables remote mouse functionality
ScanningMode | R/W | retrieve/set the Scanning mode
SupportRefMarks | R/O | Support Reference Marks
SupportScanning | R/O | Support Scanning features
SupportsUserCamera | R/O | SupportsUserCamera
SupportTracking | R/O | The object fully supports tracking points
SuppressBeepOnContact | R/W | Suppress protocol default beeping on contact. For clients that will explicitly call PlaySound when processing contact points.
TrackingFrame | R/O | An object that allows the current tracking frame to be retrieved. Only usable by C++ clients.

Collections of ICMMProtocol

CMMParameters | CMMParameters
UIExtensionCommands | User Interface Extension Commands


AutoRepeatInterval

AutoRepeatInterval - Read & Write property

Description

AutoRepeatInterval : number of millisecond between two points capture in rigid scanning

Syntax in Visual Basic or VBScript

AutoRepeatInterval () As Long

Syntax in C++

HRESULT get_AutoRepeatInterval (LONG* retVal)
HRESULT put_AutoRepeatInterval (LONG Value)

Applies to

CMMProtocol_dummy


CalibrationMode

CalibrationMode - Read & Write property

Description

Calibration Mode

Syntax in Visual Basic or VBScript

CalibrationMode () As Boolean

Syntax in C++

HRESULT get_CalibrationMode (VARIANT_BOOL* retVal)
HRESULT put_CalibrationMode (VARIANT_BOOL Value)

Applies to

CMMProtocol_dummy
ProbePathReplay


CanPlaySound

CanPlaySound - Read property

Description

Can play a sound on the DCE Device

Syntax in Visual Basic or VBScript

CanPlaySound () As Boolean

Syntax in C++

HRESULT get_CanPlaySound (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


CMM2UserTransformation

CMM2UserTransformation - Read property

Description

CMM2UserTransformation

Syntax in Visual Basic or VBScript

CMM2UserTransformation () As ITransform2

Syntax in C++

HRESULT get_CMM2UserTransformation (ITransform2* retVal)

Applies to

CMMProtocol_dummy


CMMTYPE

CMMTYPE - Read property

Description

gets the technology of the CMM

Syntax in Visual Basic or VBScript

CMMTYPE () As CMMTYPE

Syntax in C++

HRESULT get_CMMTYPE (CMMTYPE* retVal)

Applies to

CMMProtocol_dummy


CNCControllingObjectHasLock

CNCControllingObjectHasLock - Read property

Description

Whether a CNC controlling object currently has a CNC lock on this object.

Syntax in Visual Basic or VBScript

CNCControllingObjectHasLock () As Boolean

Syntax in C++

HRESULT get_CNCControllingObjectHasLock (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


CNCProtocolRunningAsManual

CNCProtocolRunningAsManual - Read property

Description

True when the protocol is CNC but is operating as manual due to absence of CNC licence.

Syntax in Visual Basic or VBScript

CNCProtocolRunningAsManual () As Boolean

Syntax in C++

HRESULT get_CNCProtocolRunningAsManual (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


CNCSTATUS

CNCSTATUS - Read property

Description

property CNCStatus

Syntax in Visual Basic or VBScript

CNCSTATUS () As CNCSTATUS

Syntax in C++

HRESULT get_CNCSTATUS (CNCSTATUS* retVal)

Applies to

CMMProtocol_dummy


Configurator

Configurator - Read property

Description

retrieves the Configurator Object

Syntax in Visual Basic or VBScript

Configurator () As ICMMProtocolConfigurator

Syntax in C++

HRESULT get_Configurator (ICMMProtocolConfigurator* retVal)

Applies to

CMMProtocol_dummy


Connected

Connected - Read & Write property

Description

proterty Connected

Syntax in Visual Basic or VBScript

Connected () As Boolean

Syntax in C++

HRESULT get_Connected (VARIANT_BOOL* retVal)
HRESULT put_Connected (VARIANT_BOOL Value)

Applies to

CMMProtocol_dummy


CurrentPosition

CurrentPosition - Read property

Description

method CurrentPosition : return a read/only point that describe the current position

Syntax in Visual Basic or VBScript

CurrentPosition () As Point3D

Syntax in C++

HRESULT get_CurrentPosition (Point3D* retVal)

Applies to

CMMProtocol_dummy


DeviceRepositionner

DeviceRepositionner - Reference Write property

Description

returns thedevice repositionner object - of type IRePosition

Syntax in Visual Basic or VBScript

DeviceRepositionner () As Object

Syntax in C++

HRESULT get_DeviceRepositionner (IDispatch** retVal)

Applies to

CMMProtocol_dummy


ErrorMap

ErrorMap - Read & Write property

Description

Object used by protocol to perform error map compensation on point co-ordinates

Syntax in Visual Basic or VBScript

ErrorMap () As ICMMErrorMap

Syntax in C++

HRESULT get_ErrorMap (ICMMErrorMap* retVal)
HRESULT put_ErrorMap (ICMMErrorMap* Value)

Applies to

CMMProtocol_dummy


ErrorMap

ErrorMap - Reference Write property

Description

Object used by protocol to perform error map compensation on point co-ordinates

Syntax in Visual Basic or VBScript

ErrorMap (ByRef As ICMMErrorMap)

Syntax in C++

HRESULT putref_ErrorMap (ICMMErrorMap* )

Applies to

CMMProtocol_dummy


ErrorMappingType

ErrorMappingType - Read property

Description

The type of error mapping support this protocol is capable of

Syntax in Visual Basic or VBScript

ErrorMappingType () As ERROR_MAPPING_TYPE

Syntax in C++

HRESULT get_ErrorMappingType (ERROR_MAPPING_TYPE* retVal)

Applies to

CMMProtocol_dummy


Fire

Fire - Read property

Description

Property Fire

Syntax in Visual Basic or VBScript

Fire () As IFireCMMProtocolEvents

Syntax in C++

HRESULT get_Fire (IFireCMMProtocolEvents* retVal)

Applies to

CMMProtocol_dummy


Homed

Homed - Read property

Description

proterty Homed : return true if the DEVICE has been homed or initialised

Syntax in Visual Basic or VBScript

Homed () As Boolean

Syntax in C++

HRESULT get_Homed (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


InTransaction

InTransaction - Read property

Description

Returns whether the protocol is currently in a measurement transaction. Note that the result returned is also affected by changes to the CalibrationMode property.

Syntax in Visual Basic or VBScript

InTransaction () As Boolean

Syntax in C++

HRESULT get_InTransaction (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


LastCNCErrorDescription

LastCNCErrorDescription - Read property

Description

property LastCNCErrorDescription

Syntax in Visual Basic or VBScript

LastCNCErrorDescription () As String

Syntax in C++

HRESULT get_LastCNCErrorDescription (BSTR* retVal)

Applies to

CMMProtocol_dummy


MaximumMultipointMovePoints

MaximumMultipointMovePoints - Read property

Description

MaximumMultipointMovePoints

Syntax in Visual Basic or VBScript

MaximumMultipointMovePoints () As Long

Syntax in C++

HRESULT get_MaximumMultipointMovePoints (LONG* retVal)

Applies to

CMMProtocol_dummy


ParentWindow

ParentWindow - Read & Write property

Description

Parent Window

Syntax in Visual Basic or VBScript

ParentWindow () As Long

Syntax in C++

HRESULT get_ParentWindow (LONG* retVal)
HRESULT put_ParentWindow (LONG Value)

Applies to

CMMProtocol_dummy
ProbeDatabase


PreTouchIJKMode

PreTouchIJKMode - Read & Write property

Description

PreTouchIJKMode

Syntax in Visual Basic or VBScript

PreTouchIJKMode () As Boolean

Syntax in C++

HRESULT get_PreTouchIJKMode (VARIANT_BOOL* retVal)
HRESULT put_PreTouchIJKMode (VARIANT_BOOL Value)

Applies to

CMMProtocol_dummy


ProbeDatabase

ProbeDatabase - Read property

Description

The object that allows us to access the probe database and the active sensor

Syntax in Visual Basic or VBScript

ProbeDatabase () As SimpleProbeDatabase

Syntax in C++

HRESULT get_ProbeDatabase (SimpleProbeDatabase* retVal)

Applies to

CMMProtocol_dummy


ProbeDatabaseIsInstalled

ProbeDatabaseIsInstalled - Read property

Description

Determines whether a probe database is currently set. Useful for clients that do not want to invoke the probe database installation through a call to get_ProbeDatabase.

Syntax in Visual Basic or VBScript

ProbeDatabaseIsInstalled () As Boolean

Syntax in C++

HRESULT get_ProbeDatabaseIsInstalled (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


ProbePathReplayEngine

ProbePathReplayEngine - Reference Write property

Description

ProbePathReplay

Syntax in Visual Basic or VBScript

ProbePathReplayEngine () As Object

Syntax in C++

HRESULT get_ProbePathReplayEngine (IDispatch** retVal)

Applies to

CMMProtocol_dummy


ProbePathTeachEngine

ProbePathTeachEngine - Reference Write property

Description

ProbePathTeachEngine

Syntax in Visual Basic or VBScript

ProbePathTeachEngine () As Object

Syntax in C++

HRESULT get_ProbePathTeachEngine (IDispatch** retVal)

Applies to

CMMProtocol_dummy


RemoteMouse

RemoteMouse - Read & Write property

Description

Enables/disables remote mouse functionality

Syntax in Visual Basic or VBScript

RemoteMouse () As Boolean

Syntax in C++

HRESULT get_RemoteMouse (VARIANT_BOOL* retVal)
HRESULT put_RemoteMouse (VARIANT_BOOL Value)

Applies to

CMMProtocol_dummy


ScanningMode

ScanningMode - Read & Write property

Description

retrieve/set the Scanning mode

Syntax in Visual Basic or VBScript

ScanningMode () As Boolean

Syntax in C++

HRESULT get_ScanningMode (VARIANT_BOOL* retVal)
HRESULT put_ScanningMode (VARIANT_BOOL Value)

Applies to

CMMProtocol_dummy


SupportRefMarks

SupportRefMarks - Read property

Description

Support Reference Marks

Syntax in Visual Basic or VBScript

SupportRefMarks () As Boolean

Syntax in C++

HRESULT get_SupportRefMarks (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


SupportScanning

SupportScanning - Read property

Description

Support Scanning features

Syntax in Visual Basic or VBScript

SupportScanning () As Boolean

Syntax in C++

HRESULT get_SupportScanning (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


SupportsUserCamera

SupportsUserCamera - Read property

Description

SupportsUserCamera

Syntax in Visual Basic or VBScript

SupportsUserCamera () As Boolean

Syntax in C++

HRESULT get_SupportsUserCamera (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


SupportTracking

SupportTracking - Read property

Description

The object fully supports tracking points

Syntax in Visual Basic or VBScript

SupportTracking () As Boolean

Syntax in C++

HRESULT get_SupportTracking (VARIANT_BOOL* retVal)

Applies to

CMMProtocol_dummy


SuppressBeepOnContact

SuppressBeepOnContact - Read & Write property

Description

Suppress protocol default beeping on contact. For clients that will explicitly call PlaySound when processing contact points.

Syntax in Visual Basic or VBScript

SuppressBeepOnContact () As Boolean

Syntax in C++

HRESULT get_SuppressBeepOnContact (VARIANT_BOOL* retVal)
HRESULT put_SuppressBeepOnContact (VARIANT_BOOL Value)

Applies to

CMMProtocol_dummy


TrackingFrame

TrackingFrame - Read property

Description

An object that allows the current tracking frame to be retrieved. Only usable by C++ clients.

Syntax in Visual Basic or VBScript

TrackingFrame () As ICMMTrackingFrame

Syntax in C++

HRESULT get_TrackingFrame (ICMMTrackingFrame* retVal)

Applies to

CMMProtocol_dummy


DoRepositioning

DoRepositioning - method

Description

OnRelocate

Syntax in Visual Basic or VBScript

DoRepositioning ()

Syntax in C++

HRESULT DoRepositioning ()

Applies to

CMMProtocol_dummy


ForceCurrentPositionUpdate

ForceCurrentPositionUpdate - method

Description

Forces the protocol to update the current position. Not all protocols will be able to implement this.

Syntax in Visual Basic or VBScript

ForceCurrentPositionUpdate ()

Syntax in C++

HRESULT ForceCurrentPositionUpdate ()

Applies to

CMMProtocol_dummy


GetCNCControllingObject

GetCNCControllingObject - method

Description

Creates an object to allow CNC controlling actions to be performed on the protocol.

Syntax in Visual Basic or VBScript

GetCNCControllingObject () As CMMCNCController

Syntax in C++

HRESULT GetCNCControllingObject (CMMCNCController* retVal)

Parameters

Name | Description
Return Value |

Applies to

CMMProtocol_dummy


GetCurrentPosition

GetCurrentPosition - method

Description

method CurrentPosition

Syntax in Visual Basic or VBScript

GetCurrentPosition (ByRef X As Double , ByRef Y As Double , ByRef Z As Double , ByRef I As Double , ByRef J As Double , ByRef K As Double)

Syntax in C++

HRESULT GetCurrentPosition (double* X , double* Y , double* Z , double* I , double* J , double* K)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |

Applies to

CMMProtocol_dummy


GetLastMappingError

GetLastMappingError - method

Description

method GetLastMappingError

Syntax in Visual Basic or VBScript

GetLastMappingError (ByRef errorX As Double , ByRef errorY As Double , ByRef errorZ As Double , ByRef preMappedX As Double , ByRef preMappedY As Double , ByRef preMappedZ As Double)

Syntax in C++

HRESULT GetLastMappingError (double* errorX , double* errorY , double* errorZ , double* preMappedX , double* preMappedY , double* preMappedZ)

Parameters

Name | Description
errorX |
errorY |
errorZ |
preMappedX |
preMappedY |
preMappedZ |

Applies to

CMMProtocol_dummy


GetRefMarks

GetRefMarks - method

Description

method GetRefMarks : return a copy of the current reference marker position

Syntax in Visual Basic or VBScript

GetRefMarks (ByRef retVal As CMMPoints)

Syntax in C++

HRESULT GetRefMarks (CMMPoints* retVal)

Parameters

Name | Description
retVal |

Applies to

CMMProtocol_dummy


GetTrackingPointObject

GetTrackingPointObject - method

Description

Creates an object to allow collection of tracking points.

Syntax in Visual Basic or VBScript

GetTrackingPointObject () As ICMMProtocolTrackingPoints

Syntax in C++

HRESULT GetTrackingPointObject (ICMMProtocolTrackingPoints* retVal)

Parameters

Name | Description
Return Value |

Applies to

CMMProtocol_dummy


GetUserCamera

GetUserCamera - method

Description

GetUserCamera

Syntax in Visual Basic or VBScript

GetUserCamera (ByRef ppViewReferencePoint As Point3D , ByRef ppViewPlaneNormal As UnitVector3D , ByRef ppViewUpVector As UnitVector3D)

Syntax in C++

HRESULT GetUserCamera (Point3D* ppViewReferencePoint , UnitVector3D* ppViewPlaneNormal , UnitVector3D* ppViewUpVector)

Parameters

Name | Description
ppViewReferencePoint |
ppViewPlaneNormal |
ppViewUpVector |

Applies to

CMMProtocol_dummy


Home

Home - method

Description

Method Homed : Home or Reset the CMM Device

Syntax in Visual Basic or VBScript

Home () As status

Syntax in C++

HRESULT Home (status* retVal)

Parameters

Name | Description
Return Value |

Applies to

CMMProtocol_dummy


PlaySound

PlaySound - method

Description

Play a sound on the DCE Device

Syntax in Visual Basic or VBScript

PlaySound (frequency As Long , Duration As Long , type As PLAY_SOUND_TYPE)

Syntax in C++

HRESULT PlaySound (LONG frequency , LONG Duration , PLAY_SOUND_TYPE type)

Parameters

Name | Description
frequency |
Duration |
type |

Applies to

CMMProtocol_dummy


StartPointStreamTransaction

StartPointStreamTransaction - method

Description

Starts a transaction and creates an object to receive the contact points as a stream. Only usable by C++ clients.

Syntax in Visual Basic or VBScript

StartPointStreamTransaction () As ICMMContactPointsStream

Syntax in C++

HRESULT StartPointStreamTransaction (ICMMContactPointsStream* retVal)

Parameters

Name | Description
Return Value |

Applies to

CMMProtocol_dummy


StartTransaction

StartTransaction - method

Description

method StartTransaction

Syntax in Visual Basic or VBScript

StartTransaction ()

Syntax in C++

HRESULT StartTransaction ()

Applies to

CMMProtocol_dummy


StopTransaction

StopTransaction - method

Description

method StopTransaction

Syntax in Visual Basic or VBScript

StopTransaction ()

Syntax in C++

HRESULT StopTransaction ()

Applies to

CMMProtocol_dummy


UncompensatePoint

UncompensatePoint - method

Description

Undoes any process implicitly done by the protocol to a point

Syntax in Visual Basic or VBScript

UncompensatePoint (uncompensateType As UNCOMPENSATE_TYPE , ByRef X As Double , ByRef Y As Double , ByRef Z As Double , ByRef I As Double , ByRef J As Double , ByRef K As Double)

Syntax in C++

HRESULT UncompensatePoint (UNCOMPENSATE_TYPE uncompensateType , double* X , double* Y , double* Z , double* I , double* J , double* K)

Parameters

Name | Description
uncompensateType |
X |
Y |
Z |
I |
J |
K |

Applies to

CMMProtocol_dummy


UnCompensatePointV

UnCompensatePointV - method

Description

Undoes any process implicitly done by the protocol to a point

Syntax in Visual Basic or VBScript

UnCompensatePointV (uncompensateType As UNCOMPENSATE_TYPE , ByRef X As Variant , ByRef Y As Variant , ByRef Z As Variant , ByRef I As Variant , ByRef J As Variant , ByRef K As Variant)

Syntax in C++

HRESULT UnCompensatePointV (UNCOMPENSATE_TYPE uncompensateType , VARIANT* X , VARIANT* Y , VARIANT* Z , VARIANT* I , VARIANT* J , VARIANT* K)

Parameters

Name | Description
uncompensateType |
X |
Y |
Z |
I |
J |
K |

Applies to

CMMProtocol_dummy


CMMParameters

CMMParameters - Read property

Description

CMMParameters

Syntax in Visual Basic or VBScript

CMMParameters () As CMMParameters

Syntax in C++

HRESULT get_CMMParameters (CMMParameters* retVal)

Applies to

CMMProtocol_dummy


UIExtensionCommands

UIExtensionCommands - Read property

Description

User Interface Extension Commands

Syntax in Visual Basic or VBScript

UIExtensionCommands () As ICMMUIExtensionCommands

Syntax in C++

HRESULT get_UIExtensionCommands (ICMMUIExtensionCommands* retVal)

Applies to

CMMProtocol_dummy


CMMSimulationProtocol

CMMSimulationProtocol - object

Description

CMMSimulationProtocol Class

Interfaces

ICMMProtocol

Methods of ICMMProtocol

CancelCurrentCNCAction | method CancelCurrentCNCAction
DoRepositioning | OnRelocate
ForceCurrentPositionUpdate | Forces the protocol to update the current position. Not all protocols will be able to implement this.
GetCNCControllingObject | Creates an object to allow CNC controlling actions to be performed on the protocol.
GetCurrentPosition | method CurrentPosition
GetLastMappingError | method GetLastMappingError
GetRefMarks | method GetRefMarks : return a copy of the current reference marker position
GetTrackingPointObject | Creates an object to allow collection of tracking points.
GetUserCamera | GetUserCamera
Home | Method Homed : Home or Reset the CMM Device
PlaySound | Play a sound on the DCE Device
StartPointStreamTransaction | Starts a transaction and creates an object to receive the contact points as a stream. Only usable by C++ clients.
StartTransaction | method StartTransaction
StopTransaction | method StopTransaction
UncompensatePoint | Undoes any process implicitly done by the protocol to a point
UnCompensatePointV | Undoes any process implicitly done by the protocol to a point

Properties of ICMMProtocol

AutoRepeatInterval | R/W | AutoRepeatInterval : number of millisecond between two points capture in rigid scanning
CalibrationMode | R/W | Calibration Mode
CanPlaySound | R/O | Can play a sound on the DCE Device
CMM2UserTransformation | R/O | CMM2UserTransformation
CMMTYPE | R/O | gets the technology of the CMM
CNCControllingObjectHasLock | R/O | Whether a CNC controlling object currently has a CNC lock on this object.
CNCProtocolRunningAsManual | R/O | True when the protocol is CNC but is operating as manual due to absence of CNC licence.
CNCSTATUS | R/O | property CNCStatus
Configurator | R/O | retrieves the Configurator Object
Connected | R/W | proterty Connected
CurrentPosition | R/O | method CurrentPosition : return a read/only point that describe the current position
DeviceRepositionner | T/O | returns thedevice repositionner object - of type IRePosition
ErrorMap | R/W | Object used by protocol to perform error map compensation on point co-ordinates
ErrorMap | W/O | Object used by protocol to perform error map compensation on point co-ordinates
ErrorMappingType | R/O | The type of error mapping support this protocol is capable of
Fire | R/O | Property Fire
Homed | R/O | proterty Homed : return true if the DEVICE has been homed or initialised
InTransaction | R/O | Returns whether the protocol is currently in a measurement transaction. Note that the result returned is also affected by changes to the CalibrationMode property.
LastCNCErrorDescription | R/O | property LastCNCErrorDescription
MaximumMultipointMovePoints | R/O | MaximumMultipointMovePoints
ParentWindow | R/W | Parent Window
PreTouchIJKMode | R/W | PreTouchIJKMode
ProbeDatabase | R/O | The object that allows us to access the probe database and the active sensor
ProbeDatabaseIsInstalled | R/O | Determines whether a probe database is currently set. Useful for clients that do not want to invoke the probe database installation through a call to get_ProbeDatabase.
ProbePathReplayEngine | T/O | ProbePathReplay
ProbePathTeachEngine | T/O | ProbePathTeachEngine
RemoteMouse | R/W | Enables/disables remote mouse functionality
ScanningMode | R/W | retrieve/set the Scanning mode
SupportRefMarks | R/O | Support Reference Marks
SupportScanning | R/O | Support Scanning features
SupportsUserCamera | R/O | SupportsUserCamera
SupportTracking | R/O | The object fully supports tracking points
SuppressBeepOnContact | R/W | Suppress protocol default beeping on contact. For clients that will explicitly call PlaySound when processing contact points.
TrackingFrame | R/O | An object that allows the current tracking frame to be retrieved. Only usable by C++ clients.

Collections of ICMMProtocol

CMMParameters | CMMParameters
UIExtensionCommands | User Interface Extension Commands


CMMSimulator

CMMSimulator - object

Description

CMMSimulator Class

Interfaces

ICMMSimulator

Events

OnIntermediatePoint | Fired when the user has inserted a intermediate point
OnManualContactPoint | Fired when a contact point has been probed manually

Methods of ICMMSimulator

GetMachineAxis | Get the absolute value of the machine axis.
InstallProbeHead | Install a new probe Head
InstallStandardProbe | Install a standard probe into Probe database (the argument can be the name of a standard probe (i.e TP20x20x2 or a full assembly definition
Load | Load the full state of the simulator from a stream or a file
LoadCMMConfiguration | Install a new cmm kinematic file
LoadConfigurationInteractive | Displays a file dialog to allow user to load the configuration of the simulator
LoadKinematicsInteractive | Displays a file dialog to allow user to load a different model for the CMM
MachineAxisAddress | The machine axes address.
MachineAxisType | The machine axes type.
MoveProbe | Move the probe to the specified position.
ProbeStructureExists | Returns TRUE if the graphical structure for the probe specified by the vcard exists
ResetMachineOrientation | Reset the machine orientation to the home position.
ResetStatistics | Reset the animation statistics.
RotateProbe | Rotate the probe head.
Save | Save the full state of the simulator in a stream or a file
SaveConfigurationInteractive | Displays a file dialog to allow user to save the configuration of the simulator
SaveDefaultConfiguration | Save the configuration of the simulator in the default location
SetMachineAxis | Set the absolute value of the machine axis.
SetMachineOrientation | Move the machine into the given position/orientation using the kinematic method and constraints given.
SimulateProbePath | Start the asynchronous simulation of the probe path.
Stop | stop the simulator

Properties of ICMMSimulator

AngularVelocity | R/W | Retrieves/sets the angular feedrate of the probe head (in deg/sec) for animation (when Anmination = cmms_ANIMATED)
Animation | R/W | Set/retreive the animation mode
BackOffBehaviour | R/W | Retrieve the backoff behavior of the CMM.
BUSY | R/O | Return the busy flag.
CMMPosition | R/O | R/O retrieve the current position of the CMM.
CMMProtocol | R/O | get the protocol
CMMVisible | R/W | Show/Hide the CMM
CollisionChecking | R/W | Returns true if the joystick move (i.e MoveProbe) performs collision checking
EmergencyStop | R/W | set/retreive the state of the Manual Emmergency stop button
Feedrate | R/W | Retrieves/sets the feedrate (in mm/sec) for animation (when Anmination = cmms_ANIMATED)
HomeOrientation | R/O | Get the home orientation of the machine.
MachineOrientation | R/O | Get the current machine orientation data for the machine being used in the simulator.
MachineOrientationSet | R/O | Has the machine orientation been set?
MaintainCameraPosition | R/W | Retrieves the camera position being maintained during simulation.
NumberOfMachineAxes | R/O | Number of machine axes.
ProbeDatabase | R/O | Get the probe database for simulation
ProbeHeadVisible | R/W | Show/Hide the ProbeHead
ProbeStructureBuilder | R/O | Get the probe-structure builder used when creating probe-graphics
ProbeVisible | R/W | Show/Hide the Probe
Statistics | R/O | Returns a string containing some animation performance statistics
TipOffset | R/O | Retrieve the current tip offset, from Quill mounting point to Tip Position.
TipPosition | R/O | R/O retrieve the current position of the active sensor tip.
TipShankDirection | R/O | Retrieve the current tip shank direction from tip toward the shank.
ToolMountingPointPosition | R/O | R/O retrieve the current position of the tool mounting point.


AngularVelocity

AngularVelocity - Read & Write property

Description

Retrieves/sets the angular feedrate of the probe head (in deg/sec) for animation (when Anmination = cmms_ANIMATED)

Syntax in Visual Basic or VBScript

AngularVelocity () As Double

Syntax in C++

HRESULT get_AngularVelocity (double* retVal)
HRESULT put_AngularVelocity (double Value)

Applies to

CMMSimulator


Animation

Animation - Read & Write property

Description

Set/retreive the animation mode

Syntax in Visual Basic or VBScript

Animation () As cmms_ANIMATION

Syntax in C++

HRESULT get_Animation (cmms_ANIMATION* retVal)
HRESULT put_Animation (cmms_ANIMATION Value)

Applies to

CMMSimulator


BackOffBehaviour

BackOffBehaviour - Read & Write property

Description

Retrieve the backoff behavior of the CMM.

Syntax in Visual Basic or VBScript

BackOffBehaviour () As cmms_BACKOFF

Syntax in C++

HRESULT get_BackOffBehaviour (cmms_BACKOFF* retVal)
HRESULT put_BackOffBehaviour (cmms_BACKOFF Value)

Applies to

CMMSimulator


BUSY

BUSY - Read property

Description

Return the busy flag.

Syntax in Visual Basic or VBScript

BUSY () As Boolean

Syntax in C++

HRESULT get_BUSY (VARIANT_BOOL* retVal)

Applies to

CMMSimulator


CMMPosition

CMMPosition - Read property

Description

R/O retrieve the current position of the CMM.

Syntax in Visual Basic or VBScript

CMMPosition () As Point3D

Syntax in C++

HRESULT get_CMMPosition (Point3D* retVal)

Applies to

CMMSimulator


CMMProtocol

CMMProtocol - Read property

Description

get the protocol

Syntax in Visual Basic or VBScript

CMMProtocol () As CMMProtocol_dummy

Syntax in C++

HRESULT get_CMMProtocol (CMMProtocol_dummy* retVal)

Applies to

CMMSimulator


CMMVisible

CMMVisible - Read & Write property

Description

Show/Hide the CMM

Syntax in Visual Basic or VBScript

CMMVisible () As Boolean

Syntax in C++

HRESULT get_CMMVisible (VARIANT_BOOL* retVal)
HRESULT put_CMMVisible (VARIANT_BOOL Value)

Applies to

CMMSimulator


CollisionChecking

CollisionChecking - Read & Write property

Description

Returns true if the joystick move (i.e MoveProbe) performs collision checking

Syntax in Visual Basic or VBScript

CollisionChecking () As Boolean

Syntax in C++

HRESULT get_CollisionChecking (VARIANT_BOOL* retVal)
HRESULT put_CollisionChecking (VARIANT_BOOL Value)

Applies to

CMMSimulator


EmergencyStop

EmergencyStop - Read & Write property

Description

set/retreive the state of the Manual Emmergency stop button

Syntax in Visual Basic or VBScript

EmergencyStop () As Boolean

Syntax in C++

HRESULT get_EmergencyStop (VARIANT_BOOL* retVal)
HRESULT put_EmergencyStop (VARIANT_BOOL Value)

Applies to

CMMSimulator


Feedrate

Feedrate - Read & Write property

Description

Retrieves/sets the feedrate (in mm/sec) for animation (when Anmination = cmms_ANIMATED)

Syntax in Visual Basic or VBScript

Feedrate () As Double

Syntax in C++

HRESULT get_Feedrate (double* retVal)
HRESULT put_Feedrate (double Value)

Applies to

CMMSimulator


HomeOrientation

HomeOrientation - Read property

Description

Get the home orientation of the machine.

Syntax in Visual Basic or VBScript

HomeOrientation () As MachineOrientationData

Syntax in C++

HRESULT get_HomeOrientation (MachineOrientationData* retVal)

Applies to

CMMSimulator


MachineOrientation

MachineOrientation - Read property

Description

Get the current machine orientation data for the machine being used in the simulator.

Syntax in Visual Basic or VBScript

MachineOrientation () As MachineOrientationData

Syntax in C++

HRESULT get_MachineOrientation (MachineOrientationData* retVal)

Applies to

CMMSimulator


MachineOrientationSet

MachineOrientationSet - Read property

Description

Has the machine orientation been set?

Syntax in Visual Basic or VBScript

MachineOrientationSet () As Boolean

Syntax in C++

HRESULT get_MachineOrientationSet (VARIANT_BOOL* retVal)

Applies to

CMMSimulator


MaintainCameraPosition

MaintainCameraPosition - Read & Write property

Description

Retrieves the camera position being maintained during simulation.

Syntax in Visual Basic or VBScript

MaintainCameraPosition () As cmms_CAMERA_POSITION

Syntax in C++

HRESULT get_MaintainCameraPosition (cmms_CAMERA_POSITION* retVal)
HRESULT put_MaintainCameraPosition (cmms_CAMERA_POSITION Value)

Applies to

CMMSimulator


NumberOfMachineAxes

NumberOfMachineAxes - Read property

Description

Number of machine axes.

Syntax in Visual Basic or VBScript

NumberOfMachineAxes () As Long

Syntax in C++

HRESULT get_NumberOfMachineAxes (LONG* retVal)

Applies to

CMMSimulator


ProbeDatabase

ProbeDatabase - Read property

Description

Get the probe database for simulation

Syntax in Visual Basic or VBScript

ProbeDatabase () As ProbeDatabase

Syntax in C++

HRESULT get_ProbeDatabase (ProbeDatabase* retVal)

Applies to

CMMSimulator


ProbeHeadVisible

ProbeHeadVisible - Read & Write property

Description

Show/Hide the ProbeHead

Syntax in Visual Basic or VBScript

ProbeHeadVisible () As Boolean

Syntax in C++

HRESULT get_ProbeHeadVisible (VARIANT_BOOL* retVal)
HRESULT put_ProbeHeadVisible (VARIANT_BOOL Value)

Applies to

CMMSimulator


ProbeStructureBuilder

ProbeStructureBuilder - Read property

Description

Get the probe-structure builder used when creating probe-graphics

Syntax in Visual Basic or VBScript

ProbeStructureBuilder () As ProbeStructureBuilder

Syntax in C++

HRESULT get_ProbeStructureBuilder (ProbeStructureBuilder* retVal)

Applies to

CMMSimulator


ProbeVisible

ProbeVisible - Read & Write property

Description

Show/Hide the Probe

Syntax in Visual Basic or VBScript

ProbeVisible () As Boolean

Syntax in C++

HRESULT get_ProbeVisible (VARIANT_BOOL* retVal)
HRESULT put_ProbeVisible (VARIANT_BOOL Value)

Applies to

CMMSimulator


Statistics

Statistics - Read property

Description

Returns a string containing some animation performance statistics

Syntax in Visual Basic or VBScript

Statistics () As String

Syntax in C++

HRESULT get_Statistics (BSTR* retVal)

Applies to

CMMSimulator


TipOffset

TipOffset - Read property

Description

Retrieve the current tip offset, from Quill mounting point to Tip Position.

Syntax in Visual Basic or VBScript

TipOffset () As Vector3D

Syntax in C++

HRESULT get_TipOffset (Vector3D* retVal)

Applies to

CMMSimulator


TipPosition

TipPosition - Read property

Description

R/O retrieve the current position of the active sensor tip.

Syntax in Visual Basic or VBScript

TipPosition () As Point3D

Syntax in C++

HRESULT get_TipPosition (Point3D* retVal)

Applies to

CMMSimulator


TipShankDirection

TipShankDirection - Read property

Description

Retrieve the current tip shank direction from tip toward the shank.

Syntax in Visual Basic or VBScript

TipShankDirection () As Vector3D

Syntax in C++

HRESULT get_TipShankDirection (Vector3D* retVal)

Applies to

CMMSimulator


ToolMountingPointPosition

ToolMountingPointPosition - Read property

Description

R/O retrieve the current position of the tool mounting point.

Syntax in Visual Basic or VBScript

ToolMountingPointPosition () As Point3D

Syntax in C++

HRESULT get_ToolMountingPointPosition (Point3D* retVal)

Applies to

CMMSimulator


GetMachineAxis

GetMachineAxis - method

Description

Get the absolute value of the machine axis.

Syntax in Visual Basic or VBScript

GetMachineAxis (axis_address As String) As Double

Syntax in C++

HRESULT GetMachineAxis (BSTR axis_address , double* retVal)

Parameters

Name | Description
axis_address |
Return Value |

Applies to

CMMSimulator


InstallProbeHead

InstallProbeHead - method

Description

Install a new probe Head

Syntax in Visual Basic or VBScript

InstallProbeHead (probeheadID As String)

Syntax in C++

HRESULT InstallProbeHead (BSTR probeheadID)

Parameters

Name | Description
probeheadID |

Applies to

CMMSimulator


InstallStandardProbe

InstallStandardProbe - method

Description

Install a standard probe into Probe database (the argument can be the name of a standard probe (i.e TP20x20x2 or a full assembly definition

Syntax in Visual Basic or VBScript

InstallStandardProbe (probeAssemblyOrStdName As String)

Syntax in C++

HRESULT InstallStandardProbe (BSTR probeAssemblyOrStdName)

Parameters

Name | Description
probeAssemblyOrStdName |

Applies to

CMMSimulator


Load

Load - method

Description

Load the full state of the simulator from a stream or a file

Syntax in Visual Basic or VBScript

Load (streamOrFilename As Variant)

Syntax in C++

HRESULT Load (VARIANT streamOrFilename)

Parameters

Name | Description
streamOrFilename |

Applies to

CMMSimulator


LoadCMMConfiguration

LoadCMMConfiguration - method

Description

Install a new cmm kinematic file

Syntax in Visual Basic or VBScript

LoadCMMConfiguration (cmmconfigurationFile As String)

Syntax in C++

HRESULT LoadCMMConfiguration (BSTR cmmconfigurationFile)

Parameters

Name | Description
cmmconfigurationFile |

Applies to

CMMSimulator


LoadConfigurationInteractive

LoadConfigurationInteractive - method

Description

Displays a file dialog to allow user to load the configuration of the simulator

Syntax in Visual Basic or VBScript

LoadConfigurationInteractive ()

Syntax in C++

HRESULT LoadConfigurationInteractive ()

Applies to

CMMSimulator


LoadKinematicsInteractive

LoadKinematicsInteractive - method

Description

Displays a file dialog to allow user to load a different model for the CMM

Syntax in Visual Basic or VBScript

LoadKinematicsInteractive ()

Syntax in C++

HRESULT LoadKinematicsInteractive ()

Applies to

CMMSimulator


MachineAxisAddress

MachineAxisAddress - method

Description

The machine axes address.

Syntax in Visual Basic or VBScript

MachineAxisAddress (axis_number As Long) As String

Syntax in C++

HRESULT MachineAxisAddress (LONG axis_number , BSTR* retVal)

Parameters

Name | Description
axis_number |
Return Value |

Applies to

CMMSimulator


MachineAxisType

MachineAxisType - method

Description

The machine axes type.

Syntax in Visual Basic or VBScript

MachineAxisType (Address As String) As cmms_AXIS_TYPE

Syntax in C++

HRESULT MachineAxisType (BSTR Address , cmms_AXIS_TYPE* retVal)

Parameters

Name | Description
Address |
Return Value |

Applies to

CMMSimulator


MoveProbe

MoveProbe - method

Description

Move the probe to the specified position.

Syntax in Visual Basic or VBScript

MoveProbe (X As Double , Y As Double , Z As Double , coordType As cmms_MOVETYPE)

Syntax in C++

HRESULT MoveProbe (double X , double Y , double Z , cmms_MOVETYPE coordType)

Parameters

Name | Description
X |
Y |
Z |
coordType |

Applies to

CMMSimulator


OnIntermediatePoint

OnIntermediatePoint - event

Description

Fired when the user has inserted a intermediate point

Syntax in Visual Basic or VBScript

OnIntermediatePoint (X As Double , Y As Double , Z As Double)

Syntax in C++

HRESULT OnIntermediatePoint (double X , double Y , double Z)

Parameters

Name | Description
X |
Y |
Z |

Applies to

CMMSimulator


OnManualContactPoint

OnManualContactPoint - event

Description

Fired when a contact point has been probed manually

Syntax in Visual Basic or VBScript

OnManualContactPoint (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double)

Syntax in C++

HRESULT OnManualContactPoint (double X , double Y , double Z , double I , double J , double K)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |

Applies to

CMMSimulator


ProbeStructureExists

ProbeStructureExists - method

Description

Returns TRUE if the graphical structure for the probe specified by the vcard exists

Syntax in Visual Basic or VBScript

ProbeStructureExists (probeNameOrVCARD As String) As Boolean

Syntax in C++

HRESULT ProbeStructureExists (BSTR probeNameOrVCARD , VARIANT_BOOL* retVal)

Parameters

Name | Description
probeNameOrVCARD |
Return Value |

Applies to

CMMSimulator


ResetMachineOrientation

ResetMachineOrientation - method

Description

Reset the machine orientation to the home position.

Syntax in Visual Basic or VBScript

ResetMachineOrientation ()

Syntax in C++

HRESULT ResetMachineOrientation ()

Applies to

CMMSimulator


ResetStatistics

ResetStatistics - method

Description

Reset the animation statistics.

Syntax in Visual Basic or VBScript

ResetStatistics ()

Syntax in C++

HRESULT ResetStatistics ()

Applies to

CMMSimulator


RotateProbe

RotateProbe - method

Description

Rotate the probe head.

Syntax in Visual Basic or VBScript

RotateProbe (A As Double , B As Double , option As cmms_ROTATEHEADOPTION)

Syntax in C++

HRESULT RotateProbe (double A , double B , cmms_ROTATEHEADOPTION option)

Parameters

Name | Description
A |
B |
option |

Applies to

CMMSimulator


Save

Save - method

Description

Save the full state of the simulator in a stream or a file

Syntax in Visual Basic or VBScript

Save (streamOrFilename As Variant)

Syntax in C++

HRESULT Save (VARIANT streamOrFilename)

Parameters

Name | Description
streamOrFilename |

Applies to

CMMSimulator


SaveConfigurationInteractive

SaveConfigurationInteractive - method

Description

Displays a file dialog to allow user to save the configuration of the simulator

Syntax in Visual Basic or VBScript

SaveConfigurationInteractive ()

Syntax in C++

HRESULT SaveConfigurationInteractive ()

Applies to

CMMSimulator


SaveDefaultConfiguration

SaveDefaultConfiguration - method

Description

Save the configuration of the simulator in the default location

Syntax in Visual Basic or VBScript

SaveDefaultConfiguration ()

Syntax in C++

HRESULT SaveDefaultConfiguration ()

Applies to

CMMSimulator


SetMachineAxis

SetMachineAxis - method

Description

Set the absolute value of the machine axis.

Syntax in Visual Basic or VBScript

SetMachineAxis (axis_address As String , abs_value As Double)

Syntax in C++

HRESULT SetMachineAxis (BSTR axis_address , double abs_value)

Parameters

Name | Description
axis_address |
abs_value |

Applies to

CMMSimulator


SetMachineOrientation

SetMachineOrientation - method

Description

Move the machine into the given position/orientation using the kinematic method and constraints given.

Syntax in Visual Basic or VBScript

SetMachineOrientation (ByRef machine_orientation As MachineOrientationData)

Syntax in C++

HRESULT SetMachineOrientation (MachineOrientationData* machine_orientation)

Parameters

Name | Description
machine_orientation |

Applies to

CMMSimulator


SimulateProbePath

SimulateProbePath - method

Description

Start the asynchronous simulation of the probe path.

Syntax in Visual Basic or VBScript

SimulateProbePath (ByRef path As ProbePath , ByRef datum As transform)

Syntax in C++

HRESULT SimulateProbePath (ProbePath* path , transform* datum)

Parameters

Name | Description
path |
datum |

Applies to

CMMSimulator


Stop

Stop - method

Description

stop the simulator

Syntax in Visual Basic or VBScript

Stop ()

Syntax in C++

HRESULT Stop ()

Applies to

CMMSimulator


CMMVectorParameter

CMMVectorParameter - object

Description

CMMVectorParameter Class

Interfaces

ICMMVectorParameter

Methods of ICMMVectorParameter

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
IsValidValue | check if the value provided is suitable for this parameter

Properties of ICMMVectorParameter

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter
vector | R/O | returns the point


CoClass

CoClass - object

Description

Constant Class

Interfaces

ICoClass

Properties of ICoClass

Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.

Collections of ICoClass

EventSources | sources of event
ImpInterfaces | the interfaces implemented by this coclass
Interfaces | Returns collection of interfaces/dispinterfaces/eventsource.


Documentation

Documentation - Read property

Description

property Documentation

Syntax in Visual Basic or VBScript

Documentation () As String

Syntax in C++

HRESULT get_Documentation (BSTR* retVal)

Applies to

CoClass
Constant
Dispinterface
Enum
Function
TypeInfo
TypeLibrary
VarDesc


GUIDAsString

GUIDAsString - Read property

Description

property GUIDAsString

Syntax in Visual Basic or VBScript

GUIDAsString () As String

Syntax in C++

HRESULT get_GUIDAsString (BSTR* retVal)

Applies to

CoClass
Dispinterface
Enum
TypeInfo
TypeLibrary
VarDesc


HelpContext

HelpContext - Read property

Description

property HelpContext

Syntax in Visual Basic or VBScript

HelpContext () As Long

Syntax in C++

HRESULT get_HelpContext (LONG* retVal)

Applies to

CoClass
Constant
Dispinterface
Enum
Function
TypeInfo
TypeLibrary
VarDesc


HelpFile

HelpFile - Read property

Description

property HelpFile

Syntax in Visual Basic or VBScript

HelpFile () As String

Syntax in C++

HRESULT get_HelpFile (BSTR* retVal)

Applies to

CoClass
Constant
Dispinterface
Enum
Function
TypeInfo
TypeLibrary
VarDesc


TypeFlags

TypeFlags - Read property

Description

Returns TYPEFLAGS

Syntax in Visual Basic or VBScript

TypeFlags () As tagTYPEFLAGS

Syntax in C++

HRESULT get_TypeFlags (tagTYPEFLAGS* retVal)

Applies to

CoClass
Dispinterface
Enum
TypeInfo
VarDesc


TypeInfo

TypeInfo - Read property

Description

property TypeInfo

Syntax in Visual Basic or VBScript

TypeInfo () As Object

Syntax in C++

HRESULT get_TypeInfo (IUnknow** retVal)

Applies to

CoClass
Dispinterface
Enum
TypeInfo
VarDesc


TypeInfoKind

TypeInfoKind - Read property

Description

Returns TYPEKIND.

Syntax in Visual Basic or VBScript

TypeInfoKind () As tagTYPEKIND

Syntax in C++

HRESULT get_TypeInfoKind (tagTYPEKIND* retVal)

Applies to

CoClass
Dispinterface
Enum
TypeInfo
VarDesc


EventSources

EventSources - Read property

Description

sources of event

Syntax in Visual Basic or VBScript

EventSources () As Collection

Syntax in C++

HRESULT get_EventSources (Collection* retVal)

Applies to

CoClass


ImpInterfaces

ImpInterfaces - Read property

Description

the interfaces implemented by this coclass

Syntax in Visual Basic or VBScript

ImpInterfaces () As Collection

Syntax in C++

HRESULT get_ImpInterfaces (Collection* retVal)

Applies to

CoClass


Interfaces

Interfaces - Read property

Description

Returns collection of interfaces/dispinterfaces/eventsource.

Syntax in Visual Basic or VBScript

Interfaces () As Collection

Syntax in C++

HRESULT get_Interfaces (Collection* retVal)

Applies to

CoClass


Collection

Collection - object

Description

Collection Class

Interfaces

ICollection

Properties of ICollection

Count | R/W | property Count
Item | R/O | property Item


Count

Count - Read & Write property

Description

property Count

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)
HRESULT put_Count (LONG Value)

Applies to

Collection
ObjectPool
PointCloudSelection
ProbePathItems


Item

Item - Read property

Description

property Item

Syntax in Visual Basic or VBScript

Item (Index As Variant) As IProbePathItem

Syntax in C++

HRESULT get_Item (VARIANT Index , IProbePathItem* retVal)

Applies to

Collection
PointCloud
ProbePathItems


CommandBar

CommandBar - object

Description

CommandBar Class

Interfaces

ICommandBar

Methods of ICommandBar

Delete |
FindControl |
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.

Properties of ICommandBar

BuiltIn | R/O | property BuiltIn
CommandBarType | R/O | property Type
Name | R/W | property Name
Position | R/W |
RowIndex | R/W |
ShowText | R/W | property ShowText
Visible | R/W | property Visible

Collections of ICommandBar

Controls | property Controls
FindControls |


BuiltIn

BuiltIn - Read property

Description

property BuiltIn

Syntax in Visual Basic or VBScript

BuiltIn () As Boolean

Syntax in C++

HRESULT get_BuiltIn (VARIANT_BOOL* retVal)

Applies to

CommandBar
CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


CommandBarType

CommandBarType - Read property

Description

property Type

Syntax in Visual Basic or VBScript

CommandBarType () As PWICommandBarType

Syntax in C++

HRESULT get_CommandBarType (PWICommandBarType* retVal)

Applies to

CommandBar


Position

Position - Read & Write property

Syntax in Visual Basic or VBScript

Position () As PWICommandBarPosition

Syntax in C++

HRESULT get_Position (PWICommandBarPosition* retVal)
HRESULT put_Position (PWICommandBarPosition Value)

Applies to

CommandBar
DatumSphere


RowIndex

RowIndex - Read & Write property

Syntax in Visual Basic or VBScript

RowIndex () As Long

Syntax in C++

HRESULT get_RowIndex (LONG* retVal)
HRESULT put_RowIndex (LONG Value)

Applies to

CommandBar


ShowText

ShowText - Read & Write property

Description

property ShowText

Syntax in Visual Basic or VBScript

ShowText () As Boolean

Syntax in C++

HRESULT get_ShowText (VARIANT_BOOL* retVal)
HRESULT put_ShowText (VARIANT_BOOL Value)

Applies to

CommandBar


Visible

Visible - Read & Write property

Description

property Visible

Syntax in Visual Basic or VBScript

Visible () As Boolean

Syntax in C++

HRESULT get_Visible (VARIANT_BOOL* retVal)
HRESULT put_Visible (VARIANT_BOOL Value)

Applies to

CommandBar
CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


Delete

Delete - method

Syntax in Visual Basic or VBScript

Delete ()

Syntax in C++

HRESULT Delete ()

Applies to

CommandBar


FindControl

FindControl - method

Syntax in Visual Basic or VBScript

FindControl (type As Variant , Id As Variant , Tag As Variant , Visible As Variant , Recursive As Variant) As ICommandBarControl

Syntax in C++

HRESULT FindControl (VARIANT type , VARIANT Id , VARIANT Tag , VARIANT Visible , VARIANT Recursive , ICommandBarControl* retVal)

Parameters

Name | Description
type |
Id |
Tag |
Visible |
Recursive |
Return Value |

Applies to

CommandBar


Reset

Reset - method

Description

Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.

Syntax in Visual Basic or VBScript

Reset ()

Syntax in C++

HRESULT Reset ()

Applies to

ICommandBarControl


Controls

Controls - Read property

Description

property Controls

Syntax in Visual Basic or VBScript

Controls () As CommandBarControls

Syntax in C++

HRESULT get_Controls (CommandBarControls* retVal)

Applies to

CommandBar


FindControls

FindControls - method

Syntax in Visual Basic or VBScript

FindControls (type As Variant , Id As Variant , Tag As Variant , Visible As Variant , Recursive As Variant) As CommandBarControls

Syntax in C++

HRESULT FindControls (VARIANT type , VARIANT Id , VARIANT Tag , VARIANT Visible , VARIANT Recursive , CommandBarControls* retVal)

Parameters

Name | Description
type |
Id |
Tag |
Visible |
Recursive |
Return Value |

Applies to

CommandBar


CommandBarButton

CommandBarButton - object

Description

CommandBarButton Class

Interfaces

ICommandBarButton

Events

Click method Click

Methods of ICommandBarButton

Delete | method Delete
Execute | method Execute
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.
SetFocus | method SetFocus

Properties of ICommandBarButton

BeginGroup | R/W | property BeginGroup
BuiltIn | R/O | property BuiltIn
Caption | R/W | property Caption
ControlType | R/O |
DescriptionText | R/W | property DescriptionText
Enabled | R/W | property Enabled
FaceId | R/W | method Id: returns the Face ID of the button ( the look of the button )
Id | R/O | method Id: returns the command ID of the button
Index | R/O | property Index : returns the index of this elements in the collection ( start at 1 )
OnAction | R/W | property OnAction
Parent | R/O | retrieves the Parent CommandBar
Style | R/W | property Style
Tag | R/W | property Tag: user defined string that help to find the control
TooltipText | R/W | property TooltipText
Visible | R/W | property Visible
Width | R/W | Retrieves/sets the with of the control


BeginGroup

BeginGroup - Read & Write property

Description

property BeginGroup

Syntax in Visual Basic or VBScript

BeginGroup () As Boolean

Syntax in C++

HRESULT get_BeginGroup (VARIANT_BOOL* retVal)
HRESULT put_BeginGroup (VARIANT_BOOL Value)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


Caption

Caption - Read & Write property

Description

property Caption

Syntax in Visual Basic or VBScript

Caption () As String

Syntax in C++

HRESULT get_Caption (BSTR* retVal)
HRESULT put_Caption (BSTR Value)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


ControlType

ControlType - Read property

Syntax in Visual Basic or VBScript

ControlType () As PWICommandControlType

Syntax in C++

HRESULT get_ControlType (PWICommandControlType* retVal)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


DescriptionText

DescriptionText - Read & Write property

Description

property DescriptionText

Syntax in Visual Basic or VBScript

DescriptionText () As String

Syntax in C++

HRESULT get_DescriptionText (BSTR* retVal)
HRESULT put_DescriptionText (BSTR Value)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


Enabled

Enabled - Read & Write property

Description

property Enabled

Syntax in Visual Basic or VBScript

Enabled () As Boolean

Syntax in C++

HRESULT get_Enabled (VARIANT_BOOL* retVal)
HRESULT put_Enabled (VARIANT_BOOL Value)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


FaceId

FaceId - Read & Write property

Description

method Id: returns the Face ID of the button ( the look of the button )

Syntax in Visual Basic or VBScript

FaceId () As Long

Syntax in C++

HRESULT get_FaceId (LONG* retVal)
HRESULT put_FaceId (LONG Value)

Applies to

CommandBarButton


Id

Id - Read property

Description

method Id: returns the command ID of the button

Syntax in Visual Basic or VBScript

Id () As Long

Syntax in C++

HRESULT get_Id (LONG* retVal)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


Index

Index - Read property

Description

property Index : returns the index of this elements in the collection ( start at 1 )

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


OnAction

OnAction - Read & Write property

Description

property OnAction

Syntax in Visual Basic or VBScript

OnAction () As String

Syntax in C++

HRESULT get_OnAction (BSTR* retVal)
HRESULT put_OnAction (BSTR Value)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


Parent

Parent - Read property

Description

retrieves the Parent CommandBar

Syntax in Visual Basic or VBScript

Parent () As CommandBar

Syntax in C++

HRESULT get_Parent (CommandBar* retVal)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


Style

Style - Read & Write property

Description

property Style

Syntax in Visual Basic or VBScript

Style () As PWICommandBarButtonStyle

Syntax in C++

HRESULT get_Style (PWICommandBarButtonStyle* retVal)
HRESULT put_Style (PWICommandBarButtonStyle Value)

Applies to

CommandBarButton


Tag

Tag - Read & Write property

Description

property Tag: user defined string that help to find the control

Syntax in Visual Basic or VBScript

Tag () As String

Syntax in C++

HRESULT get_Tag (BSTR* retVal)
HRESULT put_Tag (BSTR Value)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


TooltipText

TooltipText - Read & Write property

Description

property TooltipText

Syntax in Visual Basic or VBScript

TooltipText () As String

Syntax in C++

HRESULT get_TooltipText (BSTR* retVal)
HRESULT put_TooltipText (BSTR Value)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


Width

Width - Read & Write property

Description

Retrieves/sets the with of the control

Syntax in Visual Basic or VBScript

Width () As Long

Syntax in C++

HRESULT get_Width (LONG* retVal)
HRESULT put_Width (LONG Value)

Applies to

CommandBarButton
CommandBarComboBox
ICommandBarControl
CommandBarPopup


Click

Click - event

Description

method Click

Syntax in Visual Basic or VBScript

Click (ByRef ctrl As CommandBarButton , ByRef bCanceled As Boolean)

Syntax in C++

HRESULT Click (CommandBarButton* ctrl , VARIANT_BOOL* bCanceled , HRESULT* retVal)

Parameters

Name | Description
ctrl |
bCanceled |

Applies to

CommandBarButton


Delete

Delete - method

Description

method Delete

Syntax in Visual Basic or VBScript

Delete ()

Syntax in C++

HRESULT Delete ()

Applies to

ICommandBarControl


Execute

Execute - method

Description

method Execute

Syntax in Visual Basic or VBScript

Execute ()

Syntax in C++

HRESULT Execute ()

Applies to

ICommandBarControl


SetFocus

SetFocus - method

Description

method SetFocus

Syntax in Visual Basic or VBScript

SetFocus ()

Syntax in C++

HRESULT SetFocus ()

Applies to

ICommandBarControl


CommandBarComboBox

CommandBarComboBox - object

Description

CommandBarComboBox Class

Interfaces

ICommandBarComboBox

Events

Change method Change

Methods of ICommandBarComboBox

AddItem | method AddItem
Clear | method Clear
Delete | method Delete
Execute | method Execute
RemoveItem | method RemoveItem
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.
SetFocus | method SetFocus

Properties of ICommandBarComboBox

BeginGroup | R/W | property BeginGroup
BuiltIn | R/O | property BuiltIn
Caption | R/W | property Caption
ControlType | R/O |
DescriptionText | R/W | property DescriptionText
DropDownHeight | R/W | property DropDownHeight
DropDownWidth | R/W | property DropDownWidth
Enabled | R/W | property Enabled
Id | R/O | method Id: returns the command ID of the button
Index | R/O | property Index : returns the index of this elements in the collection ( start at 1 )
ListCount | R/O | property ListCount
ListIndex | R/W | property ListIndex: returns or set the index of the selected iten in the list (0 means none,1 means the first etc...
OnAction | R/W | property OnAction
Parent | R/O | retrieves the Parent CommandBar
Tag | R/W | property Tag: user defined string that help to find the control
Text | R/W | returns or sets the text in the display or edit portion of the command bar combo box control.
TooltipText | R/W | property TooltipText
Visible | R/W | property Visible
Width | R/W | Retrieves/sets the with of the control


DropDownHeight

DropDownHeight - Read & Write property

Description

property DropDownHeight

Syntax in Visual Basic or VBScript

DropDownHeight () As Long

Syntax in C++

HRESULT get_DropDownHeight (LONG* retVal)
HRESULT put_DropDownHeight (LONG Value)

Applies to

CommandBarComboBox


DropDownWidth

DropDownWidth - Read & Write property

Description

property DropDownWidth

Syntax in Visual Basic or VBScript

DropDownWidth () As Long

Syntax in C++

HRESULT get_DropDownWidth (LONG* retVal)
HRESULT put_DropDownWidth (LONG Value)

Applies to

CommandBarComboBox


ListCount

ListCount - Read property

Description

property ListCount

Syntax in Visual Basic or VBScript

ListCount () As Long

Syntax in C++

HRESULT get_ListCount (LONG* retVal)

Applies to

CommandBarComboBox


ListIndex

ListIndex - Read & Write property

Description

property ListIndex: returns or set the index of the selected iten in the list (0 means none,1 means the first etc...

Syntax in Visual Basic or VBScript

ListIndex () As Long

Syntax in C++

HRESULT get_ListIndex (LONG* retVal)
HRESULT put_ListIndex (LONG Value)

Applies to

CommandBarComboBox


Text

Text - Read & Write property

Description

returns or sets the text in the display or edit portion of the command bar combo box control.

Syntax in Visual Basic or VBScript

Text () As String

Syntax in C++

HRESULT get_Text (BSTR* retVal)
HRESULT put_Text (BSTR Value)

Applies to

CommandBarComboBox


AddItem

AddItem - method

Description

method AddItem

Syntax in Visual Basic or VBScript

AddItem (txt As String , Index As Variant)

Syntax in C++

HRESULT AddItem (BSTR txt , VARIANT Index)

Parameters

Name | Description
txt |
Index |

Applies to

CommandBarComboBox


Change

Change - event

Description

method Change

Syntax in Visual Basic or VBScript

Change (ByRef ctrl As CommandBarComboBox)

Syntax in C++

HRESULT Change (CommandBarComboBox* ctrl , HRESULT* retVal)

Parameters

Name | Description
ctrl |

Applies to

CommandBarComboBox


Clear

Clear - method

Description

method Clear

Syntax in Visual Basic or VBScript

Clear ()

Syntax in C++

HRESULT Clear ()

Applies to

CommandBarComboBox


RemoveItem

RemoveItem - method

Description

method RemoveItem

Syntax in Visual Basic or VBScript

RemoveItem (Index As Long)

Syntax in C++

HRESULT RemoveItem (LONG Index)

Parameters

Name | Description
Index |

Applies to

CommandBarComboBox


CommandBarControls

CommandBarControls - object

Description

CommandBarControls Class

Interfaces

ICommandBarControls

Methods of ICommandBarControls

Add method Add

Properties of ICommandBarControls

Count | R/O
Item | R/O


Count

Count - Read property

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

CommandBarControls
CommandBars


Item

Item - Read property

Syntax in Visual Basic or VBScript

Item (lIndex As Variant) As ICommandBarControl

Syntax in C++

HRESULT get_Item (VARIANT lIndex , ICommandBarControl* retVal)

Applies to

CommandBarControls
CommandBars
GDTDatumFeatureLink
ObjectPool


Add

Add - method

Description

method Add

Syntax in Visual Basic or VBScript

Add (type As PWICommandControlType , Id As Variant , atPos As Variant) As ICommandBarControl

Syntax in C++

HRESULT Add (PWICommandControlType type , VARIANT Id , VARIANT atPos , ICommandBarControl* retVal)

Parameters

Name | Description
type |
Id |
atPos |
Return Value |

Applies to

CommandBarControls


CommandBarPopup

CommandBarPopup - object

Description

CommandBarPopup Class

Interfaces

ICommandBarPopup

Methods of ICommandBarPopup

Delete | method Delete
Execute | method Execute
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.
SetFocus | method SetFocus

Properties of ICommandBarPopup

BeginGroup | R/W | property BeginGroup
BuiltIn | R/O | property BuiltIn
Caption | R/W | property Caption
ControlType | R/O |
DescriptionText | R/W | property DescriptionText
Enabled | R/W | property Enabled
Id | R/O | method Id: returns the command ID of the button
Index | R/O | property Index : returns the index of this elements in the collection ( start at 1 )
OnAction | R/W | property OnAction
Parent | R/O | retrieves the Parent CommandBar
Tag | R/W | property Tag: user defined string that help to find the control
TooltipText | R/W | property TooltipText
Visible | R/W | property Visible
Width | R/W | Retrieves/sets the with of the control

Collections of ICommandBarPopup

Controls


Controls

Controls - Read property

Syntax in Visual Basic or VBScript

Controls () As CommandBarControls

Syntax in C++

HRESULT get_Controls (CommandBarControls* retVal)

Applies to

CommandBarPopup


CommandBars

CommandBars - object

Description

CommandBars Class

Interfaces

ICommandBars

Methods of ICommandBars

Add
FindBar
FindControl
GetMessageString

Properties of ICommandBars

ActionControl | R/O | returns the button that has just been pressed
Count | R/O |
DisplayTooltips | R/W | property DisplayTooltips
Item | R/O |
LargeButtons | R/W | property LargeButtons
ParentFrame | R/W | property ParentFrame

Collections of ICommandBars

FindControls


ActionControl

ActionControl - Read property

Description

returns the button that has just been pressed

Syntax in Visual Basic or VBScript

ActionControl () As ICommandBarControl

Syntax in C++

HRESULT get_ActionControl (ICommandBarControl* retVal)

Applies to

CommandBars


DisplayTooltips

DisplayTooltips - Read & Write property

Description

property DisplayTooltips

Syntax in Visual Basic or VBScript

DisplayTooltips () As Boolean

Syntax in C++

HRESULT get_DisplayTooltips (VARIANT_BOOL* retVal)
HRESULT put_DisplayTooltips (VARIANT_BOOL Value)

Applies to

CommandBars


LargeButtons

LargeButtons - Read & Write property

Description

property LargeButtons

Syntax in Visual Basic or VBScript

LargeButtons () As Boolean

Syntax in C++

HRESULT get_LargeButtons (VARIANT_BOOL* retVal)
HRESULT put_LargeButtons (VARIANT_BOOL Value)

Applies to

CommandBars


ParentFrame

ParentFrame - Read & Write property

Description

property ParentFrame

Syntax in Visual Basic or VBScript

ParentFrame () As Long

Syntax in C++

HRESULT get_ParentFrame (LONG* retVal)
HRESULT put_ParentFrame (LONG Value)

Applies to

CommandBars


Add

Add - method

Syntax in Visual Basic or VBScript

Add (Name As Variant , Position As Variant , Temporary As Variant) As CommandBar

Syntax in C++

HRESULT Add (VARIANT Name , VARIANT Position , VARIANT Temporary , CommandBar* retVal)

Parameters

Name | Description
Name |
Position |
Temporary |
Return Value |

Applies to

CommandBars


FindBar

FindBar - method

Syntax in Visual Basic or VBScript

FindBar (type As Variant , Id As Variant) As CommandBar

Syntax in C++

HRESULT FindBar (VARIANT type , VARIANT Id , CommandBar* retVal)

Parameters

Name | Description
type |
Id |
Return Value |

Applies to

CommandBars


GetMessageString

GetMessageString - method

Syntax in Visual Basic or VBScript

GetMessageString (nCmdID As Long , ByRef str As String)

Syntax in C++

HRESULT GetMessageString (ULONG nCmdID , BSTR* str)

Parameters

Name | Description
nCmdID |
str |

Applies to

CommandBars


Constant

Constant - object

Description

Constant Class

Interfaces

IConstant

Properties of IConstant

Documentation | R/O | property Documentation
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Memberid | R/O | Returns memid.
Name | R/W | property Name
Type | R/O | Returns a ITypeDesc object that describes the type of constant.
Value | R/O | Returns value of constant.


Memberid

Memberid - Read property

Description

Returns memid.

Syntax in Visual Basic or VBScript

Memberid () As Long

Syntax in C++

HRESULT get_Memberid (LONG* retVal)

Applies to

Constant


Type

Type - Read property

Description

Returns a ITypeDesc object that describes the type of constant.

Syntax in Visual Basic or VBScript

Type () As TypeDesc

Syntax in C++

HRESULT get_Type (TypeDesc* retVal)

Applies to

Constant


Value

Value - Read property

Description

Returns value of constant.

Syntax in Visual Basic or VBScript

Value () As Variant

Syntax in C++

HRESULT get_Value (VARIANT* retVal)

Applies to

Constant


CustomActionItem

CustomActionItem - object

Interfaces

ICustomActionItem

Methods of ICustomActionItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
Execute | Execute the custom action
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ICustomActionItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
CustomAction | R/W | set/returns the macro to execute when this element is played
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ICustomActionItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


CustomAction

CustomAction - Read & Write property

Description

set/returns the macro to execute when this element is played

Syntax in Visual Basic or VBScript

CustomAction () As String

Syntax in C++

HRESULT get_CustomAction (BSTR* retVal)
HRESULT put_CustomAction (BSTR Value)

Applies to

CustomActionItem


Execute

Execute - method

Description

Execute the custom action

Syntax in Visual Basic or VBScript

Execute () As Boolean

Syntax in C++

HRESULT Execute (VARIANT_BOOL* retVal)

Parameters

Name | Description
Return Value |

Applies to

CustomActionItem


DatumFeatureCollection

DatumFeatureCollection - object

Description

DatumFeatureCollection

Interfaces

IDatumFeatureCollection

Methods of IDatumFeatureCollection

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties of IDatumFeatureCollection

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


Add

Add - method

Description

method Add : add an item to the collection

Syntax in Visual Basic or VBScript

Add (ByRef Rack As DatumSphere)

Syntax in C++

HRESULT Add (DatumSphere* Rack)

Parameters

Name | Description
Rack |

Applies to

DatumFeatureCollection


DatumOnExistingFeatures_

DatumOnExistingFeatures_ - object

Interfaces

IDatumOnExistingFeatures_Item

Methods of IDatumOnExistingFeatures_Item

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IDatumOnExistingFeatures_Item

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ReferenceLine | R/O |
ReferencePlane | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IDatumOnExistingFeatures_Item

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Links3

Links3 - Read property

Syntax in Visual Basic or VBScript

Links3 (typelink As PWI_LINK_LINE_THROUGHPOINTS) As ISequenceLink

Syntax in C++

HRESULT get_Links3 (PWI_LINK_LINE_THROUGHPOINTS typelink , ISequenceLink* retVal)

Applies to

DatumOnExistingFeatures_
DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift
Feat_CircleThroughNPoints
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane


ReferenceLine

ReferenceLine - Read property

Syntax in Visual Basic or VBScript

ReferenceLine () As SimpleLink

Syntax in C++

HRESULT get_ReferenceLine (SimpleLink* retVal)

Applies to

DatumOnExistingFeatures_
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_ProjectedOnPlane
Line_WithAngle
Meas_DistancePointLine
Plane_LinePoint
Plane_LineVector
Point_InterPlaneLine
Point_ProjectedOnLine


ReferencePlane

ReferencePlane - Read property

Syntax in Visual Basic or VBScript

ReferencePlane () As SimpleLink

Syntax in C++

HRESULT get_ReferencePlane (SimpleLink* retVal)

Applies to

DatumOnExistingFeatures_
Feat_CircleThroughNPoints
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
IGeometricCircleItem
Line_Bissector
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_Probed
Line_ProjectedOnPlane
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_DistancePointPlane
Plane_OffsetDistance
Plane_ParallelThroughPoint
Point_Inter2LinesProjected
Point_InterPlaneLine
Point_ProjectedOnPlane


ReferencePoint

ReferencePoint - Read property

Syntax in Visual Basic or VBScript

ReferencePoint () As SimpleLink

Syntax in C++

HRESULT get_ReferencePoint (SimpleLink* retVal)

Applies to

DatumOnExistingFeatures_
Line_PointVector
Line_WithAngle
Meas_DistancePointLine
Meas_DistancePointPlane
Plane_LinePoint
Plane_PointVector
Point_ProjectedOnLine
Point_ProjectedOnPlane


DatumRotate

DatumRotate - object

Interfaces

IDatumRotateItem

Methods of IDatumRotateItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IDatumRotateItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterAngle | R/O |
ParameterAxis | R/O |
ReferenceDatum | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IDatumRotateItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterAngle

ParameterAngle - Read property

Syntax in Visual Basic or VBScript

ParameterAngle () As ParameterAngle

Syntax in C++

HRESULT get_ParameterAngle (ParameterAngle* retVal)

Applies to

DatumRotate
Line_WithAngle


ParameterAxis

ParameterAxis - Read property

Syntax in Visual Basic or VBScript

ParameterAxis () As ParameterDirection

Syntax in C++

HRESULT get_ParameterAxis (ParameterDirection* retVal)

Applies to

DatumRotate


ReferenceDatum

ReferenceDatum - Read property

Syntax in Visual Basic or VBScript

ReferenceDatum () As SimpleLink

Syntax in C++

HRESULT get_ReferenceDatum (SimpleLink* retVal)

Applies to

DatumRotate
DatumRotateToFeature2D
DatumRotateToFeature3D
DatumShift


DatumRotateToFeature2D

DatumRotateToFeature2D - object

Interfaces

IDatumRotateToFeature2DItem

Methods of IDatumRotateToFeature2DItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IDatumRotateToFeature2DItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterFixedPlane | R/O |
ParameterReferenceAxis | R/O |
ReferenceDatum | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
TargetAxis | R/O |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IDatumRotateToFeature2DItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterFixedPlane

ParameterFixedPlane - Read property

Syntax in Visual Basic or VBScript

ParameterFixedPlane () As ParameterMainPlane

Syntax in C++

HRESULT get_ParameterFixedPlane (ParameterMainPlane* retVal)

Applies to

DatumRotateToFeature2D


ParameterReferenceAxis

ParameterReferenceAxis - Read property

Syntax in Visual Basic or VBScript

ParameterReferenceAxis () As ParameterDirection

Syntax in C++

HRESULT get_ParameterReferenceAxis (ParameterDirection* retVal)

Applies to

DatumRotateToFeature2D
DatumRotateToFeature3D


TargetAxis

TargetAxis - Read property

Syntax in Visual Basic or VBScript

TargetAxis () As SimpleLink

Syntax in C++

HRESULT get_TargetAxis (SimpleLink* retVal)

Applies to

DatumRotateToFeature2D
DatumRotateToFeature3D


DatumRotateToFeature3D

DatumRotateToFeature3D - object

Interfaces

IDatumRotateToFeature3DItem

Methods of IDatumRotateToFeature3DItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IDatumRotateToFeature3DItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterReferenceAxis | R/O |
ReferenceDatum | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
TargetAxis | R/O |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IDatumRotateToFeature3DItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


DatumShift

DatumShift - object

Interfaces

IDatumShiftItem

Methods of IDatumShiftItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IDatumShiftItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterNewOrigin | R/O |
ReferenceDatum | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IDatumShiftItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterNewOrigin

ParameterNewOrigin - Read property

Syntax in Visual Basic or VBScript

ParameterNewOrigin () As ParameterPoint3DEx

Syntax in C++

HRESULT get_ParameterNewOrigin (ParameterPoint3DEx* retVal)

Applies to

DatumShift


DatumSphere

DatumSphere - object

Description

DatumSphere Class

Interfaces

IDatumSphere

Methods of IDatumSphere

FillIdentityCard | fill the node with the identity card of this item
SetDiameterUnit | set the value using the specify value ( in the specified units ) without altering the internal units

Properties of IDatumSphere

_ID | R/W | INTERNAL USE ONLY
Calibration | R/O | retrieves the calibration object
Carriage | R/O | retrieves the carriage on which this datum sphere is fitted
Diameter | R/W | retrieve the diameter in MM
DiameterUnit | R/O | Get the current value in the prefered unit
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
Position | R/W |
PreferedUnit | R/O | Get the prefered units
StemDirection | R/O |
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user


Carriage

Carriage - Read property

Description

retrieves the carriage on which this datum sphere is fitted

Syntax in Visual Basic or VBScript

Carriage () As Carriage

Syntax in C++

HRESULT get_Carriage (Carriage* retVal)

Applies to

DatumSphere


Diameter

Diameter - Read & Write property

Description

retrieve the diameter in MM

Syntax in Visual Basic or VBScript

Diameter () As Double

Syntax in C++

HRESULT get_Diameter (double* retVal)
HRESULT put_Diameter (VARIANT Value)

Applies to

DatumSphere


DiameterUnit

DiameterUnit - Read property

Description

Get the current value in the prefered unit

Syntax in Visual Basic or VBScript

DiameterUnit () As Double

Syntax in C++

HRESULT get_DiameterUnit (double* retVal)

Applies to

DatumSphere


PreferedUnit

PreferedUnit - Read property

Description

Get the prefered units

Syntax in Visual Basic or VBScript

PreferedUnit () As String

Syntax in C++

HRESULT get_PreferedUnit (BSTR* retVal)

Applies to

DatumSphere


StemDirection

StemDirection - Read property

Syntax in Visual Basic or VBScript

StemDirection () As UnitVector3D

Syntax in C++

HRESULT get_StemDirection (UnitVector3D* retVal)

Applies to

DatumSphere


SetDiameterUnit

SetDiameterUnit - method

Description

set the value using the specify value ( in the specified units ) without altering the internal units

Syntax in Visual Basic or VBScript

SetDiameterUnit (ret As Double , strUnit As String)

Syntax in C++

HRESULT SetDiameterUnit (double ret , BSTR strUnit)

Parameters

Name | Description
ret |
strUnit |

Applies to

DatumSphere


Dispinterface

Dispinterface - object

Description

Dispinterface Class

Interfaces

IDispinterface

Properties of IDispinterface

Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.

Collections of IDispinterface

Methods | property Methods
Properties | property Properties


Methods

Methods - Read property

Description

property Methods

Syntax in Visual Basic or VBScript

Methods () As Collection

Syntax in C++

HRESULT get_Methods (Collection* retVal)

Applies to

Dispinterface


Properties

Properties - Read property

Description

property Properties

Syntax in Visual Basic or VBScript

Properties () As Collection

Syntax in C++

HRESULT get_Properties (Collection* retVal)

Applies to

Dispinterface


Document

Document - object

Description

a PowerINSPECT Document Object (.PWI)

Interfaces

IDocument

Events

BeforeCommandExecution | indicates that PowerINSPECT is about to execute a command
BeforeDeleteItem | indicates that an item is beeing deleted from document
BeforeDeleteMeasure | indicates that a measure is beeing deleted from document
GeometryExplorerEvent | fired when the user has made a selection with GE
OnActiveItemChange | indictates that the active item ( as selected in the active Tree view ) has changed
OnActiveMeasureChange | indictates that the active measure ( as selected in the active Tree view ) has changed
OnActiveWorkplaneChanged | The current Active work plane has changed
OnAddDynamicPoint | indicates that a dynamic point has been added on the collection
OnAddItem | indicates that a new item has been added to the document
OnBeforeDeleteDynamicPoint | indicates that a dynamic point is about to be removed from the collection
OnBeforeModifyDynamicPoint | indicates that a dynamic point in the collection is about to be modfied
OnBeforeMoveItem | Indicates that the specified item is going to be moved in the sequence tree. there is a opportunity to cancel the action
OnItemChange | indicates that an item definition has changed
OnItemMeasureChange | indicates that an item measurement has changed
OnItemMeasurementCompleted | indictates that element has leaved the Measurement state
OnItemMeasurementStart | indictates that element has entered a Measurement state for the specified measure ( the GUI to measure this item is about to be display )
OnLoggedInUserChanged | Indicates that the user has changed (security). The argument states whether the user can change items in the sequence tree.
OnMeasureAdd | indicates that an new measure has been added to the document
OnModifyDynamicPoint | indicates that a dynamic point in the collection has been modfied
OnPaletteButtonClicked | indicates that PowerINSPECT is about to open the dialog box to edit a inserted item, this give a chance not to display it by setting the boolean flag to TRUE
OnRangeMarkersChanged | indicates that the range markers in the sequence tree have changed.
OnStrategyUpdateRequested | The application has requested a Probe Path Update from the strategy
OnUnitChange | indicates that units of the document has changed
QueryDeleteItem | indicates that an item is asked to be deleted from document by the user
QueryDeleteMeasure | indicates that an measure is asked to be deleted from document by the user

Methods of IDocument

ActivateCustomTab | Bring the indicated custom tab to the front.
CheckIntersectionWithCADModel | Check intersection of a segment with the CAD model along a direction, if multiple solution found then the method returns the closest to point1
Close | Close the specified document
CreateReport | Creates an HTML Report and saves it as a single web-archive file (*.mht file) to the given location
DeactivateCustomTab | Send the indicated custom tab to the back.
FindBestFeaturePlane | Find one feature plane compatible with the given entity excluding features provided by alignments
FindClosestPoint | Find the closest point on the CAD model, within the specified proximity distance. If -1.0 is provided as proximity distance the current default value will be used. An approximation of the expected surface normal can be provided if necessary or Nothing.
FindMeasureByUniqueID | find a SequenceItem by its UniqueID
FindMultiAxisConfigForSequenceItem | Find the MultiaxisConfigurationItem used to set the machine orientation for the given sequence item.
FindSequenceItemByUniqueID | find a SequenceItem by its UniqueID
InstallCustomTab | InstallCustomTab
IntersectionWithCADModel | Intersects a segment with the CAD model along a direction, if multiple solution found then the method returns the closest to point1, a full description of the surface point including point3D , parametric parameter and normal is provided, the function returns ?ç?
IsItemSafeForReplayUI | Check if the given sequence is safe for replay. If not, warn the user and ask them if they wish to replay the item.
IsRangeSafeForReplayUI | Check if the current range of items is safe for replay. If not, warn the user and ask them if they wish to replay the items.
RemoveCustomTab | RemoveCustomTab
Save | Save the specified document. this methoid will fail if the document has not been save yet
SaveAs |
SaveCopyAS | Make a copy of the specified document
SetExcelTemplateName |
TakeOwnership | take ownership of this document, ( note : you must have enough privileged to set the Owner SID
XMLOutput | XMLOutput

Properties of IDocument

ActiveFeatureVisibility | R/W | sets/get the active item visibilty mode
ActiveGroup | R/W | set/retrieve the current active Group Item in the current active Tree( Nothing means top level)
ActiveItem | R/W | set/retrieve the current active Sequence Item in the current active Tree
ActiveMeasure | R/W | set/retrieve the current active Measure in the current active Tree
ActiveWorkplane | R/W | sets/get the current active plane
Application | R/O |
BackfaceColor | R/W | sets/retrieves flag indicating the back-facing color is on
BootstrapPosition | R/O | BootstrapPosition: define the bootstrap aligment defined for this file
CMMDatum | R/O | Returns the CMM Datum item
ConfettiSize | R/W | sets/retrieves the confetti size
EdgePointHighTol | R/W | sets/retrieves the default tolerance for edge points
EdgePointLowTol | R/W | sets/retrieves the default tolerance for edge points
EdgePointOffset | R/W | sets/retrieves the default offset for edge points
EdgePointProximityCriteria | R/W | sets/retrieves the default proximity criteria for edge Point
ExcelTemplateName | R/W |
FindCompatibleFeaturePlanesTolerance | R/W | Allows to set/get tolerance for searching compatible planes
FirstRangeMarker | R/W | Sets/retrieves the first sequence tree sub-range marker.
FullPathName | R/O |
GridMode | R/W | sets/retrieves the grid mode of the active view
HeadClearance | R/W | Sets/gets the head clearance used for collision-checking
HTMLReportTemplateName | R/W | Sets/gets the location of the current HTML Report template
IgnoreMissingContactPoints | R/W | Sets/gets whether the collision-checker ignores missing contact points
LastRangeMarker | R/W | Sets/retrieves the last sequence tree sub-range marker.
ModelShadingMode | R/W | sets/gets the current model shading mode
Name | R/W |
NextItemName | R/O | returns the name that will be given by default to the next created sequence item of the specified type
NominalTransformation | R/O | NominalTransformation: define the nominal transformation defined for this file.
NumberOfDigits | R/W | sets/retrieves the number of digit used to display coordinates or dimension
NumberOfDigitsAngle | R/W | sets/retrieves the number of digit used to display angles.
NumberOfDigitsNeutral | R/W | sets/retrieves the number of digit used to display neutral values.
ObjectPool | R/O |
OwnerSID | R/W |
PCSDatum | R/O | Returns the PCS Datum item
PositioningMatrixForSimulatedMachine | R/O | Get the alignment which maps the PCS (Cad Datum) onto the simulated-machine-datum. Note: Only valid in OMV PRO.
PositioningMatrixForSimulation | R/O | Get the alignment which maps the PCS (Cad Datum) onto the Machine Datum.
ProbePathEditor | R/O | returns the probepath editor object
ProbePathVerificationMode | R/W | Sets/gets the probe path collision-checking mode
ProbePathVisibility | R/W | sets/retrieves the current probe path visibility in CAD view.
ProbeToolClearance | R/W | Sets/gets the probe tool clearance used for collision-checking
ReportSettings | R/O | retrieves report settings of the document
RetracePointAutoCompletionDistance | R/W | sets/retrieves the default maximal distance to target allowed for retrace point
RetracePointAutomaticCompletion | R/W | sets/retrieves the default option for automatic completion ( the retrace point will be automatically accepted if it is within the RetracePointGuidedDistance criteria
RetracePointCatchmentDistance | R/W | sets/retrieves the default catchement distance for retrace points
RetracePointRecordAllPointInCatchementZone | R/W | sets/retrieves the default recording option for retrace point
Saved | R/W | True if no changes have been made to the specified document since it was last saved. Read/write Boolean.
SequenceReplayEngine | T/O | returns a pointer to the SequenceReplayEngine used for the CMM
SequenceSimulatorEngine | T/O | returns a pointer to the SequenceReplayEngine used for the simulation
Simulator | T/O | retrieves the CNC simulator object
SurfacePointHighTol | R/W | sets/retrieves the default tolerance for surface points
SurfacePointLowTol | R/W | sets/retrieves the default tolerance for surface points
SurfacePointOffset | R/W | sets/retrieves the default offset for surface points
SurfacePointProximityCriteria | R/W | sets/retrieves the default proximity criteria for Surface Point
TriangulationTolerance3D | R/W | Get the 3D-triangulation-tolerance
TriangulationToleranceMax3D | R/W | Get the maximum 3D-triangulation-tolerance
Units | R/W |
VerificationStatus | R/O | Returns true if the sequence tree contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.
VerificationStatusOfActiveItem | R/O | Returns true if the active sequence item contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.
VerificationStatusOfRange | R/O | Returns true if the selected range of sequence items contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.

Collections of IDocument

CADFiles |
CADSelectionManager | the CAD Selection manager
DynamicPoints | Dynamic Point collection
Features |
FindCompatibleFeaturePlanes | find a list of plane features that are compatible with the given entity
Measures |
ReportVariables |
SequenceItems |
UserLevels | Collection of user CAD levels belonging to this document.
VerticeSelectionManager | the Vertice Selection manager


ActiveFeatureVisibility

ActiveFeatureVisibility - Read & Write property

Description

sets/get the active item visibilty mode

Syntax in Visual Basic or VBScript

ActiveFeatureVisibility () As PWI_ACTIVEFEATURE_VISIBILITY

Syntax in C++

HRESULT get_ActiveFeatureVisibility (PWI_ACTIVEFEATURE_VISIBILITY* retVal)
HRESULT put_ActiveFeatureVisibility (PWI_ACTIVEFEATURE_VISIBILITY Value)

Applies to

Document


ActiveGroup

ActiveGroup - Read & Write property

Description

set/retrieve the current active Group Item in the current active Tree( Nothing means top level)

Syntax in Visual Basic or VBScript

ActiveGroup () As SequenceGroup

Syntax in C++

HRESULT get_ActiveGroup (SequenceGroup* retVal)
HRESULT put_ActiveGroup (VARIANT Value)

Applies to

Document


ActiveItem

ActiveItem - Read & Write property

Description

set/retrieve the current active Sequence Item in the current active Tree

Syntax in Visual Basic or VBScript

ActiveItem () As SequenceItem

Syntax in C++

HRESULT get_ActiveItem (SequenceItem* retVal)
HRESULT put_ActiveItem (VARIANT Value)

Applies to

Document


ActiveMeasure

ActiveMeasure - Read & Write property

Description

set/retrieve the current active Measure in the current active Tree

Syntax in Visual Basic or VBScript

ActiveMeasure () As measure

Syntax in C++

HRESULT get_ActiveMeasure (measure* retVal)
HRESULT put_ActiveMeasure (VARIANT Value)

Applies to

Document


ActiveWorkplane

ActiveWorkplane - Read & Write property

Description

sets/get the current active plane

Syntax in Visual Basic or VBScript

ActiveWorkplane () As Feature

Syntax in C++

HRESULT get_ActiveWorkplane (Feature* retVal)
HRESULT put_ActiveWorkplane (Feature* Value)

Applies to

Document


Application

Application - Read property

Syntax in Visual Basic or VBScript

Application () As Application

Syntax in C++

HRESULT get_Application (Application* retVal)

Applies to

Document


BackfaceColor

BackfaceColor - Read & Write property

Description

sets/retrieves flag indicating the back-facing color is on

Syntax in Visual Basic or VBScript

BackfaceColor () As Boolean

Syntax in C++

HRESULT get_BackfaceColor (VARIANT_BOOL* retVal)
HRESULT put_BackfaceColor (VARIANT_BOOL Value)

Applies to

Document


BootstrapPosition

BootstrapPosition - Read property

Description

BootstrapPosition: define the bootstrap aligment defined for this file

Syntax in Visual Basic or VBScript

BootstrapPosition () As TransformDefinition

Syntax in C++

HRESULT get_BootstrapPosition (TransformDefinition* retVal)

Applies to

Document


CMMDatum

CMMDatum - Read property

Description

Returns the CMM Datum item

Syntax in Visual Basic or VBScript

CMMDatum () As CMMDatum

Syntax in C++

HRESULT get_CMMDatum (CMMDatum* retVal)

Applies to

Document


ConfettiSize

ConfettiSize - Read & Write property

Description

sets/retrieves the confetti size

Syntax in Visual Basic or VBScript

ConfettiSize () As Double

Syntax in C++

HRESULT get_ConfettiSize (double* retVal)
HRESULT put_ConfettiSize (double Value)

Applies to

Document


EdgePointHighTol

EdgePointHighTol - Read & Write property

Description

sets/retrieves the default tolerance for edge points

Syntax in Visual Basic or VBScript

EdgePointHighTol () As Double

Syntax in C++

HRESULT get_EdgePointHighTol (double* retVal)
HRESULT put_EdgePointHighTol (double Value)

Applies to

Document


EdgePointLowTol

EdgePointLowTol - Read & Write property

Description

sets/retrieves the default tolerance for edge points

Syntax in Visual Basic or VBScript

EdgePointLowTol () As Double

Syntax in C++

HRESULT get_EdgePointLowTol (double* retVal)
HRESULT put_EdgePointLowTol (double Value)

Applies to

Document


EdgePointOffset

EdgePointOffset - Read & Write property

Description

sets/retrieves the default offset for edge points

Syntax in Visual Basic or VBScript

EdgePointOffset () As Double

Syntax in C++

HRESULT get_EdgePointOffset (double* retVal)
HRESULT put_EdgePointOffset (double Value)

Applies to

Document


EdgePointProximityCriteria

EdgePointProximityCriteria - Read & Write property

Description

sets/retrieves the default proximity criteria for edge Point

Syntax in Visual Basic or VBScript

EdgePointProximityCriteria () As Double

Syntax in C++

HRESULT get_EdgePointProximityCriteria (double* retVal)
HRESULT put_EdgePointProximityCriteria (double Value)

Applies to

Document


ExcelTemplateName

ExcelTemplateName - Read & Write property

Syntax in Visual Basic or VBScript

ExcelTemplateName () As String

Syntax in C++

HRESULT get_ExcelTemplateName (BSTR* retVal)
HRESULT put_ExcelTemplateName (BSTR Value)

Applies to

Document


FindCompatibleFeaturePlanesTolerance

FindCompatibleFeaturePlanesTolerance - Read & Write property

Description

Allows to set/get tolerance for searching compatible planes

Syntax in Visual Basic or VBScript

FindCompatibleFeaturePlanesTolerance () As Double

Syntax in C++

HRESULT get_FindCompatibleFeaturePlanesTolerance (double* retVal)
HRESULT put_FindCompatibleFeaturePlanesTolerance (double Value)

Applies to

Document


FirstRangeMarker

FirstRangeMarker - Read & Write property

Description

Sets/retrieves the first sequence tree sub-range marker.

Syntax in Visual Basic or VBScript

FirstRangeMarker () As SequenceItem

Syntax in C++

HRESULT get_FirstRangeMarker (SequenceItem* retVal)
HRESULT put_FirstRangeMarker (SequenceItem* Value)

Applies to

Document


FullPathName

FullPathName - Read property

Syntax in Visual Basic or VBScript

FullPathName () As String

Syntax in C++

HRESULT get_FullPathName (BSTR* retVal)

Applies to

Document


GridMode

GridMode - Read & Write property

Description

sets/retrieves the grid mode of the active view

Syntax in Visual Basic or VBScript

GridMode () As PWI_GridMode

Syntax in C++

HRESULT get_GridMode (PWI_GridMode* retVal)
HRESULT put_GridMode (PWI_GridMode Value)

Applies to

Document


HeadClearance

HeadClearance - Read & Write property

Description

Sets/gets the head clearance used for collision-checking

Syntax in Visual Basic or VBScript

HeadClearance () As Double

Syntax in C++

HRESULT get_HeadClearance (double* retVal)
HRESULT put_HeadClearance (double Value)

Applies to

Document


HTMLReportTemplateName

HTMLReportTemplateName - Read & Write property

Description

Sets/gets the location of the current HTML Report template

Syntax in Visual Basic or VBScript

HTMLReportTemplateName () As String

Syntax in C++

HRESULT get_HTMLReportTemplateName (BSTR* retVal)
HRESULT put_HTMLReportTemplateName (BSTR Value)

Applies to

Document


IgnoreMissingContactPoints

IgnoreMissingContactPoints - Read & Write property

Description

Sets/gets whether the collision-checker ignores missing contact points

Syntax in Visual Basic or VBScript

IgnoreMissingContactPoints () As Boolean

Syntax in C++

HRESULT get_IgnoreMissingContactPoints (VARIANT_BOOL* retVal)
HRESULT put_IgnoreMissingContactPoints (VARIANT_BOOL Value)

Applies to

Document


LastRangeMarker

LastRangeMarker - Read & Write property

Description

Sets/retrieves the last sequence tree sub-range marker.

Syntax in Visual Basic or VBScript

LastRangeMarker () As SequenceItem

Syntax in C++

HRESULT get_LastRangeMarker (SequenceItem* retVal)
HRESULT put_LastRangeMarker (SequenceItem* Value)

Applies to

Document


ModelShadingMode

ModelShadingMode - Read & Write property

Description

sets/gets the current model shading mode

Syntax in Visual Basic or VBScript

ModelShadingMode () As PWI_MODEL_SHADING_MODE

Syntax in C++

HRESULT get_ModelShadingMode (PWI_MODEL_SHADING_MODE* retVal)
HRESULT put_ModelShadingMode (PWI_MODEL_SHADING_MODE Value)

Applies to

Document


Name

Name - Read & Write property

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)
HRESULT put_Name (BSTR Value)

Applies to

ICADEntity
CMMPoint
Document
PDBDefinition
ProbePathItemCNCParameter
IProperty
IProperty1
IProperty3
PropertyAngle
PropertyGeometricTolerance
PropertyLinearDimension
PropertyPoint3D
PropertyRadialDimension
PropertyUnitVector3D
PropertyVector3D
Arc3D
IPWICircle3D
IPWICone
IPWICylinder
IPWILine3D
plane
IPWIPoint
IPWIRectangle
IPWISlot
IPWISphere
IPWITorus
ReportVariable


NextItemName

NextItemName - Read property

Description

returns the name that will be given by default to the next created sequence item of the specified type

Syntax in Visual Basic or VBScript

NextItemName (type As PWI_EntityItemType) As String

Syntax in C++

HRESULT get_NextItemName (PWI_EntityItemType type , BSTR* retVal)

Applies to

Document


NominalTransformation

NominalTransformation - Read property

Description

NominalTransformation: define the nominal transformation defined for this file.

Syntax in Visual Basic or VBScript

NominalTransformation () As TransformDefinition

Syntax in C++

HRESULT get_NominalTransformation (TransformDefinition* retVal)

Applies to

Document


NumberOfDigits

NumberOfDigits - Read & Write property

Description

sets/retrieves the number of digit used to display coordinates or dimension

Syntax in Visual Basic or VBScript

NumberOfDigits () As Long

Syntax in C++

HRESULT get_NumberOfDigits (LONG* retVal)
HRESULT put_NumberOfDigits (LONG Value)

Applies to

Document


NumberOfDigitsAngle

NumberOfDigitsAngle - Read & Write property

Description

sets/retrieves the number of digit used to display angles.

Syntax in Visual Basic or VBScript

NumberOfDigitsAngle () As Long

Syntax in C++

HRESULT get_NumberOfDigitsAngle (LONG* retVal)
HRESULT put_NumberOfDigitsAngle (LONG Value)

Applies to

Document


NumberOfDigitsNeutral

NumberOfDigitsNeutral - Read & Write property

Description

sets/retrieves the number of digit used to display neutral values.

Syntax in Visual Basic or VBScript

NumberOfDigitsNeutral () As Long

Syntax in C++

HRESULT get_NumberOfDigitsNeutral (LONG* retVal)
HRESULT put_NumberOfDigitsNeutral (LONG Value)

Applies to

Document


ObjectPool

ObjectPool - Read property

Syntax in Visual Basic or VBScript

ObjectPool () As ObjectPool

Syntax in C++

HRESULT get_ObjectPool (ObjectPool* retVal)

Applies to

Document


OwnerSID

OwnerSID - Read & Write property

Syntax in Visual Basic or VBScript

OwnerSID () As String

Syntax in C++

HRESULT get_OwnerSID (BSTR* retVal)
HRESULT put_OwnerSID (BSTR Value)

Applies to

Document


PCSDatum

PCSDatum - Read property

Description

Returns the PCS Datum item

Syntax in Visual Basic or VBScript

PCSDatum () As PCSDatum

Syntax in C++

HRESULT get_PCSDatum (PCSDatum* retVal)

Applies to

Document


PositioningMatrixForSimulatedMachine

PositioningMatrixForSimulatedMachine - Read property

Description

Get the alignment which maps the PCS (Cad Datum) onto the simulated-machine-datum. Note: Only valid in OMV PRO.

Syntax in Visual Basic or VBScript

PositioningMatrixForSimulatedMachine (ByRef coef3x4 As Variant) As Boolean

Syntax in C++

HRESULT get_PositioningMatrixForSimulatedMachine (VARIANT* coef3x4 , VARIANT_BOOL* retVal)

Applies to

Document


PositioningMatrixForSimulation

PositioningMatrixForSimulation - Read property

Description

Get the alignment which maps the PCS (Cad Datum) onto the Machine Datum.

Syntax in Visual Basic or VBScript

PositioningMatrixForSimulation (measure_or_empty As Variant , ByRef coef3x4 As Variant) As Boolean

Syntax in C++

HRESULT get_PositioningMatrixForSimulation (VARIANT measure_or_empty , VARIANT* coef3x4 , VARIANT_BOOL* retVal)

Applies to

Document


ProbePathEditor

ProbePathEditor - Read property

Description

returns the probepath editor object

Syntax in Visual Basic or VBScript

ProbePathEditor () As ProbePathEditor

Syntax in C++

HRESULT get_ProbePathEditor (ProbePathEditor* retVal)

Applies to

Document


ProbePathVerificationMode

ProbePathVerificationMode - Read & Write property

Description

Sets/gets the probe path collision-checking mode

Syntax in Visual Basic or VBScript

ProbePathVerificationMode () As Boolean

Syntax in C++

HRESULT get_ProbePathVerificationMode (VARIANT_BOOL* retVal)
HRESULT put_ProbePathVerificationMode (VARIANT_BOOL Value)

Applies to

Document


ProbePathVisibility

ProbePathVisibility - Read & Write property

Description

sets/retrieves the current probe path visibility in CAD view.

Syntax in Visual Basic or VBScript

ProbePathVisibility () As PWI_PROBE_PATH_VISIBILITY

Syntax in C++

HRESULT get_ProbePathVisibility (PWI_PROBE_PATH_VISIBILITY* retVal)
HRESULT put_ProbePathVisibility (PWI_PROBE_PATH_VISIBILITY Value)

Applies to

Document


ProbeToolClearance

ProbeToolClearance - Read & Write property

Description

Sets/gets the probe tool clearance used for collision-checking

Syntax in Visual Basic or VBScript

ProbeToolClearance () As Double

Syntax in C++

HRESULT get_ProbeToolClearance (double* retVal)
HRESULT put_ProbeToolClearance (double Value)

Applies to

Document


ReportSettings

ReportSettings - Read property

Description

retrieves report settings of the document

Syntax in Visual Basic or VBScript

ReportSettings () As ParameterReportSettings

Syntax in C++

HRESULT get_ReportSettings (ParameterReportSettings* retVal)

Applies to

Document


RetracePointAutoCompletionDistance

RetracePointAutoCompletionDistance - Read & Write property

Description

sets/retrieves the default maximal distance to target allowed for retrace point

Syntax in Visual Basic or VBScript

RetracePointAutoCompletionDistance () As Double

Syntax in C++

HRESULT get_RetracePointAutoCompletionDistance (double* retVal)
HRESULT put_RetracePointAutoCompletionDistance (double Value)

Applies to

Document


RetracePointAutomaticCompletion

RetracePointAutomaticCompletion - Read & Write property

Description

sets/retrieves the default option for automatic completion ( the retrace point will be automatically accepted if it is within the RetracePointGuidedDistance criteria

Syntax in Visual Basic or VBScript

RetracePointAutomaticCompletion () As Boolean

Syntax in C++

HRESULT get_RetracePointAutomaticCompletion (VARIANT_BOOL* retVal)
HRESULT put_RetracePointAutomaticCompletion (VARIANT_BOOL Value)

Applies to

Document


RetracePointCatchmentDistance

RetracePointCatchmentDistance - Read & Write property

Description

sets/retrieves the default catchement distance for retrace points

Syntax in Visual Basic or VBScript

RetracePointCatchmentDistance () As Double

Syntax in C++

HRESULT get_RetracePointCatchmentDistance (double* retVal)
HRESULT put_RetracePointCatchmentDistance (double Value)

Applies to

Document


RetracePointRecordAllPointInCatchementZone

RetracePointRecordAllPointInCatchementZone - Read & Write property

Description

sets/retrieves the default recording option for retrace point

Syntax in Visual Basic or VBScript

RetracePointRecordAllPointInCatchementZone () As Boolean

Syntax in C++

HRESULT get_RetracePointRecordAllPointInCatchementZone (VARIANT_BOOL* retVal)
HRESULT put_RetracePointRecordAllPointInCatchementZone (VARIANT_BOOL Value)

Applies to

Document


Saved

Saved - Read & Write property

Description

True if no changes have been made to the specified document since it was last saved. Read/write Boolean.

Syntax in Visual Basic or VBScript

Saved () As Boolean

Syntax in C++

HRESULT get_Saved (VARIANT_BOOL* retVal)
HRESULT put_Saved (VARIANT_BOOL Value)

Applies to

Document


SequenceReplayEngine

SequenceReplayEngine - Reference Write property

Description

returns a pointer to the SequenceReplayEngine used for the CMM

Syntax in Visual Basic or VBScript

SequenceReplayEngine () As Object

Syntax in C++

HRESULT get_SequenceReplayEngine (IDispatch** retVal)

Applies to

Document


SequenceSimulatorEngine

SequenceSimulatorEngine - Reference Write property

Description

returns a pointer to the SequenceReplayEngine used for the simulation

Syntax in Visual Basic or VBScript

SequenceSimulatorEngine () As Object

Syntax in C++

HRESULT get_SequenceSimulatorEngine (IDispatch** retVal)

Applies to

Document


Simulator

Simulator - Reference Write property

Description

retrieves the CNC simulator object

Syntax in Visual Basic or VBScript

Simulator () As Object

Syntax in C++

HRESULT get_Simulator (IDispatch** retVal)

Applies to

Document


SurfacePointHighTol

SurfacePointHighTol - Read & Write property

Description

sets/retrieves the default tolerance for surface points

Syntax in Visual Basic or VBScript

SurfacePointHighTol () As Double

Syntax in C++

HRESULT get_SurfacePointHighTol (double* retVal)
HRESULT put_SurfacePointHighTol (double Value)

Applies to

Document


SurfacePointLowTol

SurfacePointLowTol - Read & Write property

Description

sets/retrieves the default tolerance for surface points

Syntax in Visual Basic or VBScript

SurfacePointLowTol () As Double

Syntax in C++

HRESULT get_SurfacePointLowTol (double* retVal)
HRESULT put_SurfacePointLowTol (double Value)

Applies to

Document


SurfacePointOffset

SurfacePointOffset - Read & Write property

Description

sets/retrieves the default offset for surface points

Syntax in Visual Basic or VBScript

SurfacePointOffset () As Double

Syntax in C++

HRESULT get_SurfacePointOffset (double* retVal)
HRESULT put_SurfacePointOffset (double Value)

Applies to

Document


SurfacePointProximityCriteria

SurfacePointProximityCriteria - Read & Write property

Description

sets/retrieves the default proximity criteria for Surface Point

Syntax in Visual Basic or VBScript

SurfacePointProximityCriteria () As Double

Syntax in C++

HRESULT get_SurfacePointProximityCriteria (double* retVal)
HRESULT put_SurfacePointProximityCriteria (double Value)

Applies to

Document


TriangulationTolerance3D

TriangulationTolerance3D - Read & Write property

Description

Get the 3D-triangulation-tolerance

Syntax in Visual Basic or VBScript

TriangulationTolerance3D () As Double

Syntax in C++

HRESULT get_TriangulationTolerance3D (double* retVal)
HRESULT put_TriangulationTolerance3D (double Value)

Applies to

Document


TriangulationToleranceMax3D

TriangulationToleranceMax3D - Read & Write property

Description

Get the maximum 3D-triangulation-tolerance

Syntax in Visual Basic or VBScript

TriangulationToleranceMax3D () As Double

Syntax in C++

HRESULT get_TriangulationToleranceMax3D (double* retVal)
HRESULT put_TriangulationToleranceMax3D (double Value)

Applies to

Document


Units

Units - Read & Write property

Syntax in Visual Basic or VBScript

Units () As PWI_Units

Syntax in C++

HRESULT get_Units (PWI_Units* retVal)
HRESULT put_Units (PWI_Units Value)

Applies to

Document


VerificationStatus

VerificationStatus - Read property

Description

Returns true if the sequence tree contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.

Syntax in Visual Basic or VBScript

VerificationStatus () As ProbePathVerificationStatus

Syntax in C++

HRESULT get_VerificationStatus (ProbePathVerificationStatus* retVal)

Applies to

Document


VerificationStatusOfActiveItem

VerificationStatusOfActiveItem - Read property

Description

Returns true if the active sequence item contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.

Syntax in Visual Basic or VBScript

VerificationStatusOfActiveItem () As ProbePathVerificationStatus

Syntax in C++

HRESULT get_VerificationStatusOfActiveItem (ProbePathVerificationStatus* retVal)

Applies to

Document


VerificationStatusOfRange

VerificationStatusOfRange - Read property

Description

Returns true if the selected range of sequence items contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.

Syntax in Visual Basic or VBScript

VerificationStatusOfRange () As ProbePathVerificationStatus

Syntax in C++

HRESULT get_VerificationStatusOfRange (ProbePathVerificationStatus* retVal)

Applies to

Document


ActivateCustomTab

ActivateCustomTab - method

Description

Bring the indicated custom tab to the front.

Syntax in Visual Basic or VBScript

ActivateCustomTab (cookie As Variant)

Syntax in C++

HRESULT ActivateCustomTab (VARIANT cookie)

Parameters

Name | Description
cookie |

Applies to

Document


BeforeCommandExecution

BeforeCommandExecution - event

Description

indicates that PowerINSPECT is about to execute a command

Syntax in Visual Basic or VBScript

BeforeCommandExecution (CMMID As Long , ByRef bIntercepted As Boolean)

Syntax in C++

HRESULT BeforeCommandExecution (LONG CMMID , VARIANT_BOOL* bIntercepted)

Parameters

Name | Description
CMMID |
bIntercepted |

Applies to

Document


BeforeDeleteItem

BeforeDeleteItem - event

Description

indicates that an item is beeing deleted from document

Syntax in Visual Basic or VBScript

BeforeDeleteItem (ByRef pItem As SequenceItem)

Syntax in C++

HRESULT BeforeDeleteItem (SequenceItem* pItem)

Parameters

Name | Description
pItem |

Applies to

Document


BeforeDeleteMeasure

BeforeDeleteMeasure - event

Description

indicates that a measure is beeing deleted from document

Syntax in Visual Basic or VBScript

BeforeDeleteMeasure (ByRef pMeasure As measure)

Syntax in C++

HRESULT BeforeDeleteMeasure (measure* pMeasure)

Parameters

Name | Description
pMeasure |

Applies to

Document


CheckIntersectionWithCADModel

CheckIntersectionWithCADModel - method

Description

Check intersection of a segment with the CAD model along a direction, if multiple solution found then the method returns the closest to point1

Syntax in Visual Basic or VBScript

CheckIntersectionWithCADModel (point1 As Variant , point2 As Variant , ByRef intersectionPoint As Variant) As Boolean

Syntax in C++

HRESULT CheckIntersectionWithCADModel (VARIANT point1 , VARIANT point2 , VARIANT* intersectionPoint , VARIANT_BOOL* retVal)

Parameters

Name | Description
point1 |
point2 |
intersectionPoint |
Return Value |

Applies to

Document


Close

Close - method

Description

Close the specified document

Syntax in Visual Basic or VBScript

Close (bSaveChanges As Variant , filename As Variant)

Syntax in C++

HRESULT Close (VARIANT bSaveChanges , VARIANT filename)

Parameters

Name | Description
bSaveChanges |
filename |

Applies to

Document


CreateReport

CreateReport - method

Description

Creates an HTML Report and saves it as a single web-archive file (*.mht file) to the given location

Syntax in Visual Basic or VBScript

CreateReport (a_filename As String , ByRef a_measure As measure)

Syntax in C++

HRESULT CreateReport (BSTR a_filename , measure* a_measure)

Parameters

Name | Description
a_filename |
a_measure |

Applies to

Document


DeactivateCustomTab

DeactivateCustomTab - method

Description

Send the indicated custom tab to the back.

Syntax in Visual Basic or VBScript

DeactivateCustomTab (cookie As Variant)

Syntax in C++

HRESULT DeactivateCustomTab (VARIANT cookie)

Parameters

Name | Description
cookie |

Applies to

Document


FindBestFeaturePlane

FindBestFeaturePlane - method

Description

Find one feature plane compatible with the given entity excluding features provided by alignments

Syntax in Visual Basic or VBScript

FindBestFeaturePlane (ByRef compatible_with As ICADEntity , method As FINDPLANE_METHOD) As Feature

Syntax in C++

HRESULT FindBestFeaturePlane (ICADEntity* compatible_with , FINDPLANE_METHOD method , Feature* retVal)

Parameters

Name | Description
compatible_with |
method |
Return Value |

Applies to

Document


FindClosestPoint

FindClosestPoint - method

Description

Find the closest point on the CAD model, within the specified proximity distance. If -1.0 is provided as proximity distance the current default value will be used. An approximation of the expected surface normal can be provided if necessary or Nothing.

Syntax in Visual Basic or VBScript

FindClosestPoint (ByRef point As Point3D , ByRef approximateVector As Vector3D , proximity As Double) As ISurfacePoint

Syntax in C++

HRESULT FindClosestPoint (Point3D* point , Vector3D* approximateVector , double proximity , ISurfacePoint* retVal)

Parameters

Name | Description
point |
approximateVector |
proximity |
Return Value |

Applies to

Document


FindMeasureByUniqueID

FindMeasureByUniqueID - method

Description

find a SequenceItem by its UniqueID

Syntax in Visual Basic or VBScript

FindMeasureByUniqueID (UniqueID As Long) As measure

Syntax in C++

HRESULT FindMeasureByUniqueID (LONG UniqueID , measure* retVal)

Parameters

Name | Description
UniqueID |
Return Value |

Applies to

Document


FindMultiAxisConfigForSequenceItem

FindMultiAxisConfigForSequenceItem - method

Description

Find the MultiaxisConfigurationItem used to set the machine orientation for the given sequence item.

Syntax in Visual Basic or VBScript

FindMultiAxisConfigForSequenceItem (ByRef Item As SequenceItem) As SequenceItem

Syntax in C++

HRESULT FindMultiAxisConfigForSequenceItem (SequenceItem* Item , SequenceItem* retVal)

Parameters

Name | Description
Item |
Return Value |

Applies to

Document


FindSequenceItemByUniqueID

FindSequenceItemByUniqueID - method

Description

find a SequenceItem by its UniqueID

Syntax in Visual Basic or VBScript

FindSequenceItemByUniqueID (UniqueID As Long) As SequenceItem

Syntax in C++

HRESULT FindSequenceItemByUniqueID (LONG UniqueID , SequenceItem* retVal)

Parameters

Name | Description
UniqueID |
Return Value |

Applies to

Document


GeometryExplorerEvent

GeometryExplorerEvent - event

Description

fired when the user has made a selection with GE

Syntax in Visual Basic or VBScript

GeometryExplorerEvent (reason As PWI_GeometryExplorerEventReason , ByRef Entity As ICADEntity , ByRef selectedReferencePlane As Feature , ByRef intercepted As Boolean)

Syntax in C++

HRESULT GeometryExplorerEvent (PWI_GeometryExplorerEventReason reason , ICADEntity* Entity , Feature* selectedReferencePlane , VARIANT_BOOL* intercepted)

Parameters

Name | Description
reason |
Entity |
selectedReferencePlane |
intercepted |

Applies to

Document


InstallCustomTab

InstallCustomTab - method

Description

InstallCustomTab

Syntax in Visual Basic or VBScript

InstallCustomTab (stringOrHWND As Variant , Name As String , Activate As Long , ByRef cookie As Variant) As Object

Syntax in C++

HRESULT InstallCustomTab (VARIANT stringOrHWND , BSTR Name , LONG Activate , VARIANT* cookie , IUnknow** retVal)

Parameters

Name | Description
stringOrHWND |
Name |
Activate |
cookie |
Return Value |

Applies to

Document


IntersectionWithCADModel

IntersectionWithCADModel - method

Description

Intersects a segment with the CAD model along a direction, if multiple solution found then the method returns the closest to point1, a full description of the surface point including point3D , parametric parameter and normal is provided, the function returns ?ç?

Syntax in Visual Basic or VBScript

IntersectionWithCADModel (point1 As Variant , point2 As Variant) As ISurfacePoint

Syntax in C++

HRESULT IntersectionWithCADModel (VARIANT point1 , VARIANT point2 , ISurfacePoint* retVal)

Parameters

Name | Description
point1 |
point2 |
Return Value |

Applies to

Document


IsItemSafeForReplayUI

IsItemSafeForReplayUI - method

Description

Check if the given sequence is safe for replay. If not, warn the user and ask them if they wish to replay the item.

Syntax in Visual Basic or VBScript

IsItemSafeForReplayUI (ByRef Item As SequenceItem) As Boolean

Syntax in C++

HRESULT IsItemSafeForReplayUI (SequenceItem* Item , VARIANT_BOOL* retVal)

Parameters

Name | Description
Item |
Return Value |

Applies to

Document


IsRangeSafeForReplayUI

IsRangeSafeForReplayUI - method

Description

Check if the current range of items is safe for replay. If not, warn the user and ask them if they wish to replay the items.

Syntax in Visual Basic or VBScript

IsRangeSafeForReplayUI () As Boolean

Syntax in C++

HRESULT IsRangeSafeForReplayUI (VARIANT_BOOL* retVal)

Parameters

Name | Description
Return Value |

Applies to

Document


OnActiveWorkplaneChanged

OnActiveWorkplaneChanged - event

Description

The current Active work plane has changed

Syntax in Visual Basic or VBScript

OnActiveWorkplaneChanged (ByRef pSequenceItem As SequenceItem)

Syntax in C++

HRESULT OnActiveWorkplaneChanged (SequenceItem* pSequenceItem)

Parameters

Name | Description
pSequenceItem |

Applies to

Document


OnAddDynamicPoint

OnAddDynamicPoint - event

Description

indicates that a dynamic point has been added on the collection

Syntax in Visual Basic or VBScript

OnAddDynamicPoint (ByRef pDynamicPoint As DynamicPoint)

Syntax in C++

HRESULT OnAddDynamicPoint (DynamicPoint* pDynamicPoint)

Parameters

Name | Description
pDynamicPoint |

Applies to

Document


OnAddItem

OnAddItem - event

Description

indicates that a new item has been added to the document

Syntax in Visual Basic or VBScript

OnAddItem (ByRef pItem As SequenceItem)

Syntax in C++

HRESULT OnAddItem (SequenceItem* pItem)

Parameters

Name | Description
pItem |

Applies to

Document


OnBeforeDeleteDynamicPoint

OnBeforeDeleteDynamicPoint - event

Description

indicates that a dynamic point is about to be removed from the collection

Syntax in Visual Basic or VBScript

OnBeforeDeleteDynamicPoint (ByRef pDynamicPoint As DynamicPoint)

Syntax in C++

HRESULT OnBeforeDeleteDynamicPoint (DynamicPoint* pDynamicPoint)

Parameters

Name | Description
pDynamicPoint |

Applies to

Document


OnBeforeModifyDynamicPoint

OnBeforeModifyDynamicPoint - event

Description

indicates that a dynamic point in the collection is about to be modfied

Syntax in Visual Basic or VBScript

OnBeforeModifyDynamicPoint (ByRef pDynamicPoint As DynamicPoint)

Syntax in C++

HRESULT OnBeforeModifyDynamicPoint (DynamicPoint* pDynamicPoint)

Parameters

Name | Description
pDynamicPoint |

Applies to

Document


OnBeforeMoveItem

OnBeforeMoveItem - event

Description

Indicates that the specified item is going to be moved in the sequence tree. there is a opportunity to cancel the action

Syntax in Visual Basic or VBScript

OnBeforeMoveItem (ByRef pItemToMove As SequenceItem , ByRef pNewParentGroup As SequenceItem , newPos As Long , ByRef pbCancelationRequested As Boolean)

Syntax in C++

HRESULT OnBeforeMoveItem (SequenceItem* pItemToMove , SequenceItem* pNewParentGroup , LONG newPos , VARIANT_BOOL* pbCancelationRequested)

Parameters

Name | Description
pItemToMove |
pNewParentGroup |
newPos |
pbCancelationRequested |

Applies to

Document


OnItemMeasurementCompleted

OnItemMeasurementCompleted - event

Description

indictates that element has leaved the Measurement state

Syntax in Visual Basic or VBScript

OnItemMeasurementCompleted (ByRef pItem As SequenceItem , ByRef pMeasure As measure , bCanceled As Boolean)

Syntax in C++

HRESULT OnItemMeasurementCompleted (SequenceItem* pItem , measure* pMeasure , VARIANT_BOOL bCanceled)

Parameters

Name | Description
pItem |
pMeasure |
bCanceled |

Applies to

Document


OnItemMeasurementStart

OnItemMeasurementStart - event

Description

indictates that element has entered a Measurement state for the specified measure ( the GUI to measure this item is about to be display )

Syntax in Visual Basic or VBScript

OnItemMeasurementStart (ByRef pItem As SequenceItem , ByRef pMeasure As measure)

Syntax in C++

HRESULT OnItemMeasurementStart (SequenceItem* pItem , measure* pMeasure)

Parameters

Name | Description
pItem |
pMeasure |

Applies to

Document


OnLoggedInUserChanged

OnLoggedInUserChanged - event

Description

Indicates that the user has changed (security). The argument states whether the user can change items in the sequence tree.

Syntax in Visual Basic or VBScript

OnLoggedInUserChanged ()

Syntax in C++

HRESULT OnLoggedInUserChanged ()

Applies to

Document


OnMeasureAdd

OnMeasureAdd - event

Description

indicates that an new measure has been added to the document

Syntax in Visual Basic or VBScript

OnMeasureAdd (ByRef pMeasure As measure)

Syntax in C++

HRESULT OnMeasureAdd (measure* pMeasure)

Parameters

Name | Description
pMeasure |

Applies to

Document


OnModifyDynamicPoint

OnModifyDynamicPoint - event

Description

indicates that a dynamic point in the collection has been modfied

Syntax in Visual Basic or VBScript

OnModifyDynamicPoint (ByRef pDynamicPoint As DynamicPoint)

Syntax in C++

HRESULT OnModifyDynamicPoint (DynamicPoint* pDynamicPoint)

Parameters

Name | Description
pDynamicPoint |

Applies to

Document


OnPaletteButtonClicked

OnPaletteButtonClicked - event

Description

indicates that PowerINSPECT is about to open the dialog box to edit a inserted item, this give a chance not to display it by setting the boolean flag to TRUE

Syntax in Visual Basic or VBScript

OnPaletteButtonClicked (type As PWI_EntityItemType , ByRef bIntercepted As Boolean)

Syntax in C++

HRESULT OnPaletteButtonClicked (PWI_EntityItemType type , VARIANT_BOOL* bIntercepted)

Parameters

Name | Description
type |
bIntercepted |

Applies to

Document


OnRangeMarkersChanged

OnRangeMarkersChanged - event

Description

indicates that the range markers in the sequence tree have changed.

Syntax in Visual Basic or VBScript

OnRangeMarkersChanged ()

Syntax in C++

HRESULT OnRangeMarkersChanged ()

Applies to

Document


OnStrategyUpdateRequested

OnStrategyUpdateRequested - event

Description

The application has requested a Probe Path Update from the strategy

Syntax in Visual Basic or VBScript

OnStrategyUpdateRequested (ByRef pSequenceItem As SequenceItem)

Syntax in C++

HRESULT OnStrategyUpdateRequested (SequenceItem* pSequenceItem)

Parameters

Name | Description
pSequenceItem |

Applies to

Document


OnUnitChange

OnUnitChange - event

Description

indicates that units of the document has changed

Syntax in Visual Basic or VBScript

OnUnitChange (newUnits As PWI_Units)

Syntax in C++

HRESULT OnUnitChange (PWI_Units newUnits)

Parameters

Name | Description
newUnits |

Applies to

Document


QueryDeleteItem

QueryDeleteItem - event

Description

indicates that an item is asked to be deleted from document by the user

Syntax in Visual Basic or VBScript

QueryDeleteItem (ByRef pItem As SequenceItem , requestedFromGUI As Boolean , ByRef bDenied As Boolean)

Syntax in C++

HRESULT QueryDeleteItem (SequenceItem* pItem , VARIANT_BOOL requestedFromGUI , VARIANT_BOOL* bDenied)

Parameters

Name | Description
pItem |
requestedFromGUI |
bDenied |

Applies to

Document


QueryDeleteMeasure

QueryDeleteMeasure - event

Description

indicates that an measure is asked to be deleted from document by the user

Syntax in Visual Basic or VBScript

QueryDeleteMeasure (ByRef pMeasure As measure , requestedFromGUI As Boolean , ByRef bDenied As Boolean)

Syntax in C++

HRESULT QueryDeleteMeasure (measure* pMeasure , VARIANT_BOOL requestedFromGUI , VARIANT_BOOL* bDenied)

Parameters

Name | Description
pMeasure |
requestedFromGUI |
bDenied |

Applies to

Document


RemoveCustomTab

RemoveCustomTab - method

Description

RemoveCustomTab

Syntax in Visual Basic or VBScript

RemoveCustomTab (cookie As Variant)

Syntax in C++

HRESULT RemoveCustomTab (VARIANT cookie)

Parameters

Name | Description
cookie |

Applies to

Document


Save

Save - method

Description

Save the specified document. this methoid will fail if the document has not been save yet

Syntax in Visual Basic or VBScript

Save ()

Syntax in C++

HRESULT Save ()

Applies to

Document


SaveAs

SaveAs - method

Syntax in Visual Basic or VBScript

SaveAs (filename As String , bCreateBackup As Boolean) As Boolean

Syntax in C++

HRESULT SaveAs (BSTR filename , VARIANT_BOOL bCreateBackup , VARIANT_BOOL* retVal)

Parameters

Name | Description
filename |
bCreateBackup |
Return Value |

Applies to

Document


SaveCopyAS

SaveCopyAS - method

Description

Make a copy of the specified document

Syntax in Visual Basic or VBScript

SaveCopyAS (filename As String)

Syntax in C++

HRESULT SaveCopyAS (BSTR filename)

Parameters

Name | Description
filename |

Applies to

Document


SetExcelTemplateName

SetExcelTemplateName - method

Syntax in Visual Basic or VBScript

SetExcelTemplateName (templateName As String , extractVariable As Boolean) As Boolean

Syntax in C++

HRESULT SetExcelTemplateName (BSTR templateName , VARIANT_BOOL extractVariable , VARIANT_BOOL* retVal)

Parameters

Name | Description
templateName |
extractVariable |
Return Value |

Applies to

Document


TakeOwnership

TakeOwnership - method

Description

take ownership of this document, ( note : you must have enough privileged to set the Owner SID

Syntax in Visual Basic or VBScript

TakeOwnership ()

Syntax in C++

HRESULT TakeOwnership ()

Applies to

Document


CADFiles

CADFiles - Read property

Syntax in Visual Basic or VBScript

CADFiles () As CADFiles

Syntax in C++

HRESULT get_CADFiles (CADFiles* retVal)

Applies to

Document


CADSelectionManager

CADSelectionManager - Read property

Description

the CAD Selection manager

Syntax in Visual Basic or VBScript

CADSelectionManager () As SelectionManager

Syntax in C++

HRESULT get_CADSelectionManager (SelectionManager* retVal)

Applies to

Document


DynamicPoints

DynamicPoints - Read property

Description

Dynamic Point collection

Syntax in Visual Basic or VBScript

DynamicPoints () As DynamicPoints

Syntax in C++

HRESULT get_DynamicPoints (DynamicPoints* retVal)

Applies to

Document


Features

Features - method

Syntax in Visual Basic or VBScript

Features (type As PWI_FeatureMask) As Features

Syntax in C++

HRESULT Features (PWI_FeatureMask type , Features* retVal)

Parameters

Name | Description
type |
Return Value |

Applies to

Document


FindCompatibleFeaturePlanes

FindCompatibleFeaturePlanes - method

Description

find a list of plane features that are compatible with the given entity

Syntax in Visual Basic or VBScript

FindCompatibleFeaturePlanes (Entity As Variant , method As FINDPLANE_METHOD) As Features

Syntax in C++

HRESULT FindCompatibleFeaturePlanes (VARIANT Entity , FINDPLANE_METHOD method , Features* retVal)

Parameters

Name | Description
Entity |
method |
Return Value |

Applies to

Document


Measures

Measures - Read property

Syntax in Visual Basic or VBScript

Measures () As Measures

Syntax in C++

HRESULT get_Measures (Measures* retVal)

Applies to

Document


ReportVariables

ReportVariables - Read property

Syntax in Visual Basic or VBScript

ReportVariables () As ReportVariables

Syntax in C++

HRESULT get_ReportVariables (ReportVariables* retVal)

Applies to

Document


SequenceItems

SequenceItems - Read property

Syntax in Visual Basic or VBScript

SequenceItems () As SequenceItems

Syntax in C++

HRESULT get_SequenceItems (SequenceItems* retVal)

Applies to

Document


UserLevels

UserLevels - Read property

Description

Collection of user CAD levels belonging to this document.

Syntax in Visual Basic or VBScript

UserLevels () As CADLevels

Syntax in C++

HRESULT get_UserLevels (CADLevels* retVal)

Applies to

Document


VerticeSelectionManager

VerticeSelectionManager - Read property

Description

the Vertice Selection manager

Syntax in Visual Basic or VBScript

VerticeSelectionManager () As VerticeSelectionManager

Syntax in C++

HRESULT get_VerticeSelectionManager (VerticeSelectionManager* retVal)

Applies to

Document


Documents

Documents - object

Interfaces

IDocuments

Methods of IDocuments

Add | method Add
Close | close all opened documents
Open | Open a particular PowerINSPECT document

Properties of IDocuments

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 1 to Count or a string


Item

Item - Read property

Description

Allows random access to individual document within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Long) As CMMPoint

Syntax in C++

HRESULT get_Item (LONG Index , CMMPoint* retVal)

Applies to

ICADEntities
CMMPoints
Documents
SequenceItemIterator


Add

Add - method

Description

method Add

Syntax in Visual Basic or VBScript

Add () As Document

Syntax in C++

HRESULT Add (Document* retVal)

Parameters

Name | Description
Return Value |

Applies to

Documents


Close

Close - method

Description

close all opened documents

Syntax in Visual Basic or VBScript

Close ()

Syntax in C++

HRESULT Close ()

Applies to

Documents


Open

Open - method

Description

Open a particular PowerINSPECT document

Syntax in Visual Basic or VBScript

Open (filename As String , bMakeVisible As Variant , bReadOnly As Variant , bAddToMRU As Variant) As Document

Syntax in C++

HRESULT Open (BSTR filename , VARIANT bMakeVisible , VARIANT bReadOnly , VARIANT bAddToMRU , Document* retVal)

Parameters

Name | Description
filename |
bMakeVisible |
bReadOnly |
bAddToMRU |
Return Value |

Applies to

Documents


DynamicPoint

DynamicPoint - object

Interfaces

IDynamicPoint

Methods of IDynamicPoint

Convert | convert that point to the type specified, the point will snap to the closest point on the edge or on the surface
CreateGuidedPoint | convert that point into a guided point in the specified group
Delete | delete this item from the collection
Reverse | reverse the normal vector of the point

Properties of IDynamicPoint

DynamicPointType | R/O | get the type of this dynamic point
EdgeID | R/O |
EdgeOffset | R/W | set/get the edge offset
Index | R/O |
LowerTolerance | R/W | set/get the lower tolerance
Name | R/W | set/get the name of the point
point | R/O |
SurfaceID | R/O | get the id of the surface on which this dynamic point lies
SurfaceOffset | R/W | set/get the surface offset
UpperTolerance | R/W | set/get the upper tolerance
vector | R/O |


DynamicPointType

DynamicPointType - Read property

Description

get the type of this dynamic point

Syntax in Visual Basic or VBScript

DynamicPointType () As PWI_DynamicPointType

Syntax in C++

HRESULT get_DynamicPointType (PWI_DynamicPointType* retVal)

Applies to

DynamicPoint


EdgeID

EdgeID - Read property

Syntax in Visual Basic or VBScript

EdgeID () As String

Syntax in C++

HRESULT get_EdgeID (BSTR* retVal)

Applies to

DynamicPoint


EdgeOffset

EdgeOffset - Read & Write property

Description

set/get the edge offset

Syntax in Visual Basic or VBScript

EdgeOffset () As Double

Syntax in C++

HRESULT get_EdgeOffset (double* retVal)
HRESULT put_EdgeOffset (double Value)

Applies to

DynamicPoint


Index

Index - Read property

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

DynamicPoint


LowerTolerance

LowerTolerance - Read & Write property

Description

set/get the lower tolerance

Syntax in Visual Basic or VBScript

LowerTolerance () As Double

Syntax in C++

HRESULT get_LowerTolerance (double* retVal)
HRESULT put_LowerTolerance (double Value)

Applies to

DynamicPoint


Name

Name - Read & Write property

Description

set/get the name of the point

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)
HRESULT put_Name (BSTR Value)

Applies to

DynamicPoint


point

point - Read property

Syntax in Visual Basic or VBScript

point () As Point3D

Syntax in C++

HRESULT get_point (Point3D* retVal)

Applies to

DynamicPoint
IEdgePoint
IPWIPoint
ISurfacePoint


SurfaceID

SurfaceID - Read property

Description

get the id of the surface on which this dynamic point lies

Syntax in Visual Basic or VBScript

SurfaceID () As String

Syntax in C++

HRESULT get_SurfaceID (BSTR* retVal)

Applies to

DynamicPoint


SurfaceOffset

SurfaceOffset - Read & Write property

Description

set/get the surface offset

Syntax in Visual Basic or VBScript

SurfaceOffset () As Double

Syntax in C++

HRESULT get_SurfaceOffset (double* retVal)
HRESULT put_SurfaceOffset (double Value)

Applies to

DynamicPoint


UpperTolerance

UpperTolerance - Read & Write property

Description

set/get the upper tolerance

Syntax in Visual Basic or VBScript

UpperTolerance () As Double

Syntax in C++

HRESULT get_UpperTolerance (double* retVal)
HRESULT put_UpperTolerance (double Value)

Applies to

DynamicPoint


vector

vector - Read property

Syntax in Visual Basic or VBScript

vector () As UnitVector3D

Syntax in C++

HRESULT get_vector (UnitVector3D* retVal)

Applies to

DynamicPoint


Convert

Convert - method

Description

convert that point to the type specified, the point will snap to the closest point on the edge or on the surface

Syntax in Visual Basic or VBScript

Convert (newType As PWI_DynamicPointType) As DynamicPoint

Syntax in C++

HRESULT Convert (PWI_DynamicPointType newType , DynamicPoint* retVal)

Parameters

Name | Description
newType |
Return Value |

Applies to

DynamicPoint


CreateGuidedPoint

CreateGuidedPoint - method

Description

convert that point into a guided point in the specified group

Syntax in Visual Basic or VBScript

CreateGuidedPoint (ByRef theGroup As SurfaceGroup) As SequenceItem

Syntax in C++

HRESULT CreateGuidedPoint (SurfaceGroup* theGroup , SequenceItem* retVal)

Parameters

Name | Description
theGroup |
Return Value |

Applies to

DynamicPoint


Delete

Delete - method

Description

delete this item from the collection

Syntax in Visual Basic or VBScript

Delete ()

Syntax in C++

HRESULT Delete ()

Applies to

DynamicPoint


Reverse

Reverse - method

Description

reverse the normal vector of the point

Syntax in Visual Basic or VBScript

Reverse ()

Syntax in C++

HRESULT Reverse ()

Applies to

DynamicPoint


DynamicPoints

DynamicPoints - object

Interfaces

IDynamicPoints

Events

OnAddDynamicPoint | indicates that a dynamic point has been added on the collection
OnBeforeDeleteDynamicPoint | indicates that a dynamic point is about to be removed from the collection
OnBeforeModifyDynamicPoint | indicates that a dynamic point in the collection is about to be modfied
OnModifyDynamicPoint | indicates that a dynamic point in the collection has been modfied

Methods of IDynamicPoints

CreateDynamicPoint | create a new dynamic point
CreateFreeFormFitAlignment | use all points to create a free form fit alignemnt
CreateGuidedPoints | convert all points of this container into a guided points in the specified group
Delete | method Delete the specifyed measure from the collection
DeleteAll | method Delete all Dynamic Points from the collection

Properties of IDynamicPoints

Count | R/O | returns the number of items in the collection.
Item | R/O | allows random access to individual measure within the collection. Index can be an ordinal from 1 to Count or a string


Count

Count - Read property

Description

returns the number of items in the collection.

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

DynamicPoints
Measures


Item

Item - Read property

Description

allows random access to individual measure within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As measure

Syntax in C++

HRESULT get_Item (VARIANT Index , measure* retVal)

Applies to

DynamicPoints
Measures


CreateDynamicPoint

CreateDynamicPoint - method

Description

create a new dynamic point

Syntax in Visual Basic or VBScript

CreateDynamicPoint (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double) As DynamicPoint

Syntax in C++

HRESULT CreateDynamicPoint (double X , double Y , double Z , double I , double J , double K , DynamicPoint* retVal)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |
Return Value |

Applies to

DynamicPoints


CreateFreeFormFitAlignment

CreateFreeFormFitAlignment - method

Description

use all points to create a free form fit alignemnt

Syntax in Visual Basic or VBScript

CreateFreeFormFitAlignment () As AlignmentItem

Syntax in C++

HRESULT CreateFreeFormFitAlignment (AlignmentItem* retVal)

Parameters

Name | Description
Return Value |

Applies to

DynamicPoints


CreateGuidedPoints

CreateGuidedPoints - method

Description

convert all points of this container into a guided points in the specified group

Syntax in Visual Basic or VBScript

CreateGuidedPoints (ByRef theGroup As SurfaceGroup)

Syntax in C++

HRESULT CreateGuidedPoints (SurfaceGroup* theGroup)

Parameters

Name | Description
theGroup |

Applies to

DynamicPoints


Delete

Delete - method

Description

method Delete the specifyed measure from the collection

Syntax in Visual Basic or VBScript

Delete (Index As Variant)

Syntax in C++

HRESULT Delete (VARIANT Index)

Parameters

Name | Description
Index |

Applies to

Measures


DeleteAll

DeleteAll - method

Description

method Delete all Dynamic Points from the collection

Syntax in Visual Basic or VBScript

DeleteAll ()

Syntax in C++

HRESULT DeleteAll ()

Applies to

DynamicPoints


DynamicTarget

DynamicTarget - object

Interfaces

IDynamicTarget

Properties of IDynamicTarget

Direction | R/O | targetting direction
Name | R/O | name of a point
SurfID | R/O | targetting surface ID
Target | R/O | target point coordinates


Direction

Direction - Read property

Description

targetting direction

Syntax in Visual Basic or VBScript

Direction () As UnitVector3D

Syntax in C++

HRESULT get_Direction (UnitVector3D* retVal)

Applies to

DynamicTarget
DynamicTargetResult


Name

Name - Read property

Description

name of a point

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)

Applies to

DynamicTarget
DynamicTargetResult


SurfID

SurfID - Read property

Description

targetting surface ID

Syntax in Visual Basic or VBScript

SurfID () As Long

Syntax in C++

HRESULT get_SurfID (LONG* retVal)

Applies to

DynamicTarget
DynamicTargetResult


Target

Target - Read property

Description

target point coordinates

Syntax in Visual Basic or VBScript

Target () As Point3D

Syntax in C++

HRESULT get_Target (Point3D* retVal)

Applies to

DynamicTarget
DynamicTargetResult


DynamicTargetResult

DynamicTargetResult - object

Interfaces

IDynamicTargetResult

Properties of IDynamicTargetResult

Direction | R/O | targetting direction
distance | R/O | retuns distance between a projected target and a measured point
HasFailed | R/O | returns is the point failed
Name | R/O | name of a point
SurfID | R/O | targetting surface ID
Target | R/O | target point coordinates


distance

distance - Read property

Description

retuns distance between a projected target and a measured point

Syntax in Visual Basic or VBScript

distance () As Double

Syntax in C++

HRESULT get_distance (double* retVal)

Applies to

DynamicTargetResult


HasFailed

HasFailed - Read property

Description

returns is the point failed

Syntax in Visual Basic or VBScript

HasFailed () As Boolean

Syntax in C++

HRESULT get_HasFailed (VARIANT_BOOL* retVal)

Applies to

DynamicTargetResult


DynamicTargetResults

DynamicTargetResults - object

Interfaces

IDynamicTargetResults

Properties of IDynamicTargetResults

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual points. Index can be an ordinal from 1 to Count or a string


Item

Item - Read property

Description

Allows random access to individual points. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As SurfacePointResult

Syntax in C++

HRESULT get_Item (VARIANT Index , SurfacePointResult* retVal)

Applies to

DynamicTargetResults
DynamicTargets
EdgePointResultStack
SurfacePointResultStack


DynamicTargets

DynamicTargets - object

Interfaces

IDynamicTargets

Properties of IDynamicTargets

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual points. Index can be an ordinal from 1 to Count or a string


EdgePointItem

EdgePointItem - object

Interfaces

IEdgePointItem

Methods of IEdgePointItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
MeasuredPoint | the measured surface point for the given measure
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IEdgePointItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
EdgeOffset | R/W |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LowerTolerance | R/W |
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PointType | R/W |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SurfaceOffset | R/W |
TargetPoint | R/O |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W |
Visible | R/W | return the current state of the visible flag

Collections of IEdgePointItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
ResultStack | stack of results for the given measure


EdgeOffset

EdgeOffset - Read & Write property

Syntax in Visual Basic or VBScript

EdgeOffset () As Double

Syntax in C++

HRESULT get_EdgeOffset (double* retVal)
HRESULT put_EdgeOffset (double Value)

Applies to

EdgePointItem
SurfaceGroup
SurfaceSectionGroup


LowerTolerance

LowerTolerance - Read & Write property

Syntax in Visual Basic or VBScript

LowerTolerance () As Double

Syntax in C++

HRESULT get_LowerTolerance (double* retVal)
HRESULT put_LowerTolerance (double Value)

Applies to

EdgePointItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup


PointType

PointType - Read & Write property

Syntax in Visual Basic or VBScript

PointType () As PWI_PointType

Syntax in C++

HRESULT get_PointType (PWI_PointType* retVal)
HRESULT put_PointType (PWI_PointType Value)

Applies to

EdgePointItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup


SurfaceOffset

SurfaceOffset - Read & Write property

Syntax in Visual Basic or VBScript

SurfaceOffset () As Double

Syntax in C++

HRESULT get_SurfaceOffset (double* retVal)
HRESULT put_SurfaceOffset (double Value)

Applies to

EdgePointItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup


TargetPoint

TargetPoint - Read property

Syntax in Visual Basic or VBScript

TargetPoint () As ISurfacePoint

Syntax in C++

HRESULT get_TargetPoint (ISurfacePoint* retVal)

Applies to

EdgePointItem
SurfacePointItem


UpperTolerance

UpperTolerance - Read & Write property

Syntax in Visual Basic or VBScript

UpperTolerance () As Double

Syntax in C++

HRESULT get_UpperTolerance (double* retVal)
HRESULT put_UpperTolerance (double Value)

Applies to

EdgePointItem
SurfaceGroup
SurfacePointItem
SurfaceSectionGroup


MeasuredPoint

MeasuredPoint - method

Description

the measured surface point for the given measure

Syntax in Visual Basic or VBScript

MeasuredPoint (measure As Variant) As EdgePointResult

Syntax in C++

HRESULT MeasuredPoint (VARIANT measure , EdgePointResult* retVal)

Parameters

Name | Description
measure |
Return Value |

Applies to

EdgePointItem


ResultStack

ResultStack - method

Description

stack of results for the given measure

Syntax in Visual Basic or VBScript

ResultStack (measure As Variant) As EdgePointResultStack

Syntax in C++

HRESULT ResultStack (VARIANT measure , EdgePointResultStack* retVal)

Parameters

Name | Description
measure |
Return Value |

Applies to

EdgePointItem


EdgePointResult

EdgePointResult - object

Interfaces

IEdgePointResult

Properties of IEdgePointResult

ContactPoint | R/O | the coordinates of the probe point in contact with the actual surface
Deviation | R/O | the deviation
DeviationVector | R/O | the deviation vector
EdgePoint | R/O | the information on the projected point
IsValid | R/O |
measure | R/O |
MeasureState | R/O | returns the measurement state
Parent | R/O |
ProbeCenter | R/O | the coordinates of the probe center
ProbeClearanceVector | R/O | the coordinates of the CMM point vector
ProbeDiameter | R/W | the probe diameter


ContactPoint

ContactPoint - Read property

Description

the coordinates of the probe point in contact with the actual surface

Syntax in Visual Basic or VBScript

ContactPoint () As Point3D

Syntax in C++

HRESULT get_ContactPoint (Point3D* retVal)

Applies to

EdgePointResult


Deviation

Deviation - Read property

Description

the deviation

Syntax in Visual Basic or VBScript

Deviation () As Double

Syntax in C++

HRESULT get_Deviation (double* retVal)

Applies to

EdgePointResult


DeviationVector

DeviationVector - Read property

Description

the deviation vector

Syntax in Visual Basic or VBScript

DeviationVector () As Vector3D

Syntax in C++

HRESULT get_DeviationVector (Vector3D* retVal)

Applies to

EdgePointResult
SurfacePointResult


EdgePoint

EdgePoint - Read property

Description

the information on the projected point

Syntax in Visual Basic or VBScript

EdgePoint () As IEdgePoint

Syntax in C++

HRESULT get_EdgePoint (IEdgePoint* retVal)

Applies to

EdgePointResult


ProbeCenter

ProbeCenter - Read property

Description

the coordinates of the probe center

Syntax in Visual Basic or VBScript

ProbeCenter () As Point3D

Syntax in C++

HRESULT get_ProbeCenter (Point3D* retVal)

Applies to

EdgePointResult


ProbeClearanceVector

ProbeClearanceVector - Read property

Description

the coordinates of the CMM point vector

Syntax in Visual Basic or VBScript

ProbeClearanceVector () As UnitVector3D

Syntax in C++

HRESULT get_ProbeClearanceVector (UnitVector3D* retVal)

Applies to

EdgePointResult


ProbeDiameter

ProbeDiameter - Read & Write property

Description

the probe diameter

Syntax in Visual Basic or VBScript

ProbeDiameter () As Double

Syntax in C++

HRESULT get_ProbeDiameter (double* retVal)
HRESULT put_ProbeDiameter (double Value)

Applies to

EdgePointResult
SurfacePointResult


EdgePointResultStack

EdgePointResultStack - object

Interfaces

IEdgePointResultStack

Properties of IEdgePointResultStack

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual points. Index can be an ordinal from 1 to Count or a string


EntityFromPoints

EntityFromPoints - object

Description

EntityFromPoint Class

Interfaces

IEntityFromPoints

Properties of IEntityFromPoints

AverageMinimumZoneEntity | R/O | return the Least Square entity
CalculusMethod | R/W | Calculus Method : describe the method used for the calculation
Deviation | R/O | Deviation : retrieve the signed deviation of the specified point
Entity | R/O | return the entity matching type
EntityType | R/W | return/set the type of the entity
Extra | R/O | Extra
LeastSquareEntity | R/O | return the Least Square entity
MaxDeviation | R/O | retreives the maximum deviation found with the provides CMMpoints
MaxDeviationPointIndex | R/O | retreives the index of the point with the maximum deviation found
MaximumInscribedEntity | R/O | return the Least Square entity
MinimumCircumscribedEntity | R/O | return the Least Square entity
OuterMaterialPoint | R/O | OuterMaterialPoint
ProbeDiameter | R/W | PropDiameter
ReferencePlane | R/O | Reference Plane

Collections of IEntityFromPoints

CMMPoints return a pointer to the inner CMMPoints Array that can be populated


AverageMinimumZoneEntity

AverageMinimumZoneEntity - Read property

Description

return the Least Square entity

Syntax in Visual Basic or VBScript

AverageMinimumZoneEntity () As ICADEntity

Syntax in C++

HRESULT get_AverageMinimumZoneEntity (ICADEntity* retVal)

Applies to

EntityFromPoints


CalculusMethod

CalculusMethod - Read & Write property

Description

Calculus Method : describe the method used for the calculation

Syntax in Visual Basic or VBScript

CalculusMethod () As LSTSQ_CALCULATION

Syntax in C++

HRESULT get_CalculusMethod (LSTSQ_CALCULATION* retVal)
HRESULT put_CalculusMethod (LSTSQ_CALCULATION Value)

Applies to

EntityFromPoints


Deviation

Deviation - Read property

Description

Deviation : retrieve the signed deviation of the specified point

Syntax in Visual Basic or VBScript

Deviation (type As LSTSQ_ENTYPE , point As Variant) As Double

Syntax in C++

HRESULT get_Deviation (LSTSQ_ENTYPE type , VARIANT point , double* retVal)

Applies to

EntityFromPoints


Entity

Entity - Read property

Description

return the entity matching type

Syntax in Visual Basic or VBScript

Entity (type As LSTSQ_ENTYPE) As ICADEntity

Syntax in C++

HRESULT get_Entity (LSTSQ_ENTYPE type , ICADEntity* retVal)

Applies to

EntityFromPoints


EntityType

EntityType - Read & Write property

Description

return/set the type of the entity

Syntax in Visual Basic or VBScript

EntityType () As LSTSQ_TYPE

Syntax in C++

HRESULT get_EntityType (LSTSQ_TYPE* retVal)
HRESULT put_EntityType (LSTSQ_TYPE Value)

Applies to

EntityFromPoints


Extra

Extra - Read property

Description

Extra

Syntax in Visual Basic or VBScript

Extra () As Array

Syntax in C++

HRESULT get_Extra (SAFEARRAY* retVal)

Applies to

EntityFromPoints


LeastSquareEntity

LeastSquareEntity - Read property

Description

return the Least Square entity

Syntax in Visual Basic or VBScript

LeastSquareEntity () As ICADEntity

Syntax in C++

HRESULT get_LeastSquareEntity (ICADEntity* retVal)

Applies to

EntityFromPoints


MaxDeviation

MaxDeviation - Read property

Description

retreives the maximum deviation found with the provides CMMpoints

Syntax in Visual Basic or VBScript

MaxDeviation () As Double

Syntax in C++

HRESULT get_MaxDeviation (double* retVal)

Applies to

EntityFromPoints


MaxDeviationPointIndex

MaxDeviationPointIndex - Read property

Description

retreives the index of the point with the maximum deviation found

Syntax in Visual Basic or VBScript

MaxDeviationPointIndex () As Long

Syntax in C++

HRESULT get_MaxDeviationPointIndex (LONG* retVal)

Applies to

EntityFromPoints


MaximumInscribedEntity

MaximumInscribedEntity - Read property

Description

return the Least Square entity

Syntax in Visual Basic or VBScript

MaximumInscribedEntity () As ICADEntity

Syntax in C++

HRESULT get_MaximumInscribedEntity (ICADEntity* retVal)

Applies to

EntityFromPoints


MinimumCircumscribedEntity

MinimumCircumscribedEntity - Read property

Description

return the Least Square entity

Syntax in Visual Basic or VBScript

MinimumCircumscribedEntity () As ICADEntity

Syntax in C++

HRESULT get_MinimumCircumscribedEntity (ICADEntity* retVal)

Applies to

EntityFromPoints


OuterMaterialPoint

OuterMaterialPoint - Read property

Description

OuterMaterialPoint

Syntax in Visual Basic or VBScript

OuterMaterialPoint () As Point3D

Syntax in C++

HRESULT get_OuterMaterialPoint (Point3D* retVal)

Applies to

EntityFromPoints


ProbeDiameter

ProbeDiameter - Read & Write property

Description

PropDiameter

Syntax in Visual Basic or VBScript

ProbeDiameter () As Double

Syntax in C++

HRESULT get_ProbeDiameter (double* retVal)
HRESULT put_ProbeDiameter (double Value)

Applies to

EntityFromPoints


ReferencePlane

ReferencePlane - Read property

Description

Reference Plane

Syntax in Visual Basic or VBScript

ReferencePlane () As plane

Syntax in C++

HRESULT get_ReferencePlane (plane* retVal)

Applies to

EntityFromPoints


CMMPoints

CMMPoints - Read property

Description

return a pointer to the inner CMMPoints Array that can be populated

Syntax in Visual Basic or VBScript

CMMPoints () As CMMPoints

Syntax in C++

HRESULT get_CMMPoints (CMMPoints* retVal)

Applies to

EntityFromPoints


Enum

Enum - object

Description

Enum Class

Interfaces

IEnum

Properties of IEnum

Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.

Collections of IEnum

Elements property Elements


Elements

Elements - Read property

Description

property Elements

Syntax in Visual Basic or VBScript

Elements () As Collection

Syntax in C++

HRESULT get_Elements (Collection* retVal)

Applies to

Enum


Feat_Circle_PlaneConic

Feat_Circle_PlaneConic - object

Interfaces

IFeat_Circle_PlaneConicItem

Methods of IFeat_Circle_PlaneConicItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_Circle_PlaneConicItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyCircularity | R/O |
ReferenceConic | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_Circle_PlaneConicItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Links2

Links2 - Read property

Syntax in Visual Basic or VBScript

Links2 (typelink As PWI_LINK_MEAS_DISTANCE2POINTS) As ISequenceLink

Syntax in C++

HRESULT get_Links2 (PWI_LINK_MEAS_DISTANCE2POINTS typelink , ISequenceLink* retVal)

Applies to

Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
IGeometricCircleItem
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition


NominalEntity

NominalEntity - Read & Write property

Syntax in Visual Basic or VBScript

NominalEntity () As ICADEntity

Syntax in C++

HRESULT get_NominalEntity (ICADEntity* retVal)
HRESULT put_NominalEntity (ICADEntity* Value)

Applies to

Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_Cone
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
GDTItem
IGeometricCircleItem
IGeometricItem
IGeometricLaserScannedItem
IGeometricLineItem
IGeometricPlaneItem
IGeometricPointItem
LaserScannedCylinder
LaserScannedSlot
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Meas_RelativePosition
NominalPoint
NominalVector
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint


PropertyCircularity

PropertyCircularity - Read property

Syntax in Visual Basic or VBScript

PropertyCircularity () As PropertyGeometricTolerance

Syntax in C++

HRESULT get_PropertyCircularity (PropertyGeometricTolerance* retVal)

Applies to

Feat_Circle_PlaneConic
Feat_CircleThroughNPoints
Feat_ProbedCircle


ReferenceConic

ReferenceConic - Read property

Syntax in Visual Basic or VBScript

ReferenceConic () As SimpleLink

Syntax in C++

HRESULT get_ReferenceConic (SimpleLink* retVal)

Applies to

Feat_Circle_PlaneConic


Feat_CircleThroughNPoints

Feat_CircleThroughNPoints - object

Interfaces

IFeat_CircleThroughNPointsItem

Methods of IFeat_CircleThroughNPointsItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_CircleThroughNPointsItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureArc | R/O |
FeatureCentre | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyCentre | R/O |
PropertyCircularity | R/O |
PropertyRadius | R/O |
ReferencePlane | R/O |
ReferencePoints | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_CircleThroughNPointsItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureArc

FeatureArc - Read property

Syntax in Visual Basic or VBScript

FeatureArc () As Feature

Syntax in C++

HRESULT get_FeatureArc (Feature* retVal)

Applies to

Feat_CircleThroughNPoints
Feat_LaserScannedCircle
Feat_ProbedCircle
Feat_SinglePointCircle
IGeometricCircleItem


FeatureCentre

FeatureCentre - Read property

Syntax in Visual Basic or VBScript

FeatureCentre () As Feature

Syntax in C++

HRESULT get_FeatureCentre (Feature* retVal)

Applies to

Feat_CircleThroughNPoints
Feat_LaserScannedCircle
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
IGeometricCircleItem
LaserScannedSlot


PropertyCentre

PropertyCentre - Read property

Syntax in Visual Basic or VBScript

PropertyCentre () As PropertyPoint3D

Syntax in C++

HRESULT get_PropertyCentre (PropertyPoint3D* retVal)

Applies to

Feat_CircleThroughNPoints
Feat_LaserScannedCircle
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
Feat_Torus
IGeometricCircleItem
LaserScannedSlot


PropertyRadius

PropertyRadius - Read property

Syntax in Visual Basic or VBScript

PropertyRadius () As PropertyRadialDimension

Syntax in C++

HRESULT get_PropertyRadius (PropertyRadialDimension* retVal)

Applies to

Feat_CircleThroughNPoints
Feat_Cylinder
Feat_LaserScannedCircle
Feat_LaserScannedSphere
Feat_ProbedCircle
Feat_SinglePointCircle
Feat_Slot
Feat_Sphere
IGeometricCircleItem
LaserScannedCylinder
LaserScannedSlot


ReferencePoints

ReferencePoints - Read property

Syntax in Visual Basic or VBScript

ReferencePoints () As MultipleLink

Syntax in C++

HRESULT get_ReferencePoints (MultipleLink* retVal)

Applies to

Feat_CircleThroughNPoints


Feat_Cone

Feat_Cone - object

Interfaces

IFeat_ConeItem

Methods of IFeat_ConeItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_ConeItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureApex | R/O |
FeatureAxis | R/O |
FeatureCone | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBasePoint | R/O |
ParameterBoundary | R/O |
ParameterHeight | R/O |
ParameterMaterialSide | R/O |
ParameterQuadrant | R/O |
ParameterRadius | R/O |
PropertyConicity | R/O |
PropertyDirection | R/O |
PropertyHalfAngle | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_ConeItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureApex

FeatureApex - Read property

Syntax in Visual Basic or VBScript

FeatureApex () As Feature

Syntax in C++

HRESULT get_FeatureApex (Feature* retVal)

Applies to

Feat_Cone


FeatureAxis

FeatureAxis - Read property

Syntax in Visual Basic or VBScript

FeatureAxis () As Feature

Syntax in C++

HRESULT get_FeatureAxis (Feature* retVal)

Applies to

Feat_Cone
Feat_Cylinder
Feat_Torus
LaserScannedCylinder


FeatureCone

FeatureCone - Read property

Syntax in Visual Basic or VBScript

FeatureCone () As Feature

Syntax in C++

HRESULT get_FeatureCone (Feature* retVal)

Applies to

Feat_Cone


ParameterBasePoint

ParameterBasePoint - Read property

Syntax in Visual Basic or VBScript

ParameterBasePoint () As ParameterPoint3D

Syntax in C++

HRESULT get_ParameterBasePoint (ParameterPoint3D* retVal)

Applies to

Feat_Cone
Feat_Cylinder
LaserScannedCylinder


ParameterBoundary

ParameterBoundary - Read property

Syntax in Visual Basic or VBScript

ParameterBoundary () As ParameterBoundary

Syntax in C++

HRESULT get_ParameterBoundary (ParameterBoundary* retVal)

Applies to

Feat_Cone
Feat_Cylinder
Feat_LaserScannedPatch
Feat_LaserScannedSphere
IGeometricLineItem
IGeometricPlaneItem
LaserScannedCylinder
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints


ParameterHeight

ParameterHeight - Read property

Syntax in Visual Basic or VBScript

ParameterHeight () As ParameterAngle

Syntax in C++

HRESULT get_ParameterHeight (ParameterAngle* retVal)

Applies to

Feat_Cone
Feat_Cylinder
LaserScannedCylinder


ParameterMaterialSide

ParameterMaterialSide - Read property

Syntax in Visual Basic or VBScript

ParameterMaterialSide () As ParameterMaterialSide

Syntax in C++

HRESULT get_ParameterMaterialSide (ParameterMaterialSide* retVal)

Applies to

Feat_Cone
Feat_Cylinder
Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_Slot
Feat_Sphere
Feat_Torus
Line_Probed


ParameterQuadrant

ParameterQuadrant - Read property

Syntax in Visual Basic or VBScript

ParameterQuadrant () As ParameterAngleQuadrant

Syntax in C++

HRESULT get_ParameterQuadrant (ParameterAngleQuadrant* retVal)

Applies to

Feat_Cone
Feat_Cylinder
Feat_ProbedCircle


ParameterRadius

ParameterRadius - Read property

Syntax in Visual Basic or VBScript

ParameterRadius () As ParameterAngle

Syntax in C++

HRESULT get_ParameterRadius (ParameterAngle* retVal)

Applies to

Feat_Cone


PropertyConicity

PropertyConicity - Read property

Syntax in Visual Basic or VBScript

PropertyConicity () As PropertyGeometricTolerance

Syntax in C++

HRESULT get_PropertyConicity (PropertyGeometricTolerance* retVal)

Applies to

Feat_Cone


PropertyDirection

PropertyDirection - Read property

Syntax in Visual Basic or VBScript

PropertyDirection () As PropertyUnitVector3D

Syntax in C++

HRESULT get_PropertyDirection (PropertyUnitVector3D* retVal)

Applies to

Feat_Cone
Feat_Cylinder
Feat_Torus
IGeometricLineItem
LaserScannedCylinder
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint


PropertyHalfAngle

PropertyHalfAngle - Read property

Syntax in Visual Basic or VBScript

PropertyHalfAngle () As PropertyAngle

Syntax in C++

HRESULT get_PropertyHalfAngle (PropertyAngle* retVal)

Applies to

Feat_Cone


Feat_Cylinder

Feat_Cylinder - object

Interfaces

IFeat_CylinderItem

Methods of IFeat_CylinderItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_CylinderItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxis | R/O |
FeatureCylinder | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBasePoint | R/O |
ParameterBoundary | R/O |
ParameterHeight | R/O |
ParameterMaterialSide | R/O |
ParameterQuadrant | R/O |
PropertyCylindricity | R/O |
PropertyDirection | R/O |
PropertyRadius | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_CylinderItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureCylinder

FeatureCylinder - Read property

Syntax in Visual Basic or VBScript

FeatureCylinder () As Feature

Syntax in C++

HRESULT get_FeatureCylinder (Feature* retVal)

Applies to

Feat_Cylinder
LaserScannedCylinder


PropertyCylindricity

PropertyCylindricity - Read property

Syntax in Visual Basic or VBScript

PropertyCylindricity () As PropertyGeometricTolerance

Syntax in C++

HRESULT get_PropertyCylindricity (PropertyGeometricTolerance* retVal)

Applies to

Feat_Cylinder
LaserScannedCylinder


Feat_LaserScannedCircle

Feat_LaserScannedCircle - object

Interfaces

IFeat_LaserScannedCircleItem

Methods of IFeat_LaserScannedCircleItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_LaserScannedCircleItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureArc | R/O |
FeatureCentre | R/O |
FeatureNormalVector | R/O |
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterEvaluateWithNominal | R/O |
ParameterExtrusion | R/O |
ParameterSearchDistance | R/O |
PointCloud | R/O |
PropertyCentre | R/O |
PropertyNormalVector | R/O |
PropertyRadius | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_LaserScannedCircleItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureNormalVector

FeatureNormalVector - Read property

Syntax in Visual Basic or VBScript

FeatureNormalVector () As Feature

Syntax in C++

HRESULT get_FeatureNormalVector (Feature* retVal)

Applies to

Feat_LaserScannedCircle
Feat_LaserScannedRectangle
LaserScannedSlot


FeaturePlane

FeaturePlane - Read property

Syntax in Visual Basic or VBScript

FeaturePlane () As Feature

Syntax in C++

HRESULT get_FeaturePlane (Feature* retVal)

Applies to

Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
IGeometricPlaneItem
LaserScannedSlot
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_OffsetDistance
Plane_ParallelThroughPoint
Plane_PointVector
Plane_Probed
Plane_WithOffsetPoints


ParameterEvaluateWithNominal

ParameterEvaluateWithNominal - Read property

Syntax in Visual Basic or VBScript

ParameterEvaluateWithNominal () As ParameterAngle

Syntax in C++

HRESULT get_ParameterEvaluateWithNominal (ParameterAngle* retVal)

Applies to

Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
LaserScannedCylinder
LaserScannedSlot


ParameterExtrusion

ParameterExtrusion - Read property

Syntax in Visual Basic or VBScript

ParameterExtrusion () As ParameterAngle

Syntax in C++

HRESULT get_ParameterExtrusion (ParameterAngle* retVal)

Applies to

Feat_LaserScannedCircle
Feat_LaserScannedRectangle
LaserScannedSlot


ParameterSearchDistance

ParameterSearchDistance - Read property

Syntax in Visual Basic or VBScript

ParameterSearchDistance () As ParameterAngle

Syntax in C++

HRESULT get_ParameterSearchDistance (ParameterAngle* retVal)

Applies to

Feat_LaserScannedCircle
Feat_LaserScannedRectangle
LaserScannedSlot


PointCloud

PointCloud - Read property

Syntax in Visual Basic or VBScript

PointCloud (measure As Variant) As PointCloud

Syntax in C++

HRESULT get_PointCloud (VARIANT measure , PointCloud* retVal)

Applies to

Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
Feat_LaserScannedSphere
IGeometricLaserScannedItem
LaserScannedCylinder
LaserScannedSlot


PropertyNormalVector

PropertyNormalVector - Read property

Syntax in Visual Basic or VBScript

PropertyNormalVector () As PropertyUnitVector3D

Syntax in C++

HRESULT get_PropertyNormalVector (PropertyUnitVector3D* retVal)

Applies to

Feat_LaserScannedCircle
Feat_LaserScannedPatch
Feat_LaserScannedRectangle
LaserScannedSlot
Plane_Bissector
Plane_LinePoint
Plane_LineVector
Plane_Probed
Plane_WithOffsetPoints


ExportPoints

ExportPoints - method

Syntax in Visual Basic or VBScript

ExportPoints (measure As Variant , flag As PWI_POINTCLOUD_EXPORT_FLAG , format As PWI_POINTCLOUD_EXPORT_FORMAT , filename As String) As Boolean

Syntax in C++

HRESULT ExportPoints (VARIANT measure , PWI_POINTCLOUD_EXPORT_FLAG flag , PWI_POINTCLOUD_EXPORT_FORMAT format , BSTR filename , VARIANT_BOOL* retVal)

Parameters

Name | Description
measure |
flag |
format |
filename |
Return Value |

Applies to

IGeometricLaserScannedItem


Feat_LaserScannedPatch

Feat_LaserScannedPatch - object

Interfaces

IFeat_LaserScannedPatchItem

Methods of IFeat_LaserScannedPatchItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_LaserScannedPatchItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterEvaluateWithNominal | R/O |
ParameterPoint | R/O |
PointCloud | R/O |
PropertyNormalVector | R/O |
PropertyPlanarity | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_LaserScannedPatchItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterPoint

ParameterPoint - Read property

Syntax in Visual Basic or VBScript

ParameterPoint () As ParameterPoint3D

Syntax in C++

HRESULT get_ParameterPoint (ParameterPoint3D* retVal)

Applies to

Feat_LaserScannedPatch
NominalPoint
Plane_Probed


PropertyPlanarity

PropertyPlanarity - Read property

Syntax in Visual Basic or VBScript

PropertyPlanarity () As PropertyGeometricTolerance

Syntax in C++

HRESULT get_PropertyPlanarity (PropertyGeometricTolerance* retVal)

Applies to

Feat_LaserScannedPatch
Plane_Probed


Feat_LaserScannedRectangle

Feat_LaserScannedRectangle - object

Interfaces

IFeat_LaserScannedRectangleItem

Methods of IFeat_LaserScannedRectangleItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_LaserScannedRectangleItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureMajorAxis | R/O |
FeatureMinorAxis | R/O |
FeatureNormalVector | R/O |
FeaturePlane | R/O |
FeatureRectangle | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterEvaluateWithNominal | R/O |
ParameterExtrusion | R/O |
ParameterSearchDistance | R/O |
PointCloud | R/O |
PropertyCentre | R/O |
PropertyLength | R/O |
PropertyMajorAxis | R/O |
PropertyNormalVector | R/O |
PropertyWidth | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_LaserScannedRectangleItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureMajorAxis

FeatureMajorAxis - Read property

Syntax in Visual Basic or VBScript

FeatureMajorAxis () As Feature

Syntax in C++

HRESULT get_FeatureMajorAxis (Feature* retVal)

Applies to

Feat_LaserScannedRectangle
Feat_Polygone
Feat_Rectangle
Feat_Slot
LaserScannedSlot


FeatureMinorAxis

FeatureMinorAxis - Read property

Syntax in Visual Basic or VBScript

FeatureMinorAxis () As Feature

Syntax in C++

HRESULT get_FeatureMinorAxis (Feature* retVal)

Applies to

Feat_LaserScannedRectangle
Feat_Rectangle
Feat_Slot
LaserScannedSlot


FeatureRectangle

FeatureRectangle - Read property

Syntax in Visual Basic or VBScript

FeatureRectangle () As Feature

Syntax in C++

HRESULT get_FeatureRectangle (Feature* retVal)

Applies to

Feat_LaserScannedRectangle
Feat_Rectangle


PropertyLength

PropertyLength - Read property

Syntax in Visual Basic or VBScript

PropertyLength () As PropertyLinearDimension

Syntax in C++

HRESULT get_PropertyLength (PropertyLinearDimension* retVal)

Applies to

Feat_LaserScannedRectangle
Feat_Rectangle
Feat_Slot
LaserScannedSlot


PropertyMajorAxis

PropertyMajorAxis - Read property

Syntax in Visual Basic or VBScript

PropertyMajorAxis () As PropertyUnitVector3D

Syntax in C++

HRESULT get_PropertyMajorAxis (PropertyUnitVector3D* retVal)

Applies to

Feat_LaserScannedRectangle
Feat_Polygone
Feat_Rectangle
Feat_Slot
LaserScannedSlot


PropertyWidth

PropertyWidth - Read property

Syntax in Visual Basic or VBScript

PropertyWidth () As PropertyLinearDimension

Syntax in C++

HRESULT get_PropertyWidth (PropertyLinearDimension* retVal)

Applies to

Feat_LaserScannedRectangle
Feat_Rectangle


Feat_LaserScannedSphere

Feat_LaserScannedSphere - object

Interfaces

IFeat_LaserScannedSphereItem

Methods of IFeat_LaserScannedSphereItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_LaserScannedSphereItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureSphere | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterEvaluateWithNominal | R/O |
ParameterQuadrantAz | R/O |
ParameterQuadrantEl | R/O |
PointCloud | R/O |
PropertyCentre | R/O |
PropertyRadius | R/O |
PropertySphericity | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_LaserScannedSphereItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureSphere

FeatureSphere - Read property

Syntax in Visual Basic or VBScript

FeatureSphere () As Feature

Syntax in C++

HRESULT get_FeatureSphere (Feature* retVal)

Applies to

Feat_LaserScannedSphere
Feat_Sphere


ParameterQuadrantAz

ParameterQuadrantAz - Read property

Syntax in Visual Basic or VBScript

ParameterQuadrantAz () As ParameterAngleQuadrant

Syntax in C++

HRESULT get_ParameterQuadrantAz (ParameterAngleQuadrant* retVal)

Applies to

Feat_LaserScannedSphere
Feat_Sphere
Feat_Torus


ParameterQuadrantEl

ParameterQuadrantEl - Read property

Syntax in Visual Basic or VBScript

ParameterQuadrantEl () As ParameterAngleQuadrant

Syntax in C++

HRESULT get_ParameterQuadrantEl (ParameterAngleQuadrant* retVal)

Applies to

Feat_LaserScannedSphere
Feat_Sphere
Feat_Torus


PropertySphericity

PropertySphericity - Read property

Syntax in Visual Basic or VBScript

PropertySphericity () As PropertyGeometricTolerance

Syntax in C++

HRESULT get_PropertySphericity (PropertyGeometricTolerance* retVal)

Applies to

Feat_LaserScannedSphere
Feat_Sphere


Feat_Polygone

Feat_Polygone - object

Interfaces

IFeat_PolygoneItem

Methods of IFeat_PolygoneItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_PolygoneItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureMajorAxis | R/O |
FeaturePolygon | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterGuidedMeasure | R/O |
ParameterMaterialSide | R/O |
ParameterNumberOfEgdes | R/O |
ParameterOffset | R/O |
PropertyCentre | R/O |
PropertyExscribedRadius | R/O |
PropertyInscribedRadius | R/O |
PropertyMajorAxis | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_PolygoneItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeaturePolygon

FeaturePolygon - Read property

Syntax in Visual Basic or VBScript

FeaturePolygon () As Feature

Syntax in C++

HRESULT get_FeaturePolygon (Feature* retVal)

Applies to

Feat_Polygone


ParameterGuidedMeasure

ParameterGuidedMeasure - Read property

Syntax in Visual Basic or VBScript

ParameterGuidedMeasure () As ParameterGuidedMeasure

Syntax in C++

HRESULT get_ParameterGuidedMeasure (ParameterGuidedMeasure* retVal)

Applies to

Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_Slot
Line_Probed


ParameterNumberOfEgdes

ParameterNumberOfEgdes - Read property

Syntax in Visual Basic or VBScript

ParameterNumberOfEgdes () As ParameterAngle

Syntax in C++

HRESULT get_ParameterNumberOfEgdes (ParameterAngle* retVal)

Applies to

Feat_Polygone


ParameterOffset

ParameterOffset - Read property

Syntax in Visual Basic or VBScript

ParameterOffset () As ParameterAngle

Syntax in C++

HRESULT get_ParameterOffset (ParameterAngle* retVal)

Applies to

Feat_Polygone
Feat_ProbedCircle
Feat_Rectangle
Feat_SinglePointCircle
Feat_Slot
Line_Probed


PropertyExscribedRadius

PropertyExscribedRadius - Read property

Syntax in Visual Basic or VBScript

PropertyExscribedRadius () As PropertyRadialDimension

Syntax in C++

HRESULT get_PropertyExscribedRadius (PropertyRadialDimension* retVal)

Applies to

Feat_Polygone


PropertyInscribedRadius

PropertyInscribedRadius - Read property

Syntax in Visual Basic or VBScript

PropertyInscribedRadius () As PropertyRadialDimension

Syntax in C++

HRESULT get_PropertyInscribedRadius (PropertyRadialDimension* retVal)

Applies to

Feat_Polygone


Feat_ProbedCircle

Feat_ProbedCircle - object

Interfaces

IFeat_ProbedCircleItem

Methods of IFeat_ProbedCircleItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_ProbedCircleItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureArc | R/O |
FeatureCentre | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterGuidedMeasure | R/O |
ParameterMaterialSide | R/O |
ParameterOffset | R/O |
ParameterQuadrant | R/O |
PropertyCentre | R/O |
PropertyCircularity | R/O |
PropertyRadius | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_ProbedCircleItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Feat_Rectangle

Feat_Rectangle - object

Interfaces

IFeat_RectangleItem

Methods of IFeat_RectangleItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_RectangleItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureMajorAxis | R/O |
FeatureMinorAxis | R/O |
FeatureRectangle | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterGuidedMeasure | R/O |
ParameterMaterialSide | R/O |
ParameterOffset | R/O |
PropertyCentre | R/O |
PropertyLength | R/O |
PropertyMajorAxis | R/O |
PropertyWidth | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_RectangleItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Feat_SinglePointCircle

Feat_SinglePointCircle - object

Interfaces

IFeat_SinglePointCircleItem

Methods of IFeat_SinglePointCircleItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_SinglePointCircleItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureArc | R/O |
FeatureCentre | R/O |
FeatureProbeCenter | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterOffset | R/O |
PropertyCentre | R/O |
PropertyRadius | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_SinglePointCircleItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureProbeCenter

FeatureProbeCenter - Read property

Syntax in Visual Basic or VBScript

FeatureProbeCenter () As Feature

Syntax in C++

HRESULT get_FeatureProbeCenter (Feature* retVal)

Applies to

Feat_SinglePointCircle


Feat_Slot

Feat_Slot - object

Interfaces

IFeat_SlotItem

Methods of IFeat_SlotItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_SlotItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureCentre1 | R/O |
FeatureCentre2 | R/O |
FeatureMajorAxis | R/O |
FeatureMinorAxis | R/O |
FeatureRoundedSlot | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterGuidedMeasure | R/O |
ParameterMaterialSide | R/O |
ParameterOffset | R/O |
PropertyCentre | R/O |
PropertyLength | R/O |
PropertyMajorAxis | R/O |
PropertyProfile | R/O |
PropertyRadius | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_SlotItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureCentre1

FeatureCentre1 - Read property

Syntax in Visual Basic or VBScript

FeatureCentre1 () As Feature

Syntax in C++

HRESULT get_FeatureCentre1 (Feature* retVal)

Applies to

Feat_Slot
LaserScannedSlot


FeatureCentre2

FeatureCentre2 - Read property

Syntax in Visual Basic or VBScript

FeatureCentre2 () As Feature

Syntax in C++

HRESULT get_FeatureCentre2 (Feature* retVal)

Applies to

Feat_Slot
LaserScannedSlot


FeatureRoundedSlot

FeatureRoundedSlot - Read property

Syntax in Visual Basic or VBScript

FeatureRoundedSlot () As Feature

Syntax in C++

HRESULT get_FeatureRoundedSlot (Feature* retVal)

Applies to

Feat_Slot
LaserScannedSlot


PropertyProfile

PropertyProfile - Read property

Syntax in Visual Basic or VBScript

PropertyProfile () As PropertyGeometricTolerance

Syntax in C++

HRESULT get_PropertyProfile (PropertyGeometricTolerance* retVal)

Applies to

Feat_Slot
Feat_Torus
LaserScannedSlot


Feat_Sphere

Feat_Sphere - object

Interfaces

IFeat_SphereItem

Methods of IFeat_SphereItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_SphereItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureSphere | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterMaterialSide | R/O |
ParameterOrientation | R/O |
ParameterQuadrantAz | R/O |
ParameterQuadrantEl | R/O |
PropertyCentre | R/O |
PropertyRadius | R/O |
PropertySphericity | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_SphereItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterOrientation

ParameterOrientation - Read property

Syntax in Visual Basic or VBScript

ParameterOrientation () As ParameterVector3D

Syntax in C++

HRESULT get_ParameterOrientation (ParameterVector3D* retVal)

Applies to

Feat_Sphere


Feat_Torus

Feat_Torus - object

Interfaces

IFeat_TorusItem

Methods of IFeat_TorusItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IFeat_TorusItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxis | R/O |
FeatureCentre | R/O |
FeatureTorus | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterMaterialSide | R/O |
ParameterQuadrantAz | R/O |
ParameterQuadrantEl | R/O |
PropertyCentre | R/O |
PropertyDirection | R/O |
PropertyMajorRadius | R/O |
PropertyMinorRadius | R/O |
PropertyProfile | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IFeat_TorusItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureTorus

FeatureTorus - Read property

Syntax in Visual Basic or VBScript

FeatureTorus () As Feature

Syntax in C++

HRESULT get_FeatureTorus (Feature* retVal)

Applies to

Feat_Torus


PropertyMajorRadius

PropertyMajorRadius - Read property

Syntax in Visual Basic or VBScript

PropertyMajorRadius () As PropertyRadialDimension

Syntax in C++

HRESULT get_PropertyMajorRadius (PropertyRadialDimension* retVal)

Applies to

Feat_Torus


PropertyMinorRadius

PropertyMinorRadius - Read property

Syntax in Visual Basic or VBScript

PropertyMinorRadius () As PropertyRadialDimension

Syntax in C++

HRESULT get_PropertyMinorRadius (PropertyRadialDimension* retVal)

Applies to

Feat_Torus


Feature

Feature - object

Interfaces

IFeature

Properties of IFeature

Description | R/O | return a description of the feature in the current locale language
Entity | R/O | extract the entity for the feature
FeatureType | R/O | property FeatureType : Get the type of this Feature
Handle | R/O | return the handle of this item
ID | R/O | property ID : Get the ID of this Feature
Index | R/O | returns the index of this property in its parent collection
Name | R/O | property Name : return the name of this feature
Parent | R/O | return ISequence Item that owns this feature

Collections of IFeature

ConnectedLinks return the collection of the links that reference this feature


Description - Read property

Description

return a description of the feature in the current locale language

Syntax in Visual Basic or VBScript

Description () As String

Syntax in C++

HRESULT get_Description (BSTR* retVal)

Applies to

Feature
GDTDatumFeatureLink
GDTFeaturesLink
ISequenceLink
MultipleLink
SimpleLink


Entity

Entity - Read property

Description

extract the entity for the feature

Syntax in Visual Basic or VBScript

Entity (measure As Variant) As ICADEntity

Syntax in C++

HRESULT get_Entity (VARIANT measure , ICADEntity* retVal)

Applies to

Feature


FeatureType

FeatureType - Read property

Description

property FeatureType : Get the type of this Feature

Syntax in Visual Basic or VBScript

FeatureType () As PWI_FeatureType

Syntax in C++

HRESULT get_FeatureType (PWI_FeatureType* retVal)

Applies to

Feature


Handle

Handle - Read property

Description

return the handle of this item

Syntax in Visual Basic or VBScript

Handle () As Long

Syntax in C++

HRESULT get_Handle (LONG* retVal)

Applies to

Feature


ID

ID - Read property

Description

property ID : Get the ID of this Feature

Syntax in Visual Basic or VBScript

ID () As Integer

Syntax in C++

HRESULT get_ID (INT* retVal)

Applies to

Feature


Index

Index - Read property

Description

returns the index of this property in its parent collection

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

Feature
GDTDatumFeatureLink
GDTFeaturesLink
Parameter
ParameterAngle
ParameterAngleQuadrant
ParameterBoundary
ParameterCompensationMethod
ParameterCompositeOffset
ParameterDirection
IParameterEnum
ParameterGuidedMeasure
ParameterMainPlane
ParameterMaterialCondition
ParameterMaterialSide
ParameterMatrixDefinition
ParameterPoint3D
ParameterPoint3DEx
ParameterReportSettings
ParameterRPSConstraints
ParameterVector3D
ParameterVector3DEx
IProperty
IProperty1
IProperty3
PropertyAngle
PropertyGeometricTolerance
PropertyLinearDimension
PropertyPoint3D
PropertyRadialDimension
PropertyUnitVector3D
PropertyVector3D
ISequenceLink
MultipleLink
SimpleLink


Name

Name - Read property

Description

property Name : return the name of this feature

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)

Applies to

Feature


Parent

Parent - Read property

Description

return ISequence Item that owns this feature

Syntax in Visual Basic or VBScript

Parent () As SequenceItem

Syntax in C++

HRESULT get_Parent (SequenceItem* retVal)

Applies to

Feature
GDTDatumFeatureLink
GDTFeaturesLink
Parameter
ParameterAngle
ParameterAngleQuadrant
ParameterBoundary
ParameterCompensationMethod
ParameterCompositeOffset
ParameterDirection
IParameterEnum
ParameterGuidedMeasure
ParameterMainPlane
ParameterMaterialCondition
ParameterMaterialSide
ParameterMatrixDefinition
ParameterPoint3D
ParameterPoint3DEx
ParameterReportSettings
ParameterRPSConstraints
ParameterVector3D
ParameterVector3DEx
IProperty
IProperty1
IProperty3
PropertyAngle
PropertyGeometricTolerance
PropertyLinearDimension
PropertyPoint3D
PropertyRadialDimension
PropertyUnitVector3D
PropertyVector3D
ISequenceLink
MultipleLink
SimpleLink


ConnectedLinks

ConnectedLinks - Read property

Description

return the collection of the links that reference this feature

Syntax in Visual Basic or VBScript

ConnectedLinks () As Links

Syntax in C++

HRESULT get_ConnectedLinks (Links* retVal)

Applies to

Feature


Features

Features - object

Interfaces

IFeatures

Methods of IFeatures

Add | Add a feature to the list
Remove | Remove a feature to the list

Properties of IFeatures

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual feature within the collection. Index can be an ordinal from 1 to Count or a string


Item

Item - Read property

Description

Allows random access to individual feature within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As Feature

Syntax in C++

HRESULT get_Item (VARIANT Index , Feature* retVal)

Applies to

Features
GDTFeaturesLink


Add

Add - method

Description

Add a feature to the list

Syntax in Visual Basic or VBScript

Add (ByRef pVal As Feature)

Syntax in C++

HRESULT Add (Feature* pVal)

Parameters

Name | Description
pVal |

Applies to

Features


Remove

Remove - method

Description

Remove a feature to the list

Syntax in Visual Basic or VBScript

Remove (which As Variant) As Boolean

Syntax in C++

HRESULT Remove (VARIANT which , VARIANT_BOOL* retVal)

Parameters

Name | Description
which |
Return Value |

Applies to

Features


Function

Function - object

Description

Function Class

Interfaces

IFunction

Properties of IFunction

CPPParameters | R/O | property CPPParameters
Documentation | R/O | property Documentation
FuncFlags | R/O | property FuncFlags a combinaison of FUNCFLAGS values
FuncKind | R/O | property FUNCKIND
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
InvocationKind | R/O |
Name | R/W | property Name
ReturnType | R/O | property ReturnType
VBParameters | R/O | property VBParameters
VBReturnType | R/O | property VBReturnType

Collections of IFunction

Parameters property Parameters


CPPParameters

CPPParameters - Read property

Description

property CPPParameters

Syntax in Visual Basic or VBScript

CPPParameters () As String

Syntax in C++

HRESULT get_CPPParameters (BSTR* retVal)

Applies to

Function


FuncFlags

FuncFlags - Read property

Description

property FuncFlags a combinaison of FUNCFLAGS values

Syntax in Visual Basic or VBScript

FuncFlags () As tagFUNCFLAGS

Syntax in C++

HRESULT get_FuncFlags (tagFUNCFLAGS* retVal)

Applies to

Function


FuncKind

FuncKind - Read property

Description

property FUNCKIND

Syntax in Visual Basic or VBScript

FuncKind () As tagFUNCKIND

Syntax in C++

HRESULT get_FuncKind (tagFUNCKIND* retVal)

Applies to

Function


InvocationKind

InvocationKind - Read property

Syntax in Visual Basic or VBScript

InvocationKind () As tagINVOKEKIND

Syntax in C++

HRESULT get_InvocationKind (tagINVOKEKIND* retVal)

Applies to

Function


ReturnType

ReturnType - Read property

Description

property ReturnType

Syntax in Visual Basic or VBScript

ReturnType () As TypeDesc

Syntax in C++

HRESULT get_ReturnType (TypeDesc* retVal)

Applies to

Function


VBParameters

VBParameters - Read property

Description

property VBParameters

Syntax in Visual Basic or VBScript

VBParameters () As String

Syntax in C++

HRESULT get_VBParameters (BSTR* retVal)

Applies to

Function


VBReturnType

VBReturnType - Read property

Description

property VBReturnType

Syntax in Visual Basic or VBScript

VBReturnType () As String

Syntax in C++

HRESULT get_VBReturnType (BSTR* retVal)

Applies to

Function


Parameters

Parameters - Read property

Description

property Parameters

Syntax in Visual Basic or VBScript

Parameters () As Collection

Syntax in C++

HRESULT get_Parameters (Collection* retVal)

Applies to

Function


GDTDatumFeatureLink

GDTDatumFeatureLink - object

Interfaces

IGDTDatumFeatureLink

Properties of IGDTDatumFeatureLink

Description | R/O | return a description of the feature in the current locale language
FeatureMask | R/O | return the mask for this link
Handle | R/O | return the internal handle of this link
Index | R/O | returns the index of this property in its parent collection
Item | R/O |
LinkType | R/O | return the type of the link (Simple/Multiple)
Name | R/O | return the name of the link
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the link cannot be modified

Collections of IGDTDatumFeatureLink

PossibleFeatures property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


FeatureMask

FeatureMask - Read property

Description

return the mask for this link

Syntax in Visual Basic or VBScript

FeatureMask () As PWI_FeatureMask

Syntax in C++

HRESULT get_FeatureMask (PWI_FeatureMask* retVal)

Applies to

GDTDatumFeatureLink
GDTFeaturesLink
ISequenceLink
MultipleLink
SimpleLink


Handle

Handle - Read property

Description

return the internal handle of this link

Syntax in Visual Basic or VBScript

Handle () As Long

Syntax in C++

HRESULT get_Handle (LONG* retVal)

Applies to

GDTDatumFeatureLink
GDTFeaturesLink
ISequenceLink
MultipleLink
SimpleLink


LinkType

LinkType - Read property

Description

return the type of the link (Simple/Multiple)

Syntax in Visual Basic or VBScript

LinkType () As PWI_LinkType

Syntax in C++

HRESULT get_LinkType (PWI_LinkType* retVal)

Applies to

GDTDatumFeatureLink
GDTFeaturesLink
ISequenceLink
MultipleLink
SimpleLink


Name

Name - Read property

Description

return the name of the link

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)

Applies to

GDTDatumFeatureLink
GDTFeaturesLink
ISequenceLink
MultipleLink
SimpleLink


ReadOnly

ReadOnly - Read property

Description

return true if the link cannot be modified

Syntax in Visual Basic or VBScript

ReadOnly () As Boolean

Syntax in C++

HRESULT get_ReadOnly (VARIANT_BOOL* retVal)

Applies to

GDTDatumFeatureLink
GDTFeaturesLink
ISequenceLink
MultipleLink
SimpleLink


PossibleFeatures

PossibleFeatures - Read property

Description

property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link

Syntax in Visual Basic or VBScript

PossibleFeatures () As Features

Syntax in C++

HRESULT get_PossibleFeatures (Features* retVal)

Applies to

ISequenceLink


GDTFeature

GDTFeature - object

Interfaces

IGDTFeature

Properties of IGDTFeature

Feature | R/W | put the Feature attached to this link
MaterialCondition | R/W |


Feature

Feature - Read & Write property

Description

put the Feature attached to this link

Syntax in Visual Basic or VBScript

Feature () As Feature

Syntax in C++

HRESULT get_Feature (Feature* retVal)
HRESULT put_Feature (Feature* Value)

Applies to

GDTFeature
SimpleLink


MaterialCondition

MaterialCondition - Read & Write property

Syntax in Visual Basic or VBScript

MaterialCondition () As PWI_MaterialCondition

Syntax in C++

HRESULT get_MaterialCondition (PWI_MaterialCondition* retVal)
HRESULT put_MaterialCondition (PWI_MaterialCondition Value)

Applies to

GDTFeature
ParameterMaterialCondition


GDTFeaturesLink

GDTFeaturesLink - object

Interfaces

IGDTFeaturesLink

Methods of IGDTFeaturesLink

Add | Add a feature to the list
Remove | Remove a feature to the list

Properties of IGDTFeaturesLink

Count | R/W | Indicates the number of items in the collection.
Description | R/O | return a description of the feature in the current locale language
FeatureMask | R/O | return the mask for this link
Handle | R/O | return the internal handle of this link
Index | R/O | returns the index of this property in its parent collection
Item | R/O | Allows random access to individual feature within the collection. Index can be an ordinal from 1 to Count or a string
LinkType | R/O | return the type of the link (Simple/Multiple)
Name | R/O | return the name of the link
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the link cannot be modified

Collections of IGDTFeaturesLink

PossibleFeatures property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


Add

Add - method

Description

Add a feature to the list

Syntax in Visual Basic or VBScript

Add () As GDTFeature

Syntax in C++

HRESULT Add (GDTFeature* retVal)

Parameters

Name | Description
Return Value |

Applies to

GDTFeaturesLink


GDTItem

GDTItem - object

Interfaces

IGDTItem

Methods of IGDTItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IGDTItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DatumA | R/O |
DatumB | R/O |
DatumC | R/O |
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
GDTType | R/W |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag
WorkPlane | R/W |

Collections of IGDTItem

Features | return a collection of feature that this element provides
GDTFeatures |
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


DatumA

DatumA - Read property

Syntax in Visual Basic or VBScript

DatumA () As GDTDatumFeatureLink

Syntax in C++

HRESULT get_DatumA (GDTDatumFeatureLink* retVal)

Applies to

GDTItem


DatumB

DatumB - Read property

Syntax in Visual Basic or VBScript

DatumB () As GDTDatumFeatureLink

Syntax in C++

HRESULT get_DatumB (GDTDatumFeatureLink* retVal)

Applies to

GDTItem


DatumC

DatumC - Read property

Syntax in Visual Basic or VBScript

DatumC () As GDTDatumFeatureLink

Syntax in C++

HRESULT get_DatumC (GDTDatumFeatureLink* retVal)

Applies to

GDTItem


GDTType

GDTType - Read & Write property

Syntax in Visual Basic or VBScript

GDTType () As GDT_TYPE

Syntax in C++

HRESULT get_GDTType (GDT_TYPE* retVal)
HRESULT put_GDTType (GDT_TYPE Value)

Applies to

GDTItem


WorkPlane

WorkPlane - Read & Write property

Syntax in Visual Basic or VBScript

WorkPlane () As SimpleLink

Syntax in C++

HRESULT get_WorkPlane (SimpleLink* retVal)
HRESULT put_WorkPlane (Feature* Value)

Applies to

GDTItem


GDTFeatures

GDTFeatures - Read property

Syntax in Visual Basic or VBScript

GDTFeatures () As GDTFeaturesLink

Syntax in C++

HRESULT get_GDTFeatures (GDTFeaturesLink* retVal)

Applies to

GDTItem


GeometricGroup

GeometricGroup - object

Interfaces

IGeometricGroup

Methods of IGeometricGroup

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetExpanded | sets flag indicating group is expanded in the sequence tree
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IGeometricGroup

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
AutoTrimmingEnabled | R/W |
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
OutputToReport | R/W | get/set `output to report` flag
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IGeometricGroup

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
SequenceItems |
SequenceItemsForMeasure |


AutoTrimmingEnabled

AutoTrimmingEnabled - Read & Write property

Syntax in Visual Basic or VBScript

AutoTrimmingEnabled () As Boolean

Syntax in C++

HRESULT get_AutoTrimmingEnabled (VARIANT_BOOL* retVal)
HRESULT put_AutoTrimmingEnabled (VARIANT_BOOL Value)

Applies to

GeometricGroup


OutputToReport

OutputToReport - Read & Write property

Description

get/set `output to report` flag

Syntax in Visual Basic or VBScript

OutputToReport () As Boolean

Syntax in C++

HRESULT get_OutputToReport (VARIANT_BOOL* retVal)
HRESULT put_OutputToReport (VARIANT_BOOL Value)

Applies to

GeometricGroup
SequenceGroup
SurfaceGroup
SurfaceSectionGroup


SetExpanded

SetExpanded - method

Description

sets flag indicating group is expanded in the sequence tree

Syntax in Visual Basic or VBScript

SetExpanded (val As Boolean)

Syntax in C++

HRESULT SetExpanded (VARIANT_BOOL val)

Parameters

Name | Description
val |

Applies to

SequenceGroup


SequenceItems

SequenceItems - Read property

Syntax in Visual Basic or VBScript

SequenceItems () As SequenceItems

Syntax in C++

HRESULT get_SequenceItems (SequenceItems* retVal)

Applies to

SequenceGroup


SequenceItemsForMeasure

SequenceItemsForMeasure - Read property

Syntax in Visual Basic or VBScript

SequenceItemsForMeasure (measure As Variant) As SequenceItems

Syntax in C++

HRESULT get_SequenceItemsForMeasure (VARIANT measure , SequenceItems* retVal)

Applies to

SequenceGroup


IndexableProbeHead

IndexableProbeHead - object

Description

IndexableProbeHead Class

Interfaces

IIndexableProbeHead

Events

ActiveSensorChanged | fired after the active Sensor on the probe Head has changed
ActiveTipChanged | fired after the active tip on the probe Head has changed
AnglesChanged | method OnProbeHeadAnglesChanged
CalibrationStatusChanged | fired when the status of the calibration changed
ToolChanged | method ProbeHeadActiveToolChanged

Methods of IIndexableProbeHead

_internal_PutActiveTip | INTERNAL USE ONLY
_internal_PutProbeTool | INTERNAL USE ONLY
ComputeBestAngles | Calculate the best A and B angles to match the given vector, vector is supposed to be the stem direction from tip toward the shank
ComputeBestAnglesV | ( SCRIPT VERSION of ComputeBestAngles ) Calculate the best A and B angles to match the given vector, vector is supposed to be the stem direction from tip toward the shank
FillIdentityCard | fill the node with the identity card of this item
GetAngles | retrieve the current A and B angle of the physical indexable probe head
GetLocalDatumAtProbeMountingPoint | return the local matrix of the probe head mounting point for the specified angles
PutAngles | sets the A and B angles of the probe head, this function will returns after the physical angles have been set

Properties of IIndexableProbeHead

_ID | R/W | INTERNAL USE ONLY
A | R/O | retrieve the A parameter, this parameter describes the valid range and increment for the A angle
ActiveTip | R/W | sets/retrieves the current active probe tip, setting the active probe tip may invoke a probe change and a move of the physical device
AHingeOffset | R/O | returns the offet of the A Hinge point relative to the origin of the probe head local datum( when A=0,B=0)
AnglesAreTrusted | R/O | Retrieves whether the current A,B angle can be trusted. Can be False for probe heads that do not return the actual value until it has been changed.
B | R/O | retrieve the B parameter, this parameter describes the valid range and increment for the B angle
Calibration | R/O | retrieves the calibration object
Carriage | R/O | returns the parent carriage
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
ManualOnly | R/W | Determines whether the probe head position can be driven by a protocol
Mounting | R/W | Mounting - returns the mounting type technology ( m8 , Autojoint etc...)
Position | R/O | retrieves the R/O Position object that describes the position and orientation of the probe head relative to the CMM Zero Point
ProbeHeadType | R/O | retrieves the type of this probehead, usufull to identify its technology / OBSOLETE USE TYPE
ProbeMountingPointDatum | R/O | returns the probe mounting point datum relative to the CMM Coordinates system and the CMMZero Point, when the probe head is at its original position ( i.e A=0,B=0 for an indexable probe head
ProbeTool | R/W | sets/retrieves the current probe tool which is physically mounted on the probe head
ProbeToolMountingPoint | R/O | returns the probe mounting point relative the probe head local datum ( which has its origin at the hinge point), this is the connection point of a Probe Tool mounted on the probed head
Protocol | R/W | sets/retrieves the actual protocol object that directly interact with the physical device
QuillMountingPoint | R/O | returns the probe head mounting point on the quill relative the probe head local datum ( which has its origin at the hinge point)
ReferenceProbeLength | R/W | sets/retrieves the reference probe length -> the length of the probe used to do the calibration of the head
RotationAxisA | R/O | retrieves the Rotation Axis Vector of the A angle when B=0, in CMM Coordinates
RotationAxisB | R/O | retrieves the Rotation Axis Vector of the B angle when A=0, in CMM Coordinates
ThreadID | R/O |
TrustInitialValues | R/W | retrieves/sets if the Indexable Probe Head could trust the A,B values returned by the protocol at connection time
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user
vector | R/O | retrieves the current orientation of the probe axis in CMM coordinates


A

A - Read property

Description

retrieve the A parameter, this parameter describes the valid range and increment for the A angle

Syntax in Visual Basic or VBScript

A () As CMMFloatParameter

Syntax in C++

HRESULT get_A (CMMFloatParameter* retVal)

Applies to

IndexableProbeHead


ActiveTip

ActiveTip - Read & Write property

Description

sets/retrieves the current active probe tip, setting the active probe tip may invoke a probe change and a move of the physical device

Syntax in Visual Basic or VBScript

ActiveTip () As probeTip

Syntax in C++

HRESULT get_ActiveTip (probeTip* retVal)
HRESULT put_ActiveTip (VARIANT Value)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


AHingeOffset

AHingeOffset - Read property

Description

returns the offet of the A Hinge point relative to the origin of the probe head local datum( when A=0,B=0)

Syntax in Visual Basic or VBScript

AHingeOffset () As Point3D

Syntax in C++

HRESULT get_AHingeOffset (Point3D* retVal)

Applies to

IndexableProbeHead


AnglesAreTrusted

AnglesAreTrusted - Read property

Description

Retrieves whether the current A,B angle can be trusted. Can be False for probe heads that do not return the actual value until it has been changed.

Syntax in Visual Basic or VBScript

AnglesAreTrusted () As Boolean

Syntax in C++

HRESULT get_AnglesAreTrusted (VARIANT_BOOL* retVal)

Applies to

IndexableProbeHead


B

B - Read property

Description

retrieve the B parameter, this parameter describes the valid range and increment for the B angle

Syntax in Visual Basic or VBScript

B () As CMMFloatParameter

Syntax in C++

HRESULT get_B (CMMFloatParameter* retVal)

Applies to

IndexableProbeHead


Carriage

Carriage - Read property

Description

returns the parent carriage

Syntax in Visual Basic or VBScript

Carriage () As Carriage

Syntax in C++

HRESULT get_Carriage (Carriage* retVal)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


ManualOnly

ManualOnly - Read & Write property

Description

Determines whether the probe head position can be driven by a protocol

Syntax in Visual Basic or VBScript

ManualOnly () As Boolean

Syntax in C++

HRESULT get_ManualOnly (VARIANT_BOOL* retVal)
HRESULT put_ManualOnly (VARIANT_BOOL Value)

Applies to

IndexableProbeHead


Mounting

Mounting - Read & Write property

Description

Mounting - returns the mounting type technology ( m8 , Autojoint etc...)

Syntax in Visual Basic or VBScript

Mounting () As String

Syntax in C++

HRESULT get_Mounting (BSTR* retVal)
HRESULT put_Mounting (BSTR Value)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


Position

Position - Read property

Description

retrieves the R/O Position object that describes the position and orientation of the probe head relative to the CMM Zero Point

Syntax in Visual Basic or VBScript

Position () As Position

Syntax in C++

HRESULT get_Position (Position* retVal)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


ProbeHeadType

ProbeHeadType - Read property

Description

retrieves the type of this probehead, usufull to identify its technology / OBSOLETE USE TYPE

Syntax in Visual Basic or VBScript

ProbeHeadType () As PROBEHEAD_TYPE

Syntax in C++

HRESULT get_ProbeHeadType (PROBEHEAD_TYPE* retVal)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


ProbeMountingPointDatum

ProbeMountingPointDatum - Read property

Description

returns the probe mounting point datum relative to the CMM Coordinates system and the CMMZero Point, when the probe head is at its original position ( i.e A=0,B=0 for an indexable probe head

Syntax in Visual Basic or VBScript

ProbeMountingPointDatum () As ITransform2

Syntax in C++

HRESULT get_ProbeMountingPointDatum (ITransform2* retVal)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


ProbeTool

ProbeTool - Read & Write property

Description

sets/retrieves the current probe tool which is physically mounted on the probe head

Syntax in Visual Basic or VBScript

ProbeTool () As ProbeTool

Syntax in C++

HRESULT get_ProbeTool (ProbeTool* retVal)
HRESULT put_ProbeTool (ProbeTool* Value)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


ProbeToolMountingPoint

ProbeToolMountingPoint - Read property

Description

returns the probe mounting point relative the probe head local datum ( which has its origin at the hinge point), this is the connection point of a Probe Tool mounted on the probed head

Syntax in Visual Basic or VBScript

ProbeToolMountingPoint () As Point3D

Syntax in C++

HRESULT get_ProbeToolMountingPoint (Point3D* retVal)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


Protocol

Protocol - Read & Write property

Description

sets/retrieves the actual protocol object that directly interact with the physical device

Syntax in Visual Basic or VBScript

Protocol () As Object

Syntax in C++

HRESULT get_Protocol (IUnknow** retVal)
HRESULT put_Protocol (IUnknow* Value)

Applies to

IndexableProbeHead


QuillMountingPoint

QuillMountingPoint - Read property

Description

returns the probe head mounting point on the quill relative the probe head local datum ( which has its origin at the hinge point)

Syntax in Visual Basic or VBScript

QuillMountingPoint () As Point3D

Syntax in C++

HRESULT get_QuillMountingPoint (Point3D* retVal)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


ReferenceProbeLength

ReferenceProbeLength - Read & Write property

Description

sets/retrieves the reference probe length -> the length of the probe used to do the calibration of the head

Syntax in Visual Basic or VBScript

ReferenceProbeLength () As Double

Syntax in C++

HRESULT get_ReferenceProbeLength (double* retVal)
HRESULT put_ReferenceProbeLength (double Value)

Applies to

IndexableProbeHead
ManualProbeHead
IProbeHead


RotationAxisA

RotationAxisA - Read property

Description

retrieves the Rotation Axis Vector of the A angle when B=0, in CMM Coordinates

Syntax in Visual Basic or VBScript

RotationAxisA () As UnitVector3D

Syntax in C++

HRESULT get_RotationAxisA (UnitVector3D* retVal)

Applies to

IndexableProbeHead


RotationAxisB

RotationAxisB - Read property

Description

retrieves the Rotation Axis Vector of the B angle when A=0, in CMM Coordinates

Syntax in Visual Basic or VBScript

RotationAxisB () As UnitVector3D

Syntax in C++

HRESULT get_RotationAxisB (UnitVector3D* retVal)

Applies to

IndexableProbeHead


TrustInitialValues

TrustInitialValues - Read & Write property

Description

retrieves/sets if the Indexable Probe Head could trust the A,B values returned by the protocol at connection time

Syntax in Visual Basic or VBScript

TrustInitialValues () As Boolean

Syntax in C++

HRESULT get_TrustInitialValues (VARIANT_BOOL* retVal)
HRESULT put_TrustInitialValues (VARIANT_BOOL Value)

Applies to

IndexableProbeHead


vector

vector - Read property

Description

retrieves the current orientation of the probe axis in CMM coordinates

Syntax in Visual Basic or VBScript

vector () As UnitVector3D

Syntax in C++

HRESULT get_vector (UnitVector3D* retVal)

Applies to

IndexableProbeHead


_internal_PutActiveTip

_internal_PutActiveTip - method

Description

INTERNAL USE ONLY

Syntax in Visual Basic or VBScript

_internal_PutActiveTip (probeTip As Variant)

Syntax in C++

HRESULT _internal_PutActiveTip (VARIANT probeTip)

Parameters

Name | Description
probeTip |

Applies to

IProbeHead


_internal_PutProbeTool

_internal_PutProbeTool - method

Description

INTERNAL USE ONLY

Syntax in Visual Basic or VBScript

_internal_PutProbeTool (ByRef ProbeTool As ProbeTool)

Syntax in C++

HRESULT _internal_PutProbeTool (ProbeTool* ProbeTool)

Parameters

Name | Description
ProbeTool |

Applies to

IProbeHead


ActiveSensorChanged

ActiveSensorChanged - event

Description

fired after the active Sensor on the probe Head has changed

Syntax in Visual Basic or VBScript

ActiveSensorChanged (pOld As Object , pNew As Object)

Syntax in C++

HRESULT ActiveSensorChanged (IDispatch* pOld , IDispatch* pNew)

Parameters

Name | Description
pOld |
pNew |

Applies to

IndexableProbeHead


AnglesChanged

AnglesChanged - event

Description

method OnProbeHeadAnglesChanged

Syntax in Visual Basic or VBScript

AnglesChanged (A As Double , B As Double)

Syntax in C++

HRESULT AnglesChanged (double A , double B)

Parameters

Name | Description
A |
B |

Applies to

IndexableProbeHead


CalibrationStatusChanged

CalibrationStatusChanged - event

Description

fired when the status of the calibration changed

Syntax in Visual Basic or VBScript

CalibrationStatusChanged ()

Syntax in C++

HRESULT CalibrationStatusChanged ()

Applies to

IndexableProbeHead


ComputeBestAngles

ComputeBestAngles - method

Description

Calculate the best A and B angles to match the given vector, vector is supposed to be the stem direction from tip toward the shank

Syntax in Visual Basic or VBScript

ComputeBestAngles (I As Double , J As Double , K As Double , ByRef A As Double , ByRef B As Double)

Syntax in C++

HRESULT ComputeBestAngles (double I , double J , double K , double* A , double* B)

Parameters

Name | Description
I |
J |
K |
A |
B |

Applies to

IndexableProbeHead


ComputeBestAnglesV

ComputeBestAnglesV - method

Description

( SCRIPT VERSION of ComputeBestAngles ) Calculate the best A and B angles to match the given vector, vector is supposed to be the stem direction from tip toward the shank

Syntax in Visual Basic or VBScript

ComputeBestAnglesV (I As Double , J As Double , K As Double , ByRef A As Variant , ByRef B As Variant)

Syntax in C++

HRESULT ComputeBestAnglesV (double I , double J , double K , VARIANT* A , VARIANT* B)

Parameters

Name | Description
I |
J |
K |
A |
B |

Applies to

IndexableProbeHead


GetAngles

GetAngles - method

Description

retrieve the current A and B angle of the physical indexable probe head

Syntax in Visual Basic or VBScript

GetAngles (ByRef pA As Double , ByRef pB As Double)

Syntax in C++

HRESULT GetAngles (double* pA , double* pB)

Parameters

Name | Description
pA |
pB |

Applies to

IndexableProbeHead


GetLocalDatumAtProbeMountingPoint

GetLocalDatumAtProbeMountingPoint - method

Description

return the local matrix of the probe head mounting point for the specified angles

Syntax in Visual Basic or VBScript

GetLocalDatumAtProbeMountingPoint (A As Double , B As Double , bRelativeToCMM As Boolean) As ITransform2

Syntax in C++

HRESULT GetLocalDatumAtProbeMountingPoint (double A , double B , VARIANT_BOOL bRelativeToCMM , ITransform2* retVal)

Parameters

Name | Description
A |
B |
bRelativeToCMM |
Return Value |

Applies to

IndexableProbeHead


PutAngles

PutAngles - method

Description

sets the A and B angles of the probe head, this function will returns after the physical angles have been set

Syntax in Visual Basic or VBScript

PutAngles (A As Double , B As Double)

Syntax in C++

HRESULT PutAngles (double A , double B)

Parameters

Name | Description
A |
B |

Applies to

IndexableProbeHead


ToolChanged

ToolChanged - event

Description

method ProbeHeadActiveToolChanged

Syntax in Visual Basic or VBScript

ToolChanged (pOld As Object , pNew As Object)

Syntax in C++

HRESULT ToolChanged (IDispatch* pOld , IDispatch* pNew)

Parameters

Name | Description
pOld |
pNew |

Applies to

IndexableProbeHead


IntermediateProbePath

IntermediateProbePath - object

Interfaces

IIntermediateProbePathItem

Methods of IIntermediateProbePathItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IIntermediateProbePathItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IIntermediateProbePathItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


LaserScannedCylinder

LaserScannedCylinder - object

Interfaces

ILaserScannedCylinderItem

Methods of ILaserScannedCylinderItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILaserScannedCylinderItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxis | R/O |
FeatureCylinder | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBasePoint | R/O |
ParameterBoundary | R/O |
ParameterEvaluateWithNominal | R/O |
ParameterHeight | R/O |
PointCloud | R/O |
PropertyCylindricity | R/O |
PropertyDirection | R/O |
PropertyRadius | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILaserScannedCylinderItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


LaserScannedSlot

LaserScannedSlot - object

Interfaces

ILaserScannedSlotItem

Methods of ILaserScannedSlotItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILaserScannedSlotItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureCentre1 | R/O |
FeatureCentre2 | R/O |
FeatureMajorAxis | R/O |
FeatureMinorAxis | R/O |
FeatureNormalVector | R/O |
FeaturePlane | R/O |
FeatureRoundedSlot | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterEvaluateWithNominal | R/O |
ParameterExtrusion | R/O |
ParameterSearchDistance | R/O |
PointCloud | R/O |
PropertyCentre | R/O |
PropertyLength | R/O |
PropertyMajorAxis | R/O |
PropertyNormalVector | R/O |
PropertyProfile | R/O |
PropertyRadius | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILaserScannedSlotItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Line_Bissector

Line_Bissector - object

Interfaces

ILine_BissectorItem

Methods of ILine_BissectorItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_BissectorItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyAngle | R/O |
PropertyDirection | R/O |
PropertyPoint | R/O |
ReferenceLine1 | R/O |
ReferenceLine2 | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_BissectorItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureLine

FeatureLine - Read property

Syntax in Visual Basic or VBScript

FeatureLine () As Feature

Syntax in C++

HRESULT get_FeatureLine (Feature* retVal)

Applies to

IGeometricLineItem
Line_Bissector
Line_Inter2Planes
Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Line_PointVector
Line_Probed
Line_ProjectedOnPlane
Line_ThroughPoints
Line_WithAngle
Line_WithOffsetPoint


PropertyAngle

PropertyAngle - Read property

Syntax in Visual Basic or VBScript

PropertyAngle () As PropertyAngle

Syntax in C++

HRESULT get_PropertyAngle (PropertyAngle* retVal)

Applies to

Line_Bissector
Meas_3DAngle2Vectors
Meas_3DAnglePlaneLine
Meas_Angle2Lines
Meas_Angle2Planes


PropertyPoint

PropertyPoint - Read property

Syntax in Visual Basic or VBScript

PropertyPoint () As PropertyPoint3D

Syntax in C++

HRESULT get_PropertyPoint (PropertyPoint3D* retVal)

Applies to

IGeometricPointItem
Line_Bissector
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane


ReferenceLine1

ReferenceLine1 - Read property

Syntax in Visual Basic or VBScript

ReferenceLine1 () As SimpleLink

Syntax in C++

HRESULT get_ReferenceLine1 (SimpleLink* retVal)

Applies to

Line_Bissector
Meas_Angle2Lines
Point_Inter2Lines3D
Point_Inter2LinesProjected


ReferenceLine2

ReferenceLine2 - Read property

Syntax in Visual Basic or VBScript

ReferenceLine2 () As SimpleLink

Syntax in C++

HRESULT get_ReferenceLine2 (SimpleLink* retVal)

Applies to

Line_Bissector
Meas_Angle2Lines
Point_Inter2Lines3D
Point_Inter2LinesProjected


Line_Inter2Planes

Line_Inter2Planes - object

Interfaces

ILine_Inter2PlanesItem

Methods of ILine_Inter2PlanesItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_Inter2PlanesItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyDirection | R/O |
ReferencePlane1 | R/O |
ReferencePlane2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_Inter2PlanesItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ReferencePlane1

ReferencePlane1 - Read property

Syntax in Visual Basic or VBScript

ReferencePlane1 () As SimpleLink

Syntax in C++

HRESULT get_ReferencePlane1 (SimpleLink* retVal)

Applies to

Line_Inter2Planes
Meas_Angle2Planes
Plane_Bissector
Point_Inter3Planes


ReferencePlane2

ReferencePlane2 - Read property

Syntax in Visual Basic or VBScript

ReferencePlane2 () As SimpleLink

Syntax in C++

HRESULT get_ReferencePlane2 (SimpleLink* retVal)

Applies to

Line_Inter2Planes
Meas_Angle2Planes
Plane_Bissector
Point_Inter3Planes


Line_ParallelTroughPoint

Line_ParallelTroughPoint - object

Interfaces

ILine_ParallelTroughPointItem

Methods of ILine_ParallelTroughPointItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_ParallelTroughPointItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterMaterialCondition | R/O |
PropertyDirection | R/O |
PropertyDistance | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_ParallelTroughPointItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterMaterialCondition

ParameterMaterialCondition - Read property

Syntax in Visual Basic or VBScript

ParameterMaterialCondition () As ParameterMaterialCondition

Syntax in C++

HRESULT get_ParameterMaterialCondition (ParameterMaterialCondition* retVal)

Applies to

Line_ParallelTroughPoint
Line_PerpendicularTroughPoint
Plane_ParallelThroughPoint


PropertyDistance

PropertyDistance - Read property

Syntax in Visual Basic or VBScript

PropertyDistance () As PropertyLinearDimension

Syntax in C++

HRESULT get_PropertyDistance (PropertyLinearDimension* retVal)

Applies to

Line_ParallelTroughPoint
Line_ThroughPoints
Meas_Distance2Points
Meas_DistancePointLine
Meas_DistancePointPlane
Plane_ParallelThroughPoint


Line_PerpendicularTroughPoint

Line_PerpendicularTroughPoint - object

Interfaces

ILine_PerpendicularTroughPointItem

Methods of ILine_PerpendicularTroughPointItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_PerpendicularTroughPointItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterMaterialCondition | R/O |
PropertyDirection | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_PerpendicularTroughPointItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Line_PointVector

Line_PointVector - object

Interfaces

ILine_PointVectorItem

Methods of ILine_PointVectorItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_PointVectorItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyDirection | R/O |
ReferencePoint | R/O |
ReferenceVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_PointVectorItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ReferenceVector

ReferenceVector - Read property

Syntax in Visual Basic or VBScript

ReferenceVector () As SimpleLink

Syntax in C++

HRESULT get_ReferenceVector (SimpleLink* retVal)

Applies to

Line_PointVector
Plane_LineVector
Plane_PointVector


Line_Probed

Line_Probed - object

Interfaces

ILine_ProbedItem

Methods of ILine_ProbedItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_ProbedItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterCentroid | R/O |
ParameterGuidedMeasure | R/O |
ParameterLength | R/O |
ParameterMaterialSide | R/O |
ParameterOffset | R/O |
PropertyDirection | R/O |
PropertyLinearity | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_ProbedItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterCentroid

ParameterCentroid - Read property

Syntax in Visual Basic or VBScript

ParameterCentroid () As ParameterPoint3D

Syntax in C++

HRESULT get_ParameterCentroid (ParameterPoint3D* retVal)

Applies to

Line_Probed


ParameterLength

ParameterLength - Read property

Syntax in Visual Basic or VBScript

ParameterLength () As ParameterAngle

Syntax in C++

HRESULT get_ParameterLength (ParameterAngle* retVal)

Applies to

Line_Probed


PropertyLinearity

PropertyLinearity - Read property

Syntax in Visual Basic or VBScript

PropertyLinearity () As PropertyGeometricTolerance

Syntax in C++

HRESULT get_PropertyLinearity (PropertyGeometricTolerance* retVal)

Applies to

Line_Probed


Line_ProjectedOnPlane

Line_ProjectedOnPlane - object

Interfaces

ILine_ProjectedOnPlaneItem

Methods of ILine_ProjectedOnPlaneItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_ProjectedOnPlaneItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyDirection | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_ProjectedOnPlaneItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Line_ThroughPoints

Line_ThroughPoints - object

Interfaces

ILine_ThroughPointsItem

Methods of ILine_ThroughPointsItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_ThroughPointsItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyDirection | R/O |
PropertyDistance | R/O |
ReferencePoint1 | R/O |
ReferencePoint2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_ThroughPointsItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ReferencePoint1

ReferencePoint1 - Read property

Syntax in Visual Basic or VBScript

ReferencePoint1 () As SimpleLink

Syntax in C++

HRESULT get_ReferencePoint1 (SimpleLink* retVal)

Applies to

Line_ThroughPoints
Meas_Distance2Points
Meas_RelativePosition
Point_Middle


ReferencePoint2

ReferencePoint2 - Read property

Syntax in Visual Basic or VBScript

ReferencePoint2 () As SimpleLink

Syntax in C++

HRESULT get_ReferencePoint2 (SimpleLink* retVal)

Applies to

Line_ThroughPoints
Meas_Distance2Points
Meas_RelativePosition
Point_Middle


Line_WithAngle

Line_WithAngle - object

Interfaces

ILine_WithAngleItem

Methods of ILine_WithAngleItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_WithAngleItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterAngle | R/O |
ParameterBoundary | R/O |
PropertyDirection | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_WithAngleItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Line_WithOffsetPoint

Line_WithOffsetPoint - object

Interfaces

ILine_WithOffsetPointItem

Methods of ILine_WithOffsetPointItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ILine_WithOffsetPointItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterAlternateSolution | R/O |
ParameterBoundary | R/O |
ParameterCompositeOffsets | R/O |
PropertyDirection | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ILine_WithOffsetPointItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterAlternateSolution

ParameterAlternateSolution - Read property

Syntax in Visual Basic or VBScript

ParameterAlternateSolution () As ParameterAngle

Syntax in C++

HRESULT get_ParameterAlternateSolution (ParameterAngle* retVal)

Applies to

Line_WithOffsetPoint
Plane_WithOffsetPoints


ParameterCompositeOffsets

ParameterCompositeOffsets - Read property

Syntax in Visual Basic or VBScript

ParameterCompositeOffsets () As ParameterCompositeOffset

Syntax in C++

HRESULT get_ParameterCompositeOffsets (ParameterCompositeOffset* retVal)

Applies to

Line_WithOffsetPoint
Plane_WithOffsetPoints


Links

Links - object

Interfaces

ISequenceLinks

Properties of ISequenceLinks

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual Link within the collection. Index can be an ordinal from 1 to Count or a string


Item

Item - Read property

Description

Allows random access to individual Link within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As ISequenceLink

Syntax in C++

HRESULT get_Item (VARIANT Index , ISequenceLink* retVal)

Applies to

Links


MachineAxes

MachineAxes - object

Description

MachineAxes Class

Interfaces

IMachineAxes

Properties of IMachineAxes

AxisByAddress | R/O | Get the axis with the given address.
AxisByIndex | R/O | Get the axis at the given index.
Count | R/O | The number of axes.


MachineAxis

MachineAxis - object

Description

MachineAxis Class

Interfaces

IMachineAxis

Properties of IMachineAxis

Address | R/O | The address of this axis
Index | R/O | The index of this axis relative to the list of axes in the IMachineOrientationData parent.
MaxConstraint | R/W | The maximum axis value allowed.
MinConstraint | R/W | The minimum axis value allowed.
Parent | R/O | The parent IMachineOrientationData object.
UseAxisValue | R/W | Is the value for this axis valid?
UseConstraints | R/W | Are the constraints for this axis valid?
Value | R/W | The axis value.


MachineOrientationData

MachineOrientationData - object

Description

MachineOrientationData Class

Interfaces

IMachineOrientationData

Methods of IMachineOrientationData

AddMachineAxisAndConstraints | Add a machine axis to the list of machine axes.
AddMachineAxisAndValue | Add a machine axis to the list of machine axes.
AddMachineAxisValueAndConstraints | Add a machine axis to the list of machine axes.
ClearAxisList | Clear the list of machine axes
CompareMachineOrientation | Is the machine transform in this machine-orientation the same as the one in the parameter.
Copy | Copy the parameter object data to this object.
TransformFrom | Apply the transformation to the machine-transform.
TransformTo | Apply the inverse transformation to the machine-transform.

Properties of IMachineOrientationData

HeadTransform | R/O | The transform that maps the machine datum onto the head datum (in world coordinates).
KinematicsMethod | R/W | The kinematic method that users of this object should use
MachineTransform | R/O | The transform that maps the table datum onto the head datum (in CAD or CMM probe-centre coordinates only).
MachineTransformCoordinateSystem | R/W | The coordinate system that the machine transform is in (CAD or CMM probe-centre coordinates only).
MTDMachineName | R/W | The machine name (from MTD file) used to create any forward kinematics.
RequiresLicence | R/O | Get whether a licence is required to use this object.
TableTransform | R/O | The transform that maps the machine datum onto the table datum (in world coordinates).

Collections of IMachineOrientationData

Axes The list of machine axes.


ManualProbeHead

ManualProbeHead - object

Interfaces

IManualProbeHead

Events

ActiveSensorChanged | fired after the active Sensor on the probe Head has changed
ActiveTipChanged | fired after the active tip on the probe Head has changed
AnglesChanged | method OnProbeHeadAnglesChanged
CalibrationStatusChanged | fired when the status of the calibration changed
ToolChanged | method ProbeHeadActiveToolChanged

Methods of IManualProbeHead

_internal_PutActiveTip | INTERNAL USE ONLY
_internal_PutProbeTool | INTERNAL USE ONLY
FillIdentityCard | fill the node with the identity card of this item
SetProbeHeadType | explicitly set the type of this probehead, usufull to identify its technology

Properties of IManualProbeHead

_ID | R/W | INTERNAL USE ONLY
ActiveTip | R/W | sets/retrieves the current active probe tip, setting the active probe tip may invoke a probe change and a move of the physical device
Calibration | R/O | retrieves the calibration object
Carriage | R/O | returns the parent carriage
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
Mounting | R/W | Mounting - returns the mounting type technology ( m8 , Autojoint etc...)
Position | R/O | retrieves the R/O Position object that describes the position and orientation of the probe head relative to the CMM Zero Point
ProbeHeadType | R/O | retrieves the type of this probehead, usufull to identify its technology / OBSOLETE USE TYPE
ProbeMountingPointDatum | R/O | returns the probe mounting point datum relative to the CMM Coordinates system and the CMMZero Point, when the probe head is at its original position ( i.e A=0,B=0 for an indexable probe head
ProbeTool | R/W | sets/retrieves the current probe tool which is physically mounted on the probe head
ProbeToolMountingPoint | R/O | returns the probe mounting point relative the probe head local datum ( which has its origin at the hinge point), this is the connection point of a Probe Tool mounted on the probed head
QuillMountingPoint | R/O | returns the probe head mounting point on the quill relative the probe head local datum ( which has its origin at the hinge point)
ReferenceProbeLength | R/W | sets/retrieves the reference probe length -> the length of the probe used to do the calibration of the head
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user


SetProbeHeadType

SetProbeHeadType - method

Description

explicitly set the type of this probehead, usufull to identify its technology

Syntax in Visual Basic or VBScript

SetProbeHeadType (Value As PROBEHEAD_TYPE)

Syntax in C++

HRESULT SetProbeHeadType (PROBEHEAD_TYPE Value)

Parameters

Name | Description
Value |

Applies to

ManualProbeHead


ManualToolChanger

ManualToolChanger - object

Description

ManualToolChanger

Interfaces

IToolChanger

Events

CalibrationStatusChanged | fired when the status of the calibration changed
StatusChanged | fired when the tool changer status has changed

Methods of IToolChanger

ChangeTool | request a tool changing ( could be a asynchronous operation)
FillIdentityCard | fill the node with the identity card of this item

Properties of IToolChanger

_ID | R/W | INTERNAL USE ONLY
Calibration | R/O | retrieves the calibration object
Carriage | R/O | returns the carriage on which this ToolChanger is based
ChangeSilently | R/W | Returns TRUE if the changer is in Silent mode. Silent means No message boxes or prompts are used during ctool changes.
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
Status | R/O | retreives the status of the tool changer module
ThreadID | R/O |
ToolChangerType | R/O | returns the type of this ToolChanger
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user


Carriage

Carriage - Read property

Description

returns the carriage on which this ToolChanger is based

Syntax in Visual Basic or VBScript

Carriage () As Carriage

Syntax in C++

HRESULT get_Carriage (Carriage* retVal)

Applies to

ManualToolChanger


ChangeSilently

ChangeSilently - Read & Write property

Description

Returns TRUE if the changer is in Silent mode. Silent means No message boxes or prompts are used during ctool changes.

Syntax in Visual Basic or VBScript

ChangeSilently () As Boolean

Syntax in C++

HRESULT get_ChangeSilently (VARIANT_BOOL* retVal)
HRESULT put_ChangeSilently (VARIANT_BOOL Value)

Applies to

ManualToolChanger


Status

Status - Read property

Description

retreives the status of the tool changer module

Syntax in Visual Basic or VBScript

Status () As TOOLCHANGERSTATUS

Syntax in C++

HRESULT get_Status (TOOLCHANGERSTATUS* retVal)

Applies to

ManualToolChanger


ToolChangerType

ToolChangerType - Read property

Description

returns the type of this ToolChanger

Syntax in Visual Basic or VBScript

ToolChangerType () As TOOLCHANGER_TYPE

Syntax in C++

HRESULT get_ToolChangerType (TOOLCHANGER_TYPE* retVal)

Applies to

ManualToolChanger


ChangeTool

ChangeTool - method

Description

request a tool changing ( could be a asynchronous operation)

Syntax in Visual Basic or VBScript

ChangeTool (tool As Variant) As Long

Syntax in C++

HRESULT ChangeTool (VARIANT tool , LONG* retVal)

Parameters

Name | Description
tool |
Return Value |

Applies to

ManualToolChanger


StatusChanged

StatusChanged - event

Description

fired when the tool changer status has changed

Syntax in Visual Basic or VBScript

StatusChanged (newStatus As TOOLCHANGERSTATUS)

Syntax in C++

HRESULT StatusChanged (TOOLCHANGERSTATUS newStatus , HRESULT* retVal)

Parameters

Name | Description
newStatus |

Applies to

ManualToolChanger


MathToolbox

MathToolbox - object

Description

MathToolbox Class

Interfaces

IMathToolbox

Methods of IMathToolbox

AngleVector | method AngleVector
Circle3Points | calculate the center,normale and radius of a circle through the 3 given points
CrossProduct | method CrossProduct : a and b can be either IVector3D or IUnitVector3D and the result will be a Vector3D
Distance | method Distance Calculates the distance between 2 points : a and b can be either IPoint3D
DotProduct | method DotProduct

Properties of IMathToolbox

Inverse | R/O | method InverseMatrix
MultiplyTransform | R/O | multiply 2 matrix


Inverse

Inverse - Read property

Description

method InverseMatrix

Syntax in Visual Basic or VBScript

Inverse (ByRef a As transform) As transform

Syntax in C++

HRESULT get_Inverse (transform* a , transform* retVal)

Applies to

MathToolbox


MultiplyTransform

MultiplyTransform - Read property

Description

multiply 2 matrix

Syntax in Visual Basic or VBScript

MultiplyTransform (ByRef a As transform , ByRef b As transform) As transform

Syntax in C++

HRESULT get_MultiplyTransform (transform* a , transform* b , transform* retVal)

Applies to

MathToolbox


AngleVector

AngleVector - method

Description

method AngleVector

Syntax in Visual Basic or VBScript

AngleVector (a As Variant , b As Variant) As Double

Syntax in C++

HRESULT AngleVector (VARIANT a , VARIANT b , double* retVal)

Parameters

Name | Description
a |
b |
Return Value |

Applies to

MathToolbox


Circle3Points

Circle3Points - method

Description

calculate the center,normale and radius of a circle through the 3 given points

Syntax in Visual Basic or VBScript

Circle3Points (a As Variant , b As Variant , c As Variant , ByRef center As Double , ByRef normal As Double , ByRef radius As Double) As Boolean

Syntax in C++

HRESULT Circle3Points (VARIANT a , VARIANT b , VARIANT c , double* center , double* normal , double* radius , VARIANT_BOOL* retVal)

Parameters

Name | Description
a |
b |
c |
center |
normal |
radius |
Return Value |

Applies to

MathToolbox


CrossProduct

CrossProduct - method

Description

method CrossProduct : a and b can be either IVector3D or IUnitVector3D and the result will be a Vector3D

Syntax in Visual Basic or VBScript

CrossProduct (a As Variant , b As Variant) As Variant

Syntax in C++

HRESULT CrossProduct (VARIANT a , VARIANT b , VARIANT* retVal)

Parameters

Name | Description
a |
b |
Return Value |

Applies to

MathToolbox


Distance

Distance - method

Description

method Distance Calculates the distance between 2 points : a and b can be either IPoint3D

Syntax in Visual Basic or VBScript

Distance (a As Variant , b As Variant) As Double

Syntax in C++

HRESULT Distance (VARIANT a , VARIANT b , double* retVal)

Parameters

Name | Description
a |
b |
Return Value |

Applies to

MathToolbox


DotProduct

DotProduct - method

Description

method DotProduct

Syntax in Visual Basic or VBScript

DotProduct (a As Variant , b As Variant) As Double

Syntax in C++

HRESULT DotProduct (VARIANT a , VARIANT b , double* retVal)

Parameters

Name | Description
a |
b |
Return Value |

Applies to

MathToolbox


Meas_3DAngle2Vectors

Meas_3DAngle2Vectors - object

Interfaces

IMeas_3DAngle2VectorsItem

Methods of IMeas_3DAngle2VectorsItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IMeas_3DAngle2VectorsItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyAngle | R/O |
ReferenceDirection1 | R/O |
ReferenceDirection2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IMeas_3DAngle2VectorsItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ReferenceDirection1

ReferenceDirection1 - Read property

Syntax in Visual Basic or VBScript

ReferenceDirection1 () As SimpleLink

Syntax in C++

HRESULT get_ReferenceDirection1 (SimpleLink* retVal)

Applies to

Meas_3DAngle2Vectors


ReferenceDirection2

ReferenceDirection2 - Read property

Syntax in Visual Basic or VBScript

ReferenceDirection2 () As SimpleLink

Syntax in C++

HRESULT get_ReferenceDirection2 (SimpleLink* retVal)

Applies to

Meas_3DAngle2Vectors


Meas_3DAnglePlaneLine

Meas_3DAnglePlaneLine - object

Interfaces

IMeas_3DAnglePlaneLineItem

Methods of IMeas_3DAnglePlaneLineItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IMeas_3DAnglePlaneLineItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyAngle | R/O |
ReferenceDirection | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IMeas_3DAnglePlaneLineItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ReferenceDirection

ReferenceDirection - Read property

Syntax in Visual Basic or VBScript

ReferenceDirection () As SimpleLink

Syntax in C++

HRESULT get_ReferenceDirection (SimpleLink* retVal)

Applies to

Meas_3DAnglePlaneLine


Meas_Angle2Lines

Meas_Angle2Lines - object

Interfaces

IMeas_Angle2LinesItem

Methods of IMeas_Angle2LinesItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IMeas_Angle2LinesItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyAngle | R/O |
ReferenceLine1 | R/O |
ReferenceLine2 | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IMeas_Angle2LinesItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Meas_Angle2Planes

Meas_Angle2Planes - object

Interfaces

IMeas_Angle2PlanesItem

Methods of IMeas_Angle2PlanesItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IMeas_Angle2PlanesItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyAngle | R/O |
ReferencePlane1 | R/O |
ReferencePlane2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IMeas_Angle2PlanesItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Meas_Distance2Points

Meas_Distance2Points - object

Interfaces

IMeas_Distance2PointsItem

Methods of IMeas_Distance2PointsItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IMeas_Distance2PointsItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyDistance | R/O |
ReferencePoint1 | R/O |
ReferencePoint2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IMeas_Distance2PointsItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Meas_DistancePointLine

Meas_DistancePointLine - object

Interfaces

IMeas_DistancePointLineItem

Methods of IMeas_DistancePointLineItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IMeas_DistancePointLineItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyDistance | R/O |
ReferenceLine | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IMeas_DistancePointLineItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Meas_DistancePointPlane

Meas_DistancePointPlane - object

Interfaces

IMeas_DistancePointPlaneItem

Methods of IMeas_DistancePointPlaneItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IMeas_DistancePointPlaneItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyDistance | R/O |
ReferencePlane | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IMeas_DistancePointPlaneItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Meas_RelativePosition

Meas_RelativePosition - object

Interfaces

IMeas_RelativePositionItem

Methods of IMeas_RelativePositionItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IMeas_RelativePositionItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyLocation | R/O |
PropertyRelativePosition | R/O |
ReferencePoint1 | R/O |
ReferencePoint2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IMeas_RelativePositionItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


PropertyLocation

PropertyLocation - Read property

Syntax in Visual Basic or VBScript

PropertyLocation () As PropertyGeometricTolerance

Syntax in C++

HRESULT get_PropertyLocation (PropertyGeometricTolerance* retVal)

Applies to

Meas_RelativePosition


PropertyRelativePosition

PropertyRelativePosition - Read property

Syntax in Visual Basic or VBScript

PropertyRelativePosition () As PropertyVector3D

Syntax in C++

HRESULT get_PropertyRelativePosition (PropertyVector3D* retVal)

Applies to

Meas_RelativePosition


measure

measure - object

Interfaces

IMeasure

Methods of IMeasure

Delete | Delete this measure from the document
ImportMeasuredData | Copies measured data from amother measure, transforming it between the two alignments.
Invalidate | Invalidate all items to a unmeasured state for this particular measure

Properties of IMeasure

ActivePositioningMatrix | R/O | property ActivePositioningMatrix
Document | R/O | returns the associated document for this item
IsBuiltIn | R/O | returns whether the measure is a built-in measure - these cannot be deleted
IsSimulated | R/O | returns whether the measure is the automatic simulated measure
MeasureState | R/O | returns the measurement state
Name | R/W | Set/retrieve the name of the Measure object
UniqueID | R/O | returns a unique Identifier (ID) of this Item, this ID is unique within the same document and never changed during the timelife of the SequenceItem

Collections of IMeasure

ReportVariables property ReportVariables


ActivePositioningMatrix

ActivePositioningMatrix - Read property

Description

property ActivePositioningMatrix

Syntax in Visual Basic or VBScript

ActivePositioningMatrix (ByRef coef3x4 As Variant) As Boolean

Syntax in C++

HRESULT get_ActivePositioningMatrix (VARIANT* coef3x4 , VARIANT_BOOL* retVal)

Applies to

measure


IsBuiltIn

IsBuiltIn - Read property

Description

returns whether the measure is a built-in measure - these cannot be deleted

Syntax in Visual Basic or VBScript

IsBuiltIn () As Boolean

Syntax in C++

HRESULT get_IsBuiltIn (VARIANT_BOOL* retVal)

Applies to

measure


IsSimulated

IsSimulated - Read property

Description

returns whether the measure is the automatic simulated measure

Syntax in Visual Basic or VBScript

IsSimulated () As Boolean

Syntax in C++

HRESULT get_IsSimulated (VARIANT_BOOL* retVal)

Applies to

measure


Name

Name - Read & Write property

Description

Set/retrieve the name of the Measure object

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)
HRESULT put_Name (BSTR Value)

Applies to

measure


UniqueID

UniqueID - Read property

Description

returns a unique Identifier (ID) of this Item, this ID is unique within the same document and never changed during the timelife of the SequenceItem

Syntax in Visual Basic or VBScript

UniqueID () As Long

Syntax in C++

HRESULT get_UniqueID (LONG* retVal)

Applies to

measure


Delete

Delete - method

Description

Delete this measure from the document

Syntax in Visual Basic or VBScript

Delete ()

Syntax in C++

HRESULT Delete ()

Applies to

measure


ImportMeasuredData

ImportMeasuredData - method

Description

Copies measured data from amother measure, transforming it between the two alignments.

Syntax in Visual Basic or VBScript

ImportMeasuredData (ByRef source_meas As measure)

Syntax in C++

HRESULT ImportMeasuredData (measure* source_meas)

Parameters

Name | Description
source_meas |

Applies to

measure


Invalidate

Invalidate - method

Description

Invalidate all items to a unmeasured state for this particular measure

Syntax in Visual Basic or VBScript

Invalidate ()

Syntax in C++

HRESULT Invalidate ()

Applies to

measure


ReportVariables

ReportVariables - Read property

Description

property ReportVariables

Syntax in Visual Basic or VBScript

ReportVariables () As ReportVariables

Syntax in C++

HRESULT get_ReportVariables (ReportVariables* retVal)

Applies to

measure


Measures

Measures - object

Interfaces

IMeasures

Methods of IMeasures

Add | add a new measure to the collection
Delete | method Delete the specifyed measure from the collection
DeleteAll | method Delete all measures from the collection

Properties of IMeasures

Count | R/O | returns the number of items in the collection.
Item | R/O | allows random access to individual measure within the collection. Index can be an ordinal from 1 to Count or a string


Add

Add - method

Description

add a new measure to the collection

Syntax in Visual Basic or VBScript

Add () As measure

Syntax in C++

HRESULT Add (measure* retVal)

Parameters

Name | Description
Return Value |

Applies to

Measures


DeleteAll

DeleteAll - method

Description

method Delete all measures from the collection

Syntax in Visual Basic or VBScript

DeleteAll ()

Syntax in C++

HRESULT DeleteAll ()

Applies to

Measures


MultiaxisConfiguration

MultiaxisConfiguration - object

Interfaces

IMultiaxisConfigurationItem

Methods of IMultiaxisConfigurationItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IMultiaxisConfigurationItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IMultiaxisConfigurationItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


MultipleLink

MultipleLink - object

Interfaces

ISequenceMultipleLink

Methods of ISequenceMultipleLink

Add | Add a feature to the list
Remove | Remove a feature to the list

Properties of ISequenceMultipleLink

Description | R/O | return a description of the feature in the current locale language
FeatureMask | R/O | return the mask for this link
Handle | R/O | return the internal handle of this link
Index | R/O | returns the index of this property in its parent collection
LinkType | R/O | return the type of the link (Simple/Multiple)
Name | R/O | return the name of the link
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the link cannot be modified

Collections of ISequenceMultipleLink

Features | get the colection of Features attached to this link
PossibleFeatures | property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


Features

Features - Read property

Description

get the colection of Features attached to this link

Syntax in Visual Basic or VBScript

Features () As Features

Syntax in C++

HRESULT get_Features (Features* retVal)

Applies to

MultipleLink


NominalPoint

NominalPoint - object

Interfaces

INominalPointItem

Methods of INominalPointItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of INominalPointItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterPoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of INominalPointItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeaturePoint

FeaturePoint - Read property

Syntax in Visual Basic or VBScript

FeaturePoint () As Feature

Syntax in C++

HRESULT get_FeaturePoint (Feature* retVal)

Applies to

IGeometricPointItem
NominalPoint
Point_FeatureIntersection
Point_Inter2Lines3D
Point_Inter2LinesProjected
Point_Inter3Planes
Point_InterPlaneLine
Point_Middle
Point_ProjectedOnLine
Point_ProjectedOnPlane
Point_RetracePoint


NominalVector

NominalVector - object

Interfaces

INominalVectorItem

Methods of INominalVectorItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of INominalVectorItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureVector | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of INominalVectorItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


FeatureVector

FeatureVector - Read property

Syntax in Visual Basic or VBScript

FeatureVector () As Feature

Syntax in C++

HRESULT get_FeatureVector (Feature* retVal)

Applies to

NominalVector


ParameterVector

ParameterVector - Read property

Syntax in Visual Basic or VBScript

ParameterVector () As ParameterVector3D

Syntax in C++

HRESULT get_ParameterVector (ParameterVector3D* retVal)

Applies to

NominalVector


ObjectPool

ObjectPool - object

Description

ObjectPool Class

Interfaces

IObjectPool

Methods of IObjectPool

Add

Properties of IObjectPool

Count | R/W | property Count
Item | R/O |


Add

Add - method

Syntax in Visual Basic or VBScript

Add (ClassType As String , obj As Object) As ActiveObject

Syntax in C++

HRESULT Add (BSTR ClassType , IDispatch* obj , ActiveObject* retVal)

Parameters

Name | Description
ClassType |
obj |
Return Value |

Applies to

ObjectPool


OffsetPoint

OffsetPoint - object

Interfaces

IOffsetPoint

Properties of IOffsetPoint

CompositeOffsetType | R/W | return the type of point
Link | R/O | get the link or NULL if the type is not appropriate
Name | R/W | property Name
Offset | R/W | return the offset


CompositeOffsetType

CompositeOffsetType - Read & Write property

Description

return the type of point

Syntax in Visual Basic or VBScript

CompositeOffsetType () As PWI_CompositeOffsetType

Syntax in C++

HRESULT get_CompositeOffsetType (PWI_CompositeOffsetType* retVal)
HRESULT put_CompositeOffsetType (PWI_CompositeOffsetType Value)

Applies to

OffsetPoint


Link

Link - Read property

Description

get the link or NULL if the type is not appropriate

Syntax in Visual Basic or VBScript

Link () As ISequenceLink

Syntax in C++

HRESULT get_Link (ISequenceLink* retVal)

Applies to

OffsetPoint


Offset

Offset - Read & Write property

Description

return the offset

Syntax in Visual Basic or VBScript

Offset () As Double

Syntax in C++

HRESULT get_Offset (double* retVal)
HRESULT put_Offset (double Value)

Applies to

OffsetPoint


OffsetPoints

OffsetPoints - object

Interfaces

IOffsetPoints

Properties of IOffsetPoints

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual offsetPoint within the collection. Index can be an ordinal from 1 to Count or a string


Item

Item - Read property

Description

Allows random access to individual offsetPoint within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As OffsetPoint

Syntax in C++

HRESULT get_Item (VARIANT Index , OffsetPoint* retVal)

Applies to

OffsetPoints


OMVExporter

OMVExporter - object

Description

OMVExporter Class

Interfaces

IOMVExporter

Methods of IOMVExporter

ExportXMLCutFile | method ExportXMLCutFile
ExportXMLProbePath | method ExportXMLProbePath

Properties of IOMVExporter

Document | R/W | property PowerINSPECT Document
OutputPointType | R/W | Set/Get the output point for the probe path
OutputTransform | R/W | The transformation that will be applied to all output coordinates
OutputWorkplane | R/W | The output workplane
PartName | R/W | Set/Get the part name for the outputted path
ToolNumber | R/W | Set/Get the tool number for the outputted path
WorkpieceCoordSystemNumber | R/W | Set/Get the Workpiece coordinate system number


Document

Document - Read & Write property

Description

property PowerINSPECT Document

Syntax in Visual Basic or VBScript

Document () As Document

Syntax in C++

HRESULT get_Document (Document* retVal)
HRESULT put_Document (Document* Value)

Applies to

OMVExporter


OutputPointType

OutputPointType - Read & Write property

Description

Set/Get the output point for the probe path

Syntax in Visual Basic or VBScript

OutputPointType () As OutputPointType

Syntax in C++

HRESULT get_OutputPointType (OutputPointType* retVal)
HRESULT put_OutputPointType (OutputPointType Value)

Applies to

OMVExporter


OutputTransform

OutputTransform - Read & Write property

Description

The transformation that will be applied to all output coordinates

Syntax in Visual Basic or VBScript

OutputTransform () As transform

Syntax in C++

HRESULT get_OutputTransform (transform* retVal)
HRESULT put_OutputTransform (transform* Value)

Applies to

OMVExporter
ProbePathCXMOutputter


OutputWorkplane

OutputWorkplane - Read & Write property

Description

The output workplane

Syntax in Visual Basic or VBScript

OutputWorkplane () As IWorkplaneItem

Syntax in C++

HRESULT get_OutputWorkplane (IWorkplaneItem* retVal)
HRESULT put_OutputWorkplane (IWorkplaneItem* Value)

Applies to

OMVExporter


PartName

PartName - Read & Write property

Description

Set/Get the part name for the outputted path

Syntax in Visual Basic or VBScript

PartName () As String

Syntax in C++

HRESULT get_PartName (BSTR* retVal)
HRESULT put_PartName (BSTR Value)

Applies to

OMVExporter


ToolNumber

ToolNumber - Read & Write property

Description

Set/Get the tool number for the outputted path

Syntax in Visual Basic or VBScript

ToolNumber () As Long

Syntax in C++

HRESULT get_ToolNumber (LONG* retVal)
HRESULT put_ToolNumber (LONG Value)

Applies to

OMVExporter


WorkpieceCoordSystemNumber

WorkpieceCoordSystemNumber - Read & Write property

Description

Set/Get the Workpiece coordinate system number

Syntax in Visual Basic or VBScript

WorkpieceCoordSystemNumber () As Long

Syntax in C++

HRESULT get_WorkpieceCoordSystemNumber (LONG* retVal)
HRESULT put_WorkpieceCoordSystemNumber (LONG Value)

Applies to

OMVExporter


ExportXMLCutFile

ExportXMLCutFile - method

Description

method ExportXMLCutFile

Syntax in Visual Basic or VBScript

ExportXMLCutFile (a_filename As String , a_flags As Long , a_pmpopt_filename As String , a_tap_filename As String)

Syntax in C++

HRESULT ExportXMLCutFile (BSTR a_filename , LONG a_flags , BSTR a_pmpopt_filename , BSTR a_tap_filename)

Parameters

Name | Description
a_filename |
a_flags |
a_pmpopt_filename |
a_tap_filename |

Applies to

OMVExporter


ExportXMLProbePath

ExportXMLProbePath - method

Description

method ExportXMLProbePath

Syntax in Visual Basic or VBScript

ExportXMLProbePath (a_target As Variant)

Syntax in C++

HRESULT ExportXMLProbePath (VARIANT a_target)

Parameters

Name | Description
a_target |

Applies to

OMVExporter


OMVImportCtrl

OMVImportCtrl - object

Description

OMVImportCtrl Class

Interfaces

IOMVImportCtrl

Events

OnClose | Fired when the control is asked to close.
OnSettingsChanged | Fired when the import setting was changed by a user.

Methods of IOMVImportCtrl

ClearMessageArea Removes all the messages from the info area

Properties of IOMVImportCtrl

Appearance | R/W |
AutoSize | R/W |
Enabled | R/W |
Header | R/W | Set/Get the text of the control header
HelperSource | R/W | property HelperSource
ImportEnabled | R/W | Allows to enable/disable the import controls
Importer | R/O | property Importer
InputSource | R/W | property InputSource
PowerInspect | R/W | property PowerInspect
Reader | R/W | property Reader
TabStop | R/W |


Appearance

Appearance - Read & Write property

Syntax in Visual Basic or VBScript

Appearance () As Integer

Syntax in C++

HRESULT get_Appearance (SHORT* retVal)
HRESULT put_Appearance (SHORT Value)

Applies to

OMVImportCtrl


AutoSize

AutoSize - Read & Write property

Syntax in Visual Basic or VBScript

AutoSize () As Boolean

Syntax in C++

HRESULT get_AutoSize (VARIANT_BOOL* retVal)
HRESULT put_AutoSize (VARIANT_BOOL Value)

Applies to

OMVImportCtrl


Enabled

Enabled - Read & Write property

Syntax in Visual Basic or VBScript

Enabled () As Boolean

Syntax in C++

HRESULT get_Enabled (VARIANT_BOOL* retVal)
HRESULT put_Enabled (VARIANT_BOOL Value)

Applies to

OMVImportCtrl


Header

Header - Read & Write property

Description

Set/Get the text of the control header

Syntax in Visual Basic or VBScript

Header () As String

Syntax in C++

HRESULT get_Header (BSTR* retVal)
HRESULT put_Header (BSTR Value)

Applies to

OMVImportCtrl


HelperSource

HelperSource - Read & Write property

Description

property HelperSource

Syntax in Visual Basic or VBScript

HelperSource () As Variant

Syntax in C++

HRESULT get_HelperSource (VARIANT* retVal)
HRESULT put_HelperSource (VARIANT Value)

Applies to

OMVImportCtrl


ImportEnabled

ImportEnabled - Read & Write property

Description

Allows to enable/disable the import controls

Syntax in Visual Basic or VBScript

ImportEnabled () As Boolean

Syntax in C++

HRESULT get_ImportEnabled (VARIANT_BOOL* retVal)
HRESULT put_ImportEnabled (VARIANT_BOOL Value)

Applies to

OMVImportCtrl


Importer

Importer - Read property

Description

property Importer

Syntax in Visual Basic or VBScript

Importer () As OMVImporter

Syntax in C++

HRESULT get_Importer (OMVImporter* retVal)

Applies to

OMVImportCtrl


InputSource

InputSource - Read & Write property

Description

property InputSource

Syntax in Visual Basic or VBScript

InputSource () As Variant

Syntax in C++

HRESULT get_InputSource (VARIANT* retVal)
HRESULT put_InputSource (VARIANT Value)

Applies to

OMVImportCtrl


PowerInspect

PowerInspect - Read & Write property

Description

property PowerInspect

Syntax in Visual Basic or VBScript

PowerInspect () As Application

Syntax in C++

HRESULT get_PowerInspect (Application* retVal)
HRESULT put_PowerInspect (Application* Value)

Applies to

OMVImportCtrl


Reader

Reader - Read & Write property

Description

property Reader

Syntax in Visual Basic or VBScript

Reader () As OMVIProbePathXMLReader

Syntax in C++

HRESULT get_Reader (OMVIProbePathXMLReader* retVal)
HRESULT put_Reader (OMVIProbePathXMLReader* Value)

Applies to

OMVImportCtrl
OMVImporter


TabStop

TabStop - Read & Write property

Syntax in Visual Basic or VBScript

TabStop () As Boolean

Syntax in C++

HRESULT get_TabStop (VARIANT_BOOL* retVal)
HRESULT put_TabStop (VARIANT_BOOL Value)

Applies to

OMVImportCtrl


ClearMessageArea

ClearMessageArea - method

Description

Removes all the messages from the info area

Syntax in Visual Basic or VBScript

ClearMessageArea ()

Syntax in C++

HRESULT ClearMessageArea ()

Applies to

OMVImportCtrl


OnClose

OnClose - event

Description

Fired when the control is asked to close.

Syntax in Visual Basic or VBScript

OnClose ()

Syntax in C++

HRESULT OnClose (HRESULT* retVal)

Applies to

OMVImportCtrl


OnSettingsChanged

OnSettingsChanged - event

Description

Fired when the import setting was changed by a user.

Syntax in Visual Basic or VBScript

OnSettingsChanged ()

Syntax in C++

HRESULT OnSettingsChanged (HRESULT* retVal)

Applies to

OMVImportCtrl


OMVImporter

OMVImporter - object

Description

OMVImporter Class

Interfaces

IOMVImporter

Events

OnCurrentItemProgressChanged | method OnCurrentItemProgressChanged
OnError | method OnError
OnItemImported | method OnItemImported
OnProgressChanged | method OnProgressChanged
OnStatusChanged | method OnStatusChanged

Methods of IOMVImporter

CreateScriptReader | Helps to create and properly initialiaze a script reader
GoStep | method GoStep
Run | method Run
Stop | method Stop
Suspend | method Suspend
Validate | Validates the sequence tree of the document against the given helper source (CXM file)
ValidationResult | Returns the problems found during the last validation

Properties of IOMVImporter

Busy | R/O | property Busy
cursor | R/O | property Cursor
Document | R/W | property Document
HelperInfoSource | R/W | property HelperInfoSource
measure | R/W | property Measure
NumberOfSteps | R/O | property NumberOfSteps
Reader | R/W | property Reader
Status | R/O | property Status


Busy

Busy - Read property

Description

property Busy

Syntax in Visual Basic or VBScript

Busy () As Boolean

Syntax in C++

HRESULT get_Busy (VARIANT_BOOL* retVal)

Applies to

OMVImporter


cursor

cursor - Read property

Description

property Cursor

Syntax in Visual Basic or VBScript

cursor () As Long

Syntax in C++

HRESULT get_cursor (LONG* retVal)

Applies to

OMVImporter


Document

Document - Read & Write property

Description

property Document

Syntax in Visual Basic or VBScript

Document () As Document

Syntax in C++

HRESULT get_Document (Document* retVal)
HRESULT put_Document (Document* Value)

Applies to

OMVImporter
SequenceItemIterator
SequenceReplayEngine
SequenceReplayEngineCtrl


HelperInfoSource

HelperInfoSource - Read & Write property

Description

property HelperInfoSource

Syntax in Visual Basic or VBScript

HelperInfoSource () As Variant

Syntax in C++

HRESULT get_HelperInfoSource (VARIANT* retVal)
HRESULT put_HelperInfoSource (VARIANT Value)

Applies to

OMVImporter


measure

measure - Read & Write property

Description

property Measure

Syntax in Visual Basic or VBScript

measure () As measure

Syntax in C++

HRESULT get_measure (measure* retVal)
HRESULT put_measure (measure* Value)

Applies to

OMVImporter
SequenceReplayEngine


NumberOfSteps

NumberOfSteps - Read property

Description

property NumberOfSteps

Syntax in Visual Basic or VBScript

NumberOfSteps () As Long

Syntax in C++

HRESULT get_NumberOfSteps (LONG* retVal)

Applies to

OMVImporter


Status

Status - Read property

Description

property Status

Syntax in Visual Basic or VBScript

Status () As OMVImporterStatus

Syntax in C++

HRESULT get_Status (OMVImporterStatus* retVal)

Applies to

OMVImporter


CreateScriptReader

CreateScriptReader - method

Description

Helps to create and properly initialiaze a script reader

Syntax in Visual Basic or VBScript

CreateScriptReader (a_script_file As String , a_input_file As String) As OMVIScriptReader

Syntax in C++

HRESULT CreateScriptReader (BSTR a_script_file , BSTR a_input_file , OMVIScriptReader* retVal)

Parameters

Name | Description
a_script_file |
a_input_file |
Return Value |

Applies to

OMVImporter


GoStep

GoStep - method

Description

method GoStep

Syntax in Visual Basic or VBScript

GoStep ()

Syntax in C++

HRESULT GoStep ()

Applies to

OMVImporter


OnCurrentItemProgressChanged

OnCurrentItemProgressChanged - event

Description

method OnCurrentItemProgressChanged

Syntax in Visual Basic or VBScript

OnCurrentItemProgressChanged (a_name As String , a_step As Long , a_number_of_steps As Long)

Syntax in C++

HRESULT OnCurrentItemProgressChanged (BSTR a_name , LONG a_step , LONG a_number_of_steps , HRESULT* retVal)

Parameters

Name | Description
a_name |
a_step |
a_number_of_steps |

Applies to

OMVImporter


OnError

OnError - event

Description

method OnError

Syntax in Visual Basic or VBScript

OnError (a_code As Long , a_description As String)

Syntax in C++

HRESULT OnError (LONG a_code , BSTR a_description , HRESULT* retVal)

Parameters

Name | Description
a_code |
a_description |

Applies to

OMVImporter


OnItemImported

OnItemImported - event

Description

method OnItemImported

Syntax in Visual Basic or VBScript

OnItemImported (a_name As String , a_nb_points_received As Long , a_nb_points_expected As Long , a_result As Boolean)

Syntax in C++

HRESULT OnItemImported (BSTR a_name , LONG a_nb_points_received , LONG a_nb_points_expected , VARIANT_BOOL a_result , HRESULT* retVal)

Parameters

Name | Description
a_name |
a_nb_points_received |
a_nb_points_expected |
a_result |

Applies to

OMVImporter


OnProgressChanged

OnProgressChanged - event

Description

method OnProgressChanged

Syntax in Visual Basic or VBScript

OnProgressChanged (a_step As Long , a_number_of_steps As Long)

Syntax in C++

HRESULT OnProgressChanged (LONG a_step , LONG a_number_of_steps , HRESULT* retVal)

Parameters

Name | Description
a_step |
a_number_of_steps |

Applies to

OMVImporter


OnStatusChanged

OnStatusChanged - event

Description

method OnStatusChanged

Syntax in Visual Basic or VBScript

OnStatusChanged (a_status As OMVImporterStatus)

Syntax in C++

HRESULT OnStatusChanged (OMVImporterStatus a_status , HRESULT* retVal)

Parameters

Name | Description
a_status |

Applies to

OMVImporter


Run

Run - method

Description

method Run

Syntax in Visual Basic or VBScript

Run ()

Syntax in C++

HRESULT Run ()

Applies to

OMVImporter


Stop

Stop - method

Description

method Stop

Syntax in Visual Basic or VBScript

Stop ()

Syntax in C++

HRESULT Stop ()

Applies to

OMVImporter


Suspend

Suspend - method

Description

method Suspend

Syntax in Visual Basic or VBScript

Suspend ()

Syntax in C++

HRESULT Suspend ()

Applies to

OMVImporter


Validate

Validate - method

Description

Validates the sequence tree of the document against the given helper source (CXM file)

Syntax in Visual Basic or VBScript

Validate () As OMVImportValidationResult

Syntax in C++

HRESULT Validate (OMVImportValidationResult* retVal)

Parameters

Name | Description
Return Value |

Applies to

OMVImporter


ValidationResult

ValidationResult - method

Description

Returns the problems found during the last validation

Syntax in Visual Basic or VBScript

ValidationResult () As String

Syntax in C++

HRESULT ValidationResult (BSTR* retVal)

Parameters

Name | Description
Return Value |

Applies to

OMVImporter


OMVIProbePathXMLItem

OMVIProbePathXMLItem - object

Description

OMVIProbePathXMLItem Class

Interfaces

IOMVIItem

Properties of IOMVIItem

IsCompleted | R/W | Returns TRUE if the item has all points for PowerINSPECT sequence item or the last portion of points. FALSE otherwise.
RichInfo | R/O |

Collections of IOMVIItem

ContactPoints


IsCompleted

IsCompleted - Read & Write property

Description

Returns TRUE if the item has all points for PowerINSPECT sequence item or the last portion of points. FALSE otherwise.

Syntax in Visual Basic or VBScript

IsCompleted () As Boolean

Syntax in C++

HRESULT get_IsCompleted (VARIANT_BOOL* retVal)
HRESULT put_IsCompleted (VARIANT_BOOL Value)

Applies to

OMVIProbePathXMLItem


RichInfo

RichInfo - Read property

Syntax in Visual Basic or VBScript

RichInfo () As IOMVIItemRichInfo

Syntax in C++

HRESULT get_RichInfo (IOMVIItemRichInfo* retVal)

Applies to

OMVIProbePathXMLItem


ContactPoints

ContactPoints - Read property

Syntax in Visual Basic or VBScript

ContactPoints () As CMMPoints

Syntax in C++

HRESULT get_ContactPoints (CMMPoints* retVal)

Applies to

OMVIProbePathXMLItem


OMVIProbePathXMLItems

OMVIProbePathXMLItems - object

Description

OMVIProbePathXMLItems Class

Interfaces

IOMVIItemSequentialStream

Methods of IOMVIItemSequentialStream

Close | Informs the stream that it may release all the resources.
Initialize | Informs the stream that it needs to take any initialization action.
Read | Provides the current item object, the Stream Status must be READY in order this method to succeed.

Properties of IOMVIItemSequentialStream

Status R/O returns the current status of the stream


Status

Status - Read property

Description

returns the current status of the stream

Syntax in Visual Basic or VBScript

Status () As OMVISequentialStreamStatus

Syntax in C++

HRESULT get_Status (OMVISequentialStreamStatus* retVal)

Applies to

OMVIProbePathXMLItems


Close

Close - method

Description

Informs the stream that it may release all the resources.

Syntax in Visual Basic or VBScript

Close ()

Syntax in C++

HRESULT Close ()

Applies to

OMVIProbePathXMLItems


Initialize

Initialize - method

Description

Informs the stream that it needs to take any initialization action.

Syntax in Visual Basic or VBScript

Initialize ()

Syntax in C++

HRESULT Initialize ()

Applies to

OMVIProbePathXMLItems


Read

Read - method

Description

Provides the current item object, the Stream Status must be READY in order this method to succeed.

Syntax in Visual Basic or VBScript

Read () As OMVIProbePathXMLItem

Syntax in C++

HRESULT Read (OMVIProbePathXMLItem* retVal)

Parameters

Name | Description
Return Value |

Applies to

OMVIProbePathXMLItems


OMVIProbePathXMLReader

OMVIProbePathXMLReader - object

Description

OMVIProbePathXMLReader Class

Interfaces

IOMVIReader

Methods of IOMVIReader

Configure | The method is called when a user wants to configure the reader.
Parse | method Parse

Properties of IOMVIReader

Configurable | R/O | Allows to check if this reader is configuirable
ControlsEndOfItem | R/O | method ControlsEndOfItem
Parameters | W/O | Allows to provide an object to the reader where it can save its own data
PromptForStart | R/W | Informs if a user should be prompted for start
ProvidesApproachVector | R/O |
ProvidesProbeDiameter | R/O | Return VARIANT_TRUE if the reader is able to provide probe diameter for items, VARIANT_FALSE otherwise.
Source | R/W |
Stream | R/O | items stream


Configurable

Configurable - Read property

Description

Allows to check if this reader is configuirable

Syntax in Visual Basic or VBScript

Configurable () As Boolean

Syntax in C++

HRESULT get_Configurable (VARIANT_BOOL* retVal)

Applies to

OMVIProbePathXMLReader
OMVIScriptReader


ControlsEndOfItem

ControlsEndOfItem - Read property

Description

method ControlsEndOfItem

Syntax in Visual Basic or VBScript

ControlsEndOfItem () As Boolean

Syntax in C++

HRESULT get_ControlsEndOfItem (VARIANT_BOOL* retVal)

Applies to

OMVIProbePathXMLReader
OMVIScriptReader


Parameters

Parameters - Write property

Description

Allows to provide an object to the reader where it can save its own data

Syntax in Visual Basic or VBScript

Parameters (ByRef Value As RegPropertyBag)

Syntax in C++

HRESULT put_Parameters (RegPropertyBag* Value)

Applies to

OMVIProbePathXMLReader
OMVIScriptReader


PromptForStart

PromptForStart - Read & Write property

Description

Informs if a user should be prompted for start

Syntax in Visual Basic or VBScript

PromptForStart () As Boolean

Syntax in C++

HRESULT get_PromptForStart (VARIANT_BOOL* retVal)
HRESULT put_PromptForStart (VARIANT_BOOL Value)

Applies to

OMVIProbePathXMLReader
OMVIScriptReader
OMVScriptReaderBridge


ProvidesApproachVector

ProvidesApproachVector - Read property

Syntax in Visual Basic or VBScript

ProvidesApproachVector () As Boolean

Syntax in C++

HRESULT get_ProvidesApproachVector (VARIANT_BOOL* retVal)

Applies to

OMVIProbePathXMLReader
OMVIScriptReader


ProvidesProbeDiameter

ProvidesProbeDiameter - Read property

Description

Return VARIANT_TRUE if the reader is able to provide probe diameter for items, VARIANT_FALSE otherwise.

Syntax in Visual Basic or VBScript

ProvidesProbeDiameter () As Boolean

Syntax in C++

HRESULT get_ProvidesProbeDiameter (VARIANT_BOOL* retVal)

Applies to

OMVIProbePathXMLReader
OMVIScriptReader


Source

Source - Read & Write property

Syntax in Visual Basic or VBScript

Source () As Variant

Syntax in C++

HRESULT get_Source (VARIANT* retVal)
HRESULT put_Source (VARIANT Value)

Applies to

OMVIProbePathXMLReader
OMVIScriptReader


Stream

Stream - Read property

Description

items stream

Syntax in Visual Basic or VBScript

Stream () As OMVIProbePathXMLItems

Syntax in C++

HRESULT get_Stream (OMVIProbePathXMLItems* retVal)

Applies to

OMVIProbePathXMLReader
OMVIScriptReader


Configure

Configure - method

Description

The method is called when a user wants to configure the reader.

Syntax in Visual Basic or VBScript

Configure (a_hwnd As Long)

Syntax in C++

HRESULT Configure (LONG a_hwnd)

Parameters

Name | Description
a_hwnd |

Applies to

OMVIProbePathXMLReader


Parse

Parse - method

Description

method Parse

Syntax in Visual Basic or VBScript

Parse ()

Syntax in C++

HRESULT Parse ()

Applies to

OMVIProbePathXMLReader


OMVIScriptItem

OMVIScriptItem - object

Description

OMVIScriptItem Class

Interfaces

IOMVIItem

Properties of IOMVIItem

IsCompleted | R/W | Returns TRUE if the item has all points for PowerINSPECT sequence item or the last portion of points. FALSE otherwise.
RichInfo | R/O |

Collections of IOMVIItem

ContactPoints


OMVIScriptItems

OMVIScriptItems - object

Description

OMVIScriptItems Class

Interfaces

IOMVIItemSequentialStream

Methods of IOMVIItemSequentialStream

Close | Informs the stream that it may release all the resources.
Initialize | Informs the stream that it needs to take any initialization action.
Read | Provides the current item object, the Stream Status must be READY in order this method to succeed.

Properties of IOMVIItemSequentialStream

Status R/O returns the current status of the stream


OMVIScriptReader

OMVIScriptReader - object

Description

OMVIScriptReader Class

Interfaces

IOMVIScriptReader

Methods of IOMVIScriptReader

Configure | The method is called when a user wants to configure the reader.
Parse | method Parse

Properties of IOMVIScriptReader

Configurable | R/O | Allows to check if this reader is configuirable
ControlsEndOfItem | R/O | method ControlsEndOfItem
InputFile | R/W | property InputFile
LastScriptError | R/O | Returns a description of the last error found in a script
NeedsInputFile | R/W | property NeedsInputFile
Parameters | W/O | Allows to provide an object to the reader where it can save its own data
PromptForStart | R/W | Informs if a user should be prompted for start
ProvidesApproachVector | R/O |
ProvidesProbeDiameter | R/O | Return VARIANT_TRUE if the reader is able to provide probe diameter for items, VARIANT_FALSE otherwise.
Source | R/W |
Stream | R/O | items stream


InputFile

InputFile - Read & Write property

Description

property InputFile

Syntax in Visual Basic or VBScript

InputFile () As String

Syntax in C++

HRESULT get_InputFile (BSTR* retVal)
HRESULT put_InputFile (BSTR Value)

Applies to

OMVIScriptReader


LastScriptError

LastScriptError - Read property

Description

Returns a description of the last error found in a script

Syntax in Visual Basic or VBScript

LastScriptError () As String

Syntax in C++

HRESULT get_LastScriptError (BSTR* retVal)

Applies to

OMVIScriptReader


NeedsInputFile

NeedsInputFile - Read & Write property

Description

property NeedsInputFile

Syntax in Visual Basic or VBScript

NeedsInputFile () As Boolean

Syntax in C++

HRESULT get_NeedsInputFile (VARIANT_BOOL* retVal)
HRESULT put_NeedsInputFile (VARIANT_BOOL Value)

Applies to

OMVIScriptReader
OMVScriptReaderBridge


OMVIXmlCutFileItem

OMVIXmlCutFileItem - object

Description

OMVIXmlCutFileItem Class

Interfaces

IOMVIItem

Properties of IOMVIItem

IsCompleted | R/W | Returns TRUE if the item has all points for PowerINSPECT sequence item or the last portion of points. FALSE otherwise.
RichInfo | R/O |

Collections of IOMVIItem

ContactPoints


OMVIXmlCutFileItems

OMVIXmlCutFileItems - object

Description

OMVIXmlCutFileItems Class

Interfaces

IOMVIItemSequentialStream

Methods of IOMVIItemSequentialStream

Close | Informs the stream that it may release all the resources.
Initialize | Informs the stream that it needs to take any initialization action.
Read | Provides the current item object, the Stream Status must be READY in order this method to succeed.

Properties of IOMVIItemSequentialStream

Status R/O returns the current status of the stream


OMVIXmlCutFileReader

OMVIXmlCutFileReader - object

Description

OMVIXmlCutFileReader Class

Interfaces

IOMVIReader

Methods of IOMVIReader

Configure | The method is called when a user wants to configure the reader.
Parse | method Parse

Properties of IOMVIReader

Configurable | R/O | Allows to check if this reader is configuirable
ControlsEndOfItem | R/O | method ControlsEndOfItem
Parameters | W/O | Allows to provide an object to the reader where it can save its own data
PromptForStart | R/W | Informs if a user should be prompted for start
ProvidesApproachVector | R/O |
ProvidesProbeDiameter | R/O | Return VARIANT_TRUE if the reader is able to provide probe diameter for items, VARIANT_FALSE otherwise.
Source | R/W |
Stream | R/O | items stream


OMVScriptReaderBridge

OMVScriptReaderBridge - object

Description

OMVScriptReaderBridge Class

Interfaces

IOMVScriptReaderBridge

Properties of IOMVScriptReaderBridge

ControlsEndOfItem | R/W | property ControlsEndOfItem
NeedsInputFile | R/W | property NeedsInputFile
Parameters | R/O | Provides an object to the reader where it can save its own data
PromptForStart | R/W | Informs if a user should be prompted for start
ProvidesApproachVector | R/W | property ProvidesApproachVector
ProvidesProbeDiameter | R/W | property ProvidesProbeDiameter
ScriptReaderPath | R/O | Provides the path of the current reader script


ControlsEndOfItem

ControlsEndOfItem - Read & Write property

Description

property ControlsEndOfItem

Syntax in Visual Basic or VBScript

ControlsEndOfItem () As Boolean

Syntax in C++

HRESULT get_ControlsEndOfItem (VARIANT_BOOL* retVal)
HRESULT put_ControlsEndOfItem (VARIANT_BOOL Value)

Applies to

OMVScriptReaderBridge


Parameters

Parameters - Read property

Description

Provides an object to the reader where it can save its own data

Syntax in Visual Basic or VBScript

Parameters () As RegPropertyBag

Syntax in C++

HRESULT get_Parameters (RegPropertyBag* retVal)

Applies to

OMVScriptReaderBridge


ProvidesApproachVector

ProvidesApproachVector - Read & Write property

Description

property ProvidesApproachVector

Syntax in Visual Basic or VBScript

ProvidesApproachVector () As Boolean

Syntax in C++

HRESULT get_ProvidesApproachVector (VARIANT_BOOL* retVal)
HRESULT put_ProvidesApproachVector (VARIANT_BOOL Value)

Applies to

OMVScriptReaderBridge


ProvidesProbeDiameter

ProvidesProbeDiameter - Read & Write property

Description

property ProvidesProbeDiameter

Syntax in Visual Basic or VBScript

ProvidesProbeDiameter () As Boolean

Syntax in C++

HRESULT get_ProvidesProbeDiameter (VARIANT_BOOL* retVal)
HRESULT put_ProvidesProbeDiameter (VARIANT_BOOL Value)

Applies to

OMVScriptReaderBridge


ScriptReaderPath

ScriptReaderPath - Read property

Description

Provides the path of the current reader script

Syntax in Visual Basic or VBScript

ScriptReaderPath () As String

Syntax in C++

HRESULT get_ScriptReaderPath (BSTR* retVal)

Applies to

OMVScriptReaderBridge


Parameter

Parameter - object

Description

Parameter Class

Interfaces

IParameter

Properties of IParameter

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


ParameterAngle

ParameterAngle - object

Interfaces

IParameter1

Properties of IParameter1

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


Description - Read property

Description

return a description of the parameter in the current locale language

Syntax in Visual Basic or VBScript

Description () As String

Syntax in C++

HRESULT get_Description (BSTR* retVal)

Applies to

Parameter
ParameterAngle
ParameterAngleQuadrant
ParameterBoundary
ParameterCompensationMethod
ParameterCompositeOffset
ParameterDirection
IParameterEnum
ParameterGuidedMeasure
ParameterMainPlane
ParameterMaterialCondition
ParameterMaterialSide
ParameterMatrixDefinition
ParameterPoint3D
ParameterPoint3DEx
ParameterReportSettings
ParameterRPSConstraints
ParameterVector3D
ParameterVector3DEx


Name

Name - Read property

Description

retrieve the name of the parameter

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)

Applies to

Parameter
ParameterAngle
ParameterAngleQuadrant
ParameterBoundary
ParameterCompensationMethod
ParameterCompositeOffset
ParameterDirection
IParameterEnum
ParameterGuidedMeasure
ParameterMainPlane
ParameterMaterialCondition
ParameterMaterialSide
ParameterMatrixDefinition
ParameterPoint3D
ParameterPoint3DEx
ParameterReportSettings
ParameterRPSConstraints
ParameterVector3D
ParameterVector3DEx


ParameterType

ParameterType - Read property

Description

return the Type of the parameter

Syntax in Visual Basic or VBScript

ParameterType () As PWI_ParamType

Syntax in C++

HRESULT get_ParameterType (PWI_ParamType* retVal)

Applies to

Parameter
ParameterAngle
ParameterAngleQuadrant
ParameterBoundary
ParameterCompensationMethod
ParameterCompositeOffset
ParameterDirection
IParameterEnum
ParameterGuidedMeasure
ParameterMainPlane
ParameterMaterialCondition
ParameterMaterialSide
ParameterMatrixDefinition
ParameterPoint3D
ParameterPoint3DEx
ParameterReportSettings
ParameterRPSConstraints
ParameterVector3D
ParameterVector3DEx


ReadOnly

ReadOnly - Read property

Description

return true if the parameter cannot be modified

Syntax in Visual Basic or VBScript

ReadOnly () As Boolean

Syntax in C++

HRESULT get_ReadOnly (VARIANT_BOOL* retVal)

Applies to

Parameter
ParameterAngle
ParameterAngleQuadrant
ParameterBoundary
ParameterCompensationMethod
ParameterCompositeOffset
ParameterDirection
IParameterEnum
ParameterGuidedMeasure
ParameterMainPlane
ParameterMaterialCondition
ParameterMaterialSide
ParameterMatrixDefinition
ParameterPoint3D
ParameterPoint3DEx
ParameterReportSettings
ParameterRPSConstraints
ParameterVector3D
ParameterVector3DEx


Value

Value - Read & Write property

Description

retrieve the value of the parameter as a VARIANT

Syntax in Visual Basic or VBScript

Value () As Variant

Syntax in C++

HRESULT get_Value (VARIANT* retVal)
HRESULT put_Value (VARIANT Value)

Applies to

Parameter
ParameterAngle
ParameterAngleQuadrant
ParameterBoundary
ParameterCompensationMethod
ParameterCompositeOffset
ParameterDirection
IParameterEnum
ParameterGuidedMeasure
ParameterMainPlane
ParameterMaterialCondition
ParameterMaterialSide
ParameterMatrixDefinition
ParameterPoint3D
ParameterPoint3DEx
ParameterReportSettings
ParameterRPSConstraints
ParameterVector3D
ParameterVector3DEx


ParameterAngleQuadrant

ParameterAngleQuadrant - object

Interfaces

IParameterAngleQuadrant

Methods of IParameterAngleQuadrant

NormaliseAngles | normalize the 2 angles : will make sure that startAngle < endAngle and that the 2 angles are in the proper range
NormaliseAnglesV | normalize the 2 angles ( SCRIPTABLE version of NormaliseAngles ) : will make sure that startAngle < endAngle and that the 2 angles are in the proper range
PutAngles | Put both angles at the same time

Properties of IParameterAngleQuadrant

Description | R/O | return a description of the parameter in the current locale language
EndAngle | R/W | sets/retrieves the end angle in degree
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
StartAngle | R/W | sets/retrieves the start angle in degree
Value | R/W | retrieve the value of the parameter as a VARIANT


EndAngle

EndAngle - Read & Write property

Description

sets/retrieves the end angle in degree

Syntax in Visual Basic or VBScript

EndAngle () As Double

Syntax in C++

HRESULT get_EndAngle (double* retVal)
HRESULT put_EndAngle (double Value)

Applies to

ParameterAngleQuadrant


StartAngle

StartAngle - Read & Write property

Description

sets/retrieves the start angle in degree

Syntax in Visual Basic or VBScript

StartAngle () As Double

Syntax in C++

HRESULT get_StartAngle (double* retVal)
HRESULT put_StartAngle (double Value)

Applies to

ParameterAngleQuadrant


NormaliseAngles

NormaliseAngles - method

Description

normalize the 2 angles : will make sure that startAngle < endAngle and that the 2 angles are in the proper range

Syntax in Visual Basic or VBScript

NormaliseAngles (ByRef StartAngle As Double , ByRef EndAngle As Double)

Syntax in C++

HRESULT NormaliseAngles (double* StartAngle , double* EndAngle)

Parameters

Name | Description
StartAngle |
EndAngle |

Applies to

ParameterAngleQuadrant


NormaliseAnglesV

NormaliseAnglesV - method

Description

normalize the 2 angles ( SCRIPTABLE version of NormaliseAngles ) : will make sure that startAngle < endAngle and that the 2 angles are in the proper range

Syntax in Visual Basic or VBScript

NormaliseAnglesV (ByRef StartAngle As Variant , ByRef EndAngle As Variant)

Syntax in C++

HRESULT NormaliseAnglesV (VARIANT* StartAngle , VARIANT* EndAngle)

Parameters

Name | Description
StartAngle |
EndAngle |

Applies to

ParameterAngleQuadrant


PutAngles

PutAngles - method

Description

Put both angles at the same time

Syntax in Visual Basic or VBScript

PutAngles (StartAngle As Double , EndAngle As Double)

Syntax in C++

HRESULT PutAngles (double StartAngle , double EndAngle)

Parameters

Name | Description
StartAngle |
EndAngle |

Applies to

ParameterAngleQuadrant


ParameterBoolean

ParameterBoolean - object

Interfaces

IParameter1

Properties of IParameter1

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


ParameterBoundary

ParameterBoundary - object

Interfaces

IParameterBoundary

Methods of IParameterBoundary

Evaluate Evaluate the boundary of a entity

Properties of IParameterBoundary

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
LimitInX | R/W | set/retrieve if the boundary limits along the X direction
LimitInY | R/W | set/retrieve if the boundary limits along the Y direction
LimitInZ | R/W | set/retrieve if the boundary limits along the Z direction
MaxPoint | R/O | the max point of the boundary box
MinPoint | R/O | the min point of the boundary box
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


LimitInX

LimitInX - Read & Write property

Description

set/retrieve if the boundary limits along the X direction

Syntax in Visual Basic or VBScript

LimitInX () As Boolean

Syntax in C++

HRESULT get_LimitInX (VARIANT_BOOL* retVal)
HRESULT put_LimitInX (VARIANT_BOOL Value)

Applies to

ParameterBoundary


LimitInY

LimitInY - Read & Write property

Description

set/retrieve if the boundary limits along the Y direction

Syntax in Visual Basic or VBScript

LimitInY () As Boolean

Syntax in C++

HRESULT get_LimitInY (VARIANT_BOOL* retVal)
HRESULT put_LimitInY (VARIANT_BOOL Value)

Applies to

ParameterBoundary


LimitInZ

LimitInZ - Read & Write property

Description

set/retrieve if the boundary limits along the Z direction

Syntax in Visual Basic or VBScript

LimitInZ () As Boolean

Syntax in C++

HRESULT get_LimitInZ (VARIANT_BOOL* retVal)
HRESULT put_LimitInZ (VARIANT_BOOL Value)

Applies to

ParameterBoundary


MaxPoint

MaxPoint - Read property

Description

the max point of the boundary box

Syntax in Visual Basic or VBScript

MaxPoint () As Point3D

Syntax in C++

HRESULT get_MaxPoint (Point3D* retVal)

Applies to

ParameterBoundary


MinPoint

MinPoint - Read property

Description

the min point of the boundary box

Syntax in Visual Basic or VBScript

MinPoint () As Point3D

Syntax in C++

HRESULT get_MinPoint (Point3D* retVal)

Applies to

ParameterBoundary


Evaluate

Evaluate - method

Description

Evaluate the boundary of a entity

Syntax in Visual Basic or VBScript

Evaluate (measure As Variant)

Syntax in C++

HRESULT Evaluate (VARIANT measure)

Parameters

Name | Description
measure |

Applies to

ParameterBoundary


ParameterCompensationMethod

ParameterCompensationMethod - object

Interfaces

IParameterCompensationMethod

Methods of IParameterCompensationMethod

SetDirection sets the compensation direction, the Compensation Method will be updated accordingly, Dir could be a IFeature, a Vector or an empty variant

Properties of IParameterCompensationMethod

CompensationDir | R/O | get the compensation Direction. only valid when PWI_ProbeCompenstionMethod = pcm_ALONG_A_EXPLICIT_DIRECTION
CompensationMethod | R/W | sets/retrieves the CompensationMethod type
Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Link | R/O | gets the link. only valid when PWI_ProbeCompenstionMethod = pcm_ALONG_A_EXISITING_DIRECTION
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


CompensationDir

CompensationDir - Read property

Description

get the compensation Direction. only valid when PWI_ProbeCompenstionMethod = pcm_ALONG_A_EXPLICIT_DIRECTION

Syntax in Visual Basic or VBScript

CompensationDir () As ParameterVector3D

Syntax in C++

HRESULT get_CompensationDir (ParameterVector3D* retVal)

Applies to

ParameterCompensationMethod


CompensationMethod

CompensationMethod - Read & Write property

Description

sets/retrieves the CompensationMethod type

Syntax in Visual Basic or VBScript

CompensationMethod () As PWI_ProbeCompenstionMethod

Syntax in C++

HRESULT get_CompensationMethod (PWI_ProbeCompenstionMethod* retVal)
HRESULT put_CompensationMethod (PWI_ProbeCompenstionMethod Value)

Applies to

ParameterCompensationMethod


Link

Link - Read property

Description

gets the link. only valid when PWI_ProbeCompenstionMethod = pcm_ALONG_A_EXISITING_DIRECTION

Syntax in Visual Basic or VBScript

Link () As SimpleLink

Syntax in C++

HRESULT get_Link (SimpleLink* retVal)

Applies to

ParameterCompensationMethod


SetDirection

SetDirection - method

Description

sets the compensation direction, the Compensation Method will be updated accordingly, Dir could be a IFeature, a Vector or an empty variant

Syntax in Visual Basic or VBScript

SetDirection (dir As Variant)

Syntax in C++

HRESULT SetDirection (VARIANT dir)

Parameters

Name | Description
dir |

Applies to

ParameterCompensationMethod


ParameterCompositeOffset

ParameterCompositeOffset - object

Interfaces

IParameterCompositeOffset

Properties of IParameterCompositeOffset

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT

Collections of IParameterCompositeOffset

Offsets |
PossibleFeatures | property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


Offsets

Offsets - Read property

Syntax in Visual Basic or VBScript

Offsets () As OffsetPoints

Syntax in C++

HRESULT get_Offsets (OffsetPoints* retVal)

Applies to

ParameterCompositeOffset


ParameterDimension

ParameterDimension - object

Interfaces

IParameter1

Properties of IParameter1

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


ParameterDirection

ParameterDirection - object

Interfaces

IParameterDirection

Properties of IParameterDirection

Description | R/O | return a description of the parameter in the current locale language
Direction | R/W |
Index | R/O | returns the index of this property in its parent collection
LocalisedValue | R/O | Returns value as localised string.
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


Direction

Direction - Read & Write property

Syntax in Visual Basic or VBScript

Direction () As PWI_MainDirection

Syntax in C++

HRESULT get_Direction (PWI_MainDirection* retVal)
HRESULT put_Direction (PWI_MainDirection Value)

Applies to

ParameterDirection


LocalisedValue

LocalisedValue - Read property

Description

Returns value as localised string.

Syntax in Visual Basic or VBScript

LocalisedValue () As String

Syntax in C++

HRESULT get_LocalisedValue (BSTR* retVal)

Applies to

ParameterDirection
IParameterEnum
ParameterMainPlane
ParameterMaterialCondition
ParameterMaterialSide


ParameterGuidedMeasure

ParameterGuidedMeasure - object

Interfaces

IParameterGuidedMeasure

Properties of IParameterGuidedMeasure

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
UseGuidedMeasure | R/W |
Value | R/W | retrieve the value of the parameter as a VARIANT


UseGuidedMeasure

UseGuidedMeasure - Read & Write property

Syntax in Visual Basic or VBScript

UseGuidedMeasure () As Boolean

Syntax in C++

HRESULT get_UseGuidedMeasure (VARIANT_BOOL* retVal)
HRESULT put_UseGuidedMeasure (VARIANT_BOOL Value)

Applies to

ParameterGuidedMeasure


ParameterInteger

ParameterInteger - object

Interfaces

IParameter1

Properties of IParameter1

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


ParameterMainPlane

ParameterMainPlane - object

Interfaces

IParameterMainPlane

Properties of IParameterMainPlane

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
LocalisedValue | R/O | Returns value as localised string.
MainPlane | R/W |
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


MainPlane

MainPlane - Read & Write property

Syntax in Visual Basic or VBScript

MainPlane () As PWI_MainPlane

Syntax in C++

HRESULT get_MainPlane (PWI_MainPlane* retVal)
HRESULT put_MainPlane (PWI_MainPlane Value)

Applies to

ParameterMainPlane


ParameterMaterialCondition

ParameterMaterialCondition - object

Interfaces

IParameterMaterialCondition

Properties of IParameterMaterialCondition

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
LocalisedValue | R/O | Returns value as localised string.
MaterialCondition | R/W |
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


ParameterMaterialSide

ParameterMaterialSide - object

Interfaces

IParameterMaterialSide

Properties of IParameterMaterialSide

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
LocalisedValue | R/O | Returns value as localised string.
MaterialSide | R/W |
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


MaterialSide

MaterialSide - Read & Write property

Syntax in Visual Basic or VBScript

MaterialSide () As PWI_MaterialSide

Syntax in C++

HRESULT get_MaterialSide (PWI_MaterialSide* retVal)
HRESULT put_MaterialSide (PWI_MaterialSide Value)

Applies to

ParameterMaterialSide


ParameterMatrixDefinition

ParameterMatrixDefinition - object

Interfaces

IParameterMatrixDefinition

Properties of IParameterMatrixDefinition

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
matrix | R/O | Return a pointer to the internal matrix definition object.
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


matrix

matrix - Read property

Description

Return a pointer to the internal matrix definition object.

Syntax in Visual Basic or VBScript

matrix () As TransformDefinition

Syntax in C++

HRESULT get_matrix (TransformDefinition* retVal)

Applies to

ParameterMatrixDefinition


ParameterPoint3D

ParameterPoint3D - object

Interfaces

IParameterPoint3D

Methods of IParameterPoint3D

GetCoordinate | retrieve the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)
SetCoordinates | set the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)

Properties of IParameterPoint3D

CoordinateType | R/O | Prefered coordinate type
Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
point | R/W | retrieve the point
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


CoordinateType

CoordinateType - Read property

Description

Prefered coordinate type

Syntax in Visual Basic or VBScript

CoordinateType () As ICoordFormatPoint3D

Syntax in C++

HRESULT get_CoordinateType (ICoordFormatPoint3D* retVal)

Applies to

ParameterPoint3D


point

point - Read & Write property

Description

retrieve the point

Syntax in Visual Basic or VBScript

point () As Point3D

Syntax in C++

HRESULT get_point (Point3D* retVal)
HRESULT put_point (VARIANT Value)

Applies to

ParameterPoint3D


GetCoordinate

GetCoordinate - method

Description

retrieve the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)

Syntax in Visual Basic or VBScript

GetCoordinate (Index As Long) As Double

Syntax in C++

HRESULT GetCoordinate (LONG Index , double* retVal)

Parameters

Name | Description
Index |
Return Value |

Applies to

ParameterPoint3D


SetCoordinates

SetCoordinates - method

Description

set the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)

Syntax in Visual Basic or VBScript

SetCoordinates (v1 As Double , v2 As Double , v3 As Double)

Syntax in C++

HRESULT SetCoordinates (double v1 , double v2 , double v3)

Parameters

Name | Description
v1 |
v2 |
v3 |

Applies to

ParameterPoint3D


ParameterPoint3DEx

ParameterPoint3DEx - object

Interfaces

IParameterPoint3DEx

Properties of IParameterPoint3DEx

Description | R/O | return a description of the parameter in the current locale language
ExplicitDefinition | R/O |
ImplicitDefinition | R/O |
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
type | R/W |
Value | R/W | retrieve the value of the parameter as a VARIANT


ExplicitDefinition

ExplicitDefinition - Read property

Syntax in Visual Basic or VBScript

ExplicitDefinition () As ParameterPoint3D

Syntax in C++

HRESULT get_ExplicitDefinition (ParameterPoint3D* retVal)

Applies to

ParameterPoint3DEx
ParameterVector3DEx


ImplicitDefinition

ImplicitDefinition - Read property

Syntax in Visual Basic or VBScript

ImplicitDefinition () As SimpleLink

Syntax in C++

HRESULT get_ImplicitDefinition (SimpleLink* retVal)

Applies to

ParameterPoint3DEx
ParameterVector3DEx


type

type - Read & Write property

Syntax in Visual Basic or VBScript

type () As PWI_ParameterEXType

Syntax in C++

HRESULT get_type (PWI_ParameterEXType* retVal)
HRESULT put_type (PWI_ParameterEXType Value)

Applies to

ParameterPoint3DEx
ParameterVector3DEx
VarDesc


ParameterReportSettings

ParameterReportSettings - object

Interfaces

IParameterReportSettings

Properties of IParameterReportSettings

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT
xml | R/W | Get/Set an report configuration for an item. Must be well-formed XML.


xml

xml - Read & Write property

Description

Get/Set an report configuration for an item. Must be well-formed XML.

Syntax in Visual Basic or VBScript

xml () As String

Syntax in C++

HRESULT get_xml (BSTR* retVal)
HRESULT put_xml (BSTR Value)

Applies to

ParameterReportSettings


ParameterRPSConstraints

ParameterRPSConstraints - object

Interfaces

IParameterRPSConstraints

Methods of IParameterRPSConstraints

Add | add a new constraint
Delete | add a new constraint

Properties of IParameterRPSConstraints

Count | R/W | Indicates the number of items in the collection.
Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Item | R/O | Allows random access to individual parameter within the collection. Index can be an ordinal from 1 to Count or a string
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


Item

Item - Read property

Description

Allows random access to individual parameter within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As Parameter

Syntax in C++

HRESULT get_Item (VARIANT Index , Parameter* retVal)

Applies to

ParameterRPSConstraints
Parameters


Add

Add - method

Description

add a new constraint

Syntax in Visual Basic or VBScript

Add () As RPSConstraint

Syntax in C++

HRESULT Add (RPSConstraint* retVal)

Parameters

Name | Description
Return Value |

Applies to

ParameterRPSConstraints


Delete

Delete - method

Description

add a new constraint

Syntax in Visual Basic or VBScript

Delete (constraint As Variant)

Syntax in C++

HRESULT Delete (VARIANT constraint)

Parameters

Name | Description
constraint |

Applies to

ParameterRPSConstraints


Parameters

Parameters - object

Interfaces

IParameters

Properties of IParameters

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual parameter within the collection. Index can be an ordinal from 1 to Count or a string


ParameterVector3D

ParameterVector3D - object

Interfaces

IParameterVector3D

Methods of IParameterVector3D

GetCoordinate | retrieve the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)
SetCoordinates | set the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)

Properties of IParameterVector3D

CoordinateType | R/O | Prefered coordinate system
Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT
vector | R/W | retrieve the coordinates of the point


CoordinateType

CoordinateType - Read property

Description

Prefered coordinate system

Syntax in Visual Basic or VBScript

CoordinateType () As ICoordFormatUnitVector3D

Syntax in C++

HRESULT get_CoordinateType (ICoordFormatUnitVector3D* retVal)

Applies to

ParameterVector3D


vector

vector - Read & Write property

Description

retrieve the coordinates of the point

Syntax in Visual Basic or VBScript

vector () As UnitVector3D

Syntax in C++

HRESULT get_vector (UnitVector3D* retVal)
HRESULT put_vector (VARIANT Value)

Applies to

ParameterVector3D


GetCoordinate

GetCoordinate - method

Description

retrieve the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)

Syntax in Visual Basic or VBScript

GetCoordinate (Index As Long) As Double

Syntax in C++

HRESULT GetCoordinate (LONG Index , double* retVal)

Parameters

Name | Description
Index |
Return Value |

Applies to

ParameterVector3D


ParameterVector3DEx

ParameterVector3DEx - object

Interfaces

IParameterVector3DEx

Properties of IParameterVector3DEx

Description | R/O | return a description of the parameter in the current locale language
ExplicitDefinition | R/O |
ImplicitDefinition | R/O |
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
type | R/W |
Value | R/W | retrieve the value of the parameter as a VARIANT


PCSDatum

PCSDatum - object

Interfaces

IPCSDatumItem

Methods of IPCSDatumItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPCSDatumItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPCSDatumItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


PDBDefinition

PDBDefinition - object

Description

PDBDefinition Class

Interfaces

IPDBDefinition

Methods of IPDBDefinition

Attribute |
GetPropertyDouble | extract a double property from the PDBdefinition
GetPropertyString | extract a string property from the PDBdefinition
Initialize |
Node | depreciated - do not use
Property |

Properties of IPDBDefinition

Class | R/O
id | R/O
Name | R/W
Parent | R/O
Tag | R/O
Value | R/W


Plane_Bissector

Plane_Bissector - object

Interfaces

IPlane_BissectorItem

Methods of IPlane_BissectorItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPlane_BissectorItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyNormalVector | R/O |
ReferencePlane1 | R/O |
ReferencePlane2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPlane_BissectorItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Plane_LinePoint

Plane_LinePoint - object

Interfaces

IPlane_LinePointItem

Methods of IPlane_LinePointItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPlane_LinePointItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyNormalVector | R/O |
ReferenceLine | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPlane_LinePointItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Plane_LineVector

Plane_LineVector - object

Interfaces

IPlane_LineVectorItem

Methods of IPlane_LineVectorItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPlane_LineVectorItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyNormalVector | R/O |
ReferenceLine | R/O |
ReferenceVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPlane_LineVectorItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Plane_OffsetDistance

Plane_OffsetDistance - object

Interfaces

IPlane_OffsetDistanceItem

Methods of IPlane_OffsetDistanceItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPlane_OffsetDistanceItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterDistance | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPlane_OffsetDistanceItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterDistance

ParameterDistance - Read property

Syntax in Visual Basic or VBScript

ParameterDistance () As ParameterAngle

Syntax in C++

HRESULT get_ParameterDistance (ParameterAngle* retVal)

Applies to

Plane_OffsetDistance


Plane_ParallelThroughPoint

Plane_ParallelThroughPoint - object

Interfaces

IPlane_ParallelThroughPointItem

Methods of IPlane_ParallelThroughPointItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPlane_ParallelThroughPointItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterMaterialCondition | R/O |
PropertyDistance | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPlane_ParallelThroughPointItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Plane_PointVector

Plane_PointVector - object

Interfaces

IPlane_PointVectorItem

Methods of IPlane_PointVectorItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPlane_PointVectorItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ReferencePoint | R/O |
ReferenceVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPlane_PointVectorItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Plane_Probed

Plane_Probed - object

Interfaces

IPlane_ProbedItem

Methods of IPlane_ProbedItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPlane_ProbedItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterPoint | R/O |
PropertyNormalVector | R/O |
PropertyPlanarity | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPlane_ProbedItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Plane_WithOffsetPoints

Plane_WithOffsetPoints - object

Interfaces

IPlane_WithOffsetPointsItem

Methods of IPlane_WithOffsetPointsItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPlane_WithOffsetPointsItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterAlternateSolution | R/O |
ParameterBoundary | R/O |
ParameterCompositeOffsets | R/O |
PropertyNormalVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPlane_WithOffsetPointsItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


plane

plane - object

Description

EntityFromPoint Class

Interfaces

IPWIPlane

Methods of IPWIPlane

SetCoefficients |
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties of IPWIPlane

A | R/O
B | R/O
C | R/O
D | R/O
Evaluator | T/O
Name | R/W
NormalVector | R/O
origin | R/O
ReadOnly | R/O
TypeOf | R/O


Point_FeatureIntersection

Point_FeatureIntersection - object

Interfaces

IPoint_FeatureIntersectionItem

Methods of IPoint_FeatureIntersectionItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPoint_FeatureIntersectionItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterUseUnboundedEntities | R/O |
PropertyPoint | R/O |
ReferenceFeature | R/O |
ReferenceFeature2D | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPoint_FeatureIntersectionItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterUseUnboundedEntities

ParameterUseUnboundedEntities - Read property

Syntax in Visual Basic or VBScript

ParameterUseUnboundedEntities () As ParameterAngle

Syntax in C++

HRESULT get_ParameterUseUnboundedEntities (ParameterAngle* retVal)

Applies to

Point_FeatureIntersection


ReferenceFeature

ReferenceFeature - Read property

Syntax in Visual Basic or VBScript

ReferenceFeature () As SimpleLink

Syntax in C++

HRESULT get_ReferenceFeature (SimpleLink* retVal)

Applies to

Point_FeatureIntersection


ReferenceFeature2D

ReferenceFeature2D - Read property

Syntax in Visual Basic or VBScript

ReferenceFeature2D () As SimpleLink

Syntax in C++

HRESULT get_ReferenceFeature2D (SimpleLink* retVal)

Applies to

Point_FeatureIntersection


Point_Inter2Lines3D

Point_Inter2Lines3D - object

Interfaces

IPoint_Inter2Lines3DItem

Methods of IPoint_Inter2Lines3DItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPoint_Inter2Lines3DItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferenceLine1 | R/O |
ReferenceLine2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPoint_Inter2Lines3DItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Point_Inter2LinesProjected

Point_Inter2LinesProjected - object

Interfaces

IPoint_Inter2LinesProjectedItem

Methods of IPoint_Inter2LinesProjectedItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPoint_Inter2LinesProjectedItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferenceLine1 | R/O |
ReferenceLine2 | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPoint_Inter2LinesProjectedItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Point_Inter3Planes

Point_Inter3Planes - object

Interfaces

IPoint_Inter3PlanesItem

Methods of IPoint_Inter3PlanesItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPoint_Inter3PlanesItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferencePlane1 | R/O |
ReferencePlane2 | R/O |
ReferencePlane3 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPoint_Inter3PlanesItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ReferencePlane3

ReferencePlane3 - Read property

Syntax in Visual Basic or VBScript

ReferencePlane3 () As SimpleLink

Syntax in C++

HRESULT get_ReferencePlane3 (SimpleLink* retVal)

Applies to

Point_Inter3Planes


Point_InterPlaneLine

Point_InterPlaneLine - object

Interfaces

IPoint_InterPlaneLineItem

Methods of IPoint_InterPlaneLineItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPoint_InterPlaneLineItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPoint_InterPlaneLineItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Point_Middle

Point_Middle - object

Interfaces

IPoint_MiddleItem

Methods of IPoint_MiddleItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPoint_MiddleItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferencePoint1 | R/O |
ReferencePoint2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPoint_MiddleItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Point_ProjectedOnLine

Point_ProjectedOnLine - object

Interfaces

IPoint_ProjectedOnLineItem

Methods of IPoint_ProjectedOnLineItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPoint_ProjectedOnLineItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferenceLine | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPoint_ProjectedOnLineItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Point_ProjectedOnPlane

Point_ProjectedOnPlane - object

Interfaces

IPoint_ProjectedOnPlaneItem

Methods of IPoint_ProjectedOnPlaneItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPoint_ProjectedOnPlaneItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferencePlane | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPoint_ProjectedOnPlaneItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


Point_RetracePoint

Point_RetracePoint - object

Interfaces

IPoint_RetracePointItem

Methods of IPoint_RetracePointItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of IPoint_RetracePointItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterCompensationMethod | R/O |
PropertyDistanceOnPlane | R/O |
PropertyDistanceToTarget | R/O |
PropertyDistanceToTargetPlane | R/O |
PropertyTargetPoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of IPoint_RetracePointItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ParameterCompensationMethod

ParameterCompensationMethod - Read property

Syntax in Visual Basic or VBScript

ParameterCompensationMethod () As ParameterCompensationMethod

Syntax in C++

HRESULT get_ParameterCompensationMethod (ParameterCompensationMethod* retVal)

Applies to

Point_RetracePoint


PropertyDistanceOnPlane

PropertyDistanceOnPlane - Read property

Syntax in Visual Basic or VBScript

PropertyDistanceOnPlane () As PropertyLinearDimension

Syntax in C++

HRESULT get_PropertyDistanceOnPlane (PropertyLinearDimension* retVal)

Applies to

Point_RetracePoint


PropertyDistanceToTarget

PropertyDistanceToTarget - Read property

Syntax in Visual Basic or VBScript

PropertyDistanceToTarget () As PropertyLinearDimension

Syntax in C++

HRESULT get_PropertyDistanceToTarget (PropertyLinearDimension* retVal)

Applies to

Point_RetracePoint


PropertyDistanceToTargetPlane

PropertyDistanceToTargetPlane - Read property

Syntax in Visual Basic or VBScript

PropertyDistanceToTargetPlane () As PropertyLinearDimension

Syntax in C++

HRESULT get_PropertyDistanceToTargetPlane (PropertyLinearDimension* retVal)

Applies to

Point_RetracePoint


PropertyTargetPoint

PropertyTargetPoint - Read property

Syntax in Visual Basic or VBScript

PropertyTargetPoint () As PropertyPoint3D

Syntax in C++

HRESULT get_PropertyTargetPoint (PropertyPoint3D* retVal)

Applies to

Point_RetracePoint


Point3D

Point3D - object

Description

Point Class

Interfaces

IPoint3D

Methods of IPoint3D

GetCoordinates | retreives the 3 coordinates ( cartesian ) in one round trip ( this version is not scriptable )
GetCoordinatesV | retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )
SetCoordinates | set the XYZ coordinates of the point
SetPolarCoordinates | set the Polar coordinates (Angle,Radius,Height) of the point
SetSphericalCoordinates | set the Spherical coordinates (Azimuth,Elevation,Magnitude) of the point
TransformFrom | Transformation of point
TransformTo | Transformation of point

Properties of IPoint3D

Angle | R/W | get the Angle of the point ( First Polar Coordinate)
Azimuth | R/W | get the Azimuth of the point ( First Spherical Coordinate)
Elevation | R/W | get the Elevation of the point ( Second Spherical Coordinate)
Height | R/W | get the Height of the point ( Third Polar Coordinate)
Magnitude | R/W | get the Magnitude of the point ( Third Spherical Coordinate)
Radius | R/W | get the Radius of the point ( Second Polar Coordinate)
Value | R/W |
X | R/W | get the X coordinate of the point
Y | R/W | get the Y coordinate of the point
Z | R/W | get the Z coordinate of the point


PointCloud

PointCloud - object

Description

PointCloud Class

Interfaces

IPointCloud

Methods of IPointCloud

AddPointXYZ | method AddPointXYZ
AddPointXYZIJK | method AddPointXYZIJK
Import | method Import
Scale | method Scale : scale the point cloud
UnsetProjectionData | method UnsetProjectionData

Properties of IPointCloud

Count | R/O | property Count: returns the number of point in the point cloud
Deviation | R/W | property Deviation
Diameter | R/W | property Diameter : set/retrieve the associated probe diameter
HasProjectedInfo | R/O | property HasProjectedInfo: returns TRUE if this objects contains some information about deviation associated with the points
HasValidIJK | R/O | property HasValidIJK: returns true if the point cloud contains valid IJK vectors in its original set
HasValidProjection | R/O | property HasValidProjection
Item | R/O | property Item
MaximumDeviation | R/O | property MaximumDeviation
MaxPoint | R/O | property MaxPoint
MinimumDeviation | R/O | property MinimumDeviation
MinPoint | R/O | property MinPoint
Offset | R/W | property Offset
ScanlineCount | R/O | property ScanlineCount


PointCloudPoint

PointCloudPoint - object

Description

PointCloudPoint Class

Interfaces

IPointCloudPoint

Methods of IPointCloudPoint

UnsetProjectionData method UnsetProjectionData

Properties of IPointCloudPoint

Deviation | R/W | property Deviation
HasValidProjection | R/O | property HasValidProjection
Index | R/W | property Index
Name | R/W | property Name
point | R/O | property Point
ProjectedPoint | R/O | property ProjectedPoint
ProjectedVector | R/O | property ProjectedVector
vector | R/O | property Vector


PointCloudSelection

PointCloudSelection - object

Description

IPointCloudSelection Class

Interfaces

IPointCloudSelection

Methods of IPointCloudSelection

Get | method Get
Inverse | method Inverse
Set | method Set
SetAll | method SetAll
SetSize | method SetSize

Properties of IPointCloudSelection

Count R/W property Count


Get

Get - method

Description

method Get

Syntax in Visual Basic or VBScript

Get (nIndex As Long) As Boolean

Syntax in C++

HRESULT Get (LONG nIndex , VARIANT_BOOL* retVal)

Parameters

Name | Description
nIndex |
Return Value |

Applies to

PointCloudSelection


Inverse

Inverse - method

Description

method Inverse

Syntax in Visual Basic or VBScript

Inverse ()

Syntax in C++

HRESULT Inverse ()

Applies to

PointCloudSelection


Set

Set - method

Description

method Set

Syntax in Visual Basic or VBScript

Set (nIndex As Long , bFlag As Boolean)

Syntax in C++

HRESULT Set (LONG nIndex , VARIANT_BOOL bFlag)

Parameters

Name | Description
nIndex |
bFlag |

Applies to

PointCloudSelection


SetAll

SetAll - method

Description

method SetAll

Syntax in Visual Basic or VBScript

SetAll (bFlag As Boolean)

Syntax in C++

HRESULT SetAll (VARIANT_BOOL bFlag)

Parameters

Name | Description
bFlag |

Applies to

PointCloudSelection


SetSize

SetSize - method

Description

method SetSize

Syntax in Visual Basic or VBScript

SetSize (nNewSize As Long)

Syntax in C++

HRESULT SetSize (LONG nNewSize)

Parameters

Name | Description
nNewSize |

Applies to

PointCloudSelection


Position

Position - object

Description

ProbeHeadPosition Class

Interfaces

IPosition

Properties of IPosition

LocalDatum | R/O
MNTLEN | R/O
XVEC | R/O
ZVEC | R/O


LocalDatum

LocalDatum - Read property

Syntax in Visual Basic or VBScript

LocalDatum () As ITransform2

Syntax in C++

HRESULT get_LocalDatum (ITransform2* retVal)

Applies to

Position


MNTLEN

MNTLEN - Read property

Syntax in Visual Basic or VBScript

MNTLEN () As Point3D

Syntax in C++

HRESULT get_MNTLEN (Point3D* retVal)

Applies to

Position


XVEC

XVEC - Read property

Syntax in Visual Basic or VBScript

XVEC () As UnitVector3D

Syntax in C++

HRESULT get_XVEC (UnitVector3D* retVal)

Applies to

Position


ZVEC

ZVEC - Read property

Syntax in Visual Basic or VBScript

ZVEC () As UnitVector3D

Syntax in C++

HRESULT get_ZVEC (UnitVector3D* retVal)

Applies to

Position


ProbeDatabase

ProbeDatabase - object

Description

ProbeDatabase Class

Interfaces

IProbeDatabase

Methods of IProbeDatabase

ActivateSensor |
BuildProbePathForTipCalibration | Build a probe path that can be used to calibrate the following tip
CalibrateActiveSensor | brings a user interface to allow the active sensor to be calibrated
Compensate | get the compemsate coordinates according the active sensor
EditDatabase | brings a user dialog box to allow the underlying probe database to be managed
EditSensor |
Load | Load the probe database, stream could be a BSTR
ReconcileSensor |
Save | Save the probe database, if stream is null then the last known filename is used
Uncompensate | get the compemsate coordinates according the active sensor

Properties of IProbeDatabase

ActiveSensorName | R/O | returns the name of the current active sensor
ActiveSensorType | R/O | returns the type of the current active sensor
Carriage | R/W | Carriage
CatalogueXMLPath | R/O | returns the path where all XML components related files are stored
Filename | R/W | The current file where this database is store
ParentWindow | R/W | Parent Window
Property | R/O |
Protocol | R/O | sets/retrieves the protocol that actually controls this carriage
SensorProperty | R/O |
Settings | R/O | The general settings for the probe database
Toolbox | R/O | returns a toolbox in the same context (process and thread ) as the probedatabase


ActiveSensorName

ActiveSensorName - Read property

Description

returns the name of the current active sensor

Syntax in Visual Basic or VBScript

ActiveSensorName () As String

Syntax in C++

HRESULT get_ActiveSensorName (BSTR* retVal)

Applies to

ProbeDatabase
SimpleProbeDatabase


ActiveSensorType

ActiveSensorType - Read property

Description

returns the type of the current active sensor

Syntax in Visual Basic or VBScript

ActiveSensorType () As _PROBESENSORTYPE

Syntax in C++

HRESULT get_ActiveSensorType (_PROBESENSORTYPE* retVal)

Applies to

ProbeDatabase
SimpleProbeDatabase


Carriage

Carriage - Read & Write property

Description

Carriage

Syntax in Visual Basic or VBScript

Carriage () As Carriage

Syntax in C++

HRESULT get_Carriage (Carriage* retVal)
HRESULT put_Carriage (Carriage* Value)

Applies to

ProbeDatabase


CatalogueXMLPath

CatalogueXMLPath - Read property

Description

returns the path where all XML components related files are stored

Syntax in Visual Basic or VBScript

CatalogueXMLPath () As String

Syntax in C++

HRESULT get_CatalogueXMLPath (BSTR* retVal)

Applies to

ProbeDatabase
ProbeDatabaseToolbox


Filename

Filename - Read & Write property

Description

The current file where this database is store

Syntax in Visual Basic or VBScript

Filename () As String

Syntax in C++

HRESULT get_Filename (BSTR* retVal)
HRESULT put_Filename (BSTR Value)

Applies to

ProbeDatabase


Property

Property - Read property

Syntax in Visual Basic or VBScript

Property (Property As _SENSORPROPERTY) As Variant

Syntax in C++

HRESULT get_Property (_SENSORPROPERTY Property , VARIANT* retVal)

Applies to

ProbeDatabase
IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
probeTip
SimpleProbeDatabase


SensorProperty

SensorProperty - Read property

Syntax in Visual Basic or VBScript

SensorProperty (bstrVCard As String , Property As _SENSORPROPERTY) As Variant

Syntax in C++

HRESULT get_SensorProperty (BSTR bstrVCard , _SENSORPROPERTY Property , VARIANT* retVal)

Applies to

ProbeDatabase
SimpleProbeDatabase


Settings

Settings - Read property

Description

The general settings for the probe database

Syntax in Visual Basic or VBScript

Settings () As IProbeDatabaseSettings

Syntax in C++

HRESULT get_Settings (IProbeDatabaseSettings* retVal)

Applies to

ProbeDatabase


Toolbox

Toolbox - Read property

Description

returns a toolbox in the same context (process and thread ) as the probedatabase

Syntax in Visual Basic or VBScript

Toolbox () As ProbeDatabaseToolbox

Syntax in C++

HRESULT get_Toolbox (ProbeDatabaseToolbox* retVal)

Applies to

ProbeDatabase


ActivateSensor

ActivateSensor - method

Syntax in Visual Basic or VBScript

ActivateSensor (bstrVCard As String , hParentWindow As Long) As ACTIVATE_SENSOR_RETVAL

Syntax in C++

HRESULT ActivateSensor (BSTR bstrVCard , LONG hParentWindow , ACTIVATE_SENSOR_RETVAL* retVal)

Parameters

Name | Description
bstrVCard |
hParentWindow |
Return Value |

Applies to

SimpleProbeDatabase


BuildProbePathForTipCalibration

BuildProbePathForTipCalibration - method

Description

Build a probe path that can be used to calibrate the following tip

Syntax in Visual Basic or VBScript

BuildProbePathForTipCalibration (Tip As Variant , optionalStartPosition As Variant , ByRef ProbePath As Variant)

Syntax in C++

HRESULT BuildProbePathForTipCalibration (VARIANT Tip , VARIANT optionalStartPosition , VARIANT* ProbePath)

Parameters

Name | Description
Tip |
optionalStartPosition |
ProbePath |

Applies to

ProbeDatabase


CalibrateActiveSensor

CalibrateActiveSensor - method

Description

brings a user interface to allow the active sensor to be calibrated

Syntax in Visual Basic or VBScript

CalibrateActiveSensor ()

Syntax in C++

HRESULT CalibrateActiveSensor ()

Applies to

SimpleProbeDatabase


Compensate

Compensate - method

Description

get the compemsate coordinates according the active sensor

Syntax in Visual Basic or VBScript

Compensate (ByRef pointOrVector As Variant)

Syntax in C++

HRESULT Compensate (VARIANT* pointOrVector)

Parameters

Name | Description
pointOrVector |

Applies to

SimpleProbeDatabase


EditDatabase

EditDatabase - method

Description

brings a user dialog box to allow the underlying probe database to be managed

Syntax in Visual Basic or VBScript

EditDatabase ()

Syntax in C++

HRESULT EditDatabase ()

Applies to

SimpleProbeDatabase


EditSensor

EditSensor - method

Syntax in Visual Basic or VBScript

EditSensor (ByRef pbstrVCard As String , hParentWindow As Long) As Boolean

Syntax in C++

HRESULT EditSensor (BSTR* pbstrVCard , LONG hParentWindow , VARIANT_BOOL* retVal)

Parameters

Name | Description
pbstrVCard |
hParentWindow |
Return Value |

Applies to

SimpleProbeDatabase


Load

Load - method

Description

Load the probe database, stream could be a BSTR

Syntax in Visual Basic or VBScript

Load (stream As Variant)

Syntax in C++

HRESULT Load (VARIANT stream)

Parameters

Name | Description
stream |

Applies to

SimpleProbeDatabase


ReconcileSensor

ReconcileSensor - method

Syntax in Visual Basic or VBScript

ReconcileSensor (ByRef pbstrVCard As String , hParentWindow As Long) As Boolean

Syntax in C++

HRESULT ReconcileSensor (BSTR* pbstrVCard , LONG hParentWindow , VARIANT_BOOL* retVal)

Parameters

Name | Description
pbstrVCard |
hParentWindow |
Return Value |

Applies to

SimpleProbeDatabase


Save

Save - method

Description

Save the probe database, if stream is null then the last known filename is used

Syntax in Visual Basic or VBScript

Save (stream As Variant)

Syntax in C++

HRESULT Save (VARIANT stream)

Parameters

Name | Description
stream |

Applies to

SimpleProbeDatabase


Uncompensate

Uncompensate - method

Description

get the compemsate coordinates according the active sensor

Syntax in Visual Basic or VBScript

Uncompensate (ByRef pointOrVector As Variant)

Syntax in C++

HRESULT Uncompensate (VARIANT* pointOrVector)

Parameters

Name | Description
pointOrVector |

Applies to

SimpleProbeDatabase


ProbeDatabaseToolbox

ProbeDatabaseToolbox - object

Description

ProbeDatabaseToolbox

Interfaces

IProbeDatabaseToolbox

Methods of IProbeDatabaseToolbox

BuildProbeHeadEnvelope | Graphically build the envelope around a probe head ( start from the tool mounting point toward the quill ( upward )
BuildProbeToolGraphics | Graphically build a tool
CreateProbeHeadFromCatalogue | build up a probe head from the catalogue
CreateProbeRackFromCatalogue | build up a probe rack from the catalogue
CreateProbeToolFromAssemblyDefinition | create a probe from a assembly reference that exists in the ProbeCatalogue, assemblyDefinition can also be a XMLDocument containing the tag <AssemblyDefinition>
CreateSimpleStarProbe | create a coumpound tools with 5 simple touch trigger sensors
CreateTouchTriggerProbeWithOneSensor | create a simple touch trigger probe with a single spherical tip
FakeCalibrate |
FakeCalibrateTip |
GetProbeHeadKinematics | retrieve the probe head kinematics for as a XML iland string
PseudoCalibrateTip |
PseudoCalibrateTool |
ReconcileProbeTip |
SetProbeHeadOrientation |
SynchroniseDatabase | Copy all the tools from the source into the destination, avoiding duplicates. Copied tools will be uncalibrated in the destination.

Properties of IProbeDatabaseToolbox

CatalogueXMLPath | R/O | returns the path where all XML components related files are stored
CMMConfigurationPath | R/O | returns the path where all CMM Kinematics and related files are stored
ProbeHeadCatalogue | R/O | return the catalogue as a MSXMLDocumentObject
ProbePartCatalogue | R/O | Access the ProbePart Catalogue
UserCMMDefinitionPath | R/O | returns the path where the user store his own complete CMM Definition


CMMConfigurationPath

CMMConfigurationPath - Read property

Description

returns the path where all CMM Kinematics and related files are stored

Syntax in Visual Basic or VBScript

CMMConfigurationPath () As String

Syntax in C++

HRESULT get_CMMConfigurationPath (BSTR* retVal)

Applies to

ProbeDatabaseToolbox


ProbeHeadCatalogue

ProbeHeadCatalogue - Read property

Description

return the catalogue as a MSXMLDocumentObject

Syntax in Visual Basic or VBScript

ProbeHeadCatalogue () As IXMLDOMDocument

Syntax in C++

HRESULT get_ProbeHeadCatalogue (IXMLDOMDocument* retVal)

Applies to

ProbeDatabaseToolbox


ProbePartCatalogue

ProbePartCatalogue - Read property

Description

Access the ProbePart Catalogue

Syntax in Visual Basic or VBScript

ProbePartCatalogue () As IXMLDOMDocument

Syntax in C++

HRESULT get_ProbePartCatalogue (IXMLDOMDocument* retVal)

Applies to

ProbeDatabaseToolbox


UserCMMDefinitionPath

UserCMMDefinitionPath - Read property

Description

returns the path where the user store his own complete CMM Definition

Syntax in Visual Basic or VBScript

UserCMMDefinitionPath () As String

Syntax in C++

HRESULT get_UserCMMDefinitionPath (BSTR* retVal)

Applies to

ProbeDatabaseToolbox


BuildProbeHeadEnvelope

BuildProbeHeadEnvelope - method

Description

Graphically build the envelope around a probe head ( start from the tool mounting point toward the quill ( upward )

Syntax in Visual Basic or VBScript

BuildProbeHeadEnvelope (ByRef ProbeHead As IProbeHead , ByRef builderCallBack As ProbeStructureBuilder)

Syntax in C++

HRESULT BuildProbeHeadEnvelope (IProbeHead* ProbeHead , ProbeStructureBuilder* builderCallBack)

Parameters

Name | Description
ProbeHead |
builderCallBack |

Applies to

ProbeDatabaseToolbox


BuildProbeToolGraphics

BuildProbeToolGraphics - method

Description

Graphically build a tool

Syntax in Visual Basic or VBScript

BuildProbeToolGraphics (ByRef ProbeTool As ProbeTool , ByRef builderCallBack As ProbeStructureBuilder)

Syntax in C++

HRESULT BuildProbeToolGraphics (ProbeTool* ProbeTool , ProbeStructureBuilder* builderCallBack)

Parameters

Name | Description
ProbeTool |
builderCallBack |

Applies to

ProbeDatabaseToolbox


CreateProbeHeadFromCatalogue

CreateProbeHeadFromCatalogue - method

Description

build up a probe head from the catalogue

Syntax in Visual Basic or VBScript

CreateProbeHeadFromCatalogue (probeheadID As String) As IProbeHead

Syntax in C++

HRESULT CreateProbeHeadFromCatalogue (BSTR probeheadID , IProbeHead* retVal)

Parameters

Name | Description
probeheadID |
Return Value |

Applies to

ProbeDatabaseToolbox


CreateProbeRackFromCatalogue

CreateProbeRackFromCatalogue - method

Description

build up a probe rack from the catalogue

Syntax in Visual Basic or VBScript

CreateProbeRackFromCatalogue (proberackID As String) As ProbeRack

Syntax in C++

HRESULT CreateProbeRackFromCatalogue (BSTR proberackID , ProbeRack* retVal)

Parameters

Name | Description
proberackID |
Return Value |

Applies to

ProbeDatabaseToolbox


CreateProbeToolFromAssemblyDefinition

CreateProbeToolFromAssemblyDefinition - method

Description

create a probe from a assembly reference that exists in the ProbeCatalogue, assemblyDefinition can also be a XMLDocument containing the tag <AssemblyDefinition>

Syntax in Visual Basic or VBScript

CreateProbeToolFromAssemblyDefinition (assemblyDefinition As Variant) As ProbeTool

Syntax in C++

HRESULT CreateProbeToolFromAssemblyDefinition (VARIANT assemblyDefinition , ProbeTool* retVal)

Parameters

Name | Description
assemblyDefinition |
Return Value |

Applies to

ProbeDatabaseToolbox


CreateSimpleStarProbe

CreateSimpleStarProbe - method

Description

create a coumpound tools with 5 simple touch trigger sensors

Syntax in Visual Basic or VBScript

CreateSimpleStarProbe (UserName As String , lengthToJunction As Double , connectionSize As Double , mainSensorLength As Double , mainSensorDiameter As Double , starSensorLength As Double , starSensorDiameter As Double) As ProbeTool

Syntax in C++

HRESULT CreateSimpleStarProbe (BSTR UserName , double lengthToJunction , double connectionSize , double mainSensorLength , double mainSensorDiameter , double starSensorLength , double starSensorDiameter , ProbeTool* retVal)

Parameters

Name | Description
UserName |
lengthToJunction |
connectionSize |
mainSensorLength |
mainSensorDiameter |
starSensorLength |
starSensorDiameter |
Return Value |

Applies to

ProbeDatabaseToolbox


CreateTouchTriggerProbeWithOneSensor

CreateTouchTriggerProbeWithOneSensor - method

Description

create a simple touch trigger probe with a single spherical tip

Syntax in Visual Basic or VBScript

CreateTouchTriggerProbeWithOneSensor (UserName As String , length As Double , tipDiameter As Double) As ProbeTool

Syntax in C++

HRESULT CreateTouchTriggerProbeWithOneSensor (BSTR UserName , double length , double tipDiameter , ProbeTool* retVal)

Parameters

Name | Description
UserName |
length |
tipDiameter |
Return Value |

Applies to

ProbeDatabaseToolbox


FakeCalibrate

FakeCalibrate - method

Syntax in Visual Basic or VBScript

FakeCalibrate (ByRef calibratable_item As _ICalProbeDatabaseItem)

Syntax in C++

HRESULT FakeCalibrate (_ICalProbeDatabaseItem* calibratable_item)

Parameters

Name | Description
calibratable_item |

Applies to

ProbeDatabaseToolbox


FakeCalibrateTip

FakeCalibrateTip - method

Syntax in Visual Basic or VBScript

FakeCalibrateTip (ByRef calibratable_item As probeTip , Diameter As Double , length As Double , offset_X As Double , offset_Y As Double , offset_Z As Double)

Syntax in C++

HRESULT FakeCalibrateTip (probeTip* calibratable_item , double Diameter , double length , double offset_X , double offset_Y , double offset_Z)

Parameters

Name | Description
calibratable_item |
Diameter |
length |
offset_X |
offset_Y |
offset_Z |

Applies to

ProbeDatabaseToolbox


GetProbeHeadKinematics

GetProbeHeadKinematics - method

Description

retrieve the probe head kinematics for as a XML iland string

Syntax in Visual Basic or VBScript

GetProbeHeadKinematics (ByRef ProbeHead As IProbeHead) As String

Syntax in C++

HRESULT GetProbeHeadKinematics (IProbeHead* ProbeHead , BSTR* retVal)

Parameters

Name | Description
ProbeHead |
Return Value |

Applies to

ProbeDatabaseToolbox


PseudoCalibrateTip

PseudoCalibrateTip - method

Syntax in Visual Basic or VBScript

PseudoCalibrateTip (ByRef tool As probeTip)

Syntax in C++

HRESULT PseudoCalibrateTip (probeTip* tool)

Parameters

Name | Description
tool |

Applies to

ProbeDatabaseToolbox


PseudoCalibrateTool

PseudoCalibrateTool - method

Syntax in Visual Basic or VBScript

PseudoCalibrateTool (ByRef tool As ProbeTool)

Syntax in C++

HRESULT PseudoCalibrateTool (ProbeTool* tool)

Parameters

Name | Description
tool |

Applies to

ProbeDatabaseToolbox


ReconcileProbeTip

ReconcileProbeTip - method

Syntax in Visual Basic or VBScript

ReconcileProbeTip (ByRef pdb As ProbeDatabase , VCARD As String) As probeTip

Syntax in C++

HRESULT ReconcileProbeTip (ProbeDatabase* pdb , BSTR VCARD , probeTip* retVal)

Parameters

Name | Description
pdb |
VCARD |
Return Value |

Applies to

ProbeDatabaseToolbox


SetProbeHeadOrientation

SetProbeHeadOrientation - method

Syntax in Visual Basic or VBScript

SetProbeHeadOrientation (ByRef pProbeHead As IProbeHead , var_vX As Variant , var_vY As Variant)

Syntax in C++

HRESULT SetProbeHeadOrientation (IProbeHead* pProbeHead , VARIANT var_vX , VARIANT var_vY)

Parameters

Name | Description
pProbeHead |
var_vX |
var_vY |

Applies to

ProbeDatabaseToolbox


SynchroniseDatabase

SynchroniseDatabase - method

Description

Copy all the tools from the source into the destination, avoiding duplicates. Copied tools will be uncalibrated in the destination.

Syntax in Visual Basic or VBScript

SynchroniseDatabase (ByRef pdbSource As ProbeDatabase , ByRef pdbDestination As ProbeDatabase)

Syntax in C++

HRESULT SynchroniseDatabase (ProbeDatabase* pdbSource , ProbeDatabase* pdbDestination)

Parameters

Name | Description
pdbSource |
pdbDestination |

Applies to

ProbeDatabaseToolbox


ProbePath

ProbePath - object

Description

ProbePath Class

Interfaces

IProbePath

Events

BeforeDeleteItem | an item is about to be deleted from the ProbePath
OnAddItem | an item has been added to the ProbePath
OnGlobalChange | All elements of the probe path have changed
OnItemChange | an item has changed
OnItemDeleted | an item has been delete from the collection ( see BeforeDeleteItem)
OnItemPositionMeasured | method OnItemPositionMeasured
OnLockStateChanged | the lock state of the probe path items has changed

Methods of IProbePath

Clear | Clear and remove all elements in this probe path
CopyTo | copy the contents of this probe path into the specified one
FillArrayWithMeasuredCMMPoints |
GetActiveSensor | extract the active sensor at the current location or if not defined
GetCopy | create a copy the contents of this probe path into the specified one
Insert | method Insert
InsertBooleanParameter | Add a Float Parameter
InsertCompositeMeasureMove | Add an Composite Move to the probe path
InsertDynamicPositionalItem | Add a positional instruction to the probe Path, which is a defined
InsertFloatParameter | Add a Float Parameter
InsertMachineConfiguration | Insert a machine-configuration item into the probe-path.
InsertParameter | Add a Parameter
InsertPositionalItem | Add a positional instruction to the probe Path
InsertProbeAutoOrientation | Add a probe orientation change,instruct the probe to rotate so that the current active tip is along the specified vector
InsertProbePath | append the content of other ProbePath to this one at the specified location
InsertProbeSensorDefinition | Add a probe sensor definition/recall in the probe path
InsertScanCommand | Insert a scan instruction into the probe-path.
InvalidateMeasures | Clear all recorded CMMPoints on items
LockEdit |
LockUnit | Prevent other clients of the object from changing the units.
Remove | Remove a probe path item at the specified position
Scale | scale the probe path ( note : units are not changed
TransformFrom | Transformation of points
TransformTo | Transformation of points
UnlockEdit |
UnlockUnit | Remove existing unit lock, if any from the object.
XMLOutput | Get probe path in XML format

Properties of IProbePath

ContainsMultiaxisConfiguration | R/O | Does the probe-path contain machine configurations?
CustomData | R/W |
DelayNotifications | R/W |
DMIS | R/O | DMIS
IsEditLocked | R/O |
IsUnitLocked | R/O | Test whethee the units are currently locked.
MeasurementState | R/O |
NumberOfMeasurableItem | R/O |
NumberOfMeasuredItem | R/O |
PathType | R/W |
StrategyType | R/W |
units | R/W | sets/retrieves the unit of the probe path ( only mm or in or empty string)

Collections of IProbePath

Items | property Items
ProbingParameters | returns a collection of parameters than can be used by a object that knows how to generate this probe path


ContainsMultiaxisConfiguration

ContainsMultiaxisConfiguration - Read property

Description

Does the probe-path contain machine configurations?

Syntax in Visual Basic or VBScript

ContainsMultiaxisConfiguration () As Boolean

Syntax in C++

HRESULT get_ContainsMultiaxisConfiguration (VARIANT_BOOL* retVal)

Applies to

ProbePath


CustomData

CustomData - Read & Write property

Syntax in Visual Basic or VBScript

CustomData () As Variant

Syntax in C++

HRESULT get_CustomData (VARIANT* retVal)
HRESULT put_CustomData (VARIANT Value)

Applies to

ProbePath


DelayNotifications

DelayNotifications - Read & Write property

Syntax in Visual Basic or VBScript

DelayNotifications () As Boolean

Syntax in C++

HRESULT get_DelayNotifications (VARIANT_BOOL* retVal)
HRESULT put_DelayNotifications (VARIANT_BOOL Value)

Applies to

ProbePath


DMIS

DMIS - Read property

Description

DMIS

Syntax in Visual Basic or VBScript

DMIS () As String

Syntax in C++

HRESULT get_DMIS (BSTR* retVal)

Applies to

ProbePath
ProbePathDynamicPosition
IProbePathItem
ProbePathItemActiveMove
ProbePathItemCNCParameter
ProbePathMachineConfiguration
ProbePathPositionalItem
ProbePathScanItem


IsEditLocked

IsEditLocked - Read property

Syntax in Visual Basic or VBScript

IsEditLocked () As Boolean

Syntax in C++

HRESULT get_IsEditLocked (VARIANT_BOOL* retVal)

Applies to

ProbePath


IsUnitLocked

IsUnitLocked - Read property

Description

Test whethee the units are currently locked.

Syntax in Visual Basic or VBScript

IsUnitLocked () As Boolean

Syntax in C++

HRESULT get_IsUnitLocked (VARIANT_BOOL* retVal)

Applies to

ProbePath


MeasurementState

MeasurementState - Read property

Syntax in Visual Basic or VBScript

MeasurementState () As ValidMeasureState

Syntax in C++

HRESULT get_MeasurementState (ValidMeasureState* retVal)

Applies to

ProbePath


NumberOfMeasurableItem

NumberOfMeasurableItem - Read property

Syntax in Visual Basic or VBScript

NumberOfMeasurableItem () As Long

Syntax in C++

HRESULT get_NumberOfMeasurableItem (LONG* retVal)

Applies to

ProbePath


NumberOfMeasuredItem

NumberOfMeasuredItem - Read property

Syntax in Visual Basic or VBScript

NumberOfMeasuredItem () As Long

Syntax in C++

HRESULT get_NumberOfMeasuredItem (LONG* retVal)

Applies to

ProbePath


PathType

PathType - Read & Write property

Syntax in Visual Basic or VBScript

PathType () As ProbePathType

Syntax in C++

HRESULT get_PathType (ProbePathType* retVal)
HRESULT put_PathType (ProbePathType Value)

Applies to

ProbePath


StrategyType

StrategyType - Read & Write property

Syntax in Visual Basic or VBScript

StrategyType () As ProbePathStrategyType

Syntax in C++

HRESULT get_StrategyType (ProbePathStrategyType* retVal)
HRESULT put_StrategyType (ProbePathStrategyType Value)

Applies to

ProbePath


units

units - Read & Write property

Description

sets/retrieves the unit of the probe path ( only mm or in or empty string)

Syntax in Visual Basic or VBScript

units () As String

Syntax in C++

HRESULT get_units (BSTR* retVal)
HRESULT put_units (BSTR Value)

Applies to

ProbePath


BeforeDeleteItem

BeforeDeleteItem - event

Description

an item is about to be deleted from the ProbePath

Syntax in Visual Basic or VBScript

BeforeDeleteItem (pos As Integer , ByRef pItem As IProbePathItem)

Syntax in C++

HRESULT BeforeDeleteItem (INT pos , IProbePathItem* pItem)

Parameters

Name | Description
pos |
pItem |

Applies to

ProbePath


Clear

Clear - method

Description

Clear and remove all elements in this probe path

Syntax in Visual Basic or VBScript

Clear ()

Syntax in C++

HRESULT Clear ()

Applies to

ProbePath


CopyTo

CopyTo - method

Description

copy the contents of this probe path into the specified one

Syntax in Visual Basic or VBScript

CopyTo (ByRef pdest As ProbePath , copyMeasures As Boolean)

Syntax in C++

HRESULT CopyTo (ProbePath* pdest , VARIANT_BOOL copyMeasures)

Parameters

Name | Description
pdest |
copyMeasures |

Applies to

ProbePath


FillArrayWithMeasuredCMMPoints

FillArrayWithMeasuredCMMPoints - method

Syntax in Visual Basic or VBScript

FillArrayWithMeasuredCMMPoints (ByRef retval As Variant)

Syntax in C++

HRESULT FillArrayWithMeasuredCMMPoints (VARIANT* retval)

Parameters

Name | Description
retval |

Applies to

ProbePath


GetActiveSensor

GetActiveSensor - method

Description

extract the active sensor at the current location or if not defined

Syntax in Visual Basic or VBScript

GetActiveSensor (cursor As Long , ByRef strSensorName As String , ByRef strSensorIDCard As String)

Syntax in C++

HRESULT GetActiveSensor (LONG cursor , BSTR* strSensorName , BSTR* strSensorIDCard)

Parameters

Name | Description
cursor |
strSensorName |
strSensorIDCard |

Applies to

ProbePath


GetCopy

GetCopy - method

Description

create a copy the contents of this probe path into the specified one

Syntax in Visual Basic or VBScript

GetCopy (copyMeasures As Boolean) As ProbePath

Syntax in C++

HRESULT GetCopy (VARIANT_BOOL copyMeasures , ProbePath* retVal)

Parameters

Name | Description
copyMeasures |
Return Value |

Applies to

ProbePath


Insert

Insert - method

Description

method Insert

Syntax in Visual Basic or VBScript

Insert (type As ProbeItemType , atPos As Long) As IProbePathItem

Syntax in C++

HRESULT Insert (ProbeItemType type , LONG atPos , IProbePathItem* retVal)

Parameters

Name | Description
type |
atPos |
Return Value |

Applies to

ProbePath


InsertBooleanParameter

InsertBooleanParameter - method

Description

Add a Float Parameter

Syntax in Visual Basic or VBScript

InsertBooleanParameter (Name As String , Value As Boolean , atPos As Long) As ProbePathItemCNCParameter

Syntax in C++

HRESULT InsertBooleanParameter (BSTR Name , VARIANT_BOOL Value , LONG atPos , ProbePathItemCNCParameter* retVal)

Parameters

Name | Description
Name |
Value |
atPos |
Return Value |

Applies to

ProbePath


InsertCompositeMeasureMove

InsertCompositeMeasureMove - method

Description

Add an Composite Move to the probe path

Syntax in Visual Basic or VBScript

InsertCompositeMeasureMove (targetX As Double , targetY As Double , targetZ As Double , approachI As Double , approachJ As Double , approachK As Double , atPos As Long) As ProbePathItemActiveMove

Syntax in C++

HRESULT InsertCompositeMeasureMove (double targetX , double targetY , double targetZ , double approachI , double approachJ , double approachK , LONG atPos , ProbePathItemActiveMove* retVal)

Parameters

Name | Description
targetX |
targetY |
targetZ |
approachI |
approachJ |
approachK |
atPos |
Return Value |

Applies to

ProbePath


InsertDynamicPositionalItem

InsertDynamicPositionalItem - method

Description

Add a positional instruction to the probe Path, which is a defined

Syntax in Visual Basic or VBScript

InsertDynamicPositionalItem (surfPoint_X As Double , surfPoint_Y As Double , surfPoint_Z As Double , PointType As PointType , outerMaterialDirection_I As Double , outerMaterialDirection_J As Double , outerMaterialDirection_K As Double , distance As Double , type As ProbePositionalItemType , atPos As Long) As ProbePathDynamicPosition

Syntax in C++

HRESULT InsertDynamicPositionalItem (double surfPoint_X , double surfPoint_Y , double surfPoint_Z , PointType PointType , double outerMaterialDirection_I , double outerMaterialDirection_J , double outerMaterialDirection_K , double distance , ProbePositionalItemType type , LONG atPos , ProbePathDynamicPosition* retVal)

Parameters

Name | Description
surfPoint_X |
surfPoint_Y |
surfPoint_Z |
PointType |
outerMaterialDirection_I |
outerMaterialDirection_J |
outerMaterialDirection_K |
distance |
type |
atPos |
Return Value |

Applies to

ProbePath


InsertFloatParameter

InsertFloatParameter - method

Description

Add a Float Parameter

Syntax in Visual Basic or VBScript

InsertFloatParameter (Name As String , Value As Double , units As String , atPos As Long) As ProbePathItemCNCParameter

Syntax in C++

HRESULT InsertFloatParameter (BSTR Name , double Value , BSTR units , LONG atPos , ProbePathItemCNCParameter* retVal)

Parameters

Name | Description
Name |
Value |
units |
atPos |
Return Value |

Applies to

ProbePath


InsertMachineConfiguration

InsertMachineConfiguration - method

Description

Insert a machine-configuration item into the probe-path.

Syntax in Visual Basic or VBScript

InsertMachineConfiguration (creator_type As MachineConfigurationCreatorType , pos As Long) As ProbePathMachineConfiguration

Syntax in C++

HRESULT InsertMachineConfiguration (MachineConfigurationCreatorType creator_type , LONG pos , ProbePathMachineConfiguration* retVal)

Parameters

Name | Description
creator_type |
pos |
Return Value |

Applies to

ProbePath


InsertParameter

InsertParameter - method

Description

Add a Parameter

Syntax in Visual Basic or VBScript

InsertParameter (Name As String , parameterVCARD As Variant , atPos As Long) As ProbePathItemCNCParameter

Syntax in C++

HRESULT InsertParameter (BSTR Name , VARIANT parameterVCARD , LONG atPos , ProbePathItemCNCParameter* retVal)

Parameters

Name | Description
Name |
parameterVCARD |
atPos |
Return Value |

Applies to

ProbePath


InsertPositionalItem

InsertPositionalItem - method

Description

Add a positional instruction to the probe Path

Syntax in Visual Basic or VBScript

InsertPositionalItem (X As Double , Y As Double , Z As Double , type As ProbePositionalItemType , CoordType As ProbePositionalCoordType , atPos As Long) As ProbePathPositionalItem

Syntax in C++

HRESULT InsertPositionalItem (double X , double Y , double Z , ProbePositionalItemType type , ProbePositionalCoordType CoordType , LONG atPos , ProbePathPositionalItem* retVal)

Parameters

Name | Description
X |
Y |
Z |
type |
CoordType |
atPos |
Return Value |

Applies to

ProbePath


InsertProbeAutoOrientation

InsertProbeAutoOrientation - method

Description

Add a probe orientation change,instruct the probe to rotate so that the current active tip is along the specified vector

Syntax in Visual Basic or VBScript

InsertProbeAutoOrientation (I As Double , J As Double , K As Double , atPos As Long) As ProbePathItemCNCParameter

Syntax in C++

HRESULT InsertProbeAutoOrientation (double I , double J , double K , LONG atPos , ProbePathItemCNCParameter* retVal)

Parameters

Name | Description
I |
J |
K |
atPos |
Return Value |

Applies to

ProbePath


InsertProbePath

InsertProbePath - method

Description

append the content of other ProbePath to this one at the specified location

Syntax in Visual Basic or VBScript

InsertProbePath (ByRef pSrc As ProbePath , atPos As Long)

Syntax in C++

HRESULT InsertProbePath (ProbePath* pSrc , LONG atPos)

Parameters

Name | Description
pSrc |
atPos |

Applies to

ProbePath


InsertProbeSensorDefinition

InsertProbeSensorDefinition - method

Description

Add a probe sensor definition/recall in the probe path

Syntax in Visual Basic or VBScript

InsertProbeSensorDefinition (tipName As String , tipVCard As String , atPos As Long) As ProbePathItemCNCParameter

Syntax in C++

HRESULT InsertProbeSensorDefinition (BSTR tipName , BSTR tipVCard , LONG atPos , ProbePathItemCNCParameter* retVal)

Parameters

Name | Description
tipName |
tipVCard |
atPos |
Return Value |

Applies to

ProbePath


InsertScanCommand

InsertScanCommand - method

Description

Insert a scan instruction into the probe-path.

Syntax in Visual Basic or VBScript

InsertScanCommand (scan_command_type As ScanInstructionType , pos As Long) As ProbePathScanItem

Syntax in C++

HRESULT InsertScanCommand (ScanInstructionType scan_command_type , LONG pos , ProbePathScanItem* retVal)

Parameters

Name | Description
scan_command_type |
pos |
Return Value |

Applies to

ProbePath


InvalidateMeasures

InvalidateMeasures - method

Description

Clear all recorded CMMPoints on items

Syntax in Visual Basic or VBScript

InvalidateMeasures ()

Syntax in C++

HRESULT InvalidateMeasures ()

Applies to

ProbePath


LockEdit

LockEdit - method

Syntax in Visual Basic or VBScript

LockEdit (cookie As Long)

Syntax in C++

HRESULT LockEdit (LONG cookie)

Parameters

Name | Description
cookie |

Applies to

ProbePath


LockUnit

LockUnit - method

Description

Prevent other clients of the object from changing the units.

Syntax in Visual Basic or VBScript

LockUnit (cookie As Long)

Syntax in C++

HRESULT LockUnit (LONG cookie)

Parameters

Name | Description
cookie |

Applies to

ProbePath


OnAddItem

OnAddItem - event

Description

an item has been added to the ProbePath

Syntax in Visual Basic or VBScript

OnAddItem (pos As Integer , ByRef pItem As IProbePathItem)

Syntax in C++

HRESULT OnAddItem (INT pos , IProbePathItem* pItem)

Parameters

Name | Description
pos |
pItem |

Applies to

ProbePath


OnGlobalChange

OnGlobalChange - event

Description

All elements of the probe path have changed

Syntax in Visual Basic or VBScript

OnGlobalChange ()

Syntax in C++

HRESULT OnGlobalChange ()

Applies to

ProbePath


OnItemChange

OnItemChange - event

Description

an item has changed

Syntax in Visual Basic or VBScript

OnItemChange (pos As Integer , ByRef pItem As IProbePathItem)

Syntax in C++

HRESULT OnItemChange (INT pos , IProbePathItem* pItem)

Parameters

Name | Description
pos |
pItem |

Applies to

ProbePath


OnItemDeleted

OnItemDeleted - event

Description

an item has been delete from the collection ( see BeforeDeleteItem)

Syntax in Visual Basic or VBScript

OnItemDeleted ()

Syntax in C++

HRESULT OnItemDeleted ()

Applies to

ProbePath


OnItemPositionMeasured

OnItemPositionMeasured - event

Description

method OnItemPositionMeasured

Syntax in Visual Basic or VBScript

OnItemPositionMeasured (pos As Integer , ByRef pItem As IProbePathItem)

Syntax in C++

HRESULT OnItemPositionMeasured (INT pos , IProbePathItem* pItem)

Parameters

Name | Description
pos |
pItem |

Applies to

ProbePath


OnLockStateChanged

OnLockStateChanged - event

Description

the lock state of the probe path items has changed

Syntax in Visual Basic or VBScript

OnLockStateChanged (isLocked As Boolean)

Syntax in C++

HRESULT OnLockStateChanged (VARIANT_BOOL isLocked)

Parameters

Name | Description
isLocked |

Applies to

ProbePath


Remove

Remove - method

Description

Remove a probe path item at the specified position

Syntax in Visual Basic or VBScript

Remove (atPos As Long)

Syntax in C++

HRESULT Remove (LONG atPos)

Parameters

Name | Description
atPos |

Applies to

ProbePath


Scale

Scale - method

Description

scale the probe path ( note : units are not changed

Syntax in Visual Basic or VBScript

Scale (factor As Double)

Syntax in C++

HRESULT Scale (double factor)

Parameters

Name | Description
factor |

Applies to

ProbePath


TransformFrom

TransformFrom - method

Description

Transformation of points

Syntax in Visual Basic or VBScript

TransformFrom (ByRef transform As transform)

Syntax in C++

HRESULT TransformFrom (transform* transform)

Parameters

Name | Description
transform |

Applies to

Vector3D


TransformTo

TransformTo - method

Description

Transformation of points

Syntax in Visual Basic or VBScript

TransformTo (ByRef transform As transform)

Syntax in C++

HRESULT TransformTo (transform* transform)

Parameters

Name | Description
transform |

Applies to

Vector3D


UnlockEdit

UnlockEdit - method

Syntax in Visual Basic or VBScript

UnlockEdit (cookie As Long)

Syntax in C++

HRESULT UnlockEdit (LONG cookie)

Parameters

Name | Description
cookie |

Applies to

ProbePath


UnlockUnit

UnlockUnit - method

Description

Remove existing unit lock, if any from the object.

Syntax in Visual Basic or VBScript

UnlockUnit (cookie As Long)

Syntax in C++

HRESULT UnlockUnit (LONG cookie)

Parameters

Name | Description
cookie |

Applies to

ProbePath


XMLOutput

XMLOutput - method

Description

Get probe path in XML format

Syntax in Visual Basic or VBScript

XMLOutput (pNode As Object)

Syntax in C++

HRESULT XMLOutput (IDispatch* pNode)

Parameters

Name | Description
pNode |

Applies to

ProbePath


Items

Items - Read property

Description

property Items

Syntax in Visual Basic or VBScript

Items () As ProbePathItems

Syntax in C++

HRESULT get_Items (ProbePathItems* retVal)

Applies to

ProbePath


ProbingParameters

ProbingParameters - Read property

Description

returns a collection of parameters than can be used by a object that knows how to generate this probe path

Syntax in Visual Basic or VBScript

ProbingParameters () As CMMParameters

Syntax in C++

HRESULT get_ProbingParameters (CMMParameters* retVal)

Applies to

ProbePath


ProbePathCXMOutputter

ProbePathCXMOutputter - object

Description

ProbePathCXMOutputter Class

Interfaces

IProbePathCXMOutputter

Methods of IProbePathCXMOutputter

Append | Appends the given probe path to output.
AppendComment | Appends the given string as a comment.
AppendMOWorkplane | Appends a machine-orientation workplane definition to the output
AppendWithName | Appends the given probe path to output and marks it as belonging to a sequence item with the given name.
AppendWorkplane | Appends workplane definition to the output
Save | Saves the generated CXM file to a file on the disk.
SaveToXML | Dumps the generated CXM to the given XMLDocument object.
SetOrientationPointName | Set the current orientation point name.

Properties of IProbePathCXMOutputter

CADBoundingBox | R/W | Allows to get/set the CAD bounding box, it is used in the FromPoint coordinates calculation
FromPoint | R/O | Allows to get/set the starting point coordinates (so called From Point)
OutputPoint | R/W | Get/Put the type of outputted point coordinates
OutputTransform | R/W | The transformation that will be applied to all output coordinates
OutputWorkplaneName | R/W | The output workplane name
PartName | R/W | Allows to get/set the NC program part name
SafeMoveDirection | R/O | Allows to get/set the safe move direction
SafeMoveDistance | R/W | Allows to get/set the safe move distance
ToolNumber | R/W | Allows to get/set the tool number
WCSNumber | R/W | Allows to get/set the Workpiece coordinate system number


CADBoundingBox

CADBoundingBox - Read & Write property

Description

Allows to get/set the CAD bounding box, it is used in the FromPoint coordinates calculation

Syntax in Visual Basic or VBScript

CADBoundingBox () As BoundingBox

Syntax in C++

HRESULT get_CADBoundingBox (BoundingBox* retVal)
HRESULT put_CADBoundingBox (BoundingBox* Value)

Applies to

ProbePathCXMOutputter


FromPoint

FromPoint - Read property

Description

Allows to get/set the starting point coordinates (so called From Point)

Syntax in Visual Basic or VBScript

FromPoint () As Point3D

Syntax in C++

HRESULT get_FromPoint (Point3D* retVal)

Applies to

ProbePathCXMOutputter


OutputPoint

OutputPoint - Read & Write property

Description

Get/Put the type of outputted point coordinates

Syntax in Visual Basic or VBScript

OutputPoint () As OutputPointType

Syntax in C++

HRESULT get_OutputPoint (OutputPointType* retVal)
HRESULT put_OutputPoint (OutputPointType Value)

Applies to

ProbePathCXMOutputter


OutputWorkplaneName

OutputWorkplaneName - Read & Write property

Description

The output workplane name

Syntax in Visual Basic or VBScript

OutputWorkplaneName () As String

Syntax in C++

HRESULT get_OutputWorkplaneName (BSTR* retVal)
HRESULT put_OutputWorkplaneName (BSTR Value)

Applies to

ProbePathCXMOutputter


PartName

PartName - Read & Write property

Description

Allows to get/set the NC program part name

Syntax in Visual Basic or VBScript

PartName () As String

Syntax in C++

HRESULT get_PartName (BSTR* retVal)
HRESULT put_PartName (BSTR Value)

Applies to

ProbePathCXMOutputter


SafeMoveDirection

SafeMoveDirection - Read property

Description

Allows to get/set the safe move direction

Syntax in Visual Basic or VBScript

SafeMoveDirection () As UnitVector3D

Syntax in C++

HRESULT get_SafeMoveDirection (UnitVector3D* retVal)

Applies to

ProbePathCXMOutputter


SafeMoveDistance

SafeMoveDistance - Read & Write property

Description

Allows to get/set the safe move distance

Syntax in Visual Basic or VBScript

SafeMoveDistance () As Double

Syntax in C++

HRESULT get_SafeMoveDistance (double* retVal)
HRESULT put_SafeMoveDistance (double Value)

Applies to

ProbePathCXMOutputter


ToolNumber

ToolNumber - Read & Write property

Description

Allows to get/set the tool number

Syntax in Visual Basic or VBScript

ToolNumber () As Long

Syntax in C++

HRESULT get_ToolNumber (LONG* retVal)
HRESULT put_ToolNumber (LONG Value)

Applies to

ProbePathCXMOutputter


WCSNumber

WCSNumber - Read & Write property

Description

Allows to get/set the Workpiece coordinate system number

Syntax in Visual Basic or VBScript

WCSNumber () As Long

Syntax in C++

HRESULT get_WCSNumber (LONG* retVal)
HRESULT put_WCSNumber (LONG Value)

Applies to

ProbePathCXMOutputter


Append

Append - method

Description

Appends the given probe path to output.

Syntax in Visual Basic or VBScript

Append (ByRef a_probe_path As ProbePath)

Syntax in C++

HRESULT Append (ProbePath* a_probe_path)

Parameters

Name | Description
a_probe_path |

Applies to

ProbePathCXMOutputter


AppendComment

AppendComment - method

Description

Appends the given string as a comment.

Syntax in Visual Basic or VBScript

AppendComment (a_comment As String)

Syntax in C++

HRESULT AppendComment (BSTR a_comment)

Parameters

Name | Description
a_comment |

Applies to

ProbePathCXMOutputter


AppendMOWorkplane

AppendMOWorkplane - method

Description

Appends a machine-orientation workplane definition to the output

Syntax in Visual Basic or VBScript

AppendMOWorkplane (ByRef machine_orientation As MachineOrientationData , creator_type As MachineConfigurationCreatorType)

Syntax in C++

HRESULT AppendMOWorkplane (MachineOrientationData* machine_orientation , MachineConfigurationCreatorType creator_type)

Parameters

Name | Description
machine_orientation |
creator_type |

Applies to

ProbePathCXMOutputter


AppendWithName

AppendWithName - method

Description

Appends the given probe path to output and marks it as belonging to a sequence item with the given name.

Syntax in Visual Basic or VBScript

AppendWithName (a_short_name As String , a_name As String , ByRef a_comment As String , ByRef a_probe_path As ProbePath)

Syntax in C++

HRESULT AppendWithName (BSTR a_short_name , BSTR a_name , BSTR* a_comment , ProbePath* a_probe_path)

Parameters

Name | Description
a_short_name |
a_name |
a_comment |
a_probe_path |

Applies to

ProbePathCXMOutputter


AppendWorkplane

AppendWorkplane - method

Description

Appends workplane definition to the output

Syntax in Visual Basic or VBScript

AppendWorkplane (ByRef a_transform As transform , a_name As String)

Syntax in C++

HRESULT AppendWorkplane (transform* a_transform , BSTR a_name)

Parameters

Name | Description
a_transform |
a_name |

Applies to

ProbePathCXMOutputter


Save

Save - method

Description

Saves the generated CXM file to a file on the disk.

Syntax in Visual Basic or VBScript

Save (a_filename As String)

Syntax in C++

HRESULT Save (BSTR a_filename)

Parameters

Name | Description
a_filename |

Applies to

ProbePathCXMOutputter


SaveToXML

SaveToXML - method

Description

Dumps the generated CXM to the given XMLDocument object.

Syntax in Visual Basic or VBScript

SaveToXML (a_node_or_document As Object)

Syntax in C++

HRESULT SaveToXML (IDispatch* a_node_or_document)

Parameters

Name | Description
a_node_or_document |

Applies to

ProbePathCXMOutputter


SetOrientationPointName

SetOrientationPointName - method

Description

Set the current orientation point name.

Syntax in Visual Basic or VBScript

SetOrientationPointName (orientation_point_name As String)

Syntax in C++

HRESULT SetOrientationPointName (BSTR orientation_point_name)

Parameters

Name | Description
orientation_point_name |

Applies to

ProbePathCXMOutputter


ProbePathDynamicPosition

ProbePathDynamicPosition - object

Description

ProbePathDynamicPosition Class

Interfaces

IProbePathDynamicPosition

Methods of IProbePathDynamicPosition

RecordMeasuredPositionAndVector | use to record the measure point ( only valid for MEASURE_TO COMPOSITE_MEASURE_MOVE )
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties of IProbePathDynamicPosition

AbsolutePosition | R/W | property AbsolutePosition: returns/sets the absolute coordinates of the targeted position of the probe center.Note setting the absolute position doesn;t aloter the CoordType property
ApproachVector | R/W | property ApproachVector
CoordType | R/W | property CoordType
DefinitionType | R/W | sets/returns the item defition type
DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
MeasuredCMMPoint | R/O | property MeasuredPoint
Offset | R/W | property Offset
OuterMaterialDirection | R/W | property OuterMaterialDirection
PointType | R/W | property PointType
Position | R/W | property Position: returns/sets the position of the probe center at the expected contact point.The position is either as an increment or a absolute position, depending of the CoordType value
PositionalItemType | R/W | property Type
PreviousAbsolutePosition | R/O | (property PreviousAbsolutePosition, The theorical absolute position of the probe before this move is executed
ProbePath | R/O | returns the parent probe path
SurfacePoint | R/W | property SurfacePoint
ValidMeasure | R/W | return TRUE is the held measured is valid


AbsolutePosition

AbsolutePosition - Read & Write property

Description

property AbsolutePosition: returns/sets the absolute coordinates of the targeted position of the probe center.Note setting the absolute position doesn;t aloter the CoordType property

Syntax in Visual Basic or VBScript

AbsolutePosition () As Point3D

Syntax in C++

HRESULT get_AbsolutePosition (Point3D* retVal)
HRESULT put_AbsolutePosition (VARIANT Value)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove
ProbePathPositionalItem


ApproachVector

ApproachVector - Read & Write property

Description

property ApproachVector

Syntax in Visual Basic or VBScript

ApproachVector () As UnitVector3D

Syntax in C++

HRESULT get_ApproachVector (UnitVector3D* retVal)
HRESULT put_ApproachVector (VARIANT Value)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove


CoordType

CoordType - Read & Write property

Description

property CoordType

Syntax in Visual Basic or VBScript

CoordType () As ProbePositionalCoordType

Syntax in C++

HRESULT get_CoordType (ProbePositionalCoordType* retVal)
HRESULT put_CoordType (ProbePositionalCoordType Value)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove
ProbePathPositionalItem


DefinitionType

DefinitionType - Read & Write property

Description

sets/returns the item defition type

Syntax in Visual Basic or VBScript

DefinitionType () As ItemDefinitionType

Syntax in C++

HRESULT get_DefinitionType (ItemDefinitionType* retVal)
HRESULT put_DefinitionType (ItemDefinitionType Value)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove
ProbePathPositionalItem


Index

Index - Read property

Description

Index

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

ProbePathDynamicPosition
IProbePathItem
ProbePathItemActiveMove
ProbePathItemCNCParameter
ProbePathMachineConfiguration
ProbePathPositionalItem
ProbePathScanItem


ItemType

ItemType - Read property

Description

ItemType

Syntax in Visual Basic or VBScript

ItemType () As ProbeItemType

Syntax in C++

HRESULT get_ItemType (ProbeItemType* retVal)

Applies to

ProbePathDynamicPosition
IProbePathItem
ProbePathItemActiveMove
ProbePathItemCNCParameter
ProbePathMachineConfiguration
ProbePathPositionalItem
ProbePathScanItem


MagicNumber

MagicNumber - Read property

Syntax in Visual Basic or VBScript

MagicNumber (ByRef pVal As Integer)

Syntax in C++

HRESULT get_MagicNumber (BYTE* pVal)

Applies to

ProbePathDynamicPosition
IProbePathItem
ProbePathItemActiveMove
ProbePathItemCNCParameter
ProbePathMachineConfiguration
ProbePathPositionalItem
ProbePathScanItem


MeasuredCMMPoint

MeasuredCMMPoint - Read property

Description

property MeasuredPoint

Syntax in Visual Basic or VBScript

MeasuredCMMPoint () As CMMPoint

Syntax in C++

HRESULT get_MeasuredCMMPoint (CMMPoint* retVal)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove
ProbePathPositionalItem


Offset

Offset - Read & Write property

Description

property Offset

Syntax in Visual Basic or VBScript

Offset () As Double

Syntax in C++

HRESULT get_Offset (double* retVal)
HRESULT put_Offset (double Value)

Applies to

PointCloud
ProbePathDynamicPosition


OuterMaterialDirection

OuterMaterialDirection - Read & Write property

Description

property OuterMaterialDirection

Syntax in Visual Basic or VBScript

OuterMaterialDirection () As UnitVector3D

Syntax in C++

HRESULT get_OuterMaterialDirection (UnitVector3D* retVal)
HRESULT put_OuterMaterialDirection (VARIANT Value)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove


PointType

PointType - Read & Write property

Description

property PointType

Syntax in Visual Basic or VBScript

PointType () As PointType

Syntax in C++

HRESULT get_PointType (PointType* retVal)
HRESULT put_PointType (PointType Value)

Applies to

ProbePathDynamicPosition


Position

Position - Read & Write property

Description

property Position: returns/sets the position of the probe center at the expected contact point.The position is either as an increment or a absolute position, depending of the CoordType value

Syntax in Visual Basic or VBScript

Position () As Point3D

Syntax in C++

HRESULT get_Position (Point3D* retVal)
HRESULT put_Position (VARIANT Value)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove
ProbePathPositionalItem


PositionalItemType

PositionalItemType - Read & Write property

Description

property Type

Syntax in Visual Basic or VBScript

PositionalItemType () As ProbePositionalItemType

Syntax in C++

HRESULT get_PositionalItemType (ProbePositionalItemType* retVal)
HRESULT put_PositionalItemType (ProbePositionalItemType Value)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove
ProbePathPositionalItem


PreviousAbsolutePosition

PreviousAbsolutePosition - Read property

Description

(property PreviousAbsolutePosition, The theorical absolute position of the probe before this move is executed

Syntax in Visual Basic or VBScript

PreviousAbsolutePosition () As Point3D

Syntax in C++

HRESULT get_PreviousAbsolutePosition (Point3D* retVal)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove
ProbePathPositionalItem


ProbePath

ProbePath - Read property

Description

returns the parent probe path

Syntax in Visual Basic or VBScript

ProbePath () As ProbePath

Syntax in C++

HRESULT get_ProbePath (ProbePath* retVal)

Applies to

ProbePathDynamicPosition
IProbePathItem
ProbePathItemActiveMove
ProbePathItemCNCParameter
ProbePathMachineConfiguration
ProbePathPositionalItem
ProbePathScanItem


SurfacePoint

SurfacePoint - Read & Write property

Description

property SurfacePoint

Syntax in Visual Basic or VBScript

SurfacePoint () As Point3D

Syntax in C++

HRESULT get_SurfacePoint (Point3D* retVal)
HRESULT put_SurfacePoint (VARIANT Value)

Applies to

ProbePathDynamicPosition


ValidMeasure

ValidMeasure - Read & Write property

Description

return TRUE is the held measured is valid

Syntax in Visual Basic or VBScript

ValidMeasure () As Boolean

Syntax in C++

HRESULT get_ValidMeasure (VARIANT_BOOL* retVal)
HRESULT put_ValidMeasure (VARIANT_BOOL Value)

Applies to

ProbePathDynamicPosition
ProbePathItemActiveMove
ProbePathPositionalItem


RecordMeasuredPositionAndVector

RecordMeasuredPositionAndVector - method

Description

use to record the measure point ( only valid for MEASURE_TO COMPOSITE_MEASURE_MOVE )

Syntax in Visual Basic or VBScript

RecordMeasuredPositionAndVector (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double , probe_diameter As Double)

Syntax in C++

HRESULT RecordMeasuredPositionAndVector (double X , double Y , double Z , double I , double J , double K , double probe_diameter)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |
probe_diameter |

Applies to

ProbePathPositionalItem


ProbePathEditor

ProbePathEditor - object

Interfaces

IProbePathEditor

Events

OnStatusChanged indicates that the state of the ProbePathEditor has changed

Methods of IProbePathEditor

Cancel | exit the EDIT mode and revert back to the previous probe path
Commit | commit the current probe path and remain in Edit mode
Edit | enter the EDIT mode

Properties of IProbePathEditor

Behavior | R/W | set/retrieve the editor behavior
CallBackObject | R/W | Set the call back object
Mode | R/O | sets/retrieves the probe path editor mode
ProbePath | R/W | sets/retrieves the probe path to edit


Behavior

Behavior - Read & Write property

Description

set/retrieve the editor behavior

Syntax in Visual Basic or VBScript

Behavior () As ProbePathEditorBehavior

Syntax in C++

HRESULT get_Behavior (ProbePathEditorBehavior* retVal)
HRESULT put_Behavior (ProbePathEditorBehavior Value)

Applies to

ProbePathEditor


CallBackObject

CallBackObject - Read & Write property

Description

Set the call back object

Syntax in Visual Basic or VBScript

CallBackObject () As IProbePathEditorCallBack

Syntax in C++

HRESULT get_CallBackObject (IProbePathEditorCallBack* retVal)
HRESULT put_CallBackObject (IProbePathEditorCallBack* Value)

Applies to

ProbePathEditor


Mode

Mode - Read property

Description

sets/retrieves the probe path editor mode

Syntax in Visual Basic or VBScript

Mode () As ProbePathEditorMode

Syntax in C++

HRESULT get_Mode (ProbePathEditorMode* retVal)

Applies to

ProbePathEditor


ProbePath

ProbePath - Read & Write property

Description

sets/retrieves the probe path to edit

Syntax in Visual Basic or VBScript

ProbePath () As ProbePath

Syntax in C++

HRESULT get_ProbePath (ProbePath* retVal)
HRESULT put_ProbePath (ProbePath* Value)

Applies to

ProbePathEditor


Cancel

Cancel - method

Description

exit the EDIT mode and revert back to the previous probe path

Syntax in Visual Basic or VBScript

Cancel ()

Syntax in C++

HRESULT Cancel ()

Applies to

ProbePathEditor


Commit

Commit - method

Description

commit the current probe path and remain in Edit mode

Syntax in Visual Basic or VBScript

Commit ()

Syntax in C++

HRESULT Commit ()

Applies to

ProbePathEditor


Edit

Edit - method

Description

enter the EDIT mode

Syntax in Visual Basic or VBScript

Edit ()

Syntax in C++

HRESULT Edit ()

Applies to

ProbePathEditor


OnStatusChanged

OnStatusChanged - event

Description

indicates that the state of the ProbePathEditor has changed

Syntax in Visual Basic or VBScript

OnStatusChanged (Mode As ProbePathEditorMode)

Syntax in C++

HRESULT OnStatusChanged (ProbePathEditorMode Mode)

Parameters

Name | Description
Mode |

Applies to

ProbePathEditor


ProbePathFaultItem

ProbePathFaultItem - object

Description

ProbePathFaultItem Class

Interfaces

IProbePathFaultItem

Properties of IProbePathFaultItem

End | R/O | The end point of the fault segment.
FaultType | R/O | The probe-path fault-type.
Index | R/O | The index of this item relative to the list of faults in the IProbePathFaults parent.
Parent | R/O | The parent IProbePathFaults object
ProbePathItemIndex | R/O | The index of the probe-path item that this fault relates to.
Start | R/O | The start point of the fault segment.


End

End - Read property

Description

The end point of the fault segment.

Syntax in Visual Basic or VBScript

End () As Point3D

Syntax in C++

HRESULT get_End (Point3D* retVal)

Applies to

ProbePathFaultItem


FaultType

FaultType - Read property

Description

The probe-path fault-type.

Syntax in Visual Basic or VBScript

FaultType () As ProbePathFaultType

Syntax in C++

HRESULT get_FaultType (ProbePathFaultType* retVal)

Applies to

ProbePathFaultItem


Index

Index - Read property

Description

The index of this item relative to the list of faults in the IProbePathFaults parent.

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

ProbePathFaultItem


Parent

Parent - Read property

Description

The parent IProbePathFaults object

Syntax in Visual Basic or VBScript

Parent () As ProbePathFaults

Syntax in C++

HRESULT get_Parent (ProbePathFaults* retVal)

Applies to

ProbePathFaultItem


ProbePathItemIndex

ProbePathItemIndex - Read property

Description

The index of the probe-path item that this fault relates to.

Syntax in Visual Basic or VBScript

ProbePathItemIndex () As Long

Syntax in C++

HRESULT get_ProbePathItemIndex (LONG* retVal)

Applies to

ProbePathFaultItem


Start

Start - Read property

Description

The start point of the fault segment.

Syntax in Visual Basic or VBScript

Start () As Point3D

Syntax in C++

HRESULT get_Start (Point3D* retVal)

Applies to

ProbePathFaultItem


ProbePathFaultItems

ProbePathFaultItems - object

Description

ProbePathFaultItems Class

Interfaces

IProbePathFaultItems

Properties of IProbePathFaultItems

Count | R/O | The number of fault items.
Item | R/O | Get the fault-item at the given index.


Count

Count - Read property

Description

The number of fault items.

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

ProbePathFaultItems


Item

Item - Read property

Description

Get the fault-item at the given index.

Syntax in Visual Basic or VBScript

Item (item_index As Long) As ProbePathFaultItem

Syntax in C++

HRESULT get_Item (LONG item_index , ProbePathFaultItem* retVal)

Applies to

ProbePathFaultItems


ProbePathFaults

ProbePathFaults - object

Description

ProbePathFaults Class

Interfaces

IProbePathFaults

Events

AddPointFault | Add a fault-item to the end of the list
AddRangeFault | Add a fault-item to the end of the list.
Clear | Remove all the fault-items.
RemoveItem | Remove the fault-item at the given index.

Methods of IProbePathFaults

AddPointFault | Add a fault-item to the end of the list
AddRangeFault | Add a fault-item to the end of the list.
Clear | Remove all the fault-items.
RemoveItem | Remove the fault-item at the given index.

Properties of IProbePathFaults

VerificationStatus R/W The probe-path verification status.

Collections of IProbePathFaults

Items The list of probe-path faults.


VerificationStatus

VerificationStatus - Read & Write property

Description

The probe-path verification status.

Syntax in Visual Basic or VBScript

VerificationStatus () As ProbePathVerificationStatus

Syntax in C++

HRESULT get_VerificationStatus (ProbePathVerificationStatus* retVal)
HRESULT put_VerificationStatus (ProbePathVerificationStatus Value)

Applies to

ProbePathFaults


AddPointFault

AddPointFault - event

Description

Add a fault-item to the end of the list

Syntax in Visual Basic or VBScript

AddPointFault (fault_type As ProbePathFaultType , ByRef Point As Point3D , probe_path_item_index As Long)

Syntax in C++

HRESULT AddPointFault (ProbePathFaultType fault_type , Point3D* Point , LONG probe_path_item_index)

Parameters

Name | Description
fault_type |
Point |
probe_path_item_index |

Applies to

ProbePathFaults


AddRangeFault

AddRangeFault - event

Description

Add a fault-item to the end of the list.

Syntax in Visual Basic or VBScript

AddRangeFault (fault_type As ProbePathFaultType , ByRef range_start_point As Point3D , ByRef range_end_point As Point3D , probe_path_item_index As Long)

Syntax in C++

HRESULT AddRangeFault (ProbePathFaultType fault_type , Point3D* range_start_point , Point3D* range_end_point , LONG probe_path_item_index)

Parameters

Name | Description
fault_type |
range_start_point |
range_end_point |
probe_path_item_index |

Applies to

ProbePathFaults


Clear

Clear - event

Description

Remove all the fault-items.

Syntax in Visual Basic or VBScript

Clear ()

Syntax in C++

HRESULT Clear ()

Applies to

ProbePathFaults


RemoveItem

RemoveItem - event

Description

Remove the fault-item at the given index.

Syntax in Visual Basic or VBScript

RemoveItem (Index As Long)

Syntax in C++

HRESULT RemoveItem (LONG Index)

Parameters

Name | Description
Index |

Applies to

ProbePathFaults


Items

Items - Read property

Description

The list of probe-path faults.

Syntax in Visual Basic or VBScript

Items () As ProbePathFaultItems

Syntax in C++

HRESULT get_Items (ProbePathFaultItems* retVal)

Applies to

ProbePathFaults


ProbePathItemActiveMove

ProbePathItemActiveMove - object

Description

ProbePathItemActiveMove Class

Interfaces

IProbePathItemActiveMove

Methods of IProbePathItemActiveMove

RecordMeasuredPositionAndVector | use to record the measure point ( only valid for MEASURE_TO COMPOSITE_MEASURE_MOVE )
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties of IProbePathItemActiveMove

AbsolutePosition | R/W | property AbsolutePosition: returns/sets the absolute coordinates of the targeted position of the probe center.Note setting the absolute position doesn;t aloter the CoordType property
ApproachVector | R/W | property ApproachVector
CoordType | R/W | property CoordType
DefinitionType | R/W | sets/returns the item defition type
DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
MeasuredCMMPoint | R/O | property MeasuredPoint
OuterMaterialDirection | R/W | property OuterMaterialDirection
Position | R/W | property Position: returns/sets the position of the probe center at the expected contact point.The position is either as an increment or a absolute position, depending of the CoordType value
PositionalItemType | R/W | property Type
PreviousAbsolutePosition | R/O | (property PreviousAbsolutePosition, The theorical absolute position of the probe before this move is executed
ProbePath | R/O | returns the parent probe path
ValidMeasure | R/W | return TRUE is the held measured is valid


ProbePathItemCNCParameter

ProbePathItemCNCParameter - object

Description

ProbePathItemCNCParameter Class

Interfaces

IProbePathItemCNCParameter

Properties of IProbePathItemCNCParameter

Definition | R/O |
DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
Name | R/W |
ParameterType | R/W |
ProbePath | R/O | returns the parent probe path
Value | R/W |


Definition

Definition - Read property

Syntax in Visual Basic or VBScript

Definition () As PDBDefinition

Syntax in C++

HRESULT get_Definition (PDBDefinition* retVal)

Applies to

ProbePathItemCNCParameter


ParameterType

ParameterType - Read & Write property

Syntax in Visual Basic or VBScript

ParameterType () As ParameterItemType

Syntax in C++

HRESULT get_ParameterType (ParameterItemType* retVal)
HRESULT put_ParameterType (ParameterItemType Value)

Applies to

ProbePathItemCNCParameter


Value

Value - Read & Write property

Syntax in Visual Basic or VBScript

Value () As Variant

Syntax in C++

HRESULT get_Value (VARIANT* retVal)
HRESULT put_Value (VARIANT Value)

Applies to

CMMPoint
PDBDefinition
Point3D
ProbePathItemCNCParameter
ReportVariable
UnitVector3D
Vector3D


ProbePathItems

ProbePathItems - object

Description

ProbePathItems Class

Interfaces

IProbePathItems

Methods of IProbePathItems

Insert | method Add
Remove | Remove At

Properties of IProbePathItems

Count | R/W | property Count
Item | R/O | property Item


Insert

Insert - method

Description

method Add

Syntax in Visual Basic or VBScript

Insert (type As ProbeItemType , atPos As Long) As IProbePathItem

Syntax in C++

HRESULT Insert (ProbeItemType type , LONG atPos , IProbePathItem* retVal)

Parameters

Name | Description
type |
atPos |
Return Value |

Applies to

ProbePathItems


Remove

Remove - method

Description

Remove At

Syntax in Visual Basic or VBScript

Remove (atPos As Long)

Syntax in C++

HRESULT Remove (LONG atPos)

Parameters

Name | Description
atPos |

Applies to

ProbePathItems


ProbePathMachineConfiguration

ProbePathMachineConfiguration - object

Description

ProbePathMachineConfiguration Class

Interfaces

IProbePathMachineConfiguration

Methods of IProbePathMachineConfiguration

Copy Copy the parameter object data into this object.

Properties of IProbePathMachineConfiguration

DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MachineConfigurationCreatorType | R/O | The type of object that created this item.
MachineOrientation | R/O | The machine orientation of this item.
MagicNumber | R/O |
Position | R/O | The position at which the machine orientation should be performed.
ProbePath | R/O | returns the parent probe path


MachineConfigurationCreatorType

MachineConfigurationCreatorType - Read property

Description

The type of object that created this item.

Syntax in Visual Basic or VBScript

MachineConfigurationCreatorType () As MachineConfigurationCreatorType

Syntax in C++

HRESULT get_MachineConfigurationCreatorType (MachineConfigurationCreatorType* retVal)

Applies to

ProbePathMachineConfiguration


MachineOrientation

MachineOrientation - Read property

Description

The machine orientation of this item.

Syntax in Visual Basic or VBScript

MachineOrientation () As MachineOrientationData

Syntax in C++

HRESULT get_MachineOrientation (MachineOrientationData* retVal)

Applies to

ProbePathMachineConfiguration


Position

Position - Read property

Description

The position at which the machine orientation should be performed.

Syntax in Visual Basic or VBScript

Position () As Point3D

Syntax in C++

HRESULT get_Position (Point3D* retVal)

Applies to

ProbePathMachineConfiguration


Copy

Copy - method

Description

Copy the parameter object data into this object.

Syntax in Visual Basic or VBScript

Copy (ByRef machine_configuration As ProbePathMachineConfiguration)

Syntax in C++

HRESULT Copy (ProbePathMachineConfiguration* machine_configuration)

Parameters

Name | Description
machine_configuration |

Applies to

ProbePathMachineConfiguration


ProbePathPositionalItem

ProbePathPositionalItem - object

Description

ProbePathItemIntermediatePoint Class

Interfaces

IProbePathPositionalItem

Methods of IProbePathPositionalItem

RecordMeasuredPositionAndVector | use to record the measure point ( only valid for MEASURE_TO COMPOSITE_MEASURE_MOVE )
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties of IProbePathPositionalItem

AbsolutePosition | R/W | property AbsolutePosition: returns/sets the absolute coordinates of the targeted position of the probe center.Note setting the absolute position doesn;t aloter the CoordType property
CoordType | R/W | property CoordType
DefinitionType | R/W | sets/returns the item defition type
DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
MeasuredCMMPoint | R/O | property MeasuredPoint
Position | R/W | property Position: returns/sets the position of the probe center at the expected contact point.The position is either as an increment or a absolute position, depending of the CoordType value
PositionalItemType | R/W | property Type
PreviousAbsolutePosition | R/O | (property PreviousAbsolutePosition, The theorical absolute position of the probe before this move is executed
ProbePath | R/O | returns the parent probe path
ValidMeasure | R/W | return TRUE is the held measured is valid


ProbePathReplay

ProbePathReplay - object

Description

ProbePathReplay Class

Interfaces

IProbePathReplay

Events

OnCNCError | Fired when a CNC error occurs during the reply, asking whether to retry and continue
OnJobStatusChanged | Change when the job status has changed
OnStepStatusChanged | Change when the status of the current step has changed

Methods of IProbePathReplay

ConvertPointAccordingToMachinePosition | Convert the given point and vector from the current type to the new type according to the current position of the machine.
EmergencyStop | cancel any pending action. current step is also cancelled
GoStep | do one step only
Rewind | set the curent step to be the first
Run | runs all steps up to the end
RunWithController | runs all steps up to the end
Stop | cancel any pending action. current step is completed

Properties of IProbePathReplay

AlignmentDatum | R/W |
BUSY | R/O |
CalibrationMode | R/W | Calibration Mode
CMMProtocol | R/O | calling this function will also set the carriage, you may want to use CMMProtocol or Carriage at your convenience but only call one of them
CurrentProbePathItem | R/O |
CurStep | R/W |
CurStepStatus | R/O |
JOBSTATUS | R/O |
ProbePath | R/W |
ProbeReconciliator | R/W | sets/retrieves the ProbeReconcilator, which will be used to substitute probes that do not formally exists on the driven system
RetryAndContinueMode | R/W | set/retrieve the retry and continue mode.


AlignmentDatum

AlignmentDatum - Read & Write property

Syntax in Visual Basic or VBScript

AlignmentDatum () As transform

Syntax in C++

HRESULT get_AlignmentDatum (transform* retVal)
HRESULT put_AlignmentDatum (transform* Value)

Applies to

ProbePathReplay
ProbePathTeach


BUSY

BUSY - Read property

Syntax in Visual Basic or VBScript

BUSY () As Boolean

Syntax in C++

HRESULT get_BUSY (VARIANT_BOOL* retVal)

Applies to

ProbePathReplay
SequenceReplayEngine


CMMProtocol

CMMProtocol - Read property

Description

calling this function will also set the carriage, you may want to use CMMProtocol or Carriage at your convenience but only call one of them

Syntax in Visual Basic or VBScript

CMMProtocol () As CMMProtocol_dummy

Syntax in C++

HRESULT get_CMMProtocol (CMMProtocol_dummy* retVal)

Applies to

ProbePathReplay


CurrentProbePathItem

CurrentProbePathItem - Read property

Syntax in Visual Basic or VBScript

CurrentProbePathItem () As Object

Syntax in C++

HRESULT get_CurrentProbePathItem (IUnknow** retVal)

Applies to

ProbePathReplay


CurStep

CurStep - Read & Write property

Syntax in Visual Basic or VBScript

CurStep () As Long

Syntax in C++

HRESULT get_CurStep (LONG* retVal)
HRESULT put_CurStep (LONG Value)

Applies to

ProbePathReplay


CurStepStatus

CurStepStatus - Read property

Syntax in Visual Basic or VBScript

CurStepStatus () As STEPSTATUS

Syntax in C++

HRESULT get_CurStepStatus (STEPSTATUS* retVal)

Applies to

ProbePathReplay


JOBSTATUS

JOBSTATUS - Read property

Syntax in Visual Basic or VBScript

JOBSTATUS () As JOBSTATUS

Syntax in C++

HRESULT get_JOBSTATUS (JOBSTATUS* retVal)

Applies to

ProbePathReplay


ProbePath

ProbePath - Read & Write property

Syntax in Visual Basic or VBScript

ProbePath () As ProbePath

Syntax in C++

HRESULT get_ProbePath (ProbePath* retVal)
HRESULT put_ProbePath (ProbePath* Value)

Applies to

ProbePathReplay
ProbePathTeach


ProbeReconciliator

ProbeReconciliator - Read & Write property

Description

sets/retrieves the ProbeReconcilator, which will be used to substitute probes that do not formally exists on the driven system

Syntax in Visual Basic or VBScript

ProbeReconciliator () As Object

Syntax in C++

HRESULT get_ProbeReconciliator (IDispatch** retVal)
HRESULT put_ProbeReconciliator (IDispatch* Value)

Applies to

ProbePathReplay


RetryAndContinueMode

RetryAndContinueMode - Read & Write property

Description

set/retrieve the retry and continue mode.

Syntax in Visual Basic or VBScript

RetryAndContinueMode () As Boolean

Syntax in C++

HRESULT get_RetryAndContinueMode (VARIANT_BOOL* retVal)
HRESULT put_RetryAndContinueMode (VARIANT_BOOL Value)

Applies to

ProbePathReplay


ConvertPointAccordingToMachinePosition

ConvertPointAccordingToMachinePosition - method

Description

Convert the given point and vector from the current type to the new type according to the current position of the machine.

Syntax in Visual Basic or VBScript

ConvertPointAccordingToMachinePosition (current_type As ProbePathType , new_type As ProbePathType , ByRef Point As Point3D , ByRef vector As Vector3D)

Syntax in C++

HRESULT ConvertPointAccordingToMachinePosition (ProbePathType current_type , ProbePathType new_type , Point3D* Point , Vector3D* vector)

Parameters

Name | Description
current_type |
new_type |
Point |
vector |

Applies to

ProbePathReplay


EmergencyStop

EmergencyStop - method

Description

cancel any pending action. current step is also cancelled

Syntax in Visual Basic or VBScript

EmergencyStop ()

Syntax in C++

HRESULT EmergencyStop ()

Applies to

SequenceReplayEngine


GoStep

GoStep - method

Description

do one step only

Syntax in Visual Basic or VBScript

GoStep ()

Syntax in C++

HRESULT GoStep ()

Applies to

SequenceReplayEngine


OnCNCError

OnCNCError - event

Description

Fired when a CNC error occurs during the reply, asking whether to retry and continue

Syntax in Visual Basic or VBScript

OnCNCError (ErrorDescription As String)

Syntax in C++

HRESULT OnCNCError (BSTR ErrorDescription)

Parameters

Name | Description
ErrorDescription |

Applies to

SequenceReplayEngine


OnJobStatusChanged

OnJobStatusChanged - event

Description

Change when the job status has changed

Syntax in Visual Basic or VBScript

OnJobStatusChanged (status As JOBSTATUS)

Syntax in C++

HRESULT OnJobStatusChanged (JOBSTATUS status)

Parameters

Name | Description
status |

Applies to

ProbePathReplay


OnStepStatusChanged

OnStepStatusChanged - event

Description

Change when the status of the current step has changed

Syntax in Visual Basic or VBScript

OnStepStatusChanged (currentStep As Long , status As STEPSTATUS)

Syntax in C++

HRESULT OnStepStatusChanged (LONG currentStep , STEPSTATUS status)

Parameters

Name | Description
currentStep |
status |

Applies to

ProbePathReplay


Rewind

Rewind - method

Description

set the curent step to be the first

Syntax in Visual Basic or VBScript

Rewind ()

Syntax in C++

HRESULT Rewind ()

Applies to

SequenceReplayEngine


Run

Run - method

Description

runs all steps up to the end

Syntax in Visual Basic or VBScript

Run ()

Syntax in C++

HRESULT Run ()

Applies to

SequenceReplayEngine


RunWithController

RunWithController - method

Description

runs all steps up to the end

Syntax in Visual Basic or VBScript

RunWithController (ByRef pController As CMMCNCController)

Syntax in C++

HRESULT RunWithController (CMMCNCController* pController)

Parameters

Name | Description
pController |

Applies to

ProbePathReplay


Stop

Stop - method

Description

cancel any pending action. current step is completed

Syntax in Visual Basic or VBScript

Stop ()

Syntax in C++

HRESULT Stop ()

Applies to

ProbePathReplay


ProbePathScanItem

ProbePathScanItem - object

Description

ProbePathScanItem Class

Interfaces

IProbePathScanItem

Methods of IProbePathScanItem

AddPoints | Add contact points.
ClearPoints | Clear contact points.
GetPoints | Get the points.

Properties of IProbePathScanItem

DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
ProbeDiameter | R/W | property ProbeDiameter
ProbePath | R/O | returns the parent probe path
ScanInstruction | R/O | The scan instruction associated with this object.


ProbeDiameter

ProbeDiameter - Read & Write property

Description

property ProbeDiameter

Syntax in Visual Basic or VBScript

ProbeDiameter () As Double

Syntax in C++

HRESULT get_ProbeDiameter (double* retVal)
HRESULT put_ProbeDiameter (double Value)

Applies to

ProbePathScanItem


ScanInstruction

ScanInstruction - Read property

Description

The scan instruction associated with this object.

Syntax in Visual Basic or VBScript

ScanInstruction () As IScanInstruction

Syntax in C++

HRESULT get_ScanInstruction (IScanInstruction* retVal)

Applies to

ProbePathScanItem


AddPoints

AddPoints - method

Description

Add contact points.

Syntax in Visual Basic or VBScript

AddPoints (data As Array)

Syntax in C++

HRESULT AddPoints (SAFEARRAY data)

Parameters

Name | Description
data |

Applies to

ProbePathScanItem


ClearPoints

ClearPoints - method

Description

Clear contact points.

Syntax in Visual Basic or VBScript

ClearPoints ()

Syntax in C++

HRESULT ClearPoints ()

Applies to

ProbePathScanItem


GetPoints

GetPoints - method

Description

Get the points.

Syntax in Visual Basic or VBScript

GetPoints (ByRef ppSa As Array)

Syntax in C++

HRESULT GetPoints (SAFEARRAY* ppSa)

Parameters

Name | Description
ppSa |

Applies to

ProbePathScanItem


ProbePathTeach

ProbePathTeach - object

Description

ProbePathTeach Class

Interfaces

IProbePathTeach

Events

OnCoordTypeChange | the Coordinate Type has has changed (ABSOLUTE/INCREMENTAL
OnCursorChange | the insertion point has changed
OnPositionalItemTypeChange | Fire_OnPositionalItemTypeChange

Methods of IProbePathTeach

GetActiveSensorAtCursor | returns the name and identity card of the current active tip
RecordCurrentPosition | Insert a point matching the e current position of the CMM using the current settings
SynchroniseProbeHead | this method check that the correctnesss Head parameter and insert a element if necessary

Properties of IProbePathTeach

AlignmentDatum | R/W |
CoordType | R/W | Retrieves/sets the recording mode for new coordinates
cursor | R/W |
Enable | R/W |
PositionalItemType | R/W | Retrieves/sets the type of Positional Item that will be next inserted
ProbePath | R/W |


CoordType

CoordType - Read & Write property

Description

Retrieves/sets the recording mode for new coordinates

Syntax in Visual Basic or VBScript

CoordType () As ProbePositionalCoordType

Syntax in C++

HRESULT get_CoordType (ProbePositionalCoordType* retVal)
HRESULT put_CoordType (ProbePositionalCoordType Value)

Applies to

ProbePathTeach


cursor

cursor - Read & Write property

Syntax in Visual Basic or VBScript

cursor () As Long

Syntax in C++

HRESULT get_cursor (LONG* retVal)
HRESULT put_cursor (LONG Value)

Applies to

ProbePathTeach
SequenceItemIterator
SequenceReplayEngine


Enable

Enable - Read & Write property

Syntax in Visual Basic or VBScript

Enable () As Boolean

Syntax in C++

HRESULT get_Enable (VARIANT_BOOL* retVal)
HRESULT put_Enable (VARIANT_BOOL Value)

Applies to

ProbePathTeach


PositionalItemType

PositionalItemType - Read & Write property

Description

Retrieves/sets the type of Positional Item that will be next inserted

Syntax in Visual Basic or VBScript

PositionalItemType () As ProbePositionalItemType

Syntax in C++

HRESULT get_PositionalItemType (ProbePositionalItemType* retVal)
HRESULT put_PositionalItemType (ProbePositionalItemType Value)

Applies to

ProbePathTeach


GetActiveSensorAtCursor

GetActiveSensorAtCursor - method

Description

returns the name and identity card of the current active tip

Syntax in Visual Basic or VBScript

GetActiveSensorAtCursor (ByRef strSensorName As String , ByRef strSensorIDCard As String)

Syntax in C++

HRESULT GetActiveSensorAtCursor (BSTR* strSensorName , BSTR* strSensorIDCard)

Parameters

Name | Description
strSensorName |
strSensorIDCard |

Applies to

ProbePathTeach


OnCoordTypeChange

OnCoordTypeChange - event

Description

the Coordinate Type has has changed (ABSOLUTE/INCREMENTAL

Syntax in Visual Basic or VBScript

OnCoordTypeChange (newPos As ProbePositionalCoordType)

Syntax in C++

HRESULT OnCoordTypeChange (ProbePositionalCoordType newPos)

Parameters

Name | Description
newPos |

Applies to

ProbePathTeach


OnCursorChange

OnCursorChange - event

Description

the insertion point has changed

Syntax in Visual Basic or VBScript

OnCursorChange (newPos As Long)

Syntax in C++

HRESULT OnCursorChange (LONG newPos)

Parameters

Name | Description
newPos |

Applies to

ProbePathTeach


OnPositionalItemTypeChange

OnPositionalItemTypeChange - event

Description

Fire_OnPositionalItemTypeChange

Syntax in Visual Basic or VBScript

OnPositionalItemTypeChange (newType As ProbePositionalItemType)

Syntax in C++

HRESULT OnPositionalItemTypeChange (ProbePositionalItemType newType)

Parameters

Name | Description
newType |

Applies to

ProbePathTeach


RecordCurrentPosition

RecordCurrentPosition - method

Description

Insert a point matching the e current position of the CMM using the current settings

Syntax in Visual Basic or VBScript

RecordCurrentPosition ()

Syntax in C++

HRESULT RecordCurrentPosition ()

Applies to

ProbePathTeach


SynchroniseProbeHead

SynchroniseProbeHead - method

Description

this method check that the correctnesss Head parameter and insert a element if necessary

Syntax in Visual Basic or VBScript

SynchroniseProbeHead () As Boolean

Syntax in C++

HRESULT SynchroniseProbeHead (VARIANT_BOOL* retVal)

Parameters

Name | Description
Return Value |

Applies to

ProbePathTeach


ProbeRack

ProbeRack - object

Description

ProbeRack

Interfaces

IProbeRack

Methods of IProbeRack

FillIdentityCard fill the node with the identity card of this item

Properties of IProbeRack

_ID | R/W | INTERNAL USE ONLY
Calibration | R/O | retrieves the calibration object
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
LocalDatum | R/O | returns the nominal local of the rack in CMM coordinate
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections of IProbeRack

SlotCollection returns the collection of slots


LocalDatum

LocalDatum - Read property

Description

returns the nominal local of the rack in CMM coordinate

Syntax in Visual Basic or VBScript

LocalDatum () As ITransform2

Syntax in C++

HRESULT get_LocalDatum (ITransform2* retVal)

Applies to

ProbeRack


SlotCollection

SlotCollection - Read property

Description

returns the collection of slots

Syntax in Visual Basic or VBScript

SlotCollection () As ProbeRackSlotCollection

Syntax in C++

HRESULT get_SlotCollection (ProbeRackSlotCollection* retVal)

Applies to

ProbeRack


ProbeRackCollection

ProbeRackCollection - object

Description

ProbeRackCollection

Interfaces

IProbeRackCollection

Methods of IProbeRackCollection

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties of IProbeRackCollection

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


Add

Add - method

Description

method Add : add an item to the collection

Syntax in Visual Basic or VBScript

Add (ByRef Rack As ProbeRack)

Syntax in C++

HRESULT Add (ProbeRack* Rack)

Parameters

Name | Description
Rack |

Applies to

ProbeRackCollection


ProbeRackSlot

ProbeRackSlot - object

Description

ProbeRackSlot

Interfaces

IProbeRackSlot

Methods of IProbeRackSlot

FillIdentityCard fill the node with the identity card of this item

Properties of IProbeRackSlot

_ID | R/W | INTERNAL USE ONLY
Calibration | R/O | retrieves the calibration object
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the index of this object within the parent collection
InterfaceType | R/O |
NominalPositionRelativeToRack | R/O | return the position of this slot relative to the Rack Local Coordinate System - Before Calibration - as provided by the manufacturer or defined by the user
PositionRelativeToCMM | R/O | return the Calibrated position of this slot relative to CMM Coordinate System
PositionRelativeToRack | R/O | return the Calibrated position of this slot relative to the Rack Local Coordinate System
Rack | R/O | return the parent Rack
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user


index

index - Read property

Description

returns the index of this object within the parent collection

Syntax in Visual Basic or VBScript

index () As Long

Syntax in C++

HRESULT get_index (LONG* retVal)

Applies to

ProbeRackSlot
ProbeTool


NominalPositionRelativeToRack

NominalPositionRelativeToRack - Read property

Description

return the position of this slot relative to the Rack Local Coordinate System - Before Calibration - as provided by the manufacturer or defined by the user

Syntax in Visual Basic or VBScript

NominalPositionRelativeToRack () As Point3D

Syntax in C++

HRESULT get_NominalPositionRelativeToRack (Point3D* retVal)

Applies to

ProbeRackSlot


PositionRelativeToCMM

PositionRelativeToCMM - Read property

Description

return the Calibrated position of this slot relative to CMM Coordinate System

Syntax in Visual Basic or VBScript

PositionRelativeToCMM () As Point3D

Syntax in C++

HRESULT get_PositionRelativeToCMM (Point3D* retVal)

Applies to

ProbeRackSlot


PositionRelativeToRack

PositionRelativeToRack - Read property

Description

return the Calibrated position of this slot relative to the Rack Local Coordinate System

Syntax in Visual Basic or VBScript

PositionRelativeToRack () As Point3D

Syntax in C++

HRESULT get_PositionRelativeToRack (Point3D* retVal)

Applies to

ProbeRackSlot


Rack

Rack - Read property

Description

return the parent Rack

Syntax in Visual Basic or VBScript

Rack () As ProbeRack

Syntax in C++

HRESULT get_Rack (ProbeRack* retVal)

Applies to

ProbeRackSlot


ProbeRackSlotCollection

ProbeRackSlotCollection - object

Description

ProbeRackSlotCollection

Interfaces

IProbeRackSlotCollection

Methods of IProbeRackSlotCollection

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties of IProbeRackSlotCollection

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


Add

Add - method

Description

method Add : add an item to the collection

Syntax in Visual Basic or VBScript

Add (ByRef Rack As ProbeRackSlot)

Syntax in C++

HRESULT Add (ProbeRackSlot* Rack)

Parameters

Name | Description
Rack |

Applies to

ProbeRackSlotCollection


ProbeReconciliator

ProbeReconciliator - object

Description

DatumFeatureCollection

Interfaces

IProbeReconciliator

Methods of IProbeReconciliator

CollectSensorDefinitionItems
Reconciliate
ReconciliateTip
RegisterVCARD

Properties of IProbeReconciliator

IsVCARDRegistered R/O returns T_TRUE if the VCARD is already known by the reconcilator


IsVCARDRegistered

IsVCARDRegistered - Read property

Description

returns T_TRUE if the VCARD is already known by the reconcilator

Syntax in Visual Basic or VBScript

IsVCARDRegistered (vVCARD As String) As Boolean

Syntax in C++

HRESULT get_IsVCARDRegistered (BSTR vVCARD , VARIANT_BOOL* retVal)

Applies to

ProbeReconciliator


CollectSensorDefinitionItems

CollectSensorDefinitionItems - method

Syntax in Visual Basic or VBScript

CollectSensorDefinitionItems (pProbePath As Variant)

Syntax in C++

HRESULT CollectSensorDefinitionItems (VARIANT pProbePath)

Parameters

Name | Description
pProbePath |

Applies to

ProbeReconciliator


Reconciliate

Reconciliate - method

Syntax in Visual Basic or VBScript

Reconciliate (ByRef pProbeDatabase As ProbeDatabase) As Boolean

Syntax in C++

HRESULT Reconciliate (ProbeDatabase* pProbeDatabase , VARIANT_BOOL* retVal)

Parameters

Name | Description
pProbeDatabase |
Return Value |

Applies to

ProbeReconciliator


ReconciliateTip

ReconciliateTip - method

Syntax in Visual Basic or VBScript

ReconciliateTip (ByRef pProbeDatabase As ProbeDatabase , VCARD As String) As probeTip

Syntax in C++

HRESULT ReconciliateTip (ProbeDatabase* pProbeDatabase , BSTR VCARD , probeTip* retVal)

Parameters

Name | Description
pProbeDatabase |
VCARD |
Return Value |

Applies to

ProbeReconciliator


RegisterVCARD

RegisterVCARD - method

Syntax in Visual Basic or VBScript

RegisterVCARD (vVCARD As String)

Syntax in C++

HRESULT RegisterVCARD (BSTR vVCARD)

Parameters

Name | Description
vVCARD |

Applies to

ProbeReconciliator


ProbeSensorCollection

ProbeSensorCollection - object

Description

ProbeSensorCollection Class

Interfaces

IProbeSensorCollection

Events

Add | fired after a element has been inserted into the collection
AfterDelete | fired after a element has been removed from the collection
Changed | fired after a element definition has changed
Delete | fired before a element will be removed from the collection

Methods of IProbeSensorCollection

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties of IProbeSensorCollection

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


Add

Add - method

Description

method Add : add an item to the collection

Syntax in Visual Basic or VBScript

Add (ByRef Sensor As IProbeSensor)

Syntax in C++

HRESULT Add (IProbeSensor* Sensor)

Parameters

Name | Description
Sensor |

Applies to

ProbeSensorCollection


ProbeSensorCylinder

ProbeSensorCylinder - object

Description

ProbeSensorCylinder Class

Interfaces

IProbeSensorCylinder

Methods of IProbeSensorCylinder

FillIdentityCard | fill the node with the identity card of this item
GetProbeTip | retrieves the probe tip that match the given A and B angle, if bCreate = True, a new tip will be automatically create if none exists
RemoveUnusedAutomaticTips | remove unused tips that may have been created automaticaly by the system

Properties of IProbeSensorCylinder

_ID | R/W | INTERNAL USE ONLY
CalibratedDiameter | R/O | returns the calibrated diameter in mm
CalibratedLength | R/O | returns/sets the calibrated length of the sensor which is the length of its stem as process during the calibration phase
Calibration | R/O | retrieves the calibration object
connection | R/W | sets/returns the connection on which this sensor is fitted on the probe tool
Diameter | R/O | returns the parameter that describes the manufactured probe diameter
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the 0-based index of this object within the parent collection. this correspond to the index of the connector on which this element is connected to
InterfaceType | R/O |
length | R/O | returns/sets the length description of the sensor which is the length of its stem as provided by the manufacturer
Location | R/O | Location of the probe sensor active point(tip) relative to the probe head origin on the local probe head coordinates system
NoseType | R/W | sets/returns the type of cylindrical probe nose
ProbeTool | R/O | retrieves the parent probe tool
ProbeType | R/O | returns the type of this sensor
Property | R/O |
StemVector | R/O | stem vector of the sensor expressed on the local probe head coordinates system
ThreadID | R/O |
TipHeight | R/O | returns the information concerning the valid height of the cylinder tip of the sensor
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections of IProbeSensorCylinder

ProbeTipCollection returns the probe tip collection which are all registered position (calibrated or not)


CalibratedDiameter

CalibratedDiameter - Read property

Description

returns the calibrated diameter in mm

Syntax in Visual Basic or VBScript

CalibratedDiameter () As Double

Syntax in C++

HRESULT get_CalibratedDiameter (double* retVal)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere


CalibratedLength

CalibratedLength - Read property

Description

returns/sets the calibrated length of the sensor which is the length of its stem as process during the calibration phase

Syntax in Visual Basic or VBScript

CalibratedLength () As Double

Syntax in C++

HRESULT get_CalibratedLength (double* retVal)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere


connection

connection - Read & Write property

Description

sets/returns the connection on which this sensor is fitted on the probe tool

Syntax in Visual Basic or VBScript

connection () As ProbeToolConnection

Syntax in C++

HRESULT get_connection (ProbeToolConnection* retVal)
HRESULT put_connection (ProbeToolConnection* Value)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere


Diameter

Diameter - Read property

Description

returns the parameter that describes the manufactured probe diameter

Syntax in Visual Basic or VBScript

Diameter () As CMMFloatParameter

Syntax in C++

HRESULT get_Diameter (CMMFloatParameter* retVal)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere


index

index - Read property

Description

returns the 0-based index of this object within the parent collection. this correspond to the index of the connector on which this element is connected to

Syntax in Visual Basic or VBScript

index () As Long

Syntax in C++

HRESULT get_index (LONG* retVal)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere


length

length - Read property

Description

returns/sets the length description of the sensor which is the length of its stem as provided by the manufacturer

Syntax in Visual Basic or VBScript

length () As CMMFloatParameter

Syntax in C++

HRESULT get_length (CMMFloatParameter* retVal)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere


Location

Location - Read property

Description

Location of the probe sensor active point(tip) relative to the probe head origin on the local probe head coordinates system

Syntax in Visual Basic or VBScript

Location () As Point3D

Syntax in C++

HRESULT get_Location (Point3D* retVal)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere


NoseType

NoseType - Read & Write property

Description

sets/returns the type of cylindrical probe nose

Syntax in Visual Basic or VBScript

NoseType () As PROBESENSORCYLINDER_TYPE

Syntax in C++

HRESULT get_NoseType (PROBESENSORCYLINDER_TYPE* retVal)
HRESULT put_NoseType (PROBESENSORCYLINDER_TYPE Value)

Applies to

ProbeSensorCylinder


ProbeTool

ProbeTool - Read property

Description

retrieves the parent probe tool

Syntax in Visual Basic or VBScript

ProbeTool () As ProbeTool

Syntax in C++

HRESULT get_ProbeTool (ProbeTool* retVal)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere
ProbeToolConnection


ProbeType

ProbeType - Read property

Description

returns the type of this sensor

Syntax in Visual Basic or VBScript

ProbeType () As _PROBESENSORTYPE

Syntax in C++

HRESULT get_ProbeType (_PROBESENSORTYPE* retVal)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere


StemVector

StemVector - Read property

Description

stem vector of the sensor expressed on the local probe head coordinates system

Syntax in Visual Basic or VBScript

StemVector () As UnitVector3D

Syntax in C++

HRESULT get_StemVector (UnitVector3D* retVal)

Applies to

IProbeSensor
ProbeSensorCylinder
ProbeSensorSphere


TipHeight

TipHeight - Read property

Description

returns the information concerning the valid height of the cylinder tip of the sensor

Syntax in Visual Basic or VBScript

TipHeight () As CMMFloatParameter

Syntax in C++

HRESULT get_TipHeight (CMMFloatParameter* retVal)

Applies to

ProbeSensorCylinder


GetProbeTip

GetProbeTip - method

Description

retrieves the probe tip that match the given A and B angle, if bCreate = True, a new tip will be automatically create if none exists

Syntax in Visual Basic or VBScript

GetProbeTip (A As Double , B As Double , bCreate As Boolean) As probeTip

Syntax in C++

HRESULT GetProbeTip (double A , double B , VARIANT_BOOL bCreate , probeTip* retVal)

Parameters

Name | Description
A |
B |
bCreate |
Return Value |

Applies to

IProbeSensor


RemoveUnusedAutomaticTips

RemoveUnusedAutomaticTips - method

Description

remove unused tips that may have been created automaticaly by the system

Syntax in Visual Basic or VBScript

RemoveUnusedAutomaticTips ()

Syntax in C++

HRESULT RemoveUnusedAutomaticTips ()

Applies to

ProbeTool


ProbeTipCollection

ProbeTipCollection - Read property

Description

returns the probe tip collection which are all registered position (calibrated or not)

Syntax in Visual Basic or VBScript

ProbeTipCollection () As ProbeTipCollection

Syntax in C++

HRESULT get_ProbeTipCollection (ProbeTipCollection* retVal)

Applies to

IProbeSensor


ProbeSensorSphere

ProbeSensorSphere - object

Description

ProbeSensorSphere Class

Interfaces

IProbeSensorSphere

Methods of IProbeSensorSphere

FillIdentityCard | fill the node with the identity card of this item
GetProbeTip | retrieves the probe tip that match the given A and B angle, if bCreate = True, a new tip will be automatically create if none exists
RemoveUnusedAutomaticTips | remove unused tips that may have been created automaticaly by the system

Properties of IProbeSensorSphere

_ID | R/W | INTERNAL USE ONLY
CalibratedDiameter | R/O | returns the calibrated diameter in mm
CalibratedLength | R/O | returns/sets the calibrated length of the sensor which is the length of its stem as process during the calibration phase
Calibration | R/O | retrieves the calibration object
connection | R/W | sets/returns the connection on which this sensor is fitted on the probe tool
Diameter | R/O | returns the parameter that describes the manufactured probe diameter
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the 0-based index of this object within the parent collection. this correspond to the index of the connector on which this element is connected to
InterfaceType | R/O |
length | R/O | returns/sets the length description of the sensor which is the length of its stem as provided by the manufacturer
Location | R/O | Location of the probe sensor active point(tip) relative to the probe head origin on the local probe head coordinates system
ProbeTool | R/O | retrieves the parent probe tool
ProbeType | R/O | returns the type of this sensor
Property | R/O |
StemVector | R/O | stem vector of the sensor expressed on the local probe head coordinates system
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections of IProbeSensorSphere

ProbeTipCollection returns the probe tip collection which are all registered position (calibrated or not)


ProbeStructureBuilder

ProbeStructureBuilder - object

Description

ProbeStructureBuilder Class

Interfaces

IProbeStructureBuilder

Methods of IProbeStructureBuilder

addCone | Adds cone to new probe
addCylinder | Adds cylinder to new probe
addSphere | Adds sphere to new probe
addTip | Adds a new probe tip
endElement | Completes an element in the structure
EndProbeBuilder | End building a new probe
startElement | Starts a new element in the structure
StartProbeBuilder | Start building a new probe


probeTip

probeTip - object

Description

ProbeTip Class

Interfaces

IProbeTip

Methods of IProbeTip

Compensate | Apply the probe offset compensation to the give coordinates according to this tip
Delete | remove this element from its parent collection
FillIdentityCard | fill the node with the identity card of this item
GetSmartName | return a smart name for this tip based on the sensor/tool and type of probehead actually used
Uncompensate | Undo the effect of the probe offset compensation on the give coordinates according to this tip

Properties of IProbeTip

_ID | R/W | INTERNAL USE ONLY
A | R/O | retrieves the A angle for which this tip is defined
B | R/O | retrieves the B angle for which this tip is defined
Calibration | R/O | retrieves the calibration object
Diameter | R/O | Actual Diameter as calibrated ( in milimeters )
Direction | R/O | Direction of the probe shaft when this tip is active ( from tip along the shaft direction : i.e for a vertical probe, this will be 0,0,+1)
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the 0-based index of this object within the parent collection
InterfaceType | R/O |
IsTemporary | R/W | returns TRUE if the tip is a temporary position, a temporary position is not persisted and is removed once the tip is not active anymore
offset | R/O | returns the calibrated offset for this tip
ProbeSensor | R/O | return the parent ProbeSensor
Property | R/O |
SmartName | R/O | return a smart name for this tip based on the sensor/tool and type of probehead actually used
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections of IProbeTip

parent returns the parent object of this object i.e the collection


A

A - Read property

Description

retrieves the A angle for which this tip is defined

Syntax in Visual Basic or VBScript

A () As Double

Syntax in C++

HRESULT get_A (double* retVal)

Applies to

probeTip


B

B - Read property

Description

retrieves the B angle for which this tip is defined

Syntax in Visual Basic or VBScript

B () As Double

Syntax in C++

HRESULT get_B (double* retVal)

Applies to

probeTip


Diameter

Diameter - Read property

Description

Actual Diameter as calibrated ( in milimeters )

Syntax in Visual Basic or VBScript

Diameter () As Double

Syntax in C++

HRESULT get_Diameter (double* retVal)

Applies to

probeTip


Direction

Direction - Read property

Description

Direction of the probe shaft when this tip is active ( from tip along the shaft direction : i.e for a vertical probe, this will be 0,0,+1)

Syntax in Visual Basic or VBScript

Direction () As UnitVector3D

Syntax in C++

HRESULT get_Direction (UnitVector3D* retVal)

Applies to

probeTip


index

index - Read property

Description

returns the 0-based index of this object within the parent collection

Syntax in Visual Basic or VBScript

index () As Long

Syntax in C++

HRESULT get_index (LONG* retVal)

Applies to

probeTip
ProbeToolConnection


IsTemporary

IsTemporary - Read & Write property

Description

returns TRUE if the tip is a temporary position, a temporary position is not persisted and is removed once the tip is not active anymore

Syntax in Visual Basic or VBScript

IsTemporary () As Boolean

Syntax in C++

HRESULT get_IsTemporary (VARIANT_BOOL* retVal)
HRESULT put_IsTemporary (VARIANT_BOOL Value)

Applies to

probeTip


offset

offset - Read property

Description

returns the calibrated offset for this tip

Syntax in Visual Basic or VBScript

offset () As Point3D

Syntax in C++

HRESULT get_offset (Point3D* retVal)

Applies to

probeTip


ProbeSensor

ProbeSensor - Read property

Description

return the parent ProbeSensor

Syntax in Visual Basic or VBScript

ProbeSensor () As IProbeSensor

Syntax in C++

HRESULT get_ProbeSensor (IProbeSensor* retVal)

Applies to

probeTip


SmartName

SmartName - Read property

Description

return a smart name for this tip based on the sensor/tool and type of probehead actually used

Syntax in Visual Basic or VBScript

SmartName () As String

Syntax in C++

HRESULT get_SmartName (BSTR* retVal)

Applies to

probeTip


Compensate

Compensate - method

Description

Apply the probe offset compensation to the give coordinates according to this tip

Syntax in Visual Basic or VBScript

Compensate (ByRef pointOrVector As Variant)

Syntax in C++

HRESULT Compensate (VARIANT* pointOrVector)

Parameters

Name | Description
pointOrVector |

Applies to

probeTip


Delete

Delete - method

Description

remove this element from its parent collection

Syntax in Visual Basic or VBScript

Delete ()

Syntax in C++

HRESULT Delete ()

Applies to

ProbeTool


GetSmartName

GetSmartName - method

Description

return a smart name for this tip based on the sensor/tool and type of probehead actually used

Syntax in Visual Basic or VBScript

GetSmartName (IncludeDiameter As Boolean) As String

Syntax in C++

HRESULT GetSmartName (VARIANT_BOOL IncludeDiameter , BSTR* retVal)

Parameters

Name | Description
IncludeDiameter |
Return Value |

Applies to

probeTip


Uncompensate

Uncompensate - method

Description

Undo the effect of the probe offset compensation on the give coordinates according to this tip

Syntax in Visual Basic or VBScript

Uncompensate (ByRef pointOrVector As Variant)

Syntax in C++

HRESULT Uncompensate (VARIANT* pointOrVector)

Parameters

Name | Description
pointOrVector |

Applies to

probeTip


parent

parent - Read property

Description

returns the parent object of this object i.e the collection

Syntax in Visual Basic or VBScript

parent () As ProbeToolCollection

Syntax in C++

HRESULT get_parent (ProbeToolCollection* retVal)

Applies to

ProbeTool


ProbeTipCollection

ProbeTipCollection - object

Description

ProbeTipCollection Class

Interfaces

IProbeTipCollection

Events

Add | fired after a element has been inserted into the collection
AfterDelete | fired after a element has been removed from the collection
Changed | fired after a element definition has changed
Delete | fired before a element will be removed from the collection

Methods of IProbeTipCollection

Delete method Delete : delete a tip from the collection

Properties of IProbeTipCollection

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


Delete

Delete - method

Description

method Delete : delete a tip from the collection

Syntax in Visual Basic or VBScript

Delete (Tip As Variant)

Syntax in C++

HRESULT Delete (VARIANT Tip)

Parameters

Name | Description
Tip |

Applies to

ProbeTipCollection


ProbeTool

ProbeTool - object

Description

ProbeTool Class

Interfaces

IProbeTool

Events

ActiveSensorChange

Methods of IProbeTool

Delete | remove this element from its parent collection
FillIdentityCard | fill the node with the identity card of this item
RemoveUnusedAutomaticTips | remove unused tips that may have been created automaticaly by the system

Properties of IProbeTool

_ID | R/W | INTERNAL USE ONLY
ActiveSensor | R/W | sets/retrieves the active probe sensor
assemblyDefinition | R/W | retrieves/sets the Assembly definition XML string
Calibration | R/O | retrieves the calibration object
Carriage | R/O | returns the parent ICarriage
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the index of this object within the parent collection
InterfaceType | R/O |
JunctionOffset | R/O | retreives the position of the junction point of this tool relative to the probe Head center point the local Probe Head co-ordinate system
Sensor | R/O | retrieve a sensor of this probe by name
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections of IProbeTool

Connections | retrieves the connections ProbeToolConnections
parent | returns the parent object of this object i.e the collection


ActiveSensor

ActiveSensor - Read & Write property

Description

sets/retrieves the active probe sensor

Syntax in Visual Basic or VBScript

ActiveSensor () As IProbeSensor

Syntax in C++

HRESULT get_ActiveSensor (IProbeSensor* retVal)
HRESULT put_ActiveSensor (VARIANT Value)

Applies to

ProbeTool


assemblyDefinition

assemblyDefinition - Read & Write property

Description

retrieves/sets the Assembly definition XML string

Syntax in Visual Basic or VBScript

assemblyDefinition () As String

Syntax in C++

HRESULT get_assemblyDefinition (BSTR* retVal)
HRESULT put_assemblyDefinition (BSTR Value)

Applies to

ProbeTool


Carriage

Carriage - Read property

Description

returns the parent ICarriage

Syntax in Visual Basic or VBScript

Carriage () As Carriage

Syntax in C++

HRESULT get_Carriage (Carriage* retVal)

Applies to

ProbeTool


JunctionOffset

JunctionOffset - Read property

Description

retreives the position of the junction point of this tool relative to the probe Head center point the local Probe Head co-ordinate system

Syntax in Visual Basic or VBScript

JunctionOffset () As Vector3D

Syntax in C++

HRESULT get_JunctionOffset (Vector3D* retVal)

Applies to

ProbeTool


Sensor

Sensor - Read property

Description

retrieve a sensor of this probe by name

Syntax in Visual Basic or VBScript

Sensor (Sensor As Variant) As IProbeSensor

Syntax in C++

HRESULT get_Sensor (VARIANT Sensor , IProbeSensor* retVal)

Applies to

ProbeTool


ActiveSensorChange

ActiveSensorChange - event

Syntax in Visual Basic or VBScript

ActiveSensorChange (pOld As Object , pNew As Object)

Syntax in C++

HRESULT ActiveSensorChange (IDispatch* pOld , IDispatch* pNew , HRESULT* retVal)

Parameters

Name | Description
pOld |
pNew |

Applies to

ProbeTool


Connections

Connections - Read property

Description

retrieves the connections ProbeToolConnections

Syntax in Visual Basic or VBScript

Connections () As ProbeToolConnections

Syntax in C++

HRESULT get_Connections (ProbeToolConnections* retVal)

Applies to

ProbeTool


ProbeToolCollection

ProbeToolCollection - object

Description

ProbeDatabase Class

Interfaces

IProbeToolCollection

Events

Add | fired after a element has been inserted into the collection
AfterDelete | fired after a element has been removed from the collection
Changed | fired after a element definition has changed
Delete | fired before a element will be removed from the collection

Methods of IProbeToolCollection

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection
DeleteAll | Delete all the connections

Properties of IProbeToolCollection

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


Add

Add - method

Description

method Add : add an item to the collection

Syntax in Visual Basic or VBScript

Add (ByRef Sensor As ProbeTool)

Syntax in C++

HRESULT Add (ProbeTool* Sensor)

Parameters

Name | Description
Sensor |

Applies to

ProbeToolCollection


DeleteAll

DeleteAll - method

Description

Delete all the connections

Syntax in Visual Basic or VBScript

DeleteAll ()

Syntax in C++

HRESULT DeleteAll ()

Applies to

ProbeToolConnections


ProbeToolConnection

ProbeToolConnection - object

Description

ProbeToolConnection

Interfaces

IProbeToolConnection

Methods of IProbeToolConnection

Delete | remove this connection from the parent connections collection
FillIdentityCard | fill the node with the identity card of this item

Properties of IProbeToolConnection

_ID | R/W | INTERNAL USE ONLY
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the 0-based index of this object within the parent collection
InterfaceType | R/O |
ProbeSensor | R/W | sets/retrieves the attached sensor
ProbeTool | R/O | retrieves the parent probe tool
SensorMountingDirection | R/O | returns the sensor Mounting Direction
SensorMountingPoint | R/O | returns the sensor Mounting point
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections of IProbeToolConnection

parent returns the parent object of this object i.e the collection


ProbeSensor

ProbeSensor - Read & Write property

Description

sets/retrieves the attached sensor

Syntax in Visual Basic or VBScript

ProbeSensor () As IProbeSensor

Syntax in C++

HRESULT get_ProbeSensor (IProbeSensor* retVal)
HRESULT put_ProbeSensor (IProbeSensor* Value)

Applies to

ProbeToolConnection


SensorMountingDirection

SensorMountingDirection - Read property

Description

returns the sensor Mounting Direction

Syntax in Visual Basic or VBScript

SensorMountingDirection () As UnitVector3D

Syntax in C++

HRESULT get_SensorMountingDirection (UnitVector3D* retVal)

Applies to

ProbeToolConnection


SensorMountingPoint

SensorMountingPoint - Read property

Description

returns the sensor Mounting point

Syntax in Visual Basic or VBScript

SensorMountingPoint () As Point3D

Syntax in C++

HRESULT get_SensorMountingPoint (Point3D* retVal)

Applies to

ProbeToolConnection


Delete

Delete - method

Description

remove this connection from the parent connections collection

Syntax in Visual Basic or VBScript

Delete ()

Syntax in C++

HRESULT Delete ()

Applies to

ProbeToolConnection


ProbeToolConnections

ProbeToolConnections - object

Description

ProbeToolConnections

Interfaces

IProbeToolConnections

Methods of IProbeToolConnections

Delete | remove a connection from the collection
DeleteAll | Delete all the connections

Properties of IProbeToolConnections

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


Delete

Delete - method

Description

remove a connection from the collection

Syntax in Visual Basic or VBScript

Delete (connection As Variant)

Syntax in C++

HRESULT Delete (VARIANT connection)

Parameters

Name | Description
connection |

Applies to

ProbeToolConnections


Properties

Properties - object

Interfaces

IProperties

Properties of IProperties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual property within the collection. Index can be an ordinal from 1 to Count or a string


Item

Item - Read property

Description

Allows random access to individual property within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As IProperty

Syntax in C++

HRESULT get_Item (VARIANT Index , IProperty* retVal)

Applies to

Properties


PropertyAngle

PropertyAngle - object

Interfaces

IPropertyAngle

Properties of IPropertyAngle

AngleRange | R/W | Return the desired range for reporting the angle
Description | R/O |
Error | R/O | return the actual measured error for the given measure
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the lower tolerance for this property
Measured | R/O | return the actual measured value for the given measure
Name | R/W |
Nominal | R/W | get the nominal value of the property
OutputToReport | R/W |
OverRun | R/O | return the actual measured overrun for the given measure
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the upper tolerance for this property


AngleRange

AngleRange - Read & Write property

Description

Return the desired range for reporting the angle

Syntax in Visual Basic or VBScript

AngleRange () As PWI_AngleValidRange

Syntax in C++

HRESULT get_AngleRange (PWI_AngleValidRange* retVal)
HRESULT put_AngleRange (PWI_AngleValidRange Value)

Applies to

PropertyAngle


Description

Description - Read property

Syntax in Visual Basic or VBScript

Description () As String

Syntax in C++

HRESULT get_Description (BSTR* retVal)

Applies to

IProperty
IProperty1
IProperty3
PropertyAngle
PropertyGeometricTolerance
PropertyLinearDimension
PropertyPoint3D
PropertyRadialDimension
PropertyUnitVector3D
PropertyVector3D


Error

Error - Read property

Description

return the actual measured error for the given measure

Syntax in Visual Basic or VBScript

Error (measure As Variant) As Double

Syntax in C++

HRESULT get_Error (VARIANT measure , double* retVal)

Applies to

IProperty1
PropertyAngle
PropertyLinearDimension
PropertyRadialDimension


LowerTol

LowerTol - Read & Write property

Description

get the lower tolerance for this property

Syntax in Visual Basic or VBScript

LowerTol () As Double

Syntax in C++

HRESULT get_LowerTol (double* retVal)
HRESULT put_LowerTol (double Value)

Applies to

IProperty1
PropertyAngle
PropertyLinearDimension
PropertyRadialDimension


Measured

Measured - Read property

Description

return the actual measured value for the given measure

Syntax in Visual Basic or VBScript

Measured (measure As Variant) As Double

Syntax in C++

HRESULT get_Measured (VARIANT measure , double* retVal)

Applies to

IProperty1
PropertyAngle
PropertyLinearDimension
PropertyRadialDimension


Nominal

Nominal - Read & Write property

Description

get the nominal value of the property

Syntax in Visual Basic or VBScript

Nominal () As Double

Syntax in C++

HRESULT get_Nominal (double* retVal)
HRESULT put_Nominal (double Value)

Applies to

IProperty1
PropertyAngle
PropertyLinearDimension
PropertyRadialDimension


OutputToReport

OutputToReport - Read & Write property

Syntax in Visual Basic or VBScript

OutputToReport () As Boolean

Syntax in C++

HRESULT get_OutputToReport (VARIANT_BOOL* retVal)
HRESULT put_OutputToReport (VARIANT_BOOL Value)

Applies to

IProperty
IProperty1
IProperty3
PropertyAngle
PropertyGeometricTolerance
PropertyLinearDimension
PropertyPoint3D
PropertyRadialDimension
PropertyUnitVector3D
PropertyVector3D


OverRun

OverRun - Read property

Description

return the actual measured overrun for the given measure

Syntax in Visual Basic or VBScript

OverRun (measure As Variant) As Double

Syntax in C++

HRESULT get_OverRun (VARIANT measure , double* retVal)

Applies to

IProperty1
PropertyAngle
PropertyLinearDimension
PropertyRadialDimension


PropertyType

PropertyType - Read property

Syntax in Visual Basic or VBScript

PropertyType () As PWI_PropertyType

Syntax in C++

HRESULT get_PropertyType (PWI_PropertyType* retVal)

Applies to

IProperty
IProperty1
IProperty3
PropertyAngle
PropertyGeometricTolerance
PropertyLinearDimension
PropertyPoint3D
PropertyRadialDimension
PropertyUnitVector3D
PropertyVector3D


UpperTol

UpperTol - Read & Write property

Description

get the upper tolerance for this property

Syntax in Visual Basic or VBScript

UpperTol () As Double

Syntax in C++

HRESULT get_UpperTol (double* retVal)
HRESULT put_UpperTol (double Value)

Applies to

IProperty1
PropertyAngle
PropertyLinearDimension
PropertyRadialDimension


PropertyGeometricTolerance

PropertyGeometricTolerance - object

Interfaces

IPropertyGeometricTolerance

Properties of IPropertyGeometricTolerance

Description | R/O |
Index | R/O | returns the index of this property in its parent collection
maxValue | R/W | get the maximum allowed deviation
Measured | R/O | set the actual measured deviation
Name | R/W |
OutputToReport | R/W |
OverRun | R/O | set the actual measured overrun
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |


maxValue

maxValue - Read & Write property

Description

get the maximum allowed deviation

Syntax in Visual Basic or VBScript

maxValue () As Double

Syntax in C++

HRESULT get_maxValue (double* retVal)
HRESULT put_maxValue (double Value)

Applies to

PropertyGeometricTolerance


Measured

Measured - Read property

Description

set the actual measured deviation

Syntax in Visual Basic or VBScript

Measured (measure As Variant) As Double

Syntax in C++

HRESULT get_Measured (VARIANT measure , double* retVal)

Applies to

PropertyGeometricTolerance


OverRun

OverRun - Read property

Description

set the actual measured overrun

Syntax in Visual Basic or VBScript

OverRun (measure As Variant) As Double

Syntax in C++

HRESULT get_OverRun (VARIANT measure , double* retVal)

Applies to

PropertyGeometricTolerance


PropertyLinearDimension

PropertyLinearDimension - object

Interfaces

IPropertyLinearDimension

Properties of IPropertyLinearDimension

Description | R/O |
Error | R/O | return the actual measured error for the given measure
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the lower tolerance for this property
Measured | R/O | return the actual measured value for the given measure
Name | R/W |
Nominal | R/W | get the nominal value of the property
OutputToReport | R/W |
OverRun | R/O | return the actual measured overrun for the given measure
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the upper tolerance for this property


PropertyPoint3D

PropertyPoint3D - object

Interfaces

IPropertyPoint3D

Methods of IPropertyPoint3D

SetLowerTolerances | set the 3 lower tolerance values
SetNominals | set the 3 nominal values
SetUpperTolerances | set the 3 upper tolerance values

Properties of IPropertyPoint3D

CoordinateType | R/O | prefered coordinate type ( cartesian, polar, spherical
Description | R/O |
Error | R/O | return the measured error ( also called deviation ) for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the Lower Tolerance value for the specified coordinate ( index = 0,1 or 2)
Measured | R/O | return the measured value for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
MeasuredCoord | T/O | get the measured coordinates for the given measure
Name | R/W |
Nominal | R/W | return the nominal value for the specified coordinate ( index = 0,1 or 2)
NominalCoord | R/W | get the nominal coordinates
OutputCoordToReport | R/W | return true if the specified coordinate is candidate to be printed in the Excel Report
OutputToReport | R/W |
OverRun | R/O | return the measured OVERUN ( if error is outof tolerance bounds) , for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the Upper Tolerance value for the specified coordinate ( index = 0,1 or 2)


CoordinateType

CoordinateType - Read property

Description

prefered coordinate type ( cartesian, polar, spherical

Syntax in Visual Basic or VBScript

CoordinateType () As ICoordFormatPoint3D

Syntax in C++

HRESULT get_CoordinateType (ICoordFormatPoint3D* retVal)

Applies to

PropertyPoint3D


Error

Error - Read property

Description

return the measured error ( also called deviation ) for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)

Syntax in Visual Basic or VBScript

Error (Index As Integer , measure As Variant) As Double

Syntax in C++

HRESULT get_Error (INT Index , VARIANT measure , double* retVal)

Applies to

IProperty3
PropertyPoint3D
PropertyUnitVector3D
PropertyVector3D


LowerTol

LowerTol - Read & Write property

Description

get the Lower Tolerance value for the specified coordinate ( index = 0,1 or 2)

Syntax in Visual Basic or VBScript

LowerTol (Index As Integer) As Double

Syntax in C++

HRESULT get_LowerTol (INT Index , double* retVal)
HRESULT put_LowerTol (INT Index , double Value)

Applies to

IProperty3
PropertyPoint3D
PropertyUnitVector3D
PropertyVector3D


Measured

Measured - Read property

Description

return the measured value for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)

Syntax in Visual Basic or VBScript

Measured (Index As Integer , measure As Variant) As Double

Syntax in C++

HRESULT get_Measured (INT Index , VARIANT measure , double* retVal)

Applies to

IProperty3
PropertyPoint3D
PropertyUnitVector3D
PropertyVector3D


MeasuredCoord

MeasuredCoord - Reference Write property

Description

get the measured coordinates for the given measure

Syntax in Visual Basic or VBScript

MeasuredCoord (measure As Variant) As Object

Syntax in C++

HRESULT get_MeasuredCoord (VARIANT measure , IDispatch** retVal)

Applies to

IProperty3
PropertyPoint3D
PropertyUnitVector3D
PropertyVector3D


Nominal

Nominal - Read & Write property

Description

return the nominal value for the specified coordinate ( index = 0,1 or 2)

Syntax in Visual Basic or VBScript

Nominal (Index As Integer) As Double

Syntax in C++

HRESULT get_Nominal (INT Index , double* retVal)
HRESULT put_Nominal (INT Index , double Value)

Applies to

IProperty3
PropertyPoint3D
PropertyUnitVector3D
PropertyVector3D


NominalCoord

NominalCoord - Read & Write property

Description

get the nominal coordinates

Syntax in Visual Basic or VBScript

NominalCoord () As Object

Syntax in C++

HRESULT get_NominalCoord (IDispatch** retVal)
HRESULT put_NominalCoord (VARIANT Value)

Applies to

IProperty3
PropertyPoint3D
PropertyUnitVector3D
PropertyVector3D


OutputCoordToReport

OutputCoordToReport - Read & Write property

Description

return true if the specified coordinate is candidate to be printed in the Excel Report

Syntax in Visual Basic or VBScript

OutputCoordToReport (Index As Integer) As Boolean

Syntax in C++

HRESULT get_OutputCoordToReport (INT Index , VARIANT_BOOL* retVal)
HRESULT put_OutputCoordToReport (INT Index , VARIANT_BOOL Value)

Applies to

IProperty3
PropertyPoint3D
PropertyUnitVector3D
PropertyVector3D


OverRun

OverRun - Read property

Description

return the measured OVERUN ( if error is outof tolerance bounds) , for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)

Syntax in Visual Basic or VBScript

OverRun (Index As Integer , measure As Variant) As Double

Syntax in C++

HRESULT get_OverRun (INT Index , VARIANT measure , double* retVal)

Applies to

IProperty3
PropertyPoint3D
PropertyUnitVector3D
PropertyVector3D


UpperTol

UpperTol - Read & Write property

Description

get the Upper Tolerance value for the specified coordinate ( index = 0,1 or 2)

Syntax in Visual Basic or VBScript

UpperTol (Index As Integer) As Double

Syntax in C++

HRESULT get_UpperTol (INT Index , double* retVal)
HRESULT put_UpperTol (INT Index , double Value)

Applies to

IProperty3
PropertyPoint3D
PropertyUnitVector3D
PropertyVector3D


SetLowerTolerances

SetLowerTolerances - method

Description

set the 3 lower tolerance values

Syntax in Visual Basic or VBScript

SetLowerTolerances (X As Double , Y As Double , Z As Double)

Syntax in C++

HRESULT SetLowerTolerances (double X , double Y , double Z)

Parameters

Name | Description
X |
Y |
Z |

Applies to

IProperty3


SetNominals

SetNominals - method

Description

set the 3 nominal values

Syntax in Visual Basic or VBScript

SetNominals (X As Double , Y As Double , Z As Double)

Syntax in C++

HRESULT SetNominals (double X , double Y , double Z)

Parameters

Name | Description
X |
Y |
Z |

Applies to

IProperty3


SetUpperTolerances

SetUpperTolerances - method

Description

set the 3 upper tolerance values

Syntax in Visual Basic or VBScript

SetUpperTolerances (X As Double , Y As Double , Z As Double)

Syntax in C++

HRESULT SetUpperTolerances (double X , double Y , double Z)

Parameters

Name | Description
X |
Y |
Z |

Applies to

IProperty3


PropertyRadialDimension

PropertyRadialDimension - object

Interfaces

IPropertyRadialDimension

Methods of IPropertyRadialDimension

ConvertTo change the type of the radial dimension, by changing the nominal value accordingly

Properties of IPropertyRadialDimension

Description | R/O |
Error | R/O | return the actual measured error for the given measure
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the lower tolerance for this property
Measured | R/O | return the actual measured value for the given measure
Name | R/W |
Nominal | R/W | get the nominal value of the property
OutputToReport | R/W |
OverRun | R/O | return the actual measured overrun for the given measure
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
RadialDimensionType | R/W | change the type of the radial dimension, by preseving the nominal value
UpperTol | R/W | get the upper tolerance for this property


RadialDimensionType

RadialDimensionType - Read & Write property

Description

change the type of the radial dimension, by preseving the nominal value

Syntax in Visual Basic or VBScript

RadialDimensionType () As PWI_RadialDimensionType

Syntax in C++

HRESULT get_RadialDimensionType (PWI_RadialDimensionType* retVal)
HRESULT put_RadialDimensionType (PWI_RadialDimensionType Value)

Applies to

PropertyRadialDimension


ConvertTo

ConvertTo - method

Description

change the type of the radial dimension, by changing the nominal value accordingly

Syntax in Visual Basic or VBScript

ConvertTo (type As PWI_RadialDimensionType)

Syntax in C++

HRESULT ConvertTo (PWI_RadialDimensionType type)

Parameters

Name | Description
type |

Applies to

PropertyRadialDimension


PropertyUnitVector3D

PropertyUnitVector3D - object

Interfaces

IPropertyUnitVector3D

Methods of IPropertyUnitVector3D

SetLowerTolerances | set the 3 lower tolerance values
SetNominals | set the 3 nominal values
SetUpperTolerances | set the 3 upper tolerance values

Properties of IPropertyUnitVector3D

CoordinateType | R/O | prefered coordinate system
Description | R/O |
Error | R/O | return the measured error ( also called deviation ) for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the Lower Tolerance value for the specified coordinate ( index = 0,1 or 2)
Measured | R/O | return the measured value for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
MeasuredCoord | T/O | get the measured coordinates for the given measure
Name | R/W |
Nominal | R/W | return the nominal value for the specified coordinate ( index = 0,1 or 2)
NominalCoord | R/W | get the nominal coordinates
OutputCoordToReport | R/W | return true if the specified coordinate is candidate to be printed in the Excel Report
OutputToReport | R/W |
OverRun | R/O | return the measured OVERUN ( if error is outof tolerance bounds) , for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the Upper Tolerance value for the specified coordinate ( index = 0,1 or 2)


CoordinateType

CoordinateType - Read property

Description

prefered coordinate system

Syntax in Visual Basic or VBScript

CoordinateType () As ICoordFormatUnitVector3D

Syntax in C++

HRESULT get_CoordinateType (ICoordFormatUnitVector3D* retVal)

Applies to

PropertyUnitVector3D
PropertyVector3D


PropertyVector3D

PropertyVector3D - object

Interfaces

IPropertyVector3D

Methods of IPropertyVector3D

SetLowerTolerances | set the 3 lower tolerance values
SetNominals | set the 3 nominal values
SetUpperTolerances | set the 3 upper tolerance values

Properties of IPropertyVector3D

CoordinateType | R/O | prefered coordinate system
Description | R/O |
Error | R/O | return the measured error ( also called deviation ) for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the Lower Tolerance value for the specified coordinate ( index = 0,1 or 2)
Measured | R/O | return the measured value for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
MeasuredCoord | T/O | get the measured coordinates for the given measure
Name | R/W |
Nominal | R/W | return the nominal value for the specified coordinate ( index = 0,1 or 2)
NominalCoord | R/W | get the nominal coordinates
OutputCoordToReport | R/W | return true if the specified coordinate is candidate to be printed in the Excel Report
OutputToReport | R/W |
OverRun | R/O | return the measured OVERUN ( if error is outof tolerance bounds) , for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the Upper Tolerance value for the specified coordinate ( index = 0,1 or 2)


ProtocolConnector

ProtocolConnector - object


rbDHTMLBridge

rbDHTMLBridge - object

Description

rbDHTMLBridge Class

Interfaces

IrbDHTMLBridge

Methods of IrbDHTMLBridge

EnableModeless |
FilterDataObject |
GetDropTarget |
GetExternal |
GetHostInfo |
GetOptionKeyPath |
HideUI |
LocalizeString | Returns localised string if possible
OnDocWindowActivate |
OnElementClicked | Informs the engine that an element is clicked
OnFrameWindowActivate |
ReportParameters | Returns XML reported by report engine about settings of report
ResizeBorder |
set_export_info | method set_export_info
set_page_settings | method set_page_settings
ShowContextMenu |
ShowUI |
tm_getConfig | method tm_getConfig
tm_getConfigLocation | method tm_getConfigLocation
tm_getParameters | Returns the available collection of id's as an XML document
tm_getStyles | method tm_getStyle
tm_getTemplate | method tm_getTemplate
tm_getTemplateNoCache | returns a template as it is stored
tm_init | method tm_init
tm_locate_file | method tm_locate_file
tm_saveTemplate | Saves the provided template with the provided name
TranslateAccelerator |
TranslateUrl |
UpdateUI |

Properties of IrbDHTMLBridge

Debug | R/O | Retrieve the debugging mode
Editing | R/O | Retrieve the editing mode
PIXmlDocument | T/O | property
ReportCompleted | R/W | Property ReportCompleted. To be set by the report composer engine (currently scripting) when a report is completed and ready to use.
ReportCustomiserEngine | T/O | property ReportCustomiserEngine
ReportDocument | T/O | property ReportDocument
templatesManager | T/O | property templatesManager
tm_error_str | R/O | property tm_error_str
tm_initialized | R/O | property tm_initialized
tm_MaximumTimeout | R/W | Configures maximum time for report creation, milliseconds


Debug

Debug - Read property

Description

Retrieve the debugging mode

Syntax in Visual Basic or VBScript

Debug () As Boolean

Syntax in C++

HRESULT get_Debug (VARIANT_BOOL* retVal)

Applies to

rbDHTMLBridge


Editing

Editing - Read property

Description

Retrieve the editing mode

Syntax in Visual Basic or VBScript

Editing () As Boolean

Syntax in C++

HRESULT get_Editing (VARIANT_BOOL* retVal)

Applies to

rbDHTMLBridge


PIXmlDocument

PIXmlDocument - Reference Write property

Description

property

Syntax in Visual Basic or VBScript

PIXmlDocument () As Object

Syntax in C++

HRESULT get_PIXmlDocument (IDispatch** retVal)

Applies to

rbDHTMLBridge


ReportCompleted

ReportCompleted - Read & Write property

Description

Property ReportCompleted. To be set by the report composer engine (currently scripting) when a report is completed and ready to use.

Syntax in Visual Basic or VBScript

ReportCompleted () As Long

Syntax in C++

HRESULT get_ReportCompleted (LONG* retVal)
HRESULT put_ReportCompleted (LONG Value)

Applies to

rbDHTMLBridge


ReportCustomiserEngine

ReportCustomiserEngine - Reference Write property

Description

property ReportCustomiserEngine

Syntax in Visual Basic or VBScript

ReportCustomiserEngine () As Object

Syntax in C++

HRESULT get_ReportCustomiserEngine (IDispatch** retVal)

Applies to

rbDHTMLBridge


ReportDocument

ReportDocument - Reference Write property

Description

property ReportDocument

Syntax in Visual Basic or VBScript

ReportDocument () As Object

Syntax in C++

HRESULT get_ReportDocument (IDispatch** retVal)

Applies to

rbDHTMLBridge


templatesManager

templatesManager - Reference Write property

Description

property templatesManager

Syntax in Visual Basic or VBScript

templatesManager () As Object

Syntax in C++

HRESULT get_templatesManager (IDispatch** retVal)

Applies to

rbDHTMLBridge


tm_error_str

tm_error_str - Read property

Description

property tm_error_str

Syntax in Visual Basic or VBScript

tm_error_str () As String

Syntax in C++

HRESULT get_tm_error_str (BSTR* retVal)

Applies to

rbDHTMLBridge


tm_initialized

tm_initialized - Read property

Description

property tm_initialized

Syntax in Visual Basic or VBScript

tm_initialized () As Long

Syntax in C++

HRESULT get_tm_initialized (LONG* retVal)

Applies to

rbDHTMLBridge


tm_MaximumTimeout

tm_MaximumTimeout - Read & Write property

Description

Configures maximum time for report creation, milliseconds

Syntax in Visual Basic or VBScript

tm_MaximumTimeout () As Long

Syntax in C++

HRESULT get_tm_MaximumTimeout (LONG* retVal)
HRESULT put_tm_MaximumTimeout (LONG Value)

Applies to

rbDHTMLBridge


EnableModeless

EnableModeless - method

Syntax in Visual Basic or VBScript

EnableModeless (fEnable As Boolean)

Syntax in C++

HRESULT EnableModeless (VARIANT_BOOL fEnable)

Parameters

Name | Description
fEnable |

Applies to

rbDHTMLBridge


FilterDataObject

FilterDataObject - method

Syntax in Visual Basic or VBScript

FilterDataObject (pDO As Object , ByRef ppDORet As Object)

Syntax in C++

HRESULT FilterDataObject (IUnknow* pDO , IUnknow** ppDORet)

Parameters

Name | Description
pDO |
ppDORet |

Applies to

rbDHTMLBridge


GetDropTarget

GetDropTarget - method

Syntax in Visual Basic or VBScript

GetDropTarget (pDropTarget As Object , ByRef ppDropTarget As Object)

Syntax in C++

HRESULT GetDropTarget (IUnknow* pDropTarget , IUnknow** ppDropTarget)

Parameters

Name | Description
pDropTarget |
ppDropTarget |

Applies to

rbDHTMLBridge


GetExternal

GetExternal - method

Syntax in Visual Basic or VBScript

GetExternal (ByRef ppDispatch As Object)

Syntax in C++

HRESULT GetExternal (IDispatch** ppDispatch)

Parameters

Name | Description
ppDispatch |

Applies to

rbDHTMLBridge


GetHostInfo

GetHostInfo - method

Syntax in Visual Basic or VBScript

GetHostInfo (ByRef pdwFlags As Long , ByRef pdwDoubleClick As Long)

Syntax in C++

HRESULT GetHostInfo (ULONG* pdwFlags , ULONG* pdwDoubleClick)

Parameters

Name | Description
pdwFlags |
pdwDoubleClick |

Applies to

rbDHTMLBridge


GetOptionKeyPath

GetOptionKeyPath - method

Syntax in Visual Basic or VBScript

GetOptionKeyPath (ByRef pbstrKey As String , dw As Long)

Syntax in C++

HRESULT GetOptionKeyPath (BSTR* pbstrKey , ULONG dw)

Parameters

Name | Description
pbstrKey |
dw |

Applies to

rbDHTMLBridge


HideUI

HideUI - method

Syntax in Visual Basic or VBScript

HideUI ()

Syntax in C++

HRESULT HideUI ()

Applies to

rbDHTMLBridge


LocalizeString

LocalizeString - method

Description

Returns localised string if possible

Syntax in Visual Basic or VBScript

LocalizeString (a_string_in As String) As String

Syntax in C++

HRESULT LocalizeString (BSTR a_string_in , BSTR* retVal)

Parameters

Name | Description
a_string_in |
Return Value |

Applies to

rbDHTMLBridge


OnDocWindowActivate

OnDocWindowActivate - method

Syntax in Visual Basic or VBScript

OnDocWindowActivate (fActivate As Boolean)

Syntax in C++

HRESULT OnDocWindowActivate (VARIANT_BOOL fActivate)

Parameters

Name | Description
fActivate |

Applies to

rbDHTMLBridge


OnElementClicked

OnElementClicked - method

Description

Informs the engine that an element is clicked

Syntax in Visual Basic or VBScript

OnElementClicked (a_event As Object)

Syntax in C++

HRESULT OnElementClicked (IDispatch* a_event)

Parameters

Name | Description
a_event |

Applies to

rbDHTMLBridge


OnFrameWindowActivate

OnFrameWindowActivate - method

Syntax in Visual Basic or VBScript

OnFrameWindowActivate (fActivate As Boolean)

Syntax in C++

HRESULT OnFrameWindowActivate (VARIANT_BOOL fActivate)

Parameters

Name | Description
fActivate |

Applies to

rbDHTMLBridge


ReportParameters

ReportParameters - method

Description

Returns XML reported by report engine about settings of report

Syntax in Visual Basic or VBScript

ReportParameters (a_item_id As String) As String

Syntax in C++

HRESULT ReportParameters (BSTR a_item_id , BSTR* retVal)

Parameters

Name | Description
a_item_id |
Return Value |

Applies to

rbDHTMLBridge


ResizeBorder

ResizeBorder - method

Syntax in Visual Basic or VBScript

ResizeBorder (left As Long , top As Long , right As Long , bottom As Long , pUIWindow As Object , fFrameWindow As Boolean)

Syntax in C++

HRESULT ResizeBorder (LONG left , LONG top , LONG right , LONG bottom , IUnknow* pUIWindow , VARIANT_BOOL fFrameWindow)

Parameters

Name | Description
left |
top |
right |
bottom |
pUIWindow |
fFrameWindow |

Applies to

rbDHTMLBridge


set_export_info

set_export_info - method

Description

method set_export_info

Syntax in Visual Basic or VBScript

set_export_info (a_node As Object , a_styles As Object)

Syntax in C++

HRESULT set_export_info (IDispatch* a_node , IDispatch* a_styles)

Parameters

Name | Description
a_node |
a_styles |

Applies to

rbDHTMLBridge


set_page_settings

set_page_settings - method

Description

method set_page_settings

Syntax in Visual Basic or VBScript

set_page_settings ()

Syntax in C++

HRESULT set_page_settings ()

Applies to

rbDHTMLBridge


ShowContextMenu

ShowContextMenu - method

Syntax in Visual Basic or VBScript

ShowContextMenu (dwID As Long , x As Long , y As Long , pcmdtReserved As Object , pdispReserved As Object)

Syntax in C++

HRESULT ShowContextMenu (ULONG dwID , ULONG x , ULONG y , IUnknow* pcmdtReserved , IDispatch* pdispReserved , HRESULT* retVal)

Parameters

Name | Description
dwID |
x |
y |
pcmdtReserved |
pdispReserved |

Applies to

rbDHTMLBridge


ShowUI

ShowUI - method

Syntax in Visual Basic or VBScript

ShowUI (dwID As Long , pActiveObject As Object , pCommandTarget As Object , pFrame As Object , pDoc As Object)

Syntax in C++

HRESULT ShowUI (ULONG dwID , IUnknow* pActiveObject , IUnknow* pCommandTarget , IUnknow* pFrame , IUnknow* pDoc , HRESULT* retVal)

Parameters

Name | Description
dwID |
pActiveObject |
pCommandTarget |
pFrame |
pDoc |

Applies to

rbDHTMLBridge


tm_getConfig

tm_getConfig - method

Description

method tm_getConfig

Syntax in Visual Basic or VBScript

tm_getConfig (a_id_of_template As String , a_parameters As Variant) As Object

Syntax in C++

HRESULT tm_getConfig (BSTR a_id_of_template , VARIANT a_parameters , IDispatch** retVal)

Parameters

Name | Description
a_id_of_template |
a_parameters |
Return Value |

Applies to

rbDHTMLBridge


tm_getConfigLocation

tm_getConfigLocation - method

Description

method tm_getConfigLocation

Syntax in Visual Basic or VBScript

tm_getConfigLocation () As String

Syntax in C++

HRESULT tm_getConfigLocation (BSTR* retVal)

Parameters

Name | Description
Return Value |

Applies to

rbDHTMLBridge


tm_getParameters

tm_getParameters - method

Description

Returns the available collection of id's as an XML document

Syntax in Visual Basic or VBScript

tm_getParameters () As Object

Syntax in C++

HRESULT tm_getParameters (IDispatch** retVal)

Parameters

Name | Description
Return Value |

Applies to

rbDHTMLBridge


tm_getStyles

tm_getStyles - method

Description

method tm_getStyle

Syntax in Visual Basic or VBScript

tm_getStyles () As Object

Syntax in C++

HRESULT tm_getStyles (IDispatch** retVal)

Parameters

Name | Description
Return Value |

Applies to

rbDHTMLBridge


tm_getTemplate

tm_getTemplate - method

Description

method tm_getTemplate

Syntax in Visual Basic or VBScript

tm_getTemplate (id_of_template As String , a_parameters As Variant) As Object

Syntax in C++

HRESULT tm_getTemplate (BSTR id_of_template , VARIANT a_parameters , IDispatch** retVal)

Parameters

Name | Description
id_of_template |
a_parameters |
Return Value |

Applies to

rbDHTMLBridge


tm_getTemplateNoCache

tm_getTemplateNoCache - method

Description

returns a template as it is stored

Syntax in Visual Basic or VBScript

tm_getTemplateNoCache (a_template_name As String , a_parameters As Variant) As Object

Syntax in C++

HRESULT tm_getTemplateNoCache (BSTR a_template_name , VARIANT a_parameters , IDispatch** retVal)

Parameters

Name | Description
a_template_name |
a_parameters |
Return Value |

Applies to

rbDHTMLBridge


tm_init

tm_init - method

Description

method tm_init

Syntax in Visual Basic or VBScript

tm_init (html_doc As Object)

Syntax in C++

HRESULT tm_init (IDispatch* html_doc)

Parameters

Name | Description
html_doc |

Applies to

rbDHTMLBridge


tm_locate_file

tm_locate_file - method

Description

method tm_locate_file

Syntax in Visual Basic or VBScript

tm_locate_file (a_filename As String) As String

Syntax in C++

HRESULT tm_locate_file (BSTR a_filename , BSTR* retVal)

Parameters

Name | Description
a_filename |
Return Value |

Applies to

rbDHTMLBridge


tm_saveTemplate

tm_saveTemplate - method

Description

Saves the provided template with the provided name

Syntax in Visual Basic or VBScript

tm_saveTemplate (a_template_name As String , a_template_html As String , a_parameters As Variant)

Syntax in C++

HRESULT tm_saveTemplate (BSTR a_template_name , BSTR a_template_html , VARIANT a_parameters)

Parameters

Name | Description
a_template_name |
a_template_html |
a_parameters |

Applies to

rbDHTMLBridge


TranslateAccelerator

TranslateAccelerator - method

Syntax in Visual Basic or VBScript

TranslateAccelerator (hWnd As ULONG_PTR , nMessage As Long , wParam As ULONG_PTR , lParam As ULONG_PTR , bstrGuidCmdGroup As String , nCmdID As Long)

Syntax in C++

HRESULT TranslateAccelerator (ULONG_PTR hWnd , ULONG nMessage , ULONG_PTR wParam , ULONG_PTR lParam , BSTR bstrGuidCmdGroup , ULONG nCmdID , HRESULT* retVal)

Parameters

Name | Description
hWnd |
nMessage |
wParam |
lParam |
bstrGuidCmdGroup |
nCmdID |

Applies to

rbDHTMLBridge


TranslateUrl

TranslateUrl - method

Syntax in Visual Basic or VBScript

TranslateUrl (dwTranslate As Long , bstrURLIn As String , ByRef pbstrURLOut As String)

Syntax in C++

HRESULT TranslateUrl (ULONG dwTranslate , BSTR bstrURLIn , BSTR* pbstrURLOut)

Parameters

Name | Description
dwTranslate |
bstrURLIn |
pbstrURLOut |

Applies to

rbDHTMLBridge


UpdateUI

UpdateUI - method

Syntax in Visual Basic or VBScript

UpdateUI ()

Syntax in C++

HRESULT UpdateUI ()

Applies to

rbDHTMLBridge


rbReportVariables

rbReportVariables - object

Description

rbReportVariables Class

Interfaces

IrbReportVariables

Properties of IrbReportVariables

length | R/O | property length
name | R/O | property name
value | R/O | property value


length

length - Read property

Description

property length

Syntax in Visual Basic or VBScript

length () As Long

Syntax in C++

HRESULT get_length (LONG* retVal)

Applies to

rbReportVariables


name

name - Read property

Description

property name

Syntax in Visual Basic or VBScript

name (a_index As Long) As String

Syntax in C++

HRESULT get_name (LONG a_index , BSTR* retVal)

Applies to

rbReportVariables


value

value - Read property

Description

property value

Syntax in Visual Basic or VBScript

value (a_index As Long) As String

Syntax in C++

HRESULT get_value (LONG a_index , BSTR* retVal)

Applies to

rbReportVariables


rbTemplatesManager

rbTemplatesManager - object

Description

rbTemplatesManager Class

Interfaces

IrbTemplatesManager

Methods of IrbTemplatesManager

client_add | method client_add
client_set_html_document | method client_set_html_document
client_set_template | method client_set_template
extract_variables | method extract_variables
getConfig | method getConfig
getParameters | Returns the available collection of id's as an XML document
getStyles | method getStyles
getTemplate | method getTemplate
getTemplateNoCache | returns a template as it is stored
locate_file | method locate_file
saveTemplate | Saves the provided template with the provided name

Properties of IrbTemplatesManager

config_location | R/O | property config_location
error_str | R/O | property error_str
initialized | R/O | property initialized
ReportConfigName | R/O | method ReportConfigName


config_location

config_location - Read property

Description

property config_location

Syntax in Visual Basic or VBScript

config_location (cookies As Long) As String

Syntax in C++

HRESULT get_config_location (LONG cookies , BSTR* retVal)

Applies to

rbTemplatesManager


error_str

error_str - Read property

Description

property error_str

Syntax in Visual Basic or VBScript

error_str (cookies As Long) As String

Syntax in C++

HRESULT get_error_str (LONG cookies , BSTR* retVal)

Applies to

rbTemplatesManager


initialized

initialized - Read property

Description

property initialized

Syntax in Visual Basic or VBScript

initialized (cookies As Long) As Long

Syntax in C++

HRESULT get_initialized (LONG cookies , LONG* retVal)

Applies to

rbTemplatesManager


ReportConfigName

ReportConfigName - Read property

Description

method ReportConfigName

Syntax in Visual Basic or VBScript

ReportConfigName (a_cookies As Long) As String

Syntax in C++

HRESULT get_ReportConfigName (LONG a_cookies , BSTR* retVal)

Applies to

rbTemplatesManager


client_add

client_add - method

Description

method client_add

Syntax in Visual Basic or VBScript

client_add () As Long

Syntax in C++

HRESULT client_add (LONG* retVal)

Parameters

Name | Description
Return Value |

Applies to

rbTemplatesManager


client_set_html_document

client_set_html_document - method

Description

method client_set_html_document

Syntax in Visual Basic or VBScript

client_set_html_document (cookies As Long , html_document As Object)

Syntax in C++

HRESULT client_set_html_document (LONG cookies , IDispatch* html_document)

Parameters

Name | Description
cookies |
html_document |

Applies to

rbTemplatesManager


client_set_template

client_set_template - method

Description

method client_set_template

Syntax in Visual Basic or VBScript

client_set_template (cookies As Long , template_filename As String)

Syntax in C++

HRESULT client_set_template (LONG cookies , BSTR template_filename)

Parameters

Name | Description
cookies |
template_filename |

Applies to

rbTemplatesManager


extract_variables

extract_variables - method

Description

method extract_variables

Syntax in Visual Basic or VBScript

extract_variables (a_config_filename As String) As rbReportVariables

Syntax in C++

HRESULT extract_variables (BSTR a_config_filename , rbReportVariables* retVal)

Parameters

Name | Description
a_config_filename |
Return Value |

Applies to

rbTemplatesManager


getConfig

getConfig - method

Description

method getConfig

Syntax in Visual Basic or VBScript

getConfig (cookies As Long , a_name_of_template As String , a_parameters As Object) As Object

Syntax in C++

HRESULT getConfig (LONG cookies , BSTR a_name_of_template , IDispatch* a_parameters , IDispatch** retVal)

Parameters

Name | Description
cookies |
a_name_of_template |
a_parameters |
Return Value |

Applies to

rbTemplatesManager


getParameters

getParameters - method

Description

Returns the available collection of id's as an XML document

Syntax in Visual Basic or VBScript

getParameters (a_cookies As Long) As Object

Syntax in C++

HRESULT getParameters (LONG a_cookies , IDispatch** retVal)

Parameters

Name | Description
a_cookies |
Return Value |

Applies to

rbTemplatesManager


getStyles

getStyles - method

Description

method getStyles

Syntax in Visual Basic or VBScript

getStyles (cookies As Long) As Object

Syntax in C++

HRESULT getStyles (LONG cookies , IDispatch** retVal)

Parameters

Name | Description
cookies |
Return Value |

Applies to

rbTemplatesManager


getTemplate

getTemplate - method

Description

method getTemplate

Syntax in Visual Basic or VBScript

getTemplate (cookies As Long , a_name_of_template As String , a_parameters As Object) As Object

Syntax in C++

HRESULT getTemplate (LONG cookies , BSTR a_name_of_template , IDispatch* a_parameters , IDispatch** retVal)

Parameters

Name | Description
cookies |
a_name_of_template |
a_parameters |
Return Value |

Applies to

rbTemplatesManager


getTemplateNoCache

getTemplateNoCache - method

Description

returns a template as it is stored

Syntax in Visual Basic or VBScript

getTemplateNoCache (a_cookies As Long , a_template_name As String , a_parameters As Variant) As Object

Syntax in C++

HRESULT getTemplateNoCache (LONG a_cookies , BSTR a_template_name , VARIANT a_parameters , IDispatch** retVal)

Parameters

Name | Description
a_cookies |
a_template_name |
a_parameters |
Return Value |

Applies to

rbTemplatesManager


locate_file

locate_file - method

Description

method locate_file

Syntax in Visual Basic or VBScript

locate_file (cookies As Long , a_filename As String) As String

Syntax in C++

HRESULT locate_file (LONG cookies , BSTR a_filename , BSTR* retVal)

Parameters

Name | Description
cookies |
a_filename |
Return Value |

Applies to

rbTemplatesManager


saveTemplate

saveTemplate - method

Description

Saves the provided template with the provided name

Syntax in Visual Basic or VBScript

saveTemplate (a_cookies As Long , a_template_name As String , a_template_html As String , a_parameters As Variant)

Syntax in C++

HRESULT saveTemplate (LONG a_cookies , BSTR a_template_name , BSTR a_template_html , VARIANT a_parameters)

Parameters

Name | Description
a_cookies |
a_template_name |
a_template_html |
a_parameters |

Applies to

rbTemplatesManager


RegPropertyBag

RegPropertyBag - object

Description

Property bag class for storing properties in the registry.

Interfaces

IRegPropertyBag

Methods of IRegPropertyBag

Close | Closes the registry key.
Flush | Performs a flush on the open registry key.
Open | Opens a registry key to store properties in.
OpenSubKey | Opens a subkey of the open registry key.
Read | Reads a property from the open registry key.
ReadObjectAsBinaryStream | Initialises an instance of an object from a binary stream in the open registry key.
Write | Writes a property to the open registry key.
WriteObjectAsBinaryStream | Writes an object as a binary stream to the open registry key.

Properties of IRegPropertyBag

hKey | R/W | The handle to the open registry key. THIS PROPERTY SHOULD BE USED WITH CARE!
KeyOpen | R/O | True if the object has an open registry key.


hKey

hKey - Read & Write property

Description

The handle to the open registry key. THIS PROPERTY SHOULD BE USED WITH CARE!

Syntax in Visual Basic or VBScript

hKey () As Long

Syntax in C++

HRESULT get_hKey (LONG* retVal)
HRESULT put_hKey (LONG Value)

Applies to

RegPropertyBag


KeyOpen

KeyOpen - Read property

Description

True if the object has an open registry key.

Syntax in Visual Basic or VBScript

KeyOpen () As Boolean

Syntax in C++

HRESULT get_KeyOpen (VARIANT_BOOL* retVal)

Applies to

RegPropertyBag


Close

Close - method

Description

Closes the registry key.

Syntax in Visual Basic or VBScript

Close ()

Syntax in C++

HRESULT Close ()

Applies to

RegPropertyBag


Flush

Flush - method

Description

Performs a flush on the open registry key.

Syntax in Visual Basic or VBScript

Flush ()

Syntax in C++

HRESULT Flush ()

Applies to

RegPropertyBag


Open

Open - method

Description

Opens a registry key to store properties in.

Syntax in Visual Basic or VBScript

Open (Root As String , SubKey As String)

Syntax in C++

HRESULT Open (BSTR Root , BSTR SubKey)

Parameters

Name | Description
Root |
SubKey |

Applies to

RegPropertyBag


OpenSubKey

OpenSubKey - method

Description

Opens a subkey of the open registry key.

Syntax in Visual Basic or VBScript

OpenSubKey (SubKey As String) As RegPropertyBag

Syntax in C++

HRESULT OpenSubKey (BSTR SubKey , RegPropertyBag* retVal)

Parameters

Name | Description
SubKey |
Return Value |

Applies to

RegPropertyBag


Read

Read - method

Description

Reads a property from the open registry key.

Syntax in Visual Basic or VBScript

Read (PropName As String , ByRef Value As Variant , CreateIfDoesntExist As Boolean)

Syntax in C++

HRESULT Read (BSTR PropName , VARIANT* Value , VARIANT_BOOL CreateIfDoesntExist)

Parameters

Name | Description
PropName |
Value |
CreateIfDoesntExist |

Applies to

RegPropertyBag


ReadObjectAsBinaryStream

ReadObjectAsBinaryStream - method

Description

Initialises an instance of an object from a binary stream in the open registry key.

Syntax in Visual Basic or VBScript

ReadObjectAsBinaryStream (PropName As String , Object As Object , InitIfDoesntExist As Boolean)

Syntax in C++

HRESULT ReadObjectAsBinaryStream (BSTR PropName , IUnknow* Object , VARIANT_BOOL InitIfDoesntExist)

Parameters

Name | Description
PropName |
Object |
InitIfDoesntExist |

Applies to

RegPropertyBag


Write

Write - method

Description

Writes a property to the open registry key.

Syntax in Visual Basic or VBScript

Write (PropName As String , ByRef Value As Variant)

Syntax in C++

HRESULT Write (BSTR PropName , VARIANT* Value)

Parameters

Name | Description
PropName |
Value |

Applies to

RegPropertyBag


WriteObjectAsBinaryStream

WriteObjectAsBinaryStream - method

Description

Writes an object as a binary stream to the open registry key.

Syntax in Visual Basic or VBScript

WriteObjectAsBinaryStream (PropName As String , Object As Object)

Syntax in C++

HRESULT WriteObjectAsBinaryStream (BSTR PropName , IUnknow* Object)

Parameters

Name | Description
PropName |
Object |

Applies to

RegPropertyBag


ReportVariable

ReportVariable - object

Interfaces

IReportVariable

Properties of IReportVariable

ID | R/O | property ID
Name | R/W |
Value | R/W |


ID

ID - Read property

Description

property ID

Syntax in Visual Basic or VBScript

ID () As Integer

Syntax in C++

HRESULT get_ID (INT* retVal)

Applies to

ReportVariable


ReportVariables

ReportVariables - object

Interfaces

IReportVariables

Properties of IReportVariables

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual ReportVariable within the collection. Index can be an ordinal from 1 to Count or a string


Item

Item - Read property

Description

Allows random access to individual ReportVariable within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As ReportVariable

Syntax in C++

HRESULT get_Item (VARIANT Index , ReportVariable* retVal)

Applies to

ReportVariables


RPSConstraint

RPSConstraint - object

Interfaces

IRPSConstraint

Properties of IRPSConstraint

Feature | R/W | set/retrieve the constrained feature
Index | R/O | index of the constraint
LockDirection | R/W | set/retrieve the lock state for plane /axis
LockX | R/W | set/retrieve the X coordinate lock state
LockY | R/W | set/retrieve the Y coordinate lock state
LockZ | R/W | set/retrieve the Z coordinate lock state
point | R/O | returns the nominal coordinates of the point in the RPS localDatum
type | R/O | Constraint type


Feature

Feature - Read & Write property

Description

set/retrieve the constrained feature

Syntax in Visual Basic or VBScript

Feature () As Feature

Syntax in C++

HRESULT get_Feature (Feature* retVal)
HRESULT put_Feature (Feature* Value)

Applies to

RPSConstraint


Index

Index - Read property

Description

index of the constraint

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

RPSConstraint


LockDirection

LockDirection - Read & Write property

Description

set/retrieve the lock state for plane /axis

Syntax in Visual Basic or VBScript

LockDirection () As PWI_RPSDirectionLock

Syntax in C++

HRESULT get_LockDirection (PWI_RPSDirectionLock* retVal)
HRESULT put_LockDirection (PWI_RPSDirectionLock Value)

Applies to

RPSConstraint


LockX

LockX - Read & Write property

Description

set/retrieve the X coordinate lock state

Syntax in Visual Basic or VBScript

LockX () As Boolean

Syntax in C++

HRESULT get_LockX (VARIANT_BOOL* retVal)
HRESULT put_LockX (VARIANT_BOOL Value)

Applies to

RPSConstraint


LockY

LockY - Read & Write property

Description

set/retrieve the Y coordinate lock state

Syntax in Visual Basic or VBScript

LockY () As Boolean

Syntax in C++

HRESULT get_LockY (VARIANT_BOOL* retVal)
HRESULT put_LockY (VARIANT_BOOL Value)

Applies to

RPSConstraint


LockZ

LockZ - Read & Write property

Description

set/retrieve the Z coordinate lock state

Syntax in Visual Basic or VBScript

LockZ () As Boolean

Syntax in C++

HRESULT get_LockZ (VARIANT_BOOL* retVal)
HRESULT put_LockZ (VARIANT_BOOL Value)

Applies to

RPSConstraint


point

point - Read property

Description

returns the nominal coordinates of the point in the RPS localDatum

Syntax in Visual Basic or VBScript

point () As Point3D

Syntax in C++

HRESULT get_point (Point3D* retVal)

Applies to

RPSConstraint


type

type - Read property

Description

Constraint type

Syntax in Visual Basic or VBScript

type () As PWI_RPSConstraintType

Syntax in C++

HRESULT get_type (PWI_RPSConstraintType* retVal)

Applies to

RPSConstraint


ScanItem

ScanItem - object

Description

ScanItem Class

Interfaces

IScanItem

Properties of IScanItem

ScanItemFormat | R/O | The scan item format.
SurfacePoint | R/O | The surface point in the scanning path.
SurfaceVector | R/O | The nominal surface vector at the surface point.
Tag | R/W | Integer defining if the nth nominal point is assumed to be on the part surface (+1) or without contact to the surface (-1).


ScanItems

ScanItems - object

Description

ScanItems Class

Interfaces

IScanItems

Methods of IScanItems

Clear | Remove all the scan items.
InsertScanItem | Insert an ordinary scan-item.
InsertScanItemWithPrimary | Insert a scan-item which contains a primary tool-vector.
InsertScanItemWithSecondary | Insert a scan-item which contains a both a primary and secondary tool-vector.
Remove | Remove the item at the specified position

Properties of IScanItems

Count | R/O | The number of scan-items
Item | R/O | Get the scan-item at the given index


ScanItemWithPrimary

ScanItemWithPrimary - object

Description

ScanItemWithPrimary Class

Interfaces

IScanItemWithPrimary

Properties of IScanItemWithPrimary

PrimaryToolDirection | R/O | The primary tool vector.
ScanItemFormat | R/O | The scan item format.
SurfacePoint | R/O | The surface point in the scanning path.
SurfaceVector | R/O | The nominal surface vector at the surface point.
Tag | R/W | Integer defining if the nth nominal point is assumed to be on the part surface (+1) or without contact to the surface (-1).


ScanItemWithSecondary

ScanItemWithSecondary - object

Description

ScanItemWithSecondary Class

Interfaces

IScanItemWithSecondary

Properties of IScanItemWithSecondary

PrimaryToolDirection | R/O | The primary tool vector.
ScanItemFormat | R/O | The scan item format.
SecondaryToolDirection | R/O | The secondary tool vector.
SurfacePoint | R/O | The surface point in the scanning path.
SurfaceVector | R/O | The nominal surface vector at the surface point.
Tag | R/W | Integer defining if the nth nominal point is assumed to be on the part surface (+1) or without contact to the surface (-1).


ScanOnCircle

ScanOnCircle - object

Description

ScanOnCircle Class

Interfaces

IScanOnCircle

Methods of IScanOnCircle

Copy | Copy the parameter object data to this object.
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.

Properties of IScanOnCircle

AngleToScan | R/W | The angle to scan.
Centre | R/O | The nominal centre point of the circle.
CoordinateSystem | R/W | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
Displacement | R/W | The maximum expected distance between the nominal circle center and the actual circle center.
Form | R/W | The maximum expected form deviation of the Gauss calculated circle.
Normal | R/O | The normal vector of the circle plane.
ScanInstructionType | R/O | The scan item-type.
ScanStart | R/O | The point on the circle radius where the scan starts.
StepW | R/W | The average angular distance between 2 measured points in degrees.
SurfaceAngle | R/W | The surface angle of the circle.

Collections of IScanOnCircle

PredictedPath Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.


AngleToScan

AngleToScan - Read & Write property

Description

The angle to scan.

Syntax in Visual Basic or VBScript

AngleToScan () As Double

Syntax in C++

HRESULT get_AngleToScan (double* retVal)
HRESULT put_AngleToScan (double Value)

Applies to

ScanOnCircle
ScanOnHelix


Centre

Centre - Read property

Description

The nominal centre point of the circle.

Syntax in Visual Basic or VBScript

Centre () As Point3D

Syntax in C++

HRESULT get_Centre (Point3D* retVal)

Applies to

ScanOnCircle


CoordinateSystem

CoordinateSystem - Read & Write property

Description

The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).

Syntax in Visual Basic or VBScript

CoordinateSystem () As ProbePathType

Syntax in C++

HRESULT get_CoordinateSystem (ProbePathType* retVal)
HRESULT put_CoordinateSystem (ProbePathType Value)

Applies to

IScanInstruction
ScanOnCircle
ScanOnCurve
ScanOnHelix
ScanOnLine


Displacement

Displacement - Read & Write property

Description

The maximum expected distance between the nominal circle center and the actual circle center.

Syntax in Visual Basic or VBScript

Displacement () As Double

Syntax in C++

HRESULT get_Displacement (double* retVal)
HRESULT put_Displacement (double Value)

Applies to

ScanOnCircle


Form

Form - Read & Write property

Description

The maximum expected form deviation of the Gauss calculated circle.

Syntax in Visual Basic or VBScript

Form () As Double

Syntax in C++

HRESULT get_Form (double* retVal)
HRESULT put_Form (double Value)

Applies to

ScanOnCircle


Normal

Normal - Read property

Description

The normal vector of the circle plane.

Syntax in Visual Basic or VBScript

Normal () As Vector3D

Syntax in C++

HRESULT get_Normal (Vector3D* retVal)

Applies to

ScanOnCircle


ScanInstructionType

ScanInstructionType - Read property

Description

The scan item-type.

Syntax in Visual Basic or VBScript

ScanInstructionType () As ScanInstructionType

Syntax in C++

HRESULT get_ScanInstructionType (ScanInstructionType* retVal)

Applies to

IScanInstruction
ScanOnCircle
ScanOnCurve
ScanOnHelix
ScanOnLine


ScanStart

ScanStart - Read property

Description

The point on the circle radius where the scan starts.

Syntax in Visual Basic or VBScript

ScanStart () As Point3D

Syntax in C++

HRESULT get_ScanStart (Point3D* retVal)

Applies to

ScanOnCircle


StepW

StepW - Read & Write property

Description

The average angular distance between 2 measured points in degrees.

Syntax in Visual Basic or VBScript

StepW () As Double

Syntax in C++

HRESULT get_StepW (double* retVal)
HRESULT put_StepW (double Value)

Applies to

ScanOnCircle
ScanOnHelix


SurfaceAngle

SurfaceAngle - Read & Write property

Description

The surface angle of the circle.

Syntax in Visual Basic or VBScript

SurfaceAngle () As Double

Syntax in C++

HRESULT get_SurfaceAngle (double* retVal)
HRESULT put_SurfaceAngle (double Value)

Applies to

ScanOnCircle


Copy

Copy - method

Description

Copy the parameter object data to this object.

Syntax in Visual Basic or VBScript

Copy (ByRef scan_instruction As IScanInstruction)

Syntax in C++

HRESULT Copy (IScanInstruction* scan_instruction)

Parameters

Name | Description
scan_instruction |

Applies to

IScanInstruction


TransformScanParametersFrom

TransformScanParametersFrom - method

Description

Apply the transformation to the scan-instruction parameters.

Syntax in Visual Basic or VBScript

TransformScanParametersFrom (ByRef transform As ITransform2)

Syntax in C++

HRESULT TransformScanParametersFrom (ITransform2* transform)

Parameters

Name | Description
transform |

Applies to

IScanInstruction


TransformScanParametersTo

TransformScanParametersTo - method

Description

Apply the inverse transformation to the scan-instruction parameters.

Syntax in Visual Basic or VBScript

TransformScanParametersTo (ByRef transform As ITransform2)

Syntax in C++

HRESULT TransformScanParametersTo (ITransform2* transform)

Parameters

Name | Description
transform |

Applies to

IScanInstruction


PredictedPath

PredictedPath - Read property

Description

Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.

Syntax in Visual Basic or VBScript

PredictedPath () As ScanItems

Syntax in C++

HRESULT get_PredictedPath (ScanItems* retVal)

Applies to

IScanInstruction


ScanOnCurve

ScanOnCurve - object

Description

ScanOnCurve Class

Interfaces

IScanOnCurve

Methods of IScanOnCurve

Copy | Copy the parameter object data to this object.
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.

Properties of IScanOnCurve

Angle | R/W | The maximum angle between the 2 segments between the last 3 points.
AtNominals | R/W | VARIANT_TRUE if the arguments Distance and Angle are ignored.
Closed | R/W | Whether the contour is closed.
CoordinateSystem | R/W | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
Deviation | R/W | The maximum expected bias of measured data from the nominal data in the direction of the nominal direction vector.
distance | R/W | The maximum distance between 2 returned points.
MinRadiusOfCurvature | R/W | The prognostic minimum radius in the curve to measure. Only values greater zero are allowed.
ScanInstructionType | R/O | The scan item-type.
ScanItemFormat | R/O | Get the type of scan-item format stored. The format is set by the first item added.

Collections of IScanOnCurve

PredictedPath | Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.
ScanItems | Get the list of scan-items contained in this item.


Angle

Angle - Read & Write property

Description

The maximum angle between the 2 segments between the last 3 points.

Syntax in Visual Basic or VBScript

Angle () As Double

Syntax in C++

HRESULT get_Angle (double* retVal)
HRESULT put_Angle (double Value)

Applies to

ScanOnCurve


AtNominals

AtNominals - Read & Write property

Description

VARIANT_TRUE if the arguments Distance and Angle are ignored.

Syntax in Visual Basic or VBScript

AtNominals () As Boolean

Syntax in C++

HRESULT get_AtNominals (VARIANT_BOOL* retVal)
HRESULT put_AtNominals (VARIANT_BOOL Value)

Applies to

ScanOnCurve


Closed

Closed - Read & Write property

Description

Whether the contour is closed.

Syntax in Visual Basic or VBScript

Closed () As Boolean

Syntax in C++

HRESULT get_Closed (VARIANT_BOOL* retVal)
HRESULT put_Closed (VARIANT_BOOL Value)

Applies to

ScanOnCurve


Deviation

Deviation - Read & Write property

Description

The maximum expected bias of measured data from the nominal data in the direction of the nominal direction vector.

Syntax in Visual Basic or VBScript

Deviation () As Double

Syntax in C++

HRESULT get_Deviation (double* retVal)
HRESULT put_Deviation (double Value)

Applies to

ScanOnCurve


distance

distance - Read & Write property

Description

The maximum distance between 2 returned points.

Syntax in Visual Basic or VBScript

distance () As Double

Syntax in C++

HRESULT get_distance (double* retVal)
HRESULT put_distance (double Value)

Applies to

ScanOnCurve


MinRadiusOfCurvature

MinRadiusOfCurvature - Read & Write property

Description

The prognostic minimum radius in the curve to measure. Only values greater zero are allowed.

Syntax in Visual Basic or VBScript

MinRadiusOfCurvature () As Double

Syntax in C++

HRESULT get_MinRadiusOfCurvature (double* retVal)
HRESULT put_MinRadiusOfCurvature (double Value)

Applies to

ScanOnCurve


ScanItemFormat

ScanItemFormat - Read property

Description

Get the type of scan-item format stored. The format is set by the first item added.

Syntax in Visual Basic or VBScript

ScanItemFormat () As ScanItemFormat

Syntax in C++

HRESULT get_ScanItemFormat (ScanItemFormat* retVal)

Applies to

ScanOnCurve


ScanItems

ScanItems - Read property

Description

Get the list of scan-items contained in this item.

Syntax in Visual Basic or VBScript

ScanItems () As ScanItems

Syntax in C++

HRESULT get_ScanItems (ScanItems* retVal)

Applies to

ScanOnCurve


ScanOnHelix

ScanOnHelix - object

Description

ScanOnHelix Class

Interfaces

IScanOnHelix

Methods of IScanOnHelix

Copy | Copy the parameter object data to this object.
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.

Properties of IScanOnHelix

AngleToScan | R/W | The angle to scan.
Centre | R/O | The nominal centre point of the helix.
CoordinateSystem | R/W | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
Lead | R/W | The lead in mm per 360 degrees rotation.
Normal | R/O | The normal vector of the helix plane.
ScanInstructionType | R/O | The scan item-type.
ScanStart | R/O | The point on the helix radius where the scan starts.
StepW | R/W | The average angular distance between 2 measured points in degrees.
SurfaceAngle | R/W | The surface angle of the helix (90 and 270 not allowed).

Collections of IScanOnHelix

PredictedPath Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.


Centre

Centre - Read property

Description

The nominal centre point of the helix.

Syntax in Visual Basic or VBScript

Centre () As Point3D

Syntax in C++

HRESULT get_Centre (Point3D* retVal)

Applies to

ScanOnHelix


Lead

Lead - Read & Write property

Description

The lead in mm per 360 degrees rotation.

Syntax in Visual Basic or VBScript

Lead () As Double

Syntax in C++

HRESULT get_Lead (double* retVal)
HRESULT put_Lead (double Value)

Applies to

ScanOnHelix


Normal

Normal - Read property

Description

The normal vector of the helix plane.

Syntax in Visual Basic or VBScript

Normal () As Vector3D

Syntax in C++

HRESULT get_Normal (Vector3D* retVal)

Applies to

ScanOnHelix


ScanStart

ScanStart - Read property

Description

The point on the helix radius where the scan starts.

Syntax in Visual Basic or VBScript

ScanStart () As Point3D

Syntax in C++

HRESULT get_ScanStart (Point3D* retVal)

Applies to

ScanOnHelix


SurfaceAngle

SurfaceAngle - Read & Write property

Description

The surface angle of the helix (90 and 270 not allowed).

Syntax in Visual Basic or VBScript

SurfaceAngle () As Double

Syntax in C++

HRESULT get_SurfaceAngle (double* retVal)
HRESULT put_SurfaceAngle (double Value)

Applies to

ScanOnHelix


ScanOnLine

ScanOnLine - object

Description

ScanOnLine Class

Interfaces

IScanOnLine

Methods of IScanOnLine

Copy | Copy the parameter object data to this object.
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.

Properties of IScanOnLine

Angle | R/W | The maximum expected angle between the nominal line and the actual line.
CoordinateSystem | R/W | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
EndPoint | R/O | The end point of the line.
Form | R/W | The maximum expected form deviation of the Gauss calculated line.
Normal | R/O | The surface normal vector.
ScanInstructionType | R/O | The scan item-type.
StartPoint | R/O | The start point of the line.
StepW | R/W | The average distance between 2 measured points in mms.

Collections of IScanOnLine

PredictedPath Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.


Angle

Angle - Read & Write property

Description

The maximum expected angle between the nominal line and the actual line.

Syntax in Visual Basic or VBScript

Angle () As Double

Syntax in C++

HRESULT get_Angle (double* retVal)
HRESULT put_Angle (double Value)

Applies to

ScanOnLine


EndPoint

EndPoint - Read property

Description

The end point of the line.

Syntax in Visual Basic or VBScript

EndPoint () As Point3D

Syntax in C++

HRESULT get_EndPoint (Point3D* retVal)

Applies to

ScanOnLine


Form

Form - Read & Write property

Description

The maximum expected form deviation of the Gauss calculated line.

Syntax in Visual Basic or VBScript

Form () As Double

Syntax in C++

HRESULT get_Form (double* retVal)
HRESULT put_Form (double Value)

Applies to

ScanOnLine


Normal

Normal - Read property

Description

The surface normal vector.

Syntax in Visual Basic or VBScript

Normal () As Vector3D

Syntax in C++

HRESULT get_Normal (Vector3D* retVal)

Applies to

ScanOnLine


StartPoint

StartPoint - Read property

Description

The start point of the line.

Syntax in Visual Basic or VBScript

StartPoint () As Point3D

Syntax in C++

HRESULT get_StartPoint (Point3D* retVal)

Applies to

ScanOnLine


StepW

StepW - Read & Write property

Description

The average distance between 2 measured points in mms.

Syntax in Visual Basic or VBScript

StepW () As Double

Syntax in C++

HRESULT get_StepW (double* retVal)
HRESULT put_StepW (double Value)

Applies to

ScanOnLine


SelectionManager

SelectionManager - object

Description

A selection manager that handles CAD entity selection

Interfaces

ICADSelectionManager

Events

OnSelectionChange indicates that the selection has changed

Properties of ICADSelectionManager

Count | R/O | indicates the number selected vertex
Item | R/O | Allows random access to individual Vertex within the collection. Index can be an ordinal from 1 to Count or a string
Parent | T/O | indicates the parent of this object : a PowerINSPECT Document


Count

Count - Read property

Description

indicates the number selected vertex

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

SelectionManager
VerticeSelectionManager


Item

Item - Read property

Description

Allows random access to individual Vertex within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As Point3D

Syntax in C++

HRESULT get_Item (VARIANT Index , Point3D* retVal)

Applies to

SelectionManager
VerticeSelectionManager


Parent

Parent - Reference Write property

Description

indicates the parent of this object : a PowerINSPECT Document

Syntax in Visual Basic or VBScript

Parent () As Object

Syntax in C++

HRESULT get_Parent (IDispatch** retVal)

Applies to

SelectionManager
VerticeSelectionManager


OnSelectionChange

OnSelectionChange - event

Description

indicates that the selection has changed

Syntax in Visual Basic or VBScript

OnSelectionChange ()

Syntax in C++

HRESULT OnSelectionChange ()

Applies to

SelectionManager


SequenceDefinitionDatum

SequenceDefinitionDatum - object

Interfaces

ISecondaryDatumItem

Methods of ISecondaryDatumItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ISecondaryDatumItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ISecondaryDatumItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


SequenceGroup

SequenceGroup - object

Interfaces

ISequenceGroup

Methods of ISequenceGroup

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetExpanded | sets flag indicating group is expanded in the sequence tree
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ISequenceGroup

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
OutputToReport | R/W | get/set `output to report` flag
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ISequenceGroup

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
SequenceItems |
SequenceItemsForMeasure |


SequenceItem

SequenceItem - object

Interfaces

ISequenceItem

Methods of ISequenceItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ISequenceItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections of ISequenceItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


SequenceItemIterator

SequenceItemIterator - object

Description

SequenceItemIterator Class

Interfaces

ISequenceItemIterator

Methods of ISequenceItemIterator

Reset method Reset

Properties of ISequenceItemIterator

Count | R/O | returns the number of elements in the collection
cursor | R/W |
Document | R/W | property Document
Item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 1 to Count or a string
IteratorType | R/W | Put/Get iterator type as a combination of IteratorType types
UseActiveOnly | R/W | Put/Get using the active item only
UseRange | R/W | Put/Get controlling the range usage


Count

Count - Read property

Description

returns the number of elements in the collection

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

SequenceItemIterator


IteratorType

IteratorType - Read & Write property

Description

Put/Get iterator type as a combination of IteratorType types

Syntax in Visual Basic or VBScript

IteratorType () As IteratorType

Syntax in C++

HRESULT get_IteratorType (IteratorType* retVal)
HRESULT put_IteratorType (IteratorType Value)

Applies to

SequenceItemIterator


UseActiveOnly

UseActiveOnly - Read & Write property

Description

Put/Get using the active item only

Syntax in Visual Basic or VBScript

UseActiveOnly () As Boolean

Syntax in C++

HRESULT get_UseActiveOnly (VARIANT_BOOL* retVal)
HRESULT put_UseActiveOnly (VARIANT_BOOL Value)

Applies to

SequenceItemIterator


UseRange

UseRange - Read & Write property

Description

Put/Get controlling the range usage

Syntax in Visual Basic or VBScript

UseRange () As Boolean

Syntax in C++

HRESULT get_UseRange (VARIANT_BOOL* retVal)
HRESULT put_UseRange (VARIANT_BOOL Value)

Applies to

SequenceItemIterator


Reset

Reset - method

Description

method Reset

Syntax in Visual Basic or VBScript

Reset ()

Syntax in C++

HRESULT Reset ()

Applies to

SequenceItemIterator


SequenceItems

SequenceItems - object

Interfaces

ISequenceItems

Methods of ISequenceItems

AddAlignment | method AddAlignment : Add a AddAlignment to this collection of sequence items
AddGeometricItem | method AddAlignment : Add a AddAlignment to this collection of sequence items
AddGroup | method AddGroup
AddItem | method AddItem : Add an item to this collection of sequence items
ImportPointCloudFile | Read a file file of point as a cloud, will generate one or more point clouds

Properties of ISequenceItems

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual SequenceItem within the collection. Index can be an ordinal from 1 to Count or a string


Item

Item - Read property

Description

Allows random access to individual SequenceItem within the collection. Index can be an ordinal from 1 to Count or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As SequenceItem

Syntax in C++

HRESULT get_Item (VARIANT Index , SequenceItem* retVal)

Applies to

SequenceItems


AddAlignment

AddAlignment - method

Description

method AddAlignment : Add a AddAlignment to this collection of sequence items

Syntax in Visual Basic or VBScript

AddAlignment (Item As PWI_AlignmentType) As SequenceItem

Syntax in C++

HRESULT AddAlignment (PWI_AlignmentType Item , SequenceItem* retVal)

Parameters

Name | Description
Item |
Return Value |

Applies to

SequenceItems


AddGeometricItem

AddGeometricItem - method

Description

method AddAlignment : Add a AddAlignment to this collection of sequence items

Syntax in Visual Basic or VBScript

AddGeometricItem (Item As PWI_GeometricItemType) As IGeometricItem

Syntax in C++

HRESULT AddGeometricItem (PWI_GeometricItemType Item , IGeometricItem* retVal)

Parameters

Name | Description
Item |
Return Value |

Applies to

SequenceItems


AddGroup

AddGroup - method

Description

method AddGroup

Syntax in Visual Basic or VBScript

AddGroup (Item As PWI_GroupType) As SequenceGroup

Syntax in C++

HRESULT AddGroup (PWI_GroupType Item , SequenceGroup* retVal)

Parameters

Name | Description
Item |
Return Value |

Applies to

SequenceItems


AddItem

AddItem - method

Description

method AddItem : Add an item to this collection of sequence items

Syntax in Visual Basic or VBScript

AddItem (Item As PWI_EntityItemType) As SequenceItem

Syntax in C++

HRESULT AddItem (PWI_EntityItemType Item , SequenceItem* retVal)

Parameters

Name | Description
Item |
Return Value |

Applies to

SequenceItems


ImportPointCloudFile

ImportPointCloudFile - method

Description

Read a file file of point as a cloud, will generate one or more point clouds

Syntax in Visual Basic or VBScript

ImportPointCloudFile (measure As Variant , filename As String) As Long

Syntax in C++

HRESULT ImportPointCloudFile (VARIANT measure , BSTR filename , LONG* retVal)

Parameters

Name | Description
measure |
filename |
Return Value |

Applies to

SequenceItems


SequenceReplayEngine

SequenceReplayEngine - object

Description

SequenceReplayEngine Class

Interfaces

ISequenceReplayEngine

Events

OnCNCError | Fired when a CNC error occurs during the reply, asking whether to retry and continue
OnCurrentItemProgressChanged | Fired to notify progress on the current item being replayed
OnStatusChanged | Change when the job status has changed

Methods of ISequenceReplayEngine

EmergencyStop | cancel any pending action. current step is also cancelled
FullStop | Suspend the current action. Restart the current entity. Unlock the CMM.
GoBack | Move back at the start of the current entity or at the start of the previous entity
GoStep | do one step only
Rewind | set the curent step to be the first
Run | runs all steps up to the end
RunOnNewMeasure | Add a new measure inside PowerINSPECT , and start rerunning the sequence
RunSelectedItem | Runs the currently selected item
Suspend | Cancel any pending action. Current step is completed.

Properties of ISequenceReplayEngine

BUSY | R/O |
CMMProtocol | R/W | set the protocol
CurrentSequenceItem | R/O |
cursor | R/W |
Document | R/W | property Document
measure | R/W | property Measure
Mode | R/O |
NumberOfStep | R/O | returns the number of step for whole completion
status | R/O |


CMMProtocol

CMMProtocol - Read & Write property

Description

set the protocol

Syntax in Visual Basic or VBScript

CMMProtocol () As CMMProtocol_dummy

Syntax in C++

HRESULT get_CMMProtocol (CMMProtocol_dummy* retVal)
HRESULT put_CMMProtocol (CMMProtocol_dummy* Value)

Applies to

SequenceReplayEngine


CurrentSequenceItem

CurrentSequenceItem - Read property

Syntax in Visual Basic or VBScript

CurrentSequenceItem () As Object

Syntax in C++

HRESULT get_CurrentSequenceItem (IUnknow** retVal)

Applies to

SequenceReplayEngine


Mode

Mode - Read property

Syntax in Visual Basic or VBScript

Mode () As SRE_MODE

Syntax in C++

HRESULT get_Mode (SRE_MODE* retVal)

Applies to

SequenceReplayEngine


NumberOfStep

NumberOfStep - Read property

Description

returns the number of step for whole completion

Syntax in Visual Basic or VBScript

NumberOfStep () As Long

Syntax in C++

HRESULT get_NumberOfStep (LONG* retVal)

Applies to

SequenceReplayEngine


status

status - Read property

Syntax in Visual Basic or VBScript

status () As SRE_STATUS

Syntax in C++

HRESULT get_status (SRE_STATUS* retVal)

Applies to

SequenceReplayEngine


FullStop

FullStop - method

Description

Suspend the current action. Restart the current entity. Unlock the CMM.

Syntax in Visual Basic or VBScript

FullStop ()

Syntax in C++

HRESULT FullStop ()

Applies to

SequenceReplayEngine


GoBack

GoBack - method

Description

Move back at the start of the current entity or at the start of the previous entity

Syntax in Visual Basic or VBScript

GoBack ()

Syntax in C++

HRESULT GoBack ()

Applies to

SequenceReplayEngine


OnCurrentItemProgressChanged

OnCurrentItemProgressChanged - event

Description

Fired to notify progress on the current item being replayed

Syntax in Visual Basic or VBScript

OnCurrentItemProgressChanged (pos As Long , maxsteps As Long)

Syntax in C++

HRESULT OnCurrentItemProgressChanged (LONG pos , LONG maxsteps)

Parameters

Name | Description
pos |
maxsteps |

Applies to

SequenceReplayEngine


OnStatusChanged

OnStatusChanged - event

Description

Change when the job status has changed

Syntax in Visual Basic or VBScript

OnStatusChanged (status As SRE_STATUS)

Syntax in C++

HRESULT OnStatusChanged (SRE_STATUS status)

Parameters

Name | Description
status |

Applies to

SequenceReplayEngine


RunOnNewMeasure

RunOnNewMeasure - method

Description

Add a new measure inside PowerINSPECT , and start rerunning the sequence

Syntax in Visual Basic or VBScript

RunOnNewMeasure ()

Syntax in C++

HRESULT RunOnNewMeasure ()

Applies to

SequenceReplayEngine


RunSelectedItem

RunSelectedItem - method

Description

Runs the currently selected item

Syntax in Visual Basic or VBScript

RunSelectedItem ()

Syntax in C++

HRESULT RunSelectedItem ()

Applies to

SequenceReplayEngine


Suspend

Suspend - method

Description

Cancel any pending action. Current step is completed.

Syntax in Visual Basic or VBScript

Suspend ()

Syntax in C++

HRESULT Suspend ()

Applies to

SequenceReplayEngine


SequenceReplayEngineCtrl

SequenceReplayEngineCtrl - object

Description

SequenceReplayEngineCtrl Class

Interfaces

ISequenceReplayEngineCtrl

Events

OnClickedBackOneStep | Fired when the user presses the One Step button
OnClickedDoNextStep | Fired when the user presses the Next Step button
OnClickedEStop | Fired when the user presses the EStop button
OnClickedFullStop | Fired when the user presses the Full Stop button
OnClickedReplay | Fired when the user presses the Replay button
OnClickedRewind | Fired when the user presses the Rewind button
OnClickedSuspend | Fired when the user presses the Suspend button

Properties of ISequenceReplayEngineCtrl

Document | R/W | property Document
SequenceReplayEngine | R/W | property SequenceReplayEngine


SequenceReplayEngine

SequenceReplayEngine - Read & Write property

Description

property SequenceReplayEngine

Syntax in Visual Basic or VBScript

SequenceReplayEngine () As SequenceReplayEngine

Syntax in C++

HRESULT get_SequenceReplayEngine (SequenceReplayEngine* retVal)
HRESULT put_SequenceReplayEngine (SequenceReplayEngine* Value)

Applies to

SequenceReplayEngineCtrl


OnClickedBackOneStep

OnClickedBackOneStep - event

Description

Fired when the user presses the One Step button

Syntax in Visual Basic or VBScript

OnClickedBackOneStep ()

Syntax in C++

HRESULT OnClickedBackOneStep ()

Applies to

SequenceReplayEngineCtrl


OnClickedDoNextStep

OnClickedDoNextStep - event

Description

Fired when the user presses the Next Step button

Syntax in Visual Basic or VBScript

OnClickedDoNextStep ()

Syntax in C++

HRESULT OnClickedDoNextStep ()

Applies to

SequenceReplayEngineCtrl


OnClickedEStop

OnClickedEStop - event

Description

Fired when the user presses the EStop button

Syntax in Visual Basic or VBScript

OnClickedEStop ()

Syntax in C++

HRESULT OnClickedEStop ()

Applies to

SequenceReplayEngineCtrl


OnClickedFullStop

OnClickedFullStop - event

Description

Fired when the user presses the Full Stop button

Syntax in Visual Basic or VBScript

OnClickedFullStop ()

Syntax in C++

HRESULT OnClickedFullStop ()

Applies to

SequenceReplayEngineCtrl


OnClickedReplay

OnClickedReplay - event

Description

Fired when the user presses the Replay button

Syntax in Visual Basic or VBScript

OnClickedReplay ()

Syntax in C++

HRESULT OnClickedReplay ()

Applies to

SequenceReplayEngineCtrl


OnClickedRewind

OnClickedRewind - event

Description

Fired when the user presses the Rewind button

Syntax in Visual Basic or VBScript

OnClickedRewind ()

Syntax in C++

HRESULT OnClickedRewind ()

Applies to

SequenceReplayEngineCtrl


OnClickedSuspend

OnClickedSuspend - event

Description

Fired when the user presses the Suspend button

Syntax in Visual Basic or VBScript

OnClickedSuspend ()

Syntax in C++

HRESULT OnClickedSuspend ()

Applies to

SequenceReplayEngineCtrl


SequenceReplayValidator

SequenceReplayValidator - object

Description

SequenceReplayValidator Class

Interfaces

ISequenceReplayValidator

Methods of ISequenceReplayValidator

ErrorsInMarkedRange | Validate all sequence items in the marked range.
ErrorsWithActiveItem | Validate the active sequence item
ValidateActiveItem | Validate some or all sequence items, depending on the type of the active item.
ValidateAllItems | Validate all sequence items in the marked range.
ValidateMarkedRange | Validate all sequence items in the marked range.


ErrorsInMarkedRange

ErrorsInMarkedRange - method

Description

Validate all sequence items in the marked range.

Syntax in Visual Basic or VBScript

ErrorsInMarkedRange (ByRef pDocument As Document , ByRef pMeasure As measure , ByRef pDatabase As SimpleProbeDatabase) As Long

Syntax in C++

HRESULT ErrorsInMarkedRange (Document* pDocument , measure* pMeasure , SimpleProbeDatabase* pDatabase , LONG* retVal)

Parameters

Name | Description
pDocument |
pMeasure |
pDatabase |
Return Value |

Applies to

SequenceReplayValidator


ErrorsWithActiveItem

ErrorsWithActiveItem - method

Description

Validate the active sequence item

Syntax in Visual Basic or VBScript

ErrorsWithActiveItem (ByRef pDocument As Document , ByRef pMeasure As measure , ByRef pDatabase As SimpleProbeDatabase) As Long

Syntax in C++

HRESULT ErrorsWithActiveItem (Document* pDocument , measure* pMeasure , SimpleProbeDatabase* pDatabase , LONG* retVal)

Parameters

Name | Description
pDocument |
pMeasure |
pDatabase |
Return Value |

Applies to

SequenceReplayValidator


ValidateActiveItem

ValidateActiveItem - method

Description

Validate some or all sequence items, depending on the type of the active item.

Syntax in Visual Basic or VBScript

ValidateActiveItem (ByRef pDocument As Document , ByRef pMeasure As measure , ByRef pDatabase As SimpleProbeDatabase) As String

Syntax in C++

HRESULT ValidateActiveItem (Document* pDocument , measure* pMeasure , SimpleProbeDatabase* pDatabase , BSTR* retVal)

Parameters

Name | Description
pDocument |
pMeasure |
pDatabase |
Return Value |

Applies to

SequenceReplayValidator


ValidateAllItems

ValidateAllItems - method

Description

Validate all sequence items in the marked range.

Syntax in Visual Basic or VBScript

ValidateAllItems (ByRef pDocument As Document , ByRef pMeasure As measure , ByRef pDatabase As SimpleProbeDatabase) As String

Syntax in C++

HRESULT ValidateAllItems (Document* pDocument , measure* pMeasure , SimpleProbeDatabase* pDatabase , BSTR* retVal)

Parameters

Name | Description
pDocument |
pMeasure |
pDatabase |
Return Value |

Applies to

SequenceReplayValidator


ValidateMarkedRange

ValidateMarkedRange - method

Description

Validate all sequence items in the marked range.

Syntax in Visual Basic or VBScript

ValidateMarkedRange (ByRef pDocument As Document , ByRef pMeasure As measure , ByRef pDatabase As SimpleProbeDatabase) As String

Syntax in C++

HRESULT ValidateMarkedRange (Document* pDocument , measure* pMeasure , SimpleProbeDatabase* pDatabase , BSTR* retVal)

Parameters

Name | Description
pDocument |
pMeasure |
pDatabase |
Return Value |

Applies to

SequenceReplayValidator


SimpleLink

SimpleLink - object

Interfaces

ISequenceSimpleLink

Properties of ISequenceSimpleLink

Description | R/O | return a description of the feature in the current locale language
Feature | R/W | put the Feature attached to this link
FeatureMask | R/O | return the mask for this link
Handle | R/O | return the internal handle of this link
Index | R/O | returns the index of this property in its parent collection
LinkType | R/O | return the type of the link (Simple/Multiple)
Name | R/O | return the name of the link
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the link cannot be modified
Reversed | R/W | sets/retrieves the reverse flag of the link
Reversible | R/O | returns if the link can support reversed features

Collections of ISequenceSimpleLink

PossibleFeatures property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


Reversed

Reversed - Read & Write property

Description

sets/retrieves the reverse flag of the link

Syntax in Visual Basic or VBScript

Reversed () As Boolean

Syntax in C++

HRESULT get_Reversed (VARIANT_BOOL* retVal)
HRESULT put_Reversed (VARIANT_BOOL Value)

Applies to

SimpleLink


Reversible

Reversible - Read property

Description

returns if the link can support reversed features

Syntax in Visual Basic or VBScript

Reversible () As Boolean

Syntax in C++

HRESULT get_Reversible (VARIANT_BOOL* retVal)

Applies to

SimpleLink


SimpleProbeDatabase

SimpleProbeDatabase - object

Interfaces

ISimpleProbeDatabase

Events

ProbeTipChanged method OnProbeTipChanged

Methods of ISimpleProbeDatabase

ActivateSensor |
CalibrateActiveSensor | brings a user interface to allow the active sensor to be calibrated
Compensate | get the compemsate coordinates according the active sensor
EditDatabase | brings a user dialog box to allow the underlying probe database to be managed
EditSensor |
Load | Load the probe database, stream could be a BSTR
ReconcileSensor |
Save | Save the probe database, if stream is null then the last known filename is used
Uncompensate | get the compemsate coordinates according the active sensor

Properties of ISimpleProbeDatabase

ActiveSensorName | R/O | returns the name of the current active sensor
ActiveSensorType | R/O | returns the type of the current active sensor
Property | R/O |
Protocol | R/O | sets/retrieves the protocol that actually controls this carriage
SensorProperty | R/O |


ProbeTipChanged

ProbeTipChanged - event

Description

method OnProbeTipChanged

Syntax in Visual Basic or VBScript

ProbeTipChanged (pOld As Object , pNew As Object)

Syntax in C++

HRESULT ProbeTipChanged (IDispatch* pOld , IDispatch* pNew)

Parameters

Name | Description
pOld |
pNew |

Applies to

ProbeDatabase


SurfaceGroup

SurfaceGroup - object

Interfaces

ISurfaceGroup

Methods of ISurfaceGroup

AddCMMPoint | OBSOLETE : Add a single CMMPoint ( probe offset compensation will not apply
AddCMMPoints |
ApplyOffsetNow |
ApplyToleranceNow |
Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
RenumberPointNow |
ReplayWithPoints | Replay the elements with the given points
SetExpanded | sets flag indicating group is expanded in the sequence tree
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
Statistics | not yet implemented
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ISurfaceGroup

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
Counter | R/W |
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
EdgeOffset | R/W |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Label | R/W |
LowerTolerance | R/W |
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
MinimumNumberOfPoints | R/W | Minimum number of points to make the measurement valid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
OutputToReport | R/W | get/set `output to report` flag
PeckerStrategy | R/W | returns the Pecker Strategy object
PointType | R/W |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
Step | R/W |
SurfaceGroupType | R/W |
SurfaceOffset | R/W |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W |
Visible | R/W | return the current state of the visible flag

Collections of ISurfaceGroup

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
SequenceItems |
SequenceItemsForMeasure |


Counter

Counter - Read & Write property

Syntax in Visual Basic or VBScript

Counter () As Integer

Syntax in C++

HRESULT get_Counter (INT* retVal)
HRESULT put_Counter (INT Value)

Applies to

SurfaceGroup
SurfaceSectionGroup


Label

Label - Read & Write property

Syntax in Visual Basic or VBScript

Label () As String

Syntax in C++

HRESULT get_Label (BSTR* retVal)
HRESULT put_Label (BSTR Value)

Applies to

SurfaceGroup
SurfaceSectionGroup


MinimumNumberOfPoints

MinimumNumberOfPoints - Read & Write property

Description

Minimum number of points to make the measurement valid

Syntax in Visual Basic or VBScript

MinimumNumberOfPoints () As Long

Syntax in C++

HRESULT get_MinimumNumberOfPoints (LONG* retVal)
HRESULT put_MinimumNumberOfPoints (LONG Value)

Applies to

SurfaceGroup
SurfaceSectionGroup


PeckerStrategy

PeckerStrategy - Read & Write property

Description

returns the Pecker Strategy object

Syntax in Visual Basic or VBScript

PeckerStrategy () As Object

Syntax in C++

HRESULT get_PeckerStrategy (IDispatch** retVal)
HRESULT put_PeckerStrategy (IDispatch* Value)

Applies to

SurfaceGroup
SurfaceSectionGroup


Step

Step - Read & Write property

Syntax in Visual Basic or VBScript

Step () As Integer

Syntax in C++

HRESULT get_Step (INT* retVal)
HRESULT put_Step (INT Value)

Applies to

SurfaceGroup
SurfaceSectionGroup


SurfaceGroupType

SurfaceGroupType - Read & Write property

Syntax in Visual Basic or VBScript

SurfaceGroupType () As PWI_SurfaceGroupType

Syntax in C++

HRESULT get_SurfaceGroupType (PWI_SurfaceGroupType* retVal)
HRESULT put_SurfaceGroupType (PWI_SurfaceGroupType Value)

Applies to

SurfaceGroup
SurfaceSectionGroup


AddCMMPoint

AddCMMPoint - method

Description

OBSOLETE : Add a single CMMPoint ( probe offset compensation will not apply

Syntax in Visual Basic or VBScript

AddCMMPoint (measure As Variant , X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double) As Boolean

Syntax in C++

HRESULT AddCMMPoint (VARIANT measure , double X , double Y , double Z , double I , double J , double K , VARIANT_BOOL* retVal)

Parameters

Name | Description
measure |
X |
Y |
Z |
I |
J |
K |
Return Value |

Applies to

SurfaceGroup


AddCMMPoints

AddCMMPoints - method

Syntax in Visual Basic or VBScript

AddCMMPoints (measure As Variant , ProbeDiameter As Variant , CMMPoints As Variant , combination_of_REPLAYPOINTSFLAGS As Long , Offset As Variant , LowerTol As Variant , UpperTol As Variant , ProximityCriteria As Variant , IgnoreBadPoint As Variant) As Boolean

Syntax in C++

HRESULT AddCMMPoints (VARIANT measure , VARIANT ProbeDiameter , VARIANT CMMPoints , LONG combination_of_REPLAYPOINTSFLAGS , VARIANT Offset , VARIANT LowerTol , VARIANT UpperTol , VARIANT ProximityCriteria , VARIANT IgnoreBadPoint , VARIANT_BOOL* retVal)

Parameters

Name | Description
measure |
ProbeDiameter |
CMMPoints |
combination_of_REPLAYPOINTSFLAGS |
Offset |
LowerTol |
UpperTol |
ProximityCriteria |
IgnoreBadPoint |
Return Value |

Applies to

SurfaceGroup


ApplyOffsetNow

ApplyOffsetNow - method

Syntax in Visual Basic or VBScript

ApplyOffsetNow ()

Syntax in C++

HRESULT ApplyOffsetNow ()

Applies to

SurfaceGroup


ApplyToleranceNow

ApplyToleranceNow - method

Syntax in Visual Basic or VBScript

ApplyToleranceNow ()

Syntax in C++

HRESULT ApplyToleranceNow ()

Applies to

SurfaceGroup


RenumberPointNow

RenumberPointNow - method

Syntax in Visual Basic or VBScript

RenumberPointNow ()

Syntax in C++

HRESULT RenumberPointNow ()

Applies to

SurfaceGroup


Statistics

Statistics - method

Description

not yet implemented

Syntax in Visual Basic or VBScript

Statistics (measure As Variant) As IMeasureStatistics

Syntax in C++

HRESULT Statistics (VARIANT measure , IMeasureStatistics* retVal)

Parameters

Name | Description
measure |
Return Value |

Applies to

SurfaceGroup


SurfacePointItem

SurfacePointItem - object

Interfaces

ISurfacePointItem

Methods of ISurfacePointItem

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
MeasuredPoint | the measured surface point for the given measure
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ISurfacePointItem

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LowerTolerance | R/W |
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PointType | R/W |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SurfaceOffset | R/W |
TargetPoint | R/O |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W |
Visible | R/W | return the current state of the visible flag

Collections of ISurfacePointItem

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
ResultStack | stack of results for the given measure


MeasuredPoint

MeasuredPoint - method

Description

the measured surface point for the given measure

Syntax in Visual Basic or VBScript

MeasuredPoint (measure As Variant) As SurfacePointResult

Syntax in C++

HRESULT MeasuredPoint (VARIANT measure , SurfacePointResult* retVal)

Parameters

Name | Description
measure |
Return Value |

Applies to

SurfacePointItem


ResultStack

ResultStack - method

Description

stack of results for the given measure

Syntax in Visual Basic or VBScript

ResultStack (measure As Variant) As SurfacePointResultStack

Syntax in C++

HRESULT ResultStack (VARIANT measure , SurfacePointResultStack* retVal)

Parameters

Name | Description
measure |
Return Value |

Applies to

SurfacePointItem


SurfacePointResult

SurfacePointResult - object

Interfaces

ISurfacePointResult

Properties of ISurfacePointResult

ContactPoint | R/O | the coordinates of the point of the probe that touch the actual surface
Deviation | R/O | the true length deviation
DeviationVector | R/O | the deviation vector
IsValid | R/O |
measure | R/O |
MeasureState | R/O | returns the measurement state
Parent | R/O |
ProbeCenter | R/O | the coordinates of the probe center in CADCoordinates
ProbeClearanceVector | R/O | the coordinates of the CMM point vector in CAD Coordinates
ProbeDiameter | R/W | the probe diameter
SurfacePoint | R/O | the information on the projected point


ContactPoint

ContactPoint - Read property

Description

the coordinates of the point of the probe that touch the actual surface

Syntax in Visual Basic or VBScript

ContactPoint () As Point3D

Syntax in C++

HRESULT get_ContactPoint (Point3D* retVal)

Applies to

SurfacePointResult


Deviation

Deviation - Read property

Description

the true length deviation

Syntax in Visual Basic or VBScript

Deviation () As Double

Syntax in C++

HRESULT get_Deviation (double* retVal)

Applies to

SurfacePointResult


ProbeCenter

ProbeCenter - Read property

Description

the coordinates of the probe center in CADCoordinates

Syntax in Visual Basic or VBScript

ProbeCenter () As Point3D

Syntax in C++

HRESULT get_ProbeCenter (Point3D* retVal)

Applies to

SurfacePointResult


ProbeClearanceVector

ProbeClearanceVector - Read property

Description

the coordinates of the CMM point vector in CAD Coordinates

Syntax in Visual Basic or VBScript

ProbeClearanceVector () As UnitVector3D

Syntax in C++

HRESULT get_ProbeClearanceVector (UnitVector3D* retVal)

Applies to

SurfacePointResult


SurfacePoint

SurfacePoint - Read property

Description

the information on the projected point

Syntax in Visual Basic or VBScript

SurfacePoint () As ISurfacePoint

Syntax in C++

HRESULT get_SurfacePoint (ISurfacePoint* retVal)

Applies to

SurfacePointResult


SurfacePointResultStack

SurfacePointResultStack - object

Interfaces

ISurfacePointResultStack

Properties of ISurfacePointResultStack

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual points. Index can be an ordinal from 1 to Count or a string


SurfaceSectionGroup

SurfaceSectionGroup - object

Interfaces

ISurfaceSectionGroup

Methods of ISurfaceSectionGroup

AddCMMPoint | OBSOLETE : Add a single CMMPoint ( probe offset compensation will not apply
AddCMMPoints |
ApplyOffsetNow |
ApplyToleranceNow |
Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
RenumberPointNow |
ReplayWithPoints | Replay the elements with the given points
SetExpanded | sets flag indicating group is expanded in the sequence tree
SetSectionParameters | set the parameter of the section plane
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
Statistics | not yet implemented
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties of ISurfaceSectionGroup

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
Counter | R/W |
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
EdgeOffset | R/W |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Label | R/W |
LowerTolerance | R/W |
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
MinimumNumberOfPoints | R/W | Minimum number of points to make the measurement valid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
OutputToReport | R/W | get/set `output to report` flag
PeckerStrategy | R/W | returns the Pecker Strategy object
PointType | R/W |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
Step | R/W |
SurfaceGroupType | R/W |
SurfaceOffset | R/W |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W |
Visible | R/W | return the current state of the visible flag

Collections of ISurfaceSectionGroup

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
SequenceItems |
SequenceItemsForMeasure |


SetSectionParameters

SetSectionParameters - method

Description

set the parameter of the section plane

Syntax in Visual Basic or VBScript

SetSectionParameters (point As Variant , vector As Variant)

Syntax in C++

HRESULT SetSectionParameters (VARIANT point , VARIANT vector)

Parameters

Name | Description
point |
vector |

Applies to

SurfaceSectionGroup


TemperedTrackingPoints

TemperedTrackingPoints - object

Description

TemperedTrackingPoints Class

Interfaces

ITemperedTrackingPoints

Events

TrackingPoint method TrackingPoint

Properties of ITemperedTrackingPoints

CMMProtocol | R/W | CMMProtocol object to collect tracking points from
CMMProtocol | W/O | CMMProtocol object to collect tracking points from
TrackingInterval | R/W | Minimum interval (in ms) at which tracking points are sent


CMMProtocol

CMMProtocol - Read & Write property

Description

CMMProtocol object to collect tracking points from

Syntax in Visual Basic or VBScript

CMMProtocol () As CMMProtocol_dummy

Syntax in C++

HRESULT get_CMMProtocol (CMMProtocol_dummy* retVal)
HRESULT put_CMMProtocol (CMMProtocol_dummy* Value)

Applies to

TemperedTrackingPoints


CMMProtocol

CMMProtocol - Reference Write property

Description

CMMProtocol object to collect tracking points from

Syntax in Visual Basic or VBScript

CMMProtocol (ByRef As CMMProtocol_dummy)

Syntax in C++

HRESULT putref_CMMProtocol (CMMProtocol_dummy* )

Applies to

TemperedTrackingPoints


TrackingInterval

TrackingInterval - Read & Write property

Description

Minimum interval (in ms) at which tracking points are sent

Syntax in Visual Basic or VBScript

TrackingInterval () As Long

Syntax in C++

HRESULT get_TrackingInterval (LONG* retVal)
HRESULT put_TrackingInterval (LONG Value)

Applies to

TemperedTrackingPoints


TrackingPoint

TrackingPoint - event

Description

method TrackingPoint

Syntax in Visual Basic or VBScript

TrackingPoint (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double)

Syntax in C++

HRESULT TrackingPoint (double X , double Y , double Z , double I , double J , double K)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |

Applies to

TemperedTrackingPoints


TrackerCommand

TrackerCommand - object

Description

TrackerCommand Class

Interfaces

ITrackerCommand

Methods of ITrackerCommand

Abort
ChangeTarget
ConfigChanged
Connect
Disconnect
EnvironmentUpdate
GoDefaultHome
Initialise
LevelToGravity
Motors
PointLaser
Scan
Search
Sight
TakeManualPoint
TakeStaticPoint


Abort

Abort - method

Syntax in Visual Basic or VBScript

Abort ()

Syntax in C++

HRESULT Abort ()

Applies to

TrackerCommand


ChangeTarget

ChangeTarget - method

Syntax in Visual Basic or VBScript

ChangeTarget ()

Syntax in C++

HRESULT ChangeTarget ()

Applies to

TrackerCommand


ConfigChanged

ConfigChanged - method

Syntax in Visual Basic or VBScript

ConfigChanged ()

Syntax in C++

HRESULT ConfigChanged ()

Applies to

TrackerCommand


Connect

Connect - method

Syntax in Visual Basic or VBScript

Connect ()

Syntax in C++

HRESULT Connect ()

Applies to

TrackerCommand


Disconnect

Disconnect - method

Syntax in Visual Basic or VBScript

Disconnect ()

Syntax in C++

HRESULT Disconnect ()

Applies to

TrackerCommand


EnvironmentUpdate

EnvironmentUpdate - method

Syntax in Visual Basic or VBScript

EnvironmentUpdate ()

Syntax in C++

HRESULT EnvironmentUpdate ()

Applies to

TrackerCommand


GoDefaultHome

GoDefaultHome - method

Syntax in Visual Basic or VBScript

GoDefaultHome ()

Syntax in C++

HRESULT GoDefaultHome ()

Applies to

TrackerCommand


Initialise

Initialise - method

Syntax in Visual Basic or VBScript

Initialise ()

Syntax in C++

HRESULT Initialise ()

Applies to

TrackerCommand


LevelToGravity

LevelToGravity - method

Syntax in Visual Basic or VBScript

LevelToGravity ()

Syntax in C++

HRESULT LevelToGravity ()

Applies to

TrackerCommand


Motors

Motors - method

Syntax in Visual Basic or VBScript

Motors ()

Syntax in C++

HRESULT Motors ()

Applies to

TrackerCommand


PointLaser

PointLaser - method

Syntax in Visual Basic or VBScript

PointLaser (dX As Double , dY As Double , dZ As Double , dI As Double , dJ As Double , dK As Double , vbSearch As Boolean , vbTakePoint As Boolean)

Syntax in C++

HRESULT PointLaser (double dX , double dY , double dZ , double dI , double dJ , double dK , VARIANT_BOOL vbSearch , VARIANT_BOOL vbTakePoint)

Parameters

Name | Description
dX |
dY |
dZ |
dI |
dJ |
dK |
vbSearch |
vbTakePoint |

Applies to

TrackerCommand


Scan

Scan - method

Syntax in Visual Basic or VBScript

Scan ()

Syntax in C++

HRESULT Scan ()

Applies to

TrackerCommand


Search

Search - method

Syntax in Visual Basic or VBScript

Search ()

Syntax in C++

HRESULT Search ()

Applies to

TrackerCommand


Sight

Sight - method

Syntax in Visual Basic or VBScript

Sight ()

Syntax in C++

HRESULT Sight ()

Applies to

TrackerCommand


TakeManualPoint

TakeManualPoint - method

Syntax in Visual Basic or VBScript

TakeManualPoint ()

Syntax in C++

HRESULT TakeManualPoint ()

Applies to

TrackerCommand


TakeStaticPoint

TakeStaticPoint - method

Syntax in Visual Basic or VBScript

TakeStaticPoint ()

Syntax in C++

HRESULT TakeStaticPoint ()

Applies to

TrackerCommand


TrackerProbeDb

TrackerProbeDb - object

Description

TrackerProbeDb Class

Interfaces

ISimpleProbeDatabase

Events

ProbeTipChanged method OnProbeTipChanged

Methods of ISimpleProbeDatabase

ActivateSensor |
CalibrateActiveSensor | brings a user interface to allow the active sensor to be calibrated
Compensate | get the compemsate coordinates according the active sensor
EditDatabase | brings a user dialog box to allow the underlying probe database to be managed
EditSensor |
Load | Load the probe database, stream could be a BSTR
ReconcileSensor |
Save | Save the probe database, if stream is null then the last known filename is used
Uncompensate | get the compemsate coordinates according the active sensor

Properties of ISimpleProbeDatabase

ActiveSensorName | R/O | returns the name of the current active sensor
ActiveSensorType | R/O | returns the type of the current active sensor
Property | R/O |
Protocol | R/O | sets/retrieves the protocol that actually controls this carriage
SensorProperty | R/O |


transform

transform - object

Description

Transform Class

Interfaces

ITransform

Methods of ITransform

CreateRotation | Create a rotation of the specified angle ( in degree) around one axis ( through the origin )
CreateRotationAtPoint | Create a rotation of the specified angle ( in degree) around one axis ( defined with a vector and a point )
CreateTransform | Create a transformation with 2 vectors and an origin
CreateTransform1V | Create a transformation with a single vector and an origin
CreateTranslation | Create a translation
TransformFrom |
TransformTo |

Properties of ITransform

From | R/O
To | R/O


TransformDefinition

TransformDefinition - object

Interfaces

ITransformDefinition

Methods of ITransformDefinition

Load | load the definition matrix from a .MAT file
Save | save the definition matrix from a .MAT file

Properties of ITransformDefinition

transform R/O get the transformation matrix


transform

transform - Read property

Description

get the transformation matrix

Syntax in Visual Basic or VBScript

transform () As ITransform2

Syntax in C++

HRESULT get_transform (ITransform2* retVal)

Applies to

TransformDefinition


Load

Load - method

Description

load the definition matrix from a .MAT file

Syntax in Visual Basic or VBScript

Load (file As String)

Syntax in C++

HRESULT Load (BSTR file)

Parameters

Name | Description
file |

Applies to

TransformDefinition


Save

Save - method

Description

save the definition matrix from a .MAT file

Syntax in Visual Basic or VBScript

Save (file As String)

Syntax in C++

HRESULT Save (BSTR file)

Parameters

Name | Description
file |

Applies to

TransformDefinition


TypeDesc

TypeDesc - object

Description

TypeDesc Class

Interfaces

ITypeDesc

Properties of ITypeDesc

CPPTypeStr | R/O |
PointerDesc | R/O | Returns a TypeInformation object with more information about the VT_USERDEFINED type.
Type | R/O | Returns the type as combination of VARENUM.
UserDefinedDesc | R/O | Returns a TypeInformation object with more information about the VT_USERDEFINED type.
VBTypeStr | R/O |


CPPTypeStr

CPPTypeStr - Read property

Syntax in Visual Basic or VBScript

CPPTypeStr () As String

Syntax in C++

HRESULT get_CPPTypeStr (BSTR* retVal)

Applies to

TypeDesc


PointerDesc

PointerDesc - Read property

Description

Returns a TypeInformation object with more information about the VT_USERDEFINED type.

Syntax in Visual Basic or VBScript

PointerDesc () As TypeDesc

Syntax in C++

HRESULT get_PointerDesc (TypeDesc* retVal)

Applies to

TypeDesc


Type

Type - Read property

Description

Returns the type as combination of VARENUM.

Syntax in Visual Basic or VBScript

Type () As Long

Syntax in C++

HRESULT get_Type (LONG* retVal)

Applies to

TypeDesc


UserDefinedDesc

UserDefinedDesc - Read property

Description

Returns a TypeInformation object with more information about the VT_USERDEFINED type.

Syntax in Visual Basic or VBScript

UserDefinedDesc () As TypeInfo

Syntax in C++

HRESULT get_UserDefinedDesc (TypeInfo* retVal)

Applies to

TypeDesc


VBTypeStr

VBTypeStr - Read property

Syntax in Visual Basic or VBScript

VBTypeStr () As String

Syntax in C++

HRESULT get_VBTypeStr (BSTR* retVal)

Applies to

TypeDesc


TypeInfo

TypeInfo - object

Description

TypeInfo Class

Interfaces

ITypeInformation

Properties of ITypeInformation

Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.


TypeInformation

TypeInformation - object

Description

TypeInformation Class

Interfaces

ITypeInformation

Properties of ITypeInformation

Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.


TypeLibrary

TypeLibrary - object

Description

TypeLibrary Class

Interfaces

ITypeLibrary

Methods of ITypeLibrary

EnumValueAsString | resolve a enum value into a string
FindEnum | find a enum by name

Properties of ITypeLibrary

Documentation | R/O | property Documentation
FullPathname | R/O | property FullPathname
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
LocaleID | R/O | property LocaleID
MajorVersion | R/O | property MajorVersion
MinorVersion | R/O | property MinorVersion
Name | R/W | property Name

Collections of ITypeLibrary

TypeInfos property TypeInfos


FullPathname

FullPathname - Read property

Description

property FullPathname

Syntax in Visual Basic or VBScript

FullPathname () As String

Syntax in C++

HRESULT get_FullPathname (BSTR* retVal)

Applies to

TypeLibrary


LocaleID

LocaleID - Read property

Description

property LocaleID

Syntax in Visual Basic or VBScript

LocaleID () As Long

Syntax in C++

HRESULT get_LocaleID (LONG* retVal)

Applies to

TypeLibrary


MajorVersion

MajorVersion - Read property

Description

property MajorVersion

Syntax in Visual Basic or VBScript

MajorVersion () As Integer

Syntax in C++

HRESULT get_MajorVersion (INT* retVal)

Applies to

TypeLibrary


MinorVersion

MinorVersion - Read property

Description

property MinorVersion

Syntax in Visual Basic or VBScript

MinorVersion () As Integer

Syntax in C++

HRESULT get_MinorVersion (INT* retVal)

Applies to

TypeLibrary


EnumValueAsString

EnumValueAsString - method

Description

resolve a enum value into a string

Syntax in Visual Basic or VBScript

EnumValueAsString (enumName As String , enumValue As Long) As String

Syntax in C++

HRESULT EnumValueAsString (BSTR enumName , LONG enumValue , BSTR* retVal)

Parameters

Name | Description
enumName |
enumValue |
Return Value |

Applies to

TypeLibrary


FindEnum

FindEnum - method

Description

find a enum by name

Syntax in Visual Basic or VBScript

FindEnum (enumName As String) As Enum

Syntax in C++

HRESULT FindEnum (BSTR enumName , Enum* retVal)

Parameters

Name | Description
enumName |
Return Value |

Applies to

TypeLibrary


TypeInfos

TypeInfos - Read property

Description

property TypeInfos

Syntax in Visual Basic or VBScript

TypeInfos () As Collection

Syntax in C++

HRESULT get_TypeInfos (Collection* retVal)

Applies to

TypeLibrary


UnitConverter

UnitConverter - object

Description

UnitConverter Class

Interfaces

IUnitConverter

Methods of IUnitConverter

Convert
LoadUnitFile
UNITTYPE


Convert

Convert - method

Syntax in Visual Basic or VBScript

Convert (value As Double , unitFrom As String , unitTo As String) As Double

Syntax in C++

HRESULT Convert (double value , BSTR unitFrom , BSTR unitTo , double* retVal)

Parameters

Name | Description
value |
unitFrom |
unitTo |
Return Value |

Applies to

UnitConverter


LoadUnitFile

LoadUnitFile - method

Syntax in Visual Basic or VBScript

LoadUnitFile (file As String)

Syntax in C++

HRESULT LoadUnitFile (BSTR file)

Parameters

Name | Description
file |

Applies to

UnitConverter


UNITTYPE

UNITTYPE - method

Syntax in Visual Basic or VBScript

UNITTYPE (unit As String) As UNITTYPE

Syntax in C++

HRESULT UNITTYPE (BSTR unit , UNITTYPE* retVal)

Parameters

Name | Description
unit |
Return Value |

Applies to

UnitConverter


UnitVector3D

UnitVector3D - object

Description

UnitVector Class

Interfaces

IUnitVector3D

Methods of IUnitVector3D

GetCoordinates | retreives the 3 coordinates ( cartesian ) in one round trip ( this version cannot be used in scripts )
GetCoordinatesV | retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )
Reverse | Reverse the vector
SetApparentAngles | set the ABC coordinates of the vector
SetAzimuthElevation | set the Azimuth and Elevation of the vector , keeping the length
SetCoordinates | set the IJK coordinates of the vector ( coordinates will be unified)
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties of IUnitVector3D

A | R/O | retrieve the A angle of the vector (angle in the XY plane)
Azimuth | R/W | retrieve the Azimuth angle of the vector
B | R/O | retrieve the B angle of the vector (angle in the YZ plane)
C | R/O | retrieve the C angle of the vector (angle in the ZX plane)
Elevation | R/W | retrieve the Elevation angle coordinate of the vector
I | R/W | retrieve the I coordinate of the vector
J | R/W | retrieve the J coordinate of the vector
K | R/W | retrieve the K coordinate of the vector
Magnitude | R/W | get the Magnitude of the vector ( Third Spherical Coordinate)
Value | R/W |


VarDesc

VarDesc - object

Description

Constant Class

Interfaces

IVarDesc

Properties of IVarDesc

CPPType | R/O |
Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
type | R/W |
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.
VBType | R/O |


CPPType

CPPType - Read property

Syntax in Visual Basic or VBScript

CPPType () As String

Syntax in C++

HRESULT get_CPPType (BSTR* retVal)

Applies to

VarDesc


VBType

VBType - Read property

Syntax in Visual Basic or VBScript

VBType () As String

Syntax in C++

HRESULT get_VBType (BSTR* retVal)

Applies to

VarDesc


Vector3D

Vector3D - object

Description

Vector Class

Interfaces

IVector3D

Methods of IVector3D

GetCoordinates | retreives the 3 coordinates ( cartesian ) in one round trip
GetCoordinatesV | retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )
Scale | scale this vector by a factor
SetApparentAngles | set the ABC coordinates of the vector
SetAzimuthElevation | set the Azimuth and Elevation of the vector , keeping the length
SetCoordinates | set the IJK coordinates of the vector ( coordinates will be unified)
SetPolarCoordinates | set the Polar coordinates (Angle,Radius,Height) of the vector
SetSphericalCoordinates | set the Spherical coordinates (Azimuth,Elevation,Magnitude) of the vector
TransformFrom | Transformation of points
TransformTo | Transformation of points
Unify | make this vector a unit vector

Properties of IVector3D

A | R/O | retrieve the A angle of the vector (angle in the XY plane)
Azimuth | R/W | retrieve the Azimuth angle of the vector
B | R/O | retrieve the B angle of the vector (angle in the YZ plane)
C | R/O | retrieve the C angle of the vector (angle in the ZX plane)
Elevation | R/W | retrieve the Elevation angle coordinate of the vector
I | R/W | retrieve the I coordinate of the vector
J | R/W | retrieve the J coordinate of the vector
K | R/W | retrieve the K coordinate of the vector
Magnitude | R/W | get the Magnitude of the vector ( Third Spherical Coordinate)
Value | R/W |


VerticeSelectionManager

VerticeSelectionManager - object

Description

A selection manager that handles vertice selection on an CADFILE

Interfaces

IVerticeSelectionManager

Events

OnSelectionChange indicates that the selection has changed

Methods of IVerticeSelectionManager

Activate | enter the Geometry Explorer mode
Cancel | exit the Geometry Explorer

Properties of IVerticeSelectionManager

Count | R/O | indicates the number selected vertex
Filter | R/W | set/retrieve the filter type / pwicetUNSPECIFIED if no filter
Item | R/O | Allows random access to individual Vertex within the collection. Index can be an ordinal from 1 to Count or a string
Mode | R/W | set/retrieve the geometry explorer mode
Parent | T/O | indicates the parent of this object : a PowerINSPECT Document

Collections of IVerticeSelectionManager

ExtraEntities retrieve the extra feature available


Filter

Filter - Read & Write property

Description

set/retrieve the filter type / pwicetUNSPECIFIED if no filter

Syntax in Visual Basic or VBScript

Filter () As PWICADENTITYTYPE

Syntax in C++

HRESULT get_Filter (PWICADENTITYTYPE* retVal)
HRESULT put_Filter (PWICADENTITYTYPE Value)

Applies to

VerticeSelectionManager


Mode

Mode - Read & Write property

Description

set/retrieve the geometry explorer mode

Syntax in Visual Basic or VBScript

Mode () As GeometryExplorerMode

Syntax in C++

HRESULT get_Mode (GeometryExplorerMode* retVal)
HRESULT put_Mode (GeometryExplorerMode Value)

Applies to

VerticeSelectionManager


Activate

Activate - method

Description

enter the Geometry Explorer mode

Syntax in Visual Basic or VBScript

Activate ()

Syntax in C++

HRESULT Activate ()

Applies to

VerticeSelectionManager


Cancel

Cancel - method

Description

exit the Geometry Explorer

Syntax in Visual Basic or VBScript

Cancel ()

Syntax in C++

HRESULT Cancel ()

Applies to

VerticeSelectionManager


ExtraEntities

ExtraEntities - Read property

Description

retrieve the extra feature available

Syntax in Visual Basic or VBScript

ExtraEntities () As ICADEntities

Syntax in C++

HRESULT get_ExtraEntities (ICADEntities* retVal)

Applies to

VerticeSelectionManager


WebScreen

WebScreen - object

Description

WebScreen Class

Interfaces

IWebScreen

Events

OnDoubleClick | Fires when the user double-clicks the object.
OnKeyDown | Fires when the user presses a key.
OnKeyPress | Fires when the user presses an alphanumeric key.
OnKeyUp | Fires when the user releases a key.
OnMouseDown | Fired when the user presses a mouse button down.
OnMouseLClick | Fired when the user clicks on a report in editing mode with the left button.
OnMouseMove | Fires when the user moves the mouse over the object.
OnMouseOver | Fires when the user moves the mouse pointer into the object.
OnMouseRClick | Fired when the user clicks on a report in editing mode with the right button.
OnMouseUp | Fires when the user releases a mouse button while the mouse is over the object.
OnResize | Fires when the size of the object is about to change.
OnScroll | Fires when the user repositions the scroll box in the scroll bar on the object.
ReportCompleted | Fired when a report creation was completely finished.

Methods of IWebScreen

CallScript | method CallScript
Export | method Export
Print | method Print
RefreshReport | Force the current showing report to be re-generated
ReportSettings | Returns XML reported by report engine about settings of report
ShowPageSetup | method ShowPageSetup
ShowPrintPreview | method ShowPrintPreview

Properties of IWebScreen

DHTMLBridge | R/O | property DHTMLBridge
Editing | R/W | Set/Retrieve the editing mode
IsReportReady | R/O | property IsReportReady
MaximumTimeout | R/W | Configures maximum time for report creation, milliseconds
PIXmlDocument | R/W | property PIXmlDocument
RegistryOptionPath | R/O | Returns registry subpath of HCKU where used settings of IE are contained
ReportConfigName | R/W | property ReportConfigName
templatesManager | R/W | Allows to set/get template manager object for this report document
WebBrowser | T/O | property WebBrowser


DHTMLBridge

DHTMLBridge - Read property

Description

property DHTMLBridge

Syntax in Visual Basic or VBScript

DHTMLBridge () As rbDHTMLBridge

Syntax in C++

HRESULT get_DHTMLBridge (rbDHTMLBridge* retVal)

Applies to

WebScreen


Editing

Editing - Read & Write property

Description

Set/Retrieve the editing mode

Syntax in Visual Basic or VBScript

Editing () As Boolean

Syntax in C++

HRESULT get_Editing (VARIANT_BOOL* retVal)
HRESULT put_Editing (VARIANT_BOOL Value)

Applies to

WebScreen


IsReportReady

IsReportReady - Read property

Description

property IsReportReady

Syntax in Visual Basic or VBScript

IsReportReady () As Boolean

Syntax in C++

HRESULT get_IsReportReady (VARIANT_BOOL* retVal)

Applies to

WebScreen


MaximumTimeout

MaximumTimeout - Read & Write property

Description

Configures maximum time for report creation, milliseconds

Syntax in Visual Basic or VBScript

MaximumTimeout () As Long

Syntax in C++

HRESULT get_MaximumTimeout (LONG* retVal)
HRESULT put_MaximumTimeout (LONG Value)

Applies to

WebScreen


PIXmlDocument

PIXmlDocument - Read & Write property

Description

property PIXmlDocument

Syntax in Visual Basic or VBScript

PIXmlDocument () As IXMLDOMNode

Syntax in C++

HRESULT get_PIXmlDocument (IXMLDOMNode* retVal)
HRESULT put_PIXmlDocument (IXMLDOMNode* Value)

Applies to

WebScreen


RegistryOptionPath

RegistryOptionPath - Read property

Description

Returns registry subpath of HCKU where used settings of IE are contained

Syntax in Visual Basic or VBScript

RegistryOptionPath () As String

Syntax in C++

HRESULT get_RegistryOptionPath (BSTR* retVal)

Applies to

WebScreen


ReportConfigName

ReportConfigName - Read & Write property

Description

property ReportConfigName

Syntax in Visual Basic or VBScript

ReportConfigName () As String

Syntax in C++

HRESULT get_ReportConfigName (BSTR* retVal)
HRESULT put_ReportConfigName (BSTR Value)

Applies to

WebScreen


templatesManager

templatesManager - Read & Write property

Description

Allows to set/get template manager object for this report document

Syntax in Visual Basic or VBScript

templatesManager () As rbTemplatesManager

Syntax in C++

HRESULT get_templatesManager (rbTemplatesManager* retVal)
HRESULT put_templatesManager (rbTemplatesManager* Value)

Applies to

WebScreen


WebBrowser

WebBrowser - Reference Write property

Description

property WebBrowser

Syntax in Visual Basic or VBScript

WebBrowser () As Object

Syntax in C++

HRESULT get_WebBrowser (IDispatch** retVal)

Applies to

WebScreen


CallScript

CallScript - method

Description

method CallScript

Syntax in Visual Basic or VBScript

CallScript (name_of_func As String , id_of_item As Variant)

Syntax in C++

HRESULT CallScript (BSTR name_of_func , VARIANT id_of_item)

Parameters

Name | Description
name_of_func |
id_of_item |

Applies to

WebScreen


Export

Export - method

Description

method Export

Syntax in Visual Basic or VBScript

Export (filename As String)

Syntax in C++

HRESULT Export (BSTR filename)

Parameters

Name | Description
filename |

Applies to

WebScreen


OnDoubleClick

OnDoubleClick - event

Description

Fires when the user double-clicks the object.

Syntax in Visual Basic or VBScript

OnDoubleClick (a_event As Object)

Syntax in C++

HRESULT OnDoubleClick (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnKeyDown

OnKeyDown - event

Description

Fires when the user presses a key.

Syntax in Visual Basic or VBScript

OnKeyDown (a_event As Object)

Syntax in C++

HRESULT OnKeyDown (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnKeyPress

OnKeyPress - event

Description

Fires when the user presses an alphanumeric key.

Syntax in Visual Basic or VBScript

OnKeyPress (a_event As Object)

Syntax in C++

HRESULT OnKeyPress (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnKeyUp

OnKeyUp - event

Description

Fires when the user releases a key.

Syntax in Visual Basic or VBScript

OnKeyUp (a_event As Object)

Syntax in C++

HRESULT OnKeyUp (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnMouseDown

OnMouseDown - event

Description

Fired when the user presses a mouse button down.

Syntax in Visual Basic or VBScript

OnMouseDown (a_event As Object)

Syntax in C++

HRESULT OnMouseDown (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnMouseLClick

OnMouseLClick - event

Description

Fired when the user clicks on a report in editing mode with the left button.

Syntax in Visual Basic or VBScript

OnMouseLClick (a_event As Object)

Syntax in C++

HRESULT OnMouseLClick (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnMouseMove

OnMouseMove - event

Description

Fires when the user moves the mouse over the object.

Syntax in Visual Basic or VBScript

OnMouseMove (a_event As Object)

Syntax in C++

HRESULT OnMouseMove (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnMouseOver

OnMouseOver - event

Description

Fires when the user moves the mouse pointer into the object.

Syntax in Visual Basic or VBScript

OnMouseOver (a_event As Object)

Syntax in C++

HRESULT OnMouseOver (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnMouseRClick

OnMouseRClick - event

Description

Fired when the user clicks on a report in editing mode with the right button.

Syntax in Visual Basic or VBScript

OnMouseRClick (a_event As Object)

Syntax in C++

HRESULT OnMouseRClick (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnMouseUp

OnMouseUp - event

Description

Fires when the user releases a mouse button while the mouse is over the object.

Syntax in Visual Basic or VBScript

OnMouseUp (a_event As Object)

Syntax in C++

HRESULT OnMouseUp (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnResize

OnResize - event

Description

Fires when the size of the object is about to change.

Syntax in Visual Basic or VBScript

OnResize (a_event As Object)

Syntax in C++

HRESULT OnResize (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


OnScroll

OnScroll - event

Description

Fires when the user repositions the scroll box in the scroll bar on the object.

Syntax in Visual Basic or VBScript

OnScroll (a_event As Object)

Syntax in C++

HRESULT OnScroll (IDispatch* a_event , HRESULT* retVal)

Parameters

Name | Description
a_event |

Applies to

WebScreen


Print

Print - method

Description

method Print

Syntax in Visual Basic or VBScript

Print (is_show_ui As Long)

Syntax in C++

HRESULT Print (LONG is_show_ui)

Parameters

Name | Description
is_show_ui |

Applies to

WebScreen


RefreshReport

RefreshReport - method

Description

Force the current showing report to be re-generated

Syntax in Visual Basic or VBScript

RefreshReport ()

Syntax in C++

HRESULT RefreshReport ()

Applies to

WebScreen


ReportCompleted

ReportCompleted - event

Description

Fired when a report creation was completely finished.

Syntax in Visual Basic or VBScript

ReportCompleted ()

Syntax in C++

HRESULT ReportCompleted (HRESULT* retVal)

Applies to

WebScreen


ReportSettings

ReportSettings - method

Description

Returns XML reported by report engine about settings of report

Syntax in Visual Basic or VBScript

ReportSettings (a_item_id As String) As String

Syntax in C++

HRESULT ReportSettings (BSTR a_item_id , BSTR* retVal)

Parameters

Name | Description
a_item_id |
Return Value |

Applies to

WebScreen


ShowPageSetup

ShowPageSetup - method

Description

method ShowPageSetup

Syntax in Visual Basic or VBScript

ShowPageSetup ()

Syntax in C++

HRESULT ShowPageSetup ()

Applies to

WebScreen


ShowPrintPreview

ShowPrintPreview - method

Description

method ShowPrintPreview

Syntax in Visual Basic or VBScript

ShowPrintPreview ()

Syntax in C++

HRESULT ShowPrintPreview ()

Applies to

WebScreen


Axes

Axes - Read property

Description

The list of machine axes.

Syntax in Visual Basic or VBScript

Axes () As MachineAxes

Syntax in C++

HRESULT get_Axes (MachineAxes* retVal)

Applies to

MachineOrientationData


Categories

Categories - Read property

Description

property Categories

Syntax in Visual Basic or VBScript

Categories () As CMMParametersCategories

Syntax in C++

HRESULT get_Categories (CMMParametersCategories* retVal)

Applies to

CMMParameters


Clone

Clone - method

Description

Clone : create an exact copy of this object and return a pointer to it

Syntax in Visual Basic or VBScript

Clone () As CMMParameters

Syntax in C++

HRESULT Clone (CMMParameters* retVal)

Parameters

Name | Description
Return Value |

Applies to

CMMParameters


entities

entities - Read property

Description

a list of entities in the document

Syntax in Visual Basic or VBScript

entities () As IXMLDOMNamedNodeMap

Syntax in C++

HRESULT get_entities (IXMLDOMNamedNodeMap* retVal)

Applies to

IXMLDOMDocumentType


getElementsByTagName

getElementsByTagName - method

Description

build a list of elements by name

Syntax in Visual Basic or VBScript

getElementsByTagName (tagName As String) As IXMLDOMNodeList

Syntax in C++

HRESULT getElementsByTagName (BSTR tagName , IXMLDOMNodeList* retVal)

Parameters

Name | Description
tagName |
Return Value |

Applies to

IXMLDOMDocument


Item

Item - Read property

Description

Allows random access to individual Category object within the collection. Index can be an ordinal from 0 to Count -1 or a string being a name of a category

Syntax in Visual Basic or VBScript

Item (Index As Variant) As CMMParametersCategory

Syntax in C++

HRESULT get_Item (VARIANT Index , CMMParametersCategory* retVal)

Applies to

CMMParametersCategories


notations

notations - Read property

Description

a list of notations in the document

Syntax in Visual Basic or VBScript

notations () As IXMLDOMNamedNodeMap

Syntax in C++

HRESULT get_notations (IXMLDOMNamedNodeMap* retVal)

Applies to

IXMLDOMDocumentType


selectNodes

selectNodes - method

Description

execute query on the subtree

Syntax in Visual Basic or VBScript

selectNodes (queryString As String) As IXMLDOMNodeList

Syntax in C++

HRESULT selectNodes (BSTR queryString , IXMLDOMNodeList* retVal)

Parameters

Name | Description
queryString |
Return Value |

Applies to

IXMLDOMNode


_IAddInManagerEvents

_IAddInManagerEvents - interface

Description

_IAddInManagerEvents Interface

Methods

OnResetUserInterface


_IApplicationEvents

_IApplicationEvents - interface

Methods

ApplicationBeforeClose | fires when the application is about to close and to shutydown : client should release all the pointer to the application at this stage
CMMConnectionAboutToChange |
DocumentActivate |
DocumentBeforeClose |
DocumentBeforeSave |
DocumentClose | indicates that this document is going to be closed and should not be accessed anymore
DocumentDeactivate |
DocumentOpen |
NewDocument |
OnActiveItemChange | indictates that the active item ( as selected in the active Tree view ) has changed
OnActiveMeasureChange | indictates that the active measure ( as selected in the active Tree view ) has changed
OnExecuteCustomAction | indicates that PowerINSPECT is about to execute a custom action
OnFullScreenInspectionCompleted | indicates that a full screen inspection has completed
OnFullScreenInspectionStarted | indicates that a full screen inspection has started
OnItemChange | indicates that an item definition has changed
OnItemMeasureChange | indicates that an item measurement has changed
OnLocaleChange | indicates that the locale setting has change


_ICarriageEvents

_ICarriageEvents - interface

Description

_ICarriageEvents Interface : events generated by a CCarriage Object

Methods

ActiveSensorChanged | fired after the active sensor on the probe Head has changed
ActiveTipChanged | fired after the active tip on the probe Head has changed
ActiveToolChanged | fired after the active tool mounted on the probe Head has changed
CalibrationStatusChanged | fired when the status of the calibration changed for the given item : item could be head,sensor,or tip
ConfigurationChanged | fired when the configuration of the carriage has changed
ExtendsChanged | fired when the extends of the carriage has changed
Loaded | fired when the carriage has been persisted back from a storage
ProbeHeadChanged | fired after the probe Head has changed
ProbeHeadPositionChanged | fired when the position of the probe head has changed
ProbeTipAdded | fired when a probe tip has been added
ProbeTipDeleted | fired when a probe tip has been deleted
TransactionEnded | fired when a transaction is committed or rolled back
TransactionStarted | fired when we start a transaction


_ICMMParameterEvents

_ICMMParameterEvents - interface

Description

_ICMMParameterEvents Interface

Methods

OnChanged | method OnChanged
OnChangeRequested | method OnChangeRequested


_ICMMParametersEvents

_ICMMParametersEvents - interface

Description

_ICMMParametersEvents Interface

Methods

OnCMMParameterChanged | method OnCMMParamerChanged
OnCMMParameterChangeRequested | method OnCMMParameterChangeRequested


_ICMMProtocolEvents

_ICMMProtocolEvents - interface

Description

_ICMMProtocolEvents Interface

Methods

CNCControllingLockChanged | Fired when a CNC controlling object locks or unlocks its CNC control
ContactPoint | method ContactPoint
ContactPointCalibration | method ContactPointCalibration
EnableModeless | Fired to request the client to disable or enable its main window and other modeless dialogs
IntermediatePoint | method IntermediatePoint
OnCalibrationModeChanged | OnCalibration Mode change
OnCMMHomed | method OnCMMHomed : the CMM homed flag is now set
OnCMMParameterChanged | method OnCMMParamerChanged
OnCNCStatusChanged | method OnCNCStatusChanged
OnCompletion | method OnCNCError
OnConnectionChanged | method Connect
OnReadyForCommand | method OnReadyForCommand: call to the Protocol Object can be made here
OnRefMarks | method OnRefMarks
PreTouchIJKModeChanged | method PreTouchIJKModeChanged
ProbeDatabaseChanged | Fired by the protocol if the probe database object changes
ProbeTipChanged | Fired by the protocol for convenience when the probe database fires its ProbeTipChanged event
RemoteMouseChanged | Fired when the protocol's remote mouse state changes
RequestDisconnect | Fired to request consent to disconnect
TransactionChanged | Fired by the protocol when it has been informed that a transaction has started or stopped
VirtualCommand | method VirtualCommand
VirtualCommandCalibration | method VirtualCommandCalibration


_ICMMSimulatorEvents

_ICMMSimulatorEvents - interface

Description

_ICMMSimulatorEvents Interface

Methods

OnIntermediatePoint | Fired when the user has inserted a intermediate point
OnManualContactPoint | Fired when a contact point has been probed manually


_ICMMUIExtensionCommandsEvents

_ICMMUIExtensionCommandsEvents - interface

Methods

CommandsModified | method CommandsModified
CommandStateChanged | method CommandStateChanged


CommandsModified

CommandsModified - method

Description

method CommandsModified

Syntax in Visual Basic or VBScript

CommandsModified ()

Syntax in C++

HRESULT CommandsModified ()

Applies to

_ICMMUIExtensionCommandsEvents


CommandStateChanged

CommandStateChanged - method

Description

method CommandStateChanged

Syntax in Visual Basic or VBScript

CommandStateChanged (ByRef pExtensionCommand As ICMMUIExtensionCommand)

Syntax in C++

HRESULT CommandStateChanged (ICMMUIExtensionCommand* pExtensionCommand)

Parameters

Name | Description
pExtensionCommand |

Applies to

_ICMMUIExtensionCommandsEvents


_ICollectionEvents

_ICollectionEvents - interface

Description

_ICollectionEvents Interface

Methods

Add | fired after a element has been inserted into the collection
AfterDelete | fired after a element has been removed from the collection
Changed | fired after a element definition has changed
Delete | fired before a element will be removed from the collection


_ICommandBarButtonEvents

_ICommandBarButtonEvents - interface

Description

_ICommandBarButtonEvents Interface

Methods

Click method Click


_ICommandBarComboBoxEvents

_ICommandBarComboBoxEvents - interface

Description

_ICommandBarComboBoxEvents Interface

Methods

Change method Change


_ICommandBarControlsEvents

_ICommandBarControlsEvents - interface

Description

_ICommandBarControlsEvents Interface


_ICommandBarEvents

_ICommandBarEvents - interface

Description

_ICommandBarEvents Interface


_ICommandBarsEvents

_ICommandBarsEvents - interface

Description

_ICommandBarsEvents Interface


_IDocumentEvents

_IDocumentEvents - interface

Methods

BeforeCommandExecution | indicates that PowerINSPECT is about to execute a command
BeforeDeleteItem | indicates that an item is beeing deleted from document
BeforeDeleteMeasure | indicates that a measure is beeing deleted from document
GeometryExplorerEvent | fired when the user has made a selection with GE
OnActiveItemChange | indictates that the active item ( as selected in the active Tree view ) has changed
OnActiveMeasureChange | indictates that the active measure ( as selected in the active Tree view ) has changed
OnActiveWorkplaneChanged | The current Active work plane has changed
OnAddDynamicPoint | indicates that a dynamic point has been added on the collection
OnAddItem | indicates that a new item has been added to the document
OnBeforeDeleteDynamicPoint | indicates that a dynamic point is about to be removed from the collection
OnBeforeModifyDynamicPoint | indicates that a dynamic point in the collection is about to be modfied
OnBeforeMoveItem | Indicates that the specified item is going to be moved in the sequence tree. there is a opportunity to cancel the action
OnItemChange | indicates that an item definition has changed
OnItemMeasureChange | indicates that an item measurement has changed
OnItemMeasurementCompleted | indictates that element has leaved the Measurement state
OnItemMeasurementStart | indictates that element has entered a Measurement state for the specified measure ( the GUI to measure this item is about to be display )
OnLoggedInUserChanged | Indicates that the user has changed (security). The argument states whether the user can change items in the sequence tree.
OnMeasureAdd | indicates that an new measure has been added to the document
OnModifyDynamicPoint | indicates that a dynamic point in the collection has been modfied
OnPaletteButtonClicked | indicates that PowerINSPECT is about to open the dialog box to edit a inserted item, this give a chance not to display it by setting the boolean flag to TRUE
OnRangeMarkersChanged | indicates that the range markers in the sequence tree have changed.
OnStrategyUpdateRequested | The application has requested a Probe Path Update from the strategy
OnUnitChange | indicates that units of the document has changed
QueryDeleteItem | indicates that an item is asked to be deleted from document by the user
QueryDeleteMeasure | indicates that an measure is asked to be deleted from document by the user


_IDynamicPointsEvents

_IDynamicPointsEvents - interface

Methods

OnAddDynamicPoint | indicates that a dynamic point has been added on the collection
OnBeforeDeleteDynamicPoint | indicates that a dynamic point is about to be removed from the collection
OnBeforeModifyDynamicPoint | indicates that a dynamic point in the collection is about to be modfied
OnModifyDynamicPoint | indicates that a dynamic point in the collection has been modfied


_IIndexableProbeHeadEvents

_IIndexableProbeHeadEvents - interface

Description

_IIndexableProbeHeadEvents Interface

Methods

ActiveSensorChanged | fired after the active Sensor on the probe Head has changed
ActiveTipChanged | fired after the active tip on the probe Head has changed
AnglesChanged | method OnProbeHeadAnglesChanged
CalibrationStatusChanged | fired when the status of the calibration changed
ToolChanged | method ProbeHeadActiveToolChanged


_IIndexableProbeHeadProtocolEvents

_IIndexableProbeHeadProtocolEvents - interface

Description

_IIndexableProbeHeadProtocolEvents Interface

Methods

ProbeHeadAnglesChanged method OnProbeHeadAnglesChanged


_IOMVImportCtrlEvents

_IOMVImportCtrlEvents - interface

Description

_IOMVImportCtrlEvents Interface

Methods

OnClose | Fired when the control is asked to close.
OnSettingsChanged | Fired when the import setting was changed by a user.


_IOMVImporterEvents

_IOMVImporterEvents - interface

Description

_IOMVImporterEvents Interface

Methods

OnCurrentItemProgressChanged | method OnCurrentItemProgressChanged
OnError | method OnError
OnItemImported | method OnItemImported
OnProgressChanged | method OnProgressChanged
OnStatusChanged | method OnStatusChanged


_IPositionEvents

_IPositionEvents - interface

Description

_IPositionEvents Interface


_IProbePathEditorEvents

_IProbePathEditorEvents - interface

Methods

OnStatusChanged indicates that the state of the ProbePathEditor has changed


_IProbePathEvents

_IProbePathEvents - interface

Description

_IProbePathEvents Interface

Methods

BeforeDeleteItem | an item is about to be deleted from the ProbePath
OnAddItem | an item has been added to the ProbePath
OnGlobalChange | All elements of the probe path have changed
OnItemChange | an item has changed
OnItemDeleted | an item has been delete from the collection ( see BeforeDeleteItem)
OnItemPositionMeasured | method OnItemPositionMeasured
OnLockStateChanged | the lock state of the probe path items has changed


_IProbePathReplayEvents

_IProbePathReplayEvents - interface

Description

_IProbePathReplayEvents Interface

Methods

OnCNCError | Fired when a CNC error occurs during the reply, asking whether to retry and continue
OnJobStatusChanged | Change when the job status has changed
OnStepStatusChanged | Change when the status of the current step has changed


_IProbePathReplayEvents2

_IProbePathReplayEvents2 - interface

Description

_IProbePathReplayEvents Interface

Methods

GetProbePathReplay |
OnCNCError | Fired when a CNC error occurs during the reply, asking whether to retry and continue
OnJobStatusChanged | Change when the job status has changed
OnStepStatusChanged | Change when the status of the current step has changed


GetProbePathReplay

GetProbePathReplay - method

Syntax in Visual Basic or VBScript

GetProbePathReplay () As ProbePathReplay

Syntax in C++

HRESULT GetProbePathReplay (ProbePathReplay* retVal)

Parameters

Name | Description
Return Value |

Applies to

_IProbePathReplayEvents2


_IProbePathTeachEvents

_IProbePathTeachEvents - interface

Description

_IProbePathTeachEvents Interface

Methods

OnCoordTypeChange | the Coordinate Type has has changed (ABSOLUTE/INCREMENTAL
OnCursorChange | the insertion point has changed
OnPositionalItemTypeChange | Fire_OnPositionalItemTypeChange


_IProbeToolEvents

_IProbeToolEvents - interface

Description

_IProbeToolEvents Interface

Methods

ActiveSensorChange


_IrbDHTMLBridgeEvents

_IrbDHTMLBridgeEvents - interface

Description

_IrbDHTMLBridgeEvents Interface


_ISelectionManagerEvents

_ISelectionManagerEvents - interface

Methods

OnSelectionChange indicates that the selection has changed


_ISequenceReplayEngineCtrlEvents

_ISequenceReplayEngineCtrlEvents - interface

Description

_ISequenceReplayEngineCtrlEvents Interface

Methods

OnClickedBackOneStep | Fired when the user presses the One Step button
OnClickedDoNextStep | Fired when the user presses the Next Step button
OnClickedEStop | Fired when the user presses the EStop button
OnClickedFullStop | Fired when the user presses the Full Stop button
OnClickedReplay | Fired when the user presses the Replay button
OnClickedRewind | Fired when the user presses the Rewind button
OnClickedSuspend | Fired when the user presses the Suspend button


_ISequenceReplayEngineEvents

_ISequenceReplayEngineEvents - interface

Description

_ISequenceReplayEngineEvents Interface

Methods

OnCNCError | Fired when a CNC error occurs during the reply, asking whether to retry and continue
OnCurrentItemProgressChanged | Fired to notify progress on the current item being replayed
OnStatusChanged | Change when the job status has changed


_ISimpleProbeDatabaseEvents

_ISimpleProbeDatabaseEvents - interface

Description

_ISimpleProbeDatabaseEvents Interface

Methods

ProbeTipChanged method OnProbeTipChanged


_ISynchronousReplayEvents

_ISynchronousReplayEvents - interface

Description

_IProbePathReplayEvents Interface

Methods

OnCNCError | Fired when a CNC error occurs during the reply, asking whether to retry and continue
OnStepStatusChanged | Change when the status of the current step has changed
OnTick | Change when the job status has changed


OnTick

OnTick - method

Description

Change when the job status has changed

Syntax in Visual Basic or VBScript

OnTick ()

Syntax in C++

HRESULT OnTick ()

Applies to

_ISynchronousReplayEvents


_ITemperedTrackingPointsEvents

_ITemperedTrackingPointsEvents - interface

Description

_ITemperedTrackingPointsEvents Interface

Methods

TrackingPoint method TrackingPoint


_IToolChangerEvents

_IToolChangerEvents - interface

Description

_IToolChangerEvents Interface

Methods

CalibrationStatusChanged | fired when the status of the calibration changed
StatusChanged | fired when the tool changer status has changed


_IWebScreenEvents

_IWebScreenEvents - interface

Description

_IWebScreenEvents Interface

Methods

OnDoubleClick | Fires when the user double-clicks the object.
OnKeyDown | Fires when the user presses a key.
OnKeyPress | Fires when the user presses an alphanumeric key.
OnKeyUp | Fires when the user releases a key.
OnMouseDown | Fired when the user presses a mouse button down.
OnMouseLClick | Fired when the user clicks on a report in editing mode with the left button.
OnMouseMove | Fires when the user moves the mouse over the object.
OnMouseOver | Fires when the user moves the mouse pointer into the object.
OnMouseRClick | Fired when the user clicks on a report in editing mode with the right button.
OnMouseUp | Fires when the user releases a mouse button while the mouse is over the object.
OnResize | Fires when the size of the object is about to change.
OnScroll | Fires when the user repositions the scroll box in the scroll bar on the object.
ReportCompleted | Fired when a report creation was completely finished.


IActiveObject

IActiveObject - interface

Description

IActiveObject Interface

Methods

Delete Deletes the object and remove it from it's containing document

Properties

AutoLoad | R/W | property AutoLoad : True if the OLE object is automatically loaded when the document that contains it is opened. Read/write Boolean.
Index | R/O | Returns the index number of the object within the collection of similar objects. Read-only Long.
Name | R/W | property Name
Object | T/O | Returns the OLE Automation object associated with this OLE object. Read-only Object.
ProgID | R/O | property ProgID


IAddInCollection

IAddInCollection - interface

Description

IAddInCollection Interface

Methods

Add | Add an add in
Remove | Remove an add-in by index ( zero based ) , prog ID or IDispatch

Properties

Application | T/O | returns the application object
Count | R/O | returns the number of add-in in the collection
Item | R/O | returns the item at index ( zero based or progID)

Used in

AddInCollection


Application

Application - Reference Write property

Description

returns the application object

Syntax in Visual Basic or VBScript

Application () As Object

Syntax in C++

HRESULT get_Application (IDispatch** retVal)

Applies to

IAddInCollection


Count

Count - Read property

Description

returns the number of add-in in the collection

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

IAddInCollection


Item

Item - Read property

Description

returns the item at index ( zero based or progID)

Syntax in Visual Basic or VBScript

Item (lIndex As Variant) As IAddInInfo

Syntax in C++

HRESULT get_Item (VARIANT lIndex , IAddInInfo* retVal)

Applies to

IAddInCollection


Add

Add - method

Description

Add an add in

Syntax in Visual Basic or VBScript

Add (Filename As String) As IAddInInfo

Syntax in C++

HRESULT Add (BSTR Filename , IAddInInfo* retVal)

Parameters

Name | Description
Filename |
Return Value |

Applies to

IAddInCollection


Remove

Remove - method

Description

Remove an add-in by index ( zero based ) , prog ID or IDispatch

Syntax in Visual Basic or VBScript

Remove (addin_or_progID_or_index As Variant)

Syntax in C++

HRESULT Remove (VARIANT addin_or_progID_or_index)

Parameters

Name | Description
addin_or_progID_or_index |

Applies to

IAddInCollection


IAddInInfo

IAddInInfo - interface

Description

IAddIn Interface

Methods

Delete Deletes the object and remove it from it's containing document

Properties

AddInType | R/O |
AutoLoad | R/W | property AutoLoad : True if the OLE object is automatically loaded when the document that contains it is opened. Read/write Boolean.
Filename | R/O | property Filename
Index | R/O | Returns the index number of the object within the collection of similar objects. Read-only Long.
Loaded | R/W |
Object | T/O | Returns the OLE Automation object associated with this OLE object. Read-only Object.
ProgID | R/O | property ProgID


AddInType

AddInType - Read property

Syntax in Visual Basic or VBScript

AddInType () As PSAI_AddInType

Syntax in C++

HRESULT get_AddInType (PSAI_AddInType* retVal)

Applies to

IAddInInfo


Filename

Filename - Read property

Description

property Filename

Syntax in Visual Basic or VBScript

Filename () As String

Syntax in C++

HRESULT get_Filename (BSTR* retVal)

Applies to

IAddInInfo


Loaded

Loaded - Read & Write property

Description

Syntax in Visual Basic or VBScript

Loaded () As Boolean

Syntax in C++

HRESULT get_Loaded (VARIANT_BOOL* retVal)
HRESULT put_Loaded (VARIANT_BOOL Value)

Applies to

IAddInInfo


IAlignmentFreeFormFit

IAlignmentFreeFormFit - interface

Description

IAlignmentFreeFormFit interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
Results | returns a collection of result points
Targets | returns a collection of target points


IAlignmentFromFile

IAlignmentFromFile - interface

Description

IAlignmentFromFile Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
LoadFromFile |
Move | Move the item into a different location ( either within the same group or into a different group)
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IAlignmentItem

IAlignmentItem - interface

Description

IAlignmentItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IAlignmentRPS

IAlignmentRPS - interface

Description

IAlignmentRPS interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalDatum | R/W | returns a local datum
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IApplication

IApplication - interface

Description

IApplication Interface

Methods

CheckPaf | returns the number of day left for the licence: (0= no licence or expired) ( -1 = permanent ) ( n : n day left)
CreateLocalObject | Create a object in the same thread context as the PowerINSPECT Application
ExecuteCommand | Execute a command by string
ExecuteCommandID | Send a command to the application, a positive number 'send' a command, a negative number will 'post' a command
LogonUser | logon as a specific user
Quit | Quit the application
RequestDisconnection |
SendCMMPoint | Send a CMM point to PowerINSPECT
ShowHTMLDialog |

Properties

ActiveDocument | R/W | set/get the currently active document
ActiveItem | R/O | Returns the current active Sequence Item in the current active Tree
ActiveMeasure | R/O | Returns the current active Measure in the current active Tree
Application | R/O | property Application
BuildNumber | R/O | returns the PowerINSPECT current BuildNumber
CMMDriver | T/O | Retrieves the CMMDriver object which is hosted in the PowerINSPECT application
DelayInspection | R/W | Returns the state of the DelayInspection Flag
FeatureLicenced | R/O | Check if a feature is licenced
Fullscreen | R/W | Returns or sets the fullscreen Mode state
GDIHandlesInUse | R/O | Retrieve the number of GDI handles in use in the PI process.
Height | R/W | Returns or sets the size of the specified object, in points. ( 1 point = 1/72 inch)
hInstance | R/O | Retrieves the handle of the PowerINSPECT hInstance
hWnd | R/O | Retrieves the handle of the Main PowerINSPECT window
LCID | R/O | retrieve the current LCID
Left | R/W | Returns or sets the position of the specified object, in points. ( 1 point = 1/72 inch)
Locale | R/W | Set the locale used by PowerINSPECT. No documents must be opened. locale can be a string following the ISO standard or a LCID
MajorVersion | R/O | returns the PowerINSPECT Major Version
MinorVersion | R/O | returns the PowerINSPECT MinorVersion
Path | R/O | Retrieves the Path of the PowerINSPECT Executable
ProductType | R/O | Return the generic product type
RegistryPath | R/O | Retrieve registry path for application
Top | R/W | Returns or sets the position of the specified object, in points. ( 1 point = 1/72 inch)
UsableHeight | R/O | Returns maximum width of the specified object, in points. ( 1 point = 1/72 inch)
UsableWidth | R/O | Returns maximum width of the specified object, in points. ( 1 point = 1/72 inch)
UserHandlesInUse | R/O | Retrieve the number of User handles in use in the PI process.
Version | R/O | returns the version string
Visible | R/W |
Width | R/W | Returns or sets the size of the specified object, in points. ( 1 point = 1/72 inch)
WindowState | R/W | Returns or sets the main window state

Collections

AddInCollection | returns the AddIn Collection Object
CommandBars | returns the CommandBars collection object
Documents |


IBestFitItem

IBestFitItem - interface

Description

IBestFitItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
AllowTX | R/W | set/retrieve whether the best-fit is allowed to translate in X ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)
AllowTY | R/W | set/retrieve whether the best-fit is allowed to translate in Y ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)
AllowTZ | R/W | set/retrieve whether the best-fit is allowed to translate in Z ( only valid if BestFitMethod = BST_TRANSLATION_ONLY)
BestFitMethod | R/W | set/retrieve the bestfit method
BestFitMethodString | R/O | retrieve the bestfit method as a human readable localised string.
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FittingType | R/W | Get/set the fitting type (which tolerances are used)
FittingTypeString | R/O | Get a text description of the fitting type
FixedLine | R/O | Returns the reference line used for the rotational axis.
FixedPlaneAxis | R/O | returns Fixed Axis definition , ( only valid if BestFitMethod = BST_2D_BESTFIT)
fixedPoint | R/O | Fixed Point , ( only valid if BestFitMethod = BST_ROTATION_ONLY
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LinkedAlignment | R/O | Returns an alignment item that was corrected with this best fit.
LinkGroups | R/O | returns the collections of linked groups
LockPlaneTranslation | R/W | set/retrieve whether the best-fit is allowed to translate along the axis of the 2D Bestfit ( only valid if BestFitMethod = pwibst_BST_2D_BESTFIT)
LowerTolerance | R/W | Get/set the lower tolerance for fitting
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MaxIteration | R/W | set/retrieve the number of iterations maximum allowed for this bestfit
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
Result | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
StopCriteria | R/W | set/retrieve the stop criteria for this bestfit
ToleranceType | R/W | Get/set the tolerance type (which tolerances are used)
ToleranceTypeString | R/O | Get a text description of the tolerances used for fitting
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W | Get/set the upper tolerance for fitting
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IBestFitResult

IBestFitResult - interface

Description

IBestFitResult Interface

Methods

Calculate | Evaluate the bestfit
PositioningMatrix | return the positioning matrix to convert CMM coordinates to Part Coordinates

Properties

DeltaTransform | R/O | the Delta Transformation
IsValid | R/O |
measure | R/O |
MeasureState | R/O | returns the measurement state
Parent | R/O |
StatisticAfter | R/O | the statistics after the Best-fit have been applied
StatisticBefore | R/O | the statistics before the Best-fit have been applied


IBestFitStat

IBestFitStat - interface

Description

IBestFitStat Interface

Properties

MaximumDeviation | R/O | retrieve the Maximum Deviation
Mean | R/O | retrieve the Mean Error
MinimumDeviation | R/O | retrieve the Minimum Deviation
NumberOfFailure | R/O | retrieve the Number of Point in Failure
NumberOfPoints | R/O | retrieve the Number of entities
StandardDeviation | R/O | retrieve the Standard Deviation


MaximumDeviation

MaximumDeviation - Read property

Description

retrieve the Maximum Deviation

Syntax in Visual Basic or VBScript

MaximumDeviation () As Double

Syntax in C++

HRESULT get_MaximumDeviation (double* retVal)

Applies to

IBestFitStat


Mean

Mean - Read property

Description

retrieve the Mean Error

Syntax in Visual Basic or VBScript

Mean () As Double

Syntax in C++

HRESULT get_Mean (double* retVal)

Applies to

IBestFitStat


MinimumDeviation

MinimumDeviation - Read property

Description

retrieve the Minimum Deviation

Syntax in Visual Basic or VBScript

MinimumDeviation () As Double

Syntax in C++

HRESULT get_MinimumDeviation (double* retVal)

Applies to

IBestFitStat


NumberOfFailure

NumberOfFailure - Read property

Description

retrieve the Number of Point in Failure

Syntax in Visual Basic or VBScript

NumberOfFailure () As Long

Syntax in C++

HRESULT get_NumberOfFailure (LONG* retVal)

Applies to

IBestFitStat


NumberOfPoints

NumberOfPoints - Read property

Description

retrieve the Number of entities

Syntax in Visual Basic or VBScript

NumberOfPoints () As Long

Syntax in C++

HRESULT get_NumberOfPoints (LONG* retVal)

Applies to

IBestFitStat


StandardDeviation

StandardDeviation - Read property

Description

retrieve the Standard Deviation

Syntax in Visual Basic or VBScript

StandardDeviation () As Double

Syntax in C++

HRESULT get_StandardDeviation (double* retVal)

Applies to

IBestFitStat
IMeasureStatistics


IBoundingBox3D

IBoundingBox3D - interface

Description

IBoundingBox3D Interface - a 3D rectangular bounded box

Methods

Reset | reset the box to a invalid box
UpdateWithBox | update the box with a other box
UpdateWithPoint | update the box with a point

Properties

IsValid | R/O | returns TRUE if the box is valid
MaxPoint | R/O | Returns the max point of the box
MinPoint | R/O | Returns the min point of the box
ReadOnly | R/O | returns true if the box is read only


IsValid

IsValid - Read property

Description

returns TRUE if the box is valid

Syntax in Visual Basic or VBScript

IsValid () As Boolean

Syntax in C++

HRESULT get_IsValid (VARIANT_BOOL* retVal)

Applies to

BoundingBox


MaxPoint

MaxPoint - Read property

Description

Returns the max point of the box

Syntax in Visual Basic or VBScript

MaxPoint () As Point3D

Syntax in C++

HRESULT get_MaxPoint (Point3D* retVal)

Applies to

BoundingBox


MinPoint

MinPoint - Read property

Description

Returns the min point of the box

Syntax in Visual Basic or VBScript

MinPoint () As Point3D

Syntax in C++

HRESULT get_MinPoint (Point3D* retVal)

Applies to

BoundingBox


ReadOnly

ReadOnly - Read property

Description

returns true if the box is read only

Syntax in Visual Basic or VBScript

ReadOnly (ByRef retVal As Boolean)

Syntax in C++

HRESULT get_ReadOnly (VARIANT_BOOL* retVal)

Applies to

BoundingBox


Reset

Reset - method

Description

reset the box to a invalid box

Syntax in Visual Basic or VBScript

Reset ()

Syntax in C++

HRESULT Reset ()

Applies to

BoundingBox


UpdateWithBox

UpdateWithBox - method

Description

update the box with a other box

Syntax in Visual Basic or VBScript

UpdateWithBox (ByRef point As BoundingBox)

Syntax in C++

HRESULT UpdateWithBox (BoundingBox* point)

Parameters

Name | Description
point |

Applies to

BoundingBox


UpdateWithPoint

UpdateWithPoint - method

Description

update the box with a point

Syntax in Visual Basic or VBScript

UpdateWithPoint (ByRef point As Point3D)

Syntax in C++

HRESULT UpdateWithPoint (Point3D* point)

Parameters

Name | Description
point |

Applies to

BoundingBox


IBrowseHelper

IBrowseHelper - interface

Description

IBrowseHelper Interface

Methods

BrowseIDispatchTypeLibrary | Browse the type library of a given object
BrowseTypeLibrary | method BrowseTypeLibrary
BrowseTypeLibraryIID | method BrowseTypeLibraryIID
CPPTypeStr | retrieve the CPPType String
VBTypeStr | retrieve the VBType String


ICADEntities

ICADEntities - interface

Description

ICADEntities Interface

Methods

Add | method Add
Remove | method Remove

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 1 to Count or a string

Used in

ExtraEntities


Add

Add - method

Description

method Add

Syntax in Visual Basic or VBScript

Add (type As PWICADENTITYTYPE) As ICADEntity

Syntax in C++

HRESULT Add (PWICADENTITYTYPE type , ICADEntity* retVal)

Parameters

Name | Description
type |
Return Value |

Applies to

ICADEntities


ICADEntity

ICADEntity - interface

Description

ICADEntity Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

Evaluator | T/O
Name | R/W
ReadOnly | R/O
TypeOf | R/O


Evaluator

Evaluator - Reference Write property

Syntax in Visual Basic or VBScript

Evaluator () As Object

Syntax in C++

HRESULT get_Evaluator (IDispatch** retVal)

Applies to

ICADEntity
Arc3D
IPWICircle3D
IPWICone
IPWICylinder
IPWILine3D
plane
IPWIPoint
IPWIRectangle
IPWISlot
IPWISphere
IPWITorus


ReadOnly

ReadOnly - Read property

Syntax in Visual Basic or VBScript

ReadOnly () As Boolean

Syntax in C++

HRESULT get_ReadOnly (VARIANT_BOOL* retVal)

Applies to

ICADEntity
Arc3D
IPWICircle3D
IPWICone
IPWICylinder
IPWILine3D
plane
IPWIPoint
IPWIRectangle
IPWISlot
IPWISphere
IPWITorus


TypeOf

TypeOf - Read property

Syntax in Visual Basic or VBScript

TypeOf () As PWICADENTITYTYPE

Syntax in C++

HRESULT get_TypeOf (PWICADENTITYTYPE* retVal)

Applies to

ICADEntity
Arc3D
IPWICircle3D
IPWICone
IPWICylinder
IPWILine3D
plane
IPWIPoint
IPWIRectangle
IPWISlot
IPWISphere
IPWITorus


ICADFile

ICADFile - interface

Description

ICADFile Interface

Properties

BoundingBox | R/O | returns the Bounded Box of the CAD file
filename | R/W | filename
LocalDatum | R/O | LocalDatum: define the transformation matrix defined for this file

Collections

CADLevels Collection of CAD levels belonging to this item.


ICADFiles

ICADFiles - interface

Description

ICADFiles Interface

Methods

Add | method Add
Remove | method Remove

Properties

BoundingBox | R/O | returns the Bounded Box of all the CAD file in the collection
Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual CADFile within the collection. Index can be an ordinal from 1 to Count or a string

Used in

CADFiles


ICADLevel

ICADLevel - interface

Description

ICADLevel Interface

Properties

Active | R/W | Whether the CAD level is active for projection.
Color | R/W | The color of the CAD level
Index | R/O | Index of the CAD level.
Name | R/W | Name of the CAD level.
Visible | R/W | Visibility of the CAD level in the active view.

Collections

CADObjects Collection of CAD objects belonging to this item.


ICADLevels

ICADLevels - interface

Description

ICADLevels Interface

Methods

Add | Method Add
Remove | Method Remove

Properties

Count | R/O | The number of items in the collection.
IsReadOnly | R/O | Return true if this collection is read-only and cannot be modified.
Item | R/O | Allows random access to individual CAD levels within the collection. Index can be an ordinal from 1 to Count, or a string.

Used in

CADLevels
UserLevels


ICADObject

ICADObject - interface

Description

ICADObject Interface

Properties

Index | R/O | Index of the CAD object.
Name | R/O | Name of the CAD object.
UniqueID | R/O | Unique ID of the CAD object.


ICADObjects

ICADObjects - interface

Description

ICADObjects Interface

Methods

Assign | Assigns an object with the given name to this collection. The object will be removed from the original level.
Revert | Returns an object with the given name to the original collection. Results: S_OK - success, S_FALSE - the object was not found, E_FAIL - error.

Properties

Count | R/O | The number of items in the collection.
IsReadOnly | R/O | Return true if this collection is read-only and cannot be modified.
Item | R/O | Allows random access to individual CAD objects within the collection. Index can be an ordinal from 1 to Count, or a string.

Used in

CADObjects


ICADSelectionManager

ICADSelectionManager - interface

Description

ICADSelectionManager Interface

Properties

Count | R/O | indicates the number selected vertex
Item | R/O | Allows random access to individual Vertex within the collection. Index can be an ordinal from 1 to Count or a string
Parent | T/O | indicates the parent of this object : a PowerINSPECT Document

Used in

CADSelectionManager


ICADViewReportItem

ICADViewReportItem - interface

Description

ICADViewReportItem Interface

Methods

ApplyViewSettings | applies the view settings on the active CADView again
Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GenerateImage | Generates CAD View Report image
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
RecordViewSettings | records the current view settings in the item
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterPlayWhenMeasured | R/O |
ParameterReportSettings | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ICADViewStateItem

ICADViewStateItem - interface

Description

ICADViewStateItem Interface

Methods

ApplyViewSettings | applies the view settings on the active CADView again
Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
RecordViewSettings | records the current view settings in the item
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ICalibration

ICalibration - interface

Description

ICalibration Interface

Methods

Calibrate invokes the User Interface Wizard that will carried out the calibration for this element

Properties

Admin | R/O | Internal use only, retrieve the CalibrationAdministration Object
LastCalibrationDate | R/O | returns the date when the last calibration has been performed
RequireNewCalibration | R/O | retrieves whether or not a new Calibration is requested for this element, before it can be used accuratly
Status | R/O | returns the calibration state of this element


ICalibrationAdmin

ICalibrationAdmin - interface

Description

ICalibrationAdmin Interface

Methods

SetCalibrationData internal use only: set the data that will be used to perform the calibration, the content depends on which item is beeing calibrated

Properties

Status | W/O | internal use only: set the calibration state
ThreadID | R/O |


ICarriage

ICarriage - interface

Description

ICarriage Interface

Methods

Commit | commit the changes made
Compensate | Apply the probe offset compensation to the give coordinates according the current active tip
FillIdentityCard | fill the node with the identity card of this item
FindTip |
Rollback | rollback to the state we were in at the start of this transaction
StartTransaction | creates a start point which we can rollback to
Uncompensate | Undo the effect of the probe offset compensation on the give coordinates according the current active tip

Properties

_ID | R/W | INTERNAL USE ONLY
ActiveSensor | R/W | sets/retrieves the active sensor,if necessary a probe tool change will happen, the active tip is not guaranty to be correctly set at the end
ActiveTip | R/W | sets/retrieves the active probe tip,ProbeTip could be a FULLQUALIFIED name for the type, in this case a probe tool operation may be executed.
ActiveTool | R/W | sets/retrieves the active probe tool,ProbeTool could be a 0-based index , a string representing the name of the tool or a pointer to a tool, in this case, the tool must belong to the collection
Calibration | R/O | retrieves the calibration object
Configuration | R/W | retreives/sets the Carriage configuration
DatumSphere | R/O | sets/retrieves the active Datum Sphere used to calibrate sensor on this carriage
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
MaxPoint | R/O | R/W returns the Max Point of the carriage volume
MinPoint | R/O | R/W returns the Min Point of the carriage volume
Position | R/O | Position of the carriage relative to the first carriage
ProbeDatabase | R/O | retrieves the parent probedatabase
ProbeHead | R/W | sets/retrieves the probeHead
ProbeHeadMountingDirection | R/O | R/W returns the direction of the probe head mounting device ( usually Z-)
Protocol | R/O | sets/retrieves the protocol that actually controls this carriage
ThreadID | R/O |
ToolChanger | R/W | retrieves/sets the tool changer
TransactionState | R/O | are we currently carrying out a transaction
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections

DatumFeatureCollection | retrieves the datum feature collection available on this carriage
ProbeTipCollection | retrieves the probe tip collection
ProbeToolCollection | retrieves the probe tool collection associated with this carriage
RackCollection | retrieves the rack collection associated with this carriage


ICarriages

ICarriages - interface

Description

ICarriages Interface

Methods

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


ICMMBoolParameter

ICMMBoolParameter - interface

Description

ICMMBoolParameter Interface

Methods

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
IsValidValue | check if the value provided is suitable for this parameter

Properties

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter


ICMMCNCController

ICMMCNCController - interface

Description

ICMMCNCController Interface

Methods

CancelCurrentCNCAction | method CancelCurrentCNCAction
EndQueue |
Home | Home or Reset the CMM Device
LockCNCControl | Locks the protocol to be controlled by this object alone. Must be called successfully before controlling calls will succeed.
MeasureTo | Perform a composite measure move.
MultipointMove | MultipointMove
RapidMoveTo | Perform a rapid move from the current position to the new position.
RapidMoveWithMachineOrientation | Perform a rapid move from the current position/orientation to the new position/orientation.
SafeMoveTo | Perform a safe move from the current position to the new position.
ScanMove | Perform a Scan move.
StartQueue |
TouchPoint | method TouchPoint
UnlockCNCControl | Unlocks this object's control of the protocol object for use by other controllers.

Properties

CMMProtocol | R/O | The protocol object being controlled by this object.
HasCNCControlLock | R/O | Whether this object has a CNC controlling lock.
MachineOrientation | R/O | Get the current machine orientation.
QueueComplete | R/O | A command queue has completed execution.
QueuedCount | R/O | Number of commands in queue which have yet to complete execution.
Queuing | R/O | Protocol is building a command queue.


ICMMDatumItem

ICMMDatumItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ICMMFloatParameter

ICMMFloatParameter - interface

Description

ICMMFloatParameter Interface

Methods

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
GetValueUnit | Get the current value in the specified unit
IsValidValue | check if the value provided is suitable for this parameter
SetValueUnit | set the value using the specify value ( in the specified units ) without altering the internal units

Properties

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
Increment | R/W | increment or 0 if all values possible
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
LowerRange | R/W | minimum authorized value
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
units | R/W | expected unit for this parameter
UNITTYPE | R/O |
UpperRange | R/W | maximum authorized value
ValidUnits | R/O | returns the list of supported units
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter


Increment

Increment - Read & Write property

Description

increment or 0 if all values possible

Syntax in Visual Basic or VBScript

Increment () As Double

Syntax in C++

HRESULT get_Increment (double* retVal)
HRESULT put_Increment (double Value)

Applies to

CMMFloatParameter


LowerRange

LowerRange - Read & Write property

Description

minimum authorized value

Syntax in Visual Basic or VBScript

LowerRange () As Double

Syntax in C++

HRESULT get_LowerRange (double* retVal)
HRESULT put_LowerRange (double Value)

Applies to

CMMFloatParameter


units

units - Read & Write property

Description

expected unit for this parameter

Syntax in Visual Basic or VBScript

units () As String

Syntax in C++

HRESULT get_units (BSTR* retVal)
HRESULT put_units (BSTR Value)

Applies to

CMMFloatParameter
CMMPlaneParameter
CMMPointParameter


UNITTYPE

UNITTYPE - Read property

Syntax in Visual Basic or VBScript

UNITTYPE () As UNITTYPE

Syntax in C++

HRESULT get_UNITTYPE (UNITTYPE* retVal)

Applies to

CMMFloatParameter


UpperRange

UpperRange - Read & Write property

Description

maximum authorized value

Syntax in Visual Basic or VBScript

UpperRange () As Double

Syntax in C++

HRESULT get_UpperRange (double* retVal)
HRESULT put_UpperRange (double Value)

Applies to

CMMFloatParameter


ValidUnits

ValidUnits - Read property

Description

returns the list of supported units

Syntax in Visual Basic or VBScript

ValidUnits () As String

Syntax in C++

HRESULT get_ValidUnits (BSTR* retVal)

Applies to

CMMFloatParameter


GetValueUnit

GetValueUnit - method

Description

Get the current value in the specified unit

Syntax in Visual Basic or VBScript

GetValueUnit (strUnit As String) As Double

Syntax in C++

HRESULT GetValueUnit (BSTR strUnit , double* retVal)

Parameters

Name | Description
strUnit |
Return Value |

Applies to

CMMFloatParameter


SetValueUnit

SetValueUnit - method

Description

set the value using the specify value ( in the specified units ) without altering the internal units

Syntax in Visual Basic or VBScript

SetValueUnit (ret As Double , strUnit As String)

Syntax in C++

HRESULT SetValueUnit (double ret , BSTR strUnit)

Parameters

Name | Description
ret |
strUnit |

Applies to

CMMFloatParameter


ICMMParameter

ICMMParameter - interface

Description

ICMMParameter Interface

Methods

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
IsValidValue | check if the value provided is suitable for this parameter

Properties

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter


ICMMParameters

ICMMParameters - interface

Description

ICMMParameters Interface

Methods

AddBoolParameter | method AddBoolParameter
AddFloatParameter | method AddFloatParameter
AddPlaneParameter | Add a plane parameter
AddPointParameter | Add a plane parameter
AddVectorParameter | Add a vector parameter
ApplyPackedValue |
CopyTo | copy the contents of this CMMPameters object to the pDest
InsertCopy | Insert Copy
TransferParameters | TransferParameters : set all parameters to their values when defined in refParemeters
XMLOutput | Get CMMParameter path in XML format

Properties

Count | R/O | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count -1 or a string
ReadOnly | R/W | ReadOnly

Used in

Clone
CMMParameters
ProbingParameters


Count

Count - Read property

Description

Indicates the number of items in the collection.

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

CMMParameters


Item

Item - Read property

Description

Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count -1 or a string

Syntax in Visual Basic or VBScript

Item (Index As Variant) As ICMMParameter

Syntax in C++

HRESULT get_Item (VARIANT Index , ICMMParameter* retVal)

Applies to

CMMParameters


ReadOnly

ReadOnly - Read & Write property

Description

ReadOnly

Syntax in Visual Basic or VBScript

ReadOnly () As Boolean

Syntax in C++

HRESULT get_ReadOnly (VARIANT_BOOL* retVal)
HRESULT put_ReadOnly (VARIANT_BOOL Value)

Applies to

CMMParameters


AddBoolParameter

AddBoolParameter - method

Description

method AddBoolParameter

Syntax in Visual Basic or VBScript

AddBoolParameter (Name As String , Description As String , curValue As Boolean , bIsDMIS As Boolean , bsCategory As String , bsUIName As String , bIsUIAccessible As Boolean) As ICMMParameter

Syntax in C++

HRESULT AddBoolParameter (BSTR Name , BSTR Description , VARIANT_BOOL curValue , VARIANT_BOOL bIsDMIS , BSTR bsCategory , BSTR bsUIName , VARIANT_BOOL bIsUIAccessible , ICMMParameter* retVal)

Parameters

Name | Description
Name |
Description |
curValue |
bIsDMIS |
bsCategory |
bsUIName |
bIsUIAccessible |
Return Value |

Applies to

CMMParameters


AddFloatParameter

AddFloatParameter - method

Description

method AddFloatParameter

Syntax in Visual Basic or VBScript

AddFloatParameter (Name As String , Description As String , units As String , minValue As Double , maxValue As Double , curValue As Double , increment As Double , bIsDMIS As Boolean , bsCategory As String , bsUIName As String , bIsUIAccessible As Boolean) As ICMMParameter

Syntax in C++

HRESULT AddFloatParameter (BSTR Name , BSTR Description , BSTR units , double minValue , double maxValue , double curValue , double increment , VARIANT_BOOL bIsDMIS , BSTR bsCategory , BSTR bsUIName , VARIANT_BOOL bIsUIAccessible , ICMMParameter* retVal)

Parameters

Name | Description
Name |
Description |
units |
minValue |
maxValue |
curValue |
increment |
bIsDMIS |
bsCategory |
bsUIName |
bIsUIAccessible |
Return Value |

Applies to

CMMParameters


AddPlaneParameter

AddPlaneParameter - method

Description

Add a plane parameter

Syntax in Visual Basic or VBScript

AddPlaneParameter (Name As String , Description As String , units As String) As CMMPlaneParameter

Syntax in C++

HRESULT AddPlaneParameter (BSTR Name , BSTR Description , BSTR units , CMMPlaneParameter* retVal)

Parameters

Name | Description
Name |
Description |
units |
Return Value |

Applies to

CMMParameters


AddPointParameter

AddPointParameter - method

Description

Add a plane parameter

Syntax in Visual Basic or VBScript

AddPointParameter (Name As String , Description As String , units As String) As CMMPointParameter

Syntax in C++

HRESULT AddPointParameter (BSTR Name , BSTR Description , BSTR units , CMMPointParameter* retVal)

Parameters

Name | Description
Name |
Description |
units |
Return Value |

Applies to

CMMParameters


AddVectorParameter

AddVectorParameter - method

Description

Add a vector parameter

Syntax in Visual Basic or VBScript

AddVectorParameter (Name As String , Description As String) As CMMVectorParameter

Syntax in C++

HRESULT AddVectorParameter (BSTR Name , BSTR Description , CMMVectorParameter* retVal)

Parameters

Name | Description
Name |
Description |
Return Value |

Applies to

CMMParameters


ApplyPackedValue

ApplyPackedValue - method

Syntax in Visual Basic or VBScript

ApplyPackedValue (PackedValue As Variant , option As ApplyPackValueOption)

Syntax in C++

HRESULT ApplyPackedValue (VARIANT PackedValue , ApplyPackValueOption option)

Parameters

Name | Description
PackedValue |
option |

Applies to

CMMParameters


CopyTo

CopyTo - method

Description

copy the contents of this CMMPameters object to the pDest

Syntax in Visual Basic or VBScript

CopyTo (ByRef pDest As CMMParameters)

Syntax in C++

HRESULT CopyTo (CMMParameters* pDest)

Parameters

Name | Description
pDest |

Applies to

CMMParameters


InsertCopy

InsertCopy - method

Description

Insert Copy

Syntax in Visual Basic or VBScript

InsertCopy (ByRef refParameter As ICMMParameter)

Syntax in C++

HRESULT InsertCopy (ICMMParameter* refParameter)

Parameters

Name | Description
refParameter |

Applies to

CMMParameters


TransferParameters

TransferParameters - method

Description

TransferParameters : set all parameters to their values when defined in refParemeters

Syntax in Visual Basic or VBScript

TransferParameters (ByRef refParemeters As CMMParameters)

Syntax in C++

HRESULT TransferParameters (CMMParameters* refParemeters)

Parameters

Name | Description
refParemeters |

Applies to

CMMParameters


XMLOutput

XMLOutput - method

Description

Get CMMParameter path in XML format

Syntax in Visual Basic or VBScript

XMLOutput (option As ApplyPackValueOption , pNode As Object)

Syntax in C++

HRESULT XMLOutput (ApplyPackValueOption option , IDispatch* pNode)

Parameters

Name | Description
option |
pNode |

Applies to

CMMParameters


ICMMParametersCategories

ICMMParametersCategories - interface

Description

ICMMParametersCategories Interface

Properties

Count R/O Indicates the number of categories in the categorie collection

Used in

Categories


Count

Count - Read property

Description

Indicates the number of categories in the categorie collection

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

CMMParametersCategories


ICMMParametersCategory

ICMMParametersCategory - interface

Description

ICMMParametersCategory Interface

Properties

Count | R/O | Indicates the number of parameter under this category
Item | R/O | Allows random access to individual Parameter within the collection. Index can be an ordinal from 0 to Count -1 or a string being a name of a parameter
Name | R/O | property Name

Used in

Item


Count

Count - Read property

Description

Indicates the number of parameter under this category

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

CMMParametersCategory


Item

Item - Read property

Description

Allows random access to individual Parameter within the collection. Index can be an ordinal from 0 to Count -1 or a string being a name of a parameter

Syntax in Visual Basic or VBScript

Item (Index As Variant) As ICMMParameter

Syntax in C++

HRESULT get_Item (VARIANT Index , ICMMParameter* retVal)

Applies to

CMMParametersCategory


Name

Name - Read property

Description

property Name

Syntax in Visual Basic or VBScript

Name () As String

Syntax in C++

HRESULT get_Name (BSTR* retVal)

Applies to

CMMParametersCategory


ICMMParameterToolbox

ICMMParameterToolbox - interface

Description

ICMMParameterToolbox Interface

Methods

GetPackedStringBool | Get the packed string for a BOOLEAN
GetPackedStringBooleanParameter | Create the packed value for a CMM BooleanParameter
GetPackedStringFloat | Get the packed string for a Float
GetPackedStringFloatParameter | Create the packed value for a CMM FloatParameter.
GetPackedStringPlane | Get the packed string for a Plane
GetPackedStringPoint | Get the packed string for a Point
GetPackedStringTransform | Create a Transform xml-element that has the given name and units attributes
GetPackedStringVector | Get the packed string for a Vector
IsPackedString | returns true if the string is a valid packed string
PackValueAndUnits | Returns a string that contains the value followed by the units
UnpackParameter | Unpack a CMMParameter Packed string
UnpackPointParameter | Unpack the point XYZ values held in strParam (packed using GetPackedStringPoint)
UnpackPointParameterV | Unpack the point XYZ values held in strParam (packed using GetPackedStringPoint)
UnpackTransformParameter | Unpack Transform element from strParam (packed using GetPackedStringTransform()) into transform.
UnpackVectorParameter | Unpack the vector IJK values held in strParam (packed using GetPackedStringVector)
UnpackVectorParameterV | Unpack the vector IJK values held in strParam (packed using GetPackedStringVector)


ICMMPlaneParameter

ICMMPlaneParameter - interface

Description

ICMMPlaneParameter Interface

Methods

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
IsValidValue | check if the value provided is suitable for this parameter

Properties

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
Plane | R/O | returns the plane
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
units | R/W | expected unit for this parameter
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter


Plane

Plane - Read property

Description

returns the plane

Syntax in Visual Basic or VBScript

Plane () As plane

Syntax in C++

HRESULT get_Plane (plane* retVal)

Applies to

CMMPlaneParameter


ICMMPoint

ICMMPoint - interface

Description

ICMMPoint Interface

Methods

TransformFrom
TransformTo

Properties

Name | R/W
OuterMaterialDirection | R/O
PreTouchPoint | R/O
ProbeCenter | R/O
ProbeDiameter | R/W
Value | R/W


OuterMaterialDirection

OuterMaterialDirection - Read property

Syntax in Visual Basic or VBScript

OuterMaterialDirection () As Vector3D

Syntax in C++

HRESULT get_OuterMaterialDirection (Vector3D* retVal)

Applies to

CMMPoint


PreTouchPoint

PreTouchPoint - Read property

Syntax in Visual Basic or VBScript

PreTouchPoint () As Point3D

Syntax in C++

HRESULT get_PreTouchPoint (Point3D* retVal)

Applies to

CMMPoint


ProbeCenter

ProbeCenter - Read property

Syntax in Visual Basic or VBScript

ProbeCenter () As Point3D

Syntax in C++

HRESULT get_ProbeCenter (Point3D* retVal)

Applies to

CMMPoint


ProbeDiameter

ProbeDiameter - Read & Write property

Syntax in Visual Basic or VBScript

ProbeDiameter () As Double

Syntax in C++

HRESULT get_ProbeDiameter (double* retVal)
HRESULT put_ProbeDiameter (double Value)

Applies to

CMMPoint


TransformFrom

TransformFrom - method

Syntax in Visual Basic or VBScript

TransformFrom (ByRef transform As transform)

Syntax in C++

HRESULT TransformFrom (transform* transform)

Parameters

Name | Description
transform |

Applies to

CMMPoint


TransformTo

TransformTo - method

Syntax in Visual Basic or VBScript

TransformTo (ByRef transform As transform)

Syntax in C++

HRESULT TransformTo (transform* transform)

Parameters

Name | Description
transform |

Applies to

CMMPoint


ICMMPointParameter

ICMMPointParameter - interface

Description

ICMMPointParameter Interface

Methods

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
IsValidValue | check if the value provided is suitable for this parameter

Properties

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
Point | R/O | returns the point
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
units | R/W | expected unit for this parameter
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter


Point

Point - Read property

Description

returns the point

Syntax in Visual Basic or VBScript

Point () As Point3D

Syntax in C++

HRESULT get_Point (Point3D* retVal)

Applies to

CMMPointParameter


ICMMPoints

ICMMPoints - interface

Description

ICMMPoints Interface - a collection of CMMPoint

Methods

Add | method Add
AddNamedXYZIJK | method AddNamedXYZIJK
AddXYZIJK | method AddXYZJIK
Append | Append: add a copy of the srcCollection into this collection
Clear | method Clear : Empty all points from the list
CopyFrom | CopyFrom: create a copy from srcCollection into this collection
Remove | method Remove : remove a point from the list at the specified index
Scale | Scale: scale the points cloud ( usefull to convert between inches and mm
TransformFrom |
TransformTo |

Properties

Count | R/W | Indicates the number of items in the collection.
IsReadOnly | R/O | returns TRUE if the collection is a readonly collection
Item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 1 to Count or a string
ProbeDiameter | R/W | returns the probe diameter

Used in

CMMPoints
ContactPoints


IsReadOnly

IsReadOnly - Read property

Description

returns TRUE if the collection is a readonly collection

Syntax in Visual Basic or VBScript

IsReadOnly () As Boolean

Syntax in C++

HRESULT get_IsReadOnly (VARIANT_BOOL* retVal)

Applies to

CMMPoints


ProbeDiameter

ProbeDiameter - Read & Write property

Description

returns the probe diameter

Syntax in Visual Basic or VBScript

ProbeDiameter () As Double

Syntax in C++

HRESULT get_ProbeDiameter (double* retVal)
HRESULT put_ProbeDiameter (double Value)

Applies to

CMMPoints


Add

Add - method

Description

method Add

Syntax in Visual Basic or VBScript

Add () As CMMPoint

Syntax in C++

HRESULT Add (CMMPoint* retVal)

Parameters

Name | Description
Return Value |

Applies to

CMMPoints


AddNamedXYZIJK

AddNamedXYZIJK - method

Description

method AddNamedXYZIJK

Syntax in Visual Basic or VBScript

AddNamedXYZIJK (Name As String , X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double) As CMMPoint

Syntax in C++

HRESULT AddNamedXYZIJK (BSTR Name , double X , double Y , double Z , double I , double J , double K , CMMPoint* retVal)

Parameters

Name | Description
Name |
X |
Y |
Z |
I |
J |
K |
Return Value |

Applies to

CMMPoints


AddXYZIJK

AddXYZIJK - method

Description

method AddXYZJIK

Syntax in Visual Basic or VBScript

AddXYZIJK (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double) As CMMPoint

Syntax in C++

HRESULT AddXYZIJK (double X , double Y , double Z , double I , double J , double K , CMMPoint* retVal)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |
Return Value |

Applies to

CMMPoints


Append

Append - method

Description

Append: add a copy of the srcCollection into this collection

Syntax in Visual Basic or VBScript

Append (ByRef srcCollection As CMMPoints)

Syntax in C++

HRESULT Append (CMMPoints* srcCollection)

Parameters

Name | Description
srcCollection |

Applies to

CMMPoints


Clear

Clear - method

Description

method Clear : Empty all points from the list

Syntax in Visual Basic or VBScript

Clear ()

Syntax in C++

HRESULT Clear ()

Applies to

CMMPoints


CopyFrom

CopyFrom - method

Description

CopyFrom: create a copy from srcCollection into this collection

Syntax in Visual Basic or VBScript

CopyFrom (ByRef srcCollection As CMMPoints)

Syntax in C++

HRESULT CopyFrom (CMMPoints* srcCollection)

Parameters

Name | Description
srcCollection |

Applies to

CMMPoints


Remove

Remove - method

Description

method Remove : remove a point from the list at the specified index

Syntax in Visual Basic or VBScript

Remove (Index As Variant)

Syntax in C++

HRESULT Remove (VARIANT Index)

Parameters

Name | Description
Index |

Applies to

CMMPoints


Scale

Scale - method

Description

Scale: scale the points cloud ( usefull to convert between inches and mm

Syntax in Visual Basic or VBScript

Scale (scaleFactor As Double)

Syntax in C++

HRESULT Scale (double scaleFactor)

Parameters

Name | Description
scaleFactor |

Applies to

CMMPoints


ICMMProtocol

ICMMProtocol - interface

Description

ICMMProtocol Interface

Methods

CancelCurrentCNCAction | method CancelCurrentCNCAction
DoRepositioning | OnRelocate
ForceCurrentPositionUpdate | Forces the protocol to update the current position. Not all protocols will be able to implement this.
GetCNCControllingObject | Creates an object to allow CNC controlling actions to be performed on the protocol.
GetCurrentPosition | method CurrentPosition
GetLastMappingError | method GetLastMappingError
GetRefMarks | method GetRefMarks : return a copy of the current reference marker position
GetTrackingPointObject | Creates an object to allow collection of tracking points.
GetUserCamera | GetUserCamera
Home | Method Homed : Home or Reset the CMM Device
PlaySound | Play a sound on the DCE Device
StartPointStreamTransaction | Starts a transaction and creates an object to receive the contact points as a stream. Only usable by C++ clients.
StartTransaction | method StartTransaction
StopTransaction | method StopTransaction
UncompensatePoint | Undoes any process implicitly done by the protocol to a point
UnCompensatePointV | Undoes any process implicitly done by the protocol to a point

Properties

AutoRepeatInterval | R/W | AutoRepeatInterval : number of millisecond between two points capture in rigid scanning
CalibrationMode | R/W | Calibration Mode
CanPlaySound | R/O | Can play a sound on the DCE Device
CMM2UserTransformation | R/O | CMM2UserTransformation
CMMTYPE | R/O | gets the technology of the CMM
CNCControllingObjectHasLock | R/O | Whether a CNC controlling object currently has a CNC lock on this object.
CNCProtocolRunningAsManual | R/O | True when the protocol is CNC but is operating as manual due to absence of CNC licence.
CNCSTATUS | R/O | property CNCStatus
Configurator | R/O | retrieves the Configurator Object
Connected | R/W | proterty Connected
CurrentPosition | R/O | method CurrentPosition : return a read/only point that describe the current position
DeviceRepositionner | T/O | returns thedevice repositionner object - of type IRePosition
ErrorMap | R/W | Object used by protocol to perform error map compensation on point co-ordinates
ErrorMap | W/O | Object used by protocol to perform error map compensation on point co-ordinates
ErrorMappingType | R/O | The type of error mapping support this protocol is capable of
Fire | R/O | Property Fire
Homed | R/O | proterty Homed : return true if the DEVICE has been homed or initialised
InTransaction | R/O | Returns whether the protocol is currently in a measurement transaction. Note that the result returned is also affected by changes to the CalibrationMode property.
LastCNCErrorDescription | R/O | property LastCNCErrorDescription
MaximumMultipointMovePoints | R/O | MaximumMultipointMovePoints
ParentWindow | R/W | Parent Window
PreTouchIJKMode | R/W | PreTouchIJKMode
ProbeDatabase | R/O | The object that allows us to access the probe database and the active sensor
ProbeDatabaseIsInstalled | R/O | Determines whether a probe database is currently set. Useful for clients that do not want to invoke the probe database installation through a call to get_ProbeDatabase.
ProbePathReplayEngine | T/O | ProbePathReplay
ProbePathTeachEngine | T/O | ProbePathTeachEngine
RemoteMouse | R/W | Enables/disables remote mouse functionality
ScanningMode | R/W | retrieve/set the Scanning mode
SupportRefMarks | R/O | Support Reference Marks
SupportScanning | R/O | Support Scanning features
SupportsUserCamera | R/O | SupportsUserCamera
SupportTracking | R/O | The object fully supports tracking points
SuppressBeepOnContact | R/W | Suppress protocol default beeping on contact. For clients that will explicitly call PlaySound when processing contact points.
TrackingFrame | R/O | An object that allows the current tracking frame to be retrieved. Only usable by C++ clients.

Collections

CMMParameters | CMMParameters
UIExtensionCommands | User Interface Extension Commands


ICMMProtocolConfigurator

ICMMProtocolConfigurator - interface

Description

ICMMProtocolConfigurator Interface

Methods

Configure Call a user interface that will allow the user to set the script parameters

Properties

CMMProtocol R/O the CMMProtocol being managed by this object


CMMProtocol

CMMProtocol - Read property

Description

the CMMProtocol being managed by this object

Syntax in Visual Basic or VBScript

CMMProtocol () As CMMProtocol_dummy

Syntax in C++

HRESULT get_CMMProtocol (CMMProtocol_dummy* retVal)

Applies to

ICMMProtocolConfigurator


Configure

Configure - method

Description

Call a user interface that will allow the user to set the script parameters

Syntax in Visual Basic or VBScript

Configure ()

Syntax in C++

HRESULT Configure ()

Applies to

ICMMProtocolConfigurator


ICMMSimulator

ICMMSimulator - interface

Description

IICMMSimulator Interface

Methods

GetMachineAxis | Get the absolute value of the machine axis.
InstallProbeHead | Install a new probe Head
InstallStandardProbe | Install a standard probe into Probe database (the argument can be the name of a standard probe (i.e TP20x20x2 or a full assembly definition
Load | Load the full state of the simulator from a stream or a file
LoadCMMConfiguration | Install a new cmm kinematic file
LoadConfigurationInteractive | Displays a file dialog to allow user to load the configuration of the simulator
LoadKinematicsInteractive | Displays a file dialog to allow user to load a different model for the CMM
MachineAxisAddress | The machine axes address.
MachineAxisType | The machine axes type.
MoveProbe | Move the probe to the specified position.
ProbeStructureExists | Returns TRUE if the graphical structure for the probe specified by the vcard exists
ResetMachineOrientation | Reset the machine orientation to the home position.
ResetStatistics | Reset the animation statistics.
RotateProbe | Rotate the probe head.
Save | Save the full state of the simulator in a stream or a file
SaveConfigurationInteractive | Displays a file dialog to allow user to save the configuration of the simulator
SaveDefaultConfiguration | Save the configuration of the simulator in the default location
SetMachineAxis | Set the absolute value of the machine axis.
SetMachineOrientation | Move the machine into the given position/orientation using the kinematic method and constraints given.
SimulateProbePath | Start the asynchronous simulation of the probe path.
Stop | stop the simulator

Properties

AngularVelocity | R/W | Retrieves/sets the angular feedrate of the probe head (in deg/sec) for animation (when Anmination = cmms_ANIMATED)
Animation | R/W | Set/retreive the animation mode
BackOffBehaviour | R/W | Retrieve the backoff behavior of the CMM.
BUSY | R/O | Return the busy flag.
CMMPosition | R/O | R/O retrieve the current position of the CMM.
CMMProtocol | R/O | get the protocol
CMMVisible | R/W | Show/Hide the CMM
CollisionChecking | R/W | Returns true if the joystick move (i.e MoveProbe) performs collision checking
EmergencyStop | R/W | set/retreive the state of the Manual Emmergency stop button
Feedrate | R/W | Retrieves/sets the feedrate (in mm/sec) for animation (when Anmination = cmms_ANIMATED)
HomeOrientation | R/O | Get the home orientation of the machine.
MachineOrientation | R/O | Get the current machine orientation data for the machine being used in the simulator.
MachineOrientationSet | R/O | Has the machine orientation been set?
MaintainCameraPosition | R/W | Retrieves the camera position being maintained during simulation.
NumberOfMachineAxes | R/O | Number of machine axes.
ProbeDatabase | R/O | Get the probe database for simulation
ProbeHeadVisible | R/W | Show/Hide the ProbeHead
ProbeStructureBuilder | R/O | Get the probe-structure builder used when creating probe-graphics
ProbeVisible | R/W | Show/Hide the Probe
Statistics | R/O | Returns a string containing some animation performance statistics
TipOffset | R/O | Retrieve the current tip offset, from Quill mounting point to Tip Position.
TipPosition | R/O | R/O retrieve the current position of the active sensor tip.
TipShankDirection | R/O | Retrieve the current tip shank direction from tip toward the shank.
ToolMountingPointPosition | R/O | R/O retrieve the current position of the tool mounting point.


ICMMUIExtensionCommand

ICMMUIExtensionCommand - interface

Description

ICMMUIExtensionCommand Interface

Methods

Execute Executes the interface extension command

Properties

AddToTaskBarMenu | R/O | Whether to add this command to the task bar icon context menu
AddToToolbar | R/O | Whether to add this command to the user interface extension toolbar
AllowMultipleExecution | R/O |
BitMap | R/O | Get a pointer to the CBitmap for this command
Checked | R/O | The user interface extension command's checked state
Enabled | R/O | The user interface extension command's enabled state
EnableModeless | R/O |
Text | R/O | The user interface extension command's text
ToolTipText | R/O | Tooltip text for this command


AddToTaskBarMenu

AddToTaskBarMenu - Read property

Description

Whether to add this command to the task bar icon context menu

Syntax in Visual Basic or VBScript

AddToTaskBarMenu () As Boolean

Syntax in C++

HRESULT get_AddToTaskBarMenu (VARIANT_BOOL* retVal)

Applies to

ICMMUIExtensionCommand


AddToToolbar

AddToToolbar - Read property

Description

Whether to add this command to the user interface extension toolbar

Syntax in Visual Basic or VBScript

AddToToolbar () As Boolean

Syntax in C++

HRESULT get_AddToToolbar (VARIANT_BOOL* retVal)

Applies to

ICMMUIExtensionCommand


AllowMultipleExecution

AllowMultipleExecution - Read property

Syntax in Visual Basic or VBScript

AllowMultipleExecution () As Boolean

Syntax in C++

HRESULT get_AllowMultipleExecution (VARIANT_BOOL* retVal)

Applies to

ICMMUIExtensionCommand


BitMap

BitMap - Read property

Description

Get a pointer to the CBitmap for this command

Syntax in Visual Basic or VBScript

BitMap () As Long

Syntax in C++

HRESULT get_BitMap (LONG* retVal)

Applies to

ICMMUIExtensionCommand


Checked

Checked - Read property

Description

The user interface extension command's checked state

Syntax in Visual Basic or VBScript

Checked () As Boolean

Syntax in C++

HRESULT get_Checked (VARIANT_BOOL* retVal)

Applies to

ICMMUIExtensionCommand


Enabled

Enabled - Read property

Description

The user interface extension command's enabled state

Syntax in Visual Basic or VBScript

Enabled () As Boolean

Syntax in C++

HRESULT get_Enabled (VARIANT_BOOL* retVal)

Applies to

ICMMUIExtensionCommand


EnableModeless

EnableModeless - Read property

Syntax in Visual Basic or VBScript

EnableModeless () As Boolean

Syntax in C++

HRESULT get_EnableModeless (VARIANT_BOOL* retVal)

Applies to

ICMMUIExtensionCommand


Text

Text - Read property

Description

The user interface extension command's text

Syntax in Visual Basic or VBScript

Text () As String

Syntax in C++

HRESULT get_Text (BSTR* retVal)

Applies to

ICMMUIExtensionCommand


ToolTipText

ToolTipText - Read property

Description

Tooltip text for this command

Syntax in Visual Basic or VBScript

ToolTipText () As String

Syntax in C++

HRESULT get_ToolTipText (BSTR* retVal)

Applies to

ICMMUIExtensionCommand


Execute

Execute - method

Description

Executes the interface extension command

Syntax in Visual Basic or VBScript

Execute ()

Syntax in C++

HRESULT Execute ()

Applies to

ICMMUIExtensionCommand


ICMMUIExtensionCommands

ICMMUIExtensionCommands - interface

Description

ICMMUIExtensionCommands Interface

Properties

Count | R/O | Returns the number of objects in the collection
Item | R/O | Returns a specific object in the collection

Used in

UIExtensionCommands


Count

Count - Read property

Description

Returns the number of objects in the collection

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

ICMMUIExtensionCommands


Item

Item - Read property

Description

Returns a specific object in the collection

Syntax in Visual Basic or VBScript

Item (Index As Long) As ICMMUIExtensionCommand

Syntax in C++

HRESULT get_Item (LONG Index , ICMMUIExtensionCommand* retVal)

Applies to

ICMMUIExtensionCommands


ICMMVectorParameter

ICMMVectorParameter - interface

Description

ICMMVectorParameter Interface

Methods

ApplyPackedValue | modify the value and/or definition of this parameter using a packed String
Clone | Clone : create an exact copy of this object and return a pointer to it
IsValidValue | check if the value provided is suitable for this parameter

Properties

Category | R/W | Get the current category name
Description | R/W | Description of the parameter
isDMIS | R/O | Is this parameter a DMIS Parameter
IsUIAccessible | R/W | Get the current IsUIAccessible flag
Name | R/O | name of the parameter
PackedValue | R/O | PackValue
ParameterType | R/O | type of this parameter
ReadOnly | R/W | ReadOnly
UIName | R/W | User defined (translated) name of the parameter
Value | R/W | value of the parameter
VCARD | R/O | Get the VCARD of the parameter
vector | R/O | returns the point


vector

vector - Read property

Description

returns the point

Syntax in Visual Basic or VBScript

vector () As Vector3D

Syntax in C++

HRESULT get_vector (Vector3D* retVal)

Applies to

CMMVectorParameter


ICoClass

ICoClass - interface

Description

ICoClass Interface

Properties

Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.

Collections

EventSources | sources of event
ImpInterfaces | the interfaces implemented by this coclass
Interfaces | Returns collection of interfaces/dispinterfaces/eventsource.


ICollection

ICollection - interface

Description

ICollection Interface

Properties

Count | R/W | property Count
Item | R/O | property Item

Used in

Elements
EventSources
ImpInterfaces
Interfaces
Methods
Parameters
Properties
TypeInfos


ICommandBar

ICommandBar - interface

Description

ICommandBar Interface

Methods

Delete |
FindControl |
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.

Properties

BuiltIn | R/O | property BuiltIn
CommandBarType | R/O | property Type
Name | R/W | property Name
Position | R/W |
RowIndex | R/W |
ShowText | R/W | property ShowText
Visible | R/W | property Visible

Collections

Controls | property Controls
FindControls |


ICommandBarButton

ICommandBarButton - interface

Description

ICommandBarButton Interface

Methods

Delete | method Delete
Execute | method Execute
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.
SetFocus | method SetFocus

Properties

BeginGroup | R/W | property BeginGroup
BuiltIn | R/O | property BuiltIn
Caption | R/W | property Caption
ControlType | R/O |
DescriptionText | R/W | property DescriptionText
Enabled | R/W | property Enabled
FaceId | R/W | method Id: returns the Face ID of the button ( the look of the button )
Id | R/O | method Id: returns the command ID of the button
Index | R/O | property Index : returns the index of this elements in the collection ( start at 1 )
OnAction | R/W | property OnAction
Parent | R/O | retrieves the Parent CommandBar
Style | R/W | property Style
Tag | R/W | property Tag: user defined string that help to find the control
TooltipText | R/W | property TooltipText
Visible | R/W | property Visible
Width | R/W | Retrieves/sets the with of the control


ICommandBarComboBox

ICommandBarComboBox - interface

Description

ICommandBarComboBox Interface

Methods

AddItem | method AddItem
Clear | method Clear
Delete | method Delete
Execute | method Execute
RemoveItem | method RemoveItem
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.
SetFocus | method SetFocus

Properties

BeginGroup | R/W | property BeginGroup
BuiltIn | R/O | property BuiltIn
Caption | R/W | property Caption
ControlType | R/O |
DescriptionText | R/W | property DescriptionText
DropDownHeight | R/W | property DropDownHeight
DropDownWidth | R/W | property DropDownWidth
Enabled | R/W | property Enabled
Id | R/O | method Id: returns the command ID of the button
Index | R/O | property Index : returns the index of this elements in the collection ( start at 1 )
ListCount | R/O | property ListCount
ListIndex | R/W | property ListIndex: returns or set the index of the selected iten in the list (0 means none,1 means the first etc...
OnAction | R/W | property OnAction
Parent | R/O | retrieves the Parent CommandBar
Tag | R/W | property Tag: user defined string that help to find the control
Text | R/W | returns or sets the text in the display or edit portion of the command bar combo box control.
TooltipText | R/W | property TooltipText
Visible | R/W | property Visible
Width | R/W | Retrieves/sets the with of the control


ICommandBarControl

ICommandBarControl - interface

Description

ICommandBarControl Interface

Methods

Delete | method Delete
Execute | method Execute
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.
SetFocus | method SetFocus

Properties

BeginGroup | R/W | property BeginGroup
BuiltIn | R/O | property BuiltIn
Caption | R/W | property Caption
ControlType | R/O |
DescriptionText | R/W | property DescriptionText
Enabled | R/W | property Enabled
Id | R/O | method Id: returns the command ID of the button
Index | R/O | property Index : returns the index of this elements in the collection ( start at 1 )
OnAction | R/W | property OnAction
Parent | R/O | retrieves the Parent CommandBar
Tag | R/W | property Tag: user defined string that help to find the control
TooltipText | R/W | property TooltipText
Visible | R/W | property Visible
Width | R/W | Retrieves/sets the with of the control


ICommandBarControls

ICommandBarControls - interface

Description

ICommandBarControls Interface

Methods

Add method Add

Properties

Count | R/O
Item | R/O

Used in

Controls
Controls
FindControls


ICommandBarPopup

ICommandBarPopup - interface

Description

ICommandBarPopup Interface

Methods

Delete | method Delete
Execute | method Execute
Reset | Resets a built-in command bar to its default configuration, or resets a built-in command bar control to its original function and face.
SetFocus | method SetFocus

Properties

BeginGroup | R/W | property BeginGroup
BuiltIn | R/O | property BuiltIn
Caption | R/W | property Caption
ControlType | R/O |
DescriptionText | R/W | property DescriptionText
Enabled | R/W | property Enabled
Id | R/O | method Id: returns the command ID of the button
Index | R/O | property Index : returns the index of this elements in the collection ( start at 1 )
OnAction | R/W | property OnAction
Parent | R/O | retrieves the Parent CommandBar
Tag | R/W | property Tag: user defined string that help to find the control
TooltipText | R/W | property TooltipText
Visible | R/W | property Visible
Width | R/W | Retrieves/sets the with of the control

Collections

Controls


ICommandBars

ICommandBars - interface

Description

ICommandBars Interface

Methods

Add
FindBar
FindControl
GetMessageString

Properties

ActionControl | R/O | returns the button that has just been pressed
Count | R/O |
DisplayTooltips | R/W | property DisplayTooltips
Item | R/O |
LargeButtons | R/W | property LargeButtons
ParentFrame | R/W | property ParentFrame

Used in

CommandBars


IConstant

IConstant - interface

Description

IConstant Interface

Properties

Documentation | R/O | property Documentation
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Memberid | R/O | Returns memid.
Name | R/W | property Name
Type | R/O | Returns a ITypeDesc object that describes the type of constant.
Value | R/O | Returns value of constant.


ICoordFormat

ICoordFormat - interface

Description

ICoordFormatPoint3D Interface

Properties

InfoString | R/O | Get the displayable info string of the coordinate specified by the index
NumberOfValue | R/O | Get the number of choice ( number of value) for the current coordinate format
Prefix | R/O | Get the displayable prefix of the coordinate specified by the index
Unit | R/O | Get the unit of the value specified by the index
ValueArray | R/O | Get a array that contains the values


InfoString

InfoString - Read property

Description

Get the displayable info string of the coordinate specified by the index

Syntax in Visual Basic or VBScript

InfoString (Index As Long) As String

Syntax in C++

HRESULT get_InfoString (LONG Index , BSTR* retVal)

Applies to

ICoordFormat
ICoordFormatPoint3D
ICoordFormatUnitVector3D
ICoordFormatVector3D


NumberOfValue

NumberOfValue - Read property

Description

Get the number of choice ( number of value) for the current coordinate format

Syntax in Visual Basic or VBScript

NumberOfValue () As Long

Syntax in C++

HRESULT get_NumberOfValue (LONG* retVal)

Applies to

ICoordFormat
ICoordFormatPoint3D
ICoordFormatUnitVector3D
ICoordFormatVector3D


Prefix

Prefix - Read property

Description

Get the displayable prefix of the coordinate specified by the index

Syntax in Visual Basic or VBScript

Prefix (Index As Long) As String

Syntax in C++

HRESULT get_Prefix (LONG Index , BSTR* retVal)

Applies to

ICoordFormat
ICoordFormatPoint3D
ICoordFormatUnitVector3D
ICoordFormatVector3D


Unit

Unit - Read property

Description

Get the unit of the value specified by the index

Syntax in Visual Basic or VBScript

Unit (Index As Long) As geomUnitType

Syntax in C++

HRESULT get_Unit (LONG Index , geomUnitType* retVal)

Applies to

ICoordFormat
ICoordFormatPoint3D
ICoordFormatUnitVector3D
ICoordFormatVector3D


ValueArray

ValueArray - Read property

Description

Get a array that contains the values

Syntax in Visual Basic or VBScript

ValueArray () As Variant

Syntax in C++

HRESULT get_ValueArray (VARIANT* retVal)

Applies to

ICoordFormat
ICoordFormatPoint3D
ICoordFormatUnitVector3D
ICoordFormatVector3D


ICoordFormatPoint3D

ICoordFormatPoint3D - interface

Description

ICoordFormatPoint3D Interface

Properties

CoordType | R/W | retreive the coordinate format
InfoString | R/O | Get the displayable info string of the coordinate specified by the index
NumberOfValue | R/O | Get the number of choice ( number of value) for the current coordinate format
Prefix | R/O | Get the displayable prefix of the coordinate specified by the index
Unit | R/O | Get the unit of the value specified by the index
ValueArray | R/O | Get a array that contains the values


CoordType

CoordType - Read & Write property

Description

retreive the coordinate format

Syntax in Visual Basic or VBScript

CoordType () As geomPoint3DCoordinateType

Syntax in C++

HRESULT get_CoordType (geomPoint3DCoordinateType* retVal)
HRESULT put_CoordType (geomPoint3DCoordinateType Value)

Applies to

ICoordFormatPoint3D
ICoordFormatUnitVector3D
ICoordFormatVector3D


ICoordFormatUnitVector3D

ICoordFormatUnitVector3D - interface

Description

ICoordFormatUnitVector3D Interface

Properties

CoordType | R/W | retreive the coordinate format
InfoString | R/O | Get the displayable info string of the coordinate specified by the index
NumberOfValue | R/O | Get the number of choice ( number of value) for the current coordinate format
Prefix | R/O | Get the displayable prefix of the coordinate specified by the index
Unit | R/O | Get the unit of the value specified by the index
ValueArray | R/O | Get a array that contains the values


ICoordFormatVector3D

ICoordFormatVector3D - interface

Description

ICoordFormatVector3D Interface

Properties

CoordType | R/W | retreive the coordinate format
InfoString | R/O | Get the displayable info string of the coordinate specified by the index
NumberOfValue | R/O | Get the number of choice ( number of value) for the current coordinate format
Prefix | R/O | Get the displayable prefix of the coordinate specified by the index
Unit | R/O | Get the unit of the value specified by the index
ValueArray | R/O | Get a array that contains the values


ICustomActionItem

ICustomActionItem - interface

Description

ICustomActionItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
Execute | Execute the custom action
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
CustomAction | R/W | set/returns the macro to execute when this element is played
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IDatumFeatureCollection

IDatumFeatureCollection - interface

Description

IProbeRackSlotCollection Interface

Methods

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string

Used in

DatumFeatureCollection


IDatumOnExistingFeatures_Item

IDatumOnExistingFeatures_Item - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ReferenceLine | R/O |
ReferencePlane | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IDatumRotateItem

IDatumRotateItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterAngle | R/O |
ParameterAxis | R/O |
ReferenceDatum | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IDatumRotateToFeature2DItem

IDatumRotateToFeature2DItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterFixedPlane | R/O |
ParameterReferenceAxis | R/O |
ReferenceDatum | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
TargetAxis | R/O |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IDatumRotateToFeature3DItem

IDatumRotateToFeature3DItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterReferenceAxis | R/O |
ReferenceDatum | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
TargetAxis | R/O |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IDatumShiftItem

IDatumShiftItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterNewOrigin | R/O |
ReferenceDatum | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IDatumSphere

IDatumSphere - interface

Description

IDatumSphere Interface

Methods

FillIdentityCard | fill the node with the identity card of this item
SetDiameterUnit | set the value using the specify value ( in the specified units ) without altering the internal units

Properties

_ID | R/W | INTERNAL USE ONLY
Calibration | R/O | retrieves the calibration object
Carriage | R/O | retrieves the carriage on which this datum sphere is fitted
Diameter | R/W | retrieve the diameter in MM
DiameterUnit | R/O | Get the current value in the prefered unit
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
Position | R/W |
PreferedUnit | R/O | Get the prefered units
StemDirection | R/O |
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user


IDigitisedCurve

IDigitisedCurve - interface

Description

IDigitisedCurve Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PointCloud | R/O | return the point cloud associated with the given measure, in CMM coordinates
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


PointCloud

PointCloud - Read property

Description

return the point cloud associated with the given measure, in CMM coordinates

Syntax in Visual Basic or VBScript

PointCloud (measure As Variant) As PointCloud

Syntax in C++

HRESULT get_PointCloud (VARIANT measure , PointCloud* retVal)

Applies to

IDigitisedCurve
IPointCloudItem


IDispinterface

IDispinterface - interface

Description

IDispinterface Interface

Properties

Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.

Collections

Methods | property Methods
Properties | property Properties


IDocument

IDocument - interface

Description

the PowerINSPECT Document interface

Methods

ActivateCustomTab | Bring the indicated custom tab to the front.
CheckIntersectionWithCADModel | Check intersection of a segment with the CAD model along a direction, if multiple solution found then the method returns the closest to point1
Close | Close the specified document
CreateReport | Creates an HTML Report and saves it as a single web-archive file (*.mht file) to the given location
DeactivateCustomTab | Send the indicated custom tab to the back.
FindBestFeaturePlane | Find one feature plane compatible with the given entity excluding features provided by alignments
FindClosestPoint | Find the closest point on the CAD model, within the specified proximity distance. If -1.0 is provided as proximity distance the current default value will be used. An approximation of the expected surface normal can be provided if necessary or Nothing.
FindMeasureByUniqueID | find a SequenceItem by its UniqueID
FindMultiAxisConfigForSequenceItem | Find the MultiaxisConfigurationItem used to set the machine orientation for the given sequence item.
FindSequenceItemByUniqueID | find a SequenceItem by its UniqueID
InstallCustomTab | InstallCustomTab
IntersectionWithCADModel | Intersects a segment with the CAD model along a direction, if multiple solution found then the method returns the closest to point1, a full description of the surface point including point3D , parametric parameter and normal is provided, the function returns ?ç?
IsItemSafeForReplayUI | Check if the given sequence is safe for replay. If not, warn the user and ask them if they wish to replay the item.
IsRangeSafeForReplayUI | Check if the current range of items is safe for replay. If not, warn the user and ask them if they wish to replay the items.
RemoveCustomTab | RemoveCustomTab
Save | Save the specified document. this methoid will fail if the document has not been save yet
SaveAs |
SaveCopyAS | Make a copy of the specified document
SetExcelTemplateName |
TakeOwnership | take ownership of this document, ( note : you must have enough privileged to set the Owner SID
XMLOutput | XMLOutput

Properties

ActiveFeatureVisibility | R/W | sets/get the active item visibilty mode
ActiveGroup | R/W | set/retrieve the current active Group Item in the current active Tree( Nothing means top level)
ActiveItem | R/W | set/retrieve the current active Sequence Item in the current active Tree
ActiveMeasure | R/W | set/retrieve the current active Measure in the current active Tree
ActiveWorkplane | R/W | sets/get the current active plane
Application | R/O |
BackfaceColor | R/W | sets/retrieves flag indicating the back-facing color is on
BootstrapPosition | R/O | BootstrapPosition: define the bootstrap aligment defined for this file
CMMDatum | R/O | Returns the CMM Datum item
ConfettiSize | R/W | sets/retrieves the confetti size
EdgePointHighTol | R/W | sets/retrieves the default tolerance for edge points
EdgePointLowTol | R/W | sets/retrieves the default tolerance for edge points
EdgePointOffset | R/W | sets/retrieves the default offset for edge points
EdgePointProximityCriteria | R/W | sets/retrieves the default proximity criteria for edge Point
ExcelTemplateName | R/W |
FindCompatibleFeaturePlanesTolerance | R/W | Allows to set/get tolerance for searching compatible planes
FirstRangeMarker | R/W | Sets/retrieves the first sequence tree sub-range marker.
FullPathName | R/O |
GridMode | R/W | sets/retrieves the grid mode of the active view
HeadClearance | R/W | Sets/gets the head clearance used for collision-checking
HTMLReportTemplateName | R/W | Sets/gets the location of the current HTML Report template
IgnoreMissingContactPoints | R/W | Sets/gets whether the collision-checker ignores missing contact points
LastRangeMarker | R/W | Sets/retrieves the last sequence tree sub-range marker.
ModelShadingMode | R/W | sets/gets the current model shading mode
Name | R/W |
NextItemName | R/O | returns the name that will be given by default to the next created sequence item of the specified type
NominalTransformation | R/O | NominalTransformation: define the nominal transformation defined for this file.
NumberOfDigits | R/W | sets/retrieves the number of digit used to display coordinates or dimension
NumberOfDigitsAngle | R/W | sets/retrieves the number of digit used to display angles.
NumberOfDigitsNeutral | R/W | sets/retrieves the number of digit used to display neutral values.
ObjectPool | R/O |
OwnerSID | R/W |
PCSDatum | R/O | Returns the PCS Datum item
PositioningMatrixForSimulatedMachine | R/O | Get the alignment which maps the PCS (Cad Datum) onto the simulated-machine-datum. Note: Only valid in OMV PRO.
PositioningMatrixForSimulation | R/O | Get the alignment which maps the PCS (Cad Datum) onto the Machine Datum.
ProbePathEditor | R/O | returns the probepath editor object
ProbePathVerificationMode | R/W | Sets/gets the probe path collision-checking mode
ProbePathVisibility | R/W | sets/retrieves the current probe path visibility in CAD view.
ProbeToolClearance | R/W | Sets/gets the probe tool clearance used for collision-checking
ReportSettings | R/O | retrieves report settings of the document
RetracePointAutoCompletionDistance | R/W | sets/retrieves the default maximal distance to target allowed for retrace point
RetracePointAutomaticCompletion | R/W | sets/retrieves the default option for automatic completion ( the retrace point will be automatically accepted if it is within the RetracePointGuidedDistance criteria
RetracePointCatchmentDistance | R/W | sets/retrieves the default catchement distance for retrace points
RetracePointRecordAllPointInCatchementZone | R/W | sets/retrieves the default recording option for retrace point
Saved | R/W | True if no changes have been made to the specified document since it was last saved. Read/write Boolean.
SequenceReplayEngine | T/O | returns a pointer to the SequenceReplayEngine used for the CMM
SequenceSimulatorEngine | T/O | returns a pointer to the SequenceReplayEngine used for the simulation
Simulator | T/O | retrieves the CNC simulator object
SurfacePointHighTol | R/W | sets/retrieves the default tolerance for surface points
SurfacePointLowTol | R/W | sets/retrieves the default tolerance for surface points
SurfacePointOffset | R/W | sets/retrieves the default offset for surface points
SurfacePointProximityCriteria | R/W | sets/retrieves the default proximity criteria for Surface Point
TriangulationTolerance3D | R/W | Get the 3D-triangulation-tolerance
TriangulationToleranceMax3D | R/W | Get the maximum 3D-triangulation-tolerance
Units | R/W |
VerificationStatus | R/O | Returns true if the sequence tree contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.
VerificationStatusOfActiveItem | R/O | Returns true if the active sequence item contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.
VerificationStatusOfRange | R/O | Returns true if the selected range of sequence items contains faults or collisions. Returns the first fault found or ppvs_UNVERIFIED if probe-path verification is switched off.

Collections

CADFiles |
CADSelectionManager | the CAD Selection manager
DynamicPoints | Dynamic Point collection
Features |
FindCompatibleFeaturePlanes | find a list of plane features that are compatible with the given entity
Measures |
ReportVariables |
SequenceItems |
UserLevels | Collection of user CAD levels belonging to this document.
VerticeSelectionManager | the Vertice Selection manager


IDocuments

IDocuments - interface

Description

IDocuments Interface

Methods

Add | method Add
Close | close all opened documents
Open | Open a particular PowerINSPECT document

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 1 to Count or a string

Used in

Documents


IDynamicPoint

IDynamicPoint - interface

Description

IDynamicPoint Interface

Methods

Convert | convert that point to the type specified, the point will snap to the closest point on the edge or on the surface
CreateGuidedPoint | convert that point into a guided point in the specified group
Delete | delete this item from the collection
Reverse | reverse the normal vector of the point

Properties

DynamicPointType | R/O | get the type of this dynamic point
EdgeID | R/O |
EdgeOffset | R/W | set/get the edge offset
Index | R/O |
LowerTolerance | R/W | set/get the lower tolerance
Name | R/W | set/get the name of the point
point | R/O |
SurfaceID | R/O | get the id of the surface on which this dynamic point lies
SurfaceOffset | R/W | set/get the surface offset
UpperTolerance | R/W | set/get the upper tolerance
vector | R/O |


IDynamicPoints

IDynamicPoints - interface

Description

IDynamicPoints Interface

Methods

CreateDynamicPoint | create a new dynamic point
CreateFreeFormFitAlignment | use all points to create a free form fit alignemnt
CreateGuidedPoints | convert all points of this container into a guided points in the specified group
Delete | method Delete the specifyed measure from the collection
DeleteAll | method Delete all Dynamic Points from the collection

Properties

Count | R/O | returns the number of items in the collection.
Item | R/O | allows random access to individual measure within the collection. Index can be an ordinal from 1 to Count or a string

Used in

DynamicPoints


IDynamicTarget

IDynamicTarget - interface

Description

IDynamicTarget Interface

Properties

Direction | R/O | targetting direction
Name | R/O | name of a point
SurfID | R/O | targetting surface ID
Target | R/O | target point coordinates


IDynamicTargetResult

IDynamicTargetResult - interface

Description

IDynamicTargetResult Interface

Properties

Direction | R/O | targetting direction
distance | R/O | retuns distance between a projected target and a measured point
HasFailed | R/O | returns is the point failed
Name | R/O | name of a point
SurfID | R/O | targetting surface ID
Target | R/O | target point coordinates


IDynamicTargetResults

IDynamicTargetResults - interface

Description

IDynamicTargetResults Interface

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual points. Index can be an ordinal from 1 to Count or a string

Used in

Results


IDynamicTargets

IDynamicTargets - interface

Description

IDynamicTargets Interface

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual points. Index can be an ordinal from 1 to Count or a string

Used in

Targets


IEdgePoint

IEdgePoint - interface

Description

IEdgePoint Interface

Properties

Boundary | R/O | not yet implemented
CurveID | R/O |
EdgeNormal | R/O |
EdgeType | R/O |
point | R/O |
Surface | R/O | not yet implemented
SurfaceName | R/O | Name of surface
SurfaceNormal | R/O |
SurfID | R/O |
T | R/O | parameter along the curve of the edge
U | R/O |
V | R/O |


Boundary

Boundary - Read property

Description

not yet implemented

Syntax in Visual Basic or VBScript

Boundary () As ICADEntity

Syntax in C++

HRESULT get_Boundary (ICADEntity* retVal)

Applies to

IEdgePoint


CurveID

CurveID - Read property

Syntax in Visual Basic or VBScript

CurveID () As Long

Syntax in C++

HRESULT get_CurveID (LONG* retVal)

Applies to

IEdgePoint


EdgeNormal

EdgeNormal - Read property

Syntax in Visual Basic or VBScript

EdgeNormal () As UnitVector3D

Syntax in C++

HRESULT get_EdgeNormal (UnitVector3D* retVal)

Applies to

IEdgePoint


EdgeType

EdgeType - Read property

Syntax in Visual Basic or VBScript

EdgeType () As PWI_EdgeType

Syntax in C++

HRESULT get_EdgeType (PWI_EdgeType* retVal)

Applies to

IEdgePoint


Surface

Surface - Read property

Description

not yet implemented

Syntax in Visual Basic or VBScript

Surface () As ICADEntity

Syntax in C++

HRESULT get_Surface (ICADEntity* retVal)

Applies to

IEdgePoint


SurfaceName

SurfaceName - Read property

Description

Name of surface

Syntax in Visual Basic or VBScript

SurfaceName () As String

Syntax in C++

HRESULT get_SurfaceName (BSTR* retVal)

Applies to

IEdgePoint


SurfaceNormal

SurfaceNormal - Read property

Syntax in Visual Basic or VBScript

SurfaceNormal () As UnitVector3D

Syntax in C++

HRESULT get_SurfaceNormal (UnitVector3D* retVal)

Applies to

IEdgePoint


SurfID

SurfID - Read property

Syntax in Visual Basic or VBScript

SurfID () As Long

Syntax in C++

HRESULT get_SurfID (LONG* retVal)

Applies to

IEdgePoint
ISurfacePoint


T

T - Read property

Description

parameter along the curve of the edge

Syntax in Visual Basic or VBScript

T () As Double

Syntax in C++

HRESULT get_T (double* retVal)

Applies to

IEdgePoint


U

U - Read property

Syntax in Visual Basic or VBScript

U () As Double

Syntax in C++

HRESULT get_U (double* retVal)

Applies to

IEdgePoint
ISurfacePoint


V

V - Read property

Syntax in Visual Basic or VBScript

V () As Double

Syntax in C++

HRESULT get_V (double* retVal)

Applies to

IEdgePoint
ISurfacePoint


IEdgePointItem

IEdgePointItem - interface

Description

IEdgePointItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
MeasuredPoint | the measured surface point for the given measure
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
EdgeOffset | R/W |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LowerTolerance | R/W |
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PointType | R/W |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SurfaceOffset | R/W |
TargetPoint | R/O |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W |
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
ResultStack | stack of results for the given measure


IEdgePointResult

IEdgePointResult - interface

Description

IEdgePointResult Interface

Properties

ContactPoint | R/O | the coordinates of the probe point in contact with the actual surface
Deviation | R/O | the deviation
DeviationVector | R/O | the deviation vector
EdgePoint | R/O | the information on the projected point
IsValid | R/O |
measure | R/O |
MeasureState | R/O | returns the measurement state
Parent | R/O |
ProbeCenter | R/O | the coordinates of the probe center
ProbeClearanceVector | R/O | the coordinates of the CMM point vector
ProbeDiameter | R/W | the probe diameter


IEdgePointResultStack

IEdgePointResultStack - interface

Description

IEdgePointResultStack - a collection of EdgePointResult objects

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual points. Index can be an ordinal from 1 to Count or a string

Used in

ResultStack


IEntityFromPoints

IEntityFromPoints - interface

Description

IEntityFromPoints

Properties

AverageMinimumZoneEntity | R/O | return the Least Square entity
CalculusMethod | R/W | Calculus Method : describe the method used for the calculation
Deviation | R/O | Deviation : retrieve the signed deviation of the specified point
Entity | R/O | return the entity matching type
EntityType | R/W | return/set the type of the entity
Extra | R/O | Extra
LeastSquareEntity | R/O | return the Least Square entity
MaxDeviation | R/O | retreives the maximum deviation found with the provides CMMpoints
MaxDeviationPointIndex | R/O | retreives the index of the point with the maximum deviation found
MaximumInscribedEntity | R/O | return the Least Square entity
MinimumCircumscribedEntity | R/O | return the Least Square entity
OuterMaterialPoint | R/O | OuterMaterialPoint
ProbeDiameter | R/W | PropDiameter
ReferencePlane | R/O | Reference Plane

Collections

CMMPoints return a pointer to the inner CMMPoints Array that can be populated


IEnum

IEnum - interface

Description

IEnum Interface

Properties

Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.

Collections

Elements property Elements


IFeat_Circle_PlaneConicItem

IFeat_Circle_PlaneConicItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyCircularity | R/O |
ReferenceConic | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_CircleThroughNPointsItem

IFeat_CircleThroughNPointsItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureArc | R/O |
FeatureCentre | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyCentre | R/O |
PropertyCircularity | R/O |
PropertyRadius | R/O |
ReferencePlane | R/O |
ReferencePoints | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_ConeItem

IFeat_ConeItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureApex | R/O |
FeatureAxis | R/O |
FeatureCone | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBasePoint | R/O |
ParameterBoundary | R/O |
ParameterHeight | R/O |
ParameterMaterialSide | R/O |
ParameterQuadrant | R/O |
ParameterRadius | R/O |
PropertyConicity | R/O |
PropertyDirection | R/O |
PropertyHalfAngle | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_CylinderItem

IFeat_CylinderItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxis | R/O |
FeatureCylinder | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBasePoint | R/O |
ParameterBoundary | R/O |
ParameterHeight | R/O |
ParameterMaterialSide | R/O |
ParameterQuadrant | R/O |
PropertyCylindricity | R/O |
PropertyDirection | R/O |
PropertyRadius | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_LaserScannedCircleItem

IFeat_LaserScannedCircleItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureArc | R/O |
FeatureCentre | R/O |
FeatureNormalVector | R/O |
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterEvaluateWithNominal | R/O |
ParameterExtrusion | R/O |
ParameterSearchDistance | R/O |
PointCloud | R/O |
PropertyCentre | R/O |
PropertyNormalVector | R/O |
PropertyRadius | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_LaserScannedPatchItem

IFeat_LaserScannedPatchItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterEvaluateWithNominal | R/O |
ParameterPoint | R/O |
PointCloud | R/O |
PropertyNormalVector | R/O |
PropertyPlanarity | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_LaserScannedRectangleItem

IFeat_LaserScannedRectangleItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureMajorAxis | R/O |
FeatureMinorAxis | R/O |
FeatureNormalVector | R/O |
FeaturePlane | R/O |
FeatureRectangle | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterEvaluateWithNominal | R/O |
ParameterExtrusion | R/O |
ParameterSearchDistance | R/O |
PointCloud | R/O |
PropertyCentre | R/O |
PropertyLength | R/O |
PropertyMajorAxis | R/O |
PropertyNormalVector | R/O |
PropertyWidth | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_LaserScannedSphereItem

IFeat_LaserScannedSphereItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureSphere | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterEvaluateWithNominal | R/O |
ParameterQuadrantAz | R/O |
ParameterQuadrantEl | R/O |
PointCloud | R/O |
PropertyCentre | R/O |
PropertyRadius | R/O |
PropertySphericity | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_PolygoneItem

IFeat_PolygoneItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureMajorAxis | R/O |
FeaturePolygon | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterGuidedMeasure | R/O |
ParameterMaterialSide | R/O |
ParameterNumberOfEgdes | R/O |
ParameterOffset | R/O |
PropertyCentre | R/O |
PropertyExscribedRadius | R/O |
PropertyInscribedRadius | R/O |
PropertyMajorAxis | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_ProbedCircleItem

IFeat_ProbedCircleItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureArc | R/O |
FeatureCentre | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterGuidedMeasure | R/O |
ParameterMaterialSide | R/O |
ParameterOffset | R/O |
ParameterQuadrant | R/O |
PropertyCentre | R/O |
PropertyCircularity | R/O |
PropertyRadius | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_RectangleItem

IFeat_RectangleItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureMajorAxis | R/O |
FeatureMinorAxis | R/O |
FeatureRectangle | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterGuidedMeasure | R/O |
ParameterMaterialSide | R/O |
ParameterOffset | R/O |
PropertyCentre | R/O |
PropertyLength | R/O |
PropertyMajorAxis | R/O |
PropertyWidth | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_SinglePointCircleItem

IFeat_SinglePointCircleItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureArc | R/O |
FeatureCentre | R/O |
FeatureProbeCenter | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterOffset | R/O |
PropertyCentre | R/O |
PropertyRadius | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_SlotItem

IFeat_SlotItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureCentre1 | R/O |
FeatureCentre2 | R/O |
FeatureMajorAxis | R/O |
FeatureMinorAxis | R/O |
FeatureRoundedSlot | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterGuidedMeasure | R/O |
ParameterMaterialSide | R/O |
ParameterOffset | R/O |
PropertyCentre | R/O |
PropertyLength | R/O |
PropertyMajorAxis | R/O |
PropertyProfile | R/O |
PropertyRadius | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_SphereItem

IFeat_SphereItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureSphere | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterMaterialSide | R/O |
ParameterOrientation | R/O |
ParameterQuadrantAz | R/O |
ParameterQuadrantEl | R/O |
PropertyCentre | R/O |
PropertyRadius | R/O |
PropertySphericity | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeat_TorusItem

IFeat_TorusItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxis | R/O |
FeatureCentre | R/O |
FeatureTorus | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterMaterialSide | R/O |
ParameterQuadrantAz | R/O |
ParameterQuadrantEl | R/O |
PropertyCentre | R/O |
PropertyDirection | R/O |
PropertyMajorRadius | R/O |
PropertyMinorRadius | R/O |
PropertyProfile | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IFeature

IFeature - interface

Description

IFeature Interface

Properties

Description | R/O | return a description of the feature in the current locale language
Entity | R/O | extract the entity for the feature
FeatureType | R/O | property FeatureType : Get the type of this Feature
Handle | R/O | return the handle of this item
ID | R/O | property ID : Get the ID of this Feature
Index | R/O | returns the index of this property in its parent collection
Name | R/O | property Name : return the name of this feature
Parent | R/O | return ISequence Item that owns this feature

Collections

ConnectedLinks return the collection of the links that reference this feature


IFeatures

IFeatures - interface

Description

IFeatures Interface

Methods

Add | Add a feature to the list
Remove | Remove a feature to the list

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual feature within the collection. Index can be an ordinal from 1 to Count or a string

Used in

Features
Features
Features
FindCompatibleFeaturePlanes
PossibleFeatures


IFireCMMProtocolEvents

IFireCMMProtocolEvents - interface

Description

IFireCMMProtocolEvents Interface

Methods

CNCControllingLockChanged | Fired when a CNC controlling object locks or unlocks its CNC control
ContactPoint | method ContactPoint
ContactPointCalibration | method ContactPointCalibration
EnableModeless | Fired to request the client to disable or enable its main window and other modeless dialogs
IntermediatePoint | method IntermediatePoint
OnCalibrationModeChanged | OnCalibration Mode change
OnCMMHomed | method OnCMMHomed : the CMM homed flag is now set
OnCMMParameterChanged | method OnCMMParamerChanged
OnCNCStatusChanged | method OnCNCStatusChanged
OnCompletion | method OnCNCError
OnConnectionChanged | method Connect
PreTouchIJKModeChanged | method PreTouchIJKModeChanged
ProbeDatabaseChanged | Fired by the protocol if the probe database object changes
ProbeTipChanged | Fired by the protocol for convenience when the probe database fires its ProbeTipChanged event
RemoteMouseChanged | Fired when the protocol's remote mouse state changes
RequestDisconnect | Fired to request consent to disconnect
TransactionChanged | Fired by the protocol when it has been informed that a transaction has started or stopped
VirtualCommand | method VirtualCommand
VirtualCommandCalibration | method VirtualCommandCalibration


IFunction

IFunction - interface

Description

IFunction Interface

Properties

CPPParameters | R/O | property CPPParameters
Documentation | R/O | property Documentation
FuncFlags | R/O | property FuncFlags a combinaison of FUNCFLAGS values
FuncKind | R/O | property FUNCKIND
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
InvocationKind | R/O |
Name | R/W | property Name
ReturnType | R/O | property ReturnType
VBParameters | R/O | property VBParameters
VBReturnType | R/O | property VBReturnType

Collections

Parameters property Parameters


IGDTDatumFeatureLink

IGDTDatumFeatureLink - interface

Description

IGDTDatumFeatureLink Interface

Properties

Description | R/O | return a description of the feature in the current locale language
FeatureMask | R/O | return the mask for this link
Handle | R/O | return the internal handle of this link
Index | R/O | returns the index of this property in its parent collection
Item | R/O |
LinkType | R/O | return the type of the link (Simple/Multiple)
Name | R/O | return the name of the link
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the link cannot be modified

Collections

PossibleFeatures property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


IGDTFeature

IGDTFeature - interface

Description

IGDTFeature Interface

Properties

Feature | R/W | put the Feature attached to this link
MaterialCondition | R/W |


IGDTFeaturesLink

IGDTFeaturesLink - interface

Description

IGDTFeaturesLink Interface

Methods

Add | Add a feature to the list
Remove | Remove a feature to the list

Properties

Count | R/W | Indicates the number of items in the collection.
Description | R/O | return a description of the feature in the current locale language
FeatureMask | R/O | return the mask for this link
Handle | R/O | return the internal handle of this link
Index | R/O | returns the index of this property in its parent collection
Item | R/O | Allows random access to individual feature within the collection. Index can be an ordinal from 1 to Count or a string
LinkType | R/O | return the type of the link (Simple/Multiple)
Name | R/O | return the name of the link
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the link cannot be modified

Used in

GDTFeatures


IGDTItem

IGDTItem - interface

Description

IGDTItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DatumA | R/O |
DatumB | R/O |
DatumC | R/O |
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
GDTType | R/W |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag
WorkPlane | R/W |

Collections

Features | return a collection of feature that this element provides
GDTFeatures |
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IGeometricCircleItem

IGeometricCircleItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureArc | R/O |
FeatureCentre | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyCentre | R/O |
PropertyRadius | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IGeometricGroup

IGeometricGroup - interface

Description

IGeometricGroup Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetExpanded | sets flag indicating group is expanded in the sequence tree
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
AutoTrimmingEnabled | R/W |
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
OutputToReport | R/W | get/set `output to report` flag
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
SequenceItems |
SequenceItemsForMeasure |


IGeometricItem

IGeometricItem - interface

Description

IGeometricItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IGeometricLaserScannedItem

IGeometricLaserScannedItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PointCloud | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IGeometricLineItem

IGeometricLineItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyDirection | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IGeometricPlaneItem

IGeometricPlaneItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IGeometricPointItem

IGeometricPointItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IHTMLConnector

IHTMLConnector - interface

Description

IHTMLConnector Interface

Methods

LocalizeString | return a localized version of a string
Refresh | method Refresh

Properties

CurrentMeasure | T/O | property CurrentMeasure
Name | R/W | property Name
SequenceItem | T/O | property SequenceItem


CurrentMeasure

CurrentMeasure - Reference Write property

Description

property CurrentMeasure

Syntax in Visual Basic or VBScript

CurrentMeasure () As Object

Syntax in C++

HRESULT get_CurrentMeasure (IDispatch** retVal)

Applies to

IHTMLConnector


SequenceItem

SequenceItem - Reference Write property

Description

property SequenceItem

Syntax in Visual Basic or VBScript

SequenceItem () As Object

Syntax in C++

HRESULT get_SequenceItem (IDispatch** retVal)

Applies to

IHTMLConnector


LocalizeString

LocalizeString - method

Description

return a localized version of a string

Syntax in Visual Basic or VBScript

LocalizeString (strID As Variant) As String

Syntax in C++

HRESULT LocalizeString (VARIANT strID , BSTR* retVal)

Parameters

Name | Description
strID |
Return Value |

Applies to

IHTMLConnector


Refresh

Refresh - method

Description

method Refresh

Syntax in Visual Basic or VBScript

Refresh ()

Syntax in C++

HRESULT Refresh ()

Applies to

IHTMLConnector


IIndexableProbeHead

IIndexableProbeHead - interface

Description

IIndexableProbeHead Interface

Methods

_internal_PutActiveTip | INTERNAL USE ONLY
_internal_PutProbeTool | INTERNAL USE ONLY
ComputeBestAngles | Calculate the best A and B angles to match the given vector, vector is supposed to be the stem direction from tip toward the shank
ComputeBestAnglesV | ( SCRIPT VERSION of ComputeBestAngles ) Calculate the best A and B angles to match the given vector, vector is supposed to be the stem direction from tip toward the shank
FillIdentityCard | fill the node with the identity card of this item
GetAngles | retrieve the current A and B angle of the physical indexable probe head
GetLocalDatumAtProbeMountingPoint | return the local matrix of the probe head mounting point for the specified angles
PutAngles | sets the A and B angles of the probe head, this function will returns after the physical angles have been set

Properties

_ID | R/W | INTERNAL USE ONLY
A | R/O | retrieve the A parameter, this parameter describes the valid range and increment for the A angle
ActiveTip | R/W | sets/retrieves the current active probe tip, setting the active probe tip may invoke a probe change and a move of the physical device
AHingeOffset | R/O | returns the offet of the A Hinge point relative to the origin of the probe head local datum( when A=0,B=0)
AnglesAreTrusted | R/O | Retrieves whether the current A,B angle can be trusted. Can be False for probe heads that do not return the actual value until it has been changed.
B | R/O | retrieve the B parameter, this parameter describes the valid range and increment for the B angle
Calibration | R/O | retrieves the calibration object
Carriage | R/O | returns the parent carriage
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
ManualOnly | R/W | Determines whether the probe head position can be driven by a protocol
Mounting | R/W | Mounting - returns the mounting type technology ( m8 , Autojoint etc...)
Position | R/O | retrieves the R/O Position object that describes the position and orientation of the probe head relative to the CMM Zero Point
ProbeHeadType | R/O | retrieves the type of this probehead, usufull to identify its technology / OBSOLETE USE TYPE
ProbeMountingPointDatum | R/O | returns the probe mounting point datum relative to the CMM Coordinates system and the CMMZero Point, when the probe head is at its original position ( i.e A=0,B=0 for an indexable probe head
ProbeTool | R/W | sets/retrieves the current probe tool which is physically mounted on the probe head
ProbeToolMountingPoint | R/O | returns the probe mounting point relative the probe head local datum ( which has its origin at the hinge point), this is the connection point of a Probe Tool mounted on the probed head
Protocol | R/W | sets/retrieves the actual protocol object that directly interact with the physical device
QuillMountingPoint | R/O | returns the probe head mounting point on the quill relative the probe head local datum ( which has its origin at the hinge point)
ReferenceProbeLength | R/W | sets/retrieves the reference probe length -> the length of the probe used to do the calibration of the head
RotationAxisA | R/O | retrieves the Rotation Axis Vector of the A angle when B=0, in CMM Coordinates
RotationAxisB | R/O | retrieves the Rotation Axis Vector of the B angle when A=0, in CMM Coordinates
ThreadID | R/O |
TrustInitialValues | R/W | retrieves/sets if the Indexable Probe Head could trust the A,B values returned by the protocol at connection time
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user
vector | R/O | retrieves the current orientation of the probe axis in CMM coordinates


IIndexableProbeHeadProtocol

IIndexableProbeHeadProtocol - interface

Description

IIndexableProbeHeadProtocol

Methods

AnglesAreTrusted | Ask if the current probe angles are correct
GetAngles | Get the current angular position of the probe
SetAngles | Move the probe to a new angular position


IIntermediateProbePathItem

IIntermediateProbePathItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILaserScannedCylinderItem

ILaserScannedCylinderItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxis | R/O |
FeatureCylinder | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBasePoint | R/O |
ParameterBoundary | R/O |
ParameterEvaluateWithNominal | R/O |
ParameterHeight | R/O |
PointCloud | R/O |
PropertyCylindricity | R/O |
PropertyDirection | R/O |
PropertyRadius | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILaserScannedSlotItem

ILaserScannedSlotItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureCentre | R/O |
FeatureCentre1 | R/O |
FeatureCentre2 | R/O |
FeatureMajorAxis | R/O |
FeatureMinorAxis | R/O |
FeatureNormalVector | R/O |
FeaturePlane | R/O |
FeatureRoundedSlot | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterEvaluateWithNominal | R/O |
ParameterExtrusion | R/O |
ParameterSearchDistance | R/O |
PointCloud | R/O |
PropertyCentre | R/O |
PropertyLength | R/O |
PropertyMajorAxis | R/O |
PropertyNormalVector | R/O |
PropertyProfile | R/O |
PropertyRadius | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_BissectorItem

ILine_BissectorItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyAngle | R/O |
PropertyDirection | R/O |
PropertyPoint | R/O |
ReferenceLine1 | R/O |
ReferenceLine2 | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_Inter2PlanesItem

ILine_Inter2PlanesItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyDirection | R/O |
ReferencePlane1 | R/O |
ReferencePlane2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_ParallelTroughPointItem

ILine_ParallelTroughPointItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterMaterialCondition | R/O |
PropertyDirection | R/O |
PropertyDistance | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_PerpendicularTroughPointItem

ILine_PerpendicularTroughPointItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterMaterialCondition | R/O |
PropertyDirection | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_PointVectorItem

ILine_PointVectorItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyDirection | R/O |
ReferencePoint | R/O |
ReferenceVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_ProbedItem

ILine_ProbedItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterCentroid | R/O |
ParameterGuidedMeasure | R/O |
ParameterLength | R/O |
ParameterMaterialSide | R/O |
ParameterOffset | R/O |
PropertyDirection | R/O |
PropertyLinearity | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_ProjectedOnPlaneItem

ILine_ProjectedOnPlaneItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyDirection | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_ThroughPointsItem

ILine_ThroughPointsItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyDirection | R/O |
PropertyDistance | R/O |
ReferencePoint1 | R/O |
ReferencePoint2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_WithAngleItem

ILine_WithAngleItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterAngle | R/O |
ParameterBoundary | R/O |
PropertyDirection | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ILine_WithOffsetPointItem

ILine_WithOffsetPointItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureLine | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterAlternateSolution | R/O |
ParameterBoundary | R/O |
ParameterCompositeOffsets | R/O |
PropertyDirection | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IMachineAxes

IMachineAxes - interface

Description

IMachineAxes Interface

Properties

AxisByAddress | R/O | Get the axis with the given address.
AxisByIndex | R/O | Get the axis at the given index.
Count | R/O | The number of axes.

Used in

Axes


AxisByAddress

AxisByAddress - Read property

Description

Get the axis with the given address.

Syntax in Visual Basic or VBScript

AxisByAddress (axis_address As String) As MachineAxis

Syntax in C++

HRESULT get_AxisByAddress (BSTR axis_address , MachineAxis* retVal)

Applies to

MachineAxes


AxisByIndex

AxisByIndex - Read property

Description

Get the axis at the given index.

Syntax in Visual Basic or VBScript

AxisByIndex (axis_index As Long) As MachineAxis

Syntax in C++

HRESULT get_AxisByIndex (LONG axis_index , MachineAxis* retVal)

Applies to

MachineAxes


Count

Count - Read property

Description

The number of axes.

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

MachineAxes


IMachineAxis

IMachineAxis - interface

Description

IMachineAxis Interface

Properties

Address | R/O | The address of this axis
Index | R/O | The index of this axis relative to the list of axes in the IMachineOrientationData parent.
MaxConstraint | R/W | The maximum axis value allowed.
MinConstraint | R/W | The minimum axis value allowed.
Parent | R/O | The parent IMachineOrientationData object.
UseAxisValue | R/W | Is the value for this axis valid?
UseConstraints | R/W | Are the constraints for this axis valid?
Value | R/W | The axis value.


Address

Address - Read property

Description

The address of this axis

Syntax in Visual Basic or VBScript

Address () As String

Syntax in C++

HRESULT get_Address (BSTR* retVal)

Applies to

MachineAxis


Index

Index - Read property

Description

The index of this axis relative to the list of axes in the IMachineOrientationData parent.

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)

Applies to

MachineAxis


MaxConstraint

MaxConstraint - Read & Write property

Description

The maximum axis value allowed.

Syntax in Visual Basic or VBScript

MaxConstraint () As Double

Syntax in C++

HRESULT get_MaxConstraint (double* retVal)
HRESULT put_MaxConstraint (double Value)

Applies to

MachineAxis


MinConstraint

MinConstraint - Read & Write property

Description

The minimum axis value allowed.

Syntax in Visual Basic or VBScript

MinConstraint () As Double

Syntax in C++

HRESULT get_MinConstraint (double* retVal)
HRESULT put_MinConstraint (double Value)

Applies to

MachineAxis


Parent

Parent - Read property

Description

The parent IMachineOrientationData object.

Syntax in Visual Basic or VBScript

Parent () As MachineOrientationData

Syntax in C++

HRESULT get_Parent (MachineOrientationData* retVal)

Applies to

MachineAxis


UseAxisValue

UseAxisValue - Read & Write property

Description

Is the value for this axis valid?

Syntax in Visual Basic or VBScript

UseAxisValue () As Boolean

Syntax in C++

HRESULT get_UseAxisValue (VARIANT_BOOL* retVal)
HRESULT put_UseAxisValue (VARIANT_BOOL Value)

Applies to

MachineAxis


UseConstraints

UseConstraints - Read & Write property

Description

Are the constraints for this axis valid?

Syntax in Visual Basic or VBScript

UseConstraints () As Boolean

Syntax in C++

HRESULT get_UseConstraints (VARIANT_BOOL* retVal)
HRESULT put_UseConstraints (VARIANT_BOOL Value)

Applies to

MachineAxis


Value

Value - Read & Write property

Description

The axis value.

Syntax in Visual Basic or VBScript

Value () As Double

Syntax in C++

HRESULT get_Value (double* retVal)
HRESULT put_Value (double Value)

Applies to

MachineAxis


IMachineOrientationData

IMachineOrientationData - interface

Description

IMachineOrientationData Interface

Methods

AddMachineAxisAndConstraints | Add a machine axis to the list of machine axes.
AddMachineAxisAndValue | Add a machine axis to the list of machine axes.
AddMachineAxisValueAndConstraints | Add a machine axis to the list of machine axes.
ClearAxisList | Clear the list of machine axes
CompareMachineOrientation | Is the machine transform in this machine-orientation the same as the one in the parameter.
Copy | Copy the parameter object data to this object.
TransformFrom | Apply the transformation to the machine-transform.
TransformTo | Apply the inverse transformation to the machine-transform.

Properties

HeadTransform | R/O | The transform that maps the machine datum onto the head datum (in world coordinates).
KinematicsMethod | R/W | The kinematic method that users of this object should use
MachineTransform | R/O | The transform that maps the table datum onto the head datum (in CAD or CMM probe-centre coordinates only).
MachineTransformCoordinateSystem | R/W | The coordinate system that the machine transform is in (CAD or CMM probe-centre coordinates only).
MTDMachineName | R/W | The machine name (from MTD file) used to create any forward kinematics.
RequiresLicence | R/O | Get whether a licence is required to use this object.
TableTransform | R/O | The transform that maps the machine datum onto the table datum (in world coordinates).

Collections

Axes The list of machine axes.


HeadTransform

HeadTransform - Read property

Description

The transform that maps the machine datum onto the head datum (in world coordinates).

Syntax in Visual Basic or VBScript

HeadTransform () As ITransform2

Syntax in C++

HRESULT get_HeadTransform (ITransform2* retVal)

Applies to

MachineOrientationData


KinematicsMethod

KinematicsMethod - Read & Write property

Description

The kinematic method that users of this object should use

Syntax in Visual Basic or VBScript

KinematicsMethod () As KinematicMethodType

Syntax in C++

HRESULT get_KinematicsMethod (KinematicMethodType* retVal)
HRESULT put_KinematicsMethod (KinematicMethodType Value)

Applies to

MachineOrientationData


MachineTransform

MachineTransform - Read property

Description

The transform that maps the table datum onto the head datum (in CAD or CMM probe-centre coordinates only).

Syntax in Visual Basic or VBScript

MachineTransform () As ITransform2

Syntax in C++

HRESULT get_MachineTransform (ITransform2* retVal)

Applies to

MachineOrientationData


MachineTransformCoordinateSystem

MachineTransformCoordinateSystem - Read & Write property

Description

The coordinate system that the machine transform is in (CAD or CMM probe-centre coordinates only).

Syntax in Visual Basic or VBScript

MachineTransformCoordinateSystem () As ProbePathType

Syntax in C++

HRESULT get_MachineTransformCoordinateSystem (ProbePathType* retVal)
HRESULT put_MachineTransformCoordinateSystem (ProbePathType Value)

Applies to

MachineOrientationData


MTDMachineName

MTDMachineName - Read & Write property

Description

The machine name (from MTD file) used to create any forward kinematics.

Syntax in Visual Basic or VBScript

MTDMachineName () As String

Syntax in C++

HRESULT get_MTDMachineName (BSTR* retVal)
HRESULT put_MTDMachineName (BSTR Value)

Applies to

MachineOrientationData


RequiresLicence

RequiresLicence - Read property

Description

Get whether a licence is required to use this object.

Syntax in Visual Basic or VBScript

RequiresLicence () As Boolean

Syntax in C++

HRESULT get_RequiresLicence (VARIANT_BOOL* retVal)

Applies to

MachineOrientationData


TableTransform

TableTransform - Read property

Description

The transform that maps the machine datum onto the table datum (in world coordinates).

Syntax in Visual Basic or VBScript

TableTransform () As ITransform2

Syntax in C++

HRESULT get_TableTransform (ITransform2* retVal)

Applies to

MachineOrientationData


AddMachineAxisAndConstraints

AddMachineAxisAndConstraints - event

Description

Add a machine axis to the list of machine axes.

Syntax in Visual Basic or VBScript

AddMachineAxisAndConstraints (Address As String , min_axis_value As Double , max_axis_value As Double) As MachineAxis

Syntax in C++

HRESULT AddMachineAxisAndConstraints (BSTR Address , double min_axis_value , double max_axis_value , MachineAxis* retVal)

Parameters

Name | Description
Address |
min_axis_value |
max_axis_value |
Return Value |

Applies to

MachineOrientationData


AddMachineAxisAndValue

AddMachineAxisAndValue - event

Description

Add a machine axis to the list of machine axes.

Syntax in Visual Basic or VBScript

AddMachineAxisAndValue (Address As String , Value As Double) As MachineAxis

Syntax in C++

HRESULT AddMachineAxisAndValue (BSTR Address , double Value , MachineAxis* retVal)

Parameters

Name | Description
Address |
Value |
Return Value |

Applies to

MachineOrientationData


AddMachineAxisValueAndConstraints

AddMachineAxisValueAndConstraints - event

Description

Add a machine axis to the list of machine axes.

Syntax in Visual Basic or VBScript

AddMachineAxisValueAndConstraints (Address As String , Value As Double , min_axis_value As Double , max_axis_value As Double) As MachineAxis

Syntax in C++

HRESULT AddMachineAxisValueAndConstraints (BSTR Address , double Value , double min_axis_value , double max_axis_value , MachineAxis* retVal)

Parameters

Name | Description
Address |
Value |
min_axis_value |
max_axis_value |
Return Value |

Applies to

MachineOrientationData


ClearAxisList

ClearAxisList - event

Description

Clear the list of machine axes

Syntax in Visual Basic or VBScript

ClearAxisList ()

Syntax in C++

HRESULT ClearAxisList ()

Applies to

MachineOrientationData


CompareMachineOrientation

CompareMachineOrientation - event

Description

Is the machine transform in this machine-orientation the same as the one in the parameter.

Syntax in Visual Basic or VBScript

CompareMachineOrientation (ByRef machine_orientation As MachineOrientationData) As Boolean

Syntax in C++

HRESULT CompareMachineOrientation (MachineOrientationData* machine_orientation , VARIANT_BOOL* retVal)

Parameters

Name | Description
machine_orientation |
Return Value |

Applies to

MachineOrientationData


Copy

Copy - event

Description

Copy the parameter object data to this object.

Syntax in Visual Basic or VBScript

Copy (ByRef machine_orientation As MachineOrientationData)

Syntax in C++

HRESULT Copy (MachineOrientationData* machine_orientation)

Parameters

Name | Description
machine_orientation |

Applies to

MachineOrientationData


TransformFrom

TransformFrom - event

Description

Apply the transformation to the machine-transform.

Syntax in Visual Basic or VBScript

TransformFrom (ByRef transform As ITransform2)

Syntax in C++

HRESULT TransformFrom (ITransform2* transform)

Parameters

Name | Description
transform |

Applies to

MachineOrientationData


TransformTo

TransformTo - event

Description

Apply the inverse transformation to the machine-transform.

Syntax in Visual Basic or VBScript

TransformTo (ByRef transform As ITransform2)

Syntax in C++

HRESULT TransformTo (ITransform2* transform)

Parameters

Name | Description
transform |

Applies to

MachineOrientationData


IManualProbeHead

IManualProbeHead - interface

Description

IManualProbeHead Interface

Methods

_internal_PutActiveTip | INTERNAL USE ONLY
_internal_PutProbeTool | INTERNAL USE ONLY
FillIdentityCard | fill the node with the identity card of this item
SetProbeHeadType | explicitly set the type of this probehead, usufull to identify its technology

Properties

_ID | R/W | INTERNAL USE ONLY
ActiveTip | R/W | sets/retrieves the current active probe tip, setting the active probe tip may invoke a probe change and a move of the physical device
Calibration | R/O | retrieves the calibration object
Carriage | R/O | returns the parent carriage
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
Mounting | R/W | Mounting - returns the mounting type technology ( m8 , Autojoint etc...)
Position | R/O | retrieves the R/O Position object that describes the position and orientation of the probe head relative to the CMM Zero Point
ProbeHeadType | R/O | retrieves the type of this probehead, usufull to identify its technology / OBSOLETE USE TYPE
ProbeMountingPointDatum | R/O | returns the probe mounting point datum relative to the CMM Coordinates system and the CMMZero Point, when the probe head is at its original position ( i.e A=0,B=0 for an indexable probe head
ProbeTool | R/W | sets/retrieves the current probe tool which is physically mounted on the probe head
ProbeToolMountingPoint | R/O | returns the probe mounting point relative the probe head local datum ( which has its origin at the hinge point), this is the connection point of a Probe Tool mounted on the probed head
QuillMountingPoint | R/O | returns the probe head mounting point on the quill relative the probe head local datum ( which has its origin at the hinge point)
ReferenceProbeLength | R/W | sets/retrieves the reference probe length -> the length of the probe used to do the calibration of the head
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user


IMathToolbox

IMathToolbox - interface

Description

IMathToolbox Interface

Methods

AngleVector | method AngleVector
Circle3Points | calculate the center,normale and radius of a circle through the 3 given points
CrossProduct | method CrossProduct : a and b can be either IVector3D or IUnitVector3D and the result will be a Vector3D
Distance | method Distance Calculates the distance between 2 points : a and b can be either IPoint3D
DotProduct | method DotProduct

Properties

Inverse | R/O | method InverseMatrix
MultiplyTransform | R/O | multiply 2 matrix


IMeas_3DAngle2VectorsItem

IMeas_3DAngle2VectorsItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyAngle | R/O |
ReferenceDirection1 | R/O |
ReferenceDirection2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IMeas_3DAnglePlaneLineItem

IMeas_3DAnglePlaneLineItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyAngle | R/O |
ReferenceDirection | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IMeas_Angle2LinesItem

IMeas_Angle2LinesItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyAngle | R/O |
ReferenceLine1 | R/O |
ReferenceLine2 | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IMeas_Angle2PlanesItem

IMeas_Angle2PlanesItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyAngle | R/O |
ReferencePlane1 | R/O |
ReferencePlane2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IMeas_Distance2PointsItem

IMeas_Distance2PointsItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyDistance | R/O |
ReferencePoint1 | R/O |
ReferencePoint2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IMeas_DistancePointLineItem

IMeas_DistancePointLineItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyDistance | R/O |
ReferenceLine | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IMeas_DistancePointPlaneItem

IMeas_DistancePointPlaneItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyDistance | R/O |
ReferencePlane | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IMeas_RelativePositionItem

IMeas_RelativePositionItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links2 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyLocation | R/O |
PropertyRelativePosition | R/O |
ReferencePoint1 | R/O |
ReferencePoint2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IMeasure

IMeasure - interface

Description

IMeasure Interface

Methods

Delete | Delete this measure from the document
ImportMeasuredData | Copies measured data from amother measure, transforming it between the two alignments.
Invalidate | Invalidate all items to a unmeasured state for this particular measure

Properties

ActivePositioningMatrix | R/O | property ActivePositioningMatrix
Document | R/O | returns the associated document for this item
IsBuiltIn | R/O | returns whether the measure is a built-in measure - these cannot be deleted
IsSimulated | R/O | returns whether the measure is the automatic simulated measure
MeasureState | R/O | returns the measurement state
Name | R/W | Set/retrieve the name of the Measure object
UniqueID | R/O | returns a unique Identifier (ID) of this Item, this ID is unique within the same document and never changed during the timelife of the SequenceItem

Collections

ReportVariables property ReportVariables


IMeasures

IMeasures - interface

Description

IMeasures Interface

Methods

Add | add a new measure to the collection
Delete | method Delete the specifyed measure from the collection
DeleteAll | method Delete all measures from the collection

Properties

Count | R/O | returns the number of items in the collection.
Item | R/O | allows random access to individual measure within the collection. Index can be an ordinal from 1 to Count or a string

Used in

Measures


IMeasureStatistics

IMeasureStatistics - interface

Description

IMeasureStatistics Interface

Methods

Refresh | Make sure the statistic are up-to-date and refresh them eventually
RetrieveCount | Retrieve the number of entities between the ]low,high] range

Properties

AboveToleranceCount | R/O | retrieve the number of points above the higher tolerance bound
BelowToleranceCount | R/O | retrieve the number of points below the lower tolerance bound
FailureCount | R/O | retrieve the number of failures
LowerTolerance | R/W | retrieve the Lower Tolerance
MaximumValue | R/O | returns maximum value in the serie
MeanError | R/O | retrieve the mean of error
measure | R/O |
MinimumValue | R/O | returns minimum value in the serie
Parent | R/O |
StandardDeviation | R/O | retrieve the Standard Deviation
UpperTolerance | R/W | retrieve the Upper Tolerance
ValueCount | R/O | get the total number of items
WithinToleranceCount | R/O | retrieve the number of points within the tolerance bounds


AboveToleranceCount

AboveToleranceCount - Read property

Description

retrieve the number of points above the higher tolerance bound

Syntax in Visual Basic or VBScript

AboveToleranceCount () As Long

Syntax in C++

HRESULT get_AboveToleranceCount (LONG* retVal)

Applies to

IMeasureStatistics


BelowToleranceCount

BelowToleranceCount - Read property

Description

retrieve the number of points below the lower tolerance bound

Syntax in Visual Basic or VBScript

BelowToleranceCount () As Long

Syntax in C++

HRESULT get_BelowToleranceCount (LONG* retVal)

Applies to

IMeasureStatistics


FailureCount

FailureCount - Read property

Description

retrieve the number of failures

Syntax in Visual Basic or VBScript

FailureCount () As Long

Syntax in C++

HRESULT get_FailureCount (LONG* retVal)

Applies to

IMeasureStatistics


LowerTolerance

LowerTolerance - Read & Write property

Description

retrieve the Lower Tolerance

Syntax in Visual Basic or VBScript

LowerTolerance () As Double

Syntax in C++

HRESULT get_LowerTolerance (double* retVal)
HRESULT put_LowerTolerance (double Value)

Applies to

IMeasureStatistics


MaximumValue

MaximumValue - Read property

Description

returns maximum value in the serie

Syntax in Visual Basic or VBScript

MaximumValue () As Double

Syntax in C++

HRESULT get_MaximumValue (double* retVal)

Applies to

IMeasureStatistics


MeanError

MeanError - Read property

Description

retrieve the mean of error

Syntax in Visual Basic or VBScript

MeanError () As Double

Syntax in C++

HRESULT get_MeanError (double* retVal)

Applies to

IMeasureStatistics


MinimumValue

MinimumValue - Read property

Description

returns minimum value in the serie

Syntax in Visual Basic or VBScript

MinimumValue () As Double

Syntax in C++

HRESULT get_MinimumValue (double* retVal)

Applies to

IMeasureStatistics


Parent

Parent - Read property

Syntax in Visual Basic or VBScript

Parent () As PDBDefinition

Syntax in C++

HRESULT get_Parent (PDBDefinition* retVal)

Applies to

IMeasureStatistics
PDBDefinition


UpperTolerance

UpperTolerance - Read & Write property

Description

retrieve the Upper Tolerance

Syntax in Visual Basic or VBScript

UpperTolerance () As Double

Syntax in C++

HRESULT get_UpperTolerance (double* retVal)
HRESULT put_UpperTolerance (double Value)

Applies to

IMeasureStatistics


ValueCount

ValueCount - Read property

Description

get the total number of items

Syntax in Visual Basic or VBScript

ValueCount () As Long

Syntax in C++

HRESULT get_ValueCount (LONG* retVal)

Applies to

IMeasureStatistics


WithinToleranceCount

WithinToleranceCount - Read property

Description

retrieve the number of points within the tolerance bounds

Syntax in Visual Basic or VBScript

WithinToleranceCount () As Long

Syntax in C++

HRESULT get_WithinToleranceCount (LONG* retVal)

Applies to

IMeasureStatistics


Refresh

Refresh - method

Description

Make sure the statistic are up-to-date and refresh them eventually

Syntax in Visual Basic or VBScript

Refresh ()

Syntax in C++

HRESULT Refresh ()

Applies to

IMeasureStatistics


RetrieveCount

RetrieveCount - method

Description

Retrieve the number of entities between the ]low,high] range

Syntax in Visual Basic or VBScript

RetrieveCount (low As Double , high As Double) As Long

Syntax in C++

HRESULT RetrieveCount (double low , double high , LONG* retVal)

Parameters

Name | Description
low |
high |
Return Value |

Applies to

IMeasureStatistics


IMultiaxisConfigurationItem

IMultiaxisConfigurationItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


INominalPointItem

INominalPointItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterPoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


INominalVectorItem

INominalVectorItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureVector | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IObjectPool

IObjectPool - interface

Description

IObjectPool Interface

Methods

Add

Properties

Count | R/W | property Count
Item | R/O |


IOffsetPoint

IOffsetPoint - interface

Description

IOffsetPoint Interface

Properties

CompositeOffsetType | R/W | return the type of point
Link | R/O | get the link or NULL if the type is not appropriate
Name | R/W | property Name
Offset | R/W | return the offset


IOffsetPoints

IOffsetPoints - interface

Description

IOffsetPoints Interface

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual offsetPoint within the collection. Index can be an ordinal from 1 to Count or a string

Used in

Offsets


IOMVExporter

IOMVExporter - interface

Description

IOMVExporter Interface

Methods

ExportXMLCutFile | method ExportXMLCutFile
ExportXMLProbePath | method ExportXMLProbePath

Properties

Document | R/W | property PowerINSPECT Document
OutputPointType | R/W | Set/Get the output point for the probe path
OutputTransform | R/W | The transformation that will be applied to all output coordinates
OutputWorkplane | R/W | The output workplane
PartName | R/W | Set/Get the part name for the outputted path
ToolNumber | R/W | Set/Get the tool number for the outputted path
WorkpieceCoordSystemNumber | R/W | Set/Get the Workpiece coordinate system number


IOMVIItem

IOMVIItem - interface

Description

IOMVIItem Interface

Properties

IsCompleted | R/W | Returns TRUE if the item has all points for PowerINSPECT sequence item or the last portion of points. FALSE otherwise.
RichInfo | R/O |

Collections

ContactPoints


IOMVIItemRichInfo

IOMVIItemRichInfo - interface

Description

IOMVIItemRichInfo Interface

Properties

ItemID | R/O
ItemType | R/O


ItemID

ItemID - Read property

Syntax in Visual Basic or VBScript

ItemID () As Long

Syntax in C++

HRESULT get_ItemID (LONG* retVal)

Applies to

IOMVIItemRichInfo


ItemType

ItemType - Read property

Syntax in Visual Basic or VBScript

ItemType () As Long

Syntax in C++

HRESULT get_ItemType (LONG* retVal)

Applies to

IOMVIItemRichInfo


IOMVIItemSequentialStream

IOMVIItemSequentialStream - interface

Description

IOMVIItemSequentialStream Interface

Methods

Close | Informs the stream that it may release all the resources.
Initialize | Informs the stream that it needs to take any initialization action.
Read | Provides the current item object, the Stream Status must be READY in order this method to succeed.

Properties

Status R/O returns the current status of the stream


IOMVImportCtrl

IOMVImportCtrl - interface

Description

IOMVImportCtrl Interface

Methods

ClearMessageArea Removes all the messages from the info area

Properties

Appearance | R/W |
AutoSize | R/W |
Enabled | R/W |
Header | R/W | Set/Get the text of the control header
HelperSource | R/W | property HelperSource
ImportEnabled | R/W | Allows to enable/disable the import controls
Importer | R/O | property Importer
InputSource | R/W | property InputSource
PowerInspect | R/W | property PowerInspect
Reader | R/W | property Reader
TabStop | R/W |


IOMVImporter

IOMVImporter - interface

Description

IOMVImporter Interface

Methods

CreateScriptReader | Helps to create and properly initialiaze a script reader
GoStep | method GoStep
Run | method Run
Stop | method Stop
Suspend | method Suspend
Validate | Validates the sequence tree of the document against the given helper source (CXM file)
ValidationResult | Returns the problems found during the last validation

Properties

Busy | R/O | property Busy
cursor | R/O | property Cursor
Document | R/W | property Document
HelperInfoSource | R/W | property HelperInfoSource
measure | R/W | property Measure
NumberOfSteps | R/O | property NumberOfSteps
Reader | R/W | property Reader
Status | R/O | property Status


IOMVIReader

IOMVIReader - interface

Description

IOMVIReader Interface

Methods

Configure | The method is called when a user wants to configure the reader.
Parse | method Parse

Properties

Configurable | R/O | Allows to check if this reader is configuirable
ControlsEndOfItem | R/O | method ControlsEndOfItem
Parameters | W/O | Allows to provide an object to the reader where it can save its own data
PromptForStart | R/W | Informs if a user should be prompted for start
ProvidesApproachVector | R/O |
ProvidesProbeDiameter | R/O | Return VARIANT_TRUE if the reader is able to provide probe diameter for items, VARIANT_FALSE otherwise.
Source | R/W |
Stream | R/O | items stream


IOMVIScriptReader

IOMVIScriptReader - interface

Description

IOMVIScriptReader Interface

Methods

Configure | The method is called when a user wants to configure the reader.
Parse | method Parse

Properties

Configurable | R/O | Allows to check if this reader is configuirable
ControlsEndOfItem | R/O | method ControlsEndOfItem
InputFile | R/W | property InputFile
LastScriptError | R/O | Returns a description of the last error found in a script
NeedsInputFile | R/W | property NeedsInputFile
Parameters | W/O | Allows to provide an object to the reader where it can save its own data
PromptForStart | R/W | Informs if a user should be prompted for start
ProvidesApproachVector | R/O |
ProvidesProbeDiameter | R/O | Return VARIANT_TRUE if the reader is able to provide probe diameter for items, VARIANT_FALSE otherwise.
Source | R/W |
Stream | R/O | items stream


IOMVScriptReaderBridge

IOMVScriptReaderBridge - interface

Description

IOMVScriptReaderBridge Interface

Properties

ControlsEndOfItem | R/W | property ControlsEndOfItem
NeedsInputFile | R/W | property NeedsInputFile
Parameters | R/O | Provides an object to the reader where it can save its own data
PromptForStart | R/W | Informs if a user should be prompted for start
ProvidesApproachVector | R/W | property ProvidesApproachVector
ProvidesProbeDiameter | R/W | property ProvidesProbeDiameter
ScriptReaderPath | R/O | Provides the path of the current reader script


IParameter

IParameter - interface

Description

IParameter Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameter1

IParameter1 - interface

Description

IParameter1 Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterAngleQuadrant

IParameterAngleQuadrant - interface

Description

IParameterAngleQuadrant Interface

Methods

NormaliseAngles | normalize the 2 angles : will make sure that startAngle < endAngle and that the 2 angles are in the proper range
NormaliseAnglesV | normalize the 2 angles ( SCRIPTABLE version of NormaliseAngles ) : will make sure that startAngle < endAngle and that the 2 angles are in the proper range
PutAngles | Put both angles at the same time

Properties

Description | R/O | return a description of the parameter in the current locale language
EndAngle | R/W | sets/retrieves the end angle in degree
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
StartAngle | R/W | sets/retrieves the start angle in degree
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterBoundary

IParameterBoundary - interface

Description

IParameterBoundary Interface

Methods

Evaluate Evaluate the boundary of a entity

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
LimitInX | R/W | set/retrieve if the boundary limits along the X direction
LimitInY | R/W | set/retrieve if the boundary limits along the Y direction
LimitInZ | R/W | set/retrieve if the boundary limits along the Z direction
MaxPoint | R/O | the max point of the boundary box
MinPoint | R/O | the min point of the boundary box
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterCompensationMethod

IParameterCompensationMethod - interface

Description

IParameterCompensationMethod Interface

Methods

SetDirection sets the compensation direction, the Compensation Method will be updated accordingly, Dir could be a IFeature, a Vector or an empty variant

Properties

CompensationDir | R/O | get the compensation Direction. only valid when PWI_ProbeCompenstionMethod = pcm_ALONG_A_EXPLICIT_DIRECTION
CompensationMethod | R/W | sets/retrieves the CompensationMethod type
Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Link | R/O | gets the link. only valid when PWI_ProbeCompenstionMethod = pcm_ALONG_A_EXISITING_DIRECTION
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterCompositeOffset

IParameterCompositeOffset - interface

Description

IParameterVector3D Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT

Collections

Offsets |
PossibleFeatures | property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


IParameterDirection

IParameterDirection - interface

Description

IParameterDirection Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Direction | R/W |
Index | R/O | returns the index of this property in its parent collection
LocalisedValue | R/O | Returns value as localised string.
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterEnum

IParameterEnum - interface

Description

IParameterEnum Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
LocalisedValue | R/O | Returns value as localised string.
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterGuidedMeasure

IParameterGuidedMeasure - interface

Description

IParameterGuidedMeasure Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
UseGuidedMeasure | R/W |
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterMainPlane

IParameterMainPlane - interface

Description

IParameterMainPlane Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
LocalisedValue | R/O | Returns value as localised string.
MainPlane | R/W |
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterMaterialCondition

IParameterMaterialCondition - interface

Description

IParameterMaterialCondition Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
LocalisedValue | R/O | Returns value as localised string.
MaterialCondition | R/W |
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterMaterialSide

IParameterMaterialSide - interface

Description

IParameterMaterialSide Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
LocalisedValue | R/O | Returns value as localised string.
MaterialSide | R/W |
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterMatrixDefinition

IParameterMatrixDefinition - interface

Description

IParameterMatrixDefinition Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
matrix | R/O | Return a pointer to the internal matrix definition object.
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterPoint3D

IParameterPoint3D - interface

Description

IParameterPoint3D Interface

Methods

GetCoordinate | retrieve the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)
SetCoordinates | set the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)

Properties

CoordinateType | R/O | Prefered coordinate type
Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
point | R/W | retrieve the point
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterPoint3DEx

IParameterPoint3DEx - interface

Description

IParameterPoint3DEx Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
ExplicitDefinition | R/O |
ImplicitDefinition | R/O |
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
type | R/W |
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameterReportSettings

IParameterReportSettings - interface

Description

IParameterReportSettings Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT
xml | R/W | Get/Set an report configuration for an item. Must be well-formed XML.


IParameterRPSConstraints

IParameterRPSConstraints - interface

Description

IParameterRPSConstraints Interface

Methods

Add | add a new constraint
Delete | add a new constraint

Properties

Count | R/W | Indicates the number of items in the collection.
Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Item | R/O | Allows random access to individual parameter within the collection. Index can be an ordinal from 1 to Count or a string
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT


IParameters

IParameters - interface

Description

IParameters Interface

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual parameter within the collection. Index can be an ordinal from 1 to Count or a string

Used in

Parameters


IParameterVector3D

IParameterVector3D - interface

Description

IParameterVector3D Interface

Methods

GetCoordinate | retrieve the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)
SetCoordinates | set the values of the point in accordance with the current coordinate system (Cartesian,Polar,Spherical)

Properties

CoordinateType | R/O | Prefered coordinate system
Description | R/O | return a description of the parameter in the current locale language
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
Value | R/W | retrieve the value of the parameter as a VARIANT
vector | R/W | retrieve the coordinates of the point


IParameterVector3DEx

IParameterVector3DEx - interface

Description

IParameterVector3DEx Interface

Properties

Description | R/O | return a description of the parameter in the current locale language
ExplicitDefinition | R/O |
ImplicitDefinition | R/O |
Index | R/O | returns the index of this property in its parent collection
Name | R/O | retrieve the name of the parameter
ParameterType | R/O | return the Type of the parameter
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the parameter cannot be modified
type | R/W |
Value | R/W | retrieve the value of the parameter as a VARIANT


IPCSDatumItem

IPCSDatumItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPDBDefinition

IPDBDefinition - interface

Description

IPDBDefinition Interface

Methods

Attribute |
GetPropertyDouble | extract a double property from the PDBdefinition
GetPropertyString | extract a string property from the PDBdefinition
Initialize |
Node | depreciated - do not use
Property |

Properties

Class | R/O
id | R/O
Name | R/W
Parent | R/O
Tag | R/O
Value | R/W


Class

Class - Read property

Syntax in Visual Basic or VBScript

Class () As TKIND_RECORD

Syntax in C++

HRESULT get_Class (TKIND_RECORD* retVal)

Applies to

PDBDefinition


id

id - Read property

Syntax in Visual Basic or VBScript

id () As TKIND_RECORD

Syntax in C++

HRESULT get_id (TKIND_RECORD* retVal)

Applies to

PDBDefinition


Tag

Tag - Read property

Syntax in Visual Basic or VBScript

Tag () As String

Syntax in C++

HRESULT get_Tag (BSTR* retVal)

Applies to

PDBDefinition


Attribute

Attribute - method

Syntax in Visual Basic or VBScript

Attribute (str As String) As Variant

Syntax in C++

HRESULT Attribute (BSTR str , VARIANT* retVal)

Parameters

Name | Description
str |
Return Value |

Applies to

PDBDefinition


GetPropertyDouble

GetPropertyDouble - method

Description

extract a double property from the PDBdefinition

Syntax in Visual Basic or VBScript

GetPropertyDouble (str As String) As Double

Syntax in C++

HRESULT GetPropertyDouble (BSTR str , double* retVal)

Parameters

Name | Description
str |
Return Value |

Applies to

PDBDefinition


GetPropertyString

GetPropertyString - method

Description

extract a string property from the PDBdefinition

Syntax in Visual Basic or VBScript

GetPropertyString (str As String) As String

Syntax in C++

HRESULT GetPropertyString (BSTR str , BSTR* retVal)

Parameters

Name | Description
str |
Return Value |

Applies to

PDBDefinition


Initialize

Initialize - method

Syntax in Visual Basic or VBScript

Initialize (idCard As String)

Syntax in C++

HRESULT Initialize (BSTR idCard)

Parameters

Name | Description
idCard |

Applies to

PDBDefinition


Node

Node - method

Description

depreciated - do not use

Syntax in Visual Basic or VBScript

Node (str As String) As PDBDefinition

Syntax in C++

HRESULT Node (BSTR str , PDBDefinition* retVal)

Parameters

Name | Description
str |
Return Value |

Applies to

PDBDefinition


Property

Property - method

Syntax in Visual Basic or VBScript

Property (str As String) As Variant

Syntax in C++

HRESULT Property (BSTR str , VARIANT* retVal)

Parameters

Name | Description
str |
Return Value |

Applies to

PDBDefinition


IPlane_BissectorItem

IPlane_BissectorItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyNormalVector | R/O |
ReferencePlane1 | R/O |
ReferencePlane2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPlane_LinePointItem

IPlane_LinePointItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyNormalVector | R/O |
ReferenceLine | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPlane_LineVectorItem

IPlane_LineVectorItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
PropertyNormalVector | R/O |
ReferenceLine | R/O |
ReferenceVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPlane_OffsetDistanceItem

IPlane_OffsetDistanceItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterDistance | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPlane_ParallelThroughPointItem

IPlane_ParallelThroughPointItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterMaterialCondition | R/O |
PropertyDistance | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPlane_PointVectorItem

IPlane_PointVectorItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ReferencePoint | R/O |
ReferenceVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPlane_ProbedItem

IPlane_ProbedItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterBoundary | R/O |
ParameterPoint | R/O |
PropertyNormalVector | R/O |
PropertyPlanarity | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPlane_WithOffsetPointsItem

IPlane_WithOffsetPointsItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePlane | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterAlternateSolution | R/O |
ParameterBoundary | R/O |
ParameterCompositeOffsets | R/O |
PropertyNormalVector | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint_FeatureIntersectionItem

IPoint_FeatureIntersectionItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterUseUnboundedEntities | R/O |
PropertyPoint | R/O |
ReferenceFeature | R/O |
ReferenceFeature2D | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint_Inter2Lines3DItem

IPoint_Inter2Lines3DItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferenceLine1 | R/O |
ReferenceLine2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint_Inter2LinesProjectedItem

IPoint_Inter2LinesProjectedItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferenceLine1 | R/O |
ReferenceLine2 | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint_Inter3PlanesItem

IPoint_Inter3PlanesItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferencePlane1 | R/O |
ReferencePlane2 | R/O |
ReferencePlane3 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint_InterPlaneLineItem

IPoint_InterPlaneLineItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferenceLine | R/O |
ReferencePlane | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint_MiddleItem

IPoint_MiddleItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferencePoint1 | R/O |
ReferencePoint2 | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint_ProjectedOnLineItem

IPoint_ProjectedOnLineItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferenceLine | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint_ProjectedOnPlaneItem

IPoint_ProjectedOnPlaneItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Links3 | R/O |
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PropertyPoint | R/O |
ReferencePlane | R/O |
ReferencePoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint_RetracePointItem

IPoint_RetracePointItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeaturePoint | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntity | R/W |
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ParameterCompensationMethod | R/O |
PropertyDistanceOnPlane | R/O |
PropertyDistanceToTarget | R/O |
PropertyDistanceToTargetPlane | R/O |
PropertyTargetPoint | R/O |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IPoint3D

IPoint3D - interface

Description

IPoint3D Interface

Methods

GetCoordinates | retreives the 3 coordinates ( cartesian ) in one round trip ( this version is not scriptable )
GetCoordinatesV | retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )
SetCoordinates | set the XYZ coordinates of the point
SetPolarCoordinates | set the Polar coordinates (Angle,Radius,Height) of the point
SetSphericalCoordinates | set the Spherical coordinates (Azimuth,Elevation,Magnitude) of the point
TransformFrom | Transformation of point
TransformTo | Transformation of point

Properties

Angle | R/W | get the Angle of the point ( First Polar Coordinate)
Azimuth | R/W | get the Azimuth of the point ( First Spherical Coordinate)
Elevation | R/W | get the Elevation of the point ( Second Spherical Coordinate)
Height | R/W | get the Height of the point ( Third Polar Coordinate)
Magnitude | R/W | get the Magnitude of the point ( Third Spherical Coordinate)
Radius | R/W | get the Radius of the point ( Second Polar Coordinate)
Value | R/W |
X | R/W | get the X coordinate of the point
Y | R/W | get the Y coordinate of the point
Z | R/W | get the Z coordinate of the point


Angle

Angle - Read & Write property

Description

get the Angle of the point ( First Polar Coordinate)

Syntax in Visual Basic or VBScript

Angle () As Double

Syntax in C++

HRESULT get_Angle (double* retVal)
HRESULT put_Angle (double Value)

Applies to

Point3D


Azimuth

Azimuth - Read & Write property

Description

get the Azimuth of the point ( First Spherical Coordinate)

Syntax in Visual Basic or VBScript

Azimuth () As Double

Syntax in C++

HRESULT get_Azimuth (double* retVal)
HRESULT put_Azimuth (double Value)

Applies to

Point3D


Elevation

Elevation - Read & Write property

Description

get the Elevation of the point ( Second Spherical Coordinate)

Syntax in Visual Basic or VBScript

Elevation () As Double

Syntax in C++

HRESULT get_Elevation (double* retVal)
HRESULT put_Elevation (double Value)

Applies to

Point3D


Height

Height - Read & Write property

Description

get the Height of the point ( Third Polar Coordinate)

Syntax in Visual Basic or VBScript

Height () As Double

Syntax in C++

HRESULT get_Height (double* retVal)
HRESULT put_Height (double Value)

Applies to

Point3D


Magnitude

Magnitude - Read & Write property

Description

get the Magnitude of the point ( Third Spherical Coordinate)

Syntax in Visual Basic or VBScript

Magnitude () As Double

Syntax in C++

HRESULT get_Magnitude (double* retVal)
HRESULT put_Magnitude (double Value)

Applies to

Point3D


Radius

Radius - Read & Write property

Description

get the Radius of the point ( Second Polar Coordinate)

Syntax in Visual Basic or VBScript

Radius () As Double

Syntax in C++

HRESULT get_Radius (double* retVal)
HRESULT put_Radius (double Value)

Applies to

Point3D


X

X - Read & Write property

Description

get the X coordinate of the point

Syntax in Visual Basic or VBScript

X () As Double

Syntax in C++

HRESULT get_X (double* retVal)
HRESULT put_X (double Value)

Applies to

Point3D


Y

Y - Read & Write property

Description

get the Y coordinate of the point

Syntax in Visual Basic or VBScript

Y () As Double

Syntax in C++

HRESULT get_Y (double* retVal)
HRESULT put_Y (double Value)

Applies to

Point3D


Z

Z - Read & Write property

Description

get the Z coordinate of the point

Syntax in Visual Basic or VBScript

Z () As Double

Syntax in C++

HRESULT get_Z (double* retVal)
HRESULT put_Z (double Value)

Applies to

Point3D


GetCoordinates

GetCoordinates - method

Description

retreives the 3 coordinates ( cartesian ) in one round trip ( this version is not scriptable )

Syntax in Visual Basic or VBScript

GetCoordinates (ByRef pX As Double , ByRef pY As Double , ByRef pZ As Double)

Syntax in C++

HRESULT GetCoordinates (double* pX , double* pY , double* pZ)

Parameters

Name | Description
pX |
pY |
pZ |

Applies to

Point3D


GetCoordinatesV

GetCoordinatesV - method

Description

retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )

Syntax in Visual Basic or VBScript

GetCoordinatesV (ByRef pX As Variant , ByRef pY As Variant , ByRef pZ As Variant)

Syntax in C++

HRESULT GetCoordinatesV (VARIANT* pX , VARIANT* pY , VARIANT* pZ)

Parameters

Name | Description
pX |
pY |
pZ |

Applies to

Point3D


SetCoordinates

SetCoordinates - method

Description

set the XYZ coordinates of the point

Syntax in Visual Basic or VBScript

SetCoordinates (X As Double , Y As Double , Z As Double)

Syntax in C++

HRESULT SetCoordinates (double X , double Y , double Z)

Parameters

Name | Description
X |
Y |
Z |

Applies to

Point3D


SetPolarCoordinates

SetPolarCoordinates - method

Description

set the Polar coordinates (Angle,Radius,Height) of the point

Syntax in Visual Basic or VBScript

SetPolarCoordinates (Angle As Double , Radius As Double , Height As Double)

Syntax in C++

HRESULT SetPolarCoordinates (double Angle , double Radius , double Height)

Parameters

Name | Description
Angle |
Radius |
Height |

Applies to

Point3D


SetSphericalCoordinates

SetSphericalCoordinates - method

Description

set the Spherical coordinates (Azimuth,Elevation,Magnitude) of the point

Syntax in Visual Basic or VBScript

SetSphericalCoordinates (Azimuth As Double , Elevation As Double , Magnitude As Double)

Syntax in C++

HRESULT SetSphericalCoordinates (double Azimuth , double Elevation , double Magnitude)

Parameters

Name | Description
Azimuth |
Elevation |
Magnitude |

Applies to

Point3D


TransformFrom

TransformFrom - method

Description

Transformation of point

Syntax in Visual Basic or VBScript

TransformFrom (ByRef transform As transform)

Syntax in C++

HRESULT TransformFrom (transform* transform)

Parameters

Name | Description
transform |

Applies to

Point3D


TransformTo

TransformTo - method

Description

Transformation of point

Syntax in Visual Basic or VBScript

TransformTo (ByRef transform As transform)

Syntax in C++

HRESULT TransformTo (transform* transform)

Parameters

Name | Description
transform |

Applies to

Point3D


IPointCloud

IPointCloud - interface

Description

IPointCloud Interface

Methods

AddPointXYZ | method AddPointXYZ
AddPointXYZIJK | method AddPointXYZIJK
Import | method Import
Scale | method Scale : scale the point cloud
UnsetProjectionData | method UnsetProjectionData

Properties

Count | R/O | property Count: returns the number of point in the point cloud
Deviation | R/W | property Deviation
Diameter | R/W | property Diameter : set/retrieve the associated probe diameter
HasProjectedInfo | R/O | property HasProjectedInfo: returns TRUE if this objects contains some information about deviation associated with the points
HasValidIJK | R/O | property HasValidIJK: returns true if the point cloud contains valid IJK vectors in its original set
HasValidProjection | R/O | property HasValidProjection
Item | R/O | property Item
MaximumDeviation | R/O | property MaximumDeviation
MaxPoint | R/O | property MaxPoint
MinimumDeviation | R/O | property MinimumDeviation
MinPoint | R/O | property MinPoint
Offset | R/W | property Offset
ScanlineCount | R/O | property ScanlineCount


Count

Count - Read property

Description

property Count: returns the number of point in the point cloud

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

PointCloud


Deviation

Deviation - Read & Write property

Description

property Deviation

Syntax in Visual Basic or VBScript

Deviation (nIndex As Long) As Double

Syntax in C++

HRESULT get_Deviation (LONG nIndex , double* retVal)
HRESULT put_Deviation (double Value)

Applies to

PointCloud
PointCloudPoint


Diameter

Diameter - Read & Write property

Description

property Diameter : set/retrieve the associated probe diameter

Syntax in Visual Basic or VBScript

Diameter () As Double

Syntax in C++

HRESULT get_Diameter (double* retVal)
HRESULT put_Diameter (double Value)

Applies to

PointCloud


HasProjectedInfo

HasProjectedInfo - Read property

Description

property HasProjectedInfo: returns TRUE if this objects contains some information about deviation associated with the points

Syntax in Visual Basic or VBScript

HasProjectedInfo () As Boolean

Syntax in C++

HRESULT get_HasProjectedInfo (VARIANT_BOOL* retVal)

Applies to

PointCloud


HasValidIJK

HasValidIJK - Read property

Description

property HasValidIJK: returns true if the point cloud contains valid IJK vectors in its original set

Syntax in Visual Basic or VBScript

HasValidIJK () As Boolean

Syntax in C++

HRESULT get_HasValidIJK (VARIANT_BOOL* retVal)

Applies to

PointCloud


HasValidProjection

HasValidProjection - Read property

Description

property HasValidProjection

Syntax in Visual Basic or VBScript

HasValidProjection (nIndex As Long) As Boolean

Syntax in C++

HRESULT get_HasValidProjection (LONG nIndex , VARIANT_BOOL* retVal)

Applies to

PointCloud
PointCloudPoint


MaximumDeviation

MaximumDeviation - Read property

Description

property MaximumDeviation

Syntax in Visual Basic or VBScript

MaximumDeviation () As Double

Syntax in C++

HRESULT get_MaximumDeviation (double* retVal)

Applies to

PointCloud


MaxPoint

MaxPoint - Read property

Description

property MaxPoint

Syntax in Visual Basic or VBScript

MaxPoint () As Point3D

Syntax in C++

HRESULT get_MaxPoint (Point3D* retVal)

Applies to

PointCloud


MinimumDeviation

MinimumDeviation - Read property

Description

property MinimumDeviation

Syntax in Visual Basic or VBScript

MinimumDeviation () As Double

Syntax in C++

HRESULT get_MinimumDeviation (double* retVal)

Applies to

PointCloud


MinPoint

MinPoint - Read property

Description

property MinPoint

Syntax in Visual Basic or VBScript

MinPoint () As Point3D

Syntax in C++

HRESULT get_MinPoint (Point3D* retVal)

Applies to

PointCloud


ScanlineCount

ScanlineCount - Read property

Description

property ScanlineCount

Syntax in Visual Basic or VBScript

ScanlineCount () As Long

Syntax in C++

HRESULT get_ScanlineCount (LONG* retVal)

Applies to

PointCloud


AddPointXYZ

AddPointXYZ - method

Description

method AddPointXYZ

Syntax in Visual Basic or VBScript

AddPointXYZ (X As Double , Y As Double , Z As Double)

Syntax in C++

HRESULT AddPointXYZ (double X , double Y , double Z)

Parameters

Name | Description
X |
Y |
Z |

Applies to

PointCloud


AddPointXYZIJK

AddPointXYZIJK - method

Description

method AddPointXYZIJK

Syntax in Visual Basic or VBScript

AddPointXYZIJK (X As Double , Y As Double , Z As Double , I As Double , J As Double , K As Double)

Syntax in C++

HRESULT AddPointXYZIJK (double X , double Y , double Z , double I , double J , double K)

Parameters

Name | Description
X |
Y |
Z |
I |
J |
K |

Applies to

PointCloud


Import

Import - method

Description

method Import

Syntax in Visual Basic or VBScript

Import (filename As String , format As String , ByRef pCallback As IPointCloudImportCallback) As Boolean

Syntax in C++

HRESULT Import (BSTR filename , BSTR format , IPointCloudImportCallback* pCallback , VARIANT_BOOL* retVal)

Parameters

Name | Description
filename |
format |
pCallback |
Return Value |

Applies to

PointCloud


Scale

Scale - method

Description

method Scale : scale the point cloud

Syntax in Visual Basic or VBScript

Scale (Value As Double)

Syntax in C++

HRESULT Scale (double Value)

Parameters

Name | Description
Value |

Applies to

PointCloud


UnsetProjectionData

UnsetProjectionData - method

Description

method UnsetProjectionData

Syntax in Visual Basic or VBScript

UnsetProjectionData (nIndex As Long)

Syntax in C++

HRESULT UnsetProjectionData (LONG nIndex)

Parameters

Name | Description
nIndex |

Applies to

PointCloud


IPointCloudImportCallback

IPointCloudImportCallback - interface

Description

IPointCloud Interface


IPointCloudItem

IPointCloudItem - interface

Description

IPointCloudItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
ExportPoints |
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
ProjectPoints |
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PointCloud | R/O | return the point cloud associated with the given measure, in CMM coordinates
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ExportPoints

ExportPoints - method

Syntax in Visual Basic or VBScript

ExportPoints (measure As Variant , flag As PWI_POINTCLOUD_EXPORT_FLAG , format As PWI_POINTCLOUD_EXPORT_FORMAT , what As PWI_POINTCLOUD_EXPORT_WHAT , optional_filter As Variant , filename As String) As Boolean

Syntax in C++

HRESULT ExportPoints (VARIANT measure , PWI_POINTCLOUD_EXPORT_FLAG flag , PWI_POINTCLOUD_EXPORT_FORMAT format , PWI_POINTCLOUD_EXPORT_WHAT what , VARIANT optional_filter , BSTR filename , VARIANT_BOOL* retVal)

Parameters

Name | Description
measure |
flag |
format |
what |
optional_filter |
filename |
Return Value |

Applies to

IPointCloudItem


ProjectPoints

ProjectPoints - method

Syntax in Visual Basic or VBScript

ProjectPoints (tolerance As Double)

Syntax in C++

HRESULT ProjectPoints (double tolerance)

Parameters

Name | Description
tolerance |

Applies to

IPointCloudItem


IPointCloudPoint

IPointCloudPoint - interface

Description

IPointCloudPoint Interface

Methods

UnsetProjectionData method UnsetProjectionData

Properties

Deviation | R/W | property Deviation
HasValidProjection | R/O | property HasValidProjection
Index | R/W | property Index
Name | R/W | property Name
point | R/O | property Point
ProjectedPoint | R/O | property ProjectedPoint
ProjectedVector | R/O | property ProjectedVector
vector | R/O | property Vector


Index

Index - Read & Write property

Description

property Index

Syntax in Visual Basic or VBScript

Index () As Long

Syntax in C++

HRESULT get_Index (LONG* retVal)
HRESULT put_Index (LONG Value)

Applies to

PointCloudPoint


point

point - Read property

Description

property Point

Syntax in Visual Basic or VBScript

point () As Point3D

Syntax in C++

HRESULT get_point (Point3D* retVal)

Applies to

PointCloudPoint


ProjectedPoint

ProjectedPoint - Read property

Description

property ProjectedPoint

Syntax in Visual Basic or VBScript

ProjectedPoint () As Point3D

Syntax in C++

HRESULT get_ProjectedPoint (Point3D* retVal)

Applies to

PointCloudPoint


ProjectedVector

ProjectedVector - Read property

Description

property ProjectedVector

Syntax in Visual Basic or VBScript

ProjectedVector () As UnitVector3D

Syntax in C++

HRESULT get_ProjectedVector (UnitVector3D* retVal)

Applies to

PointCloudPoint


vector

vector - Read property

Description

property Vector

Syntax in Visual Basic or VBScript

vector () As Vector3D

Syntax in C++

HRESULT get_vector (Vector3D* retVal)

Applies to

PointCloudPoint


UnsetProjectionData

UnsetProjectionData - method

Description

method UnsetProjectionData

Syntax in Visual Basic or VBScript

UnsetProjectionData ()

Syntax in C++

HRESULT UnsetProjectionData ()

Applies to

PointCloudPoint


IPointCloudSelection

IPointCloudSelection - interface

Description

IIPointCloudSelection Interface

Methods

Get | method Get
Inverse | method Inverse
Set | method Set
SetAll | method SetAll
SetSize | method SetSize

Properties

Count R/W property Count


IPosition

IPosition - interface

Description

IPosition Interface

Properties

LocalDatum | R/O
MNTLEN | R/O
XVEC | R/O
ZVEC | R/O


IProbeDatabase

IProbeDatabase - interface

Description

IProbeDatabase Interface

Methods

ActivateSensor |
BuildProbePathForTipCalibration | Build a probe path that can be used to calibrate the following tip
CalibrateActiveSensor | brings a user interface to allow the active sensor to be calibrated
Compensate | get the compemsate coordinates according the active sensor
EditDatabase | brings a user dialog box to allow the underlying probe database to be managed
EditSensor |
Load | Load the probe database, stream could be a BSTR
ReconcileSensor |
Save | Save the probe database, if stream is null then the last known filename is used
Uncompensate | get the compemsate coordinates according the active sensor

Properties

ActiveSensorName | R/O | returns the name of the current active sensor
ActiveSensorType | R/O | returns the type of the current active sensor
Carriage | R/W | Carriage
CatalogueXMLPath | R/O | returns the path where all XML components related files are stored
Filename | R/W | The current file where this database is store
ParentWindow | R/W | Parent Window
Property | R/O |
Protocol | R/O | sets/retrieves the protocol that actually controls this carriage
SensorProperty | R/O |
Settings | R/O | The general settings for the probe database
Toolbox | R/O | returns a toolbox in the same context (process and thread ) as the probedatabase


IProbeDatabaseSettings

IProbeDatabaseSettings - interface

Description

IProbeDatabaseSettings Interface

Properties

ForceManualCalibration | R/W | Whether a manual calibration shall be performed in place of CNC calibration
ManualCalibAutoDismiss | R/W | Whether the manual calibration dialog automatically dismisses itself when the specified number of points have been taken
NumberPointsCylinder | R/W | Number of points to take for cylinder calibration
NumberPointsSphere | R/W | Number of points to take for sphere calibration
SafeDistance | R/W | Probe safe distance
SafeDistanceHead | R/W | Head safe distance


ForceManualCalibration

ForceManualCalibration - Read & Write property

Description

Whether a manual calibration shall be performed in place of CNC calibration

Syntax in Visual Basic or VBScript

ForceManualCalibration () As Boolean

Syntax in C++

HRESULT get_ForceManualCalibration (VARIANT_BOOL* retVal)
HRESULT put_ForceManualCalibration (VARIANT_BOOL Value)

Applies to

IProbeDatabaseSettings


ManualCalibAutoDismiss

ManualCalibAutoDismiss - Read & Write property

Description

Whether the manual calibration dialog automatically dismisses itself when the specified number of points have been taken

Syntax in Visual Basic or VBScript

ManualCalibAutoDismiss () As Boolean

Syntax in C++

HRESULT get_ManualCalibAutoDismiss (VARIANT_BOOL* retVal)
HRESULT put_ManualCalibAutoDismiss (VARIANT_BOOL Value)

Applies to

IProbeDatabaseSettings


NumberPointsCylinder

NumberPointsCylinder - Read & Write property

Description

Number of points to take for cylinder calibration

Syntax in Visual Basic or VBScript

NumberPointsCylinder () As Long

Syntax in C++

HRESULT get_NumberPointsCylinder (LONG* retVal)
HRESULT put_NumberPointsCylinder (LONG Value)

Applies to

IProbeDatabaseSettings


NumberPointsSphere

NumberPointsSphere - Read & Write property

Description

Number of points to take for sphere calibration

Syntax in Visual Basic or VBScript

NumberPointsSphere () As Long

Syntax in C++

HRESULT get_NumberPointsSphere (LONG* retVal)
HRESULT put_NumberPointsSphere (LONG Value)

Applies to

IProbeDatabaseSettings


SafeDistance

SafeDistance - Read & Write property

Description

Probe safe distance

Syntax in Visual Basic or VBScript

SafeDistance () As Double

Syntax in C++

HRESULT get_SafeDistance (double* retVal)
HRESULT put_SafeDistance (double Value)

Applies to

IProbeDatabaseSettings


SafeDistanceHead

SafeDistanceHead - Read & Write property

Description

Head safe distance

Syntax in Visual Basic or VBScript

SafeDistanceHead () As Double

Syntax in C++

HRESULT get_SafeDistanceHead (double* retVal)
HRESULT put_SafeDistanceHead (double Value)

Applies to

IProbeDatabaseSettings


IProbeDatabaseToolbox

IProbeDatabaseToolbox - interface

Description

IProbeDatabaseToolbox Interface

Methods

BuildProbeHeadEnvelope | Graphically build the envelope around a probe head ( start from the tool mounting point toward the quill ( upward )
BuildProbeToolGraphics | Graphically build a tool
CreateProbeHeadFromCatalogue | build up a probe head from the catalogue
CreateProbeRackFromCatalogue | build up a probe rack from the catalogue
CreateProbeToolFromAssemblyDefinition | create a probe from a assembly reference that exists in the ProbeCatalogue, assemblyDefinition can also be a XMLDocument containing the tag <AssemblyDefinition>
CreateSimpleStarProbe | create a coumpound tools with 5 simple touch trigger sensors
CreateTouchTriggerProbeWithOneSensor | create a simple touch trigger probe with a single spherical tip
FakeCalibrate |
FakeCalibrateTip |
GetProbeHeadKinematics | retrieve the probe head kinematics for as a XML iland string
PseudoCalibrateTip |
PseudoCalibrateTool |
ReconcileProbeTip |
SetProbeHeadOrientation |
SynchroniseDatabase | Copy all the tools from the source into the destination, avoiding duplicates. Copied tools will be uncalibrated in the destination.

Properties

CatalogueXMLPath | R/O | returns the path where all XML components related files are stored
CMMConfigurationPath | R/O | returns the path where all CMM Kinematics and related files are stored
ProbeHeadCatalogue | R/O | return the catalogue as a MSXMLDocumentObject
ProbePartCatalogue | R/O | Access the ProbePart Catalogue
UserCMMDefinitionPath | R/O | returns the path where the user store his own complete CMM Definition


IProbeHead

IProbeHead - interface

Description

IProbeHead Interface

Methods

_internal_PutActiveTip | INTERNAL USE ONLY
_internal_PutProbeTool | INTERNAL USE ONLY
FillIdentityCard | fill the node with the identity card of this item

Properties

_ID | R/W | INTERNAL USE ONLY
ActiveTip | R/W | sets/retrieves the current active probe tip, setting the active probe tip may invoke a probe change and a move of the physical device
Calibration | R/O | retrieves the calibration object
Carriage | R/O | returns the parent carriage
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
Mounting | R/W | Mounting - returns the mounting type technology ( m8 , Autojoint etc...)
Position | R/O | retrieves the R/O Position object that describes the position and orientation of the probe head relative to the CMM Zero Point
ProbeHeadType | R/O | retrieves the type of this probehead, usufull to identify its technology / OBSOLETE USE TYPE
ProbeMountingPointDatum | R/O | returns the probe mounting point datum relative to the CMM Coordinates system and the CMMZero Point, when the probe head is at its original position ( i.e A=0,B=0 for an indexable probe head
ProbeTool | R/W | sets/retrieves the current probe tool which is physically mounted on the probe head
ProbeToolMountingPoint | R/O | returns the probe mounting point relative the probe head local datum ( which has its origin at the hinge point), this is the connection point of a Probe Tool mounted on the probed head
QuillMountingPoint | R/O | returns the probe head mounting point on the quill relative the probe head local datum ( which has its origin at the hinge point)
ReferenceProbeLength | R/W | sets/retrieves the reference probe length -> the length of the probe used to do the calibration of the head
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user


IProbePath

IProbePath - interface

Description

IProbePath Interface

Methods

Clear | Clear and remove all elements in this probe path
CopyTo | copy the contents of this probe path into the specified one
FillArrayWithMeasuredCMMPoints |
GetActiveSensor | extract the active sensor at the current location or if not defined
GetCopy | create a copy the contents of this probe path into the specified one
Insert | method Insert
InsertBooleanParameter | Add a Float Parameter
InsertCompositeMeasureMove | Add an Composite Move to the probe path
InsertDynamicPositionalItem | Add a positional instruction to the probe Path, which is a defined
InsertFloatParameter | Add a Float Parameter
InsertMachineConfiguration | Insert a machine-configuration item into the probe-path.
InsertParameter | Add a Parameter
InsertPositionalItem | Add a positional instruction to the probe Path
InsertProbeAutoOrientation | Add a probe orientation change,instruct the probe to rotate so that the current active tip is along the specified vector
InsertProbePath | append the content of other ProbePath to this one at the specified location
InsertProbeSensorDefinition | Add a probe sensor definition/recall in the probe path
InsertScanCommand | Insert a scan instruction into the probe-path.
InvalidateMeasures | Clear all recorded CMMPoints on items
LockEdit |
LockUnit | Prevent other clients of the object from changing the units.
Remove | Remove a probe path item at the specified position
Scale | scale the probe path ( note : units are not changed
TransformFrom | Transformation of points
TransformTo | Transformation of points
UnlockEdit |
UnlockUnit | Remove existing unit lock, if any from the object.
XMLOutput | Get probe path in XML format

Properties

ContainsMultiaxisConfiguration | R/O | Does the probe-path contain machine configurations?
CustomData | R/W |
DelayNotifications | R/W |
DMIS | R/O | DMIS
IsEditLocked | R/O |
IsUnitLocked | R/O | Test whethee the units are currently locked.
MeasurementState | R/O |
NumberOfMeasurableItem | R/O |
NumberOfMeasuredItem | R/O |
PathType | R/W |
StrategyType | R/W |
units | R/W | sets/retrieves the unit of the probe path ( only mm or in or empty string)

Collections

Items | property Items
ProbingParameters | returns a collection of parameters than can be used by a object that knows how to generate this probe path


IProbePathCXMOutputter

IProbePathCXMOutputter - interface

Description

IProbePathCXMOutputter Interface

Methods

Append | Appends the given probe path to output.
AppendComment | Appends the given string as a comment.
AppendMOWorkplane | Appends a machine-orientation workplane definition to the output
AppendWithName | Appends the given probe path to output and marks it as belonging to a sequence item with the given name.
AppendWorkplane | Appends workplane definition to the output
Save | Saves the generated CXM file to a file on the disk.
SaveToXML | Dumps the generated CXM to the given XMLDocument object.
SetOrientationPointName | Set the current orientation point name.

Properties

CADBoundingBox | R/W | Allows to get/set the CAD bounding box, it is used in the FromPoint coordinates calculation
FromPoint | R/O | Allows to get/set the starting point coordinates (so called From Point)
OutputPoint | R/W | Get/Put the type of outputted point coordinates
OutputTransform | R/W | The transformation that will be applied to all output coordinates
OutputWorkplaneName | R/W | The output workplane name
PartName | R/W | Allows to get/set the NC program part name
SafeMoveDirection | R/O | Allows to get/set the safe move direction
SafeMoveDistance | R/W | Allows to get/set the safe move distance
ToolNumber | R/W | Allows to get/set the tool number
WCSNumber | R/W | Allows to get/set the Workpiece coordinate system number


IProbePathDynamicPosition

IProbePathDynamicPosition - interface

Description

IProbePathPositionalItem Interface

Methods

RecordMeasuredPositionAndVector | use to record the measure point ( only valid for MEASURE_TO COMPOSITE_MEASURE_MOVE )
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

AbsolutePosition | R/W | property AbsolutePosition: returns/sets the absolute coordinates of the targeted position of the probe center.Note setting the absolute position doesn;t aloter the CoordType property
ApproachVector | R/W | property ApproachVector
CoordType | R/W | property CoordType
DefinitionType | R/W | sets/returns the item defition type
DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
MeasuredCMMPoint | R/O | property MeasuredPoint
Offset | R/W | property Offset
OuterMaterialDirection | R/W | property OuterMaterialDirection
PointType | R/W | property PointType
Position | R/W | property Position: returns/sets the position of the probe center at the expected contact point.The position is either as an increment or a absolute position, depending of the CoordType value
PositionalItemType | R/W | property Type
PreviousAbsolutePosition | R/O | (property PreviousAbsolutePosition, The theorical absolute position of the probe before this move is executed
ProbePath | R/O | returns the parent probe path
SurfacePoint | R/W | property SurfacePoint
ValidMeasure | R/W | return TRUE is the held measured is valid


IProbePathEditor

IProbePathEditor - interface

Description

IProbePathEditor Interface

Methods

Cancel | exit the EDIT mode and revert back to the previous probe path
Commit | commit the current probe path and remain in Edit mode
Edit | enter the EDIT mode

Properties

Behavior | R/W | set/retrieve the editor behavior
CallBackObject | R/W | Set the call back object
Mode | R/O | sets/retrieves the probe path editor mode
ProbePath | R/W | sets/retrieves the probe path to edit


IProbePathEditorCallBack

IProbePathEditorCallBack - interface

Description

IProbePathEditorCallBack Interface

Methods

OnContactPointAdded
OnContactPointMoved


OnContactPointAdded

OnContactPointAdded - method

Syntax in Visual Basic or VBScript

OnContactPointAdded (ByRef pProbepath As ProbePath , pos As Long)

Syntax in C++

HRESULT OnContactPointAdded (ProbePath* pProbepath , LONG pos)

Parameters

Name | Description
pProbepath |
pos |

Applies to

IProbePathEditorCallBack


OnContactPointMoved

OnContactPointMoved - method

Syntax in Visual Basic or VBScript

OnContactPointMoved (ByRef pProbepath As ProbePath , pos As Long)

Syntax in C++

HRESULT OnContactPointMoved (ProbePath* pProbepath , LONG pos)

Parameters

Name | Description
pProbepath |
pos |

Applies to

IProbePathEditorCallBack


IProbePathFaultItem

IProbePathFaultItem - interface

Description

IProbePathFaultItem Interface

Properties

End | R/O | The end point of the fault segment.
FaultType | R/O | The probe-path fault-type.
Index | R/O | The index of this item relative to the list of faults in the IProbePathFaults parent.
Parent | R/O | The parent IProbePathFaults object
ProbePathItemIndex | R/O | The index of the probe-path item that this fault relates to.
Start | R/O | The start point of the fault segment.


IProbePathFaultItems

IProbePathFaultItems - interface

Description

IProbePathFaultItems Interface

Properties

Count | R/O | The number of fault items.
Item | R/O | Get the fault-item at the given index.

Used in

Items


IProbePathFaults

IProbePathFaults - interface

Description

IProbePathFaults Interface

Methods

AddPointFault | Add a fault-item to the end of the list
AddRangeFault | Add a fault-item to the end of the list.
Clear | Remove all the fault-items.
RemoveItem | Remove the fault-item at the given index.

Properties

VerificationStatus R/W The probe-path verification status.

Collections

Items The list of probe-path faults.


IProbePathItem

IProbePathItem - interface

Description

IProbePathItem Interface

Properties

DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
ProbePath | R/O | returns the parent probe path


IProbePathItemActiveMove

IProbePathItemActiveMove - interface

Description

IProbePathItemActiveMove Interface

Methods

RecordMeasuredPositionAndVector | use to record the measure point ( only valid for MEASURE_TO COMPOSITE_MEASURE_MOVE )
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

AbsolutePosition | R/W | property AbsolutePosition: returns/sets the absolute coordinates of the targeted position of the probe center.Note setting the absolute position doesn;t aloter the CoordType property
ApproachVector | R/W | property ApproachVector
CoordType | R/W | property CoordType
DefinitionType | R/W | sets/returns the item defition type
DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
MeasuredCMMPoint | R/O | property MeasuredPoint
OuterMaterialDirection | R/W | property OuterMaterialDirection
Position | R/W | property Position: returns/sets the position of the probe center at the expected contact point.The position is either as an increment or a absolute position, depending of the CoordType value
PositionalItemType | R/W | property Type
PreviousAbsolutePosition | R/O | (property PreviousAbsolutePosition, The theorical absolute position of the probe before this move is executed
ProbePath | R/O | returns the parent probe path
ValidMeasure | R/W | return TRUE is the held measured is valid


IProbePathItemCNCParameter

IProbePathItemCNCParameter - interface

Description

IProbePathItemActiveMove Interface

Properties

Definition | R/O |
DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
Name | R/W |
ParameterType | R/W |
ProbePath | R/O | returns the parent probe path
Value | R/W |


IProbePathItems

IProbePathItems - interface

Description

IProbePathItems Interface

Methods

Insert | method Add
Remove | Remove At

Properties

Count | R/W | property Count
Item | R/O | property Item

Used in

Items


IProbePathMachineConfiguration

IProbePathMachineConfiguration - interface

Description

IProbePathMachineConfiguration Interface

Methods

Copy Copy the parameter object data into this object.

Properties

DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MachineConfigurationCreatorType | R/O | The type of object that created this item.
MachineOrientation | R/O | The machine orientation of this item.
MagicNumber | R/O |
Position | R/O | The position at which the machine orientation should be performed.
ProbePath | R/O | returns the parent probe path


IProbePathPositionalItem

IProbePathPositionalItem - interface

Description

IProbePathPositionalItem Interface

Methods

RecordMeasuredPositionAndVector | use to record the measure point ( only valid for MEASURE_TO COMPOSITE_MEASURE_MOVE )
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

AbsolutePosition | R/W | property AbsolutePosition: returns/sets the absolute coordinates of the targeted position of the probe center.Note setting the absolute position doesn;t aloter the CoordType property
CoordType | R/W | property CoordType
DefinitionType | R/W | sets/returns the item defition type
DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
MeasuredCMMPoint | R/O | property MeasuredPoint
Position | R/W | property Position: returns/sets the position of the probe center at the expected contact point.The position is either as an increment or a absolute position, depending of the CoordType value
PositionalItemType | R/W | property Type
PreviousAbsolutePosition | R/O | (property PreviousAbsolutePosition, The theorical absolute position of the probe before this move is executed
ProbePath | R/O | returns the parent probe path
ValidMeasure | R/W | return TRUE is the held measured is valid


IProbePathReplay

IProbePathReplay - interface

Description

IProbePathReplay Interface

Methods

ConvertPointAccordingToMachinePosition | Convert the given point and vector from the current type to the new type according to the current position of the machine.
EmergencyStop | cancel any pending action. current step is also cancelled
GoStep | do one step only
Rewind | set the curent step to be the first
Run | runs all steps up to the end
RunWithController | runs all steps up to the end
Stop | cancel any pending action. current step is completed

Properties

AlignmentDatum | R/W |
BUSY | R/O |
CalibrationMode | R/W | Calibration Mode
CMMProtocol | R/O | calling this function will also set the carriage, you may want to use CMMProtocol or Carriage at your convenience but only call one of them
CurrentProbePathItem | R/O |
CurStep | R/W |
CurStepStatus | R/O |
JOBSTATUS | R/O |
ProbePath | R/W |
ProbeReconciliator | R/W | sets/retrieves the ProbeReconcilator, which will be used to substitute probes that do not formally exists on the driven system
RetryAndContinueMode | R/W | set/retrieve the retry and continue mode.


IProbePathScanItem

IProbePathScanItem - interface

Description

IProbePathScanItem Interface

Methods

AddPoints | Add contact points.
ClearPoints | Clear contact points.
GetPoints | Get the points.

Properties

DMIS | R/O | DMIS
Index | R/O | Index
ItemType | R/O | ItemType
MagicNumber | R/O |
ProbeDiameter | R/W | property ProbeDiameter
ProbePath | R/O | returns the parent probe path
ScanInstruction | R/O | The scan instruction associated with this object.


IProbePathTeach

IProbePathTeach - interface

Description

IProbePathTeach Interface

Methods

GetActiveSensorAtCursor | returns the name and identity card of the current active tip
RecordCurrentPosition | Insert a point matching the e current position of the CMM using the current settings
SynchroniseProbeHead | this method check that the correctnesss Head parameter and insert a element if necessary

Properties

AlignmentDatum | R/W |
CoordType | R/W | Retrieves/sets the recording mode for new coordinates
cursor | R/W |
Enable | R/W |
PositionalItemType | R/W | Retrieves/sets the type of Positional Item that will be next inserted
ProbePath | R/W |


IProbeRack

IProbeRack - interface

Description

IProbeRack Interface

Methods

FillIdentityCard fill the node with the identity card of this item

Properties

_ID | R/W | INTERNAL USE ONLY
Calibration | R/O | retrieves the calibration object
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
LocalDatum | R/O | returns the nominal local of the rack in CMM coordinate
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections

SlotCollection returns the collection of slots


IProbeRackCollection

IProbeRackCollection - interface

Description

IProbeRackCollection Interface

Methods

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string

Used in

RackCollection


IProbeRackSlot

IProbeRackSlot - interface

Description

IProbeRackSlot Interface

Methods

FillIdentityCard fill the node with the identity card of this item

Properties

_ID | R/W | INTERNAL USE ONLY
Calibration | R/O | retrieves the calibration object
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the index of this object within the parent collection
InterfaceType | R/O |
NominalPositionRelativeToRack | R/O | return the position of this slot relative to the Rack Local Coordinate System - Before Calibration - as provided by the manufacturer or defined by the user
PositionRelativeToCMM | R/O | return the Calibrated position of this slot relative to CMM Coordinate System
PositionRelativeToRack | R/O | return the Calibrated position of this slot relative to the Rack Local Coordinate System
Rack | R/O | return the parent Rack
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user


IProbeRackSlotCollection

IProbeRackSlotCollection - interface

Description

IProbeRackSlotCollection Interface

Methods

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string

Used in

SlotCollection


IProbeReconciliator

IProbeReconciliator - interface

Description

IProbeReconciliator Interface

Methods

CollectSensorDefinitionItems
Reconciliate
ReconciliateTip
RegisterVCARD

Properties

IsVCARDRegistered R/O returns T_TRUE if the VCARD is already known by the reconcilator


IProbeSensor

IProbeSensor - interface

Description

IProbeSensor Interface

Methods

FillIdentityCard | fill the node with the identity card of this item
GetProbeTip | retrieves the probe tip that match the given A and B angle, if bCreate = True, a new tip will be automatically create if none exists
RemoveUnusedAutomaticTips | remove unused tips that may have been created automaticaly by the system

Properties

_ID | R/W | INTERNAL USE ONLY
CalibratedDiameter | R/O | returns the calibrated diameter in mm
CalibratedLength | R/O | returns/sets the calibrated length of the sensor which is the length of its stem as process during the calibration phase
Calibration | R/O | retrieves the calibration object
connection | R/W | sets/returns the connection on which this sensor is fitted on the probe tool
Diameter | R/O | returns the parameter that describes the manufactured probe diameter
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the 0-based index of this object within the parent collection. this correspond to the index of the connector on which this element is connected to
InterfaceType | R/O |
length | R/O | returns/sets the length description of the sensor which is the length of its stem as provided by the manufacturer
Location | R/O | Location of the probe sensor active point(tip) relative to the probe head origin on the local probe head coordinates system
ProbeTool | R/O | retrieves the parent probe tool
ProbeType | R/O | returns the type of this sensor
Property | R/O |
StemVector | R/O | stem vector of the sensor expressed on the local probe head coordinates system
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections

ProbeTipCollection returns the probe tip collection which are all registered position (calibrated or not)


IProbeSensorCollection

IProbeSensorCollection - interface

Description

IProbeSensorCollection Interface

Methods

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection

Properties

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string


IProbeSensorCylinder

IProbeSensorCylinder - interface

Description

IProbeSensorCylinder Interface

Methods

FillIdentityCard | fill the node with the identity card of this item
GetProbeTip | retrieves the probe tip that match the given A and B angle, if bCreate = True, a new tip will be automatically create if none exists
RemoveUnusedAutomaticTips | remove unused tips that may have been created automaticaly by the system

Properties

_ID | R/W | INTERNAL USE ONLY
CalibratedDiameter | R/O | returns the calibrated diameter in mm
CalibratedLength | R/O | returns/sets the calibrated length of the sensor which is the length of its stem as process during the calibration phase
Calibration | R/O | retrieves the calibration object
connection | R/W | sets/returns the connection on which this sensor is fitted on the probe tool
Diameter | R/O | returns the parameter that describes the manufactured probe diameter
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the 0-based index of this object within the parent collection. this correspond to the index of the connector on which this element is connected to
InterfaceType | R/O |
length | R/O | returns/sets the length description of the sensor which is the length of its stem as provided by the manufacturer
Location | R/O | Location of the probe sensor active point(tip) relative to the probe head origin on the local probe head coordinates system
NoseType | R/W | sets/returns the type of cylindrical probe nose
ProbeTool | R/O | retrieves the parent probe tool
ProbeType | R/O | returns the type of this sensor
Property | R/O |
StemVector | R/O | stem vector of the sensor expressed on the local probe head coordinates system
ThreadID | R/O |
TipHeight | R/O | returns the information concerning the valid height of the cylinder tip of the sensor
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections

ProbeTipCollection returns the probe tip collection which are all registered position (calibrated or not)


IProbeSensorSphere

IProbeSensorSphere - interface

Description

IProbeSensorSphere Interface

Methods

FillIdentityCard | fill the node with the identity card of this item
GetProbeTip | retrieves the probe tip that match the given A and B angle, if bCreate = True, a new tip will be automatically create if none exists
RemoveUnusedAutomaticTips | remove unused tips that may have been created automaticaly by the system

Properties

_ID | R/W | INTERNAL USE ONLY
CalibratedDiameter | R/O | returns the calibrated diameter in mm
CalibratedLength | R/O | returns/sets the calibrated length of the sensor which is the length of its stem as process during the calibration phase
Calibration | R/O | retrieves the calibration object
connection | R/W | sets/returns the connection on which this sensor is fitted on the probe tool
Diameter | R/O | returns the parameter that describes the manufactured probe diameter
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the 0-based index of this object within the parent collection. this correspond to the index of the connector on which this element is connected to
InterfaceType | R/O |
length | R/O | returns/sets the length description of the sensor which is the length of its stem as provided by the manufacturer
Location | R/O | Location of the probe sensor active point(tip) relative to the probe head origin on the local probe head coordinates system
ProbeTool | R/O | retrieves the parent probe tool
ProbeType | R/O | returns the type of this sensor
Property | R/O |
StemVector | R/O | stem vector of the sensor expressed on the local probe head coordinates system
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections

ProbeTipCollection returns the probe tip collection which are all registered position (calibrated or not)


IProbeStructureBuilder

IProbeStructureBuilder - interface

Description

IProbeStructureBuilder Interface

Methods

addCone | Adds cone to new probe
addCylinder | Adds cylinder to new probe
addSphere | Adds sphere to new probe
addTip | Adds a new probe tip
endElement | Completes an element in the structure
EndProbeBuilder | End building a new probe
startElement | Starts a new element in the structure
StartProbeBuilder | Start building a new probe


addCone

addCone - method

Description

Adds cone to new probe

Syntax in Visual Basic or VBScript

addCone (topX As Double , topY As Double , topZ As Double , topRadius As Double , bottomX As Double , bottomY As Double , bottomZ As Double , boottomRadius As Double , colour As Long , material As Long)

Syntax in C++

HRESULT addCone (double topX , double topY , double topZ , double topRadius , double bottomX , double bottomY , double bottomZ , double boottomRadius , LONG colour , LONG material)

Parameters

Name | Description
topX |
topY |
topZ |
topRadius |
bottomX |
bottomY |
bottomZ |
boottomRadius |
colour |
material |

Applies to

ProbeStructureBuilder


addCylinder

addCylinder - method

Description

Adds cylinder to new probe

Syntax in Visual Basic or VBScript

addCylinder (topX As Double , topY As Double , topZ As Double , bottomX As Double , bottomY As Double , bottomZ As Double , Radius As Double , colour As Long , material As Long)

Syntax in C++

HRESULT addCylinder (double topX , double topY , double topZ , double bottomX , double bottomY , double bottomZ , double Radius , LONG colour , LONG material)

Parameters

Name | Description
topX |
topY |
topZ |
bottomX |
bottomY |
bottomZ |
Radius |
colour |
material |

Applies to

ProbeStructureBuilder


addSphere

addSphere - method

Description

Adds sphere to new probe

Syntax in Visual Basic or VBScript

addSphere (X As Double , Y As Double , Z As Double , Radius As Double , colour As Long , material As Long)

Syntax in C++

HRESULT addSphere (double X , double Y , double Z , double Radius , LONG colour , LONG material)

Parameters

Name | Description
X |
Y |
Z |
Radius |
colour |
material |

Applies to

ProbeStructureBuilder


addTip

addTip - method

Description

Adds a new probe tip

Syntax in Visual Basic or VBScript

addTip (I As Double , J As Double , K As Double , Radius As Double , length As Double , colour As Long , material As Long)

Syntax in C++

HRESULT addTip (double I , double J , double K , double Radius , double length , LONG colour , LONG material)

Parameters

Name | Description
I |
J |
K |
Radius |
length |
colour |
material |

Applies to

ProbeStructureBuilder


endElement

endElement - method

Description

Completes an element in the structure

Syntax in Visual Basic or VBScript

endElement ()

Syntax in C++

HRESULT endElement ()

Applies to

ProbeStructureBuilder


EndProbeBuilder

EndProbeBuilder - method

Description

End building a new probe

Syntax in Visual Basic or VBScript

EndProbeBuilder (saveProbe As Boolean)

Syntax in C++

HRESULT EndProbeBuilder (VARIANT_BOOL saveProbe)

Parameters

Name | Description
saveProbe |

Applies to

ProbeStructureBuilder


startElement

startElement - method

Description

Starts a new element in the structure

Syntax in Visual Basic or VBScript

startElement (ByRef pUserData As Variant , probeComponentType As PROBECOMPONENT_TYPE)

Syntax in C++

HRESULT startElement (VARIANT* pUserData , PROBECOMPONENT_TYPE probeComponentType)

Parameters

Name | Description
pUserData |
probeComponentType |

Applies to

ProbeStructureBuilder


StartProbeBuilder

StartProbeBuilder - method

Description

Start building a new probe

Syntax in Visual Basic or VBScript

StartProbeBuilder (probeName As String)

Syntax in C++

HRESULT StartProbeBuilder (BSTR probeName)

Parameters

Name | Description
probeName |

Applies to

ProbeStructureBuilder


IProbeTip

IProbeTip - interface

Description

IProbeTip Interface

Methods

Compensate | Apply the probe offset compensation to the give coordinates according to this tip
Delete | remove this element from its parent collection
FillIdentityCard | fill the node with the identity card of this item
GetSmartName | return a smart name for this tip based on the sensor/tool and type of probehead actually used
Uncompensate | Undo the effect of the probe offset compensation on the give coordinates according to this tip

Properties

_ID | R/W | INTERNAL USE ONLY
A | R/O | retrieves the A angle for which this tip is defined
B | R/O | retrieves the B angle for which this tip is defined
Calibration | R/O | retrieves the calibration object
Diameter | R/O | Actual Diameter as calibrated ( in milimeters )
Direction | R/O | Direction of the probe shaft when this tip is active ( from tip along the shaft direction : i.e for a vertical probe, this will be 0,0,+1)
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the 0-based index of this object within the parent collection
InterfaceType | R/O |
IsTemporary | R/W | returns TRUE if the tip is a temporary position, a temporary position is not persisted and is removed once the tip is not active anymore
offset | R/O | returns the calibrated offset for this tip
ProbeSensor | R/O | return the parent ProbeSensor
Property | R/O |
SmartName | R/O | return a smart name for this tip based on the sensor/tool and type of probehead actually used
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections

parent returns the parent object of this object i.e the collection


IProbeTipCollection

IProbeTipCollection - interface

Description

IProbeTipCollection Interface

Methods

Delete method Delete : delete a tip from the collection

Properties

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string

Used in

parent
ProbeTipCollection
ProbeTipCollection


IProbeTool

IProbeTool - interface

Description

IProbeTool Interface

Methods

Delete | remove this element from its parent collection
FillIdentityCard | fill the node with the identity card of this item
RemoveUnusedAutomaticTips | remove unused tips that may have been created automaticaly by the system

Properties

_ID | R/W | INTERNAL USE ONLY
ActiveSensor | R/W | sets/retrieves the active probe sensor
assemblyDefinition | R/W | retrieves/sets the Assembly definition XML string
Calibration | R/O | retrieves the calibration object
Carriage | R/O | returns the parent ICarriage
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the index of this object within the parent collection
InterfaceType | R/O |
JunctionOffset | R/O | retreives the position of the junction point of this tool relative to the probe Head center point the local Probe Head co-ordinate system
Sensor | R/O | retrieve a sensor of this probe by name
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections

Connections | retrieves the connections ProbeToolConnections
parent | returns the parent object of this object i.e the collection


IProbeToolCollection

IProbeToolCollection - interface

Description

IProbeToolCollection Interface

Methods

Add | method Add : add an item to the collection
Delete | method Delete : delete an item from the collection
DeleteAll | Delete all the connections

Properties

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string

Used in

parent
ProbeToolCollection


IProbeToolConnection

IProbeToolConnection - interface

Description

IProbeToolConnection Interface

Methods

Delete | remove this connection from the parent connections collection
FillIdentityCard | fill the node with the identity card of this item

Properties

_ID | R/W | INTERNAL USE ONLY
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
index | R/O | returns the 0-based index of this object within the parent collection
InterfaceType | R/O |
ProbeSensor | R/W | sets/retrieves the attached sensor
ProbeTool | R/O | retrieves the parent probe tool
SensorMountingDirection | R/O | returns the sensor Mounting Direction
SensorMountingPoint | R/O | returns the sensor Mounting point
ThreadID | R/O |
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user

Collections

parent returns the parent object of this object i.e the collection


IProbeToolConnections

IProbeToolConnections - interface

Description

IProbeToolConnections Interface

Methods

Delete | remove a connection from the collection
DeleteAll | Delete all the connections

Properties

Count | R/W | Indicates the number of items in the collection.
item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 0 to Count-1 or a string

Used in

Connections
parent


IProperties

IProperties - interface

Description

IProperties Interface

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual property within the collection. Index can be an ordinal from 1 to Count or a string

Used in

Properties


IProperty

IProperty - interface

Description

IProperty Interface

Properties

Description | R/O |
Index | R/O | returns the index of this property in its parent collection
Name | R/W |
OutputToReport | R/W |
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |


IProperty1

IProperty1 - interface

Description

IProperty1 Interface for Angle, Dimension

Properties

Description | R/O |
Error | R/O | return the actual measured error for the given measure
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the lower tolerance for this property
Measured | R/O | return the actual measured value for the given measure
Name | R/W |
Nominal | R/W | get the nominal value of the property
OutputToReport | R/W |
OverRun | R/O | return the actual measured overrun for the given measure
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the upper tolerance for this property


IProperty3

IProperty3 - interface

Description

IProperty3 Interface

Methods

SetLowerTolerances | set the 3 lower tolerance values
SetNominals | set the 3 nominal values
SetUpperTolerances | set the 3 upper tolerance values

Properties

Description | R/O |
Error | R/O | return the measured error ( also called deviation ) for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the Lower Tolerance value for the specified coordinate ( index = 0,1 or 2)
Measured | R/O | return the measured value for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
MeasuredCoord | T/O | get the measured coordinates for the given measure
Name | R/W |
Nominal | R/W | return the nominal value for the specified coordinate ( index = 0,1 or 2)
NominalCoord | R/W | get the nominal coordinates
OutputCoordToReport | R/W | return true if the specified coordinate is candidate to be printed in the Excel Report
OutputToReport | R/W |
OverRun | R/O | return the measured OVERUN ( if error is outof tolerance bounds) , for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the Upper Tolerance value for the specified coordinate ( index = 0,1 or 2)


IPropertyAngle

IPropertyAngle - interface

Description

IPropertyAngle Interface for Angle

Properties

AngleRange | R/W | Return the desired range for reporting the angle
Description | R/O |
Error | R/O | return the actual measured error for the given measure
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the lower tolerance for this property
Measured | R/O | return the actual measured value for the given measure
Name | R/W |
Nominal | R/W | get the nominal value of the property
OutputToReport | R/W |
OverRun | R/O | return the actual measured overrun for the given measure
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the upper tolerance for this property


IPropertyGeometricTolerance

IPropertyGeometricTolerance - interface

Description

GeometricTolerance Interface for Geometric Tolerancing

Properties

Description | R/O |
Index | R/O | returns the index of this property in its parent collection
maxValue | R/W | get the maximum allowed deviation
Measured | R/O | set the actual measured deviation
Name | R/W |
OutputToReport | R/W |
OverRun | R/O | set the actual measured overrun
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |


IPropertyLinearDimension

IPropertyLinearDimension - interface

Description

IPropertyLinearDimension Interface for Geometric Tolerancing

Properties

Description | R/O |
Error | R/O | return the actual measured error for the given measure
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the lower tolerance for this property
Measured | R/O | return the actual measured value for the given measure
Name | R/W |
Nominal | R/W | get the nominal value of the property
OutputToReport | R/W |
OverRun | R/O | return the actual measured overrun for the given measure
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the upper tolerance for this property


IPropertyPoint3D

IPropertyPoint3D - interface

Description

IPropertyPoint3 Interface

Methods

SetLowerTolerances | set the 3 lower tolerance values
SetNominals | set the 3 nominal values
SetUpperTolerances | set the 3 upper tolerance values

Properties

CoordinateType | R/O | prefered coordinate type ( cartesian, polar, spherical
Description | R/O |
Error | R/O | return the measured error ( also called deviation ) for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the Lower Tolerance value for the specified coordinate ( index = 0,1 or 2)
Measured | R/O | return the measured value for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
MeasuredCoord | T/O | get the measured coordinates for the given measure
Name | R/W |
Nominal | R/W | return the nominal value for the specified coordinate ( index = 0,1 or 2)
NominalCoord | R/W | get the nominal coordinates
OutputCoordToReport | R/W | return true if the specified coordinate is candidate to be printed in the Excel Report
OutputToReport | R/W |
OverRun | R/O | return the measured OVERUN ( if error is outof tolerance bounds) , for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the Upper Tolerance value for the specified coordinate ( index = 0,1 or 2)


IPropertyRadialDimension

IPropertyRadialDimension - interface

Description

IPropertyRadialDimension Interface for Geometric Tolerancing

Methods

ConvertTo change the type of the radial dimension, by changing the nominal value accordingly

Properties

Description | R/O |
Error | R/O | return the actual measured error for the given measure
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the lower tolerance for this property
Measured | R/O | return the actual measured value for the given measure
Name | R/W |
Nominal | R/W | get the nominal value of the property
OutputToReport | R/W |
OverRun | R/O | return the actual measured overrun for the given measure
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
RadialDimensionType | R/W | change the type of the radial dimension, by preseving the nominal value
UpperTol | R/W | get the upper tolerance for this property


IPropertyUnitVector3D

IPropertyUnitVector3D - interface

Description

IPropertyUnitVector3D Interface

Methods

SetLowerTolerances | set the 3 lower tolerance values
SetNominals | set the 3 nominal values
SetUpperTolerances | set the 3 upper tolerance values

Properties

CoordinateType | R/O | prefered coordinate system
Description | R/O |
Error | R/O | return the measured error ( also called deviation ) for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the Lower Tolerance value for the specified coordinate ( index = 0,1 or 2)
Measured | R/O | return the measured value for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
MeasuredCoord | T/O | get the measured coordinates for the given measure
Name | R/W |
Nominal | R/W | return the nominal value for the specified coordinate ( index = 0,1 or 2)
NominalCoord | R/W | get the nominal coordinates
OutputCoordToReport | R/W | return true if the specified coordinate is candidate to be printed in the Excel Report
OutputToReport | R/W |
OverRun | R/O | return the measured OVERUN ( if error is outof tolerance bounds) , for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the Upper Tolerance value for the specified coordinate ( index = 0,1 or 2)


IPropertyVector3D

IPropertyVector3D - interface

Description

IPropertyVector3D Interface

Methods

SetLowerTolerances | set the 3 lower tolerance values
SetNominals | set the 3 nominal values
SetUpperTolerances | set the 3 upper tolerance values

Properties

CoordinateType | R/O | prefered coordinate system
Description | R/O |
Error | R/O | return the measured error ( also called deviation ) for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Index | R/O | returns the index of this property in its parent collection
LowerTol | R/W | get the Lower Tolerance value for the specified coordinate ( index = 0,1 or 2)
Measured | R/O | return the measured value for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
MeasuredCoord | T/O | get the measured coordinates for the given measure
Name | R/W |
Nominal | R/W | return the nominal value for the specified coordinate ( index = 0,1 or 2)
NominalCoord | R/W | get the nominal coordinates
OutputCoordToReport | R/W | return true if the specified coordinate is candidate to be printed in the Excel Report
OutputToReport | R/W |
OverRun | R/O | return the measured OVERUN ( if error is outof tolerance bounds) , for the specified coordinate ( index = 0,1 or 2) and the specified Measure ( could be an Object or a string)
Parent | R/O | return ISequence Item that owns this feature
PropertyType | R/O |
UpperTol | R/W | get the Upper Tolerance value for the specified coordinate ( index = 0,1 or 2)


IPWIArc3D

IPWIArc3D - interface

Description

IPWIArc3D Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

CenterPoint | R/O |
EndAngle | R/W | set/retrieve the end angle in degree
EndPoint | R/O |
Evaluator | T/O |
Name | R/W |
NormalVector | R/O |
Radius | R/W |
ReadOnly | R/O |
StartAngle | R/W | set/retrieve the start angle in degree
StartPoint | R/O |
TypeOf | R/O |


CenterPoint

CenterPoint - Read property

Syntax in Visual Basic or VBScript

CenterPoint () As Point3D

Syntax in C++

HRESULT get_CenterPoint (Point3D* retVal)

Applies to

Arc3D
IPWICircle3D


EndAngle

EndAngle - Read & Write property

Description

set/retrieve the end angle in degree

Syntax in Visual Basic or VBScript

EndAngle () As Double

Syntax in C++

HRESULT get_EndAngle (double* retVal)
HRESULT put_EndAngle (double Value)

Applies to

Arc3D


EndPoint

EndPoint - Read property

Syntax in Visual Basic or VBScript

EndPoint () As Point3D

Syntax in C++

HRESULT get_EndPoint (Point3D* retVal)

Applies to

Arc3D
IPWILine3D


NormalVector

NormalVector - Read property

Syntax in Visual Basic or VBScript

NormalVector () As UnitVector3D

Syntax in C++

HRESULT get_NormalVector (UnitVector3D* retVal)

Applies to

Arc3D
IPWICircle3D
plane
IPWIRectangle
IPWISlot


Radius

Radius - Read & Write property

Syntax in Visual Basic or VBScript

Radius () As Double

Syntax in C++

HRESULT get_Radius (double* retVal)
HRESULT put_Radius (double Value)

Applies to

Arc3D
IPWICircle3D
IPWICylinder
IPWISphere


StartAngle

StartAngle - Read & Write property

Description

set/retrieve the start angle in degree

Syntax in Visual Basic or VBScript

StartAngle () As Double

Syntax in C++

HRESULT get_StartAngle (double* retVal)
HRESULT put_StartAngle (double Value)

Applies to

Arc3D


StartPoint

StartPoint - Read property

Syntax in Visual Basic or VBScript

StartPoint () As Point3D

Syntax in C++

HRESULT get_StartPoint (Point3D* retVal)

Applies to

Arc3D
IPWILine3D


IPWICircle3D

IPWICircle3D - interface

Description

IPWICircle3D Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

CenterPoint | R/O
Evaluator | T/O
Name | R/W
NormalVector | R/O
Radius | R/W
ReadOnly | R/O
TypeOf | R/O


IPWICone

IPWICone - interface

Description

IPWICone Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

Apex | R/O | returns the Apex point of the cone
axis | R/O |
BottomBase | R/O |
Evaluator | T/O |
HalfAngle | R/W | set/retrieve the half angle in degree
Height | R/W |
Name | R/W |
ReadOnly | R/O |
TopBase | R/O |
TypeOf | R/O |


Apex

Apex - Read property

Description

returns the Apex point of the cone

Syntax in Visual Basic or VBScript

Apex () As Point3D

Syntax in C++

HRESULT get_Apex (Point3D* retVal)

Applies to

IPWICone


axis

axis - Read property

Syntax in Visual Basic or VBScript

axis () As IPWILine3D

Syntax in C++

HRESULT get_axis (IPWILine3D* retVal)

Applies to

IPWICone
IPWICylinder
IPWITorus


BottomBase

BottomBase - Read property

Syntax in Visual Basic or VBScript

BottomBase () As Arc3D

Syntax in C++

HRESULT get_BottomBase (Arc3D* retVal)

Applies to

IPWICone
IPWICylinder


HalfAngle

HalfAngle - Read & Write property

Description

set/retrieve the half angle in degree

Syntax in Visual Basic or VBScript

HalfAngle () As Double

Syntax in C++

HRESULT get_HalfAngle (double* retVal)
HRESULT put_HalfAngle (double Value)

Applies to

IPWICone


Height

Height - Read & Write property

Syntax in Visual Basic or VBScript

Height () As Double

Syntax in C++

HRESULT get_Height (double* retVal)
HRESULT put_Height (double Value)

Applies to

IPWICone
IPWICylinder


TopBase

TopBase - Read property

Syntax in Visual Basic or VBScript

TopBase () As Arc3D

Syntax in C++

HRESULT get_TopBase (Arc3D* retVal)

Applies to

IPWICone
IPWICylinder


IPWICylinder

IPWICylinder - interface

Description

IPWICylinder Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

axis | R/O
BottomBase | R/O
Diameter | R/W
Evaluator | T/O
Height | R/W
Name | R/W
Radius | R/W
ReadOnly | R/O
TopBase | R/O
TypeOf | R/O


Diameter

Diameter - Read & Write property

Syntax in Visual Basic or VBScript

Diameter () As Double

Syntax in C++

HRESULT get_Diameter (double* retVal)
HRESULT put_Diameter (double Value)

Applies to

IPWICylinder
IPWISphere


IPWILine3D

IPWILine3D - interface

Description

IPWILine3D Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

DirVector | R/O
EndPoint | R/O
Evaluator | T/O
Name | R/W
ReadOnly | R/O
StartPoint | R/O
TypeOf | R/O


DirVector

DirVector - Read property

Syntax in Visual Basic or VBScript

DirVector () As UnitVector3D

Syntax in C++

HRESULT get_DirVector (UnitVector3D* retVal)

Applies to

IPWILine3D


IPWIPlane

IPWIPlane - interface

Description

IPWIPlane Interface

Methods

SetCoefficients |
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

A | R/O
B | R/O
C | R/O
D | R/O
Evaluator | T/O
Name | R/W
NormalVector | R/O
origin | R/O
ReadOnly | R/O
TypeOf | R/O


A

A - Read property

Syntax in Visual Basic or VBScript

A () As Double

Syntax in C++

HRESULT get_A (double* retVal)

Applies to

plane


B

B - Read property

Syntax in Visual Basic or VBScript

B () As Double

Syntax in C++

HRESULT get_B (double* retVal)

Applies to

plane


C

C - Read property

Syntax in Visual Basic or VBScript

C () As Double

Syntax in C++

HRESULT get_C (double* retVal)

Applies to

plane


D

D - Read property

Syntax in Visual Basic or VBScript

D () As Double

Syntax in C++

HRESULT get_D (double* retVal)

Applies to

plane


origin

origin - Read property

Syntax in Visual Basic or VBScript

origin () As Point3D

Syntax in C++

HRESULT get_origin (Point3D* retVal)

Applies to

plane
IPWIRectangle
IPWISlot
IPWITorus


SetCoefficients

SetCoefficients - method

Syntax in Visual Basic or VBScript

SetCoefficients (A As Double , B As Double , C As Double , D As Double)

Syntax in C++

HRESULT SetCoefficients (double A , double B , double C , double D)

Parameters

Name | Description
A |
B |
C |
D |

Applies to

plane


IPWIPoint

IPWIPoint - interface

Description

IPWIPoint Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

Evaluator | T/O
Name | R/W
point | R/O
ReadOnly | R/O
TypeOf | R/O


IPWIRectangle

IPWIRectangle - interface

Description

IPWIRectangle Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

Evaluator | T/O
Length | R/W
MajorAxis | R/O
MinorAxis | R/O
Name | R/W
NormalVector | R/O
origin | R/O
ReadOnly | R/O
TypeOf | R/O
Vertex | R/O
VerticeCount | R/O
Width | R/W


Length

Length - Read & Write property

Syntax in Visual Basic or VBScript

Length () As Double

Syntax in C++

HRESULT get_Length (double* retVal)
HRESULT put_Length (double Value)

Applies to

IPWIRectangle
IPWISlot
IPWIWireframeEvaluator3D


MajorAxis

MajorAxis - Read property

Syntax in Visual Basic or VBScript

MajorAxis () As UnitVector3D

Syntax in C++

HRESULT get_MajorAxis (UnitVector3D* retVal)

Applies to

IPWIRectangle
IPWISlot


MinorAxis

MinorAxis - Read property

Syntax in Visual Basic or VBScript

MinorAxis () As UnitVector3D

Syntax in C++

HRESULT get_MinorAxis (UnitVector3D* retVal)

Applies to

IPWIRectangle
IPWISlot


Vertex

Vertex - Read property

Syntax in Visual Basic or VBScript

Vertex (Index As Long) As Point3D

Syntax in C++

HRESULT get_Vertex (LONG Index , Point3D* retVal)

Applies to

IPWIRectangle
IPWISlot


VerticeCount

VerticeCount - Read property

Syntax in Visual Basic or VBScript

VerticeCount () As Long

Syntax in C++

HRESULT get_VerticeCount (LONG* retVal)

Applies to

IPWIRectangle
IPWISlot


Width

Width - Read & Write property

Syntax in Visual Basic or VBScript

Width () As Double

Syntax in C++

HRESULT get_Width (double* retVal)
HRESULT put_Width (double Value)

Applies to

IPWIRectangle
IPWISlot


IPWIScript

IPWIScript - interface

Description

IPWIScript Interface

Methods

ConnectObject | Connect an object
CreateObject | Create an object local to the thread of this
DisconnectObject | Disconnect an object
MessageBox | Display a message box on the screen: you are encouraged to use the built in VBScript MsgBox as this method is for backward compatibility only
Sleep | Suspends the execution of the current thread while continuing to service the Windows message queue.

Properties

ScriptFileName | R/O | The current script file name
srcElement | T/O | The object that fired the event


ScriptFileName

ScriptFileName - Read property

Description

The current script file name

Syntax in Visual Basic or VBScript

ScriptFileName () As String

Syntax in C++

HRESULT get_ScriptFileName (BSTR* retVal)

Applies to

IPWIScript


srcElement

srcElement - Reference Write property

Description

The object that fired the event

Syntax in Visual Basic or VBScript

srcElement () As Object

Syntax in C++

HRESULT get_srcElement (IDispatch** retVal)

Applies to

IPWIScript


ConnectObject

ConnectObject - method

Description

Connect an object

Syntax in Visual Basic or VBScript

ConnectObject (pObj As Object , prefix As String)

Syntax in C++

HRESULT ConnectObject (IDispatch* pObj , BSTR prefix)

Parameters

Name | Description
pObj |
prefix |

Applies to

IPWIScript


CreateObject

CreateObject - method

Description

Create an object local to the thread of this

Syntax in Visual Basic or VBScript

CreateObject (strProgID As String , prefix As Variant) As Object

Syntax in C++

HRESULT CreateObject (BSTR strProgID , VARIANT prefix , IDispatch** retVal)

Parameters

Name | Description
strProgID |
prefix |
Return Value |

Applies to

IPWIScript


DisconnectObject

DisconnectObject - method

Description

Disconnect an object

Syntax in Visual Basic or VBScript

DisconnectObject (pObj As Object)

Syntax in C++

HRESULT DisconnectObject (IDispatch* pObj)

Parameters

Name | Description
pObj |

Applies to

IPWIScript


MessageBox

MessageBox - method

Description

Display a message box on the screen: you are encouraged to use the built in VBScript MsgBox as this method is for backward compatibility only

Syntax in Visual Basic or VBScript

MessageBox (message As String , flag As Long) As Long

Syntax in C++

HRESULT MessageBox (BSTR message , LONG flag , LONG* retVal)

Parameters

Name | Description
message |
flag |
Return Value |

Applies to

IPWIScript


Sleep

Sleep - method

Description

Suspends the execution of the current thread while continuing to service the Windows message queue.

Syntax in Visual Basic or VBScript

Sleep (milli_seconds As Long)

Syntax in C++

HRESULT Sleep (LONG milli_seconds)

Parameters

Name | Description
milli_seconds |

Applies to

IPWIScript


IPWISlot

IPWISlot - interface

Description

IPWISlot Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

Arc1 | R/O | return the first arc, readOnly
Arc2 | R/O | return the second arc, readOnly
Evaluator | T/O |
Length | R/W |
MajorAxis | R/O |
MinorAxis | R/O |
Name | R/W |
NormalVector | R/O |
origin | R/O |
ReadOnly | R/O |
TypeOf | R/O |
Vertex | R/O |
VerticeCount | R/O |
Width | R/W |


Arc1

Arc1 - Read property

Description

return the first arc, readOnly

Syntax in Visual Basic or VBScript

Arc1 () As Arc3D

Syntax in C++

HRESULT get_Arc1 (Arc3D* retVal)

Applies to

IPWISlot


Arc2

Arc2 - Read property

Description

return the second arc, readOnly

Syntax in Visual Basic or VBScript

Arc2 () As Arc3D

Syntax in C++

HRESULT get_Arc2 (Arc3D* retVal)

Applies to

IPWISlot


IPWISphere

IPWISphere - interface

Description

IPWISphere Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

Centre | R/O
Diameter | R/W
Evaluator | T/O
Name | R/W
Radius | R/W
ReadOnly | R/O
TypeOf | R/O


Centre

Centre - Read property

Syntax in Visual Basic or VBScript

Centre () As Point3D

Syntax in C++

HRESULT get_Centre (Point3D* retVal)

Applies to

IPWISphere


IPWITorus

IPWITorus - interface

Description

IPWITorus Interface

Methods

TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

axis | R/O
Evaluator | T/O
MajorDiameter | R/W
MajorRadius | R/W
MinorDiameter | R/W
MinorRadius | R/W
Name | R/W
origin | R/O
ReadOnly | R/O
TypeOf | R/O


MajorDiameter

MajorDiameter - Read & Write property

Syntax in Visual Basic or VBScript

MajorDiameter () As Double

Syntax in C++

HRESULT get_MajorDiameter (double* retVal)
HRESULT put_MajorDiameter (double Value)

Applies to

IPWITorus


MajorRadius

MajorRadius - Read & Write property

Syntax in Visual Basic or VBScript

MajorRadius () As Double

Syntax in C++

HRESULT get_MajorRadius (double* retVal)
HRESULT put_MajorRadius (double Value)

Applies to

IPWITorus


MinorDiameter

MinorDiameter - Read & Write property

Syntax in Visual Basic or VBScript

MinorDiameter () As Double

Syntax in C++

HRESULT get_MinorDiameter (double* retVal)
HRESULT put_MinorDiameter (double Value)

Applies to

IPWITorus


MinorRadius

MinorRadius - Read & Write property

Syntax in Visual Basic or VBScript

MinorRadius () As Double

Syntax in C++

HRESULT get_MinorRadius (double* retVal)
HRESULT put_MinorRadius (double Value)

Applies to

IPWITorus


IPWIWireframeEvaluator3D

IPWIWireframeEvaluator3D - interface

Description

IPWIWireframeEvaluator3D Interface

Properties

Distance | R/O | returns the absolute ( >0 ) distance from the point to the entity
EndParam | R/O |
Length | R/W |
PointAtParam | R/O |
StartParam | R/O |


Distance

Distance - Read property

Description

returns the absolute ( >0 ) distance from the point to the entity

Syntax in Visual Basic or VBScript

Distance (point As Variant , ByRef p As Double)

Syntax in C++

HRESULT get_Distance (VARIANT point , double* p)

Applies to

IPWIWireframeEvaluator3D


EndParam

EndParam - Read property

Syntax in Visual Basic or VBScript

EndParam () As Double

Syntax in C++

HRESULT get_EndParam (double* retVal)

Applies to

IPWIWireframeEvaluator3D


PointAtParam

PointAtParam - Read property

Syntax in Visual Basic or VBScript

PointAtParam (param As Double) As Double

Syntax in C++

HRESULT get_PointAtParam (double param , double* retVal)

Applies to

IPWIWireframeEvaluator3D


StartParam

StartParam - Read property

Syntax in Visual Basic or VBScript

StartParam () As Double

Syntax in C++

HRESULT get_StartParam (double* retVal)

Applies to

IPWIWireframeEvaluator3D


IrbDHTMLBridge

IrbDHTMLBridge - interface

Description

IrbDHTMLBridge Interface

Methods

EnableModeless |
FilterDataObject |
GetDropTarget |
GetExternal |
GetHostInfo |
GetOptionKeyPath |
HideUI |
LocalizeString | Returns localised string if possible
OnDocWindowActivate |
OnElementClicked | Informs the engine that an element is clicked
OnFrameWindowActivate |
ReportParameters | Returns XML reported by report engine about settings of report
ResizeBorder |
set_export_info | method set_export_info
set_page_settings | method set_page_settings
ShowContextMenu |
ShowUI |
tm_getConfig | method tm_getConfig
tm_getConfigLocation | method tm_getConfigLocation
tm_getParameters | Returns the available collection of id's as an XML document
tm_getStyles | method tm_getStyle
tm_getTemplate | method tm_getTemplate
tm_getTemplateNoCache | returns a template as it is stored
tm_init | method tm_init
tm_locate_file | method tm_locate_file
tm_saveTemplate | Saves the provided template with the provided name
TranslateAccelerator |
TranslateUrl |
UpdateUI |

Properties

Debug | R/O | Retrieve the debugging mode
Editing | R/O | Retrieve the editing mode
PIXmlDocument | T/O | property
ReportCompleted | R/W | Property ReportCompleted. To be set by the report composer engine (currently scripting) when a report is completed and ready to use.
ReportCustomiserEngine | T/O | property ReportCustomiserEngine
ReportDocument | T/O | property ReportDocument
templatesManager | T/O | property templatesManager
tm_error_str | R/O | property tm_error_str
tm_initialized | R/O | property tm_initialized
tm_MaximumTimeout | R/W | Configures maximum time for report creation, milliseconds


IrbReportVariables

IrbReportVariables - interface

Description

IrbReportVariables Interface

Properties

length | R/O | property length
name | R/O | property name
value | R/O | property value


IrbTemplatesManager

IrbTemplatesManager - interface

Description

IrbTemplatesManager Interface

Methods

client_add | method client_add
client_set_html_document | method client_set_html_document
client_set_template | method client_set_template
extract_variables | method extract_variables
getConfig | method getConfig
getParameters | Returns the available collection of id's as an XML document
getStyles | method getStyles
getTemplate | method getTemplate
getTemplateNoCache | returns a template as it is stored
locate_file | method locate_file
saveTemplate | Saves the provided template with the provided name

Properties

config_location | R/O | property config_location
error_str | R/O | property error_str
initialized | R/O | property initialized
ReportConfigName | R/O | method ReportConfigName


IRegPropertyBag

IRegPropertyBag - interface

Description

IRegPropertyBag Interface

Methods

Close | Closes the registry key.
Flush | Performs a flush on the open registry key.
Open | Opens a registry key to store properties in.
OpenSubKey | Opens a subkey of the open registry key.
Read | Reads a property from the open registry key.
ReadObjectAsBinaryStream | Initialises an instance of an object from a binary stream in the open registry key.
Write | Writes a property to the open registry key.
WriteObjectAsBinaryStream | Writes an object as a binary stream to the open registry key.

Properties

hKey | R/W | The handle to the open registry key. THIS PROPERTY SHOULD BE USED WITH CARE!
KeyOpen | R/O | True if the object has an open registry key.


IReportVariable

IReportVariable - interface

Description

IReportVariable Interface

Properties

ID | R/O | property ID
Name | R/W |
Value | R/W |


IReportVariables

IReportVariables - interface

Description

IReportVariables Interface

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual ReportVariable within the collection. Index can be an ordinal from 1 to Count or a string

Used in

ReportVariables
ReportVariables


IRPSConstraint

IRPSConstraint - interface

Description

IRPSConstraint Interface

Properties

Feature | R/W | set/retrieve the constrained feature
Index | R/O | index of the constraint
LockDirection | R/W | set/retrieve the lock state for plane /axis
LockX | R/W | set/retrieve the X coordinate lock state
LockY | R/W | set/retrieve the Y coordinate lock state
LockZ | R/W | set/retrieve the Z coordinate lock state
point | R/O | returns the nominal coordinates of the point in the RPS localDatum
type | R/O | Constraint type


IScanInstruction

IScanInstruction - interface

Description

IScanInstruction Interface

Methods

Copy | Copy the parameter object data to this object.
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.

Properties

CoordinateSystem | R/W | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
ScanInstructionType | R/O | The scan item-type.

Collections

PredictedPath Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.


IScanItem

IScanItem - interface

Description

IScanItem Interface

Properties

ScanItemFormat | R/O | The scan item format.
SurfacePoint | R/O | The surface point in the scanning path.
SurfaceVector | R/O | The nominal surface vector at the surface point.
Tag | R/W | Integer defining if the nth nominal point is assumed to be on the part surface (+1) or without contact to the surface (-1).


ScanItemFormat

ScanItemFormat - Read property

Description

The scan item format.

Syntax in Visual Basic or VBScript

ScanItemFormat () As ScanItemFormat

Syntax in C++

HRESULT get_ScanItemFormat (ScanItemFormat* retVal)

Applies to

ScanItem
ScanItemWithPrimary
ScanItemWithSecondary


SurfacePoint

SurfacePoint - Read property

Description

The surface point in the scanning path.

Syntax in Visual Basic or VBScript

SurfacePoint () As Point3D

Syntax in C++

HRESULT get_SurfacePoint (Point3D* retVal)

Applies to

ScanItem
ScanItemWithPrimary
ScanItemWithSecondary


SurfaceVector

SurfaceVector - Read property

Description

The nominal surface vector at the surface point.

Syntax in Visual Basic or VBScript

SurfaceVector () As Vector3D

Syntax in C++

HRESULT get_SurfaceVector (Vector3D* retVal)

Applies to

ScanItem
ScanItemWithPrimary
ScanItemWithSecondary


Tag

Tag - Read & Write property

Description

Integer defining if the nth nominal point is assumed to be on the part surface (+1) or without contact to the surface (-1).

Syntax in Visual Basic or VBScript

Tag () As Long

Syntax in C++

HRESULT get_Tag (LONG* retVal)
HRESULT put_Tag (LONG Value)

Applies to

ScanItem
ScanItemWithPrimary
ScanItemWithSecondary


IScanItems

IScanItems - interface

Description

IScanItems Interface

Methods

Clear | Remove all the scan items.
InsertScanItem | Insert an ordinary scan-item.
InsertScanItemWithPrimary | Insert a scan-item which contains a primary tool-vector.
InsertScanItemWithSecondary | Insert a scan-item which contains a both a primary and secondary tool-vector.
Remove | Remove the item at the specified position

Properties

Count | R/O | The number of scan-items
Item | R/O | Get the scan-item at the given index

Used in

PredictedPath
ScanItems


Count

Count - Read property

Description

The number of scan-items

Syntax in Visual Basic or VBScript

Count () As Long

Syntax in C++

HRESULT get_Count (LONG* retVal)

Applies to

ScanItems


Item

Item - Read property

Description

Get the scan-item at the given index

Syntax in Visual Basic or VBScript

Item (item_index As Long) As ScanItem

Syntax in C++

HRESULT get_Item (LONG item_index , ScanItem* retVal)

Applies to

ScanItems


Clear

Clear - event

Description

Remove all the scan items.

Syntax in Visual Basic or VBScript

Clear ()

Syntax in C++

HRESULT Clear ()

Applies to

ScanItems


InsertScanItem

InsertScanItem - event

Description

Insert an ordinary scan-item.

Syntax in Visual Basic or VBScript

InsertScanItem (ByRef surface_point As Point3D , ByRef surface_vector As Vector3D , Tag As Long , position As Long) As ScanItem

Syntax in C++

HRESULT InsertScanItem (Point3D* surface_point , Vector3D* surface_vector , LONG Tag , LONG position , ScanItem* retVal)

Parameters

Name | Description
surface_point |
surface_vector |
Tag |
position |
Return Value |

Applies to

ScanItems


InsertScanItemWithPrimary

InsertScanItemWithPrimary - event

Description

Insert a scan-item which contains a primary tool-vector.

Syntax in Visual Basic or VBScript

InsertScanItemWithPrimary (ByRef surface_point As Point3D , ByRef surface_vector As Vector3D , Tag As Long , ByRef primary_tool_vector As Vector3D , position As Long) As ScanItemWithPrimary

Syntax in C++

HRESULT InsertScanItemWithPrimary (Point3D* surface_point , Vector3D* surface_vector , LONG Tag , Vector3D* primary_tool_vector , LONG position , ScanItemWithPrimary* retVal)

Parameters

Name | Description
surface_point |
surface_vector |
Tag |
primary_tool_vector |
position |
Return Value |

Applies to

ScanItems


InsertScanItemWithSecondary

InsertScanItemWithSecondary - event

Description

Insert a scan-item which contains a both a primary and secondary tool-vector.

Syntax in Visual Basic or VBScript

InsertScanItemWithSecondary (ByRef surface_point As Point3D , ByRef surface_vector As Vector3D , Tag As Long , ByRef primary_tool_vector As Vector3D , ByRef secondary_tool_vector As Vector3D , position As Long) As ScanItemWithSecondary

Syntax in C++

HRESULT InsertScanItemWithSecondary (Point3D* surface_point , Vector3D* surface_vector , LONG Tag , Vector3D* primary_tool_vector , Vector3D* secondary_tool_vector , LONG position , ScanItemWithSecondary* retVal)

Parameters

Name | Description
surface_point |
surface_vector |
Tag |
primary_tool_vector |
secondary_tool_vector |
position |
Return Value |

Applies to

ScanItems


Remove

Remove - event

Description

Remove the item at the specified position

Syntax in Visual Basic or VBScript

Remove (atPos As Long)

Syntax in C++

HRESULT Remove (LONG atPos)

Parameters

Name | Description
atPos |

Applies to

ScanItems


IScanItemWithPrimary

IScanItemWithPrimary - interface

Description

IScanItemWithPrimary Interface

Properties

PrimaryToolDirection | R/O | The primary tool vector.
ScanItemFormat | R/O | The scan item format.
SurfacePoint | R/O | The surface point in the scanning path.
SurfaceVector | R/O | The nominal surface vector at the surface point.
Tag | R/W | Integer defining if the nth nominal point is assumed to be on the part surface (+1) or without contact to the surface (-1).


PrimaryToolDirection

PrimaryToolDirection - Read property

Description

The primary tool vector.

Syntax in Visual Basic or VBScript

PrimaryToolDirection () As Vector3D

Syntax in C++

HRESULT get_PrimaryToolDirection (Vector3D* retVal)

Applies to

ScanItemWithPrimary
ScanItemWithSecondary


IScanItemWithSecondary

IScanItemWithSecondary - interface

Description

IScanItemWithSecondary Interface

Properties

PrimaryToolDirection | R/O | The primary tool vector.
ScanItemFormat | R/O | The scan item format.
SecondaryToolDirection | R/O | The secondary tool vector.
SurfacePoint | R/O | The surface point in the scanning path.
SurfaceVector | R/O | The nominal surface vector at the surface point.
Tag | R/W | Integer defining if the nth nominal point is assumed to be on the part surface (+1) or without contact to the surface (-1).


SecondaryToolDirection

SecondaryToolDirection - Read property

Description

The secondary tool vector.

Syntax in Visual Basic or VBScript

SecondaryToolDirection () As Vector3D

Syntax in C++

HRESULT get_SecondaryToolDirection (Vector3D* retVal)

Applies to

ScanItemWithSecondary


IScanOnCircle

IScanOnCircle - interface

Description

IScanOnCircle Interface

Methods

Copy | Copy the parameter object data to this object.
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.

Properties

AngleToScan | R/W | The angle to scan.
Centre | R/O | The nominal centre point of the circle.
CoordinateSystem | R/W | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
Displacement | R/W | The maximum expected distance between the nominal circle center and the actual circle center.
Form | R/W | The maximum expected form deviation of the Gauss calculated circle.
Normal | R/O | The normal vector of the circle plane.
ScanInstructionType | R/O | The scan item-type.
ScanStart | R/O | The point on the circle radius where the scan starts.
StepW | R/W | The average angular distance between 2 measured points in degrees.
SurfaceAngle | R/W | The surface angle of the circle.

Collections

PredictedPath Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.


IScanOnCurve

IScanOnCurve - interface

Description

IScanOnCurve Interface

Methods

Copy | Copy the parameter object data to this object.
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.

Properties

Angle | R/W | The maximum angle between the 2 segments between the last 3 points.
AtNominals | R/W | VARIANT_TRUE if the arguments Distance and Angle are ignored.
Closed | R/W | Whether the contour is closed.
CoordinateSystem | R/W | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
Deviation | R/W | The maximum expected bias of measured data from the nominal data in the direction of the nominal direction vector.
distance | R/W | The maximum distance between 2 returned points.
MinRadiusOfCurvature | R/W | The prognostic minimum radius in the curve to measure. Only values greater zero are allowed.
ScanInstructionType | R/O | The scan item-type.
ScanItemFormat | R/O | Get the type of scan-item format stored. The format is set by the first item added.

Collections

PredictedPath | Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.
ScanItems | Get the list of scan-items contained in this item.


IScanOnHelix

IScanOnHelix - interface

Description

IScanOnHelix Interface

Methods

Copy | Copy the parameter object data to this object.
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.

Properties

AngleToScan | R/W | The angle to scan.
Centre | R/O | The nominal centre point of the helix.
CoordinateSystem | R/W | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
Lead | R/W | The lead in mm per 360 degrees rotation.
Normal | R/O | The normal vector of the helix plane.
ScanInstructionType | R/O | The scan item-type.
ScanStart | R/O | The point on the helix radius where the scan starts.
StepW | R/W | The average angular distance between 2 measured points in degrees.
SurfaceAngle | R/W | The surface angle of the helix (90 and 270 not allowed).

Collections

PredictedPath Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.


IScanOnLine

IScanOnLine - interface

Description

IScanOnLine Interface

Methods

Copy | Copy the parameter object data to this object.
TransformScanParametersFrom | Apply the transformation to the scan-instruction parameters.
TransformScanParametersTo | Apply the inverse transformation to the scan-instruction parameters.

Properties

Angle | R/W | The maximum expected angle between the nominal line and the actual line.
CoordinateSystem | R/W | The coordinate system the scan instruction is in (CAD or CMM probe-centre coordinates only).
EndPoint | R/O | The end point of the line.
Form | R/W | The maximum expected form deviation of the Gauss calculated line.
Normal | R/O | The surface normal vector.
ScanInstructionType | R/O | The scan item-type.
StartPoint | R/O | The start point of the line.
StepW | R/W | The average distance between 2 measured points in mms.

Collections

PredictedPath Get the list of scan-items contained in this item. Note: the predicted path is always in CAD.


ISecondaryDatumItem

ISecondaryDatumItem - interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
FeatureAxisX | R/O |
FeatureAxisY | R/O |
FeatureAxisZ | R/O |
FeatureDatum | R/O |
FeatureOrigin | R/O |
FeaturePlaneXY | R/O |
FeaturePlaneXZ | R/O |
FeaturePlaneYZ | R/O |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LocalCoordinateSystem | R/W | sets/retreieves the local coordinate system
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SupportsLocalCoordinateSystem | R/O | returns true if the entity supports a local coordinate system
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ISequenceGroup

ISequenceGroup - interface

Description

ISequenceGroup Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetExpanded | sets flag indicating group is expanded in the sequence tree
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
OutputToReport | R/W | get/set `output to report` flag
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
SequenceItems |
SequenceItemsForMeasure |


ISequenceItem

ISequenceItem - interface

Description

ISequenceItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


ISequenceItemIterator

ISequenceItemIterator - interface

Description

ISequenceItemIterator Interface

Methods

Reset method Reset

Properties

Count | R/O | returns the number of elements in the collection
cursor | R/W |
Document | R/W | property Document
Item | R/O | Allows random access to individual document within the collection. Index can be an ordinal from 1 to Count or a string
IteratorType | R/W | Put/Get iterator type as a combination of IteratorType types
UseActiveOnly | R/W | Put/Get using the active item only
UseRange | R/W | Put/Get controlling the range usage


ISequenceItems

ISequenceItems - interface

Description

ISequenceItems Interface

Methods

AddAlignment | method AddAlignment : Add a AddAlignment to this collection of sequence items
AddGeometricItem | method AddAlignment : Add a AddAlignment to this collection of sequence items
AddGroup | method AddGroup
AddItem | method AddItem : Add an item to this collection of sequence items
ImportPointCloudFile | Read a file file of point as a cloud, will generate one or more point clouds

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual SequenceItem within the collection. Index can be an ordinal from 1 to Count or a string

Used in

SequenceItems
SequenceItems
SequenceItemsForMeasure


ISequenceLink

ISequenceLink - interface

Description

ISequenceLink_base base Interface

Properties

Description | R/O | return a description of the feature in the current locale language
FeatureMask | R/O | return the mask for this link
Handle | R/O | return the internal handle of this link
Index | R/O | returns the index of this property in its parent collection
LinkType | R/O | return the type of the link (Simple/Multiple)
Name | R/O | return the name of the link
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the link cannot be modified

Collections

PossibleFeatures property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


ISequenceLinks

ISequenceLinks - interface

Description

ISequenceLinks Interface

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual Link within the collection. Index can be an ordinal from 1 to Count or a string

Used in

ConnectedLinks
Links


ISequenceMultipleLink

ISequenceMultipleLink - interface

Description

ISequenceMultipleLink Interface

Methods

Add | Add a feature to the list
Remove | Remove a feature to the list

Properties

Description | R/O | return a description of the feature in the current locale language
FeatureMask | R/O | return the mask for this link
Handle | R/O | return the internal handle of this link
Index | R/O | returns the index of this property in its parent collection
LinkType | R/O | return the type of the link (Simple/Multiple)
Name | R/O | return the name of the link
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the link cannot be modified

Collections

Features | get the colection of Features attached to this link
PossibleFeatures | property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


ISequenceReplayEngine

ISequenceReplayEngine - interface

Description

ISequenceReplayEngine Interface

Methods

EmergencyStop | cancel any pending action. current step is also cancelled
FullStop | Suspend the current action. Restart the current entity. Unlock the CMM.
GoBack | Move back at the start of the current entity or at the start of the previous entity
GoStep | do one step only
Rewind | set the curent step to be the first
Run | runs all steps up to the end
RunOnNewMeasure | Add a new measure inside PowerINSPECT , and start rerunning the sequence
RunSelectedItem | Runs the currently selected item
Suspend | Cancel any pending action. Current step is completed.

Properties

BUSY | R/O |
CMMProtocol | R/W | set the protocol
CurrentSequenceItem | R/O |
cursor | R/W |
Document | R/W | property Document
measure | R/W | property Measure
Mode | R/O |
NumberOfStep | R/O | returns the number of step for whole completion
status | R/O |


ISequenceReplayEngineCtrl

ISequenceReplayEngineCtrl - interface

Description

ISequenceReplayEngineCtrl Interface

Properties

Document | R/W | property Document
SequenceReplayEngine | R/W | property SequenceReplayEngine


ISequenceReplayValidator

ISequenceReplayValidator - interface

Description

ISequenceReplayValidator Interface

Methods

ErrorsInMarkedRange | Validate all sequence items in the marked range.
ErrorsWithActiveItem | Validate the active sequence item
ValidateActiveItem | Validate some or all sequence items, depending on the type of the active item.
ValidateAllItems | Validate all sequence items in the marked range.
ValidateMarkedRange | Validate all sequence items in the marked range.


ISequenceResult

ISequenceResult - interface

Description

ISequenceResult Interface

Properties

IsValid | R/O |
measure | R/O |
MeasureState | R/O | returns the measurement state
Parent | R/O |


ISequenceSimpleLink

ISequenceSimpleLink - interface

Description

ISequenceLink Interface

Properties

Description | R/O | return a description of the feature in the current locale language
Feature | R/W | put the Feature attached to this link
FeatureMask | R/O | return the mask for this link
Handle | R/O | return the internal handle of this link
Index | R/O | returns the index of this property in its parent collection
LinkType | R/O | return the type of the link (Simple/Multiple)
Name | R/O | return the name of the link
Parent | R/O | return ISequence Item that owns this feature
ReadOnly | R/O | return true if the link cannot be modified
Reversed | R/W | sets/retrieves the reverse flag of the link
Reversible | R/O | returns if the link can support reversed features

Collections

PossibleFeatures property PossibleFeatures : retrieve the collection of all possible entities that could be connected to this link


ISimpleProbeDatabase

ISimpleProbeDatabase - interface

Description

ISimpleProbeDatabase Interface

Methods

ActivateSensor |
CalibrateActiveSensor | brings a user interface to allow the active sensor to be calibrated
Compensate | get the compemsate coordinates according the active sensor
EditDatabase | brings a user dialog box to allow the underlying probe database to be managed
EditSensor |
Load | Load the probe database, stream could be a BSTR
ReconcileSensor |
Save | Save the probe database, if stream is null then the last known filename is used
Uncompensate | get the compemsate coordinates according the active sensor

Properties

ActiveSensorName | R/O | returns the name of the current active sensor
ActiveSensorType | R/O | returns the type of the current active sensor
Property | R/O |
Protocol | R/O | sets/retrieves the protocol that actually controls this carriage
SensorProperty | R/O |


ISurfaceGroup

ISurfaceGroup - interface

Description

ISequenceGroup Interface

Methods

AddCMMPoint | OBSOLETE : Add a single CMMPoint ( probe offset compensation will not apply
AddCMMPoints |
ApplyOffsetNow |
ApplyToleranceNow |
Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
RenumberPointNow |
ReplayWithPoints | Replay the elements with the given points
SetExpanded | sets flag indicating group is expanded in the sequence tree
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
Statistics | not yet implemented
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
Counter | R/W |
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
EdgeOffset | R/W |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Label | R/W |
LowerTolerance | R/W |
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
MinimumNumberOfPoints | R/W | Minimum number of points to make the measurement valid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
OutputToReport | R/W | get/set `output to report` flag
PeckerStrategy | R/W | returns the Pecker Strategy object
PointType | R/W |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
Step | R/W |
SurfaceGroupType | R/W |
SurfaceOffset | R/W |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W |
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
SequenceItems |
SequenceItemsForMeasure |


ISurfacePoint

ISurfacePoint - interface

Description

ISurfacePoint Interface

Properties

Normal | R/O |
point | R/O |
Surface | R/O | NOT YET IMPLEMENTED
SurfaceName | R/O | Name of a surface
SurfID | R/O |
U | R/O |
V | R/O |


Normal

Normal - Read property

Syntax in Visual Basic or VBScript

Normal () As UnitVector3D

Syntax in C++

HRESULT get_Normal (UnitVector3D* retVal)

Applies to

ISurfacePoint


Surface

Surface - Read property

Description

NOT YET IMPLEMENTED

Syntax in Visual Basic or VBScript

Surface () As ICADEntity

Syntax in C++

HRESULT get_Surface (ICADEntity* retVal)

Applies to

ISurfacePoint


SurfaceName

SurfaceName - Read property

Description

Name of a surface

Syntax in Visual Basic or VBScript

SurfaceName () As String

Syntax in C++

HRESULT get_SurfaceName (BSTR* retVal)

Applies to

ISurfacePoint


ISurfacePointItem

ISurfacePointItem - interface

Description

ISurfacePointItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
MeasuredPoint | the measured surface point for the given measure
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
LowerTolerance | R/W |
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
PointType | R/W |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
SurfaceOffset | R/W |
TargetPoint | R/O |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W |
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
ResultStack | stack of results for the given measure


ISurfacePointResult

ISurfacePointResult - interface

Description

ISurfacePointResult Interface

Properties

ContactPoint | R/O | the coordinates of the point of the probe that touch the actual surface
Deviation | R/O | the true length deviation
DeviationVector | R/O | the deviation vector
IsValid | R/O |
measure | R/O |
MeasureState | R/O | returns the measurement state
Parent | R/O |
ProbeCenter | R/O | the coordinates of the probe center in CADCoordinates
ProbeClearanceVector | R/O | the coordinates of the CMM point vector in CAD Coordinates
ProbeDiameter | R/W | the probe diameter
SurfacePoint | R/O | the information on the projected point


ISurfacePointResultStack

ISurfacePointResultStack - interface

Description

ISurfacePointResultStack - a collection of SurfacePointResult objects

Properties

Count | R/W | Indicates the number of items in the collection.
Item | R/O | Allows random access to individual points. Index can be an ordinal from 1 to Count or a string

Used in

ResultStack


ISurfaceSectionGroup

ISurfaceSectionGroup - interface

Description

ISurfaceSectionGroup Interface

Methods

AddCMMPoint | OBSOLETE : Add a single CMMPoint ( probe offset compensation will not apply
AddCMMPoints |
ApplyOffsetNow |
ApplyToleranceNow |
Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
RenumberPointNow |
ReplayWithPoints | Replay the elements with the given points
SetExpanded | sets flag indicating group is expanded in the sequence tree
SetSectionParameters | set the parameter of the section plane
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
Statistics | not yet implemented
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
Counter | R/W |
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
EdgeOffset | R/W |
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
Label | R/W |
LowerTolerance | R/W |
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
MinimumNumberOfPoints | R/W | Minimum number of points to make the measurement valid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
OutputToReport | R/W | get/set `output to report` flag
PeckerStrategy | R/W | returns the Pecker Strategy object
PointType | R/W |
ResultValid | R/O | return TRUE if this element is Valid for the given measure
Step | R/W |
SurfaceGroupType | R/W |
SurfaceOffset | R/W |
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
UpperTolerance | R/W |
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |
SequenceItems |
SequenceItemsForMeasure |


ITemperedTrackingPoints

ITemperedTrackingPoints - interface

Description

ITemperedTrackingPoints Interface

Properties

CMMProtocol | R/W | CMMProtocol object to collect tracking points from
CMMProtocol | W/O | CMMProtocol object to collect tracking points from
TrackingInterval | R/W | Minimum interval (in ms) at which tracking points are sent


IToolChanger

IToolChanger - interface

Description

IToolChanger Interface

Methods

ChangeTool | request a tool changing ( could be a asynchronous operation)
FillIdentityCard | fill the node with the identity card of this item

Properties

_ID | R/W | INTERNAL USE ONLY
Calibration | R/O | retrieves the calibration object
Carriage | R/O | returns the carriage on which this ToolChanger is based
ChangeSilently | R/W | Returns TRUE if the changer is in Silent mode. Silent means No message boxes or prompts are used during ctool changes.
FullName | R/O | retrieves the full name of this object ( this includes the identifiers of the owner object
ID | R/O | sets the internal id of the object that identifies this item unicaly
IdentityCard | R/O | retrieves the identity card for the item
InterfaceType | R/O |
Status | R/O | retreives the status of the tool changer module
ThreadID | R/O |
ToolChangerType | R/O | returns the type of this ToolChanger
UserName | R/W | sets/retrieves the user name of the object, this name could be freely defined by the user


ITrackerCommand

ITrackerCommand - interface

Description

ITrackerCommand Interface

Methods

Abort
ChangeTarget
ConfigChanged
Connect
Disconnect
EnvironmentUpdate
GoDefaultHome
Initialise
LevelToGravity
Motors
PointLaser
Scan
Search
Sight
TakeManualPoint
TakeStaticPoint


ITransform

ITransform - interface

Description

ITransform Interface

Methods

CreateRotation | Create a rotation of the specified angle ( in degree) around one axis ( through the origin )
CreateRotationAtPoint | Create a rotation of the specified angle ( in degree) around one axis ( defined with a vector and a point )
CreateTransform | Create a transformation with 2 vectors and an origin
CreateTransform1V | Create a transformation with a single vector and an origin
CreateTranslation | Create a translation
TransformFrom |
TransformTo |

Properties

From | R/O
To | R/O


From

From - Read property

Syntax in Visual Basic or VBScript

From (vectorOrPoint As Variant) As Variant

Syntax in C++

HRESULT get_From (VARIANT vectorOrPoint , VARIANT* retVal)

Applies to

transform
ITransform2


To

To - Read property

Syntax in Visual Basic or VBScript

To (vectorOrPoint As Variant) As Variant

Syntax in C++

HRESULT get_To (VARIANT vectorOrPoint , VARIANT* retVal)

Applies to

transform
ITransform2


CreateRotation

CreateRotation - method

Description

Create a rotation of the specified angle ( in degree) around one axis ( through the origin )

Syntax in Visual Basic or VBScript

CreateRotation (axis As Variant , angleDegree As Double)

Syntax in C++

HRESULT CreateRotation (VARIANT axis , double angleDegree)

Parameters

Name | Description
axis |
angleDegree |

Applies to

transform


CreateRotationAtPoint

CreateRotationAtPoint - method

Description

Create a rotation of the specified angle ( in degree) around one axis ( defined with a vector and a point )

Syntax in Visual Basic or VBScript

CreateRotationAtPoint (axis As Variant , fixedPoint As Variant , angleDegree As Double)

Syntax in C++

HRESULT CreateRotationAtPoint (VARIANT axis , VARIANT fixedPoint , double angleDegree)

Parameters

Name | Description
axis |
fixedPoint |
angleDegree |

Applies to

transform


CreateTransform

CreateTransform - method

Description

Create a transformation with 2 vectors and an origin

Syntax in Visual Basic or VBScript

CreateTransform (vectorX As Variant , vectorY As Variant , origin As Variant)

Syntax in C++

HRESULT CreateTransform (VARIANT vectorX , VARIANT vectorY , VARIANT origin)

Parameters

Name | Description
vectorX |
vectorY |
origin |

Applies to

transform


CreateTransform1V

CreateTransform1V - method

Description

Create a transformation with a single vector and an origin

Syntax in Visual Basic or VBScript

CreateTransform1V (vectorX As Variant , origin As Variant)

Syntax in C++

HRESULT CreateTransform1V (VARIANT vectorX , VARIANT origin)

Parameters

Name | Description
vectorX |
origin |

Applies to

transform


CreateTranslation

CreateTranslation - method

Description

Create a translation

Syntax in Visual Basic or VBScript

CreateTranslation (vector As Variant)

Syntax in C++

HRESULT CreateTranslation (VARIANT vector)

Parameters

Name | Description
vector |

Applies to

transform


TransformFrom

TransformFrom - method

Syntax in Visual Basic or VBScript

TransformFrom (ByRef vectorOrPoint As Variant)

Syntax in C++

HRESULT TransformFrom (VARIANT* vectorOrPoint)

Parameters

Name | Description
vectorOrPoint |

Applies to

transform


TransformTo

TransformTo - method

Syntax in Visual Basic or VBScript

TransformTo (ByRef vectorOrPoint As Variant)

Syntax in C++

HRESULT TransformTo (VARIANT* vectorOrPoint)

Parameters

Name | Description
vectorOrPoint |

Applies to

transform


ITransform2

ITransform2 - interface

Description

ITransform2 Interface : (an extended Transform that gives more information about the internal vectors )

Methods

CreateCopy |
CreateRotation | Create a rotation of the specified angle ( in degree) around one axis ( through the origin )
CreateRotationAtPoint | Create a rotation of the specified angle ( in degree) around one axis ( defined with a vector and a point )
CreateTransform | Create a transformation with 2 vectors and an origin
CreateTransform1V | Create a transformation with a single vector and an origin
CreateTranslation | Create a translation
Scale | scale the translation component by the specified amount
TransformFrom |
TransformTo |

Properties

EX | R/O | Euler Angle X in radian
EY | R/O | Euler Angle Y in radian
EZ | R/O | Euler Angle Z in radian
From | R/O |
origin | R/O | Origin
To | R/O |
vX | R/O | VX
vY | R/O | VY
vZ | R/O | VZ


EX

EX - Read property

Description

Euler Angle X in radian

Syntax in Visual Basic or VBScript

EX () As Double

Syntax in C++

HRESULT get_EX (double* retVal)

Applies to

ITransform2


EY

EY - Read property

Description

Euler Angle Y in radian

Syntax in Visual Basic or VBScript

EY () As Double

Syntax in C++

HRESULT get_EY (double* retVal)

Applies to

ITransform2


EZ

EZ - Read property

Description

Euler Angle Z in radian

Syntax in Visual Basic or VBScript

EZ () As Double

Syntax in C++

HRESULT get_EZ (double* retVal)

Applies to

ITransform2


origin

origin - Read property

Description

Origin

Syntax in Visual Basic or VBScript

origin () As Point3D

Syntax in C++

HRESULT get_origin (Point3D* retVal)

Applies to

ITransform2


vX

vX - Read property

Description

VX

Syntax in Visual Basic or VBScript

vX () As UnitVector3D

Syntax in C++

HRESULT get_vX (UnitVector3D* retVal)

Applies to

ITransform2


vY

vY - Read property

Description

VY

Syntax in Visual Basic or VBScript

vY () As UnitVector3D

Syntax in C++

HRESULT get_vY (UnitVector3D* retVal)

Applies to

ITransform2


vZ

vZ - Read property

Description

VZ

Syntax in Visual Basic or VBScript

vZ () As UnitVector3D

Syntax in C++

HRESULT get_vZ (UnitVector3D* retVal)

Applies to

ITransform2


CreateCopy

CreateCopy - method

Syntax in Visual Basic or VBScript

CreateCopy (transform As Variant)

Syntax in C++

HRESULT CreateCopy (VARIANT transform)

Parameters

Name | Description
transform |

Applies to

ITransform2


Scale

Scale - method

Description

scale the translation component by the specified amount

Syntax in Visual Basic or VBScript

Scale (Value As Double)

Syntax in C++

HRESULT Scale (double Value)

Parameters

Name | Description
Value |

Applies to

ITransform2


ITransformDefinition

ITransformDefinition - interface

Description

the ITransformDefinition interface

Methods

Load | load the definition matrix from a .MAT file
Save | save the definition matrix from a .MAT file

Properties

transform R/O get the transformation matrix


ITypeDesc

ITypeDesc - interface

Description

ITypeDesc Interface

Properties

CPPTypeStr | R/O |
PointerDesc | R/O | Returns a TypeInformation object with more information about the VT_USERDEFINED type.
Type | R/O | Returns the type as combination of VARENUM.
UserDefinedDesc | R/O | Returns a TypeInformation object with more information about the VT_USERDEFINED type.
VBTypeStr | R/O |


ITypeInformation

ITypeInformation - interface

Description

ITypeInformation Interface

Properties

Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.


ITypeLibrary

ITypeLibrary - interface

Description

ITypeLibrary Interface

Methods

EnumValueAsString | resolve a enum value into a string
FindEnum | find a enum by name

Properties

Documentation | R/O | property Documentation
FullPathname | R/O | property FullPathname
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
LocaleID | R/O | property LocaleID
MajorVersion | R/O | property MajorVersion
MinorVersion | R/O | property MinorVersion
Name | R/W | property Name

Collections

TypeInfos property TypeInfos


IUnitConverter

IUnitConverter - interface

Description

IUnitConverter Interface

Methods

Convert
LoadUnitFile
UNITTYPE


IUnitVector3D

IUnitVector3D - interface

Description

IUnitVector3D Interface

Methods

GetCoordinates | retreives the 3 coordinates ( cartesian ) in one round trip ( this version cannot be used in scripts )
GetCoordinatesV | retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )
Reverse | Reverse the vector
SetApparentAngles | set the ABC coordinates of the vector
SetAzimuthElevation | set the Azimuth and Elevation of the vector , keeping the length
SetCoordinates | set the IJK coordinates of the vector ( coordinates will be unified)
TransformFrom | Transformation of points
TransformTo | Transformation of points

Properties

A | R/O | retrieve the A angle of the vector (angle in the XY plane)
Azimuth | R/W | retrieve the Azimuth angle of the vector
B | R/O | retrieve the B angle of the vector (angle in the YZ plane)
C | R/O | retrieve the C angle of the vector (angle in the ZX plane)
Elevation | R/W | retrieve the Elevation angle coordinate of the vector
I | R/W | retrieve the I coordinate of the vector
J | R/W | retrieve the J coordinate of the vector
K | R/W | retrieve the K coordinate of the vector
Magnitude | R/W | get the Magnitude of the vector ( Third Spherical Coordinate)
Value | R/W |


A

A - Read property

Description

retrieve the A angle of the vector (angle in the XY plane)

Syntax in Visual Basic or VBScript

A () As Double

Syntax in C++

HRESULT get_A (double* retVal)

Applies to

UnitVector3D
Vector3D


Azimuth

Azimuth - Read & Write property

Description

retrieve the Azimuth angle of the vector

Syntax in Visual Basic or VBScript

Azimuth () As Double

Syntax in C++

HRESULT get_Azimuth (double* retVal)
HRESULT put_Azimuth (double Value)

Applies to

UnitVector3D
Vector3D


B

B - Read property

Description

retrieve the B angle of the vector (angle in the YZ plane)

Syntax in Visual Basic or VBScript

B () As Double

Syntax in C++

HRESULT get_B (double* retVal)

Applies to

UnitVector3D
Vector3D


C

C - Read property

Description

retrieve the C angle of the vector (angle in the ZX plane)

Syntax in Visual Basic or VBScript

C () As Double

Syntax in C++

HRESULT get_C (double* retVal)

Applies to

UnitVector3D
Vector3D


Elevation

Elevation - Read & Write property

Description

retrieve the Elevation angle coordinate of the vector

Syntax in Visual Basic or VBScript

Elevation () As Double

Syntax in C++

HRESULT get_Elevation (double* retVal)
HRESULT put_Elevation (double Value)

Applies to

UnitVector3D
Vector3D


I

I - Read & Write property

Description

retrieve the I coordinate of the vector

Syntax in Visual Basic or VBScript

I () As Double

Syntax in C++

HRESULT get_I (double* retVal)
HRESULT put_I (double Value)

Applies to

UnitVector3D
Vector3D


J

J - Read & Write property

Description

retrieve the J coordinate of the vector

Syntax in Visual Basic or VBScript

J () As Double

Syntax in C++

HRESULT get_J (double* retVal)
HRESULT put_J (double Value)

Applies to

UnitVector3D
Vector3D


K

K - Read & Write property

Description

retrieve the K coordinate of the vector

Syntax in Visual Basic or VBScript

K () As Double

Syntax in C++

HRESULT get_K (double* retVal)
HRESULT put_K (double Value)

Applies to

UnitVector3D
Vector3D


Magnitude

Magnitude - Read & Write property

Description

get the Magnitude of the vector ( Third Spherical Coordinate)

Syntax in Visual Basic or VBScript

Magnitude () As Double

Syntax in C++

HRESULT get_Magnitude (double* retVal)
HRESULT put_Magnitude (double Value)

Applies to

UnitVector3D
Vector3D


GetCoordinates

GetCoordinates - method

Description

retreives the 3 coordinates ( cartesian ) in one round trip ( this version cannot be used in scripts )

Syntax in Visual Basic or VBScript

GetCoordinates (ByRef pI As Double , ByRef pJ As Double , ByRef pK As Double)

Syntax in C++

HRESULT GetCoordinates (double* pI , double* pJ , double* pK)

Parameters

Name | Description
pI |
pJ |
pK |

Applies to

UnitVector3D


GetCoordinatesV

GetCoordinatesV - method

Description

retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )

Syntax in Visual Basic or VBScript

GetCoordinatesV (ByRef pX As Variant , ByRef pY As Variant , ByRef pZ As Variant)

Syntax in C++

HRESULT GetCoordinatesV (VARIANT* pX , VARIANT* pY , VARIANT* pZ)

Parameters

Name | Description
pX |
pY |
pZ |

Applies to

Vector3D


Reverse

Reverse - method

Description

Reverse the vector

Syntax in Visual Basic or VBScript

Reverse ()

Syntax in C++

HRESULT Reverse ()

Applies to

UnitVector3D


SetApparentAngles

SetApparentAngles - method

Description

set the ABC coordinates of the vector

Syntax in Visual Basic or VBScript

SetApparentAngles (A As Double , B As Double , C As Double)

Syntax in C++

HRESULT SetApparentAngles (double A , double B , double C)

Parameters

Name | Description
A |
B |
C |

Applies to

Vector3D


SetAzimuthElevation

SetAzimuthElevation - method

Description

set the Azimuth and Elevation of the vector , keeping the length

Syntax in Visual Basic or VBScript

SetAzimuthElevation (Azimuth As Double , Elevation As Double)

Syntax in C++

HRESULT SetAzimuthElevation (double Azimuth , double Elevation)

Parameters

Name | Description
Azimuth |
Elevation |

Applies to

Vector3D


SetCoordinates

SetCoordinates - method

Description

set the IJK coordinates of the vector ( coordinates will be unified)

Syntax in Visual Basic or VBScript

SetCoordinates (I As Double , J As Double , K As Double)

Syntax in C++

HRESULT SetCoordinates (double I , double J , double K)

Parameters

Name | Description
I |
J |
K |

Applies to

Vector3D


IVarDesc

IVarDesc - interface

Description

ICoClass Interface

Properties

CPPType | R/O |
Documentation | R/O | property Documentation
GUIDAsString | R/O | property GUIDAsString
HelpContext | R/O | property HelpContext
HelpFile | R/O | property HelpFile
Name | R/W | property Name
type | R/W |
TypeFlags | R/O | Returns TYPEFLAGS
TypeInfo | R/O | property TypeInfo
TypeInfoKind | R/O | Returns TYPEKIND.
VBType | R/O |


IVector3D

IVector3D - interface

Description

IVector3D Interface

Methods

GetCoordinates | retreives the 3 coordinates ( cartesian ) in one round trip
GetCoordinatesV | retreives the 3 coordinates ( cartesian ) in one round trip ( this version *IS* scriptable )
Scale | scale this vector by a factor
SetApparentAngles | set the ABC coordinates of the vector
SetAzimuthElevation | set the Azimuth and Elevation of the vector , keeping the length
SetCoordinates | set the IJK coordinates of the vector ( coordinates will be unified)
SetPolarCoordinates | set the Polar coordinates (Angle,Radius,Height) of the vector
SetSphericalCoordinates | set the Spherical coordinates (Azimuth,Elevation,Magnitude) of the vector
TransformFrom | Transformation of points
TransformTo | Transformation of points
Unify | make this vector a unit vector

Properties

A | R/O | retrieve the A angle of the vector (angle in the XY plane)
Azimuth | R/W | retrieve the Azimuth angle of the vector
B | R/O | retrieve the B angle of the vector (angle in the YZ plane)
C | R/O | retrieve the C angle of the vector (angle in the ZX plane)
Elevation | R/W | retrieve the Elevation angle coordinate of the vector
I | R/W | retrieve the I coordinate of the vector
J | R/W | retrieve the J coordinate of the vector
K | R/W | retrieve the K coordinate of the vector
Magnitude | R/W | get the Magnitude of the vector ( Third Spherical Coordinate)
Value | R/W |


GetCoordinates

GetCoordinates - method

Description

retreives the 3 coordinates ( cartesian ) in one round trip

Syntax in Visual Basic or VBScript

GetCoordinates (ByRef pI As Double , ByRef pJ As Double , ByRef pK As Double)

Syntax in C++

HRESULT GetCoordinates (double* pI , double* pJ , double* pK)

Parameters

Name | Description
pI |
pJ |
pK |

Applies to

Vector3D


Scale

Scale - method

Description

scale this vector by a factor

Syntax in Visual Basic or VBScript

Scale (factor As Double)

Syntax in C++

HRESULT Scale (double factor)

Parameters

Name | Description
factor |

Applies to

Vector3D


SetPolarCoordinates

SetPolarCoordinates - method

Description

set the Polar coordinates (Angle,Radius,Height) of the vector

Syntax in Visual Basic or VBScript

SetPolarCoordinates (Angle As Double , Radius As Double , Height As Double)

Syntax in C++

HRESULT SetPolarCoordinates (double Angle , double Radius , double Height)

Parameters

Name | Description
Angle |
Radius |
Height |

Applies to

Vector3D


SetSphericalCoordinates

SetSphericalCoordinates - method

Description

set the Spherical coordinates (Azimuth,Elevation,Magnitude) of the vector

Syntax in Visual Basic or VBScript

SetSphericalCoordinates (Azimuth As Double , Elevation As Double , Magnitude As Double)

Syntax in C++

HRESULT SetSphericalCoordinates (double Azimuth , double Elevation , double Magnitude)

Parameters

Name | Description
Azimuth |
Elevation |
Magnitude |

Applies to

Vector3D


Unify

Unify - method

Description

make this vector a unit vector

Syntax in Visual Basic or VBScript

Unify ()

Syntax in C++

HRESULT Unify ()

Applies to

Vector3D


IVerticeSelectionManager

IVerticeSelectionManager - interface

Description

IVerticeSelectionManager Interface

Methods

Activate | enter the Geometry Explorer mode
Cancel | exit the Geometry Explorer

Properties

Count | R/O | indicates the number selected vertex
Filter | R/W | set/retrieve the filter type / pwicetUNSPECIFIED if no filter
Item | R/O | Allows random access to individual Vertex within the collection. Index can be an ordinal from 1 to Count or a string
Mode | R/W | set/retrieve the geometry explorer mode
Parent | T/O | indicates the parent of this object : a PowerINSPECT Document

Used in

VerticeSelectionManager


IWebScreen

IWebScreen - interface

Description

IWebScreen Interface

Methods

CallScript | method CallScript
Export | method Export
Print | method Print
RefreshReport | Force the current showing report to be re-generated
ReportSettings | Returns XML reported by report engine about settings of report
ShowPageSetup | method ShowPageSetup
ShowPrintPreview | method ShowPrintPreview

Properties

DHTMLBridge | R/O | property DHTMLBridge
Editing | R/W | Set/Retrieve the editing mode
IsReportReady | R/O | property IsReportReady
MaximumTimeout | R/W | Configures maximum time for report creation, milliseconds
PIXmlDocument | R/W | property PIXmlDocument
RegistryOptionPath | R/O | Returns registry subpath of HCKU where used settings of IE are contained
ReportConfigName | R/W | property ReportConfigName
templatesManager | R/W | Allows to set/get template manager object for this report document
WebBrowser | T/O | property WebBrowser


IWorkplaneItem

IWorkplaneItem - interface

Description

IWorkplaneItem Interface

Methods

Clone | Create a new sequence item which has all the same properties as this one
CopyMeasure | Copy the result of the item from one measure to the other
Delete | Delete the item. this method may failed if the item is already referenced
Duplicate | Duplicate the item ( in the same group) and returns a pointer on the copy
GetCMMPointArray | retrieves the CMMPoint that were used to measure this item into a SafeArray
GetCMMPointDeviation | Retrieves the deviations for each received CMMPoint into a SafeArray
GetCMMtoLocalTransform | request the Transformation to convert from CMM coordinate to the local coordinate system on which the probe path associated with this item is defined
Invalidate | invalid the item result for the given measure
IsA | Check if this object implements the interface of PWI_SequenceItemInterfaceType type
Move | Move the item into a different location ( either within the same group or into a different group)
Refresh | Refresh: this method update this elements and all related items on the PowerINSPECT GUI
ReplayWithPoints | Replay the elements with the given points
SetupNominalsFromMeasure | Set up the nominals for this entity from the specified measure ( if a valide measure is specified ) or from the related nominals entity if no measure is specified
TransformationFrom | Returns transformation matrix to convert coordinates from the specified Workplane to the coordinates system of this Workplane
TransformationTo | Returns transformation matrix to convert coordinates from this Workplane to the coordinates system of the specified workplane
UpdateProbePath | request the recalculation of the probepath from the strategy object
XMLOutput | XMLOutput

Properties

AcceptPoints | R/O | return TRUE if this element can be probed and thus can accept CMMPoints
CanContainCNCProbePath | R/O | returns TRUE if this item is a good candidate to own a CNC Probe Path Item
CNCProbePath | R/W | returns the CNC Probe Path object associated with this item
CNCProbePathFaults | T/O | returns the CNC-Probe-Path Faults object associated with this item
CNCProbingStrategy | R/W | returns the CNC Probing strategy object associated with this item
Comment | R/W | Get/Set an arbitrary comment string for an item.
ContainsMachineConfiguration | R/O | Whether this item contains a machine orientation that sets the machine orientation for the sequence items below it.
DefinitionDatumItem | R/O | request the SequenceItem which represents the datum on which this element is defined
Document | R/O | returns the associated document for this item
Group | R/O | return the group which own this element or nothing
Index | R/O | get the current index of the item within its parent container
InterfaceType | R/O | return a combination of PWI_SequenceItemInterfaceType that describes which interfaces this element supports
ItemType | R/O | return the type of the element ( could be one constant from
MachineConfiguration | R/W | The machine orientation that will be used to set the machine orientation for the sequence items below it.
MeasureDate | R/O | returns the last date this elements has been defined for the specified measure
MeasureState | R/O | returns the measurement state / see also ResultValid
Name | R/W | return the name of the element
NominalEntityFlag | R/O | returns the method that this entity is using to be defined from nominals
ResultValid | R/O | return TRUE if this element is Valid for the given measure
UniqueID | R/O | returns a unique Identifier (ID) of this ISequenceItem, this ID is unique within the same document and never changed during the timelife of the SequenceItem
Visible | R/W | return the current state of the visible flag

Collections

Features | return a collection of feature that this element provides
Links | return a collection of links that need to be defined for this entity
Parameters | return a collection of parameters that defined the entity
Properties |


IXMLDOMAttribute

IXMLDOMAttribute - interface

Methods

appendChild | append a child node
cloneNode |
hasChildNodes |
insertBefore | insert a child node
removeChild | remove a child node
replaceChild | replace a child node
selectSingleNode | execute query on the subtree
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
name | R/O | get name of the attribute
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
Value | R/W | string value of the attribute
xml | R/O | return the XML source for the node and each of its descendants

Collections

selectNodes execute query on the subtree


attributes

attributes - Read property

Description

the collection of the node's attributes

Syntax in Visual Basic or VBScript

attributes () As IXMLDOMNamedNodeMap

Syntax in C++

HRESULT get_attributes (IXMLDOMNamedNodeMap* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


baseName

baseName - Read property

Description

the base name of the node (nodename with the prefix stripped off)

Syntax in Visual Basic or VBScript

baseName () As String

Syntax in C++

HRESULT get_baseName (BSTR* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


childNodes

childNodes - Read property

Description

the collection of the node's children

Syntax in Visual Basic or VBScript

childNodes () As IXMLDOMNodeList

Syntax in C++

HRESULT get_childNodes (IXMLDOMNodeList* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


dataType

dataType - Read & Write property

Description

the data type of the node

Syntax in Visual Basic or VBScript

dataType () As Variant

Syntax in C++

HRESULT get_dataType (VARIANT* retVal)
HRESULT put_dataType (BSTR Value)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


definition

definition - Read property

Description

pointer to the definition of the node in the DTD or schema

Syntax in Visual Basic or VBScript

definition () As IXMLDOMNode

Syntax in C++

HRESULT get_definition (IXMLDOMNode* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


firstChild

firstChild - Read property

Description

first child of the node

Syntax in Visual Basic or VBScript

firstChild () As IXMLDOMNode

Syntax in C++

HRESULT get_firstChild (IXMLDOMNode* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


lastChild

lastChild - Read property

Description

first child of the node

Syntax in Visual Basic or VBScript

lastChild () As IXMLDOMNode

Syntax in C++

HRESULT get_lastChild (IXMLDOMNode* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


name

name - Read property

Description

get name of the attribute

Syntax in Visual Basic or VBScript

name () As String

Syntax in C++

HRESULT get_name (BSTR* retVal)

Applies to

IXMLDOMAttribute


namespaceURI

namespaceURI - Read property

Description

the URI for the namespace applying to the node

Syntax in Visual Basic or VBScript

namespaceURI () As String

Syntax in C++

HRESULT get_namespaceURI (BSTR* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


nextSibling

nextSibling - Read property

Description

right sibling of the node

Syntax in Visual Basic or VBScript

nextSibling () As IXMLDOMNode

Syntax in C++

HRESULT get_nextSibling (IXMLDOMNode* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


nodeName

nodeName - Read property

Description

name of the node

Syntax in Visual Basic or VBScript

nodeName () As String

Syntax in C++

HRESULT get_nodeName (BSTR* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


nodeType

nodeType - Read property

Description

the node's type

Syntax in Visual Basic or VBScript

nodeType () As DOMNodeType

Syntax in C++

HRESULT get_nodeType (DOMNodeType* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


nodeTypedValue

nodeTypedValue - Read & Write property

Description

get the strongly typed value of the node

Syntax in Visual Basic or VBScript

nodeTypedValue () As Variant

Syntax in C++

HRESULT get_nodeTypedValue (VARIANT* retVal)
HRESULT put_nodeTypedValue (VARIANT Value)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


nodeTypeString

nodeTypeString - Read property

Description

the type of node in string form

Syntax in Visual Basic or VBScript

nodeTypeString () As String

Syntax in C++

HRESULT get_nodeTypeString (BSTR* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


nodeValue

nodeValue - Read & Write property

Description

value stored in the node

Syntax in Visual Basic or VBScript

nodeValue () As Variant

Syntax in C++

HRESULT get_nodeValue (VARIANT* retVal)
HRESULT put_nodeValue (VARIANT Value)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


ownerDocument

ownerDocument - Read property

Description

document that contains the node

Syntax in Visual Basic or VBScript

ownerDocument () As IXMLDOMDocument

Syntax in C++

HRESULT get_ownerDocument (IXMLDOMDocument* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


parentNode

parentNode - Read property

Description

parent of the node

Syntax in Visual Basic or VBScript

parentNode () As IXMLDOMNode

Syntax in C++

HRESULT get_parentNode (IXMLDOMNode* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


parsed

parsed - Read property

Description

has sub-tree been completely parsed

Syntax in Visual Basic or VBScript

parsed () As Boolean

Syntax in C++

HRESULT get_parsed (VARIANT_BOOL* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


prefix

prefix - Read property

Description

the prefix for the namespace applying to the node

Syntax in Visual Basic or VBScript

prefix () As String

Syntax in C++

HRESULT get_prefix (BSTR* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


previousSibling

previousSibling - Read property

Description

left sibling of the node

Syntax in Visual Basic or VBScript

previousSibling () As IXMLDOMNode

Syntax in C++

HRESULT get_previousSibling (IXMLDOMNode* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


specified

specified - Read property

Description

indicates whether node is a default value

Syntax in Visual Basic or VBScript

specified () As Boolean

Syntax in C++

HRESULT get_specified (VARIANT_BOOL* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


text

text - Read & Write property

Description

text content of the node and subtree

Syntax in Visual Basic or VBScript

text () As String

Syntax in C++

HRESULT get_text (BSTR* retVal)
HRESULT put_text (BSTR Value)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


Value

Value - Read & Write property

Description

string value of the attribute

Syntax in Visual Basic or VBScript

Value () As Variant

Syntax in C++

HRESULT get_Value (VARIANT* retVal)
HRESULT put_Value (VARIANT Value)

Applies to

IXMLDOMAttribute


xml

xml - Read property

Description

return the XML source for the node and each of its descendants

Syntax in Visual Basic or VBScript

xml () As String

Syntax in C++

HRESULT get_xml (BSTR* retVal)

Applies to

IXMLDOMAttribute
IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMDocument
IXMLDOMDocumentFragment
IXMLDOMDocumentType
IXMLDOMElement
IXMLDOMEntityReference
IXMLDOMNode
IXMLDOMProcessingInstruction
IXMLDOMText


appendChild

appendChild - method

Description

append a child node

Syntax in Visual Basic or VBScript

appendChild (ByRef newChild As IXMLDOMNode) As IXMLDOMNode

Syntax in C++

HRESULT appendChild (IXMLDOMNode* newChild , IXMLDOMNode* retVal)

Parameters

Name | Description
newChild |
Return Value |

Applies to

IXMLDOMNode


cloneNode

cloneNode - method

Syntax in Visual Basic or VBScript

cloneNode (deep As Boolean) As IXMLDOMNode

Syntax in C++

HRESULT cloneNode (VARIANT_BOOL deep , IXMLDOMNode* retVal)

Parameters

Name | Description
deep |
Return Value |

Applies to

IXMLDOMNode


hasChildNodes

hasChildNodes - method

Syntax in Visual Basic or VBScript

hasChildNodes () As Boolean

Syntax in C++

HRESULT hasChildNodes (VARIANT_BOOL* retVal)

Parameters

Name | Description
Return Value |

Applies to

IXMLDOMNode


insertBefore

insertBefore - method

Description

insert a child node

Syntax in Visual Basic or VBScript

insertBefore (ByRef newChild As IXMLDOMNode , refChild As Variant) As IXMLDOMNode

Syntax in C++

HRESULT insertBefore (IXMLDOMNode* newChild , VARIANT refChild , IXMLDOMNode* retVal)

Parameters

Name | Description
newChild |
refChild |
Return Value |

Applies to

IXMLDOMNode


removeChild

removeChild - method

Description

remove a child node

Syntax in Visual Basic or VBScript

removeChild (ByRef childNode As IXMLDOMNode) As IXMLDOMNode

Syntax in C++

HRESULT removeChild (IXMLDOMNode* childNode , IXMLDOMNode* retVal)

Parameters

Name | Description
childNode |
Return Value |

Applies to

IXMLDOMNode


replaceChild

replaceChild - method

Description

replace a child node

Syntax in Visual Basic or VBScript

replaceChild (ByRef newChild As IXMLDOMNode , ByRef oldChild As IXMLDOMNode) As IXMLDOMNode

Syntax in C++

HRESULT replaceChild (IXMLDOMNode* newChild , IXMLDOMNode* oldChild , IXMLDOMNode* retVal)

Parameters

Name | Description
newChild |
oldChild |
Return Value |

Applies to

IXMLDOMNode


selectSingleNode

selectSingleNode - method

Description

execute query on the subtree

Syntax in Visual Basic or VBScript

selectSingleNode (queryString As String) As IXMLDOMNode

Syntax in C++

HRESULT selectSingleNode (BSTR queryString , IXMLDOMNode* retVal)

Parameters

Name | Description
queryString |
Return Value |

Applies to

IXMLDOMNode


transformNode

transformNode - method

Description

apply the stylesheet to the subtree

Syntax in Visual Basic or VBScript

transformNode (ByRef stylesheet As IXMLDOMNode) As String

Syntax in C++

HRESULT transformNode (IXMLDOMNode* stylesheet , BSTR* retVal)

Parameters

Name | Description
stylesheet |
Return Value |

Applies to

IXMLDOMNode


transformNodeToObject

transformNodeToObject - method

Description

apply the stylesheet to the subtree, returning the result through a document or a stream

Syntax in Visual Basic or VBScript

transformNodeToObject (ByRef stylesheet As IXMLDOMNode , outputObject As Variant)

Syntax in C++

HRESULT transformNodeToObject (IXMLDOMNode* stylesheet , VARIANT outputObject)

Parameters

Name | Description
stylesheet |
outputObject |

Applies to

IXMLDOMNode


IXMLDOMCDATASection

IXMLDOMCDATASection - interface

Methods

appendChild | append a child node
appendData | append string to value
cloneNode |
deleteData | delete string within the value
hasChildNodes |
insertBefore | insert a child node
insertData | insert string into value
removeChild | remove a child node
replaceChild | replace a child node
replaceData | replace string within the value
selectSingleNode | execute query on the subtree
splitText | split the text node into two text nodes at the position specified
substringData | retrieve substring of value
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
data | R/W | value of the node
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
length | R/O | number of characters in value
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

selectNodes execute query on the subtree


data

data - Read & Write property

Description

value of the node

Syntax in Visual Basic or VBScript

data () As String

Syntax in C++

HRESULT get_data (BSTR* retVal)
HRESULT put_data (BSTR Value)

Applies to

IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMText


length

length - Read property

Description

number of characters in value

Syntax in Visual Basic or VBScript

length () As Long

Syntax in C++

HRESULT get_length (LONG* retVal)

Applies to

IXMLDOMCDATASection
IXMLDOMCharacterData
IXMLDOMComment
IXMLDOMText


appendData

appendData - method

Description

append string to value

Syntax in Visual Basic or VBScript

appendData (data As String)

Syntax in C++

HRESULT appendData (BSTR data)

Parameters

Name | Description
data |

Applies to

IXMLDOMText


deleteData

deleteData - method

Description

delete string within the value

Syntax in Visual Basic or VBScript

deleteData (offset As Long , count As Long)

Syntax in C++

HRESULT deleteData (LONG offset , LONG count)

Parameters

Name | Description
offset |
count |

Applies to

IXMLDOMText


insertData

insertData - method

Description

insert string into value

Syntax in Visual Basic or VBScript

insertData (offset As Long , data As String)

Syntax in C++

HRESULT insertData (LONG offset , BSTR data)

Parameters

Name | Description
offset |
data |

Applies to

IXMLDOMText


replaceData

replaceData - method

Description

replace string within the value

Syntax in Visual Basic or VBScript

replaceData (offset As Long , count As Long , data As String)

Syntax in C++

HRESULT replaceData (LONG offset , LONG count , BSTR data)

Parameters

Name | Description
offset |
count |
data |

Applies to

IXMLDOMText


splitText

splitText - method

Description

split the text node into two text nodes at the position specified

Syntax in Visual Basic or VBScript

splitText (offset As Long) As IXMLDOMText

Syntax in C++

HRESULT splitText (LONG offset , IXMLDOMText* retVal)

Parameters

Name | Description
offset |
Return Value |

Applies to

IXMLDOMText


substringData

substringData - method

Description

retrieve substring of value

Syntax in Visual Basic or VBScript

substringData (offset As Long , count As Long) As String

Syntax in C++

HRESULT substringData (LONG offset , LONG count , BSTR* retVal)

Parameters

Name | Description
offset |
count |
Return Value |

Applies to

IXMLDOMText


IXMLDOMCharacterData

IXMLDOMCharacterData - interface

Methods

appendChild | append a child node
appendData | append string to value
cloneNode |
deleteData | delete string within the value
hasChildNodes |
insertBefore | insert a child node
insertData | insert string into value
removeChild | remove a child node
replaceChild | replace a child node
replaceData | replace string within the value
selectSingleNode | execute query on the subtree
substringData | retrieve substring of value
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
data | R/W | value of the node
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
length | R/O | number of characters in value
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

selectNodes execute query on the subtree


IXMLDOMComment

IXMLDOMComment - interface

Methods

appendChild | append a child node
appendData | append string to value
cloneNode |
deleteData | delete string within the value
hasChildNodes |
insertBefore | insert a child node
insertData | insert string into value
removeChild | remove a child node
replaceChild | replace a child node
replaceData | replace string within the value
selectSingleNode | execute query on the subtree
substringData | retrieve substring of value
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
data | R/W | value of the node
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
length | R/O | number of characters in value
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

selectNodes execute query on the subtree


IXMLDOMDocument

IXMLDOMDocument - interface

Methods

abort | abort an asynchronous download
appendChild | append a child node
cloneNode |
createAttribute | create an attribute node
createCDATASection | create a CDATA section node
createComment | create a comment node
createDocumentFragment | create a DocumentFragment node
createElement | create an Element node
createEntityReference | create an entity reference node
createNode | create a node of the specified node type and name
createProcessingInstruction | create a processing instruction node
createTextNode | create a text node
hasChildNodes |
insertBefore | insert a child node
load | load document from the specified XML source
loadXML | load the document from a string
nodeFromID | retrieve node from it's ID
removeChild | remove a child node
replaceChild | replace a child node
save | save the document to a specified desination
selectSingleNode | execute query on the subtree
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

async | R/W | flag for asynchronous download
attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
doctype | R/O | node corresponding to the DOCTYPE
documentElement | R/O | the root of the tree
documentElement | W/O | the root of the tree
firstChild | R/O | first child of the node
implementation | R/O | info on this DOM implementation
lastChild | R/O | first child of the node
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ondataavailable | W/O | register an ondataavailable event handler
onreadystatechange | W/O | register a readystatechange event handler
ontransformnode | W/O | register an ontransformnode event handler
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
parseError | R/O | get the last parser error
prefix | R/O | the prefix for the namespace applying to the node
preserveWhiteSpace | R/W | indicates whether the parser preserves whitespace
previousSibling | R/O | left sibling of the node
readyState | R/O | get the state of the XML document
resolveExternals | R/W | indicates whether the parser resolves references to external DTD/Entities/Schema
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
url | R/O | get the URL for the loaded XML document
validateOnParse | R/W | indicates whether the parser performs validation
xml | R/O | return the XML source for the node and each of its descendants

Collections

getElementsByTagName | build a list of elements by name
selectNodes | execute query on the subtree


async

async - Read & Write property

Description

flag for asynchronous download

Syntax in Visual Basic or VBScript

async () As Boolean

Syntax in C++

HRESULT get_async (VARIANT_BOOL* retVal)
HRESULT put_async (VARIANT_BOOL Value)

Applies to

IXMLDOMDocument


doctype

doctype - Read property

Description

node corresponding to the DOCTYPE

Syntax in Visual Basic or VBScript

doctype () As IXMLDOMDocumentType

Syntax in C++

HRESULT get_doctype (IXMLDOMDocumentType* retVal)

Applies to

IXMLDOMDocument


documentElement

documentElement - Read property

Description

the root of the tree

Syntax in Visual Basic or VBScript

documentElement () As IXMLDOMElement

Syntax in C++

HRESULT get_documentElement (IXMLDOMElement* retVal)

Applies to

IXMLDOMDocument


documentElement

documentElement - Reference Write property

Description

the root of the tree

Syntax in Visual Basic or VBScript

documentElement (ByRef As IXMLDOMElement)

Syntax in C++

HRESULT putref_documentElement (IXMLDOMElement* )

Applies to

IXMLDOMDocument


implementation

implementation - Read property

Description

info on this DOM implementation

Syntax in Visual Basic or VBScript

implementation () As IXMLDOMImplementation

Syntax in C++

HRESULT get_implementation (IXMLDOMImplementation* retVal)

Applies to

IXMLDOMDocument


ondataavailable

ondataavailable - Write property

Description

register an ondataavailable event handler

Syntax in Visual Basic or VBScript

ondataavailable (Value As Variant)

Syntax in C++

HRESULT put_ondataavailable (VARIANT Value)

Applies to

IXMLDOMDocument


onreadystatechange

onreadystatechange - Write property

Description

register a readystatechange event handler

Syntax in Visual Basic or VBScript

onreadystatechange (Value As Variant)

Syntax in C++

HRESULT put_onreadystatechange (VARIANT Value)

Applies to

IXMLDOMDocument


ontransformnode

ontransformnode - Write property

Description

register an ontransformnode event handler

Syntax in Visual Basic or VBScript

ontransformnode (Value As Variant)

Syntax in C++

HRESULT put_ontransformnode (VARIANT Value)

Applies to

IXMLDOMDocument


parseError

parseError - Read property

Description

get the last parser error

Syntax in Visual Basic or VBScript

parseError () As IXMLDOMParseError

Syntax in C++

HRESULT get_parseError (IXMLDOMParseError* retVal)

Applies to

IXMLDOMDocument


preserveWhiteSpace

preserveWhiteSpace - Read & Write property

Description

indicates whether the parser preserves whitespace

Syntax in Visual Basic or VBScript

preserveWhiteSpace () As Boolean

Syntax in C++

HRESULT get_preserveWhiteSpace (VARIANT_BOOL* retVal)
HRESULT put_preserveWhiteSpace (VARIANT_BOOL Value)

Applies to

IXMLDOMDocument


readyState

readyState - Read property

Description

get the state of the XML document

Syntax in Visual Basic or VBScript

readyState () As Long

Syntax in C++

HRESULT get_readyState (LONG* retVal)

Applies to

IXMLDOMDocument


resolveExternals

resolveExternals - Read & Write property

Description

indicates whether the parser resolves references to external DTD/Entities/Schema

Syntax in Visual Basic or VBScript

resolveExternals () As Boolean

Syntax in C++

HRESULT get_resolveExternals (VARIANT_BOOL* retVal)
HRESULT put_resolveExternals (VARIANT_BOOL Value)

Applies to

IXMLDOMDocument


url

url - Read property

Description

get the URL for the loaded XML document

Syntax in Visual Basic or VBScript

url () As String

Syntax in C++

HRESULT get_url (BSTR* retVal)

Applies to

IXMLDOMDocument


validateOnParse

validateOnParse - Read & Write property

Description

indicates whether the parser performs validation

Syntax in Visual Basic or VBScript

validateOnParse () As Boolean

Syntax in C++

HRESULT get_validateOnParse (VARIANT_BOOL* retVal)
HRESULT put_validateOnParse (VARIANT_BOOL Value)

Applies to

IXMLDOMDocument


abort

abort - method

Description

abort an asynchronous download

Syntax in Visual Basic or VBScript

abort ()

Syntax in C++

HRESULT abort ()

Applies to

IXMLDOMDocument


createAttribute

createAttribute - method

Description

create an attribute node

Syntax in Visual Basic or VBScript

createAttribute (name As String) As IXMLDOMAttribute

Syntax in C++

HRESULT createAttribute (BSTR name , IXMLDOMAttribute* retVal)

Parameters

Name | Description
name |
Return Value |

Applies to

IXMLDOMDocument


createCDATASection

createCDATASection - method

Description

create a CDATA section node

Syntax in Visual Basic or VBScript

createCDATASection (data As String) As IXMLDOMCDATASection

Syntax in C++

HRESULT createCDATASection (BSTR data , IXMLDOMCDATASection* retVal)

Parameters

Name | Description
data |
Return Value |

Applies to

IXMLDOMDocument


createComment

createComment - method

Description

create a comment node

Syntax in Visual Basic or VBScript

createComment (data As String) As IXMLDOMComment

Syntax in C++

HRESULT createComment (BSTR data , IXMLDOMComment* retVal)

Parameters

Name | Description
data |
Return Value |

Applies to

IXMLDOMDocument


createDocumentFragment

createDocumentFragment - method

Description

create a DocumentFragment node

Syntax in Visual Basic or VBScript

createDocumentFragment () As IXMLDOMDocumentFragment

Syntax in C++

HRESULT createDocumentFragment (IXMLDOMDocumentFragment* retVal)

Parameters

Name | Description
Return Value |

Applies to

IXMLDOMDocument


createElement

createElement - method

Description

create an Element node

Syntax in Visual Basic or VBScript

createElement (tagName As String) As IXMLDOMElement

Syntax in C++

HRESULT createElement (BSTR tagName , IXMLDOMElement* retVal)

Parameters

Name | Description
tagName |
Return Value |

Applies to

IXMLDOMDocument


createEntityReference

createEntityReference - method

Description

create an entity reference node

Syntax in Visual Basic or VBScript

createEntityReference (name As String) As IXMLDOMEntityReference

Syntax in C++

HRESULT createEntityReference (BSTR name , IXMLDOMEntityReference* retVal)

Parameters

Name | Description
name |
Return Value |

Applies to

IXMLDOMDocument


createNode

createNode - method

Description

create a node of the specified node type and name

Syntax in Visual Basic or VBScript

createNode (type As Variant , name As String , namespaceURI As String) As IXMLDOMNode

Syntax in C++

HRESULT createNode (VARIANT type , BSTR name , BSTR namespaceURI , IXMLDOMNode* retVal)

Parameters

Name | Description
type |
name |
namespaceURI |
Return Value |

Applies to

IXMLDOMDocument


createProcessingInstruction

createProcessingInstruction - method

Description

create a processing instruction node

Syntax in Visual Basic or VBScript

createProcessingInstruction (target As String , data As String) As IXMLDOMProcessingInstruction

Syntax in C++

HRESULT createProcessingInstruction (BSTR target , BSTR data , IXMLDOMProcessingInstruction* retVal)

Parameters

Name | Description
target |
data |
Return Value |

Applies to

IXMLDOMDocument


createTextNode

createTextNode - method

Description

create a text node

Syntax in Visual Basic or VBScript

createTextNode (data As String) As IXMLDOMText

Syntax in C++

HRESULT createTextNode (BSTR data , IXMLDOMText* retVal)

Parameters

Name | Description
data |
Return Value |

Applies to

IXMLDOMDocument


load

load - method

Description

load document from the specified XML source

Syntax in Visual Basic or VBScript

load (xmlSource As Variant) As Boolean

Syntax in C++

HRESULT load (VARIANT xmlSource , VARIANT_BOOL* retVal)

Parameters

Name | Description
xmlSource |
Return Value |

Applies to

IXMLDOMDocument


loadXML

loadXML - method

Description

load the document from a string

Syntax in Visual Basic or VBScript

loadXML (bstrXML As String) As Boolean

Syntax in C++

HRESULT loadXML (BSTR bstrXML , VARIANT_BOOL* retVal)

Parameters

Name | Description
bstrXML |
Return Value |

Applies to

IXMLDOMDocument


nodeFromID

nodeFromID - method

Description

retrieve node from it's ID

Syntax in Visual Basic or VBScript

nodeFromID (idString As String) As IXMLDOMNode

Syntax in C++

HRESULT nodeFromID (BSTR idString , IXMLDOMNode* retVal)

Parameters

Name | Description
idString |
Return Value |

Applies to

IXMLDOMDocument


save

save - method

Description

save the document to a specified desination

Syntax in Visual Basic or VBScript

save (desination As Variant)

Syntax in C++

HRESULT save (VARIANT desination)

Parameters

Name | Description
desination |

Applies to

IXMLDOMDocument


IXMLDOMDocumentFragment

IXMLDOMDocumentFragment - interface

Methods

appendChild | append a child node
cloneNode |
hasChildNodes |
insertBefore | insert a child node
removeChild | remove a child node
replaceChild | replace a child node
selectSingleNode | execute query on the subtree
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

selectNodes execute query on the subtree


IXMLDOMDocumentType

IXMLDOMDocumentType - interface

Methods

appendChild | append a child node
cloneNode |
hasChildNodes |
insertBefore | insert a child node
removeChild | remove a child node
replaceChild | replace a child node
selectSingleNode | execute query on the subtree
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
name | R/O | name of the document type (root of the tree)
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

entities | a list of entities in the document
notations | a list of notations in the document
selectNodes | execute query on the subtree


name

name - Read property

Description

name of the document type (root of the tree)

Syntax in Visual Basic or VBScript

name () As String

Syntax in C++

HRESULT get_name (BSTR* retVal)

Applies to

IXMLDOMDocumentType


IXMLDOMElement

IXMLDOMElement - interface

Methods

appendChild | append a child node
cloneNode |
getAttribute | look up the string value of an attribute by name
getAttributeNode | look up the attribute node by name
hasChildNodes |
insertBefore | insert a child node
normalize | collapse all adjacent text nodes in sub-tree
removeAttribute | remove an attribute by name
removeAttributeNode | remove the specified attribute
removeChild | remove a child node
replaceChild | replace a child node
selectSingleNode | execute query on the subtree
setAttribute | set the string value of an attribute by name
setAttributeNode | set the specified attribute on the element
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
tagName | R/O | get the tagName of the element
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

getElementsByTagName | build a list of elements by name
selectNodes | execute query on the subtree


tagName

tagName - Read property

Description

get the tagName of the element

Syntax in Visual Basic or VBScript

tagName () As String

Syntax in C++

HRESULT get_tagName (BSTR* retVal)

Applies to

IXMLDOMElement


getAttribute

getAttribute - method

Description

look up the string value of an attribute by name

Syntax in Visual Basic or VBScript

getAttribute (name As String) As Variant

Syntax in C++

HRESULT getAttribute (BSTR name , VARIANT* retVal)

Parameters

Name | Description
name |
Return Value |

Applies to

IXMLDOMElement


getAttributeNode

getAttributeNode - method

Description

look up the attribute node by name

Syntax in Visual Basic or VBScript

getAttributeNode (name As String) As IXMLDOMAttribute

Syntax in C++

HRESULT getAttributeNode (BSTR name , IXMLDOMAttribute* retVal)

Parameters

Name | Description
name |
Return Value |

Applies to

IXMLDOMElement


normalize

normalize - method

Description

collapse all adjacent text nodes in sub-tree

Syntax in Visual Basic or VBScript

normalize ()

Syntax in C++

HRESULT normalize ()

Applies to

IXMLDOMElement


removeAttribute

removeAttribute - method

Description

remove an attribute by name

Syntax in Visual Basic or VBScript

removeAttribute (name As String)

Syntax in C++

HRESULT removeAttribute (BSTR name)

Parameters

Name | Description
name |

Applies to

IXMLDOMElement


removeAttributeNode

removeAttributeNode - method

Description

remove the specified attribute

Syntax in Visual Basic or VBScript

removeAttributeNode (ByRef DOMAttribute As IXMLDOMAttribute) As IXMLDOMAttribute

Syntax in C++

HRESULT removeAttributeNode (IXMLDOMAttribute* DOMAttribute , IXMLDOMAttribute* retVal)

Parameters

Name | Description
DOMAttribute |
Return Value |

Applies to

IXMLDOMElement


setAttribute

setAttribute - method

Description

set the string value of an attribute by name

Syntax in Visual Basic or VBScript

setAttribute (name As String , Value As Variant)

Syntax in C++

HRESULT setAttribute (BSTR name , VARIANT Value)

Parameters

Name | Description
name |
Value |

Applies to

IXMLDOMElement


setAttributeNode

setAttributeNode - method

Description

set the specified attribute on the element

Syntax in Visual Basic or VBScript

setAttributeNode (ByRef DOMAttribute As IXMLDOMAttribute) As IXMLDOMAttribute

Syntax in C++

HRESULT setAttributeNode (IXMLDOMAttribute* DOMAttribute , IXMLDOMAttribute* retVal)

Parameters

Name | Description
DOMAttribute |
Return Value |

Applies to

IXMLDOMElement


IXMLDOMEntityReference

IXMLDOMEntityReference - interface

Methods

appendChild | append a child node
cloneNode |
hasChildNodes |
insertBefore | insert a child node
removeChild | remove a child node
replaceChild | replace a child node
selectSingleNode | execute query on the subtree
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

selectNodes execute query on the subtree


IXMLDOMImplementation

IXMLDOMImplementation - interface

Methods

hasFeature


hasFeature

hasFeature - method

Syntax in Visual Basic or VBScript

hasFeature (feature As String , version As String) As Boolean

Syntax in C++

HRESULT hasFeature (BSTR feature , BSTR version , VARIANT_BOOL* retVal)

Parameters

Name | Description
feature |
version |
Return Value |

Applies to

IXMLDOMImplementation


IXMLDOMNamedNodeMap

IXMLDOMNamedNodeMap - interface

Methods

getNamedItem | lookup item by name
getQualifiedItem | lookup the item by name and namespace
nextNode | get next node from iterator
removeNamedItem | remove item by name
removeQualifiedItem | remove the item by name and namespace
reset | reset the position of iterator
setNamedItem | set item by name

Properties

item | R/O | collection of nodes
length | R/O | number of nodes in the collection

Used in

entities
notations


item

item - Read property

Description

collection of nodes

Syntax in Visual Basic or VBScript

item (index As Long) As IXMLDOMNode

Syntax in C++

HRESULT get_item (LONG index , IXMLDOMNode* retVal)

Applies to

IXMLDOMNamedNodeMap
IXMLDOMNodeList


length

length - Read property

Description

number of nodes in the collection

Syntax in Visual Basic or VBScript

length () As Long

Syntax in C++

HRESULT get_length (LONG* retVal)

Applies to

IXMLDOMNamedNodeMap
IXMLDOMNodeList


getNamedItem

getNamedItem - method

Description

lookup item by name

Syntax in Visual Basic or VBScript

getNamedItem (name As String) As IXMLDOMNode

Syntax in C++

HRESULT getNamedItem (BSTR name , IXMLDOMNode* retVal)

Parameters

Name | Description
name |
Return Value |

Applies to

IXMLDOMNamedNodeMap


getQualifiedItem

getQualifiedItem - method

Description

lookup the item by name and namespace

Syntax in Visual Basic or VBScript

getQualifiedItem (baseName As String , namespaceURI As String) As IXMLDOMNode

Syntax in C++

HRESULT getQualifiedItem (BSTR baseName , BSTR namespaceURI , IXMLDOMNode* retVal)

Parameters

Name | Description
baseName |
namespaceURI |
Return Value |

Applies to

IXMLDOMNamedNodeMap


nextNode

nextNode - method

Description

get next node from iterator

Syntax in Visual Basic or VBScript

nextNode () As IXMLDOMNode

Syntax in C++

HRESULT nextNode (IXMLDOMNode* retVal)

Parameters

Name | Description
Return Value |

Applies to

IXMLDOMNodeList


removeNamedItem

removeNamedItem - method

Description

remove item by name

Syntax in Visual Basic or VBScript

removeNamedItem (name As String) As IXMLDOMNode

Syntax in C++

HRESULT removeNamedItem (BSTR name , IXMLDOMNode* retVal)

Parameters

Name | Description
name |
Return Value |

Applies to

IXMLDOMNamedNodeMap


removeQualifiedItem

removeQualifiedItem - method

Description

remove the item by name and namespace

Syntax in Visual Basic or VBScript

removeQualifiedItem (baseName As String , namespaceURI As String) As IXMLDOMNode

Syntax in C++

HRESULT removeQualifiedItem (BSTR baseName , BSTR namespaceURI , IXMLDOMNode* retVal)

Parameters

Name | Description
baseName |
namespaceURI |
Return Value |

Applies to

IXMLDOMNamedNodeMap


reset

reset - method

Description

reset the position of iterator

Syntax in Visual Basic or VBScript

reset ()

Syntax in C++

HRESULT reset ()

Applies to

IXMLDOMNodeList


setNamedItem

setNamedItem - method

Description

set item by name

Syntax in Visual Basic or VBScript

setNamedItem (ByRef newItem As IXMLDOMNode) As IXMLDOMNode

Syntax in C++

HRESULT setNamedItem (IXMLDOMNode* newItem , IXMLDOMNode* retVal)

Parameters

Name | Description
newItem |
Return Value |

Applies to

IXMLDOMNamedNodeMap


IXMLDOMNode

IXMLDOMNode - interface

Description

Core DOM node interface

Methods

appendChild | append a child node
cloneNode |
hasChildNodes |
insertBefore | insert a child node
removeChild | remove a child node
replaceChild | replace a child node
selectSingleNode | execute query on the subtree
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

selectNodes execute query on the subtree


IXMLDOMNodeList

IXMLDOMNodeList - interface

Methods

nextNode | get next node from iterator
reset | reset the position of iterator

Properties

item | R/O | collection of nodes
length | R/O | number of nodes in the collection

Used in

getElementsByTagName
selectNodes


IXMLDOMParseError

IXMLDOMParseError - interface

Description

structure for reporting parser errors

Properties

errorCode | R/O | the error code
filepos | R/O | the absolute file position in the XML document containing the error
line | R/O | the line number in the XML document where the error occurred
linepos | R/O | the character position in the line containing the error
reason | R/O | the cause of the error
srcText | R/O | the data where the error occurred
url | R/O | the URL of the XML document containing the error


errorCode

errorCode - Read property

Description

the error code

Syntax in Visual Basic or VBScript

errorCode () As Long

Syntax in C++

HRESULT get_errorCode (LONG* retVal)

Applies to

IXMLDOMParseError


filepos

filepos - Read property

Description

the absolute file position in the XML document containing the error

Syntax in Visual Basic or VBScript

filepos () As Long

Syntax in C++

HRESULT get_filepos (LONG* retVal)

Applies to

IXMLDOMParseError


line

line - Read property

Description

the line number in the XML document where the error occurred

Syntax in Visual Basic or VBScript

line () As Long

Syntax in C++

HRESULT get_line (LONG* retVal)

Applies to

IXMLDOMParseError


linepos

linepos - Read property

Description

the character position in the line containing the error

Syntax in Visual Basic or VBScript

linepos () As Long

Syntax in C++

HRESULT get_linepos (LONG* retVal)

Applies to

IXMLDOMParseError


reason

reason - Read property

Description

the cause of the error

Syntax in Visual Basic or VBScript

reason () As String

Syntax in C++

HRESULT get_reason (BSTR* retVal)

Applies to

IXMLDOMParseError


srcText

srcText - Read property

Description

the data where the error occurred

Syntax in Visual Basic or VBScript

srcText () As String

Syntax in C++

HRESULT get_srcText (BSTR* retVal)

Applies to

IXMLDOMParseError


url

url - Read property

Description

the URL of the XML document containing the error

Syntax in Visual Basic or VBScript

url () As String

Syntax in C++

HRESULT get_url (BSTR* retVal)

Applies to

IXMLDOMParseError


IXMLDOMProcessingInstruction

IXMLDOMProcessingInstruction - interface

Methods

appendChild | append a child node
cloneNode |
hasChildNodes |
insertBefore | insert a child node
removeChild | remove a child node
replaceChild | replace a child node
selectSingleNode | execute query on the subtree
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
data | R/W | the data
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
target | R/O | the target
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

selectNodes execute query on the subtree


data

data - Read & Write property

Description

the data

Syntax in Visual Basic or VBScript

data () As String

Syntax in C++

HRESULT get_data (BSTR* retVal)
HRESULT put_data (BSTR Value)

Applies to

IXMLDOMProcessingInstruction


target

target - Read property

Description

the target

Syntax in Visual Basic or VBScript

target () As String

Syntax in C++

HRESULT get_target (BSTR* retVal)

Applies to

IXMLDOMProcessingInstruction


IXMLDOMText

IXMLDOMText - interface

Methods

appendChild | append a child node
appendData | append string to value
cloneNode |
deleteData | delete string within the value
hasChildNodes |
insertBefore | insert a child node
insertData | insert string into value
removeChild | remove a child node
replaceChild | replace a child node
replaceData | replace string within the value
selectSingleNode | execute query on the subtree
splitText | split the text node into two text nodes at the position specified
substringData | retrieve substring of value
transformNode | apply the stylesheet to the subtree
transformNodeToObject | apply the stylesheet to the subtree, returning the result through a document or a stream

Properties

attributes | R/O | the collection of the node's attributes
baseName | R/O | the base name of the node (nodename with the prefix stripped off)
childNodes | R/O | the collection of the node's children
data | R/W | value of the node
dataType | R/W | the data type of the node
definition | R/O | pointer to the definition of the node in the DTD or schema
firstChild | R/O | first child of the node
lastChild | R/O | first child of the node
length | R/O | number of characters in value
namespaceURI | R/O | the URI for the namespace applying to the node
nextSibling | R/O | right sibling of the node
nodeName | R/O | name of the node
nodeType | R/O | the node's type
nodeTypedValue | R/W | get the strongly typed value of the node
nodeTypeString | R/O | the type of node in string form
nodeValue | R/W | value stored in the node
ownerDocument | R/O | document that contains the node
parentNode | R/O | parent of the node
parsed | R/O | has sub-tree been completely parsed
prefix | R/O | the prefix for the namespace applying to the node
previousSibling | R/O | left sibling of the node
specified | R/O | indicates whether node is a default value
text | R/W | text content of the node and subtree
xml | R/O | return the XML source for the node and each of its descendants

Collections

selectNodes execute query on the subtree


_ACTIVATE_SENSOR_RETVAL

_ACTIVATE_SENSOR_RETVAL - Enumeration

Members

Name | Value | Description
asr_DENIED | 0 |
asr_NOT_FOUND | 1 |
asr_OK | 2 |


_CMMTYPE

_CMMTYPE - Enumeration

Members

Name | Value | Description
CMM_UNDEFINED | -1 |
CONVENTIONAL_CARTESIAN_MANUAL_CMM | 1 |
CONVENTIONAL_CARTESIAN_CNC_CMM | 2 |
ARTICULATED_ARM | 11 |
THEODOLITE | 20 |
CNC_THEODOLITE | 21 |


_CNCSTATUS

_CNCSTATUS - Enumeration

Members

Name | Value | Description
BUSY | 0 |
UNINITIALIZED | 1 |
WAITING_FOR_COMMAND | 2 |
EMERGENCY_STOP_ON | 3 |


_PROBESENSORTYPE

_PROBESENSORTYPE - Enumeration

Members

Name | Value | Description
PROBESENSOR_UNDEFINED | -1 |
TRIGGERPROBE_SPHERE | 10 |
TRIGGERPROBE_CYLINDER | 11 |
TRIGGERPROBE_DISK | 12 |
RIGIDPROBE_SPHERE | 20 |
RIGIDPROBE_CYLINDER | 21 |
RIGIDPROBE_DISK | 22 |
ANALOGSCANNING_SPHERE | 30 |
SENSOR_VIDEO | 100 |
SENSOR_LASER_STRIPE | 200 |
SENSOR_INFRARED | 300 |
SENSOR_NOCONTACT | 400 |
SENSOR_XRAY | 500 |

Methods and Properties That Use This Enumeration

ActiveSensorType
ProbeType


_SENSORPROPERTY

_SENSORPROPERTY - Enumeration

Members

Name | Value | Description
sp_DIAMETER | 1 |
sp_ACTIVELENGTH | 2 |
sp_PROBESHANK_DIRECTION | 3 |
sp_ANGLE_A | 4 |
sp_ANGLE_B | 5 |
sp_PROBE_LENGTH | 6 |
sp_PROBE_SHANK_DIAMETER | 7 |
sp_SENSOR_OBJECT | 8 |
sp_CALIBRATIONSTATE | 9 |
sp_SENSOR_GUID | 10 |
sp_CARRIAGE | 11 |
sp_PROBEHINGE_OFFSET | 12 |
sp_CARRIAGE_MIN_POINT | 13 |
sp_CARRIAGE_MAX_POINT | 14 |
sp_HUMAN_READABLE_NAME | 15 |
sp_SENSORTYPE | 16 |

Methods and Properties That Use This Enumeration

Property
SensorProperty


ApplyPackValueOption

ApplyPackValueOption - Enumeration

Members

Name | Value | Description
ap_VALUE_ONLY | 0 |
ap_ALL | 1 |

Methods and Properties That Use This Enumeration

ApplyPackedValue
ApplyPackedValue
XMLOutput


BESTFIT_FITTING_TYPE

BESTFIT_FITTING_TYPE - Enumeration

Members

Name | Value | Description
BFT_MMC | 0 |
BFT_LMC | 1 |
BFT_MINMAX | 2 |
BFT_BESTFIT | 3 |

Methods and Properties That Use This Enumeration

FittingType


BESTFIT_TOLERANCE_TYPE

BESTFIT_TOLERANCE_TYPE - Enumeration

Members

Name | Value | Description
BTT_POINT_TOLERANCES | 0 |
BTT_GROUP_TOLERANCES | 1 |
BTT_SPECIFY_TOLERANCES | 2 |

Methods and Properties That Use This Enumeration

ToleranceType


CALIBRATIONSTATE

CALIBRATIONSTATE - Enumeration

Members

Name | Value | Description
NOT_CALIBRATABLE | -1 |
NOT_CALIBRATED | 0 |
PSEUDO_CALIBRATED | 1 |
CALIBRATED | 2 |
BEING_CALIBRATED | 3 |

Methods and Properties That Use This Enumeration

Status
Status


ChangeMask

ChangeMask - Enumeration

Members

Name | Value | Description
CHANGE_DESCRIPTION | 2 |
CHANGE_READONLY | 4 |
CHANGE_LIMITS | 8 |
CHANGE_INCREMENT | 16 |
CHANGE_DEFAULTUNIT | 32 |
CHANGE_VALUE | 64 |
CHANGE_UINAME | 128 |


cmms_ANIMATION

cmms_ANIMATION - Enumeration

Members

Name | Value | Description
cmms_NO_ANIMATION | 0 |
cmms_ANIMATED | 1 |

Methods and Properties That Use This Enumeration

Animation


cmms_AXIS_TYPE

cmms_AXIS_TYPE - Enumeration

Members

Name | Value | Description
cmms_AXIS_TYPE_LINEAR | 0 |
cmms_AXIS_TYPE_ROTARY | 1 |

Methods and Properties That Use This Enumeration

MachineAxisType


cmms_BACKOFF

cmms_BACKOFF - Enumeration

Members

Name | Value | Description
cmms_BACKOFF_DEFAULT | 0 |
cmms_BACKOFF_TO_START | 1 |

Methods and Properties That Use This Enumeration

BackOffBehaviour


cmms_CAMERA_POSITION

cmms_CAMERA_POSITION - Enumeration

Members

Name | Value | Description
cmms_CAM_POS_STATIC | 0 |
cmms_CAM_POS_TABLE | 1 |
cmms_CAM_POS_HEAD | 2 |

Methods and Properties That Use This Enumeration

MaintainCameraPosition


cmms_MOVETYPE

cmms_MOVETYPE - Enumeration

Members

Name | Value | Description
cmms_MOVE_CMM_COORDINATE | 0 |
cmms_MOVE_TIP_COORDINATE | 1 |

Methods and Properties That Use This Enumeration

MoveProbe


cmms_ROTATEHEADOPTION

cmms_ROTATEHEADOPTION - Enumeration

Members

Name | Value | Description
cmms_PRESEVE_TIP_LOCATION | 0 |
cmms_PRESEVE_CMM_LOCATION | 1 |

Methods and Properties That Use This Enumeration

RotateProbe


CNCCOMPLETION

CNCCOMPLETION - Enumeration

Members

Name | Value | Description
MOVE_COMPLETE | 0 |
MOVE_CANCELED | 1 |
ERROR_COLLISION_DETECTED | 2 |
ERROR_NO_TOUCH_DETECTED | 3 |
ERROR_TOUCH_DURING_BACKOFF | 4 |
ERROR_MOVE_OUTSIDE_BOUNDARY | 5 |
ERROR_PROBEHEAD_ERROR | 6 |
ERROR_ILLEGAL_TOUCH | 7 |
ERROR_UNSPECIFIED | -1 |
QUEUE_COMPLETE | 8 |

Methods and Properties That Use This Enumeration

OnCompletion


ERROR_MAPPING_TYPE

ERROR_MAPPING_TYPE - Enumeration

Members

Name | Value | Description
CAN_ACCEPT_ERROR_MAP | 0 |
RECEIVES_ERROR_MAPPED_COORDS | 1 |
ERROR_MAPPING_INAPPROPRIATE | 2 |

Methods and Properties That Use This Enumeration

ErrorMappingType


FINDPLANE_METHOD

FINDPLANE_METHOD - Enumeration

Members

Name | Value | Description
pwi_fp_COINCIDENT | 0 |
pwi_fp_PARALLEL | 1 |
pwi_fp_STRICTLY_PARALLEL | 2 |
pwi_fp_STRICTLY_COINCIDENT | 3 |
pwi_fp_REVERSED_PARALLEL | 4 |
pwi_fp_REVERSED_COINCIDENT | 5 |
pwi_fp_NEAREST | 6 |

Methods and Properties That Use This Enumeration

FindBestFeaturePlane


GDT_DATUM_PLANE

GDT_DATUM_PLANE - Enumeration

Members

Name | Value | Description
dgt_PRIMARY | 0 |
dgt_SECONDARY | 1 |
dgt_TERTIARY | 2 |


GDT_ERRORN

GDT_ERRORN - Enumeration

Members

Name | Value | Description
gdt_err_FATAL | 0 |
gdt_err_WARNING | 1 |
gdt_err_NOTIMPL | 2 |
gdt_err_VERIFICATION_ERROR | 3 |
gdt_err_NO_ERROR | 4 |


GDT_SUBTYPE

GDT_SUBTYPE - Enumeration

Members

Name | Value | Description
gdst_UNSPECIFIED | -1 |
gdst_POSITION_COAXIALITY_TWO_CYLINDERS | 1280 |
gdst_POSITION_PATTERN_OF_HOLE_CARTESIAN | 1281 |
gdst_POSITION_PATTERN_OF_HOLE_POLAR | 1282 |


GDT_TYPE

GDT_TYPE - Enumeration

Members

Name | Value | Description
gdt_UNSPECIFIED | -1 |
gdt_PERPENDICULARITY | 0 |
gdt_PARALLELISM | 1 |
gdt_ANGULARITY | 2 |
gdt_LINEAR_DIMENSION | 3 |
gdt_ANGULAR_DIMENSION | 4 |
gdt_POSITION | 5 |
gdt_CONCENTRICITY | 6 |
gdt_SYMMETRY | 7 |
gdt_CIRCULAR_RUNOUT | 8 |
gdt_TOTAL_RUNOUT | 9 |
gdt_PROFILE_OF_A_SURFACE | 10 |
gdt_PROFILE_OF_A_LINE | 11 |
gdt_FORM_PLANARITY | 12 |
gdt_FORM_LINEARITY | 13 |
gdt_FORM_CIRCULARITY | 14 |
gdt_FORM_CYLINDRICITY | 15 |
gdt_FORM_CONICITY | 16 |
gdt_FORM_SPHERICITY | 17 |

Methods and Properties That Use This Enumeration

GDTType


GeometryExplorerMode

GeometryExplorerMode - Enumeration

Members

Name | Value | Description
gem_INACTIVE | 0 |
gem_WIREFRAME_MODE | 1 |
gem_SURFACE_MODE | 2 |
gem_POINT_MODE | 3 |
gem_MEASUREMENT_MODE | 4 |

Methods and Properties That Use This Enumeration

Mode


geomPoint3DCoordinateType

geomPoint3DCoordinateType - Enumeration

Members

Name | Value | Description
geomp3d_CARTESIAN | 0 |
geomp3d_POLAR | 1 |
geomp3d_SPHERICAL | 2 |

Methods and Properties That Use This Enumeration

CoordType


geomUnitType

geomUnitType - Enumeration

Members

Name | Value | Description
geomUnit_NEUTRAL | 0 |
geomUnit_DISTANCE | 1 |
geomUnit_ANGLE | 2 |

Methods and Properties That Use This Enumeration

Unit


geomVector3DCoordinateType

geomVector3DCoordinateType - Enumeration

Members

Name | Value | Description
geomv3d_IJK | 0 |
geomv3d_ANGLE | 1 |
geomv3d_AZIMUTH_ELEVATION | 2 |


ItemDefinitionType

ItemDefinitionType - Enumeration

Members

Name | Value | Description
idt_UNDEFINED | 0 |
idt_AUTO_LINK | 4097 |
idt_AUTO_APPROACH | 4098 |
idt_AUTO_RETRACT | 4099 |
idt_AUTO_LEADIN | 4100 |
idt_AUTO_LEADOUT | 4101 |
idt_AUTO_SAFEIN | 4102 |
idt_AUTO_SAFEOUT | 4103 |
idt_AUTO_SAFEPLANEIN | 4104 |
idt_AUTO_SAFEPLANEOUT | 4105 |
idt_USER_LINK | 8193 |

Methods and Properties That Use This Enumeration

DefinitionType


IteratorType

IteratorType - Enumeration

Members

Name | Value | Description
sqi_PROBEABLE_ITEM | 1 |
sqi_COMMENT_ITEM | 2 |
sqi_OTHER_NC_ITEM | 4 |
sqi_PROBEABLE_ITEM_AND_COMMENT | 3 |
sqi_PROBEABLE_ITEM_AND_OTHER_NC | 5 |
sqi_PROBEABLE_ITEM_COMMENT_OTHER_NC | 7 |

Methods and Properties That Use This Enumeration

IteratorType


JOBSTATUS

JOBSTATUS - Enumeration

Members

Name | Value | Description
job_RUNNING_ONESTEP | 0 |
job_RUNNING_ALL | 1 |
job_SUSPENDED | 2 |
job_INACTIVE | 3 |
job_SHUTTINGDOWN | 4 |
job_COMPLETED | 5 |
job_ABORTED | 6 |

Methods and Properties That Use This Enumeration

JOBSTATUS
OnJobStatusChanged


KinematicMethodType

KinematicMethodType - Enumeration

Members

Name | Value | Description
kmt_INVERSE | 0 |
kmt_INVERSE_WITH_CONSTRAINTS | 1 |
kmt_FORWARD | 2 |

Methods and Properties That Use This Enumeration

KinematicsMethod


LSTSQ_CALCULATION

LSTSQ_CALCULATION - Enumeration

Members

Name | Value | Description
lsqcAUTOMATIQUE | 0 |
lsqcNONE | 1 |
lsqcOUTERPOINT | 2 |
lsqcBOSS_RIGHT | 3 |
lsqcHOLE_LEFT | 4 |

Methods and Properties That Use This Enumeration

CalculusMethod


LSTSQ_ENTYPE

LSTSQ_ENTYPE - Enumeration

Members

Name | Value | Description
LEAST_SQUARE | 0 |
MINIMUM_CIRCUMSCRIBED | 1 |
MAXIMUM_INSCRIBED | 2 |
AVERAGE_MINIMUM_ZONE | 3 |

Methods and Properties That Use This Enumeration

Deviation
Entity


LSTSQ_TYPE

LSTSQ_TYPE - Enumeration

Members

Name | Value | Description
lsqCIRCLE | 0 |
lsqLINE | 1 |
lsqPLANE | 2 |
lsqSPHERE | 3 |
lsqCYLINDER | 4 |
lsqCONE | 5 |
lsqTORUS | 6 |
lsqRECTANGLE | 7 |
lsqROUNDEDSLOT | 8 |
lsqREGULARPOLYGON | 9 |
lsqNONE | -1 |

Methods and Properties That Use This Enumeration

EntityType


MachineConfigurationCreatorType

MachineConfigurationCreatorType - Enumeration

Members

Name | Value | Description
mcct_UNKNOWN | 0 |
mcct_DISPLAY | 1 |
mcct_MULTIAXIS_CONFIGURATION | 2 |
mcct_PCS_CONFIGURATION | 3 |
mcct_STRATEGY_AND_METHOD | 4 |

Methods and Properties That Use This Enumeration

AppendMOWorkplane
InsertMachineConfiguration
MachineConfigurationCreatorType


MATERIAL_CONDITION

MATERIAL_CONDITION - Enumeration

Members

Name | Value | Description
gdt_MATERIAL_CONDITION_ERR | -1 |
gdt_RFS | 0 |
gdt_MMC | 1 |
gdt_LMC | 2 |


MATERIAL_SIDE

MATERIAL_SIDE - Enumeration

Members

Name | Value | Description
gdt_NOTSPECIFIED | -1 |
gdt_BOSS | 0 |
gdt_HOLE | 1 |


OMVEXmlCutOptions

OMVEXmlCutOptions - Enumeration

Members

Name | Value | Description
OMVE_GENERATE_XMLCUT | 1 |
OMVE_GENERATE_TAP | 2 |


OMVImporterError

OMVImporterError - Enumeration

Members

Name | Value | Description
OMVIE_OK | 0 |
OMVIE_UNEXPECTED_EOS | 1 |
OMVIE_CANNOT_GET_STATUS | 2 |
OMVIE_HELPER_INFO_SOURCE_INIT_FAILED | 3 |
OMVIE_READER_INITIALIZATION_FIALED | 4 |
OMVIE_RECEIVED_MORE_POINTS_THAN_PROVIDED_BY_HELPER | 5 |
OMVIE_READER_NOT_PROVIDED | 6 |
OMVIE_HELPER_INFO_SOURCE_NOT_PROVIDED | 7 |
OMVIE_HELPER_SOURCE_MUST_BE_CXM | 8 |
OMVIE_DOCUMENT_MUST_EXIST | 9 |
OMVIE_CANNOT_FIND_ITEMS_IN_HELPER | 10 |
OMVIE_CANNOT_GET_RICH_INFO | 11 |
OMVIE_ITEMS_DO_NOT_MATCH | 12 |
OMVIE_GENERAL_ERROR | 13 |
OMVIE_UNEXPECTED_ERROR_WHEN_READING_FROM_HELPER | 14 |
OMVIE_NO_ITEMS_TO_IMPORT | 15 |
OMVIE_HELPER_INFO_SOURCE_CORRUPTED | 16 |
OMVIE_READER_FAILED_TO_READ_INFO | 17 |
OMVIE_NON_EOI_READER_IS_READY_WHEN_NO_ITEMS_TO_IMPORT | 18 |
OMVIE_NEGATIVE_PROBE_DIAMETER_RECEIVED | 19 |
OMVIE_UNRECOVERABLE_LAST | 999 |
OMVIE_CANNOT_PLAY_ITEM_IN_POWERINSPECT | 1000 |
OMVIE_STARTING_NOT_FROM_BEGINNING | 1001 |
OMVIE_HELPER_INFO_SOURCE_ENDED_EARLIER | 1002 |
OMVIE_HELPER_INFO_SOURCE_HAS_MORE_ITEMS | 1003 |
OMVIE_LAST_RANGE_MARKER_PASSED | 1004 |
OMVIE_RECONCILIATION_LAST | 1999 |
OMVIE_UNEXPECTED_EOS_FOR_ITEM | 2000 |
OMVIE_EOI_READER_IS_READY_WHEN_NO_ITEMS_TO_IMPORT | 2001 |
OMVIE_MORE_POINTS_FOR_ITEM_NOT_FULL_READER_WITH_EOI | 2002 |


OMVImporterStatus

OMVImporterStatus - Enumeration

Members

Name | Value | Description
OMVIS_INVALID | -1 |
OMVIS_UNINITIALIZED | 0 |
OMVIS_SUSPENDED | 1 |
OMVIS_FINISHED | 2 |
OMVIS_RUNNING_ONESTEP | 3 |
OMVIS_RUNNING_ALL | 4 |
OMVIS_ERROR | 5 |

Methods and Properties That Use This Enumeration

OnStatusChanged
Status


OMVImportResult

OMVImportResult - Enumeration

Members

Name | Value | Description
OMVIR_SUCCESS | 0 |
OMVIR_FAILED | 1 |
OMVIR_CALCULATION_FAILED | 2 |
OMVIR_FAILED_MORE_POINTS_THAN_EXPECTED | 3 |


OMVImportValidationResult

OMVImportValidationResult - Enumeration

Members

Name | Value | Description
OMVIVR_SUCCESS | 0 |
OMVIVR_WARNING | 1 |
OMVIVR_FAIL | 2 |

Methods and Properties That Use This Enumeration

Validate


OMVISequentialStreamStatus

OMVISequentialStreamStatus - Enumeration

Members

Name | Value | Description
OMVI_EOS | 0 |
OMVI_READY | 1 |
OMVI_WAITING | 2 |
OMVI_UNINITIALIZED | 3 |
OMVI_GENERAL_ERROR | 4 |

Methods and Properties That Use This Enumeration

Status


OutputPointType

OutputPointType - Enumeration

Members

Name | Value | Description
optCENTRE | 0 |
optTIP | 1 |

Methods and Properties That Use This Enumeration

OutputPoint
OutputPointType


ParameterItemType

ParameterItemType - Enumeration

Members

Name | Value | Description
CMMPARAMETER | 0 |
SENSORDEFINITION | 1 |
PROBEORIENTATION_CHANGE | 2 |

Methods and Properties That Use This Enumeration

ParameterType


ParameterType

ParameterType - Enumeration

Members

Name | Value | Description
paramFloat | 0 |
paramBool | 1 |
paramPoint | 2 |
paramVector | 3 |
paramPlane | 4 |
paramTransform | 5 |


ParameterType

ParameterType - Enumeration

Members

Name | Value | Description
paramFloat | 0 |
paramBool | 1 |
paramPoint | 2 |
paramVector | 3 |
paramPlane | 4 |
paramTransform | 5 |

Methods and Properties That Use This Enumeration

ParameterType


PDBOBJECTTYPE

PDBOBJECTTYPE - Enumeration

Members

Name | Value | Description
pty_ProbeDatabase | 256 |
pty_Carriage | 512 |
pty_ProbeHead | 768 |
pty_ManualProbeHead | 769 |
pty_IndexableProbeHead | 770 |
pty_ProbeTool | 1024 |
pty_ProbeSensor | 1280 |
pty_ProbeSensorSphere | 1281 |
pty_ProbeSensorCylinder | 1282 |
pty_ToolChanger | 1536 |
pty_ManualToolChanger | 1537 |
pty_ProbeRack | 1792 |
pty_ProbeRackSlot | 2048 |
pty_ProbeToolConnection | 2304 |
pty_ProbeTip | 2560 |
pty_DatumSphere | 2816 |
pty_ProbeMainTypeMask | -256 |

Methods and Properties That Use This Enumeration

InterfaceType


PLAY_SOUND_TYPE

PLAY_SOUND_TYPE - Enumeration

Members

Name | Value | Description
PLAY_SOUND_SYNCHRONOUS | 0 |
PLAY_SOUND_SYNCHRONOUS_WITH_PREVIOUS | 1 |
PLAY_SOUND_ASYNCHRONOUS | 2 |

Methods and Properties That Use This Enumeration

PlaySound


PointType

PointType - Enumeration

Members

Name | Value | Description
pt_PROBE_CENTER | 0 |
pt_SURFACE_POINT | 1 |

Methods and Properties That Use This Enumeration

InsertDynamicPositionalItem
PointType


PROBECOMPONENT_TYPE

PROBECOMPONENT_TYPE - Enumeration

Members

Name | Value | Description
pcc_InvalidComponent | -1 |
pcct_ProbeHead | 0 |
pcct_Probe | 1 |
pcct_ProbeBody | 2 |
pcct_Module | 3 |
pcct_Extension | 4 |
pcct_Connector | 5 |
pcct_Stylus | 6 |
pcct_StylusTip | 7 |

Methods and Properties That Use This Enumeration

startElement


PROBEHEAD_TYPE

PROBEHEAD_TYPE - Enumeration

Members

Name | Value | Description
PROBEHEAD_UNDEFINED | -1 |
PROBEHEAD_FIXED | 1 |
PROBEHEAD_ADJUSTABLE | 2 |
PROBEHEAD_INDEXABLE_MANUAL | 3 |
PROBEHEAD_INDEXABLE_CNC | 4 |
PROBEHEAD_ARTICULATEDARM | 10 |

Methods and Properties That Use This Enumeration

ProbeHeadType
SetProbeHeadType


ProbeItemType

ProbeItemType - Enumeration

Members

Name | Value | Description
pit_POSITIONAL | 1 |
pit_COMPOSITEMOVE | 2 |
pit_CNCPARAMETER | 3 |
pit_MACHINE_ORIENTATION | 4 |
pit_SCANCOMMAND | 5 |

Methods and Properties That Use This Enumeration

Insert
Insert
ItemType


ProbeItemType

ProbeItemType - Enumeration

Members

Name | Value | Description
pit_POSITIONAL | 1 |
pit_COMPOSITEMOVE | 2 |
pit_CNCPARAMETER | 3 |
pit_MACHINE_ORIENTATION | 4 |
pit_SCANCOMMAND | 5 |


ProbePathEditorBehavior

ProbePathEditorBehavior - Enumeration

Members

Name | Value | Description
ppeb_FULLMODE | 0 |
ppeb_SINGLEPOINT | 1 |
ppeb_INTERMEDIATEONLY | 2 |

Methods and Properties That Use This Enumeration

Behavior


ProbePathEditorMode

ProbePathEditorMode - Enumeration

Members

Name | Value | Description
ppem_INACTIVE | 0 |
ppem_EDITING | 1 |
ppem_CANCELING | 2 |
ppem_COMMITTING | 3 |

Methods and Properties That Use This Enumeration

Mode
OnStatusChanged


ProbePathFaultType

ProbePathFaultType - Enumeration

Members

Name | Value | Description
ppft_UNKNOWN | 0 |
ppft_COLLISION | 1 |
ppft_BAD_CONTACT | 2 |
ppft_NO_CONTACT | 3 |
ppft_MOVE_OUTSIDE_BOUNDARY | 4 |

Methods and Properties That Use This Enumeration

AddPointFault
AddRangeFault
FaultType


ProbePathStrategyType

ProbePathStrategyType - Enumeration

Members

Name | Value | Description
pps_UNKNOWN | 0 |
pps_SCAN | 1 |
pps_TOUCH | 2 |

Methods and Properties That Use This Enumeration

StrategyType


ProbePathType

ProbePathType - Enumeration

Members

Name | Value | Description
ppt_RAWCMMCoordinates | 0 |
ppt_CMMCoordinates | 1 |
ppt_CADCoordinates | 2 |

Methods and Properties That Use This Enumeration

PathType


ProbePathType

ProbePathType - Enumeration

Members

Name | Value | Description
ppt_RAWCMMCoordinates | 0 |
ppt_CMMCoordinates | 1 |
ppt_CADCoordinates | 2 |

Methods and Properties That Use This Enumeration

ConvertPointAccordingToMachinePosition
CoordinateSystem
MachineTransformCoordinateSystem


ProbePathVerificationStatus

ProbePathVerificationStatus - Enumeration

Members

Name | Value | Description
ppvs_UNVERIFIED | 0 |
ppvs_FAULTS_FOUND | 1 |
ppvs_NO_FAULTS_FOUND | 2 |
ppvs_UNDEFINED_PROBE | 3 |
ppvs_UNDEFINED_PROBE_PATH | 4 |

Methods and Properties That Use This Enumeration

VerificationStatus
VerificationStatus
VerificationStatusOfActiveItem
VerificationStatusOfRange


ProbePositionalCoordType

ProbePositionalCoordType - Enumeration

Members

Name | Value | Description
ppct_ABSOLUTE | 0 |
ppct_INCREMENTAL | 1 |

Methods and Properties That Use This Enumeration

CoordType
CoordType
InsertPositionalItem
OnCoordTypeChange


ProbePositionalItemType

ProbePositionalItemType - Enumeration

Members

Name | Value | Description
ppit_MEASURE_TO | 0 |
ppit_SAFE_MOVE_TO | 1 |
ppit_RAPID_MOVE_TO | 2 |
ppit_COMPOSITE_MEASURE_MOVE | 3 |

Methods and Properties That Use This Enumeration

InsertDynamicPositionalItem
InsertPositionalItem
OnPositionalItemTypeChange
PositionalItemType
PositionalItemType


PROBESENSORCYLINDER_TYPE

PROBESENSORCYLINDER_TYPE - Enumeration

Members

Name | Value | Description
psct_FLAT | 0 |
psct_HALFSPHERE | 1 |

Methods and Properties That Use This Enumeration

NoseType


PRODUCT_FEATURE

PRODUCT_FEATURE - Enumeration

Members

Name | Value | Description
ft_CREATE_PWI_SESSION | 0 |
ft_SAVE_PWI_FILE | 1 |
ft_CREATE_CMMDRIVER | 2 |
ft_MEASURING | 3 |
ft_MULTIPLEMEASURE | 4 |
ft_PARTMANAGEMENT | 5 |
ft_MULTIPARTMANAGEMENT | 6 |
ft_ADD_ITEM_IN_SEQUENCETREE | 7 |
ft_ADD_LASER_ITEM_IN_SEQUENCETREE | 8 |
ft_ADD_GEOMETRIC_ITEM_IN_SEQUENCETREE | 9 |
ft_ADD_SURFACE_ITEM_IN_SEQUENCETREE | 10 |
ft_MODIFY_ITEM_IN_SEQUENCETREE | 11 |
ft_POINTCLOUD_MANIPULATION | 12 |
ft_LASERSCAN_OFFLINE_EVALUATION | 13 |
ft_LASERSCAN_ONLINE_REPLAY | 14 |
ft_DISPLAY_POINTCLOUD_GUI | 15 |
ft_MEASURING_SURFACE_ONLINE | 16 |
ft_MEASURING_SURFACE_OFFLINE | 17 |
ft_FULL_OLEAUTOMATION | 18 |
ft_ADDIN_AND_MACRO | 19 |
ft_DYNAMIC_POINTSUPPORT | 20 |
ft_EMBEDDED_IGESTRANSLATOR | 21 |
ft_EMBEDDED_VDATRANSLATOR | 22 |
ft_CNC_OFFLINE | 23 |
ft_CNC_SIMULATOR | 24 |
ft_PROGRAM_EXPORT_OMV | 25 |
ft_PROGRAM_IMPORT_OMV | 26 |
ft_SET_PWIDOCUMENT_OWNERSHIP | 27 |
ft_MANUAL_PROGRAMMER | 28 |
ft_CAN_RUN_PMPOST | 29 |
ft_OMV_LITE | 30 |
ft_MULTAX | 31 |
ft_SCANNING | 32 |
ft_MULTAXSCANNING | 33 |

Methods and Properties That Use This Enumeration

FeatureLicenced


PRODUCT_TYPE

PRODUCT_TYPE - Enumeration

Members

Name | Value | Description
pt_BASED_ON_LICENCE | 128 |
pt_UNDEFINED | 0 |
pt_IS_VIEWER | 1 |
pt_IS_LITE | 2 |
pt_IS_OMVPRO | 4 |
pt_IS_OMVLITE | 8 |
pt_IS_FULL_VERSION | 16 |
pt_IS_PLAY_ONLY | 32 |
pt_REALLY_UNDEFINED | 64 |

Methods and Properties That Use This Enumeration

ProductType


PSAI_AddInAutoLoadOption

PSAI_AddInAutoLoadOption - Enumeration

Members

Name | Value | Description
psaiAUTOLOAD | 0 |
psaiNOTLOAD | 1 |


PSAI_AddInType

PSAI_AddInType - Enumeration

Members

Name | Value | Description
psaiDLL | 0 |
psaiSCRIPT | 1 |
psaiDOTNET | 2 |

Methods and Properties That Use This Enumeration

AddInType


PWI_ACTIVEFEATURE_VISIBILITY

PWI_ACTIVEFEATURE_VISIBILITY - Enumeration

Members

Name | Value | Description
pwi_afv_NORMAL | 0 |
pwi_afv_SHOW_ONLY_ACTIVE_FEATURE | 1 |

Methods and Properties That Use This Enumeration

ActiveFeatureVisibility


PWI_AlignmentType

PWI_AlignmentType - Enumeration

Members

Name | Value | Description
pwi_alg_PlanLinePoint | 36004 |
pwi_alg_3Spheres | 36010 |
pwi_alg_FreeFormFit | 36003 |
pwi_alg_FromFile | 36011 |
pwi_alg_FromGeometrics | 36013 |
pwi_alg_BestfitFromPoints | 36014 |
pwi_alg_RPS | 36016 |
pwi_alg_321 | 36017 |

Methods and Properties That Use This Enumeration

AddAlignment


PWI_AngleValidRange

PWI_AngleValidRange - Enumeration

Members

Name | Value | Description
pwiAngleRange_180_180 | 0 |
pwiAngleRange_0_360 | 1 |

Methods and Properties That Use This Enumeration

AngleRange


PWI_BESTFIT_Method

PWI_BESTFIT_Method - Enumeration

Members

Name | Value | Description
pwibst_TRANSLATION_ONLY | 1 |
pwibst_BST_FULL_BESTFIT | 2 |
pwibst_BST_2D_BESTFIT | 3 |
pwibst_BST_ROTATION_ONLY | 4 |
pwibst_BST_ROTATIONAL_AXIS | 5 |

Methods and Properties That Use This Enumeration

BestFitMethod


PWI_CompositeOffsetType

PWI_CompositeOffsetType - Enumeration

Members

Name | Value | Description
pwi_PROBED | 0 |
pwi_PROBED_REVERSED | 1 |
pwi_LINK | 2 |

Methods and Properties That Use This Enumeration

CompositeOffsetType


PWI_DynamicPointType

PWI_DynamicPointType - Enumeration

Members

Name | Value | Description
pwi_dp_SURFACE | 0 |
pwi_dp_EDGE | 1 |

Methods and Properties That Use This Enumeration

Convert
DynamicPointType


PWI_EdgeType

PWI_EdgeType - Enumeration

Members

Name | Value | Description
pwi_edge_Natural_U0 | 0 |
pwi_edge_Natural_U1 | 1 |
pwi_edge_Natural_V0 | 2 |
pwi_edge_Natural_V1 | 3 |
pwi_edge_InnerBoundary | 4 |
pwi_edge_OuterBoundary | 5 |

Methods and Properties That Use This Enumeration

EdgeType


PWI_EntityItemType

PWI_EntityItemType - Enumeration

Members

Name | Value | Description
pwi_grp_InspectionGroup_ | 36005 |
pwi_grp_Section_ | 36009 |
pwi_grp_GeometricGroup_ | 36006 |
pwi_grp_PointCloudGroup_ | 36015 |
pwi_alg_PlanLinePoint_ | 36004 |
pwi_alg_3Spheres_ | 36010 |
pwi_alg_FreeFormFit_ | 36003 |
pwi_alg_FromFile_ | 36011 |
pwi_alg_FromGeometrics_ | 36013 |
pwi_alg_BestfitFromPoints_ | 36014 |
pwi_alg_RPS_ | 36016 |
pwi_alg_321_ | 36017 |
pwi_srf_SurfacePointGuided_ | 36102 |
pwi_srf_EdgePointGuided_ | 36100 |
pwi_srf_SurfacePointOnTheFly_ | 36103 |
pwi_srf_EdgePointOnTheFly_ | 36101 |
pwi_ent_NominalPoint_ | 36611 |
pwi_ent_NominalVector_ | 36612 |
pwi_ent_Plane_Probed_ | 36200 |
pwi_ent_Plane_Bissector_ | 36206 |
pwi_ent_Plane_ParallelThroughPoint_ | 36204 |
pwi_ent_Plane_ParallelThroughRefPoint_ | 36207 |
pwi_ent_Plane_Nominal_ | 36208 |
pwi_ent_Plane_OffsetDistance_ | 36203 |
pwi_ent_Plane_PointVector_ | 36202 |
pwi_ent_Plane_WithOffsetPoints_ | 36209 |
pwi_ent_Plane_LineVector_ | 36210 |
pwi_ent_Plane_LinePoint_ | 36211 |
pwi_ent_Line_Probed_ | 36300 |
pwi_ent_Line_ThroughPoints_ | 36301 |
pwi_ent_Line_ProjectedOnPlane_ | 36302 |
pwi_ent_Line_Inter2Planes_ | 36303 |
pwi_ent_Line_WithAngle_ | 36304 |
pwi_ent_Line_Bissector_ | 36305 |
pwi_ent_Line_ParallelTroughPoint_ | 36306 |
pwi_ent_Line_PerpendicularTroughPoint_ | 36307 |
pwi_ent_Line_WithOffsetPoints_ | 36309 |
pwi_ent_Line_PointVector_ | 36310 |
pwi_ent_Line_AtAngle_ | 36308 |
pwi_ent_Point_ProjectedOnLine_ | 36400 |
pwi_ent_Point_Inter2LinesProjected_ | 36401 |
pwi_ent_Point_ProjectedOnPlane_ | 36404 |
pwi_ent_Point_Middle_ | 36405 |
pwi_ent_Point_InterPlaneLine_ | 36406 |
pwi_ent_Point_Inter3Planes_ | 36407 |
pwi_ent_Point_Inter2Lines3D_ | 36408 |
pwi_ent_Point_RetracePoint_ | 36614 |
pwi_ent_Point_FeatureIntersection_ | 36622 |
pwi_ent_Meas_Angle2Lines_ | 36500 |
pwi_ent_Meas_Angle2Planes_ | 36501 |
pwi_ent_Meas_3DAngle2Vectors_ | 36508 |
pwi_ent_Meas_3DAnglePlaneLine_ | 36509 |
pwi_ent_Meas_Distance2Points_ | 36502 |
pwi_ent_Meas_DistancePointLine_ | 36503 |
pwi_ent_Meas_DistancePointPlane_ | 36504 |
pwi_ent_Meas_RelativePosition_ | 36507 |
pwi_ent_Feat_Slot_ | 36600 |
pwi_ent_Feat_Rectangle_ | 36601 |
pwi_ent_Feat_Polygone_ | 36602 |
pwi_ent_Feat_CircleThroughNPoints_ | 36603 |
pwi_ent_Feat_ProbedCircle_ | 36604 |
pwi_ent_Feat_Cylinder_ | 36607 |
pwi_ent_Feat_Cone_ | 36608 |
pwi_ent_Feat_Sphere_ | 36609 |
pwi_ent_Feat_Torus_ | 36617 |
pwi_ent_Feat_SinglePointCircle_ | 36610 |
pwi_ent_Feat_Circle_PlaneConic_ | 36613 |
pwi_ent_Feat_Circle_OnConeAtHeight_ | 36618 |
pwi_ent_Feat_Circle_OnConeWithDiameter_ | 36619 |
pwi_ent_TruePosition_ | 36620 |
pwi_ent_GDT_ | 36621 |
pwi_ent_LaserScannedCircle_ | 36630 |
pwi_ent_LaserScannedSlot_ | 36631 |
pwi_ent_LaserScannedRectangle_ | 36632 |
pwi_ent_LaserScannedHexagon_ | 36633 |
pwi_ent_LaserScannedCorner_ | 36634 |
pwi_ent_LaserScannedPatch_ | 36635 |
pwi_ent_LaserScannedGapFlush_ | 36636 |
pwi_ent_LaserScannedSphere_ | 36637 |
pwi_ent_LaserScannedCylinder_ | 36638 |
pwi_ent_LaserScannedSCorner_ | 36639 |
pwi_ent_LaserScannedEdge_ | 36640 |
pwi_ent_DatumOnExistingFeatures_ | 36606 |
pwi_ent_DatumShift_ | 36623 |
pwi_ent_DatumRotate_ | 36624 |
pwi_ent_DatumRotateToFeature3D_ | 36625 |
pwi_ent_DatumRotateToFeature2D_ | 36626 |
pwi_ent_DatumImplicitCMM_ | 36627 |
pwi_ent_DatumImplicitPCS_ | 36628 |
pwi_ent_BestFit_ | 36000 |
pwi_ent_IntermediateProbePath_ | 36018 |
pwi_ent_Comment_ | 36001 |
pwi_ent_ProbeChangeItem_ | 36008 |
pwi_ent_BagOfPoints_ | 36700 |
pwi_ent_CADViewState_ | 36019 |
pwi_ent_CustomAction_ | 36020 |
pwi_ent_MultiaxisConfiguration_ | 36021 |
pwi_ent_CADViewReport_ | 36022 |

Methods and Properties That Use This Enumeration

AddItem
ItemType
NextItemName
OnPaletteButtonClicked


PWI_FeatureMask

PWI_FeatureMask - Enumeration

Members

Name | Value | Description
pwi_feature_Planes | 1 |
pwi_feature_Points | 2 |
pwi_feature_Lines | 4 |
pwi_feature_Datums | 8 |
pwi_feature_Vectors | 21 |
pwi_feature_RadialDimensions | 32 |
pwi_feature_LinearDimensions | 64 |
pwi_feature_Angles | 128 |
pwi_feature_Dimensions | 96 |
pwi_feature_DoubleValues | 224 |
pwi_feature_Cones | 256 |
pwi_feature_Cylinders | 512 |
pwi_feature_Shperes | 1024 |
pwi_feature_3DConics | 5888 |
pwi_feature_Circles | 2048 |
pwi_feature_Toruses | 4096 |
pwi_feature_Besfitables | 98304 |
pwi_feature_Feature2D | 403460 |
pwi_feature_Feature3D | 5889 |
pwi_feature_Geometric | 409349 |

Methods and Properties That Use This Enumeration

FeatureMask


PWI_FeatureType

PWI_FeatureType - Enumeration

Members

Name | Value | Description
pwi_feature_Plane | 1 |
pwi_feature_Point | 2 |
pwi_feature_Line | 4 |
pwi_feature_Datum | 8 |
pwi_feature_Vector | 16 |
pwi_feature_RadialDimension | 32 |
pwi_feature_LinearDimension | 64 |
pwi_feature_Angle | 128 |
pwi_feature_Cone | 256 |
pwi_feature_Cylinder | 512 |
pwi_feature_Sphere | 1024 |
pwi_feature_Circle | 2048 |
pwi_feature_Torus | 4096 |
pwi_feature_RoundedSlot | 8192 |
pwi_feature_SurfaceGuidedPoint | 16384 |
pwi_feature_SurfaceGroup | 32768 |
pwi_feature_PointCloud | 65536 |
pwi_feature_Rectangle | 131072 |
pwi_feature_Polygon | 262144 |

Methods and Properties That Use This Enumeration

FeatureType


PWI_GeometricItemType

PWI_GeometricItemType - Enumeration

Members

Name | Value | Description
pwi_ent_NominalPoint | 36611 |
pwi_ent_NominalVector | 36612 |
pwi_ent_Plane_Probed | 36200 |
pwi_ent_Plane_Bissector | 36206 |
pwi_ent_Plane_ParallelThroughRefPoint | 36207 |
pwi_ent_Plane_ParallelThroughPoint | 36204 |
pwi_ent_Plane_Nominal | 36208 |
pwi_ent_Plane_OffsetDistance | 36203 |
pwi_ent_Plane_PointVector | 36202 |
pwi_ent_Plane_WithOffsetPoints | 36209 |
pwi_ent_Plane_LineVector | 36210 |
pwi_ent_Plane_LinePoint | 36211 |
pwi_ent_Line_Probed | 36300 |
pwi_ent_Line_ThroughPoints | 36301 |
pwi_ent_Line_ProjectedOnPlane | 36302 |
pwi_ent_Line_Inter2Planes | 36303 |
pwi_ent_Line_WithAngle | 36304 |
pwi_ent_Line_Bissector | 36305 |
pwi_ent_Line_ParallelTroughPoint | 36306 |
pwi_ent_Line_PerpendicularTroughPoint | 36307 |
pwi_ent_Line_WithOffsetPoints | 36309 |
pwi_ent_Line_PointVector | 36310 |
pwi_ent_Line_AtAngle | 36308 |
pwi_ent_Point_ProjectedOnLine | 36400 |
pwi_ent_Point_Inter2LinesProjected | 36401 |
pwi_ent_Point_ProjectedOnPlane | 36404 |
pwi_ent_Point_Middle | 36405 |
pwi_ent_Point_InterPlaneLine | 36406 |
pwi_ent_Point_Inter3Planes | 36407 |
pwi_ent_Point_Inter2Lines3D | 36408 |
pwi_ent_Point_RetracePoint | 36614 |
pwi_ent_Point_FeatureIntersection | 36622 |
pwi_ent_Meas_Angle2Lines | 36500 |
pwi_ent_Meas_Angle2Planes | 36501 |
pwi_ent_Meas_3DAngle2Vectors | 36508 |
pwi_ent_Meas_3DAnglePlaneLine | 36509 |
pwi_ent_Meas_Distance2Points | 36502 |
pwi_ent_Meas_DistancePointLine | 36503 |
pwi_ent_Meas_DistancePointPlane | 36504 |
pwi_ent_Meas_RelativePosition | 36507 |
pwi_ent_Feat_Slot | 36600 |
pwi_ent_Feat_Rectangle | 36601 |
pwi_ent_Feat_Polygone | 36602 |
pwi_ent_Feat_CircleThroughNPoints | 36603 |
pwi_ent_Feat_ProbedCircle | 36604 |
pwi_ent_Feat_Cylinder | 36607 |
pwi_ent_Feat_Cone | 36608 |
pwi_ent_Feat_Sphere | 36609 |
pwi_ent_Feat_Torus | 36617 |
pwi_ent_Feat_SinglePointCircle | 36610 |
pwi_ent_Feat_Circle_PlaneConic | 36613 |
pwi_ent_Feat_Circle_OnConeAtHeight | 36618 |
pwi_ent_Feat_Circle_OnConeWithDiameter | 36619 |
pwi_ent_TruePosition | 36620 |
pwi_ent_GDT | 36621 |
pwi_ent_LaserScannedCircle | 36630 |
pwi_ent_LaserScannedSlot | 36631 |
pwi_ent_LaserScannedRectangle | 36632 |
pwi_ent_LaserScannedHexagon | 36633 |
pwi_ent_LaserScannedCorner | 36634 |
pwi_ent_LaserScannedPatch | 36635 |
pwi_ent_LaserScannedGapFlush | 36636 |
pwi_ent_LaserScannedSphere | 36637 |
pwi_ent_LaserScannedCylinder | 36638 |
pwi_ent_LaserScannedSCorner | 36639 |
pwi_ent_LaserScannedEdge | 36640 |

Methods and Properties That Use This Enumeration

AddGeometricItem


PWI_GeometryExplorerEventReason

PWI_GeometryExplorerEventReason - Enumeration

Members

Name | Value | Description
ger_ITEM_NEW | 1 |
ger_ITEM_POST_MODIFY | 2 |

Methods and Properties That Use This Enumeration

GeometryExplorerEvent


PWI_GridMode

PWI_GridMode - Enumeration

Members

Name | Value | Description
pgm_NONE | 33530 |
pgm_PCS | 33531 |
pgm_CMM | 33532 |
pgm_CMMTIP | 33533 |
pgm_WORLD | 33534 |
pgm_LOCAL_QUILL | 33535 |
pgm_LOCAL_PROBEHEAD | 33536 |
pgm_LOCAL_PROBETIP | 33537 |

Methods and Properties That Use This Enumeration

GridMode


PWI_GroupType

PWI_GroupType - Enumeration

Members

Name | Value | Description
pwi_grp_InspectionGroup | 36005 |
pwi_grp_Section | 36009 |
pwi_grp_GeometricGroup | 36006 |
pwi_grp_PointCloudGroup | 36015 |

Methods and Properties That Use This Enumeration

AddGroup


PWI_LINK_DATUMONEXISTINGFEATURES_

PWI_LINK_DATUMONEXISTINGFEATURES_ - Enumeration

Members

Name | Value | Description
pwi_link_DatumOnExistingFeatures__REFERENCEPLANE | 5000 |
pwi_link_DatumOnExistingFeatures__REFERENCELINE | 5001 |
pwi_link_DatumOnExistingFeatures__REFERENCEPOINT | 5002 |


PWI_LINK_DATUMROTATE

PWI_LINK_DATUMROTATE - Enumeration

Members

Name | Value | Description
pwi_link_DatumRotate_REFERENCEDATUM | 5000 |


PWI_LINK_DATUMROTATETOFEATURE2D

PWI_LINK_DATUMROTATETOFEATURE2D - Enumeration

Members

Name | Value | Description
pwi_link_DatumRotateToFeature2D_REFERENCEDATUM | 5000 |
pwi_link_DatumRotateToFeature2D_TARGETAXIS | 5001 |


PWI_LINK_DATUMROTATETOFEATURE3D

PWI_LINK_DATUMROTATETOFEATURE3D - Enumeration

Members

Name | Value | Description
pwi_link_DatumRotateToFeature3D_REFERENCEDATUM | 5000 |
pwi_link_DatumRotateToFeature3D_TARGETAXIS | 5001 |


PWI_LINK_DATUMSHIFT

PWI_LINK_DATUMSHIFT - Enumeration

Members

Name | Value | Description
pwi_link_DatumShift_REFERENCEDATUM | 5000 |


PWI_LINK_FEAT_CIRCLE_PLANECONIC

PWI_LINK_FEAT_CIRCLE_PLANECONIC - Enumeration

Members

Name | Value | Description
pwi_link_Feat_Circle_PlaneConic_REFERENCECONIC | 5000 |


PWI_LINK_FEAT_CIRCLETHROUGHNPOINTS

PWI_LINK_FEAT_CIRCLETHROUGHNPOINTS - Enumeration

Members

Name | Value | Description
pwi_link_Feat_CircleThroughNPoints_REFERENCEPLANE | 5000 |
pwi_link_Feat_CircleThroughNPoints_REFERENCEPOINTS | 5001 |


PWI_LINK_FEAT_POLYGONE

PWI_LINK_FEAT_POLYGONE - Enumeration

Members

Name | Value | Description
pwi_link_Feat_Polygone_REFERENCEPLANE | 5000 |


PWI_LINK_FEAT_RECTANGLE

PWI_LINK_FEAT_RECTANGLE - Enumeration

Members

Name | Value | Description
pwi_link_Feat_Rectangle_REFERENCEPLANE | 5000 |


PWI_LINK_FEAT_SLOT

PWI_LINK_FEAT_SLOT - Enumeration

Members

Name | Value | Description
pwi_link_Feat_Slot_REFERENCEPLANE | 5000 |


PWI_LINK_GEOMETRICCIRCLE

PWI_LINK_GEOMETRICCIRCLE - Enumeration

Members

Name | Value | Description
pwi_link_GeometricCircle_REFERENCEPLANE | 5000 |


PWI_LINK_LINE_BISSECTOR

PWI_LINK_LINE_BISSECTOR - Enumeration

Members

Name | Value | Description
pwi_link_Line_Bissector_REFERENCEPLANE | 5000 |
pwi_link_Line_Bissector_REFERENCELINE1 | 5001 |
pwi_link_Line_Bissector_REFERENCELINE2 | 5002 |


PWI_LINK_LINE_INTER2PLANES

PWI_LINK_LINE_INTER2PLANES - Enumeration

Members

Name | Value | Description
pwi_link_Line_Inter2Planes_REFERENCEPLANE1 | 5000 |
pwi_link_Line_Inter2Planes_REFERENCEPLANE2 | 5001 |


PWI_LINK_LINE_PARALLELTROUGHPOINT

PWI_LINK_LINE_PARALLELTROUGHPOINT - Enumeration

Members

Name | Value | Description
pwi_link_Line_ParallelTroughPoint_REFERENCEPLANE | 5000 |
pwi_link_Line_ParallelTroughPoint_REFERENCELINE | 5001 |


PWI_LINK_LINE_PERPENDICULARTROUGHPOINT

PWI_LINK_LINE_PERPENDICULARTROUGHPOINT - Enumeration

Members

Name | Value | Description
pwi_link_Line_PerpendicularTroughPoint_REFERENCEPLANE | 5000 |
pwi_link_Line_PerpendicularTroughPoint_REFERENCELINE | 5001 |


PWI_LINK_LINE_POINTVECTOR

PWI_LINK_LINE_POINTVECTOR - Enumeration

Members

Name | Value | Description
pwi_link_Line_PointVector_REFERENCEPOINT | 5000 |
pwi_link_Line_PointVector_REFERENCEVECTOR | 5001 |


PWI_LINK_LINE_PROBED

PWI_LINK_LINE_PROBED - Enumeration

Members

Name | Value | Description
pwi_link_Line_Probed_REFERENCEPLANE | 5000 |


PWI_LINK_LINE_PROJECTEDONPLANE

PWI_LINK_LINE_PROJECTEDONPLANE - Enumeration

Members

Name | Value | Description
pwi_link_Line_ProjectedOnPlane_REFERENCEPLANE | 5000 |
pwi_link_Line_ProjectedOnPlane_REFERENCELINE | 5001 |


PWI_LINK_LINE_THROUGHPOINTS

PWI_LINK_LINE_THROUGHPOINTS - Enumeration

Members

Name | Value | Description
pwi_link_Line_ThroughPoints_REFERENCEPOINT1 | 5000 |
pwi_link_Line_ThroughPoints_REFERENCEPOINT2 | 5001 |

Methods and Properties That Use This Enumeration

Links3


PWI_LINK_LINE_WITHANGLE

PWI_LINK_LINE_WITHANGLE - Enumeration

Members

Name | Value | Description
pwi_link_Line_WithAngle_REFERENCEPLANE | 5000 |
pwi_link_Line_WithAngle_REFERENCELINE | 5001 |
pwi_link_Line_WithAngle_REFERENCEPOINT | 5002 |


PWI_LINK_LINE_WITHOFFSETPOINT

PWI_LINK_LINE_WITHOFFSETPOINT - Enumeration

Members

Name | Value | Description
pwi_link_Line_WithOffsetPoint_REFERENCEPLANE | 5000 |


PWI_LINK_MEAS_3DANGLE2VECTORS

PWI_LINK_MEAS_3DANGLE2VECTORS - Enumeration

Members

Name | Value | Description
pwi_link_Meas_3DAngle2Vectors_REFERENCEDIRECTION1 | 5000 |
pwi_link_Meas_3DAngle2Vectors_REFERENCEDIRECTION2 | 5001 |


PWI_LINK_MEAS_3DANGLEPLANELINE

PWI_LINK_MEAS_3DANGLEPLANELINE - Enumeration

Members

Name | Value | Description
pwi_link_Meas_3DAnglePlaneLine_REFERENCEPLANE | 5000 |
pwi_link_Meas_3DAnglePlaneLine_REFERENCEDIRECTION | 5001 |


PWI_LINK_MEAS_ANGLE2LINES

PWI_LINK_MEAS_ANGLE2LINES - Enumeration

Members

Name | Value | Description
pwi_link_Meas_Angle2Lines_REFERENCEPLANE | 5000 |
pwi_link_Meas_Angle2Lines_REFERENCELINE1 | 5001 |
pwi_link_Meas_Angle2Lines_REFERENCELINE2 | 5002 |


PWI_LINK_MEAS_ANGLE2PLANES

PWI_LINK_MEAS_ANGLE2PLANES - Enumeration

Members

Name | Value | Description
pwi_link_Meas_Angle2Planes_REFERENCEPLANE1 | 5000 |
pwi_link_Meas_Angle2Planes_REFERENCEPLANE2 | 5001 |


PWI_LINK_MEAS_DISTANCE2POINTS

PWI_LINK_MEAS_DISTANCE2POINTS - Enumeration

Members

Name | Value | Description
pwi_link_Meas_Distance2Points_REFERENCEPOINT1 | 5000 |
pwi_link_Meas_Distance2Points_REFERENCEPOINT2 | 5001 |

Methods and Properties That Use This Enumeration

Links2


PWI_LINK_MEAS_DISTANCEPOINTLINE

PWI_LINK_MEAS_DISTANCEPOINTLINE - Enumeration

Members

Name | Value | Description
pwi_link_Meas_DistancePointLine_REFERENCEPOINT | 5000 |
pwi_link_Meas_DistancePointLine_REFERENCELINE | 5001 |


PWI_LINK_MEAS_DISTANCEPOINTPLANE

PWI_LINK_MEAS_DISTANCEPOINTPLANE - Enumeration

Members

Name | Value | Description
pwi_link_Meas_DistancePointPlane_REFERENCEPLANE | 5000 |
pwi_link_Meas_DistancePointPlane_REFERENCEPOINT | 5001 |


PWI_LINK_MEAS_RELATIVEPOSITION

PWI_LINK_MEAS_RELATIVEPOSITION - Enumeration

Members

Name | Value | Description
pwi_link_Meas_RelativePosition_REFERENCEPOINT1 | 5000 |
pwi_link_Meas_RelativePosition_REFERENCEPOINT2 | 5001 |


PWI_LINK_PLANE_BISSECTOR

PWI_LINK_PLANE_BISSECTOR - Enumeration

Members

Name | Value | Description
pwi_link_Plane_Bissector_REFERENCEPLANE1 | 5000 |
pwi_link_Plane_Bissector_REFERENCEPLANE2 | 5001 |


PWI_LINK_PLANE_LINEPOINT

PWI_LINK_PLANE_LINEPOINT - Enumeration

Members

Name | Value | Description
pwi_link_Plane_LinePoint_REFERENCELINE | 5000 |
pwi_link_Plane_LinePoint_REFERENCEPOINT | 5001 |


PWI_LINK_PLANE_LINEVECTOR

PWI_LINK_PLANE_LINEVECTOR - Enumeration

Members

Name | Value | Description
pwi_link_Plane_LineVector_REFERENCELINE | 5000 |
pwi_link_Plane_LineVector_REFERENCEVECTOR | 5001 |


PWI_LINK_PLANE_OFFSETDISTANCE

PWI_LINK_PLANE_OFFSETDISTANCE - Enumeration

Members

Name | Value | Description
pwi_link_Plane_OffsetDistance_REFERENCEPLANE | 5000 |


PWI_LINK_PLANE_PARALLELTHROUGHPOINT

PWI_LINK_PLANE_PARALLELTHROUGHPOINT - Enumeration

Members

Name | Value | Description
pwi_link_Plane_ParallelThroughPoint_REFERENCEPLANE | 5000 |


PWI_LINK_PLANE_POINTVECTOR

PWI_LINK_PLANE_POINTVECTOR - Enumeration

Members

Name | Value | Description
pwi_link_Plane_PointVector_REFERENCEPOINT | 5000 |
pwi_link_Plane_PointVector_REFERENCEVECTOR | 5001 |


PWI_LINK_POINT_FEATUREINTERSECTION

PWI_LINK_POINT_FEATUREINTERSECTION - Enumeration

Members

Name | Value | Description
pwi_link_Point_FeatureIntersection_REFERENCEFEATURE2D | 5000 |
pwi_link_Point_FeatureIntersection_REFERENCEFEATURE | 5001 |


PWI_LINK_POINT_INTER2LINES3D

PWI_LINK_POINT_INTER2LINES3D - Enumeration

Members

Name | Value | Description
pwi_link_Point_Inter2Lines3D_REFERENCELINE1 | 5000 |
pwi_link_Point_Inter2Lines3D_REFERENCELINE2 | 5001 |


PWI_LINK_POINT_INTER2LINESPROJECTED

PWI_LINK_POINT_INTER2LINESPROJECTED - Enumeration

Members

Name | Value | Description
pwi_link_Point_Inter2LinesProjected_REFERENCEPLANE | 5000 |
pwi_link_Point_Inter2LinesProjected_REFERENCELINE1 | 5001 |
pwi_link_Point_Inter2LinesProjected_REFERENCELINE2 | 5002 |


PWI_LINK_POINT_INTER3PLANES

PWI_LINK_POINT_INTER3PLANES - Enumeration

Members

Name | Value | Description
pwi_link_Point_Inter3Planes_REFERENCEPLANE1 | 5000 |
pwi_link_Point_Inter3Planes_REFERENCEPLANE2 | 5001 |
pwi_link_Point_Inter3Planes_REFERENCEPLANE3 | 5002 |


PWI_LINK_POINT_INTERPLANELINE

PWI_LINK_POINT_INTERPLANELINE - Enumeration

Members

Name | Value | Description
pwi_link_Point_InterPlaneLine_REFERENCEPLANE | 5000 |
pwi_link_Point_InterPlaneLine_REFERENCELINE | 5001 |


PWI_LINK_POINT_MIDDLE

PWI_LINK_POINT_MIDDLE - Enumeration

Members

Name | Value | Description
pwi_link_Point_Middle_REFERENCEPOINT1 | 5000 |
pwi_link_Point_Middle_REFERENCEPOINT2 | 5001 |


PWI_LINK_POINT_PROJECTEDONLINE

PWI_LINK_POINT_PROJECTEDONLINE - Enumeration

Members

Name | Value | Description
pwi_link_Point_ProjectedOnLine_REFERENCEPOINT | 5000 |
pwi_link_Point_ProjectedOnLine_REFERENCELINE | 5001 |


PWI_LINK_POINT_PROJECTEDONPLANE

PWI_LINK_POINT_PROJECTEDONPLANE - Enumeration

Members

Name | Value | Description
pwi_link_Point_ProjectedOnPlane_REFERENCEPLANE | 5000 |
pwi_link_Point_ProjectedOnPlane_REFERENCEPOINT | 5001 |


PWI_LinkType

PWI_LinkType - Enumeration

Members

Name | Value | Description
pwi_SimpleLink | 0 |
pwi_MultipleLink | 1 |
pwi_GDTDatumFeatureLink | 2 |
pwi_GDTFeaturesLink | 3 |

Methods and Properties That Use This Enumeration

LinkType


PWI_MainDirection

PWI_MainDirection - Enumeration

Members

Name | Value | Description
pwi_maindir_XPlus | 0 |
pwi_maindir_XMinus | 1 |
pwi_maindir_YPlus | 2 |
pwi_maindir_YMinus | 3 |
pwi_maindir_ZPlus | 4 |
pwi_maindir_ZMinus | 5 |

Methods and Properties That Use This Enumeration

Direction


PWI_MainPlane

PWI_MainPlane - Enumeration

Members

Name | Value | Description
pwi_plane_XOY | 0 |
pwi_plane_YOZ | 1 |
pwi_plane_ZOX | 2 |

Methods and Properties That Use This Enumeration

MainPlane


PWI_MaterialCondition

PWI_MaterialCondition - Enumeration

Members

Name | Value | Description
pwi_MEAN | 0 |
pwi_MMC | 1 |
pwi_LMC | 2 |

Methods and Properties That Use This Enumeration

MaterialCondition


PWI_MaterialSide

PWI_MaterialSide - Enumeration

Members

Name | Value | Description
pwi_side_BOSS | 0 |
pwi_side_HOLE | 1 |
pwi_side_NOTSPECIFIED | 2 |

Methods and Properties That Use This Enumeration

MaterialSide


PWI_MeasureState

PWI_MeasureState - Enumeration

Members

Name | Value | Description
pwi_ms_OK | 0 |
pwi_ms_FAILED | 1 |
pwi_ms_NOT_MEASURED | 2 |
pwi_ms_NOT_APPLICABLE | 3 |

Methods and Properties That Use This Enumeration

MeasureState
MeasureState


PWI_MODEL_SHADING_MODE

PWI_MODEL_SHADING_MODE - Enumeration

Members

Name | Value | Description
pwimsm_WIREFRAME | 0 |
pwimsm_SHADED_WIREFRAME | 1 |
pwimsm_TRANSPARENT_WIREFRAME | 2 |
pwimsm_HIDDEN_LINE | 3 |
pwimsm_SHADED | 4 |
pwimsm_TRANSPARENT | 5 |

Methods and Properties That Use This Enumeration

ModelShadingMode


PWI_NominalEntityFlag

PWI_NominalEntityFlag - Enumeration

Members

Name | Value | Description
pwi_nef_NOT_INITIALIZED | -1 |
pwi_nef_NOT_SUPPORTED | 0 |
pwi_nef_FREELY_DEFINED | 1 |
pwi_nef_DEFINED_BY_NOMINAL | 2 |
pwi_nef_IMPLICITLY_DEFINED | 3 |

Methods and Properties That Use This Enumeration

NominalEntityFlag


PWI_ParameterEXType

PWI_ParameterEXType - Enumeration

Members

Name | Value | Description
pvex_EXPLICITLY_DEFINED | 0 |
pvex_BASED_ON_EXISTING | 1 |

Methods and Properties That Use This Enumeration

type


PWI_ParamType

PWI_ParamType - Enumeration

Members

Name | Value | Description
pwi_param_Integer | 0 |
pwi_param_Dimension | 1 |
pwi_param_Angle | 2 |
pwi_param_Point3D | 3 |
pwi_param_Vector3D | 4 |
pwi_param_CompositeOffsets | 5 |
pwi_param_Direction | 6 |
pwi_param_MainPlane | 7 |
pwi_param_Boolean | 8 |
pwi_param_MaterialCondition | 9 |
pwi_param_Boundary | 10 |
pwi_param_CompensationMethod | 11 |
pwi_param_RPSConstraints | 12 |
pwi_param_MaterialSide | 13 |
pwi_param_Vector3DEX | 14 |
pwi_param_Point3DEX | 15 |
pwi_param_GuidedMeasure | 16 |
pwi_param_AngleQuadrant | 17 |
pwi_param_ReportSettings | 18 |
pwi_param_MatrixDefinition | 19 |

Methods and Properties That Use This Enumeration

ParameterType


PWI_POINTCLOUD_EXPORT_FLAG

PWI_POINTCLOUD_EXPORT_FLAG - Enumeration

Members

Name | Value | Description
pwipcx_CADCOORDINATES | 0 |
pwipcx_CMMCOORDINATES | 1 |

Methods and Properties That Use This Enumeration

ExportPoints
ExportPoints


PWI_POINTCLOUD_EXPORT_FORMAT

PWI_POINTCLOUD_EXPORT_FORMAT - Enumeration

Members

Name | Value | Description
pwipcx_ASCII | 0 |
pwipcx_PERCEPTRON_BINARY | 1 |
pwipcx_PERCEPTRON_XML | 2 |
pwipcx_PERCEPTRON_SWL | 3 |
pwipcx_IGES | 4 |

Methods and Properties That Use This Enumeration

ExportPoints
ExportPoints


PWI_POINTCLOUD_EXPORT_WHAT

PWI_POINTCLOUD_EXPORT_WHAT - Enumeration

Members

Name | Value | Description
pwipcx_ORIGINAL_POINTS | 0 |
pwipcx_ORIGINAL_POINTS_AND_VECTORS | 1 |
pwipcx_PROJECTED_POINTS | 2 |
pwipcx_PROJECTED_POINTS_AND_VECTORS | 3 |
pwipcx_DEVIATIONS | 4 |

Methods and Properties That Use This Enumeration

ExportPoints


PWI_PointType

PWI_PointType - Enumeration

Members

Name | Value | Description
pos_EdgePoint | 0 |
pos_SurfacePoint | 1 |

Methods and Properties That Use This Enumeration

PointType


PWI_PROBE_PATH_VISIBILITY

PWI_PROBE_PATH_VISIBILITY - Enumeration

Members

Name | Value | Description
ppv_SHOW_SELECTED | 0 |
ppv_SHOW_VISIBLE | 1 |
ppv_SHOW_ALL | 2 |
ppv_HIDE_ALL | 3 |
ppv_SHOW_BLOBSTEP | 4 |
ppv_UNSET | 5 |

Methods and Properties That Use This Enumeration

ProbePathVisibility


PWI_ProbeCompenstionMethod

PWI_ProbeCompenstionMethod - Enumeration

Members

Name | Value | Description
pcm_NO_COMPENSATION | 0 |
pcm_ALONG_A_EXPLICIT_DIRECTION | 1 |
pcm_ALONG_A_EXISTING_DIRECTION | 2 |

Methods and Properties That Use This Enumeration

CompensationMethod


PWI_PropertyType

PWI_PropertyType - Enumeration

Members

Name | Value | Description
pwi_property_Point3D | 0 |
pwi_property_Vector3D | 1 |
pwi_property_Angle | 2 |
pwi_property_LinearDimension | 3 |
pwi_property_RadialDimension | 4 |
pwi_property_GeometricTolerance | 5 |
pwi_property_UnitVector3D | 6 |

Methods and Properties That Use This Enumeration

PropertyType


PWI_RadialDimensionType

PWI_RadialDimensionType - Enumeration

Members

Name | Value | Description
pwi_Radius | 1 |
pwi_Diameter | 2 |

Methods and Properties That Use This Enumeration

ConvertTo
RadialDimensionType


PWI_RPSConstraintType

PWI_RPSConstraintType - Enumeration

Members

Name | Value | Description
pwirpsc_POINT | 0 |
pwirpsc_ROUNDEDSLOT | 1 |
pwirpsc_CIRCLE | 2 |
pwirpsc_POINT_ON_SURFACE | 3 |
pwirpsc_PLANE | 4 |
pwirpsc_AXIS | 5 |

Methods and Properties That Use This Enumeration

type


PWI_RPSDirectionLock

PWI_RPSDirectionLock - Enumeration

Members

Name | Value | Description
pwirps_LOCK_NOT_APPLICABLE | 0 |
pwirps_LOCK_DIRECTION | 1 |
pwirps_LOCK_POSITION | 2 |

Methods and Properties That Use This Enumeration

LockDirection


PWI_SequenceItemInterfaceType

PWI_SequenceItemInterfaceType - Enumeration

Members

Name | Value | Description
pwi_sq_ISequenceItem | 1 |
pwi_sq_ISequenceGroup | 3 |
pwi_sq_ISurfaceGroup | 7 |
pwi_sq_IGeometricItem | 9 |
pwi_sq_ISurfacePointItem | 17 |
pwi_sq_IEdgePointItem | 33 |
pwi_sq_IPointCloudGroup | 67 |
pwi_sq_IPointCloudItem | 129 |
pwi_sq_IDigitisedCurveItem | 257 |
pwi_sq_IGeometricGroup | 515 |
pwi_sq_IAlignmentItem | 1025 |
pwi_sq_IAlignmentFromFile | 3073 |
pwi_sq_IGDTItem | 4105 |
pwi_sq_IBestFitItem | 8201 |
pwi_sq_ISurfaceSectionGroup | 16391 |
pwi_sq_IntermediateProbePath | 32769 |
pwi_sq_MultiaxisConfiguration | 65537 |

Methods and Properties That Use This Enumeration

InterfaceType
IsA


PWI_SurfaceGroupType

PWI_SurfaceGroupType - Enumeration

Members

Name | Value | Description
pos_PointsOnTheFly | 0 |
pos_GuidedPoints | 1 |

Methods and Properties That Use This Enumeration

SurfaceGroupType


PWI_SurfacePoint

PWI_SurfacePoint - Enumeration

Members

Name | Value | Description
pwi_srf_SurfacePoint | 0 |
pwi_srf_EdgePoint | 1 |


PWI_Units

PWI_Units - Enumeration

Members

Name | Value | Description
units_INCHES | 0 |
units_MILLIMETRES | 1 |
units_UNDEFINED | -1 |

Methods and Properties That Use This Enumeration

OnUnitChange
Units


PWI_WindowState

PWI_WindowState - Enumeration

Members

Name | Value | Description
pwiMaximized | -4137 |
pwiMimimized | -4140 |
pwiNormal | -4143 |

Methods and Properties That Use This Enumeration

WindowState


PWICADENTITYTYPE

PWICADENTITYTYPE - Enumeration

Members

Name | Value | Description
pwicetARC3D | 0 |
pwicetCIRCLE3D | 1 |
pwicetLINE3D | 2 |
pwicetPLANE | 3 |
pwicetRECTANGLE | 4 |
pwicetSLOT | 5 |
pwicetCYLINDER | 6 |
pwicetPOLYLINE3D | 7 |
pwicetCURVE3D | 8 |
pwicetPOINT3D | 9 |
pwicetSPHERE | 10 |
pwicetTORUS | 11 |
pwicetSURFACE | 12 |
pwicetCONE | 13 |
pwicetUNSPECIFIED | -1 |

Methods and Properties That Use This Enumeration

Add
Filter
TypeOf


PWICommandBarButtonStyle

PWICommandBarButtonStyle - Enumeration

Members

Name | Value | Description
pwiButtonAutomatic | 0 |
pwiButtonIcon | 1 |
pwiButtonCaption | 16 |
pwiButtonIconAndCaption | 17 |
pwiButtonIconAndCaptionBelow | 273 |
pwiButtonIconAndWrapCaption | 4113 |
pwiButtonIconAndWrapCaptionBelow | 4369 |
pwiButtonWrapCaption | 4112 |

Methods and Properties That Use This Enumeration

Style


PWICommandBarPosition

PWICommandBarPosition - Enumeration

Members

Name | Value | Description
pwiBarLeft | 0 |
pwiBarTop | 1 |
pwiBarRight | 2 |
pwiBarBottom | 3 |
pwiBarFloating | 4 |
pwiBarPopup | 5 |

Methods and Properties That Use This Enumeration

Position


PWICommandBarType

PWICommandBarType - Enumeration

Members

Name | Value | Description
pwictrlMENUBAR | 1 |
pwictrlPOPUPBAR | 2 |
pwictrlNORMALBAR | 3 |

Methods and Properties That Use This Enumeration

CommandBarType


PWICommandControlType

PWICommandControlType - Enumeration

Members

Name | Value | Description
pwictrlBUTTON | 1 |
pwictrlCOMBOBOX | 2 |
pwictrlPOPUP | 3 |

Methods and Properties That Use This Enumeration

Add
ControlType


RECONCILIATION_STATUS

RECONCILIATION_STATUS - Enumeration

Members

Name | Value | Description
rs_NOT_RECONCILATED | 0 |
rs_EXACT_MATCH | 1 |
rs_RECONCILATED_PER_NAME | 2 |
rs_RECONCILATION_FAILED | 3 |


REPLAYPOINTSFLAGS

REPLAYPOINTSFLAGS - Enumeration

Members

Name | Value | Description
rpf_CMM_COORDINATES_POINTS | 1 |
rpf_USE_CURRENTPROBEDIAMETER | 2 |
rpf_APPLY_CURRENTPROBEOFFSET | 4 |
rpf_UNIT_MILLIMETERS | 8 |
rpf_UNIT_INCHES | 16 |


ScanInstructionType

ScanInstructionType - Enumeration

Members

Name | Value | Description
sit_unknown | 0 |
sit_circle | 1 |
sit_line | 2 |
sit_curve | 3 |
sit_helix | 4 |

Methods and Properties That Use This Enumeration

InsertScanCommand
ScanInstructionType


ScanItemFormat

ScanItemFormat - Enumeration

Members

Name | Value | Description
sif_Unknown | 0 |
sif_Normal | 1 |
sif_WithPrimary | 2 |
sif_WithSecondary | 3 |

Methods and Properties That Use This Enumeration

ScanItemFormat
ScanItemFormat


SOLVER_STATUS

SOLVER_STATUS - Enumeration

Members

Name | Value | Description
gdts_ERROR | -1 |
gdts_NOT_CALCULATED | 0 |
gdts_ACCEPTED | 1 |
gdts_REJECTED | 2 |


SRE_MODE

SRE_MODE - Enumeration

Members

Name | Value | Description
sre_MODE_ONESTEP_ALL | 0 |
sre_MODE_SELECTED | 1 |

Methods and Properties That Use This Enumeration

Mode


SRE_STATUS

SRE_STATUS - Enumeration

Members

Name | Value | Description
sre_RUNNING_ONESTEP | 0 |
sre_RUNNING_ALL | 1 |
sre_RUNNING_SELECTED | 2 |
sre_SUSPENDED | 3 |
sre_INACTIVE | 4 |
sre_SHUTTINGDOWN | 5 |
sre_COMPLETED | 6 |
sre_ABORTED | 7 |
sre_UNAVAILABLE | 8 |

Methods and Properties That Use This Enumeration

OnStatusChanged
status


status

status - Enumeration

Members

Name | Value | Description
ActionOK | 1 |
ActionDenied | 2 |
ActionPending | 3 |
ActionError | 4 |
ActionMultaxError | 5 |
ActionScanningError | 6 |
ActionQueued | 7 |

Methods and Properties That Use This Enumeration

Home
Home
MeasureTo
MultipointMove
RapidMoveTo
RapidMoveWithMachineOrientation
SafeMoveTo
ScanMove
SetAngles
TouchPoint


STEPSTATUS

STEPSTATUS - Enumeration

Members

Name | Value | Description
step_MADECURRENT | 0 |
step_STARTED | 1 |
step_COMPLETED | 2 |
step_ABORTED | 3 |

Methods and Properties That Use This Enumeration

CurStepStatus
OnStepStatusChanged


tagCALLCONV

tagCALLCONV - Enumeration

Members

Name | Value | Description
CC_FASTCALL | 0 |
CC_CDECL | 1 |
CC_MSCPASCAL | 2 |
CC_PASCAL | 2 |
CC_MACPASCAL | 3 |
CC_STDCALL | 4 |
CC_FPFASTCALL | 5 |
CC_SYSCALL | 6 |
CC_MPWCDECL | 7 |
CC_MPWPASCAL | 8 |
CC_MAX | 9 |


tagDESCKIND

tagDESCKIND - Enumeration

Members

Name | Value | Description
DESCKIND_NONE | 0 |
DESCKIND_FUNCDESC | 1 |
DESCKIND_VARDESC | 2 |
DESCKIND_TYPECOMP | 3 |
DESCKIND_IMPLICITAPPOBJ | 4 |
DESCKIND_MAX | 5 |


tagDOMNodeType

tagDOMNodeType - Enumeration

Description

Constants that define a node's type

Members

Name | Value | Description
NODE_INVALID | 0 |
NODE_ELEMENT | 1 |
NODE_ATTRIBUTE | 2 |
NODE_TEXT | 3 |
NODE_CDATA_SECTION | 4 |
NODE_ENTITY_REFERENCE | 5 |
NODE_ENTITY | 6 |
NODE_PROCESSING_INSTRUCTION | 7 |
NODE_COMMENT | 8 |
NODE_DOCUMENT | 9 |
NODE_DOCUMENT_TYPE | 10 |
NODE_DOCUMENT_FRAGMENT | 11 |
NODE_NOTATION | 12 |


tagFUNCFLAGS

tagFUNCFLAGS - Enumeration

Members

Name | Value | Description
FUNCFLAG_FRESTRICTED | 1 |
FUNCFLAG_FSOURCE | 2 |
FUNCFLAG_FBINDABLE | 4 |
FUNCFLAG_FREQUESTEDIT | 8 |
FUNCFLAG_FDISPLAYBIND | 16 |
FUNCFLAG_FDEFAULTBIND | 32 |
FUNCFLAG_FHIDDEN | 64 |
FUNCFLAG_FUSESGETLASTERROR | 128 |
FUNCFLAG_FDEFAULTCOLLELEM | 256 |
FUNCFLAG_FUIDEFAULT | 512 |
FUNCFLAG_FNONBROWSABLE | 1024 |
FUNCFLAG_FREPLACEABLE | 2048 |
FUNCFLAG_FIMMEDIATEBIND | 4096 |

Methods and Properties That Use This Enumeration

FuncFlags


tagFUNCKIND

tagFUNCKIND - Enumeration

Members

Name | Value | Description
FUNC_VIRTUAL | 0 |
FUNC_PUREVIRTUAL | 1 |
FUNC_NONVIRTUAL | 2 |
FUNC_STATIC | 3 |
FUNC_DISPATCH | 4 |

Methods and Properties That Use This Enumeration

FuncKind


tagINVOKEKIND

tagINVOKEKIND - Enumeration

Members

Name | Value | Description
INVOKE_FUNC | 1 |
INVOKE_PROPERTYGET | 2 |
INVOKE_PROPERTYPUT | 4 |
INVOKE_PROPERTYPUTREF | 8 |

Methods and Properties That Use This Enumeration

InvocationKind


tagSYSKIND

tagSYSKIND - Enumeration

Members

Name | Value | Description
SYS_WIN16 | 0 |
SYS_WIN32 | 1 |
SYS_MAC | 2 |
SYS_WIN64 | 3 |


tagTYPEFLAGS

tagTYPEFLAGS - Enumeration

Members

Name | Value | Description
TYPEFLAG_FAPPOBJECT | 1 |
TYPEFLAG_FCANCREATE | 2 |
TYPEFLAG_FLICENSED | 4 |
TYPEFLAG_FPREDECLID | 8 |
TYPEFLAG_FHIDDEN | 16 |
TYPEFLAG_FCONTROL | 32 |
TYPEFLAG_FDUAL | 64 |
TYPEFLAG_FNONEXTENSIBLE | 128 |
TYPEFLAG_FOLEAUTOMATION | 256 |
TYPEFLAG_FRESTRICTED | 512 |
TYPEFLAG_FAGGREGATABLE | 1024 |
TYPEFLAG_FREPLACEABLE | 2048 |
TYPEFLAG_FDISPATCHABLE | 4096 |
TYPEFLAG_FREVERSEBIND | 8192 |
TYPEFLAG_FPROXY | 16384 |

Methods and Properties That Use This Enumeration

TypeFlags


tagTYPEKIND

tagTYPEKIND - Enumeration

Members

Name | Value | Description
TKIND_ENUM | 0 |
TKIND_RECORD | 1 |
TKIND_MODULE | 2 |
TKIND_INTERFACE | 3 |
TKIND_DISPATCH | 4 |
TKIND_COCLASS | 5 |
TKIND_ALIAS | 6 |
TKIND_UNION | 7 |
TKIND_MAX | 8 |

Methods and Properties That Use This Enumeration

TypeInfoKind


tagVARKIND

tagVARKIND - Enumeration

Members

Name | Value | Description
VAR_PERINSTANCE | 0 |
VAR_STATIC | 1 |
VAR_CONST | 2 |
VAR_DISPATCH | 3 |


TOLERANCE_ZONE

TOLERANCE_ZONE - Enumeration

Members

Name | Value | Description
gdt_tz_UNSPECIFIED | -1 |
gdt_tz_FLOAT_TWOPARALLEL_PLANE | 0 |
gdt_tz_FLOAT_CYLINDER | 1 |
gdt_tz_FIXED_TWOPARALLEL_PLANE | 2 |
gdt_tz_FIXED_CYLINDER | 3 |
gdt_tz_COMPOSITE | 4 |


TOOLCHANGER_TYPE

TOOLCHANGER_TYPE - Enumeration

Members

Name | Value | Description
TOOLCHANGER_FAKE | 0 |
TOOLCHANGER_CNC | 1 |

Methods and Properties That Use This Enumeration

ToolChangerType


TOOLCHANGERSTATUS

TOOLCHANGERSTATUS - Enumeration

Members

Name | Value | Description
TOOLCHANGER_UNINITIALIZED | 0 |
TOOLCHANGER_WAITING_FOR_COMMAND | 1 |
TOOLCHANGER_BUSY | 2 |
TOOLCHANGER_ERROR | 3 |

Methods and Properties That Use This Enumeration

Status
StatusChanged


UNCOMPENSATE_TYPE

UNCOMPENSATE_TYPE - Enumeration

Members

Name | Value | Description
DEVICE_REPOSITION | 1 |

Methods and Properties That Use This Enumeration

UncompensatePoint
UnCompensatePointV


UNITTYPE

UNITTYPE - Enumeration

Members

Name | Value | Description
ut_INVALID | -1 |
ut_UNKNOWN | 0 |
ut_CONSTANT | 1 |
ut_LENGTH | 2 |
ut_LINEARVELOCITY | 3 |
ut_LINEARACCELERATION | 4 |
ut_ANGLE | 5 |
ut_SOLIDANGLE | 6 |
ut_ANGULARVELOCITY | 7 |
ut_ANGULARACCELERATION | 8 |
ut_AREA | 9 |
ut_VOLUME | 10 |
ut_FORCE | 11 |
ut_PRESSURE | 12 |

Methods and Properties That Use This Enumeration

UNITTYPE
UNITTYPE


ValidMeasureState

ValidMeasureState - Enumeration

Members

Name | Value | Description
pp_INVALID_MEASURE | 0 |
pp_PARTIALLY_MEASURED | 1 |
pp_FULLY_MEASURED | 2 |
pp_NOT_MEASURABLE | 3 |

Methods and Properties That Use This Enumeration

MeasurementState


VARENUM

VARENUM - Enumeration

Members

Name | Value | Description
VT_EMPTY | 0 |
VT_NULL | 1 |
VT_I2 | 2 |
VT_I4 | 3 |
VT_R4 | 4 |
VT_R8 | 5 |
VT_CY | 6 |
VT_DATE | 7 |
VT_BSTR | 8 |
VT_DISPATCH | 9 |
VT_ERROR | 10 |
VT_BOOL | 11 |
VT_VARIANT | 12 |
VT_UNKNOWN | 13 |
VT_DECIMAL | 14 |
VT_I1 | 16 |
VT_UI1 | 17 |
VT_UI2 | 18 |
VT_UI4 | 19 |
VT_I8 | 20 |
VT_UI8 | 21 |
VT_INT | 22 |
VT_UINT | 23 |
VT_VOID | 24 |
VT_HRESULT | 25 |
VT_PTR | 26 |
VT_SAFEARRAY | 27 |
VT_CARRAY | 28 |
VT_USERDEFINED | 29 |
VT_LPSTR | 30 |
VT_LPWSTR | 31 |
VT_RECORD | 36 |
VT_INT_PTR | 37 |
VT_UINT_PTR | 38 |
VT_FILETIME | 64 |
VT_BLOB | 65 |
VT_STREAM | 66 |
VT_STORAGE | 67 |
VT_STREAMED_OBJECT | 68 |
VT_STORED_OBJECT | 69 |
VT_BLOB_OBJECT | 70 |
VT_CF | 71 |
VT_CLSID | 72 |
VT_VERSIONED_STREAM | 73 |
VT_BSTR_BLOB | 4095 |
VT_VECTOR | 4096 |
VT_ARRAY | 8192 |
VT_BYREF | 16384 |
VT_RESERVED | 32768 |
VT_ILLEGAL | 65535 |
VT_ILLEGALMASKED | 4095 |
VT_TYPEMASK | 4095 |


VirtualCommand

VirtualCommand - Enumeration

Members

Name | Value | Description
VIRTUAL_OK | 0 |
VIRTUAL_CANCEL | 1 |
CANCEL_POINT | 2 |
RUN_PROGRAM | 3 |
STEP_PROGRAM | 4 |
PAUSE_PROGRAM | 5 |

Methods and Properties That Use This Enumeration

VirtualCommand
VirtualCommandCalibration


pwi_alg_PlanLinePoint - Components

Description

Features

 | Name | Type | Description
Item1 | PLP alignment 1 | pwi_feature_Datum | PLP alignment 1
Item2 | PLP alignment 1::Plane X (YOZ) | pwi_feature_Plane | PLP alignment 1::Plane X (YOZ)
Item3 | PLP alignment 1::Plane Y (XOZ) | pwi_feature_Plane | PLP alignment 1::Plane Y (XOZ)
Item4 | PLP alignment 1::Plane Z (XOY) | pwi_feature_Plane | PLP alignment 1::Plane Z (XOY)
Item5 | PLP alignment 1::X Axis | pwi_feature_Line | PLP alignment 1::X Axis
Item6 | PLP alignment 1::Y Axis | pwi_feature_Line | PLP alignment 1::Y Axis
Item7 | PLP alignment 1::Z Axis | pwi_feature_Line | PLP alignment 1::Z Axis
Item8 | PLP alignment 1::Origin | pwi_feature_Point | PLP alignment 1::Origin
Item9 | PLP alignment 1::Probed Plane | pwi_feature_Plane | PLP alignment 1::Probed Plane

Example


pwi_alg_3Spheres - Components

Description

Features

 | Name | Type | Description
Item1 | Three Spheres Alignment 1 | pwi_feature_Datum | Three Spheres Alignment 1
Item2 | Three Spheres Alignment 1::Plane X (YOZ) | pwi_feature_Plane | Three Spheres Alignment 1::Plane X (YOZ)
Item3 | Three Spheres Alignment 1::Plane Y (XOZ) | pwi_feature_Plane | Three Spheres Alignment 1::Plane Y (XOZ)
Item4 | Three Spheres Alignment 1::Plane Z (XOY) | pwi_feature_Plane | Three Spheres Alignment 1::Plane Z (XOY)
Item5 | Three Spheres Alignment 1::X Axis | pwi_feature_Line | Three Spheres Alignment 1::X Axis
Item6 | Three Spheres Alignment 1::Y Axis | pwi_feature_Line | Three Spheres Alignment 1::Y Axis
Item7 | Three Spheres Alignment 1::Z Axis | pwi_feature_Line | Three Spheres Alignment 1::Z Axis
Item8 | Three Spheres Alignment 1::Origin | pwi_feature_Point | Three Spheres Alignment 1::Origin
Item9 | Three Spheres Alignment 1:: | pwi_feature_Plane | Three Spheres Alignment 1::

Example


pwi_alg_FreeFormFit - Components

Description

Features

 | Name | Type | Description
Item1 | Free Form Fit Alignment 1 | pwi_feature_Datum | Free Form Fit Alignment 1
Item2 | Free Form Fit Alignment 1::Plane X (YOZ) | pwi_feature_Plane | Free Form Fit Alignment 1::Plane X (YOZ)
Item3 | Free Form Fit Alignment 1::Plane Y (XOZ) | pwi_feature_Plane | Free Form Fit Alignment 1::Plane Y (XOZ)
Item4 | Free Form Fit Alignment 1::Plane Z (XOY) | pwi_feature_Plane | Free Form Fit Alignment 1::Plane Z (XOY)
Item5 | Free Form Fit Alignment 1::X Axis | pwi_feature_Line | Free Form Fit Alignment 1::X Axis
Item6 | Free Form Fit Alignment 1::Y Axis | pwi_feature_Line | Free Form Fit Alignment 1::Y Axis
Item7 | Free Form Fit Alignment 1::Z Axis | pwi_feature_Line | Free Form Fit Alignment 1::Z Axis
Item8 | Free Form Fit Alignment 1::Origin | pwi_feature_Point | Free Form Fit Alignment 1::Origin

Example


pwi_alg_FromFile - Components

Description

Features

 | Name | Type | Description
Item1 | Alignment from file 1 | pwi_feature_Datum | Alignment from file 1
Item2 | Alignment from file 1::Plane X (YOZ) | pwi_feature_Plane | Alignment from file 1::Plane X (YOZ)
Item3 | Alignment from file 1::Plane Y (XOZ) | pwi_feature_Plane | Alignment from file 1::Plane Y (XOZ)
Item4 | Alignment from file 1::Plane Z (XOY) | pwi_feature_Plane | Alignment from file 1::Plane Z (XOY)
Item5 | Alignment from file 1::X Axis | pwi_feature_Line | Alignment from file 1::X Axis
Item6 | Alignment from file 1::Y Axis | pwi_feature_Line | Alignment from file 1::Y Axis
Item7 | Alignment from file 1::Z Axis | pwi_feature_Line | Alignment from file 1::Z Axis
Item8 | Alignment from file 1::Origin | pwi_feature_Point | Alignment from file 1::Origin

Example


pwi_alg_FromGeometrics - Components

Description

Features

 | Name | Type | Description
Item1 | PLP alignment 1 | pwi_feature_Datum | PLP alignment 1
Item2 | PLP alignment 1::Plane X (YOZ) | pwi_feature_Plane | PLP alignment 1::Plane X (YOZ)
Item3 | PLP alignment 1::Plane Y (XOZ) | pwi_feature_Plane | PLP alignment 1::Plane Y (XOZ)
Item4 | PLP alignment 1::Plane Z (XOY) | pwi_feature_Plane | PLP alignment 1::Plane Z (XOY)
Item5 | PLP alignment 1::X Axis | pwi_feature_Line | PLP alignment 1::X Axis
Item6 | PLP alignment 1::Y Axis | pwi_feature_Line | PLP alignment 1::Y Axis
Item7 | PLP alignment 1::Z Axis | pwi_feature_Line | PLP alignment 1::Z Axis
Item8 | PLP alignment 1::Origin | pwi_feature_Point | PLP alignment 1::Origin

Links

 | Name | Type | Description
Item1 | Reference Plane 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 1
Item2 | Reference Line 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Line 1
Item3 | Reference Point 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 1

Parameters

 | Name | Type | Description
Item1 | Main plane | pwi_param_Direction As IParameterDirection | Datum main plane (XOY)
Item2 | Main axis | pwi_param_Direction As IParameterDirection | Datum main axis
Item3 | Origin | pwi_param_Point3D As IParameterPoint3D | Datum origin
Item4 | Local datum | pwi_param_MatrixDefinition As IParameterMatrixDefinition | Local datum relative to which the PLP is defined.

Example


pwi_alg_BestfitFromPoints - Components

Description

Features

 | Name | Type | Description
Item1 | PLP alignment 1 | pwi_feature_Datum | PLP alignment 1
Item2 | PLP alignment 1::Plane X (YOZ) | pwi_feature_Plane | PLP alignment 1::Plane X (YOZ)
Item3 | PLP alignment 1::Plane Y (XOZ) | pwi_feature_Plane | PLP alignment 1::Plane Y (XOZ)
Item4 | PLP alignment 1::Plane Z (XOY) | pwi_feature_Plane | PLP alignment 1::Plane Z (XOY)
Item5 | PLP alignment 1::X Axis | pwi_feature_Line | PLP alignment 1::X Axis
Item6 | PLP alignment 1::Y Axis | pwi_feature_Line | PLP alignment 1::Y Axis
Item7 | PLP alignment 1::Z Axis | pwi_feature_Line | PLP alignment 1::Z Axis
Item8 | PLP alignment 1::Origin | pwi_feature_Point | PLP alignment 1::Origin

Links

 | Name | Type | Description
Item1 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point
Item2 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point
Item3 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point

Parameters

 | Name | Type | Description
Item1 | Hard Point | pwi_param_Boolean As IParameterBoolean | Set this value to True if the first point of the Best Fit must be considered as a fixed point
Item2 | Point co-ordinate | pwi_param_Point3D As IParameterPoint3D | Point co-ordinate
Item3 | Point co-ordinate | pwi_param_Point3D As IParameterPoint3D | Point co-ordinate
Item4 | Point co-ordinate | pwi_param_Point3D As IParameterPoint3D | Point co-ordinate

Example


pwi_alg_RPS - Components

Description

Features

 | Name | Type | Description
Item1 | RPS Alignment 1 | pwi_feature_Datum | RPS Alignment 1
Item2 | RPS Alignment 1::Plane X (YOZ) | pwi_feature_Plane | RPS Alignment 1::Plane X (YOZ)
Item3 | RPS Alignment 1::Plane Y (XOZ) | pwi_feature_Plane | RPS Alignment 1::Plane Y (XOZ)
Item4 | RPS Alignment 1::Plane Z (XOY) | pwi_feature_Plane | RPS Alignment 1::Plane Z (XOY)
Item5 | RPS Alignment 1::X Axis | pwi_feature_Line | RPS Alignment 1::X Axis
Item6 | RPS Alignment 1::Y Axis | pwi_feature_Line | RPS Alignment 1::Y Axis
Item7 | RPS Alignment 1::Z Axis | pwi_feature_Line | RPS Alignment 1::Z Axis
Item8 | RPS Alignment 1::Origin | pwi_feature_Point | RPS Alignment 1::Origin

Parameters

 | Name | Type | Description
Item1 | Offset list | pwi_param_RPSConstraints As IParameterRPSConstraint | Please define the offset list

Example


pwi_alg_321 - Components

Description

Example


pwi_ent_NominalPoint - Components

Description

Features

 | Name | Type | Description
Item1 | Point 1 | pwi_feature_Point | Point 1

Parameters

 | Name | Type | Description
Item1 | Point co-ordinate | pwi_param_Point3D As IParameterPoint3D | Point co-ordinate

Example


pwi_ent_NominalVector - Components

Description

Features

 | Name | Type | Description
Item1 | Vector 1 | pwi_feature_Vector | Vector 1

Parameters

 | Name | Type | Description
Item1 | Vector co-ordinates | pwi_param_Vector3D As IParameterVector3D | Vector co-ordinates

Example


pwi_ent_Plane_Probed - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 1 | pwi_feature_Plane | Plane 1

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary
Item2 | Centroid | pwi_param_Point3D As IParameterPoint3D | Length of the plane

Properties

 | Name | Type | Description
Item1 | Flatness | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Flatness
Item2 | Normal Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Normal Vector

Example


pwi_ent_Plane_Bissector - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 2 | pwi_feature_Plane | Plane 2

Links

 | Name | Type | Description
Item1 | Reference Plane 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 1
Item2 | Reference Plane 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 2

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Normal Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Normal Vector

Example


pwi_ent_Plane_ParallelThroughRefPoint - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 3 | pwi_feature_Plane | Plane 3

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Point 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 1

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Distance | pwi_property_LinearDimension As PropertyLinearDimension | Distance

Example


pwi_ent_Plane_ParallelThroughPoint - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 4 | pwi_feature_Plane | Plane 4

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary
Item2 | Material Condition | pwi_param_MaterialCondition As IParameterMaterialCondition | Select the material condition

Properties

 | Name | Type | Description
Item1 | Distance | pwi_property_LinearDimension As PropertyLinearDimension | Distance

Example


pwi_ent_Plane_Nominal - Components

Description

Example


pwi_ent_Plane_OffsetDistance - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 5 | pwi_feature_Plane | Plane 5

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary
Item2 | Distance | pwi_param_Dimension As IParameterDimension | Distance

Example


pwi_ent_Plane_PointVector - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 6 | pwi_feature_Plane | Plane 6

Links

 | Name | Type | Description
Item1 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point
Item2 | Reference Vector | pwi_SimpleLink As ISequenceSimpleLink | Reference Vector

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Example


pwi_ent_Plane_WithOffsetPoints - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 7 | pwi_feature_Plane | Plane 7

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary
Item2 | Offset list | pwi_param_CompositeOffsets As IParameterCompositeOffset | Please define the offset list
Item3 | Select the alternate solution | pwi_param_Boolean As IParameterBoolean | Click here if you want to select the alternate solution

Properties

 | Name | Type | Description
Item1 | Normal Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Normal Vector

Example


pwi_ent_Plane_LineVector - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 8 | pwi_feature_Plane | Plane 8

Links

 | Name | Type | Description
Item1 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line
Item2 | Reference Vector | pwi_SimpleLink As ISequenceSimpleLink | Reference Vector

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Normal Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Normal Vector

Example


pwi_ent_Plane_LinePoint - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 9 | pwi_feature_Plane | Plane 9

Links

 | Name | Type | Description
Item1 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line
Item2 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Normal Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Normal Vector

Example


pwi_ent_Line_Probed - Components

Description

Features

 | Name | Type | Description
Item1 | Line 1 | pwi_feature_Line | Line 1

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary
Item2 | Offset/Thickness | pwi_param_Dimension As IParameterDimension | Enter the thickness of the metal sheet if this entity is measured from the B surface
Item3 | Centroid | pwi_param_Point3D As IParameterPoint3D | Centroid of the line
Item4 | Length | pwi_param_Dimension As IParameterDimension | Length of the line
Item5 | Guided Measure | pwi_param_GuidedMeasure As IParameterGuidedMeasure | Guided Measure Parameters to be used with rigid probe
Item6 | Material Side | pwi_param_MaterialSide As IParameterMaterialSide | Material Side

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector
Item2 | Straightness | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Straightness

Example


pwi_ent_Line_ThroughPoints - Components

Description

Features

 | Name | Type | Description
Item1 | Line 2 | pwi_feature_Line | Line 2

Links

 | Name | Type | Description
Item1 | Reference Point 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 1
Item2 | Reference Point 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 2

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector
Item2 | Distance | pwi_property_LinearDimension As PropertyLinearDimension | Distance

Example


pwi_ent_Line_ProjectedOnPlane - Components

Description

Features

 | Name | Type | Description
Item1 | Line 3 | pwi_feature_Line | Line 3

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector

Example


pwi_ent_Line_Inter2Planes - Components

Description

Features

 | Name | Type | Description
Item1 | Line 4 | pwi_feature_Line | Line 4

Links

 | Name | Type | Description
Item1 | Reference Plane 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 1
Item2 | Reference Plane 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 2

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector

Example


pwi_ent_Line_WithAngle - Components

Description

Example


pwi_ent_Line_Bissector - Components

Description

Features

 | Name | Type | Description
Item1 | Line 5 | pwi_feature_Line | Line 5

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Line 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Line 1
Item3 | Reference Line 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Line 2

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector
Item2 | Half Angle | pwi_property_Angle As PropertyAngle | Half Angle
Item3 | Intersection | pwi_property_Point3D As PropertyPoint3D | Intersection

Example


pwi_ent_Line_ParallelTroughPoint - Components

Description

Features

 | Name | Type | Description
Item1 | Line 6 | pwi_feature_Line | Line 6

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary
Item2 | Material Condition | pwi_param_MaterialCondition As IParameterMaterialCondition | Select the material condition

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector
Item2 | Distance | pwi_property_LinearDimension As PropertyLinearDimension | Distance

Example


pwi_ent_Line_PerpendicularTroughPoint - Components

Description

Features

 | Name | Type | Description
Item1 | Line 7 | pwi_feature_Line | Line 7

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary
Item2 | Material Condition | pwi_param_MaterialCondition As IParameterMaterialCondition | Select the material condition

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector

Example


pwi_ent_Line_WithOffsetPoints - Components

Description

Features

 | Name | Type | Description
Item1 | Line 8 | pwi_feature_Line | Line 8

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary
Item2 | Offset list | pwi_param_CompositeOffsets As IParameterCompositeOffset | Please define the offset list
Item3 | Select the alternate solution | pwi_param_Boolean As IParameterBoolean | Click here if you want to select the alternate solution

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector

Example


pwi_ent_Line_PointVector - Components

Description

Features

 | Name | Type | Description
Item1 | Line 9 | pwi_feature_Line | Line 9

Links

 | Name | Type | Description
Item1 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point
Item2 | Reference Vector | pwi_SimpleLink As ISequenceSimpleLink | Reference Vector

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector

Example


pwi_ent_Line_AtAngle - Components

Description

Features

 | Name | Type | Description
Item1 | Line 10 | pwi_feature_Line | Line 10

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line
Item3 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point

Parameters

 | Name | Type | Description
Item1 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary
Item2 | Angle | pwi_param_Angle As IParameterAngle | Angle

Properties

 | Name | Type | Description
Item1 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector

Example


pwi_ent_Point_ProjectedOnLine - Components

Description

Features

 | Name | Type | Description
Item1 | Point 2 | pwi_feature_Point | Point 2

Links

 | Name | Type | Description
Item1 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point
Item2 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line

Properties

 | Name | Type | Description
Item1 | Point | pwi_property_Point3D As PropertyPoint3D | Point

Example


pwi_ent_Point_Inter2LinesProjected - Components

Description

Features

 | Name | Type | Description
Item1 | Point 3 | pwi_feature_Point | Point 3

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Line 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Line 1
Item3 | Reference Line 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Line 2

Properties

 | Name | Type | Description
Item1 | Point | pwi_property_Point3D As PropertyPoint3D | Point

Example


pwi_ent_Point_ProjectedOnPlane - Components

Description

Features

 | Name | Type | Description
Item1 | Point 4 | pwi_feature_Point | Point 4

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point

Properties

 | Name | Type | Description
Item1 | Point | pwi_property_Point3D As PropertyPoint3D | Point

Example


pwi_ent_Point_Middle - Components

Description

Features

 | Name | Type | Description
Item1 | Point 5 | pwi_feature_Point | Point 5

Links

 | Name | Type | Description
Item1 | Reference Point 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 1
Item2 | Reference Point 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 2

Properties

 | Name | Type | Description
Item1 | Point | pwi_property_Point3D As PropertyPoint3D | Point

Example


pwi_ent_Point_InterPlaneLine - Components

Description

Features

 | Name | Type | Description
Item1 | Point 6 | pwi_feature_Point | Point 6

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line

Properties

 | Name | Type | Description
Item1 | Point | pwi_property_Point3D As PropertyPoint3D | Point

Example


pwi_ent_Point_Inter3Planes - Components

Description

Features

 | Name | Type | Description
Item1 | Point 7 | pwi_feature_Point | Point 7

Links

 | Name | Type | Description
Item1 | Reference Plane 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 1
Item2 | Reference Plane 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 2
Item3 | Reference Plane 3 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 3

Properties

 | Name | Type | Description
Item1 | Point | pwi_property_Point3D As PropertyPoint3D | Point

Example


pwi_ent_Point_Inter2Lines3D - Components

Description

Features

 | Name | Type | Description
Item1 | Point 8 | pwi_feature_Point | Point 8

Links

 | Name | Type | Description
Item1 | Reference Line 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Line 1
Item2 | Reference Line 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Line 2

Properties

 | Name | Type | Description
Item1 | Point | pwi_property_Point3D As PropertyPoint3D | Point

Example


pwi_ent_Point_RetracePoint - Components

Description

Features

 | Name | Type | Description
Item1 | RP 1::Target point | pwi_feature_Point | RP 1::Target point

Parameters

 | Name | Type | Description
Item1 | Probe Radius Compensation Method | pwi_param_CompensationMethod As IParameterCompensationMethod | Probe Radius Compensation Method

Properties

 | Name | Type | Description
Item1 | Target point | pwi_property_Point3D As PropertyPoint3D | Target point
Item2 | Distance To Target Point | pwi_property_LinearDimension As PropertyLinearDimension | Distance To Target Point
Item3 | Distance to Target Plane | pwi_property_LinearDimension As PropertyLinearDimension | Distance to Target Plane
Item4 | Distance On Plane | pwi_property_LinearDimension As PropertyLinearDimension | Distance On Plane

Example


pwi_ent_Point_FeatureIntersection - Components

Description

Features

 | Name | Type | Description
Item1 | Point 9 | pwi_feature_Point | Point 9

Links

 | Name | Type | Description
Item1 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line
Item2 | Reference Feature | pwi_SimpleLink As ISequenceSimpleLink | Reference Feature

Parameters

 | Name | Type | Description
Item1 | Use Unbounded Entities | pwi_param_Boolean As IParameterBoolean | Evaluate the intersection by extending the entity if no intersection can be calculated

Properties

 | Name | Type | Description
Item1 | Point | pwi_property_Point3D As PropertyPoint3D | Point

Example


pwi_ent_Meas_Angle2Lines - Components

Description

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Line 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Line 1
Item3 | Reference Line 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Line 2

Properties

 | Name | Type | Description
Item1 | Angle | pwi_property_Angle As PropertyAngle | Angle

Example


pwi_ent_Meas_Angle2Planes - Components

Description

Links

 | Name | Type | Description
Item1 | Reference Plane 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 1
Item2 | Reference Plane 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane 2

Properties

 | Name | Type | Description
Item1 | Angle | pwi_property_Angle As PropertyAngle | Angle

Example


pwi_ent_Meas_3DAngle2Vectors - Components

Description

Links

 | Name | Type | Description
Item1 | Reference vector 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference vector 1
Item2 | Reference vector 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference vector 2

Properties

 | Name | Type | Description
Item1 | Angle | pwi_property_Angle As PropertyAngle | Angle

Example


pwi_ent_Meas_3DAnglePlaneLine - Components

Description

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Vector | pwi_SimpleLink As ISequenceSimpleLink | Reference Vector

Properties

 | Name | Type | Description
Item1 | Angle | pwi_property_Angle As PropertyAngle | Angle

Example


pwi_ent_Meas_Distance2Points - Components

Description

Links

 | Name | Type | Description
Item1 | Reference Point 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 1
Item2 | Reference Point 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 2

Properties

 | Name | Type | Description
Item1 | Distance | pwi_property_LinearDimension As PropertyLinearDimension | Distance

Example


pwi_ent_Meas_DistancePointLine - Components

Description

Links

 | Name | Type | Description
Item1 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point
Item2 | Reference Line | pwi_SimpleLink As ISequenceSimpleLink | Reference Line

Properties

 | Name | Type | Description
Item1 | Distance | pwi_property_LinearDimension As PropertyLinearDimension | Distance

Example


pwi_ent_Meas_DistancePointPlane - Components

Description

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Point | pwi_SimpleLink As ISequenceSimpleLink | Reference Point

Properties

 | Name | Type | Description
Item1 | Distance | pwi_property_LinearDimension As PropertyLinearDimension | Distance

Example


pwi_ent_Meas_RelativePosition - Components

Description

Links

 | Name | Type | Description
Item1 | Reference Point 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 1
Item2 | Reference Point 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 2

Properties

 | Name | Type | Description
Item1 | Position | pwi_property_Vector3D As PropertyVector3D | Position
Item2 | True Position | pwi_property_GeometricTolerance As PropertyGeometricTolerance | True Position

Example


pwi_ent_Feat_Slot - Components

Description

Features

 | Name | Type | Description
Item1 | Slot 1::Centre | pwi_feature_Point | Slot 1::Centre
Item2 | Slot 1::Centre1 | pwi_feature_Point | Slot 1::Centre1
Item3 | Slot 1::Centre2 | pwi_feature_Point | Slot 1::Centre2
Item4 | Slot 1::Main Axis | pwi_feature_Line | Slot 1::Main Axis
Item5 | Slot 1::Small Axis | pwi_feature_Line | Slot 1::Small Axis
Item6 | Slot 1 | pwi_feature_RoundedSlot | Slot 1

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane

Parameters

 | Name | Type | Description
Item1 | Offset/Thickness | pwi_param_Dimension As IParameterDimension | Enter the thickness of the metal sheet if this entity is measured from the B surface
Item2 | Guided Measure | pwi_param_GuidedMeasure As IParameterGuidedMeasure | Guided Measure Parameters to be used with rigid probe
Item3 | Material Side | pwi_param_MaterialSide As IParameterMaterialSide | Material Side

Properties

 | Name | Type | Description
Item1 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item2 | Length | pwi_property_LinearDimension As PropertyLinearDimension | Length
Item3 | Width | pwi_property_RadialDimension As PropertyRadialDimension | Width
Item4 | Profile | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Profile
Item5 | Main Axis | pwi_property_UnitVector3D As PropertyUnitVector3D | Main Axis

Example


pwi_ent_Feat_Rectangle - Components

Description

Features

 | Name | Type | Description
Item1 | Rectangle 1::Centre | pwi_feature_Point | Rectangle 1::Centre
Item2 | Rectangle 1::Main Axis | pwi_feature_Line | Rectangle 1::Main Axis
Item3 | Rectangle 1::Small Axis | pwi_feature_Line | Rectangle 1::Small Axis
Item4 | Rectangle 1 | pwi_feature_Rectangle | Rectangle 1

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane

Parameters

 | Name | Type | Description
Item1 | Offset/Thickness | pwi_param_Dimension As IParameterDimension | Enter the thickness of the metal sheet if this entity is measured from the B surface
Item2 | Guided Measure | pwi_param_GuidedMeasure As IParameterGuidedMeasure | Guided Measure Parameters to be used with rigid probe
Item3 | Material Side | pwi_param_MaterialSide As IParameterMaterialSide | Material Side

Properties

 | Name | Type | Description
Item1 | Width | pwi_property_LinearDimension As PropertyLinearDimension | Width
Item2 | Length | pwi_property_LinearDimension As PropertyLinearDimension | Length
Item3 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item4 | Main Axis | pwi_property_UnitVector3D As PropertyUnitVector3D | Main Axis

Example


pwi_ent_Feat_Polygone - Components

Description

Features

 | Name | Type | Description
Item1 | Polygon 1::Centre | pwi_feature_Point | Polygon 1::Centre
Item2 | Polygon 1 | pwi_feature_Polygon | Polygon 1
Item3 | Polygon 1::Main Axis | pwi_feature_Line | Polygon 1::Main Axis

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane

Parameters

 | Name | Type | Description
Item1 | No. of sides | pwi_param_Integer As IParameterInteger | No. of sides
Item2 | Offset/Thickness | pwi_param_Dimension As IParameterDimension | Enter the thickness of the metal sheet if this entity is measured from the B surface
Item3 | Guided Measure | pwi_param_GuidedMeasure As IParameterGuidedMeasure | Guided Measure Parameters to be used with rigid probe
Item4 | Material Side | pwi_param_MaterialSide As IParameterMaterialSide | Material Side

Properties

 | Name | Type | Description
Item1 | Inner Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Inner Diameter
Item2 | Outer Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Outer Diameter
Item3 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item4 | Main Axis | pwi_property_UnitVector3D As PropertyUnitVector3D | Main Axis

Example


pwi_ent_Feat_CircleThroughNPoints - Components

Description

Features

 | Name | Type | Description
Item1 | Circle 1::Centre | pwi_feature_Point | Circle 1::Centre
Item2 | Circle 1 | pwi_feature_Circle | Circle 1

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Reference Points | pwi_MultipleLink As ISequenceMultipleLink | Reference Points

Properties

 | Name | Type | Description
Item1 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item2 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter
Item3 | Circularity | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Circularity

Example


pwi_ent_Feat_ProbedCircle - Components

Description

Features

 | Name | Type | Description
Item1 | Circle 2::Centre | pwi_feature_Point | Circle 2::Centre
Item2 | Circle 2 | pwi_feature_Circle | Circle 2

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane

Parameters

 | Name | Type | Description
Item1 | Angle Quadrant | pwi_param_AngleQuadrant As IParameterAngleQuadrant | Angle Quadrant
Item2 | Material Side | pwi_param_MaterialSide As IParameterMaterialSide | Material Side
Item3 | Offset/Thickness | pwi_param_Dimension As IParameterDimension | Enter the thickness of the metal sheet if this entity is measured from the B surface
Item4 | Guided Measure | pwi_param_GuidedMeasure As IParameterGuidedMeasure | Guided Measure Parameters to be used with rigid probe

Properties

 | Name | Type | Description
Item1 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item2 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter
Item3 | Circularity | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Circularity

Example


pwi_ent_Feat_Cylinder - Components

Description

Features

 | Name | Type | Description
Item1 | Cylinder 1::Axis | pwi_feature_Line | Cylinder 1::Axis
Item2 | Cylinder 1 | pwi_feature_Cylinder | Cylinder 1

Parameters

 | Name | Type | Description
Item1 | Base Point | pwi_param_Point3D As IParameterPoint3D | Base point of the cylinder
Item2 | Height | pwi_param_Dimension As IParameterDimension | Height point of the cylinder
Item3 | Angle Quadrant | pwi_param_AngleQuadrant As IParameterAngleQuadrant | Angle Quadrant
Item4 | Material Side | pwi_param_MaterialSide As IParameterMaterialSide | Material Side
Item5 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter
Item2 | Cylindricity | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Cylindricity
Item3 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector

Example


pwi_ent_Feat_Cone - Components

Description

Features

 | Name | Type | Description
Item1 | Cone 1::Axis | pwi_feature_Line | Cone 1::Axis
Item2 | Cone 1::Apex | pwi_feature_Point | Cone 1::Apex
Item3 | Cone 1 | pwi_feature_Cone | Cone 1

Parameters

 | Name | Type | Description
Item1 | Base Point | pwi_param_Point3D As IParameterPoint3D | Height point of the cone
Item2 | Radius | pwi_param_Dimension As IParameterDimension | Radius of the cone at base point
Item3 | Height | pwi_param_Dimension As IParameterDimension | Height point of the cone
Item4 | Angle Quadrant | pwi_param_AngleQuadrant As IParameterAngleQuadrant | Angle Quadrant
Item5 | Material Side | pwi_param_MaterialSide As IParameterMaterialSide | Material Side
Item6 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Half Angle | pwi_property_Angle As PropertyAngle | Half Angle
Item2 | Conicity | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Conicity
Item3 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector

Example


pwi_ent_Feat_Sphere - Components

Description

Features

 | Name | Type | Description
Item1 | Sphere 1::Centre | pwi_feature_Point | Sphere 1::Centre
Item2 | Sphere 1 | pwi_feature_Sphere | Sphere 1

Parameters

 | Name | Type | Description
Item1 | Azimuth Quadrant | pwi_param_AngleQuadrant As IParameterAngleQuadrant | Angle Quadrant ( Azimuth )
Item2 | Elevation Quadrant | pwi_param_AngleQuadrant As IParameterAngleQuadrant | Angle Quadrant ( Elevation )
Item3 | Material Side | pwi_param_MaterialSide As IParameterMaterialSide | Material Side
Item4 | Orientation | pwi_param_Vector3D As IParameterVector3D | Orientation to North pole

Properties

 | Name | Type | Description
Item1 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter
Item2 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item3 | Sphericity | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Sphericity

Example


pwi_ent_Feat_Torus - Components

Description

Features

 | Name | Type | Description
Item1 | Torus 1::Centre | pwi_feature_Point | Torus 1::Centre
Item2 | Torus 1::Axis | pwi_feature_Line | Torus 1::Axis
Item3 | Torus 1 | pwi_feature_Torus | Torus 1

Parameters

 | Name | Type | Description
Item1 | Material Side | pwi_param_MaterialSide As IParameterMaterialSide | Material Side
Item2 | Azimuth Quadrant | pwi_param_AngleQuadrant As IParameterAngleQuadrant | Angle Quadrant ( Azimuth )
Item3 | Elevation Quadrant | pwi_param_AngleQuadrant As IParameterAngleQuadrant | Angle Quadrant ( Elevation )

Properties

 | Name | Type | Description
Item1 | Major Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Major Diameter
Item2 | Minor Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Minor Diameter
Item3 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item4 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector
Item5 | Profile | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Profile

Example


pwi_ent_Feat_SinglePointCircle - Components

Description

Features

 | Name | Type | Description
Item1 | Point 10::Centre | pwi_feature_Point | Point 10::Centre
Item2 | Point 10 | pwi_feature_Circle | Point 10
Item3 | Point 10::Probe Centre | pwi_feature_Point | Point 10::Probe Centre

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane

Parameters

 | Name | Type | Description
Item1 | Offset/Thickness | pwi_param_Dimension As IParameterDimension | Enter the thickness of the metal sheet if this entity is measured from the B surface

Properties

 | Name | Type | Description
Item1 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item2 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter

Example


pwi_ent_Feat_Circle_PlaneConic - Components

Description

Features

 | Name | Type | Description
Item1 | Circle 3::Centre | pwi_feature_Point | Circle 3::Centre
Item2 | Circle 3 | pwi_feature_Circle | Circle 3

Links

 | Name | Type | Description
Item1 | Reference Plane | pwi_SimpleLink As ISequenceSimpleLink | Reference Plane
Item2 | Cut Entity | pwi_SimpleLink As ISequenceSimpleLink | Cut Entity

Properties

 | Name | Type | Description
Item1 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item2 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter
Item3 | Circularity | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Circularity

Example


pwi_ent_Feat_Circle_OnConeAtHeight - Components

Description

Features

 | Name | Type | Description
Item1 | Circle 4::Centre | pwi_feature_Point | Circle 4::Centre
Item2 | Circle 4 | pwi_feature_Circle | Circle 4

Links

 | Name | Type | Description
Item1 | Cut Entity | pwi_SimpleLink As ISequenceSimpleLink | Cut Entity

Parameters

 | Name | Type | Description
Item1 | Distance from Apex | pwi_param_Dimension As IParameterDimension | Enter the distance from the apex at which the circle has to be created

Properties

 | Name | Type | Description
Item1 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item2 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter

Example


pwi_ent_Feat_Circle_OnConeWithDiameter - Components

Description

Features

 | Name | Type | Description
Item1 | Circle 5::Centre | pwi_feature_Point | Circle 5::Centre
Item2 | Circle 5 | pwi_feature_Circle | Circle 5

Links

 | Name | Type | Description
Item1 | Cut Entity | pwi_SimpleLink As ISequenceSimpleLink | Cut Entity

Parameters

 | Name | Type | Description
Item1 | Diameter | pwi_param_Dimension As IParameterDimension | Enter the diameter of the circle to be constructed on the cone

Properties

 | Name | Type | Description
Item1 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item2 | Distance from apex | pwi_property_LinearDimension As PropertyLinearDimension | Distance from apex

Example


pwi_ent_TruePosition - Components

Description

Links

 | Name | Type | Description
Item1 | Datum | pwi_SimpleLink As ISequenceSimpleLink | Datum
Item2 | Reference Point 1 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 1
Item3 | Reference Point 2 | pwi_SimpleLink As ISequenceSimpleLink | Reference Point 2

Parameters

 | Name | Type | Description
Item1 | Work Plane | pwi_param_MainPlane As IParameterMainPlane | Select the main plane
Item2 | Dimension 1 | pwi_param_Dimension As IParameterDimension | Dimension along direction 1
Item3 | Dimension 2 | pwi_param_Dimension As IParameterDimension | Dimension along direction 2

Properties

 | Name | Type | Description
Item1 | True Position | pwi_property_GeometricTolerance As PropertyGeometricTolerance | True Position

Example


pwi_ent_GDT - Components

Description

Links

 | Name | Type | Description
Item1 |  | pwi_SimpleLink As ISequenceSimpleLink |
Item2 |  | pwi_GDTDatumFeatureLink As ISequenceGDTDatumFeatureLink |
Item3 |  | pwi_GDTDatumFeatureLink As ISequenceGDTDatumFeatureLink |
Item4 |  | pwi_GDTDatumFeatureLink As ISequenceGDTDatumFeatureLink |
Item5 |  | pwi_GDTFeaturesLink As ISequenceGDTFeaturesLink |

Example


pwi_ent_LaserScannedCircle - Components

Description

Features

 | Name | Type | Description
Item1 | Circle 6::Centre | pwi_feature_Point | Circle 6::Centre
Item2 | Circle 6 | pwi_feature_Circle | Circle 6
Item3 | Circle 6::Plane | pwi_feature_Plane | Circle 6::Plane
Item4 | Circle 6:: | pwi_feature_Line | Circle 6::

Parameters

 | Name | Type | Description
Item1 | Evaluate from nominal | pwi_param_Boolean As IParameterBoolean | Evaluate the entity using the nominal infomation attached to it
Item2 | Extrusion | pwi_param_Dimension As IParameterDimension | Enter the value for the extrusion
Item3 | Search Distance | pwi_param_Dimension As IParameterDimension | Enter the Search Distance( Extract Nominal must be specified )

Properties

 | Name | Type | Description
Item1 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item2 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter
Item3 | Normal Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Normal Vector

Example


pwi_ent_LaserScannedSlot - Components

Description

Features

 | Name | Type | Description
Item1 | Slot 2::Centre | pwi_feature_Point | Slot 2::Centre
Item2 | Slot 2::Centre1 | pwi_feature_Point | Slot 2::Centre1
Item3 | Slot 2::Centre2 | pwi_feature_Point | Slot 2::Centre2
Item4 | Slot 2::Main Axis | pwi_feature_Line | Slot 2::Main Axis
Item5 | Slot 2::Small Axis | pwi_feature_Line | Slot 2::Small Axis
Item6 | Slot 2 | pwi_feature_RoundedSlot | Slot 2
Item7 | Slot 2::Plane | pwi_feature_Plane | Slot 2::Plane
Item8 | Slot 2:: | pwi_feature_Line | Slot 2::

Parameters

 | Name | Type | Description
Item1 | Evaluate from nominal | pwi_param_Boolean As IParameterBoolean | Evaluate the entity using the nominal infomation attached to it
Item2 | Extrusion | pwi_param_Dimension As IParameterDimension | Enter the value for the extrusion
Item3 | Search Distance | pwi_param_Dimension As IParameterDimension | Enter the Search Distance( Extract Nominal must be specified )

Properties

 | Name | Type | Description
Item1 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item2 | Length | pwi_property_LinearDimension As PropertyLinearDimension | Length
Item3 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter
Item4 | Profile | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Profile
Item5 | Main Axis | pwi_property_UnitVector3D As PropertyUnitVector3D | Main Axis
Item6 | Normal Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Normal Vector

Example


pwi_ent_LaserScannedRectangle - Components

Description

Features

 | Name | Type | Description
Item1 | Rectangle 2::Centre | pwi_feature_Point | Rectangle 2::Centre
Item2 | Rectangle 2::Main Axis | pwi_feature_Line | Rectangle 2::Main Axis
Item3 | Rectangle 2::Small Axis | pwi_feature_Line | Rectangle 2::Small Axis
Item4 | Rectangle 2::Plane | pwi_feature_Plane | Rectangle 2::Plane
Item5 | Rectangle 2:: | pwi_feature_Line | Rectangle 2::
Item6 | Rectangle 2 | pwi_feature_Rectangle | Rectangle 2

Parameters

 | Name | Type | Description
Item1 | Evaluate from nominal | pwi_param_Boolean As IParameterBoolean | Evaluate the entity using the nominal infomation attached to it
Item2 | Extrusion | pwi_param_Dimension As IParameterDimension | Enter the value for the extrusion
Item3 | Search Distance | pwi_param_Dimension As IParameterDimension | Enter the Search Distance( Extract Nominal must be specified )

Properties

 | Name | Type | Description
Item1 | Width | pwi_property_LinearDimension As PropertyLinearDimension | Width
Item2 | Length | pwi_property_LinearDimension As PropertyLinearDimension | Length
Item3 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item4 | Main Axis | pwi_property_UnitVector3D As PropertyUnitVector3D | Main Axis
Item5 | Normal Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Normal Vector

Example


pwi_ent_LaserScannedHexagon - Components

Description

Example


pwi_ent_LaserScannedCorner - Components

Description

Example


pwi_ent_LaserScannedPatch - Components

Description

Features

 | Name | Type | Description
Item1 | Plane 10 | pwi_feature_Plane | Plane 10

Parameters

 | Name | Type | Description
Item1 | Evaluate from nominal | pwi_param_Boolean As IParameterBoolean | Evaluate the entity using the nominal infomation attached to it
Item2 | Centroid | pwi_param_Point3D As IParameterPoint3D | Length of the plane
Item3 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Normal Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Normal Vector
Item2 | Flatness | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Flatness

Example


pwi_ent_LaserScannedGapFlush - Components

Description

Example


pwi_ent_LaserScannedSphere - Components

Description

Features

 | Name | Type | Description
Item1 | Sphere 2::Centre | pwi_feature_Point | Sphere 2::Centre
Item2 | Sphere 2 | pwi_feature_Sphere | Sphere 2

Parameters

 | Name | Type | Description
Item1 | Evaluate from nominal | pwi_param_Boolean As IParameterBoolean | Evaluate the entity using the nominal infomation attached to it
Item2 | Azimuth Quadrant | pwi_param_AngleQuadrant As IParameterAngleQuadrant | Angle Quadrant ( Azimuth )
Item3 | Elevation Quadrant | pwi_param_AngleQuadrant As IParameterAngleQuadrant | Angle Quadrant ( Elevation )
Item4 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter
Item2 | Centre | pwi_property_Point3D As PropertyPoint3D | Centre
Item3 | Sphericity | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Sphericity

Example


pwi_ent_LaserScannedCylinder - Components

Description

Features

 | Name | Type | Description
Item1 | Cylinder 2::Axis | pwi_feature_Line | Cylinder 2::Axis
Item2 | Cylinder 2 | pwi_feature_Cylinder | Cylinder 2

Parameters

 | Name | Type | Description
Item1 | Evaluate from nominal | pwi_param_Boolean As IParameterBoolean | Evaluate the entity using the nominal infomation attached to it
Item2 | Base Point | pwi_param_Point3D As IParameterPoint3D | Base point of the cylinder
Item3 | Height | pwi_param_Dimension As IParameterDimension | Height point of the cylinder
Item4 | Boundary | pwi_param_Boundary As IParameterBoundary | Boundary

Properties

 | Name | Type | Description
Item1 | Diameter | pwi_property_RadialDimension As PropertyRadialDimension | Diameter
Item2 | Cylindricity | pwi_property_GeometricTolerance As PropertyGeometricTolerance | Cylindricity
Item3 | Direction Vector | pwi_property_UnitVector3D As PropertyUnitVector3D | Direction Vector

Example


pwi_ent_LaserScannedSCorner - Components

Description

Example


pwi_ent_LaserScannedEdge - Components

Description

Example