Disclaimer

Delcam plc has no control over the use made of the software described in this manual and cannot accept responsibility for any loss or damage howsoever caused as a result of using the software. Users are advised that all the results from the software should be checked by a competent person, in accordance with good quality control procedures.

Information contained in this manual is subject to change without notice and does not represent a commitment by Delcam plc. The software described in this manual is furnished under licence agreement and may be used or copied in accordance with the terms of such licence. No part of this manual may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying and recording, for any purpose without the express permission of Delcam plc.

Copyright © 1996-2006 Delcam plc. All rights reserved.

Acknowledgements

This documentation references a number of registered trademarks and these are the property of their respective owners. For example, Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.


Neue Merkmale

PowerINSPECT 4.3 bietet alle Originalfunktionen von PowerINSPECT 4.2 und zusätzlich die folgenden neuen Funktionen:

  • Die Fähigkeit, Tasterpfade für Geometriemerkmale und Flächenprüfgruppen zu erstellen, welche dann als Bildschirmindikatoren verwendet werden können, um die manuelle Prüfung zu unterstützen.
  • Zusätzliche Wege zum drehen eines CAD-Modells in der CAD-Ansicht.
  • Verschiedene Erweiterungen zu Ausrichtungen. Diese sind:
    • Eine neue Methode zum berechnen einer Beste Passung, welcher Ihnen ermöglicht, nur um eine spezifizierte Achse zu drehen.
    • Die Fähigkeit, mehr als sechs Abhängigkeiten in einer Referenzpunktsystem (RPS)-Ausrichtung zu nutzen.
  • Eine neue Option (Messungen - Importiert gemessene Daten), die Ihnen ermöglicht, gemessene Daten von einer Messung zu einer anderen Messung zu importieren.
  • Eine neue Option (Messungen - Transformiert Nominalen), die Ihnen ermöglicht, ein einzelnes CAD-Modell in unterschiedlichen Koordinatensystemen zu untersuchen (und zu berichten).
  • Die Fähigkeit, Tasterpfade zu erstellen mittels Importieren einer Datei, die Sollwertpunkte enthält.
  • Verschiedene Erweiterungen zu HTML-Berichten.
    • Schnappschüsse der CAD-Ansicht können in Berichte miteinbezogen werden.
    • Sie können spezifizieren, ob Sie individuell gemessene Punkte in einen Bericht miteinbeziehen wollen.
    • Die Standard-HTML-Berichtvorlage ist erweitert worden, um zusätzliche Information einzuschließen.
  • Die Fähigkeit, zu steuern, wenn PowerINSPECT Merkmale von gemessenen Punkten berechnet mittels der Option Automatisch berechnen .
  • Neue Art, CAD-Ansicht Statuselemente zu modifizieren.
  • Neues Farbschema für Box Aufdrucke.
  • Die Fähigkeit, zu definieren, welche CAD-Ebenen verwendet werden und die individuellen Flächenprüfgruppen zu prüfen.
  • Neu Einstellungen im Formular Optionen .
  • Die Fähigkeit, ungemessene Merkmale zu nutzen, um GD&T-Gegenstände zu erstellen.
  • Eine neue Option (Werkzeuge - Dateien extrahieren aus Catia EXPORT-Datei, die Ihnen ermöglicht, individuelle CAD-Dateien ( .fic ) von Catia Export ( .exp ) zu entnehmen.
  • Eine neue Methode zum berechnen von Eigenschaftenschnittpunkten mittels unbegrenzten Elemente.
  • Verschiedene Erweiterungen zu Punktewolken. Diese sind:
    • Erweiterungen in Punktewolkedaten exportieren.
    • Zusätzliche Information, angezeigt auf der Punktewolke Registerkarte.
  • Integration mit Advanced Integrated Mathematical System (AIMS).
  • Neue Schaltfläche Geführter Flächenpunkt.


Verwenden von Tasterpfaden, um die manuelle Prüfung zu unterstützen

PowerINSPECT 4.3 erlaubt Prüfern, Tasterpfade in Form von voll abgefragten Punkten für weniger erfahrene Bediener zu erstellen und zu messen und dadurch das Potential für Messfehler zu senken.

Sie können das in einem beliebigen der nachfolgenden Wege tun:

  • Nehmen Sie manuelle Messungen auf und dann, innerhalb der gleichen Sitzung, die automatisch generierten Tasterpfade von gemessenen Daten.
  • Automatisches Modifizieren der generierten Tasterpfade mittels der Registerkarte Merkmale .
  • Generiert neue Tasterpfade durch das Navigieren zur Registerkarte Merkmale und dem Festlegen von Mess-Strategien und -Parametern.
  • Laden einer existierenden PWI-Datei, die gemessene Daten enthält und anschließendem wählen von Messungen - Generiere Tasterpfade.
    • Wenn Sie eine Datei laden, die eine Sequenz enthält, für die Tasterpfade bereits erstellt wurden und Sie nach der Anzeige der Tasterpfade mittels der entsprechenden Option Ansicht - Tasterpfade die Pfade bearbeiten und dann nach Bedarf zurückberechnen.

Ein Prüfer kann Messpfade erstellen für Flächenprüfgruppen, genau wie für die geometrische Prüfung von gemessen Ebenen, Linien, Kreisen (Bögen), Kegel, Zylindern, Spalten, Kugeln, einzelnen Punkten und Rechtecken.

In diesem Abschnitt

Illustration des 'Springballs'

Filmbeispiel von 'Springball'

Messungen – Generiert Messpfade

Verwenden der Merkmale -Registerkarte

Ansicht - Tasterpfade


Illustration des 'Springballs'

Wenn ein Operator eine Sequenz aufnimmt, die Elemente mit Tasterpfaden enthält, zeigt PowerINSPECT die Punkte entlang des zu messenden Pfads mittels eines 'Springball'-Effekts. Dies bedeutet, dass obwohl alle Punkte anfänglich in der selben Farbe gezeigt werden (typischerweise blau) der nächste zu messene Punkt als rote Kugel angezeigt wird. Wenn ein Punkt ersteinmal gemessen wurde, wird er als graue Kugel gezeigt, mit der transparenten roten Kugel, die anzeigt, wo der Punkt tatsächlich aufgenommen wurde, zum Beispiel:

Der 'Springball'-Effekt bietet sich hierfür als einen Bildschirm-Führer an, der anzeigt, was bereits gemessen wurde und was als Nächstes gemessen werden wird.

  • Transparente rote Kugelnin werden im Falle von Flächenprüfgruppen nicht verwendet, um gemessen Punkte anzuzeigen. Die normalen Messmarkierungen werden anstatt dessen angezeigt.


Filmbeispiel von 'Springball'

Das nachfolgenden Beispiel zeigt den 'Springball'-Effekt der gemessenen Bewegung von rotem zu rotem Punkt:


Messungen – Generiert Messpfade

Benutzen Sie diese Option, um Tasterpfade von gemessenen Daten zu generieren für Flächenprüfgruppen, genau wie für die geometrische Prüfung von gemessen Ebenen, Linien, Kreisen (Bögen), Kegel, Zylindern, Spalten, Kugeln, einzelnen Punkten und Rechtecken.

  1. Öffnen Sie eine PWI-Datei und versichern Sie sich, dass die Flächenprüfgruppen und Elemente in der/den Geometriegruppe(n) gemessen sind, zum Beispiel:

  2. Wählen Sie Messungen - Generiere Tasterpfade.

    • Verwenden Sie die Option Ansicht - Tasterpfade , um die Anzeigen von Tasterpfaden in der CAD-Ansicht zu steuern:

Sie können jetzt das Teil mittels Tasterpfad als Führung prüfen.

  • Wenn Sie Alle aufnehmen wählen (entgegengesetzt zu Aufnehmen für individuelle Elemente, für welcher Sie Tasterpfade erstellt haben), dann werden Sie den Messungsstatus von allen Gegenständen zurücksetzen müssen, die neu geprüft werden.


Verwenden der Merkmale -Registerkarte

Die Registerkarte Merkmale wird verwendet, um Elemente in Prüfvorgang zu erstellen und zu warten, die vereinte Tasterpfade besitzen.

  • Um die Registerkarte zu nutzen, muss der CNC Modus aktiv sein.

Sie können Tasterpfade erstellen für Flächenprüfgruppen, genau wie für die geometrische Prüfung von gemessen Ebenen, Linien, Kreisen (Bögen), Kegel, Zylindern, Spalten, Kugeln, einzelnen Punkten und Rechtecken.

When creating surface inspection groups or geometric elements, details are automatically added to the Merkmale tab for you to check or amend:

Creating a... | Using...
surface inspection group by inserting surface points on a CAD model | from the Element toolbar. This displays an Inspect dialog in the Merkmale tab and enables the Probe Path Editor for you to insert surface points.
geometric element by specifying nominal data (or in the case of lines and planes, by inserting points on a CAD model) | the Element toolbar. For example, select [image] to create a probed plane. This displays an Inspect dialog in the Merkmale tab for you to specify nominal values. If creating lines or planes, it also enables the Probe Path Editor for you to insert points on a CAD model.
geometric element (but not lines, planes or spheres) by selecting directly from a CAD model | Wireframe checker [image] from the Mouse Context toolbar. When you have selected a geometric feature with Wireframe Checker, the feature's details are displayed in the Inspect dialog in the Merkmale tab.
  • To use Wireframe Checker effectively when selecting geometric features, make sure the CAD model's wireframe is visible in the CAD View tab.

In diesem Abschnitt

Wie Messpfade in der CAD-Ansicht dargestellt werden

Über die Prüfformulare


Wie Messpfade in der CAD-Ansicht dargestellt werden

As you are creating or editing elements and their associated probe paths on the Inspect dialogs, a visual representation of both the element and its probe path appears on the CAD View tab. A probe path contains one or more probed positions. The following conventions are used to denote different parts of a probe path:

  • Green lines indicate intermediate moves (where the probe is not expected to touch the part during the move) between probed positions. Lead in and lead out moves are also indicated in green. An additional green asterisk marker appears on lead in moves to distinguish them from lead out moves.
  • Red spheres indicate touch points (that is, the points at which the probe is expected to touch the part).

For example, a cylinder probe path:

For example, a surface inspection group probe path:

  • The exact probe path created depends on the probing strategies and parameters selected for the feature.

PowerINSPECT automatically creates link moves between different probe paths. These are displayed in light grey - for example:


Über die Prüfformulare

Wenn ein Element erstellt oder bearbeitet wird, welches einen Tasterpfad enthält, erscheint ein Prüfformular in der Registerkarte Merkmale unter der Prüfvorgang. Dieses Formular beinhaltet sowohl "Definitions"-Informationen über das Element selbst (wie z.B. Sollwerte) als auch Tasterpfad-Details.

Obwohl verschiedenen Fromulare für unterschiedliche Elemente angezeigt werden (zum Beispiel Flächengruppen-Prüfung, Ebenen-Prüfung, Bogen-Prüfung und Kegel-Prüfung, basieren alle auf den selben allgemeinen Prinzipien und umfassen nachfolgende Hauptgebiete:

- Bereich Name und Modus. Hier können Sie den Standardnamen des Element oder Ihren selbst definierten Namen annehmen. Sie können auch spezifizieren, ob Sie im 'Erstellen-' oder 'Bearbeiten-' Modus arbeiten möchten.

- Elementparameter-Bereich. Die abgebildeten Parameter variieren abhängig von dem Element, das erstellt oder geändert wird, es können aber auch X-, Y- und Z-Koordinaten des Elements, Anfangs- und Endwinkel enthalten sein und Informationen darüber, ob das Merkmal innen oder außen gemessen werden soll.

- Messstrategien und Parameterbereich. Hier können Sie eine Messstrategie und -methode für das Element wählen und verschiedene Werte festlegen, die Beziehung zu dem mit dem Element verbundenen Messpfad stehen.

- Symbolleiste Bereich. Hier können Sie Änderungen in Merkmalen speichern oder abbrechen.

Diese Bereiche sind wie folgt positioniert


CNC Modus sperren

Ein Formular Prüfen wird automatisch auf der Registerkarte Merkmale angezeigt, wann immer Sie ein Element erstellen oder bearbeiten, welches einen Tasterpfad in sich vereint hat.

Wenn Sie jedoch mit diesen Elementen arbeiten wollen, ohne auch einen Tasterpfad erstellen zu wollen, können Sie die Anzeige des Prüfen Formulars unbrauchbar machen, indem Sie das CNC Modus-Symbol oberhalb der Registerkarte Merkmale anklicken. Sie können dann die Elemente modifizieren, indem Sie sie in Prüfvorgang bearbeiten.

Das CNC Modus-Symbol fungiert als Ein-/Ausschalter und so ermöglicht (oder ermöglicht nicht) ein Klicken auf das Symbol den CNC Modus.

Zum Beispiel:

  • CNC Modus ist aktiv:

  • CNC Modus ist deaktiviert:

  • Das Symbol CNC Modus erscheint nur, wenn aktuell kein Element erstellt oder geändert wird in der Registerkarte Merkmale .


Bestimmen des Elementnamens und -modus

Wenn ein neues Element erstellt wird, spezifiziert PowerINSPECT automatisch einen neuen Namen für das Element. Der Name beinhaltet den Typ des Elements und eine Nummer - zum Beispiel:

Um den Namen des Elements zu ändern geben Sie eine neue Bezeichnung ein - zum Beispiel

Die Prüf-Formulare können in den Modi Erstellen oder Ändern verwendet werden:

Modus

Beschreibung

Schaltet den Modus Ändern ein und aus.

Schalten Sie den Modus Ändern ein, wenn Sie irgendeine Information über existierende Elemente ändern möchten.

Schaltet den Modus Erstellen ein und aus. Wenn Sie bevorzugen, ein neues Element von der Element-Symbolleiste zu erstellen ist dieser Modus automatisch ausgewählt.

Wenn Sie diese Schaltfläche vom Formular Prüfen wählen, erstellt PowerINSPECT automatisch ein Element von dem Typ, der zuletzt in Prüfvorgang ausgewählt wurde (inklusive alle Parametereinstellungen für dieses Element). Wenn Sie einen unterschiedlichen Typ von Element erstellen wollen, wählen Sie die relevante Schaltfläche von der Element Symbolleiste.

Wenn Sie ein Element erstellt haben, klicken Sie auf [image], um dessen Details zu speichern und in Prüfvorgang hinzufügen. Wenn Sie den Erstellungsmodus verlassen (mittels der Schaltfläche Ein-/Ausschalten), ohne das Element zu speichern, erscheint der Elementname als 'undefiniert' und das Element wird Prüfvorgang nicht hnzugefügt.


Verwenden der Werkzeugleiste des Inspektionsformulars

Verwenden Sie den Symbolleistenbereich, um die Veränderungen in einem Merkmal zu speichern oder abzubrechen und Punkte von Tasterpfaden zu entfernen:

Points Taken indicator which automatically updates as you insert points using the Probe Path Editor.

Deletes the last point in the currently selected probe path. Available when viewing features whose probe paths can be created or edited using the Probe Path Editor (for example, planes, lines and surface inspection groups).

Saves any changes you make to the settings in the Inspect dialog. Available when in create or edit mode.

Closes the Inspect dialog. Only active when not in edit or create mode.


Einstellen der Element-Parameter

Die angezeigten Elementparameter variieren abhängig vom Typ des Elements das erstellt oder bearbeitet wird - zum Beispiel der Parameter Länge ist nur anwendbar auf Linien, Rechtecke und Nuten

wenn ein neues Element in Prüfvorgang hinzugefügt wird, vervollständigt PowerINSPECT automatisch die Elementparameter. Sie können diese jedoch bearbeiten, wenn Sie möchten.

  • PowerINSPECT erinnert sich an die Parameter, die Sie zuletzt für ein bestimmtes Element eingestellt hatten - zum Beispiel ein Kreis und wendet diese automatisch auf den nächsten von Ihnen erstelten Kreis an.

Wenn ein Element durch die Auswahl eines geometrischen Merkmals von einem CAD-Modell erstellt wird (mittels Drahtgitter-Prüfer), nutzt PowerINSPECT die Informationen vom CAD-Modell (wie zum Beispiel Sollwerte) für einige der Elementparameter.

  • Einige Elementparameter sind nur für Automatischer Berührungsauslöser-Strategien anwendbar und können nicht verändert werden, wenn eine Benutzerdefinierte Strategie ausgewählt ist. Siehe Festlegen von Mess-Strategien und Verfahren für weitere Einzelheiten über Messstrategien.

Es folgt eine Liste möglicher Element-Parameter, die erscheinen können (und die Elemente, auf die sie anwendbar sind):

Schaltfläche

Beschreibung

Anwendbar auf...

Sollwerte des Elements. Die Schaltfläche schaltet zwischen dem Anzeigen von positionellen (in X-, Y- und Z-Koordinaten) und Ausrichtungsinformationen (in I-, J- und K-Werten) des Elements hin und her. Diese Werte können im Bearbeitungsmodus für eine Automatische Berührungsauslöser-Strategie geändert werden.

Beim Definieren eines Messpfades unter Verwendung von Flächenpunkten werden die Sollwerte des ersten Punktes aus der Gruppe verwendet.

Für gemessene Linien, Nuten und Rechecke sind zwei Gruppen von I-, J-, K-Variablen verfügbar - die erste Gruppe von Werten bezieht sich auf die ursprüngliche Ausrichtung der Bezugsebene des Merkmals und die zweite Gruppe von Werten bezieht sich auf die Ausrichtung entlang der Länge des Merkmals.

Flächengruppen

Alle Geometriemerkmale

Der Radius oder Durchmesser/Breite des Elements. Die Schaltfläche schaltet zwischen dem Anzeigen von Radius oder Durchmesser/Breite um.

Für Bögen, Zylinder und Kugeln wird der Durchmesser angezeigt und für Nuten wird die Breite angezeigt

Bogen
Zylinder
Nut
Kugel

Der Radius oder der Durchmesser der Kegeloberseite. Die Schaltfläche schaltet zwischen dem Anzeigen von Radius oder Durchmesser um.

Kegel

Der Radius oder der Durchmesser der Kegelgrundfläche. Die Schaltfläche schaltet zwischen dem Anzeigen von Radius oder Durchmesser um.

Kegel

Die Anfangs- und Endwinkel eines Elements und sein Messpfad.

Diese Winkel kontrollieren den Betrag des zu messenden Merkmals. Wenn Sie Merkmale direkt vom CAD-Modell wählen, nutzt PowerINSPECT die Startwinkel vom CAD-Modell. Sie können diese jedoch ändern, wenn Sie das wünschen.

Bogen
Kegel
Zylinder

Die Seiten-Anfangs- und -Endwinkel der Kugel und ihr Messpfad.

Diese Winkel bestimmen, wieviel vom Element gemessen wird und sind nützlich zum Definieren von teilweise kugelförmigen Elementen. Wenn Sie Merkmale direkt vom CAD-Modell wählen, nutzt PowerINSPECT die Start- und Endwinkel vom CAD-Modell. Sie können diese jedoch ändern, wenn Sie das wünschen.

Kugel

Die oberen und unteren Höhenwinkel der Kugel und ihr Messpfad.

Diese Winkel bestimmen, wieviel vom Element gemessen wird und sind nützlich zum Definieren von teilweise kugelförmigen Elementen.

Kugel

Die Länge des Elements.

Linie
Rechteck
Nut

Die Breite des Elements

Rechteck

Spezifiziert die Entfernung des Tasterpfades von der Spitze des Elements.

Benutzen Sie dies, um die zu Prüfvorgang hinzugefügte effektiv gemesse Länge des Kegel- oder Zylinderelements zu ändern. Dies kann nützlich sein, wenn das Merkmal in derCAD-Modell unvollständig ist, obgleich das Ändern der effektiv gemessen Tasterlänge die Messgerät-Messpunkte im Raum und/oder mögliche Kollisionen verhindern kann.

Kegel
Zylinder

Bestimmt den Abstand des Tasterpfades vom Boden des Elements.

Benutzen Sie dies, um die zu Prüfvorgang hinzugefügte effektiv gemesse Länge des Kegel- oder Zylinderelements zu ändern. Dies kann nützlich sein, wenn das Merkmal in derCAD-Modell unvollständig ist, obgleich das Ändern der effektiv gemessen Tasterlänge die Messgerät-Messpunkte im Raum und/oder mögliche Kollisionen verhindern kann.

Kegel
Zylinder

Bestimmt den Halben Winkel des Kegels - sozusagen den Sollwinkel des Kegels.

Dies kann nützlich sein, wenn Sie einen Tasterpfad für einen Kegel ohne CAD-Zeichnung erstellen wollen.

Kegel

oder

Schalten Sie zwischen innerer und äußerer Messung des Elements hin und her.

Alle Geometriemerkmale

Schaltet zwischen den Richtungsvektoren des Merkmals und seiner Tasterpfade zwischen normal und umgekehrt um. Mit dieser Schaltfläche aktualisieren Sie die IJK-Werte für das Merkmal.

Bogen
Kegel
Zylinder
Linie
Kugel

In diesem Abschnitt

Beispiel: Start- und Endwinkel für Elemente festlegen

Beispiel: einstellen des Seitenwinkels und Höhenwinkels für eine Kugel.

Beispiel: den obere oder untere Abstände des Elements einstellen

Beispiel: Inneres oder äußeres Messen eines Merkmals festlegen

Beispiel: den Richtungsvektor umkehren


Beispiel: Start- und Endwinkel für Elemente festlegen

Wenn Sie Bögen, Kegel und Zylinder erzeugen, können Sie mittels Anfangs- und Endwinkel-Parametern teilweise Elemente definieren. Wenn Sie diese Elemente direkt in der CAD-Zeichnung mit dem Drahtgitterprüfer auswählen übernimmt PowerINSPECT automatisch die relevanten Anfangs- und Endwinkel. Zum Beispiel wenn Sie den folgenden Bogen aus der CAD-Zeichnung wählen:

Vervollständigt die Werte für Anfangs- und Endwinkel im Bogen-Prüfung Formular wie folgt:

Das Abspeichern dieser Details erzeugt ein Element mit zugehörigem Tasterpfad (entsprechend der gewählten Messstrategie und -Methode - siehe Einstellen von Messstrategien und Parametern für weitere Details). Zum Beispiel:

Verwenden Sie PowerINSPECTs lokales Kooredinatensystem als visuelle Hilfe beim Bearbeiten der Anfangs- und Endwinkel beim Arbeiten mit 3D-Merkmalen mit Anfangs- und Endwinkeln. Das lokale Koordinatensystem wird angezeigt als gepunktete rote, grüne und blaue Linien zur Darstellung der X-, Y- und Z-Achse des Merkmals. Zum Beispiel:

Die Nullposition ist die positive X-Achse des Merkmals. Unter Verwendung des lokalen Koordinatensystems als visuelle Hilfestellung können Sie dann die Anfangs- und Endwinkel verändern wie erforderlich. Zum Beispiel wird in der schattierten CAD-Ansicht erkennbar, dass das Zylindermerkmal welches mit Hilfe des Drahtgitterprüfers erzeugt wurde, in einem Tasterpfad resultiert dessen Berührungspunkte keinen direkten Kontakt zum Prüfling haben:

Um das zu beheben verändern Sie den Anfangswinkel des Merkmals von -180.00° zu-145.000° und speichern Sie die Änderung. Die CAD-Ansicht wird aktualisiert und zeigt dass alle Berührungspunkte nun Kontakt zum Prüfling haben:


Beispiel: einstellen des Seitenwinkels und Höhenwinkels für eine Kugel.

Verwenden Sie die Anfangs- und End-Azimutwinkel um den Anfangs- und Endpunkt der Kugel zu definieren - zum Beispiel:

Hierbei werden die Anfangs- und Endwinkel folgendermaßen festgelegt:

Nr. | Seitenwinkel Start | Seitenwinkel Ende
 | 0 | 360
 | 0 | 180

Verwenden Sie die Höhenwinkel , um die Höhe der Kugel zu definieren - ein Beispiel:

Hierbei werden die oberen und unteren Höhenwinkel folgendermaßen festgelegt:

Nr. | Obere Höhewinkel | Unterer Höhenwinkel
 | 0 | -90
 | 90 | 0


Beispiel: den obere oder untere Abstände des Elements einstellen

Wenn Sie den folgenden Zylinder erstellt haben, indem Sie ihn im CAD-Modell mit Hilfe des Drahtgitter-Prüfers ausgewählt haben, beachten Sie dass der Tasterpfad einige Berührungspunkte enthält, die keinen direkten Kontakt zum Prüfling haben. Der Grund dafür ist, dass der Zylinder schräg liegt.

Um dies zu ändern, zum Verringern der effektiven Messlänge des Zylinders, reduzieren Sie den Wert für die Bodentiefe. Auf diese Weise hängen die Kontaktpunkte nicht länger in der Luft. Das Abspeichern dieser Änderungen aktualisiert die CAD-Ansicht Registerkarte zu:


Beispiel: Inneres oder äußeres Messen eines Merkmals festlegen

Wenn Sie Merkmale erzeugen, kann es sein dass Sie die inneren/äußeren Messparameter ändern müssen um das bestimmte Merkmal aufzunehmen. Zum Beispiel wenn Sie gewählt hätten, den folgenden Bogen mit inneren Messparametern aufzunehmen können Sie sehen, dass das Merkmal nicht korrekt gemessen würde.

Zum Bestimmen, dass Sie das Merkmal von außen aufgenommen haben möchten:

  1. Klicken Sie [image] auf der Merkmale Registerkarte (so dass es sich in [image] ändert).
  2. Beachten Sie, dass sich die CAD-Ansicht Registerkarte aktualisiert um diese Änderung anzuzeigen:

  3. Klicken Sie auf [image] zum Speichern der Änderungen.


Beispiel: den Richtungsvektor umkehren

Wenn Sie folgendes Merkmal erstellt haben, indem Sie es im CAD-Modell mit Hilfe des Drahtgitter-Prüfers ausgewählt haben, nimmt PowerINSPECT den Richtungsvektor des Merkmals und dessen Tasterpfad von der CAD-Zeichnung.

Der Richtungsvektor wird in der CAD-Ansicht-Registerkarte durch eine durchgängige gelbe Linie mit Pfeil angezeigt - zum Beispiel:

Die Umkehrung des Richtungsvektors kehr den Vektor des Merkmals und den damit verbundenen Tasterpfad um. Das kann nützlich sein, wenn Sie Merkmale ohne ein CAD-Modell erstellen oder wenn Sie die Prüfrichtung ändern müssen um Kollisionen zu vermeiden.

Um den Richtungsvektor umzukehren:

  1. Klicken Sie auf [image] auf der Merkmale Registerkarte (so dass es sich zu [image] ändert ).
  2. Sehen Sie sich den Effekt in der CAD-Ansicht-Registerkarte an. Zum Beispiel:

  3. Klicken Sie auf [image] zum Speichern Ihrer Änderungen.


Festlegen von Mess-Strategien und Verfahren

Wenn Sie das erste Mal einen speziellen Elementtyp in Prüfvorgang hinzufügen, beispielsweise eine Kugel, erstellt PowerINSPECT das Element mit Hilfe der effektivsten Messstrategien und Methode für diesen Tasterpfad. Wenn Sie diese Einstellungen für ein Element ändern, sagen wir für einen Kegel, erinnert sich PowerINSPECT an diese Einstellungen und wendet sie automatisch beim nächsten von Ihnen erstellten Kegel an.

  • Einige Messparameter sind nur für AutoTouchTrigger-Strategien anwendbar und können nicht verändert werden, wenn eine Benutzerdefinierte Strategie ausgewählt ist.

Die verfügbaren Messstrategien und Parameter sind:

Messstrategie

Zusammen mit der Messmethode kontroliert die Strategie, wie derTasterpfad berechnet wird. Die nachfolgenden Strategien sind verfügbar:

  • Manuell - Standardstrategie für Geometriemerkmale wie Bögen, Kegel, Zylinder und Kugeln. Mit dieser Strategie nutzt PowerINSPECT die Schnitte, um die Fläche und die dazwischenliegenden Punkte, die zur Messung des Elements benötigt werden, festzulegen.
  • Benutzerdefiniert - Dies ist die einzige Strategie, die verfügbar ist für Ebenen- und Flächengruppen und sie ist die Standardstrategie für Zeilen. Es kann, wenn benötigt, auch als eine andere Strategie für Geometriemerkmale gewählt werden. Mit dieser Strategie nutzten Sie den Messpfad-Editor, um den Tasterpfad, der zur Messung des Elements benötigt wird, zu spezifizieren.

Messmethode

Zusammen mit der Messstrategie kontroliert die Methode, wie der Tasterpfad berechnet wird. Verschiedene vordefinierte Verfahren sind für jede Messstrategie verfügbar.

Klicken Sie auf [image], um die Parameter anzuschauen, die festlegen, wie der Messpfad für die ausgewählte Messmethode berechnet wird.

Nur fortgeschrittene PowerINSPECT-Benutzer sollten versuchen, diese Parameter zu ändern. Wenn die Standardmessenverfahren, die mit PowerINSPECT miteinbezogen werden, nicht zu Ihrer Zufriedenheit sind, kontaktieren Sie Ihren Verkäufer, um Ihre weiteren Anforderungen zu erörtern.

Messtiefe

Klicken Sie auf [image], um zu spezifizieren, dass die Maschine das Merkmal auf einer bestimmten Tiefe abtastet. Der Messtiefen-Wert, den Sie spezifizieren, wird vom Durchmesser des Tasters abhängig sein, den Sie benutzen und von der Dicke der zu messenden Komponente.

Betrachten Sie die Effekte Ihrer Änderungen auf der Registerkarte CAD-Ansicht - zum Beispiel bei Änderung der Messtiefe eines Bogens von 1 mm auf 3 mm:

Die Änderung der Messtiefe eines Kegels oder Zylinders ändert die Tiefe der Punkte sowohl an der Ober- als auch an der Unterkante - zum Beispiel bei Änderung der Messtiefe bei einem Zylinder von 1 mm auf 3 mm:


Über benutzerdefinierte Messmethoden

Für eine Manuell-Messstrategie sind nachfolgende Verfahren verfügbar:

Methode (Scheiben) | Beschreibung
Optimal | Diese Methode generiert einen Tasterpfad, der aus einer festen Anzahl von Schnitten um das Element besteht, wo jeder Schnitt eine feste Anzahl von ausgeglichen verteilten Punkten umfasst. Die Standardanzahl von Punkten und Schnitten hängt von dem einzelnen Element ab. Mit einem Kreis beispielsweise ist der Standard 6 Punkte in einem einzelnen Schnitt:
SchnittPunkte | Diese Methode generiert einen Tasterpfad, der aus der minimalen Anzahl von Schnitten um ein Element besteht, wo jeder bewegliche Schnitt eine feste Anzahl von Punkten umfasst, die ausgeglichen verteilt um das Element liegen. Mit einem Kreis beispielsweise ist der Standard 4 Punkte in einem einzelnen Schnitt.
Täfelung | Diese Methode ist eine spezielle Schnittpunkte-Messmethode, die für jedes neue 2D Element automatisch eine Referenzebene erstellt. Dies ist genau für das Prüfen von Stanzen nützlich.


Über Benutzerdefinierte Messmethoden

Die nachfolgenden Verfahren sind mit einer benutzerdefinierten Messstrategie verfügbar:

Methode

Beschreibung

LehrenUndLernen

Diese Methode unterstützt die Kompatibilität zu vorherigen Versionen von PowerINSPECT und bewahrt den Originaltasterpfad LehrenUndLernen. Es nutzt keine speziellen Parameter, nur die Anfahren- und Zurückziehen-Abstände des Tasters.

Es ist nur anwendbar auf Dateien, die Tasterpfade enthalten, die erstellt wurden unter Verwendung der Funktion LehrenUndLernen.

Manuell

Diese Methode erlaubt Ihnen, den Tasterpfad der CAD-Ansicht aufzunehmen.


Ändern der Parameter für eine Prüfmethode

Wenn Sie einen der Parameter für die Messmethode (zum Beispiel die Anzahl der Punkte pro Scheibe) ändern wollen

  1. Klicken Sie auf [image] neben dem Messmethoden-Aktionsfenster um das Formular Parameter anzuzeigen.

    • Das Hervorheben eines Parameters resultiert in der Anzeige einer kurzen Erläuterung, wie der Parameter sich auf den Tasterpfad auswirken wird, die sich im Bereich unter der Liste von Parametern befindet (siehe im Beispiel im nachfolgenden Schritt).
  2. Nur fortgeschrittene PowerINSPECT-Benutzer sollten versuchen, diese Parameter zu ändern. Wenn die Standardmessenverfahren, die mit PowerINSPECT miteinbezogen werden, nicht zu Ihrer Zufriedenheit sind, kontaktieren Sie Ihren Verkäufer, um Ihre weiteren Anforderungen zu erörtern.

    Spezifizieren Sie den neuen Wert für den Parameter. Für einige Optionen müssen Sie ein Auswahlfeld wählen oder abwählen; für Andere (wie Ränder) müssen Sie einen Wert eingeben; und für andere (wie Punkte) müssen Sie in die Box klicken, die den aktuellen Parameterwert zeigt und den Wert dann schrittweise erhöht oder verringert, wie zum Beispiel:

  3. Klicken Sie auf [image], um Ihre Änderungen zu speichern.


Wie PowerINSPECT automatisch die Referenzebene für ein 2D-Merkmal auswählt

Die Art, in welcher PowerINSPECT Referenzebene anwendet, hängt von der ausgewählten Messmethode ab:

Wenn die Methode Karosserieblech ausgewählt ist, erstellt PowerINSPECT automatisch eine lokale Referenzebene für das Merkmal, zum Beispiel:

Linked PowerINSPECT Graphics Directory Template

Wenn eine beliebige andere Messmethode ausgewählt ist, PowerINSPECT versucht, die Merkmale in einer existierenden Referenzebene anzupassen durch Beachtung von:

  • Der Normalenausrichtung des Merkmals und der Ebene ( beide müssen dieselbe Orientierung haben - innerhalb einer Toleranz von +/- 15°)
  • Dem Ort der Ebene - wenn es mehr als eine Ebene mit derselben Orientierung gibt, wählt PowerINSPECT diejenige aus, die dem Merkmal am nächsten ist.

Wenn keine passende Ebene gefunden werden konnte, erzeugt PowerINSPECT automatisch eine.

  • Es wird empfohlen, dass Sie beliebige Ebenen erstellen, die Sie als Referenzebenen benutzen wollen, bevor Sie 2D Merkmale erstellen, außer, wenn Sie die Messmethode Karosserieblech nutzen. Wenn Sie ein 2D-Merkmal erstellen, dann wählt PowerINSPECT automatisch die am besten entsprechende Referenzebene für dieses Merkmal.


Verwenden des Messpfad-Editors

Nutzen Sie den Messpfad-Editor, wo es angebracht ist, Tasterpfade in der CAD-Ansicht zu erstellen oder interaktiv zu ändern. Wenn beispielsweise ein benutzerdefinierter Tasterpfad für die Ebenen-, Linien- und Flächenprüfgruppen erstellt wird und wenn Zwischen-Messpfade erstellt werden.


Erzeugen benutzerdefinierter Tasterpfade

Wenn Sie gemessene Ebenen und Flächenprüfgruppen erzeugen, können Sie nur einen benutzerdefinierten Tasterpfad erstellen.

Für alle anderen Elemente kann man entweder einen Tasterpfad generieren mittels Manuell-Messstrategie oder selbst einen Tasterpfad definieren mittels Auswählen von Benutzerdefinierten Messstrategien.

Der Messpfad-Editor wird immer dann automatisch aktiviert, wenn Sie ein Element hinzufügen oder ändern, das eine Benutzerdefinierte Mess-Strategie besitzt. Wenn der Tasterpfad-Editor aktiv ist, können Sie einen benutzerdefinierten Tasterpfad wie folgt erstellen:

  1. In der Registerkarte CAD-Ansicht bewegen Sie den Mauszeiger Tasterpfad Editor ( [image]) an die Stelle, wo Sie wollen, dass die erste Position des Tasterpfads sein soll.
  2. Um eine gemessene Position hinzuzufügen, doppelklicken Sie auf die Stelle auf dem CAD-Modell, wo Sie die gemessenen Position haben wollen. Wenn der Tasterpfad Editor aktiv ist, werden Annäherungspunkte für jede Tasterposition mittels gelber Box angezeigt, zum Beispiel:

  3. Nach Bedarf zusätzliche Positionen dem Tasterpfad hinzufägen - Zum Beispiel für eine Ebene:

    • Jedes Element benötigt eine minimale Anzahl von Berührungspunkten, um es erfolgreich zu erstellen. Sie können verfolgen, wie viele Berührungspunkte immernoch benötigt werden, mittels der Anzeige Aufgenommene Punkte auf dem Formular Prüfen , welches automatisch aktualisiert wird, sobald Sie Punkte spezifizieren.
  4. Haben Sie das Hinzufügen von Punkten in den Tasterpfad ersteinmal beendet, klicken Sie auf [image] im Formular Prüfen. PowerINSPECT berechnet automatisch einen Tasterpfad, um die Punkte zu messen, die Sie ausgewählt haben und zeigt diese in der Registerkarte CAD-Ansicht an. Zum Beispiel:

  • Wenn Sie den Tasterpfad bearbeiten, den Sie erstellt haben, klicken Sie auf [image] im Prüfformular für dieses Element - siehe Ändern benutzerdefinierter Messpfade.


Ändern benutzerdefinierter Messpfade

Sie können existierende benutzerdefinierte Tasterpfade bearbeiten oder umwandeln von Manuellen Tasterpfaden in benutzerdefinierte Tasterpfade:

  1. Wählen Sie das Element im Prüfvorgang.
  2. Klicken Sie auf [image] im Prüf formular.
  3. Wenn Sie den Tasterpfad bearbeiten wollen, den Sie mittels Manuell strategien erstellt haben und in eine Benutzerdefinierte ändern wollen, wechseln Sie die ausgewählte Messstrategie im Formular Prüfen in Benutzerdefiniert.
  4. Prüfen Sie bitte, ob der Tasterpfad-Editor in der CAD- Ansicht aktiviert ist.

    Bei Verwendung des Messpfad-Editors im Änderungsmodus, erscheinen die Annäherungspunkte als gelbe Boxen, zum Beispiel:

    Der Zeiger des Tasterpfad-Editors wird auch angezeigt (als [image] [image] oder [image] ) - zum Beispiel:

  5. Ändern des Pfads. Wenn Sie Folgendes tun wollen:
    • fügen Sie eine neue Position nach der letzten Position im aktuellen Tasterpfad ein, platzieren Sie [image] den Mauszeiger über das CAD-Modell und doppelklicken Sie, um eine neue gemessenen Position einzufügen.
    • bewegen eines Berührungspunkts: 1) Bewegten Sie den Mauszeiger [image] über den Berührungspunkt; 2) Ziehen Sie den Berührungspunkt zu seiner neuen Stelle mittels der linken Maustaste; 3) Lassen Sie die Maustaste los, um die Bewegung zu vollenden. Zum Beispiel:

    • löschen einer gemessenen Position: 1) Bewegten Sie den Mauszeiger über den Berührungspunkt; 2) Rechtsklicken Sie, um ein Pop-up Menü anzuzeigen; 3) Wählen Sie Löschen von Pop-up Menü, um die Position zu löschen. Zum Beispiel:

  6. Klicken Sie auf [image] im Formular Prüfung um Ihre Änderungen zu speichern.


Ansicht - Tasterpfade

Dieses Menü erlaubt Ihnen festzulegen, welche Tasterpfade in der CAD-Ansicht zu sehen sein sollen.


Ansicht - Tasterpfade - Verbergen

Blendet alle Tasterpfade aus, ungeachtet welche Elemente gerade im Prüfvorgang ausgewählt sind. Zum Beispiel:


Ansicht - Tasterpfade - Alles anzeigen

Zeigt die Tasterpfade für alle Elemente im Prüfvorgang an (oder alle Elemente im ausgewählten Bereich). Zum Beispiel:


Ansicht - Tasterpfade - Auswahl anzeigen

Zeigt nur den Tasterpfad für das gerade im Prüfvorgang gewählte Element an. Zum Beispiel:


Ansicht - Tasterpfade - Sichtbares anzeigen

Zeigt die Tasterpfade für alle gerade sichtbaren Elemente (also diejenigen wo das Glühlampensymbol im Prüfvorgang angeschaltet ist). Zum Beispiel:


Neue Wege, die CAD-Ansicht zu drehen

Es gibt jetzt zusätzlich drei Wege, in welcher Sie die CAD-Ansicht drehen können. Vorher war der einzige Drehungsmodus um das Zentrum der Ansicht. Sie können jetzt auch drehen:

  • was aktuell sichtbar ist in der Ansicht (Option Sichtbare Ansicht - Dies ist der Standardmodus);
  • der CAD-Bezugspunkt (Option Ursprung );
  • Ein benutzerdefinierter Punkt (Option Ausgewählter Punkt).
  • Der originale Drehungsmodus um das Zentrum der Ansicht ist jetzt als Option Ansicht verfügbar.

Um den Drehungsmodus zu spezifizieren, nutzen Sie die Menüoption Ansicht - Drehanker .

In diesem Abschnitt

Ansicht – Drehungs-Anker


Ansicht – Drehungs-Anker

Wenn Sie eine CAD-Ansicht drehen, können Sie den Punkt auswählen, an welchem Sie die Drehung verankern wollen.

Angenommen, dass Sie zwei Kugeln in der CAD-Datei haben. Standardgemäß drehen diese sich um das Zentrum des aktuell Sichtbaren in der Registerkarte CAD-Ansicht (in Übereinstimmung mit der Standardoption Drehanker - sichtbar Ansicht):

In dieser Phase, wenn das ganze Teil angezeigt wird in der Registerkarte CAD-Ansicht, gibt die Option Drehanker - Sichtbare Ansicht die selben Resultate wie die Option Drehanker - Ansicht (welche das CAD-Modell dazu veranlasst, sich um das Zentrum der ganzen Ansicht zu drehen entgegengesetz zu lediglichen um die sichtbaren Teilen in der Registerkarte CAD-Ansicht). Aber Sie können die Differenz sehen, wenn Sie in eine der Sphären hineinzoomen.

Wenn der Drehanker auf Ansicht eingestellt ist, ist es schwer, die Mitte der Kugel zu erreichen, da das CAD-Modell um die ganze Ansicht gedreht wird (inklusive der Kugel, die aktuell nicht in der Registerkarte der CAD-Ansicht gezeigt wird.

Wenn Sie jedoch zurück in die Standardoption sichtbare Ansicht wechseln, sodass die Kugel um das Zentrum des aktuell Sichtbaren in der Registerkarte CAD-Ansicht gedreht wird, sind Sie automatisch im Zentrum der vergrößerten Ansicht:

Es gibt zwei andere Drehanker-Optionen neben der sichtbaren Ansicht und der Ansicht:

  • Ursprung - Das CAD-Modell wird um den CAD-Bezugspunkt gedreht (in diesem Fall die erste Kugel):

  • Gewählter Punkt - Das CAD-Modell wird um den benutzerdefinierten Punkt gedreht, zum Beispiel die Kugel oder dann der Bezugspunkt:

    Dies gibt die nachfolgende Drehung um die zweite Kugel:

    Sie können auch ein Merkmal als benutzerdefinierten Punkt wählen, zum Beispiel:

    Die Option Gewählter Punkt ist ausgegraut, bis Sie einen Punkt definiert haben, über welchen Sie die Ansicht drehen können durch eines der nachfolgenden Hilfsmittel:

    • Rechtsklicken Sie das entsprechende Merkmal im Sequenzbaum und wählen Sie Drehanker (Das Menüelement ist ausgegraut für ungeeignete Gegenstände wie Gruppen und Flächenprüfungspunkte).
    • Klicken Sie auf die Schaltfläche Geometrieelemente ändern [image] und schweben Sie über das entsprechende Geometrieelement in der CAD-Ansicht. Rechtsklicken Sie dann und wählen Sie Drehanker vom Kontextmenü.
    • Klicken Sie auf die Schaltfläche Flächenauswahl [image] und Wählen Sie die angebrachte(n) Fläche(n) in der CAD-Ansicht. Rechtsklicken Sie dann und wählen Sie Drehanker vom Kontextmenü. Der aufgenommene Punkt wird das Zentrum der gewählten Fläche(n) sein.

      Haben Sie ersteinmal einen Punkt gewählt, wird die Option Ansicht - Drehanker - Gewählter Punkt automatisch aktiviert und alle CAD-Drehungen sind um diesen Punkt, bis Sie einen verschiedenen Punkt oder die Option Ansicht - Drehanker anwählen.

    • Sie können den Mittelpunkt der Begrenzungsbox einer oder mehrerer Flächen ebenso mittels Flächenauswahl als Anker verwenden. Rechtsklicken Sie nachfolgende Auswahl und wählen Sie Drehanker.


Neues Berechnungsverfahren für die Beste Passung

PowerINSPECT 4.3 schließt eine neue Methode (Drehachse) für die Berechnung einer Besten Passung ein. Diese Methode erlaubt nur die Drehung um eine angegebenen Achse, in deren Drehzentrum auf der Achsen (entgegengesetzt zu

Nur Drehung , was die Drehung über einen festen Punkt erlaubt.

Die Methode Drehachse ist nützlich, wenn Sie Position und Ausrichtung von Merkmalen bewahren möchten - zum Beispiel, wenn Sie ein Teil haben, dass an einem bestimmten Punkt an einem anderen Teil anhängt.

Die nachfolgenden Einstellungen sind mit dieser Methode verfügbar:

  • Sperren der Verschiebung entlang des Vektors – Standardgemäß gibt Ihnen PowerINSPECT die Freiheit, oberhalb der gewählten Achse zu übersetzen. Wenn Sie jedoch die Verschiebung entlang des Vektors reparieren wollen, wählen Sie diese Option.
  • Referenzachse - Wählen Sie die Achsen, um welche Sie das CAD-Modell während der Beste Passung-Berechnung drehen wollen. Alternativ kann man [image] klicken, um ein Merkmalen direkt von der CAD-Ansicht zu wählen.

Die neuen Einstellungen erscheinen auf dem Formular Definition Beste Passung wie folgt:

In diesem Abschnitt

Beispiel der Drehung um eine Achse


Beispiel der Drehung um eine Achse

Der Schnitt illustriert, wie die Drehachsen-Berechnungsmethode vielleicht nützlich sen kann. Dies zeigt die Effekte des Nutzens dieser Methode, wenn das Versetzen entlang des Vektors gesperrt oder nicht gesperrt ist.


Szenario

Eine PowerINSPECT-Sitzung, die das CAD-Modell einer Klinge nutzt, wurde wie folgt vorbereitet:

  • Eine Geometriegruppe wurde mit einer Ebene erstellt (Ebene 1) und ein Kegel (Kegel) 1), dann ein kreisförmiges 3D Merkmal (Kreis 1) wurde erstellt mittels der Fläche und dem Kegel.
  • Eine Flächenprüfgruppe (Prüfgruppe 1) wurde erstellt mit einer Anzahl von Punkten.
  • Eine RPS-Ausrichtung wurde erstellt mittels des Kreises und einem der Flächenpunkte (SP 1):

    • Zum Erstellen der Ausrichtung wurde ein ganzes Merkmal genutzt und IJK sperren wurde eingestellt . Mit drei Verschiebungsachsen und zwei abwechselnden Achsen hierfür eingestellt, wird nur ein Punkt benötigten, um die Ausrichtung zu vollenden. Dies kann im Formular RPS-Ausrichtung Definition betrachtet werden:

  • Eine zusätzliche Flächenprüfgruppe (Prüfgruppe 2) wurde erstellt und gemessen:

  • Die obere Flächenprüfgruppe ist bestens angepasst um die Achse mit dem Kegel, jedoch ohne den Kegel zu veranlassen, entlang dessen Vektors zu verlaufen, sodass weder die Klinge, noch das Teil, welches in den Kegel passen soll, beliebige spätere Berichtigungen benötigen werden. Dafür nutzen wir die 'Gesperrter Vektor' Methode.
    • Deshalb sind die Ergebnisse für die 'ungesperrten Vektor' Methode auch gegeben.


Um eine Achse drehen: Gesperrter Vektor

  1. Klicken Sie [image] von der Symbolleiste Elemente, um das Formular Definition Beste Passung ändern anzuzeigen.
  2. Vervollständigen Sie das Formular wie folgt:

  3. Klicken Sie auf OK, um das Element Beste Passung in Prüfvorgang hinzuzufügen.
  4. Wählen Sie das Element Beste Passung von Prüfvorgang, Rechtsklicken Sie und wählen Sie Aufnehmen vom Kontextmenü, um das Formular Beste Passung-Analyse anzuzeigen.
  5. Klicken Sie auf Berechnen auf dem Formular Beste Passung-Analyse. Eine grafische Darstellung der Abweichung wird gezeigt:

    Die grüne Linie zeigt die Originalabweichung und die rote zeigt die Abweichung nach der Berechnung. Klicken Sie die Schaltfläche solange, bis die rot Linie grau wird, was bedeutet, dass die Resultate nicht mehr verbessert werden können.

  6. Klicken Sie auf OK, um das Formular Beste Passung-Analyse zu schließen.
  7. Das CAD-Modell ist aktualisiert:

    Die Verschiebung des Vektors entlang des Kegels ist unverändert, wie in der nachfolgenden Zeile der Registerkarte Information betrachtet werden kann:


Um eine Achse drehen: Ungesperrter Vektor

Wenn Sie die Abwechselnden Achsen-Methode zur Berechnung nutzen, jedoch ohne Verschiebung entlang des Vektors, sollten die Resultate der Besten Passung in der CAD-Ansicht ähnlich dein aber die Verschiebung des Vektors entlang des Kegels wird nach Bedarf geändert, was in der nachfolgenden Zeile der Registerkarte Information gezeigt wird:


Mehr eingeschränkte Merkmale in RPS-Ausrichtungen

Im Formular RPS-Ausrichtung Definition:

Es ist jetzt möglich, bis zu 12 eingeschränkte Merkmale mittels der Schaltfläche [image] hinzuzufügen, die nach dem letzten Merkmal erscheint. Wenn nicht alle ausgewählten Merkmale gleichzeitig im Formular angezeigt werden können, können Sie den Schiebebalken rechts nutzen.

Das erlaubt Ihnen, eine Ausrichtung nach Bedarf über-abhängig zu machen, typischerweise im Falle, dass sie nicht perfekt erstellt werden kann und einige Beste Passungen hierfür benötigt werden. Solche Ausrichtungen werden oft in der Automobil- und Raumfahrttechnik verwendet.


Importiert gemessene Resultate in andere Messungen

PowerINSPECT 4.3 beinhaltet eine neue Menüoption, Messungen - Importiert gemessene Daten, zum Importieren gemessener Resultate von einer Messung in eine andere Messung.

Das erlaubt Ihnen, das Teil in eine neue Position auf einer Maschine zu bewegen und zusätzliche Merkmale zu messen, ohne alle vorher gemessen Merkmale zurückberechnen. Nur die Merkmale, die in der Teileausrichtung verwendet werden, müssen zurückberechnet werden, sowie die Option Messungen - Importiert gemessene Daten automatisch alle andere Messresultate misst, die von einer Messung in eine neue Messung kopiert werden und die Resultate gemäß der zurückgemessenen Ausrichtung zurückberechnet.

In diesem Abschnitt

Messungen - Importiert gemessene Daten


Messungen - Importiert gemessene Daten

Verwenden Sie diese Menüoption, wenn Sie nach der Messung Teile auf einer Maschine physisch bewegen wollen und nicht alle zuvor gemessenen Gegenstände in Prüfvorgang zurückberechnen wollen. Dies geschieht beispielsweise vielleicht, wenn eine anfängliche Messung zeigt, dass ein Merkmal auf einem Teil außerhalb der Toleranz liegt und das Teil in die Maschine zurückkehrt zur Bearbeitung. Wenn das Teil fertig ist für die Messung nach der Maschinenneuausrichtung wünschen Sie vielleicht, nicht alle der vorher innerhalb der Toleranz gemessen Merkmale erneut aufzunehmen.

Die nachfolgenden Schritte illustrieren, wie Sie diese Option innerhalb von PowerINSPECT benutzen können:

  1. Sie haben eine PowerINSPECT-Sitzung mit einer Geometriegruppe (Geometriegruppe) 1) beinhaltet die nötigen Merkmale, um eine ELP-Ausrichtung zu erstellen, eine zusätzliche Geometriegruppe (Geometriegruppe) 2), und eine Flächenprüfgruppe (Prüfgruppe 1). Messen der Geometriegruppen und den Flächenprüfgruppen, sodass die Messungen in der Hauptteil-Messung gelagert werden:

    Sie können detaillierte Messinformation für die Prüfgruppen und Geometriemerkmale auf der Registerkarte Bericht ansehen - zum Beispiel die Messresultate für die Prüfgruppe 1:

  2. Aus irgendeinem Grund müssen Sie das Teil von der Maschine entfernen. Sie positionieren das Teil später an einer verschiedenen Stelle auf der Maschine neu.
  3. Das Erstellen einer neuen Messung, genannt Finale_Messung, nutzt die Menüoption Messungen - Neue Messung, welcher die aktuelle Messung wird. Beachten Sie, dass Messungssymbole für Gruppen in Prüfvorgang aktualisiert werden, um anzuzeigen, dass diese Gruppen noch nicht in Finale_Messung gemessen wurden:

    Beachten Sie auch, dass die Information auf der Registerkarte Bericht aktualisiert wird, um anzuzeigen, dass keine Messresultate existieren - zum Beispiel für die Prüfgruppe 1:

  4. Berechnen Sie die Merkmale in der Geometriegruppe 1 zurück, die in der ELP-Ausrichtung verwendet werden, um die Ausrichtung zu aktualisieren.
  5. Wählen Sie die Option Messungen - Importiert gemessene Daten. Das Formular Maß importieren wird für Sie angezeigt, um das Maß (Hauptteil) zu wählen, von welchem Sie Daten importieren wollen.
  6. Klicken Sie auf OK. PowerINSPECT importiert die gemessenen Daten vom Hauptteil in die Finale_Messung und rechnet diese zurück mittels zurückberechneter Ausrichtung, die Sie in Schritt 4 erstellt haben. Beachten Sie, dass Prüfvorgang für Finale_Messung aktualisiert wird, um zu reflektieren, dass die Messungsdaten importiert wurden:

    Die Information auf der Registerkarte Bericht wurde auch aktualisiert, um Details der importierten Messungen vom Hauptteil anzuzeigen. Beachten Sie, dass die Abweichungen gleich bleiben:

  7. Wenn benötigten, fügen Sie zusätzliche Gegenstände in die neue Messung ein - Zum Beispiel:

  8. Wenn die zusätzlichen Gegenstände gemessen wurden, wird sich Prüfvorgang automatisch aktualisieten, um zu zeigen, dass alle Messresultate jetzt in der aktuellen Messung aufbewahrt werden (Finale_Messung):

    Im Hauptteil messen, zusätzliche Gegenstände bleiben ungemessen:


Das Koordinatensystem eines Teil's transformieren

PowerINSPECT 4.3 beinhaltet eine neue Menüoption, Messungen - Sollwerte umformen, die Ihnen erlaubt, die Transformation von Teilen in ein anderes Koordinatensystem (vorausgesetzt, dass die Verschiebung/Drehung zum Zielbezugspunkt bekannt ist) und speichert die Transformation von einer Sitzung zur Nächsten. Dies spart Ihnen das Laden verschiedener Versionen des selben Modells, um es in verschiedenen Koordinatensystemen zu prüfen.

Dies ist besonders nützlich, wenn Sie beispielsweise Prüfinformationen in Werkzeugposition-Koordinaten liefern wollen und umgewandelte Berichte in Hauptteilposition/' Fahrzeuglinien'-Koordinaten erstellen.

In diesem Abschnitt

Messungen - Transformiert Nominalen


Messungen - Transformiert Nominalen

Wenn ein Teil ersteinmal in einer Ausrichtung/Position gemessen ist, generiert diese Option die Resultate, die von der Transformierung des Teils in verschiedenen Ausrichtungen/Positionen produziert würden.

  • Obwohl die Option durch die Definition die Sollwerte des Teils transformiert, hat dies auch den Effekt, alles andere zu transformieren, inklusive CAD- und gemessenen Daten und den Sequenzbaumobjekten.
  1. Erstellt eine neue PowerINSPECT Sitzung und zeigt das ausgerichtete Teil in der CAD-Ansicht an, zum Beispiel:

    • Sie können die Koordinatendaten bestätigen, indem Sie auf die Registerkarte Bericht klicken:

  2. Wählen Sie Messungen - Sollwerte umformen vom Menü.
  3. Das Formular Transformationsmatrix wird Ihnen angezeigt, damit Sie die benötigte Transformation spezifizieren können.
    • Haben Sie ersteimal die PWI-Datei gespeichert, wird die Transformation mit dem Teil gespeichert, sodass beim nächsten Öffnen der Datei das Teil automatisch transformiert wird. Wenn Sie zum Originalkoordinatensystem zurückkehren wollen, nutzen Sie einfach die Löschen-Schaltfläche im Formular Transformationsmatrix, um die Transformation zu entfernen, und dann die Datei zurückzuspeichern.
    • Die Originalabweichungen werden aufbewahrt.

      Vorausgesetzt, Sie wählten eine Drehung des CAD-Modell in Schritt 1 um 45 Grad Um Z. Die Registerkarte Bericht zeigt die geänderten Werte an:

    • Die Einschließung eines CAD-Ansicht Bericht -Elements erlaubt Ihnen, die Transformation zu visualisieren.


Erstellen von Messpfaden von einer Datei mit Sollwertpunkten

PowerINSPECT 4.3 beinhaltet eine neue Menüoption, Werkzeuge - Punkte importieren, welche Ihnen erlaubt, Tasterpfade automatisch zu erstellen, wenn Dateien importiert werden, die Koordinaten von spezifischen Sollwerten enthalten. Um ein Beispieldateiformat zu sehen, nehmen Sie Bezug auf Werkzeuge - Punkte importieren.

Nach dem Laden des CAD-Modells, das mit der Datei vereint ist, wählen Sie Werkzeuge - Punkte importieren und wählen Sie dann eine der folgenden Optionen aus:

  • Flächenprüfgruppe erstellen, um eine Flächenprüfgruppe von den angegebenen Punkte zu erstellen.
  • Geometriepunkte erstellen, um eine Geometriegruppe von einzelnen Punkten der angegebenen Punkte zu erstellen.

In diesem Abschnitt

Werkzeuge - Punkte importieren


Werkzeuge - Punkte importieren

Diese Möglichkeit erlaubt Ihnen, einen Tasterpfad von einer Textdatei, die spezifische Sollwertkoordinaten enthält, zu erstellen. Zum Beispiel eine durch Komma getrennte Datei von Koordinaten im XYZIJK-Format:

106,451827,50,000006,34,095465,-0,290788,-0,541083,0,789096

-0,000002, 49,524182,15,847267,0,-0,541082,0,84097

-80,268954,50,093428,25,603407,0,219156,-0,541084,0,811911

-97,762263, 0,15.50753,0,303025,0,0.952983

0,0,-0,600686,0,0,1

76,53957,0,9.198199,-0,23697,0,0.971517

91,946816,-50,000014,29,156563,0,251169,0,541084,0,802585

-1,627348,-50,000014,15,112013,0,004443, 0,541082,0,840958

-94,703469,-50,000002,30,033494,0,258701,0,541083,0,800189

Um die Datei von Punkten in PowerINSPECT zu importieren:

  1. Laden Sie das CAD-Modell, das mit der Datei, die Sie importieren wollen, verbunden ist.
  2. Wählen Sie:
    • Werkzeuge - Punkte importieren - Flächenprüfgruppe erstellen, um eine Flächenprüfgruppe von in der Datei angegebenen Punkten zu erstellen; und
    • Werkzeuge - Punkte importieren - Geometriepunkte erstellen, um eine Geometriegruppe von einzelnen Punkten von in der Datei angegebenen Punkten zu erstellen.

      Der Punkte importieren-Assistent wird angezeigt:

  3. Klicken Sie auf Suchen, um das Standard-Windowsformular Öffnen zu öffnen und lokalisieren Sie die Punktedatei, die Sie importieren möchten.

    Wenn PowerINSPECT die Dateiendung erkennt, zeigt es die Beschriebung des bekannten Dateityps unter der Registerkarte Mögliche Formate, zum Beispiel:

  4. Hervorheben des benötigten Formats. Wenn kein Format unter Mögliche Formate angezeigt wird, klicken Sie auf die Registerkarte Alle Formate und heben Sie das benötigte Format, dass in der Liste angezeigt wird, hervor.

    Wenn Sie sehen wollen, wie das ausgewählte Format die Punktkoordinaten in der Datei interpretiert, klicken Sie auf Vorschau. Zum Beispiel:

    Klicken Sie auf OK, um das Fenster zu schließen.

  5. Wenn Sie das benötigte Dateiformat gewählt haben, Klicken Sie auf Weiter, um eine Zusammenfassung der Optionen zu sehen, die im Importprozess verwendet wird:

    Wenn Sie zufrieden sind mit dieser Zusammenfassung, klicken Sie auf Weiter, um fortzufahren. Andernfalls bestätigen Sie die Optionen mittels der Schaltfläche Vorschau vor dem Fortfahren. Wenn Sie das Dateiformat ändern wollen, klicken Sie auf Zurück und fahren Sie fort ab Schritt 4. Wenn Sie den Importprozess stoppen wollen, klicken Sie Abbrechen.

  6. PowerINSPECT startet den Import von Punkten in eine neue Gruppe. Wenn Sie den Importprozess stoppen wollen, klicken Sie Stop und bestätigen Sie durch Klicken auf Ja. PowerINSPECT stoppt den Importprozess, aber Sie werden die neue Gruppe von Prüfvorgang entfernen müssen.

    Ist der Import einmal vollendet, zeigt PowerINSPECT die Punkte in der CAD-Ansicht an und eine Meldungsbox erscheint, welche die Erstellung der Prüfung oder Geometriegruppe in Prüfvorgang bestätigt und die Anzahl der Punkte, die zur Erstellung verwendet wurden.

  7. Klicken Sie auf OK, um die Bestätigungsmeldung zu schließen, gefolgt vom Klicken auf die Schaltfläche Abschließen, um den Assistenten zu schließen.

    Für ein Beispiel der Erstellung einer Geometriegruppe, siehe Werkzeuge - Punkte importieren - Geometriepunkte erstellen.

    Für ein Beispiel der Erstellung einer Flächenprüfgruppe, siehe Werkzeuge - Punkte importieren - Flächenprüfgruppe erstellen.

In diesem Abschnitt

Werkzeuge - Punkte importieren - Geometriepunkte erstellen

Werkzeuge - Punkte importieren - Flächenprüfgruppe erstellen


Werkzeuge - Punkte importieren - Geometriepunkte erstellen

Bezug nehmend auf Werkzeuge - Punkte importieren für den Gebrauch des Punkte importieren-Assistenten.

Vorausgesetzt, Sie haben den Assistenten verwendet, um die Datei mit den neun Punkten, die im Beispiel Werkzeuge - Punkte importieren gezeigt wird, im nachfolgenden Modell zu importieren:

  1. Die nachfolgenden einzelnen Punkte erscheinen in Prüfvorgang, eine neue Geometriegruppe erstellend:

  2. Haben Sie einmal die Bestätigungsmeldung und den Assistenten abgeschlossen, werden die 9 Punkte wie folgt angezeigt:


Werkzeuge - Punkte importieren - Flächenprüfgruppe erstellen

Bezug nehmend auf Werkzeuge - Punkte importieren für den Gebrauch des Punkte importieren-Assistenten.

Vorausgesetzt, Sie haben den Assistenten verwendet, um die Datei mit den neun Punkten, die im Beispiel Werkzeuge - Punkte importieren gezeigt wird, im nachfolgenden Modell zu importieren:

  1. Die nachfolgende Prüfgruppe erscheint in Prüfvorgang:

  2. Haben Sie einmal die Bestätigungsmeldung und den Assistenten abgeschlossen, werden die 9 Punkte wie folgt angezeigt:

  3. Ändern Sie die Messstrategie und Methode, wenn benötigt.


Erweiterungen für den Bericht

Die in der Registerkarte Bericht angezeigten Informationen wurden wie folgt erweitert:

  • Sie können jetzt ein CAD-Ansicht Bericht Element in Prüfvorgang oder in eine beliebige offene Gruppe in Prüfvorgang einfügen, um einen entsprechenden Schnappschuss der CAD-Ansicht und deren definierenden Charakteristika in der Registerkarte Bericht zu generieren. Sie können die Ausrichtung jedes Schnappschusses der CAD-Ansicht kontrollieren, der im Bericht eingefügt wurde. Sie haben auch die Option, das Element in Ansicht modifizieren während Aufnahme einzustellen, was den Effekt hat, dass die Position, Vergrößerung und Ausrichtung der CAD-Ansicht zur Berichtelementform zurückgeändert wird, wie wenn das CAD-Ansicht Bericht-Element als Teil von Prüfvorgang aufgenommen wird.
    • Der Schnappschuss erscheint auch in der Registerkarte Information, wenn das Element in Prüfvorgang gewählt wurde.
    • Sie können das Formular Globale Berichtoptionen auswählen (siehe unten), um die Optionen Hintergrund der Bildschirmfotos verbergen und Hohe Auflösung der Bildschirmfotos ein- oder auszustellen. Die ehemalige Option ist standardgemäß ausgewählt, sodass die Hintergründe in den Schnappschüssen nicht miteinbezogen werden. Wenn die Leiteroption ausgewählt ist, werden Schnappschüsse mit der selben Qualität wie die in CAD-Ansichtsausdrucken erstellt (wenn nicht gewählt, was standardgemäß eingestellt ist, ist die Qualität gleich der CAD-Ansicht Druckvorschau).

      Für einige Beispiele von CAD-Ansicht Bericht-Gegenständen, die Bezug nehmen auf Messungen - Sollwerte umformen.

  • Sie können gemessen Punkte anzeigen. Wählen Sie Messungen - Parameter - Variablen und klicken Sie auf Globale Berichtoptionen:

    Das nachfolgende Formular wird angezeigt:

    Sie können dann die Option Zeigt gemessene Punkte wählen, welche Ihnen das Berichten individuell gemesser Punkte ermöglichen wird.

  • Ungemessen Flächenprüfgruppen werden durch den Satz 'Keine Punkte aufgenommen' angezeigt.
  • Ungemessen Werte werden als xxxxx angezeigt (wie im Beispiel unten).
  • Jedes geometrische Merkmale wird von einer Zeichenfolge in Klammern gefolgt, die anzeigt, dass die Referenzelemente, zu welchen die Resultate relativ sind, zum Beispiel der Bezugspunkt oder Merkmale, einen Winkel plus der vereinten Referenzebene definieren:

  • Zusätzlich kann man jetzt das Koordinatensystem eines Teils wählen und umformen und die aktualisierten Koordinatendaten in der Registerkarte Bericht ansehen.

In diesem Abschnitt

CAD-Ansicht Bericht-Element


CAD-Ansicht Bericht-Element

Es mag Zeitpunkte geben, an denen Sie vielleicht einen Schnappschuss der aktuell CAD-Ansicht in Ihren Prüfbericht hinzufügen möchten. Zum Beispiel:

  • Nach der Erstellung eines einzelnen CAD-Ansicht Zustands, können Sie entscheiden, dass es vielleicht zusätzlich zur Erstellung der einzelnen CAD-Ansicht in der Prüfvorgang auch nützlich sein könnte, die Kenndaten der Ansicht für den Prüfbericht aufzunehmen.
  • Nach der Erstellung einer Flächenprüfgruppe können Sie eine Aufnahme der aktuellen CAD-Ansicht ohne alle angezeigten Elemente in Geometriegruppen angezeigt bekommen (anstatt zurück zu gehen in die Prüfvorgang, um sie alle auszuschalten).

Die Mehrheit der CAD-Ansicht-Charakteristika werden mit jedem Schnappschuss gespeichert, beispielsweise:

  • Sichtbare Elemente
  • Sichtbare CAD-Modell-Ebenen
  • Position, Vergrößerung und Ausrichtung
  • Schattierungsmodus
  • Modus Anzeigen - Aufdrucke, Vor Ort oder Messmarkierungen
  • Anzeigefilter Einstellungen.
  • Die Position, Vergrößerung und Ausrichtung der CAD-Ansicht wird dynamisch aktualisiert, um das Element CAD-Ansicht Bericht anzupassen, wenn Sie das Element rechtsklicken und Ansicht wiederherstellen auswählen (der Effekt ist der Selbe wie das Aufnehmen des CAD-Ansicht Bericht-Elements in Prüfvorgang, wenn das Element auf Ansicht modifizieren während Aufnahme gestellt ist).
  • Die Charakteristika des Berichts werden dynamisch aktualisiert, um die CAD-Ansicht anzupassen, wenn Sie das Element CAD-Ansicht Bericht Rechtsklicken und Aufnahmezustand wählen.

Das Element Prüfvorgang, welches Ihnen erlaubt, einen Schnappschuss aufzunehmen, wird CAD-Ansicht Bericht-Element genannt. Um solch ein Element in Prüfvorgang einzufügen:

  1. Stellt die CAD-Ansicht so ein, dass sie die Charakteristika hat, die Sie speichern wollen.

    Klicken Sie auf die Schaltfläche CAD-Ansicht-Bericht CadViewReportButt, um das Formular CAD-Ansicht Bericht anzuzeigen.Dies wurde gefunden:

    • auf der Symbolleiste Element, wenn Sie das Element in die Definitions- (oder die oberste) Ebene der Prüfvorgang einfügen:

      oder wenn eine Flächenprüfung oder Schnittgruppe geöffnet ist.

    • auf der Symbolleiste Verschiedenes, wenn das Element innerhalb einer offenen Geometriegruppe in Prüfvorgang eingefügt wird:

  2. Vervollständigen Sie das Formular CAD-Ansicht Bericht:

    • Ändern Sie den Namen, wie benötigt.
    • Klicken Sie danach auf das Auswahlfeld Ansicht modifizieren während Aufnahme, wenn Sie die Position, die Vergrößerung und die Ausrichtung der CAD-Ansicht zurückändern möchten zu der Form, die im Berichtelement angegeben ist, wenn das Element als Teil von Prüfvorgang aufgenommen wird.
    • Spezifizieren Sie die benötigte Ausrichtung durch Klicken auf die Optionsschaltfläche Portrait oder Landschaft.
    • Das Element wird standardgemäß in der Registerkarte Bericht erscheinen. Wenn Sie dies nicht wollen, klicken Sie auf die Schaltfläche nachfolgend zu Ausgabe in Bericht, so dass es sich zu [image] ändert (die Schaltfläche wirkt als Ein-/Ausschalter, so dass Sie sie einfach erneut klicken müssen, sollten Sie es umkehren wollen).
  3. Ein CAD-Ansicht Bericht-Element wurde der Prüfvorgang hinzugefügt - Beispielsweise:

    • Der Schnappschuss erscheint auch in der Registerkarte Information, wenn das Element in Prüfvorgang gewählt wurde.
  4. Wenn Sie auf die Registerkarte Bericht klicken, wird die aufgenommene CAD-Ansicht angezeigt:

  5. Wenn Sie beliebige der angezeigten Charakteristika des Berichtelements ändern wollen, wechseln Sie in die CAD-Ansicht, aktualisieren Sie die Anzeige, rechtsklicken Sie das Element CAD-Ansicht Bericht-Element in Prüfvorgang und wählen Sie Aufnahmezustand vom Kontextmenü. Wenn Sie erneut in die Registerkarte Bericht wechseln, werden Sie sehen, dass das Bild aktualisiert wurde.

    Wenn Sie die Position ändern wollen, vergrößern Sie die Ausrichtungen der CAD-Ansicht um jene im Berichtelement zu treffen, rechtsklicken Sie das CAD-Ansicht Bericht-Element in Prüfvorgang und wählen Sie Ansicht wiederherstellen vom Kontextmenü. Die CAD-Ansicht wird unmittelbar aktualisiert.

  6. Wenn Sie die Elemente in Prüfvorgang messen, wird PowerINSPECT automatisch die Position, Vergrößerung und Ausrichtung der CAD-Ansicht ändern, um jedes CAD-Ansicht Bericht-Element in Prüfvorgang zu treffen, das Ansicht modifizieren während Aufnahme gewählt hat.


Neue Automatikberechnungs-Option für die Messung

Sie können jetzt spezifizieren, ob Sie wollen, dass PowerINSPECT die Geometriemerkmale während der Messung automatisch berechnet. in Vorgängerversionen versuchte PowerINSPECT automatisch, Geometriemerkmale zu berechnen, wenn einmal die minimale Anzahl der Punkte aufgenommen wurde.

Es kann nützlich sein, 'Automatische Berechnung' beim Messen von Merkmalen mit großer Anzahl von Punkten (wie Kegel) unnutzbar zu machen, um die Messung zu beschleunigen.

Um die automatische Berechnung zu kontrollieren, nutzen Sie die Schaltfläche Automatisch berechnen [image] :

  • Die automatische Berechnung ist standardgemäß angeschalten und hat sich somit im Verhalten zu den Vorgängerversionen von PowerINSPECT nicht geändert.

PowerINSPECT erinnert sich an die Einstellung, die Sie in diesem Formular spezifiziert haben und wendet diese auf alle gemessen Merkmale an.

In diesem Abschnitt

Beispiel einer Messung mit eingeschaltener automatischer Berechnung

Beispiel einer Messung mit ausgeschaltener automatischer Berechnung


Beispiel einer Messung mit eingeschaltener automatischer Berechnung

Das nachfolgende Beispiel zeigt den Effekt einer Kugelmessung, die einen 'Springball'-Tasterpfad nutzt, wenn die automatische Berechnung angeschalten ist:

  1. Der erste Punkt wurde gemessen und PowerINSPECT wartet auf den zweiten Punkt, der gemessen werden soll. Die Anzahl der aufgenommenen Punkte-Anzeiger hat einen roten Hintergrund, um anzuzeigen, dass die minimale Anzahl der Punkte benötigt wird, um zu definieren, dass dieses Merkmal noch nicht erreicht wurde:

  2. Da mehr Punkte aufgenommen werden, wird PowerINSPECT versuchen, das Merkmal zu berechnen (siehe die X-,Y-, Z- und andere Werte im Formular Merkmalsaufnahme) und repräsentiert diese Werte grafisch auf der Vollbild-Messung CAD-Ansicht. Ist die minimale Anzahl der Punkte zum definieren des Merkmals (vier für eine Kugel) ersteinmal erreicht, ändert sich der Hintergrund des Anzahl der aufgenommenen Punkte-Indikators in grün. Die Messung ist noch nicht komplett, da der Tasterpfad fünf gemessene Punkte enthält und nur vier Punkte gemessen wurden:

  3. Ist der fünfte Punkt im Tasterpfad ersteinmal gemessen, schließt PowerINSPECT die Berechnung der Kugel ab, schließt automatisch das Formular Merkmalsaufnahme und zeigt das gemessene Merkmal in der CAD-Ansicht an:


Beispiel einer Messung mit ausgeschaltener automatischer Berechnung

Das nachfolgende Beispiel zeigt den Effekt einer Messkugel, die einen 'Springball'-Tasterpfad nutzt, wenn die automatische Berechnung ausgeschalten ist:

  1. Der erste Punkt wurde gemessen und PowerINSPECT wartet auf den zweiten Punkt, der gemessen werden soll. Die Anzahl der aufgenommenen Punkte-Anzeiger hat einen orangerfarbenen Hintergrund, um anzuzeigen, dass die automatische Berechnung ausgeschalten ist, so wird die Berechnung verschoben, bis alle Punkte im Tasterpfad gemessen wurden:

  2. Da mehr Punkte aufgenommen wurden, versucht PowerINSPECT nicht, die Eigenschaft aus den aufgenommenen Punkten zu berechnen. PowerINSPECT ist sich nicht gewahr, ob die minimale Anzahl der Punkte erreicht wurde, also bleibt der Hintergrund der Anzahl der aufgenommenen Punkte Indikator orange, um anzuzeigen, dass die automatische Berechnung ausgeschalten ist.

    Die Messung ist noch nicht komplett, da der Tasterpfad fünf gemessene Punkte enthält und nur vier Punkte gemessen wurden:

  3. Ist der fünfte Punkt im Tasterpfad ersteinmal gemessen, berechnet PowerINSPECT die Kugel, schließt automatisch das Formular Merkmalsaufnahme und zeigt das gemessene Merkmal in der CAD-Ansicht an:


Änderungen, um ein CAD-Ansicht Statuselement zu modifizieren

Um in anderen Bereichen von PowerINSPECT einheitlicher zu sein, hat sich die Art, wie Sie CAD-Ansicht Zustands-Elemente ändern können, folgend geändert:

Aufgabe

Erledigen Sie diese Schritte:

Umbenennen eines CAD-Ansicht Statuselements

  1. Wählen Sie das CAD-Ansicht Statuselement in Prüfvorgang, welches Sie umbenennen wollen.
  2. Klicken Sie auf die Schaltfläche Element modifizieren [image] , um das Formular CAD-Ansichtsstatus angezeigt zu bekommen.
  3. Geben Sie einen neuen Namen für das Element im Feld Name und Klicken Sie auf OK.

Alternativ kann man das CAD-Ansichts-Statuselement in der Prüfvorgang rechtsklicken, die Option Element umbenennen auswählen und dann den neuen Namen eingeben.

Aktualisiert ein CAD-Ansicht Statuselement mit der Position, Vergrößerung und Ausrichtung, die aktuell in der CAD-Ansicht angezeigt werden
  1. Stellt die CAD-Ansicht ein, um die Position, Vergrößerung und Ausrichtung zu zeigen, die Sie speichern wollen.
  2. Wählen Sie das CAD-Ansicht Statuselement in Prüfvorgang, welches Sie aktualisieren wollen.
  3. Rechtsklicken Sie und Wählen Sie Aufzeichnungsstatus aus dem Kontextmenü. Das CAD-Ansicht Statuselement wird aktualisiert.

ändert die CAD-Ansicht, um die Position zu reflektieren, vergrößert und speichert die Orientierungseinstellungen in einem CAD-Ansicht Statuselement
  1. Wählen Sie das CAD-Ansicht Statuselement in Prüfvorgang.
  2. Rechtsklicken Sie und Wählen Sie Ansicht zurücksetzen aus dem Kontextmenü. Die CAD-Ansicht wird aktualisiert, um die im CAD-Ansicht Statuselement gespeicherten Einstellungen wiederzuspiegeln.


Farben für Box-Aufdrucke

Die Farben, die für Box-Aufdrucke verwendet wurden, haben sich wie folgt geändert:

  • Das Farbschema für die umgebenden Boxen wurde vereinfacht, sodass es einfacher ist, zu sehen, welche Gegenstände innerhalb oder außerhalb der Toleranz liegen.
  • Abweichungswerte sind nun farbcodiert, um anzuzeigen, ob sie innerhalb, oberhalb oder unter der Toleranz liegen.

In diesem Abschnitt

Umgebende Box Farben

Farben der abweichenden Werte


Umgebende Box Farben

Die umgebenden Boxen nutzen nachfolgendesa Farbschema:

  • Grün - Gemessen innerhalb der Toleranz.
  • Rot - Außerhalb der Toleranz gemessen (entweder oberhalb oder unterhalb der Toleranz).
  • Gelb - ungemessen (Nur in Geometriemerkmalen anwendbar).
  • Schwarz - kann nicht bemessen werden (beispielsweise konstruierte Ebenen).

Zum Beispiel:


Farben der abweichenden Werte

Die innerhalb von Box-Aufdrucken angezeigten Abweichungswerte sind farbcodiert, um anzuzeigen, ob die Werte innerhalb, oberhalb oder unter der Toleranz liegen:

  • Grün - Innerhalb der Toleranz.
  • Rot - Über der Toleranz.
  • Blau - unterhalb der Toleranz.

Zum Beispiel:

  • Die Abweichungswerte erscheinen in Box-Aufdrucken nur, wenn Mehr Information ausgewählt ist im Formular Anzeigefilter.


CAD-Ebenen für Flächenprüfgruppen

PowerINSPECT 4.3 erlaubt Ihnen, CAD-Ebenen (oder CAD-Kontext) zu definieren, welche auf Flächenprüfungen aufgebracht werden für individuelle Flächenprüfgruppen.

Vorher wurde der CAD-Kontext in allen Flächenprüfgruppen in Prüfvorgang angewendet und kann nicht für individuelle Flächenprüfgruppen außer Kraft gesetzt werden.

Das definieren der CAD-Ebenen in Verwendung mit der Prüfung einer Flächenprüfgruppe kann nützlich sein, wenn Sie dies tun wollen:

  • Bietet mehr Führung bei der manuellen Messung, beispielsweise, um die Fläche zu steuern, auf der Punkte aufgenommen werden, ohne die tatsächlich aufzunehmenden Koordinaten zu spezifizieren.
  • Entfernt die Möglichkeit des Herausnehmens eines Punkts in der falschen Fläche. Wenn Sie beispielsweise einen Flächenpunkt auf einer Kopie messen, werden zwei Flächen vielleicht sehr nahe aneinander liegen und PowerINSPECT wird vielleicht versuchen, den Punkt zu treffen, den Sie auf dem Teil zur falschen CAD-Fläche hin gemessen haben.

    Das nachfolgenden Beispiel zeigt zwei Oberflächen, die innerhalb der Toleranz des gemessen Kontakts liegen. Mittels CAD-Ebenen (jeder Fläche in verschiedenen CAD-Ebenen) können Sie spezifizieren, dass nur die Deckfläche für diese Prüfung aktiv ist, so dass PowerINSPECT nicht versuchen wird, den gemessenng Punkten mit der unteren CAD-Fläche zu treffen.

In diesem Abschnitt

CAD-Ebenen als Flächenprüfgruppe spezifizieren


CAD-Ebenen als Flächenprüfgruppe spezifizieren

Standardgemäß nutzen alle Flächenprüfgruppen in der Prüfvorgang die selben CAD-Ebenen (oder CAD-Kontext) für die Prüfung. Wenn eine Sichtebene in den CAD-Kontext einbezogen wird, überprüft PowerINSPECT die Übereinstimmung gemessener Punkte mit den CAD-Flächen auf dieser Sichtebene. Sie können die Ebenen ansehen, die aktuell für die Prüfung auf der Registerkarte CAD-Dateiverwaltung eingestellt sind. Ein Häkchen entlang einer CAD-Ebene zeigt an, dass es in die nachfolgende Prüfung miteinbezogen wird - in folgenden Beispiel nur Ebene 1 : Flächen wurden als CAD-Ebenen für die Prüfung gewählt:

Um die Standard-CAD-Ebenen für eine Prüfung einer individuellen Flächenprüfgruppe außer Kraft zu setzen:

  1. Wählen Sie eine Flächenprüfgruppe von Prüfvorgang aus und klicken Sie [image], um das Formular Flächenprüfgruppe anzuzeigen.
  2. Klicken Sie auf die Schaltfläche Nutzbare Ebenen, um das Formularfenster Ebenenauswahl anzuzeigen:

    Standardgemäß werden sämtliche vefügbare Ebenen als aktiv ausgewählt (das ist, wenn sie zur Prüfung dieser Flächenprüfgruppe genutzt werden). Sie können Ebenen zwischen Aktive Sichtebenen (miteinbezogen in der Prüfung) und Verfügbare Sichtebenen (nicht miteinbezogen in der Prüfung) wie folgt auflisten:

    Linked PowerINSPECT Graphics Directory Template – bewegt alle Ebenen von der Liste Aktive Sichtebenen in die Liste Verfügbare Sichtebenen.

    Linked PowerINSPECT Graphics Directory Template – bewegt alle ausgewählten Ebenen von der Liste Aktive Sichtebenen in die Liste Verfügbare Sichtebenen.

    Linked PowerINSPECT Graphics Directory Template – bewegt alle ausgewählten Ebenen von der Liste Aktive Sichtebenen in die Liste Verfügbare Sichtebenen.

    Linked PowerINSPECT Graphics Directory Template – bewegt alle Ebenen von der Liste Aktive Sichtebenen in die Liste Verfügbare Sichtebenen.

  3. Wenn Sie die Ebenen gewählt haben, die Sie bei der Prüfung der Flächenprüfgruppe verwenden wollen, klicken Sie auf OK, um das Formular zu schließen und zum Formular Flächenprüfgruppe zurückzukehren.
  4. Wenn Sie das Formular Flächenprüfgruppe vervollständigt haben, klicken Sie auf OK.

Wenn Sie das Teil prüfen, ignoriert PowerINSPECT beliebige Flächen in den CAD-Ebenen, die nicht für die Prüfung gewählt wurden. Zum Beispiel, wenn ein Teil nachfolgende Ebenen aufweist:

und Sie eine Flächenprüfgruppe mit Punkten auf den Oberflächen in allen drei Ebenen, erstellt PowerINSPECT Resultate für alle Flächen - wie zum Beispiel:

Wenn Sie jedoch Ebene 2 ausschließen: Drahtmodelle von der Prüfung, PowerINSPECT ignoriert beliebige Flächen in dieser Ebene bei der Prüfung dieses Teils - zum Beispiel:


Änderungen im Formular Optionen

Wenn Sie das Formular Optionen nutzen, können Sie jetzt Hilfe in Form von Popups bekommen, auf dem Einstellungen verfügbar sind.

Verschiedene neue Einstellungen sind dem Formular Optionen auch hinzugefügt worden:

  • Ändern der Zeichensätze.
  • Ändern der Farbe von Bezeichnungslinien und Pfeilen.
  • Ändern der Farben von erlangten und Prüflinienpunkten in Punktewolken.
  • ändern der Überschreibung für den Kommentartyp, der während einer Prüfung angezeigt wird.

Um das Formular Optionen anzuzeigen, wählen Sie Werkzeuge - Optionen vom Menü.

In diesem Abschnitt

Hilfe bekommen im Formular Optionen

Ändern der Zeichensätze

Ändern der Farbe von Bezeichnungslinien und Pfeilen

Ändern der Farben von erlangten und Prüflinienpunkten

Einstellungs-Vorzüge für Kommentar-Vehalten


Hilfe bekommen im Formular Optionen

Es gibt Hilfe in Form von Popups für die verschiedenen Einstellungen im Formular.

Um ein Auswahlmenü anzuzeigen, klicken Sie auf die Schaltfläche [image] oben rechts des Formulars und bewegen Sie den Mauszeiger (jetzt in Form eines Fragezeichens) über die benötigte Einstellung:

Klicken Sie, um das relevante Auswahlfenster anzuzeigen, wie zum Beispiel:


Ändern der Zeichensätze

Sie können jetzt den Zeichensatz ändern, der für die Raster und Skalieren-Messungen in der CAD-Ansicht verwendet wird und auch für Aufdrucke. Wählen Sie die Schriftarten:

Standardgemäß ist das Feld Systemzeichensatz verwenden aktiviert und die Felder Gitter und Skalieren Zeichensatz und Aufdruck-Zeichensatz sind nicht verfügbar. Um einen Zeichensatz zu ändern, wählen Sie das Feld Nutzen des Systemzeichensatzes ab, um die anderen Felder verfügbar zu machen und machen Sie dann die benötigte Zeichensatz-Auswahl von den Auswahlisten Raster- und Skalier-Zeichensatz und/oder Markierungszeichensatz. Klicken Sie dann die Schaltfläche Zuweisen, um die entsprechenden Zeichensätze in der CAD-Ansicht zu ändern (oder andernfalls die Schaltfläche OK, wenn Sie die Änderungen ausführen und das Formular schließen wollen).


Ändern der Farbe von Bezeichnungslinien und Pfeilen

Sie können jetzt die Farbe der Linie ändern, die verwendet wird, um das Merkmal oder den Punkte zu identifizieren, auf welches siche eine Box bezieht - zum Beispiel:

Um die Farbe der Bezeichnungspfeile zu ändern, nutzen Sie die Option Markierungspfeilfarbe unter Farben - Allgemein:

Zum Ändern einer Farbe, zeigen Sie die Standard-Farbpalette entweder durch Doppelklicken auf die Farbe für die Einstellung, die Sie ändern wollen oder Klicken Sie auf die Schaltfläche unter Hauptfarbe. Wählen Sie dann eine verschiedenen Farbe. Die neulich gewählt Farbe ersetzt die Existierende. Wenn Sie sehen wollen, wie die neue Farbe innerhalb von PowerINSPECT aussieht, klicken Sie die Vorschau-Schaltfläche. Wenn Sie dann wünschen, zur Originalfarbe zurückzukehren, klicken Sie die Schaltfläche Zurücksetzen.


Ändern der Farben von erlangten und Prüflinienpunkten

Es gibt zwei neu Optionen unter Farben - Punktewolke, welche Ihnen erlauben, zusätzliche Farben bei der Arbeit mit Punktewolken zu spezifizieren:

  • Erworbene Punkte, welche die Farben von Punkten leiten, die durch einen Laser gesammelt werden, bevor sie auf die Fläche projiziert werden (Die Standardfarbe ist weiß).
  • Erworbene Abtastlinienpunkte, welche die Farben von erworbenen Laserlinienpunkten für geometrische Elemente und Flächen in der CAD-Ansicht (Die Standardfarbe ist rot).

  • Um Erworbene Abtastlinienpunkte in der CAD-Ansicht anzuzeigen, muss die Option Tastermitte anzeigen (unter Anzeigeoptionen - CAD-Ansicht) angewählt sein.


Einstellungs-Vorzüge für Kommentar-Vehalten

Wenn die aktuell Prüfsitzung einen oder mehrere Kommentare Linked PowerINSPECT Graphics Directory Template in Prüfvorgang besitzt, dann legt die angewählte Optionsschaltfläche unter dem Formular Kommentare das Vehalten während der Prüfung fest:

  • Klicken Sie auf Modal, wenn Anmerkungen durch den Benutzer bestätigt werden müssen (durch Klicken auf [image]) während einer Prüfung, bevor man die Messung fortsetzen kann.
  • Klicken Sie auf Modellos wenn Anmerkungen geöffnet bleiben können, während der Benutzer die Messung fortsetzt.
  • Lassen Sie die Standardeinstellung Nutzen der Kommentareinstellung ausgewählt, wenn es nichts außer Kraft zu setzen gibt. Dies bedeutet, dass das Vehalten jedes individuellen Kommentars durch die Einstellung bestimmt wird, durch welche er in Prüfvorgang vereint ist:

    Der obige Kommentar ist aktuell auf Ohne Modus gesetzt, weil das Standard-Als modelloses Element angewählt ist. Wenn Sie möchten, dass der Kommentar sich so verhält, wie in einer Modalen Art, so dass der Anwender gezwungen ist, zu bestätigen, bevor fortgefahren werden kann, deselektieren Sie Als modelloses Element anzeigen und klicken Sie [image].


Nutzen Sie ungemessene Merkmale zur Erstellung von GD&T-Gegenständen

Die Art, in welcher Sie GD&T-Messungen erstellen, hat sich wie fogt geändert:

  • Beide bemessene und unbemessene Konstruktionselemente sind nun verfügbar für die Auswahl, wenn Sie den GD&T Assistenten verwenden.
  • Die anfängliche Berechnung für alle GD&T Messungen, die auf dem Ergebnisvorschau-Bildschirm des Assistenten gezeigt werden, wird jetzt mittels Sollwerte eher als mit Daten von aktuellen Messungen ausgeführt. Die auf der Registerkarte Information gezeigten GD&T Messdetails sind immernoch auf der aktuellen Messung aufgebracht.

In diesem Abschnitt

Verwenden des GD&T Assistenten


Verwenden des GD&T Assistenten

Verwenden Sie den Form-/Lagetoleranz-Assistenten, um eine GD&T Messung als ein geometrisches Element zu definieren und berichten Sie dann, ob die Merkmale, gegen welche sie gemessen werden, Ihre Kriterien treffen.

Diese Anweisungen in Assistent variieren in Abhängigkeit des Typs der Messung, die Sie erstellen. Das nachfolgenden Beispiel zeigt, wie GD&T-Rechtwinkligkeitsmessungen mittels ungemessem Zylinder und gemessen Ebene erstellt werden:

  1. Öffnen Sie eine Geometriegruppe und klicken Sie dann auf Linked PowerINSPECT Graphics Directory Template in der Symbolleiste Element, um den Form-/Lagetoleranz-Assistenten anzuzeigen:

    Linked PowerINSPECT Graphics Directory Template

  2. Wenn Sie den in dem für die Identifizierung des Form-/Lagetoleranz-Element in der Geometriegruppe genutzten Namen ändern wollen, geben Sie dies in das Feld Name ein.
  3. Wählen Sie Rechtwinkligkeit und klicken Sie dann auf Weiter>, um den nächsten Bildschirm im Assistenten anzuzeigen:

    Linked PowerINSPECT Graphics Directory Template

    Der Assistentenbildschirm ist in nachfolgende Bereiche aufgeteilt:

    - Anweisungen, zur Handhabung dieser Anzeige.

    - Der GD&T Toleranzrahmen. Diese Information wird dadurch erstellt, was Sie von diesem Bildschirm wählen, beispielsweise wird hier das Rechtwinkligkeitssymbol gezeigt und dass das Merkmal eine Toleranz von 0,01 Durchmesser in Verknüpfung mit dem Bezugspunkt heben soll. A.

    - Merkmal- und Bezugspunktbereiche sind dort, wo Sie das zu messende Merkmal wählen und den Bezugspunkt, gegen welchen gemessen wird. Hier, Zylinder 1(ungemessen, bezeichnet wie bei [image] ) ist als Merkmal und Ebene ausgewählt. 1 (gemessen, wie in [image] bezeichnet) als einzelner Bezugspunkt.

    - DerToleranzbereich ist dort, wo Sie die Toleranz für die Messung definieren.

    - Klicken Sie auf die Schaltfläche Beispiel zeigen, um ein Beispieldiagramm für diesen Fall angezeigt zu bekommen.

  4. Wenn Sie die Fragen des Assistenten beantwortet haben, klicken Sie auf Weiter>, um den Bildschirm Ergebnisvorschau anzuzeigen und eine Vorschau der Resultate der GD&T-Messung zu betrachten, die mittels Sollwerten des Merkmals erstellt wurde. Farbiger Text wird verwendet, um zu kennzeichnen, ob die Messung innerhalb der Toleranz (grün) oder außerhalb der Toleranz (rot) liegt - zum Beispiel:

    Blättern Sie weiter für mehr Einzelheiten:

    Linked PowerINSPECT Graphics Directory Template

    Hier können Sie die Toleranzzone sehen. Eine Messung ist außerhalt der Toleranz, wenn der Wert der Gemessenen Zonenbreite größer ist als Wert Toleranzzone + Bonus.

    • Ein Bonus wird vielleicht hinzugefügt, wenn Sie einenMMC oder LMC Materialmodifizierer verwenden.
  5. Klicken Sie auf Drucken, wenn Sie die Information drucken wollen, die unmittelbar auf dem Ergebnisvorschaubildschirm angezeigt werden.
  6. Wenn Sie Folgendes tun wollen:
    • Zum Hinzufügen der GD&T-Messung als ein Element in der Prüfvorgang, klicken Sie auf Beenden.
    • die Details der Form-/Lagetoleranz-Messung vor dem Hinzufügen in Prüfvorgang zu ändern, klicken Sie <Zurück, um erneut vorherige Darstellungen des Form-/Lagetoleranz-Assistenten anzuschauen.
    • Für das Abbrechen der GD&T-Messung, klicken Sie auf Abbrechen.

Wenn eine GD&T-Messung ersteinmal in Prüfvorgang hinzugefügt wurde, können Sie die Details mittels derRegisterkarte Information ansehen.


Dateien von einer Catia Export Datei extrahieren

PowerINSPECT 4.3 führt eine integrierte Stütze für die Catia Exportdateien ein (.exp). Diese Dateien setzen ein Archivformat ein, welches eine oder mehrere Catia CAD (.fic-Dateien enthalten kann, welche vielleicht oder vielleicht nicht verbunden sind.

PowerINSPECT ermöglicht Ihnen nun, individuelle CAD-Dateien (.fic) von einer Exportdatei (.exp) zu extrahieren.

Verwenden Sie die Menüoption Werkzeuge - Dateien extrahieren aus Catia EXPORT-Datei, um auf diese Eigenschaft zuzugreifen.

In diesem Abschnitt

Werkzeuge - Dateien extrahieren aus Catia EXPORT-Datei


Werkzeuge - Dateien extrahieren aus Catia EXPORT-Datei

Benutzen Sie diese Option, um individuelle .fic-Dateien von Catia Export-Datien (.exp) zu extrahieren.

  • Eine Catia-Export-Datei ist ein einzelnes Archiv, das eine Reihe von *.fic-Dateien enthält. Das Konzept ist ähnlich zu dem eines ZIP- oder TAR-Archivs.

Die Daten wie folgt exportieren:

  1. Wählen Sie Dateien extrahieren aus Catia EXPORT-Datei vom Menü Werkzeuge in PowerINSPECT, um das nachfolgende Formular anzuzeigen:

  2. Suchen Sie die .exp Datei, woraus die individuellen .fic- Dateien extrahiert werden, wählen Sie sie und klicken Sie auf Öffnen.

    Die individuellen .fic-Dateien werden in einen Unterordner an der selben Stelle extrahiert, wie die .exp-Datei. Der Name des Unterordners ist der Name der .exp-Datei mit der Endung .exp, ausgetauscht durch .dir:

    Sie können jetzt die *.fic-Dateien in PowerINSPECT als CAD-Dateien laden.

    • Wenn die Exportdatei diverse .fic-Dateien mit dem selben Namen enthält, wird eine Tilde (~), gefolgt von einer Ganzzahl, eingefügt, um den Namen einmalig zu machen. Wenn es beispielsweise drei .fic-Dateien gibt, die in der Exportdatei Achsen genannt werden, werden drei Dateien erstellt: axis.fic, axis~2.fic und axis~3.fic.
    • Wenn aus beliebigen Gründen kein gültiger Dateiname vom Name/der Beschreibung in der Exportdatei erstellt werden kann, wird die .fic-Datei .ficN genannt, wobei N eine Ganzzahl ist, die bei Null startet für die erste .fic-Datei in der Exportdatei, und wird dann erhöht für jede zusätzliche .fic-Datei. Wenn es drei .fic-Dateien in der Exportdatei gibt, werden drei Dateien daraus, die fic0, fic1 und fic2 heißen.
    • Wenn beliebige der Zeichen " * / < > ? \ |, eine horizontale Registerkarte oder beliebige undruckbare Zeichen, die in einem .fic-Dateinamen/-beschreibung auftreten, dann werden sie durch einen Unterstrich (_) ersetzt.


Eigenschaft der Schnittpunkte berechnen

Eine neue Option Nutzen unbegrenzter Elemente wurde dem Formular Punkt am Schnittpunkt von Merkmalen hinzugefügt. Wenn diese Option gewählt ist (was standardgemäß der Fall ist), dann werden Merkmalsachsen nach Bedarf über physische Elementgrenzlinien erweitert, um Merkmal-Schnittpunkte zu berechnen.

In diesem Abschnitt

Punkt am Schnittpunkt von Merkmalen


Punkt am Schnittpunkt von Merkmalen

Die Eigenschaft Punkt am Schnittpunkt von Merkmalen erlaubt Ihnen, einen Punkt zu erstellen, wo die Achsen eines Merkmals sich mit Achsen eines anderen Merkmals schneiden. Die zwei Merkmale müssen bereits als Teil der Geometriegruppe erstellt sein. Sie müssen eine Referenzlinie (die Achsen eines Merkmals) und ein Referenzmerkmal (ein zweites Merkmale oder eine Achsen, die durch eine spezifische Referenzlinie geschnitten wird) spezifizieren.

Mit einer geöffneten Geometriegruppe, klickenSie auf die Symbolleiste Punkte und klicken Sie Linked PowerINSPECT Graphics Directory Template. Das Formular Punkt am Schnittpunkt von Merkmalen wird angezeigt:

  • Die Formularwerte werden immer dem Standard des vorherigen Punkts angeglichen und so können Sie vielleicht die 0,0,0 Werte wie oben gezeigt nicht sehen.

Dieses Formular ist in folgende Bereiche unterteilt:

  • Name – zeigt den automatisch gegebenen Namen dieses Punkts an. Sie können dies ändern, wenn Sie wollen.
  • Koord. System – Diese Auswahlliste zeigt eine Liste von verfügbaren Bezugspunkten und Ausrichtungen für den Punkt an. Um den Bezugspunkt auszuwählen, den Sie für den Punkt verwenden wollen, klicken Sie auf dessen Namen. PowerINSPECT nutzt PCS (Part Coordinate System) als dessen Standardbezugspunkt.
  • Nutzen unbegrenzter Elemente – Wenn diese Box ausgewählt ist (dessen Standardeinstellung), dann wird PowerINSPECT die Achsen nach Bedarf über die vereinten Elementgrenzlinien intern erweitern, bis es möglich ist, den Schnittpunkt zu erstellen, wenn dieser nicht geradewegs berechnet werden kann. Wenn Sie zu der Situation zurückkehren möchten, wo Schnittpunkte zu begrenzten Elementen eingeschränkt sind, wählen Sie die Box ab.
  • Referenzlinie – Diese Auswahlliste zeigt eine Liste von möglichen Achsen an, welche die Referenzlinie schneiden können. Wählen Sie die benötigten Achsen.
  • Referenzmerkmal – Diese Auswahlliste zeigt eine Liste von möglichen Merkmalen an, welche die Referenzlinie schneiden können. Wählen Sie die benötigte Eigenschaft.
    • Als Alternative zur Verwendung von Auswahllisten, können Sie entweder die Referenzlinie oder das Referenz 3D-Element unter Verwendung der Maus und Klicken auf das Symbol [image] rechts der Liste wählen.
  • Sollwert Einstellung – Darauf klicken erlaubt Ihnen, die vorherigen Sollwerte mit den aktuellen Sollwerten des vorgeschlagenen Punkts des CAD Elements oder von der Aktiven Messung zu überschreiben:

    • Wenn Sie aus dem CAD-Element wählen, berechnet PowerINSPECT die Sollwerte im Formular neu mittels Aufnahme der aktuellen Werte als Startpunkt und ändert diese in die Werte des nähesten Schnittpunkts zwischen der Referenzlinie und dem Referenzmerkmal.
  • Punkt – Zeigt die Werte des Sollwerts, der erstellt wird.
  • Die Toleranzwerte können für die Absichten dieser Option ignoriert werden.
  • Wenn Sie eine Achsen und ein Merkmal wählen, wo zwei oder mehr Schnittpunkte entlang der Achsen erstellt werden können, dann können Sie manuell einen Sollwert eingeben, der annäherungsweise zu den erwarteten Koordinate ist, sodass PowerINSPECT zu der Berechnung der bevorzugten Alternative geführt werden kann. (Bezug nehmend auf die Beispiele darunter).
  • Wenn der Punkt noch ungemessen ist, dann und obwohl der Sollwertpunkt als Punkt spezifiziert bleiben wird, wird der tatsächliche Schnittpunkt zurückberechnet, wenn die Merkmale, angezeigt durch Referenzlinie und Referenzmerkmal, gemessen wurden.

Wenn Sie auf OK klicken, erstellt PowerINSPECT den Punkt, der durch die Sollwerte angezeigt wird und schließt das Formular. Wenn Sie auf OK & Wiederh. klicken, erstellt PowerINSPECT den Punkt, der durch Sollwerte angezeigt wird,erstellt die Werte für einen zusätzlichen Punkt, basierend auf dem gerade erstellten Punkt und lässt das Formular geöffnet, damit Sie in beliebige Werte zusätzlicher Punkte modifizieren können. Wenn Sie auf Zuweisen klicken, erstellt PowerINSPECT den Punkt, der durch den Sollwert angezeigt wird und lässt das Formular geöffnet.

  • Die Schaltfläche Zuweisen ist nicht länger verfügbar, wenn Sie die Einstellung Sollwert nutzen, da dies den Effekt hat, den Punkt unmittelbar zu erstellen.

Beispiele

Ein Punkt wird am Schnittpunkt von zwei zylindrischen Merkmalen erstellt:

Wenn Sie das Formular Punkt am Schnittpunkt von Merkmalenanzeigen und Sie die zwei Merkmale, die im Formular zu Besginn des Themas gezeigt wurden auswählen und dann aus CAD-Element wählen werden die Sollwerte zurückberechnet wie der Schnittpunkt der zwei Merkmale, der näher dem vorherigen Werte 0,0,0 ist:

Wie Sie in der Ansicht von oben sehen können, gibt es mehr als einen möglichen Merkmalsschnittpunkt an dem Punkt 1 erstellt worden sein könnte:

Wenn Sie einen weiteren Punkt erstellen, können Sie sich versichern, dass er auf der entgegengesetzt Fläche von Zylinder 4 entlang der X-Achse verläuft, indem Sie einen Annäherungs-X-Wert eingeben (negativ), um den zeitweiligen Aufenthaltsort des X-Sollwerts des nächsten Punkts anzuzeigen.

Wenn Sie aus CAD-Element wählen, werden die Sollwerte wie folgt zurückberechnet:

Punkt 2 ist auf der entgegengesetzten Fläche von Zylinder 4 entlang der X-Achse erstellt worden:

  • Der nächste Punkte, den Sie erstellen, wird zu den vorherigen Werten standardisiert, sodass Sie die Sollwerte nach Bedarf einstellen und dann vom CAD-Element oder aus einer aktiven Messung erneut auswählen müssen.


Punktewolkedaten exportieren

Die nachfolgenden Erweiterungen wurden auf die Art und Weise gemacht, wie Sie Punktewolken von PowerINSPECT exportieren:

  • Wenn Sie Punktewolkedaten exportieren, können Sie nun exportieren:
    • Gewählte Punkte, von einer oder mehreren Punktewolken, welcher Sie von der Registerkarte CAD-Ansicht gewählt haben; und
    • alle Punkte von einer ausgewählten Punktewolke.
  • Wenn Sie Punktewolkedaten zu einer ASCII-Datei exportieren, können Sie spezifizieren, dass beliebige Kombinationen der nachfolgenden Details exportiert werden:
    • Originale Position;
    • Originaler Vektor;
    • Geplante Position;
    • Geplanter Vektor (Flächenormale); und
    • Abweichung.

Diese Erweiterungen bedeuten, dass es jetzt eine neue Prozedur zum exportieren von Punktewolkedaten gibt.

In diesem Abschnitt

Punktewolkedaten exportieren: neue Prozedur


Punktewolkedaten exportieren: neue Prozedur

  1. Wählen Sie die Punktewolkedaten, die Sie exportieren wollen. Um zu exportieren:
    • eine ganze Punktewolke, wählen Sie die Punktewolke aus der Prüfvorgang, rechtsklicken und wählen Sie anschließend Punktwolke exportieren aus dem Kontextmenü.
    • gewählte Punkte von einer oder mehreren Punktewolken, nutzen Sie die Schaltfläche Auswahl für Aufnahme von der Symbolleiste Ändern von Punktewolken, um die Punktauswahl, angezeigt in CAD-Ansicht auszuwählen, dann die Menüoption Werkzeuge - Punktewolke - Export Punktewolke wählen oder, klicken Sie die Schaltfläche Punktewolke exportieren auf der Symbolleiste Ändern von Punktewolken:

      Linked PowerINSPECT Graphics Directory Template

      PowerINSPECT zeigt das Formular Punktewolke exportieren an:

  2. Wählen Sie das Format, in welchem Sie die Punktewolke-Details von der Auswahlliste Datenformat exportieren wolen. Sie können wählen von:
    • ASCII-Datei (*.asc)
    • Perceptron XML (*.xml)
    • Perceptron BIN (*.bin)
    • ScanWorks SWL (*.swl)
  3. Spezifizieren Sie das Koordinatensystem, welches Sie zum Exportieren von Punktewolken-Details nutzen wollen durch das Auswählen der CAD Koordinaten- oder KMM-Koordinaten-Option.
  4. Spezifizieren Sie die Daten über jeden Punkt, den Sie exportieren wollen. Sie können beliebige Kombinationen wählen:
    • Original Position - Die X-, Y- und Z-Werte eines Punkts.
    • Originaler Vektor - Die I-, J- und K-Werte eines Punkts.
    • Geplante Position - Die X-, Y- und Z-Werte eines Punkts, wenn auf eine Fläche des CAD-Modells projiziert.
    • Geplanter Vektor - Die I-, J- und K-Werte eines Punkts, wenn auf eine Fläche des CAD-Modells projiziert.
    • Abweichung - Die Differenz zwischen einem Punkt in der Punktewolke und wenn er auf die Fläche des CAD-Modells projiziert wird.

      Klicken Sie auf OK. PowerINSPECT zeigt das Formular Speichern unter an:

  5. Spezifizieren Sie den Ordner und den Dateiname, in und unter welchem Sie die Daten auf dem Formular Speichern unter exportieren wollen und klicken Sie auf OK. PowerINSPECT exportiert die Daten und zeigt eine Bestätigungsmeldung, wenn der Export vollendet wurde.


Extrainformationen auf der Registerkarte Punktewolke

Die angezeigte Information im Bereich Stastistik der Registerkarte Punktewolke wurde erweitert, um die Anzahl der Punkte innerhalb der Toleranz ebenso anzuzeigen, wie die Anzahl der Punkte oberhalb und unterhalb der Toleranz. Zum Beispiel:

Der Druckvorschau-Bildschirm der Registerkarte Punktewolke ist auch erweitert, um folgendes anzuzeigen:

  • Details der Anzahl der Punkte innerhalb der Toleranz.
  • die oberen und untere Toleranzwerte.

Zum Beispiel:


AIMS-Integration

PowerINSPECT 4.3 kann einen nahtlosen Übergang zwischen PowerINSPECT und AIMS (Advanced Integrated Mathematical System) ermöglichen. Zum Beispiel:

  1. Importiert eine AIMS-Ausgabe-Datei (TDF) in eine PowerINSPECT PWI-Datei.

    Während des Imports liest PowerINSPECT die Information der AIMS-Ausgabedatei und nutzt die Information zur automatischen Erstellung der CAD-Ansicht und Prüfvorgang - Zum Beispiel:

    • Eine TDF Betrachteroption ermöglicht Ihnen auch, Information, die in der TDF-Datei innerhalb von PowerINSPECT vor dem Importieren kommt, anzuschauen.
  2. Misst die Elemente in der Prüfvorgang, wie Sie es normalerweise mit PowerINSPECT tun würden. Wenn Sie die PowerINSPECT (PWI) Datei speichern, speichert PowerINSPECT automatisch die Messresultate in der AIMS Ausgabe-Datei, die Sie importierten in Schritt 1.
  • Das AIMS-Integrations-Merkmal ist nur verfügbar, wenn Sie die benötigten Lizenzen erwerben. Für weitere Details kontaktieren Sie bitte Ihren Verkäufer.


Neue Schaltfläche Geführter Flächenpunkt

Die Schaltfläche Geführter Flächenpunkt oben in der Element-Symbolleiste der Flächenprüfung hat sich von [image] in Linked PowerINSPECT Graphics Directory Template geändert, um beliebige mögliche Verwechslungen mit der Schaltfläche Flächenauswahl [image] auf der Symbolleiste Maus-Kontext zu vermeiden.

Die Element-Symbolleiste der Flächenprüfung erscheint nun wie folgt:

Linked PowerINSPECT Graphics Directory Template


Vorschaumöglichkeiten

Vorschaumöglichkeiten werden angeboten, um die neun Funktionalität in der Entwicklungsvorstufe zu liefern, sodass Sie die deren Funktionalität abschätzen können. Häufig bieten diese Konstruktionselemente neue und erweiterte Funktionalitäten, die von Benutzern verlangt wurden.

Die folgenden Merkmale sind in PowerINSPECT 4.3 als Vorschau verfügbar:

  • Die Möglichkeit, benutzerdefinierte HTML Berichtsvorlagen mit einem Vorlageneditor zu erstellen.

Vorschaumöglichkeiten sind im Programm platziert worden, damit Sie experimentieren können. Sie haben eine minimale Anwenderschnittstelle und könnten unvollständig oder unbequem zu nutzen sein.

Vorschaufunktionen sind dafür bestimmt, Ihnen einen Einblick in unsere Entwicklungsrichtung zu geben. Wir begrüssen konstruktive Kommentare, wie wir die Funktionalität erweitern und die Anwenderschnittstelle darstellen können. Bitte geben Sie über Ihren PowerINSPECT-Verkäufer eine Rückmeldung ab.

Vorschaumöglichkeiten stehen unter fortlaufender Entwicklung: deren Vehalten hat sich vielleicht geändert seit dieses Dokument geschrieben wurde.

In diesem Abschnitt

HTML Berichtsvorlagen anpassen


HTML Berichtsvorlagen anpassen

Eine HTML Berichtvorlage kontroliert, welche Informationen einbezogen wird in beliebigen Berichten, basierend auf dieser Vorlage und wie diese Informationen präsentiert wird. Obwohl Standard HTML-Berichtvorlagen von PowerINSPECT unterstützt werden, finden Unternehmen oft heraus, dass Sie die Standardvorlagen dem Kunden angepassen müssen - Zum Beispiel:

  • Bilder wie beispielsweise Firmenlogos hinzuzufügen oder zu ändern.
  • die in den Bericht einbezogenen Informationen zu ändern.
  • den Stil und die Formatierung des Berichts zu ändern, beispielsweise Schriftarten oder Farben, um die Firmenstandards wiederzugeben.

PowerINSPECT 4.3 enthält ein eigenständiges Programm zum Ändern von HTML Berichtsvorlagen, so dass Sie diese (und andere) Änderungen an den HTML Berichtsvorlagen vornehmen können.

Der HTML-Berichtvorlage-Editor ist ein einzelnes Programm, das während der PowerINSPECT-Installation installiert wird. Das Programm ist über das PowerINSPECT Untermenü im Windows Startmenü verfügbar.

  • Der HTML-Berichtvorlagen-Editor benötigt eine Installation des Microsoft.NET Framework v1.1-Pakets auf Ihrem Computer. Dieses Paket kann von der Microsoft-Internetseite heruntergeladen werden. Ein Link zu der relevanten Microsoft Internetseite wird in den in PowerINSPECT verfügbaren Optionen aus dem Windows Startmenü miteinbezogen.

Haben Sie den Editor für HTML Berichtsvorlagen einmal gestartet, können Sie weitere Informationen über das Programm mittels der Menüoption Hilfe - Inhalt erhalten, welche die Hilfe startet.


Neue Funktionen in

PowerINSPECT 4.3

von Delcam plc

Veröffentlicht: 06/03/2007