PowerINSPECT 1300 Installation Problems and 'PWI System Update'

PWI000039

Context

this document applies to :

  1. PowerINSPECT 1300
  2. CMMDriver 2401
  3. CMMDriver 2402
Gripe no 434

Summary

PowerINSPECT 1300 did not install on a very small number of specific PCs.   Reinstalling PowerINSPECT did not fix the problem because the operating systems had missing or out of date needed files.  A new utility 'PWI System Update' has been written as a solution.  'PWI System Update'

1 checks for all of the required files and

2 can update them if necessary.

This installation problem has been fixed on PowerINSPECT 1350 and later by changing the installation scheme.

Description

PowerINSPECT fails to install with the following message:

Doctor Watson for Windows NT.
_INS576._MP.exe: This program has performed an illegal operation and will
be shut down. If the problem persists, contact the program vendor.

This message is most likely to occur almost at the end of the installation process, when the 'files copied' status is at 100%.  It may be shown for PowerINSPECT or CMMDriver.

PowerINSPECT will not run because the installation has failed.

If you then attempt to reinstall PowerINSPECT 1300 on top of the failed installation, the installation will fail again with one of the following messages:

Deinstaller failed.

TargetDir=c:\dcam\product\PowerInspect 1300. Log file =PowerInspect 1300 isu

This message is likely to occur at the beginning of the installation process if you try to install PowerINSPECT after one failed installation. It may occur for PowerINSPECT or CMMDriver.

Warning

Uninstaller setup failed to initialize. You may not be able to uninstall this product.

This message is likely to occur if you try to install PowerINSPECT or any of the other components after one failed installation.

At the end of the installation process you will not actually be able to run PowerINSPECT.

Any of these messages may occur for CMM Driver as well as for PowerINSPECT

Problem cause

PowerINSPECT has minimum version requirements for a number of key files, detailed in Technical Note PWI000038.

These requirements should normally be met if you use the recommended operating system (Windows 98 or Windows NT version 4.0, Service Pack 5 or higher) in combination with the recommended version of Internet Explorer (version 5).

Attempting to reinstall PowerINSPECT 1300 will not fix the problem because this will not update the necessary files.

Solution

Recovery of the installation process from this state should be carried out as follows. 

Back up any needed information from the PowerINSPECT 1300 installation.  (If you have been unable to run PowerINSPECT 1300 there is unlikely to be much information to back up, unless you have already constructed Excel templates, added Protocol files or similar.)

Delete CMMDriver2401.isu.  This is usually found in c:\dcam\product\CMMDriver2401 but the location depends on how you have installed it.  You should also delete the whole CMMDriver2401 and PowerINSPECT1300 folders.

(NOTE- if you have used an intermediate beta version, the CMMDriver version number may be 2402, and the PowerINSPECT version may be 1310 or 1320.)

The next stage involves using 'PWI System Update.'  This is a new application which checks for acceptable minimum versions of the needed files.   It is listed as setup.exe in the PWISystemUpdate directory on the 1350 CD.

At this point you may use 'PWI System Update' to run the Optional Diagnostic Test described below.

The PowerINSPECT installation failed because some required system files are missing.   Use 'PWI System Update' to upgrade these files.  You can do this by running PowerINSPECTSystemUpdate\setup.exe off the CD from Windows.

This will update your system files to meet the requirements for PowerINSPECT.   Missing files will be added, and out-of-date files will be replaced.

Finally install PowerINSPECT from the CD.

 

Optional Diagnostic Test

Run the 'PWI System Update' application in a DOS box or command line window.  Change to the directory on the CD with the PWISystemUpdate folder and then run setup in CHECK mode with the command 'setup CHECK.'  The example below assumes that D is the CD drive.

C:/>d:

D:\>cd PWISystemUpdate

D:\PWISystemUpdate>setup CHECK

This runs the 'PWI System Update' utility which checks for acceptable minimum versions of the required files.  A report will appear in a window.  This report is saved in two places, both in the dcam\config\temp directory:

1    Check.log, a temporary file which shows the latest update details

2    PowerINSPECTSystemUpdate.log, a file which records all update details from every time 'PWI System Update' has been run (the latest information is appended)

The start of the check.log file will show the operating system version and other details.

PowerINSPECT System Upgrade 1.000
DATE 4-7-2000 18:46:59


Language : English
OS : WINDOWS NT
WINMAJOR : 4.0
WINMINOR : 0
Internet Explorer Version : 5.00.2314.1003

The rest of check.log reports on each required file individually.  All of the files detailed in this report should have status OK.

OLEAUT32.DLL :=> OK
( current 2.40.4275.1 : expected 2.40.4275.1 ) (2000\03\15 15:56:50 598288)

If some files are not acceptable, you can simply run setup from Windows to update those files.  This updates all of the missing or out-of-date files to acceptable versions.