FATAL ERROR:  Please Contact Delcam- Unlocking 'Clocked' dongles after date change

PWI000101

Context

this document applies to :

  1. PowerINSPECT 2200 and later

 

Summary

The PowerINSPECT Licensing mechanism includes a check for the system date, so that it is not possible to extend a demonstration licence indefinitely by changing the system date.  The symptom is that PowerINSPECT shows an error message 'Fatal error:  Please contact Delcam' rather than starting up.  When this error message is displayed, PowerINSPECT creates a file called rainbow.log which is saved in the c:\dcam\config\pass directory.  This file should be sent to Delcam.  We will generate an unlocking executable called rainbow.ans.dcamfix.  The user should run this executable on the PC with the dongle.  They will be prompted to confirm the date- if this is ok, the dongle will be unlocked.

Description

The PowerINSPECT Licensing mechanism includes a check for the system date.  Each time PowerINSPECT is run, the system date is recorded as a timestamp on the dongle.  On startup, the current system date is compared with the timestamp.  If the current system date is earlier than the timestamp, PowerINSPECT will refuse to run with the message 'FATAL ERROR:  Please Contact Delcam.'

 

Problem cause

The PowerINSPECT Licensing mechanism includes a check for the system date, so that it is not possible to extend a demonstration licence indefinitely by changing the system date.

Each time PowerINSPECT is run, the system date is recorded as a timestamp on the dongle.  On startup, the current system date is compared with the timestamp.  If the current system date is earlier than the timestamp, PowerINSPECT will refuse to run with the message 'FATAL ERROR:  Please Contact Delcam.'

This test is not inlcuded in the PafWizard or Chkpaf.  For more on PowerINSPECT dongle testing, please see http://partners.delcam.com/PowerINSPECT/PWI000096.htm.

After this problem has occurred, PowerINSPECT will not run again until either:

- Delcam provides a 'fix' for this problem (rainbow.ans or rainbow.ans.dcamfix), or
- the system date 'catches up' with the timestamp

 

Solution/Workaround

When the message 'FATAL ERROR:  Please Contact Delcam.' is generated, PowerINSPECT creates a log of the dongle number and the various dates.  This is called rainbow.log and is found in the c:\dcam\config\pass directory.

Send this to Delcam.

If the system date has been changed accidentally, we will create a fixing string called

rainbow.ans, or
rainbow.ans.dcamfix

Rainbow.ans.dcamfix can be run as a standalone executable from anywhere on the PC.  To use, double click on the executable.

Rainbow.ans should be pasted in the c:\dcam\config\pass directory.  To use it, try to start PowerINSPECT again.

In either case you will be asked to confirm the current system date and time.

 

APPENDIX

 When we run the application to unlock the dongle, we can check the dates at which the dongle was last used.