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Applicability

This procedure is applicable to the entire NCSX Project. 

Introduction

With few exceptions, all NCSX Project documents will be stored electronically.  Drawings and models will be stored on the Pro/INTRALINK database and other documentation (e.g., project Plans and procedures, specifications, analyses, memorandum, etc.) will be stored on the NCSX Engineering Web Page http://www.pppl.gov/me/NCSX_Engineering/ .

Since almost all of the NCSX Project files will be electronic in nature, it is appropriate to utilize an electronic review and signature process.  The NCSX Project has adopted the Digital Signature Process and Security embodied in Adobe Acrobat.  In order to ensure consistency across the NCSX Project, Adobe Acrobat 5.0 (or later) version is required.  In Adobe Acrobat, this is called the “Acrobat Self-Sign Security.’  The Adobe Acrobat system permits personnel required to sign documents to create their own secure electronic signature (via password protection), permit authentication of the electronic signatures, and permit casual users to also view completed documents with the full signatures visible.  Inherent in all these tasks is the requirement that all users (whether personnel signing documents or casual viewers) establish their own User Attribute profile.  This profile will permit personnel to set up their own protected electronic signature or permit the casual user to verify all the signatures.  Without the unique User Attribute, the electronic signature process will not work correctly. 
Once electronically signed, the document (be it drawing or other project document) is frozen and additional changes precluded.  The signed document will then be posted in the appropriate electronic project files. Changes to approved documents are then processed in accordance with the NCSX Configuration Management Plan.

Referenced Documents

	NCSX-PLAN-PEP
	NCSX Project Execution Plan

	NCSX-PLAN-SEMP
	NCSX Systems Engineering Plan

	NCTX-PLAN-CMP
	NCSX Configuration Management Plan

	PPPL ES-DRFT-002
	PPPL Pro/INTRALINK Users Guide


Procedure

There are two distinct, albeit similar, tracks for signing drawings and models and for signing other project documents.  This procedure consists of five sections:

A. Establishing a User Attribute and Electronic User Signature Profile

B. Verifying Signatures

C. Setting up the signature blocks for a document and/or drawing

D. Signing drawings and models

E. Signing other project documents

F. Obtaining copies of approved documents

A. Establishing a User Attribute and Electronic User Signature Profile

The key element for electronic signature is for each user/person signing documents establish his or her own unique password-protected User Attribute and signature file (if the person is required to sign documents) or certificate that can only be accessed by the user.  This need only be accomplished once.  Once the User Attribute (and electronic signature if needed) is accomplished, the processes of signing a document or verifying other signatures are reasonably straightforward.
Attachment 1 to this procedure provides a visual step-by-step representation of this process. 

	Responsibility
	Action



	User 
	1.
Open Adobe Acrobat 5.0 (or later version) and select Tool Menu => Self-Sign Security => Log In

	
	2. When Self-Sign Security – Log In dialogue box opens, select New User Profile

	
	3. When Create New User Profile dialogue box opens, fill in the User Attributes:

· Name (Required)

· Organization Name (Optional)

· Organization Unit (Optional)

· Profile File => select unique password and confirm that password)

	
	4. Close Create New User dialogue box by clicking “OK”.  If only created to view and verify electronically signed documents/drawings, this completes the necessary steps.  If need to also create an electronic signature, continue to Step A5 below.


	
	5. Electronically scans signature into a word file and then crop (using the Picture toolbar cropping tool) to maximize size.  Save this as a PDF file and store in a convenient place on your computer.  Choices for the NCSX Project are:

· Full Name “signature” for signing most documents or drawings.

· Initials “signature” for signing documents with only limited space availability.

	
	6. After User Attribute file established, select Tool Menu again => Self-Sign Security => User Settings

	
	7. When Self-Sign Security – User Settings for XXXX (name of user) appears, select “Signature Appearance” and “New” button. 

	
	8. When “Configure Signature Appearance” dialogue box appears, name the title of the signature (e.g., Full Name, Initials, etc.) in the Title section and then in the “Configure Graphic” section, select “Imported Graphic” and select PDF File button. 

	
	9. Once “Select Picture” dialogue box opens, browse until desired pdf signature representation appears and then select “OK”.  This will visibly make your electronic signature appear in the signature block.

	
	10. In the “Configure Text” section, select the appropriate “show” options.  It is recommended that only the “Date” block be selected to preclude too much detail on the electronic signature.

	
	11. Select “OK” to close the “Configure Signature Appearance” dialogue box.  Your electronic signature is now established. 

	
	12. If other specific signature appearances are required (e.g., initials), repeat steps A7 through A11 until all desired electronic signature options are determined.


B. Verifying Signatures

When a document is forwarded for signature and that person wants to verify the signatures before signing, or it a casual user desires to verify signatures in order to remove the electronic question mark (?), the person must first ensure that they have an electronic User Attribute established in accordance with the procedure outlined in Section A previously.

The person approving the document is required to verify all the previous signatures before signing.  Other users have the option to either accept that this verification occurred before the document was approved or, at their option, may also verify the signatures.

Each time the document is opened once posted, all the electronic signatures will appear, albeit with a question mark (?) that indicates that the signatures on the opened document have not been re-verified.  Since the person approving the document is required to verify all the previous signatures before signing, anyone opening the document can assume that the approving official has verified the signatures before approving the document.  Nonetheless, at their option, users may also verify the signatures, although it is not required.  This section outlines the process for verifying signatures. 

Attachment 2 to this procedure provides a visual step-by-step representation of this process. 

	Responsibility
	Action



	Approving Official or User 
	1.
Open the document using Adobe Acrobat 5.0 (or later version) and Log In using the procedures in Section A.  When document is open, all signatures will have a question mark (?) appearing.  The Approving Official must then verify all signatures.  Other users have the option to verify signatures or to accept that all signatures were verified before the document was approved.

	
	2. To verify a signature for the first time, right click the signature box that is to be verified.  If the all the signatures had been previously verified and added to “Your Trusted Certificates” section in the Users Profile, proceed to step #9 below

	
	3. When the dialogue box appears, select “Verify Signature”

	
	4. When the Self-Sign Security-Validation Status” dialogue box appears, select “Verify Identity”

	
	5. When the “Verify Signature” dialogue box appears, select “Add to List”

	
	6. When the Self-Security – Alert” dialogue box, a message indicating, “Certificate for XXXXXX has been successfully added to your list of ‘Trusted Certificates’.  

	
	7. When you check “OK”, the “Self-Sign Security – Validation Status” dialogue box will appear with the message, “Signature is Valid”.  Check “Close” and the question mark (?) will change to a check mark (√).

	
	8. When the “Digital Signature – Alert” dialogue box appears, select.”OK”. this will change the question marks (?) to checks (√) once the signatures are verified.  Since the certificates are embedded in the signatures, there is no need to have the certificates on the user’s computer.

	
	9. Select Tool Menu => Digital Signature.  When the adjacent dialogue box opens, select “Verify All Signatures”.

	
	10. The :”Digital Signature –Alert” dialogue box will then change to show “Verification Complete” – check “OK” to complete the verification process.


C. Setting Up The Signature Blocks For A Document And/Or Drawing
The person that who originates the document (either drawing or other document) is responsible for setting up the initial document security for that document and for establishing the signature field for each required signature.

Attachment 3 to this procedure provides a visual step-by-step representation of this process.

	Responsibility
	Action



	Originator of the Document 
	1.
Saves the document in PDF format.

	
	2. Under the File Menu, select “Document Security.” 

	
	3. When the “Document Security” dialogue box appears, select.”Acrobat Standard Security”. 

	
	4. When the “Standard Security” dialogue box appears:

· Check the “Password Required to Change Permissions and Passwords” in the “Specify Password” section and enter “NCSX” as the password.

· In the “Permissions” section, select 128-bit RC4 (Acrobat 5.0) Encryption Level and check both blocks:

· “Enable content Access for the visually Impaired”

· “Allow Content Copying and Extraction”

· In the “Changes Allowed” section, select:

· For a drawing, “Comment Authoring, Form Field Fill-In or Signing

· For all other documents, “Only Form Field Fill-In or Signing”

· In the “Printing” section, ensure that “Fully Allowed” appears 

· Check “OK” when completed with the above

	
	5. When “Password dialogue box appears, retype in “NCSX” as the password

	
	6. Click the Form Tool icon to activate it

	
	7. Drag the cross hair over the area where the signature will be placed

	
	8. When the “Field Properties” dialogue box appears:

· Type in the Name of the person to sign the document

· In the “Type” block, ensure that “Signature” is selected

· In the “Short Description” section, enter “Prepared by, Reviewed by, or Approved by” or other appropriate descriptor of the action indicated by the signature

· Unless otherwise desired, leave “Border” section at the default settings

· In the “Text” section, select the desired font color and type 

· Unless otherwise desired, leave “Common Properties” section at the default setting

· Select “OK” when the above settings are selected.

	
	9. Repeat step C8 as many times as necessary for the number of signatures desired.

	
	10. Save the document.


D. Signing Drawings And Models

Drawings and models prepared electronically have a slightly more different sign-off process than other NCSX documents in that the final signature will be by the PPPL Drafting Supervisor who then signs and places a “Released for Fabrication”, “Pending ECN XXXX”, or “NCR-XXX” stamp on the drawing. The originator of the document will be the first person to sign the document.

Attachment 4 to this procedure provides a visual step-by-step representation of this process.

	Responsibility
	Action



	Originator of the Document 
	1.
Log-In in accordance with the procedures of Section A of this procedure.

	
	2. Opens document in PDF format.

	
	3. If not already done, establishes the document security and signature blocks in accordance with the procedures of Section C of this procedure. 

	
	4. To sign the document, activate the “Hand” icon by clicking it and then right click on his signature area field.

	
	5. When the “Self-Sign Security – Sign Document” dialogue box appears:

· Type in the user’s password in the “Confirm Password” section

· Select or edit reason for signing in the “Reason for Signing Document” section

· At the option of the user, fill in the “Location” and “Contact Information”

· Select the name of the signature determined in procedure step A8 in the “Signature Appearance” section or edit the signature appearance per procedure step A8

· Check “Save” when completed with the above and the signature will appear with a check mark (√).

	
	6. The “Self-Sign Security – Validation Status” will appear indicating that the “Signature is Valid”  

	
	7. Save document and forwards document electronically in PDF format

	Subsequent Signers
	8. Open document and verify previous signatures (if desired) in accordance with Section B of this procedure. 

	
	9. Repeat steps D1 though D6 

	
	10. Repeat step D7 until the PPPL Drafting Supervisor is next signer.  When the PPPL Drafting Supervisor is the next signer, proceed to step D11.

	PPPL Drafting Supervisor
	11. Open document and verify previous signatures (REQUIRED) in accordance with Section B of this procedure.

	
	12. If document is satisfactory, sign document in accordance with steps D1 through D6.

	
	13. Activate the “Stamp” icon and move icon of stamp to the desired location.  Left click mouse (three button mouse) to set the stamp location.


	
	14. Size the stamp top the proper size by dragging the stamp corners.

	
	15. Move the stamp icon over the stamp and right click the mouse button.

	
	16. When the “Stamp Properties” dialogue box appears, select the proper stamp message.  Note: After the stamp is placed a “Document was Modified” warning is set in the Signature Area.” warning is set in the Signature Area.

	
	17. Save fully signed drawing and place in the appropriate NCSX Pro/INTRALINK database “001_Released_Drawing_PDF_Format” folder in accordance with PPPL ES-DRFT-002.


E. Signing Other Project Documents

Signing other project documents (e.g., Plans, Procedures, etc.) is very similar to the steps outlined in Section D above. 

Attachment 5 to this procedure provides a visual step-by-step representation of this process.

	Responsibility
	Action



	Originator of the Document 
	1.
Log-In in accordance with the procedures of Section A of this procedure.

	
	2. Opens document in PDF format.

	
	3. If not already done, establishes the document security and signature blocks in accordance with the procedures of Section C of this procedure. 

	
	4. To sign the document, activate the “Hand” icon by clicking it and then right click on his signature area field.

	
	5. When the “Self-Sign Security – Sign Document” dialogue box appears:

· Type in the user’s password in the “Confirm Password” section

· Select or edit reason for signing in the “Reason for Signing Document” section

· At the option of the user, fill in the “Location” and “Contact Information”

· Select the name of the signature determined in procedure step A8 in the “Signature Appearance” section or edit the signature appearance per procedure step A8

· Check “Save” when completed with the above and the signature will appear with a check mark (√).

	
	6. The “Self-Sign Security – Validation Status” will appear indicating that the “Signature is Valid”  

	
	7. Save document and forwards document electronically in PDF format

	Subsequent Signers
	8. Open document and verify previous signatures (if desired) in accordance with Section B of this procedure. 

	
	9. Repeat steps D1 though D6 


	
	10. Repeat step D7 until the Approving Official is next signer.  When the Approving Official is the next signer, proceed to step D11.

	Approving Official
	11. Open document and verify previous signatures (REQUIRED) in accordance with Section B of this procedure.

	
	12. If document is satisfactory, sign document in accordance with steps D1 through D6.

	
	13. Forward approved document to the NCSX Engineering Project Web custodian for filing.

	NCSX Project Engineering Web Custodian
	14. File the Approved document in PDF format on the NCSX Engineering Web page < http://www.pppl.gov/me/NCSX_Engineering/ > in the format indicated in the NCSX Data Management Plan (NCSX-PLAN-DMP).

	 
	15. Obtain original media version (Word, etc.) from the originator and files this copy in the NCSX Engineering Web page folder in this format as indicated in the NCSX Data Management Plan (NCSX-PLAN-DMP).


F. Obtaining Copies Of Approved Documents

Approved documents will be posted on either the Pro/INTRALINK database for electronic drawings and models or on the NCSX Engineering Web Page < http://www.pppl.gov/me/NCSX_Engineering/ > for all other project documents.  Accessing these project files is relatively straightforward and will not be covered here.  However, it is an anomaly of the Adobe Acrobat Digital Signature Process and Security System that the signatures of all approved documents will contain a question mark (?).  Section B of this procedure outlines the steps to validate the signatures if so desired.  However, it the responsibility of the approving official to verify the signatures before signing the document.

Attachments

Attachment 1:
Establishing A User Attribute And Electronic User Signature Profile

Attachment 2:
Verifying Signatures

Attachment 3:
Setting Up The Signature Blocks For A Document And/Or Drawing

Attachment 4:
Signing Drawings And Models

Attachment 5:
Signing Other Project Documents
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Drafting Supervisor Must First Validate all Previous Signatures
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To Compare Signed Version to Earlier Unsigned Version






















Choose Tools => Self-Sign Security => Login


New User Profile =>   Then fill in the User Attributes.








Signature can be expanded to show details.











The signature area shows date and time signed, the person’s signature and a check indicating it is a valid signature.











Choose Tools => Self-Sign Security => User Settings


Security Appearance => Signature 


Then => Edit to modify appearance.  Use Imported graphic to bring a pre-setup PDF file of your signature.











When the key symbol is activated you can select “show Signatures” which provides signing details.











Signature can be expanded to show details.





The signature area shows date and time signed, the person’s signature and a check indicating it is a valid signature.








Right click signature block


Select “Verify Signature”





Select “Verify Signature”





Select “Add to List”





Check “OK”





Once the signature is added to the ‘Trusted Certificate’ list, it need not be added again (unless deleted on purpose.


Note that signature changes to a check mark (√)


Note:  Approving Official must verify all previous signatures prior to signing.





When a document is selected, Signature Blocks will Contain Question Marks (“?”) 


Under Tools Menu, select “Digit Signatures”


When another dialogue box appears, select “Verify All Signatures”

















Select “Verify All Signatures”





When Digital Signature – Alert dialogue box appears, select OK to start verification process 


























Select “Tools” and then “Self-Sign Security”


Select “Users Settings”


Select “Trusted Certificates” to view whose signatures have been previously verified.
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The creator of the document or drawing sets the documents password and signature blocks


Under the File Menu, select “Document Security” (1)


When the “Document Security” dialogue box appears, select “Acrobat Standard Security” (2)


When the “Standard Security” dialogue box appears, select (3):


Check “Password Required…” and enter “NCSX”


Select “128-bit RC4 (Acrobat 5.0)” encryption


Select both “Enable Content Access…” and “Allow Content Copying…”


In Changes section (3) , select “Only Form Field Fill-In or Signing” for documents or “Comment Authoring, Form Field Fill-In or Signing” for drawings
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Select Tools => Acrobat Standard Security => Standard Security


“Password” dialogue box appears, type in “NCSX” as the password





Click the Form Tool to activate it


Drag the cross hair over the area where the signature will be placed 


In the field properties box that appears inter the Name (e.g. Sig 1in this example).  Make sure that the Type is set to “Signature” (default is Text).  Borders, etc can be added if desired.





After all signature blocks or fields are established, the creator should save the document


Note:  the creator could sign the document before the document is saved.





From the Tools Menu, select Self-Sign Security and Log In


When Self-Sign Security – Log In dialogue box appears, input your User password and click Log In.


Repeat steps to set drawing password as outlined earlier.





Cog Engineer





Click the form tool icon to activate it.


Drag the cross hair over the area where the signature will be placed


In the Field Properties box that appears inter the Name (e.g. Sig 2).  Make sure that there is no check on Border or Background (when used in a drawing title block).  Also make sure that the Type A Short Description such as Cog Engineer, Designer, etc., can also be added.  Make sure that the Type is set to “Signature” (default is Text).  


Repeat this process for every signature area.  For drawings there will be several signatures (Sig 1, Sig 2, Sig 3, Sig 4)  


Save the drawing once the signature field blocks are established.





The originator will be the first to sign a drawing => Activate the “Hand” icon to activate it.


Right click on the signature area.  A Sign Signature Field will appear.  Select Sign Signature Field and the Self-Sign Security dialog will come up.


Fill in your password and the reason for signing the document (use pull down window).





Activate the document key and “show signature” to view signatures


Process is repeated until Drafting Supervisor’ signature 





After the first signature, the Title Block will appear as below





After Logging In, from Tools Menu, the Drafting Supervisor selects “Digital Signatures” and then “Verify Signatures”





Once validated the question mark changes to a check.





To sign the document, the Drafting Supervisor activiates the “Hand” icon


Right click on the signature area.  A Sign Signature Field will appear.  Select Sign Signature Field and the Self-Sign Security dialog will come up.


Fill in your password and the reason for signing the document (use pull down window) 


Click “Save”





Note: After the stamp is placed a “Document was modified” warning is set in the Signature area.








Activates the “Stamp” icon.


An icon of a stamp will appear.  Move the stamp to the desired location and left click mouse (three button mouse) to set stamp.  Drag stamp corners to set it to the desired size.


Move the icon over the stamp and right click mouse button and open Properties to change stamp message.





Drafting Supervisor saves drawing





The drawing is complete and now ready to be paced in the released area of the Pro/INTRALINK database





Right click on signatures and activate Compare Signed Version to Current Version.





Changes Made





Current Version





Version Signed by Engineer





When a drawing is reopened, question marks (?) will appear until the signatures are re-verified.


A user can only verify signatures => the signatures cannot be deleted by anyone





The originator of the document must first set up the signature block fields in accordance with Section C (Attachment 3)


User Logs In and confirms password





After setting up the signature block fields, the originator saves the document.





User Logs In and activates the “Hand” Icon


Right click on the signature area.  A Sign Signature Field will appear.  Select Sign Signature Field and the Self-Sign Security dialog will come up.


Each User repeats process until all Approving Official signature 


Approving Official must first verify all previous signatures prior to signing in accordance with Section B (Attachment 2)


Approving Official then sends approved document to the NCSX Engineering Web page for posting.





User fills in their password and the reason for signing the document (use pull down window).
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